




























































































































































































































































































































































































































































































































































































































































































































Browsing 

,.. s File Edit Go Utilities 

Name .. ......................................................... ........... . 

Company .. .• ...l.n!;; ............................................................. .......... . 

Street 

City & State 

Zip Code 

Telephone 

.. ... 4.7.9.!t ... ... ..................... .. 

.. .... A.Z ............................................. ........... . 

.................................................................. .. 

• .. ...... .............. ........ .. 
• ............................................................................... 

• ............................................................................... 

• 

Show Notes 

New Card 

Delete Card 

EB 

Browsing is merely HyperCard's term for moving around among cards and stacks. 
When you move from one card to the next, HyperCard moves the front card on 
the back of the stack. You'll never come to the end of a HyperCard stack. 

There should be at least three cards in the Addresses stack- Jane Doe, Connie 
Chung, and Lisa Sprocket. If the Addresses stack contained other cards, the actual 
card you see when browsing may be different than the one pictured. The impor­
tant point to remember is how you move through the cards in the stack. 

Click the Next Card button. 

The right arrow takes you to the next card in the stack. 

The second card is now at the top. 
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,. s File Edit Go Utilities 

Rddresses 

Sheet J.2 .. EJm.~.t~~t. .................................................. . 
City & State . .01h~r..T.Q.W..D, . .M.~.~~.~.~h1J.~.~JJ~ .............. . 

Zip Code .. 2.7..1..1..1. ... ......................................................................... . 

Telephone 

Find ... 

Show Notes 

New Card 

Delete Card 

As you might imagine, the left arrow button takes you to the previous card of the 
stack and moves it to the top, just the opposite effect of the right arrow. 

The top card is now at the bottom of the stack and the second card is now on top 
and visible. The left arrow key brings the bottom card of the stack back to the 
top. 

Click the Previous Card button. 

,. s File Edit Go Utilities 

Name 

Company 

Street 

City & State 

Zip Code 

Telephone 
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' Rddresses 

.~J~rn .. ~PIQ.i;;.K!'l.L ...................................................................... . 

.. G. .\'l. !:l[.0.§.©.~.$ .• ...l.n.i;; ............................. ············································ 

.. $..!.!.iJ.§ .. .4.7.9.!t .. R.9.!.!.t.!'l ... ~ .. 1.... .. ............. . 

..T§.m.P..!'l .•. .A.? .................................. ..................... . 

.. !;l.:;i.:n.4. ................................................................... . 

• ..9..Q.2.::.:;i.:;i.:;i.:::.7..5..(;!.Q ............................ . 
•............................................................................... 

• 

Show Notes 

New Card 

[§ . . 

., 
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Back K-
Home KH 
Help K? 
Recent KR 

First Kl 
Preu K2 
Ne Ht K3 
Last K4 

Find... Kr 
Message KM 
Scroll KE 
NeH1 Window >l!<I. 

Find 

Back w-
Home WH 
Help W? 
Recent WR 

First Wl 
Preu W2 
NeHt W3 
Last W4 

Find... .;;: F 
Message WM 
Scroll WE 
Nmi1 Window :)(<I. 

It's important to remember that cards are just placed on the bottom of the stack­
not removed. For instance, if the right arrow key is hit enough times, each card in 
the stack will be shown, moved to the bottom of the stack, and then reappear on 
the top when all the other cards have been viewed. 

HyperCard also has other methods besides the arrow buttons to move through the 
cards in a stack. In the Go menu, the first eight commands give you a series of 
options to help move through the cards. 

Back 
Home 
Help 
Recent 

First, Last 
Prev,Next 

Takes you to the last card you were at 
Takes you to the first card of the Home stack 
Takes you directly to the HyperCard help stack 
Shows you small pictures of the last 42 cards you have 
accessed. By clicking on any of the pictures of these cards 
you go directly to that card 
Takes you to the first or last card in the stack 
Moves you backward or forward one card at a time 

Choose First from the Go menu. 

You return to the first card in the stack. 

The arrow buttons and other browsing commands work well to move through 
cards one at a time, but in a large stack, this could become incredibly tedious. The 
Find command allows you to search all the cards in a stack for the words or parts 
of words contained in the fields. Remember, the Find command does not search 
HyperCard labels, just the fields where information is entered. In this stack, a 
button has been created called Find, but this may not always be the case. The Find 
command can also be chosen from the Go menu if a Find button isn't present. 

Select the Find command in the Go menu. 

Choosing Find brings up the message box. The flashing cursor comes up be­
tween the quotation marks. This is where you type the word you would like to 
find. It's very important that you type between the quotation marks for Hyper­
Card. 

Type 0 sprocket'' and press Return. 
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Addresses 

Sheet J.2 .. Elm..~.t~~L. .. .. . . .. . ........ . ....... .. . .. .... . ..... .. . . ... . . . . Find ... 

City & State .. Oth~r..T.9..w..n, .. M.~.~~.~.£):nrn.~ttL .......... .. 
Zip Code .2.7..11.1. ...... .................................................................... .. 

Show Notes 

New Card 

Delete Card 
Telephone " .(9.l?.L~.~.~.~n.i.2..... . .......... . ........ . ........... . ..... . .. : .. :: .... : ..... :: .... : ...... :: ..... : .... i· mm " ................................................................................... . " .................................................................................. .. " ..................................... ......................................... .... .. 

Lill . . 
Appointments Home 

.!..~ .. ~.~ ... · ... ~.~.P..~?..~.~.~t ............................................................ ............... ............................................................................................. . 

HyperCard finds the word "sprocket" in one of the cards, brings it to the top, and 
highlights the word. By pressing Return again, HyperCard will display the next 
card that contains that word. If HyperCard can't find the text, the Macintosh will 
beep. 

You've used a few of the buttons in the Addresses stack, but sometimes it can be 
difficult to tell what is a button and what is just a graphic on a card. To find all the 
buttons on a card, hold down the Command and Option keys at the same time. 

Hold down the Command and Option keys. 

All the buttons will be outlined in gray. 

Let go of the keys. 

353 HYPERCARD 

., 



First :1€1 
Preu :1€ 2 
NeHt :1€3 
lost 004 

Find... :M:F 
Messoge :M:M 
Scroll l!CE 
N<rnl Window :)(:!. 

r- s File Edit Go Utilities 

Rddresses 

.. C..~mn~~ . .c.J:rn.Dg. ........................................................................ . 

. .T.9fu .. fur..Y.Q.µ,J.m, .................................................................. . 

Sheet 
~~ 

.. 2.0.~.~.o .. ~.t~.v..~.m .. c..~~!s.................................... r ............ Fi:;:;;-f:: ............... i 
~ ........................... .................... ; 

City &State .. C..~:m;:i,p.µJ~.r.HnQ, .. C..!',.U.fumi.!t................... f """S};:~·~"r;:f~t~~· ..... ~ 
:;, .............................................. r. 

Zip Code .. 9.~.0.14. .. . .... ..... . . . .. .... ... .. .. . . ... . .... . ......... . .. . ........................ [::::::~~~::~~~::::::::::! 

Telephone liJ :~~~~~~~~~~~~:::::::::::::: : :: : ::::::::::: : : : :: :::: : :: : : : : ::: : =:::=.=:Em!\!! 
~:::: : :: : : ·: :::::::::::::::: : :: : ::::: :: : : :: : :::::: : :::::::::::::::::::::::::::::::::: 

"'!!!!!!~~~ 

You may also want to return to a card you've seen recently. HyperCard keeps 
track of the last 42 cards that you've seen in reduced form, accessed by the 
Recent command in the Go menu. 

Choose Recent from the Go menu. 

S File Edit • Tools Objects Font Style Utilities 
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Modifying a Stack 

New Link to St11ck ••• 
New Link to Rpplic11tion ••• 
New Link to Document ••. 

Ren11me This C11rd ••• 
Reorder C11rds .•• 

..tHome C11rds 

Se11rch P11ths 

The small pictures represent the last cards you've seen. If you have been to one 
card more than once, it still only appears one time. Clicking on any of the small 
pictures takes you immediately to that card. 

Click on one of the small pictures to jump directly to that card. 

Choose Home from the Go menu. 

There are thousands of stacks created in HyperCard for a multitude of applica­
tions, but the real power resides in the ability to make your own. Up to this point, 
you have been browsing and entering data in the fields provided, but not making 
any changes to the cards or stacks themselves. In fact, you couldn't have made . 
any changes if you had tried. 

HyperCard has five user levels that allow you various abilities-from just 
exploring stacks and making no changes at all in level 1, to the complete ability 
to change everything in level 5. Each level contains all the abilities of the previous 
levels plus new abilities. 

Choose Preferences from the Home menu. 

s File Edit Go Tools Objects Font Style Home 
., 

Preferences Home 
Your Nome: J.§.\J.rn .. .P. .!'!Jm.~r. .......................................................... . 

Click the user level.r.'.':1 .. ~~~~.: ............................................................. '?.~~~:1:.~.~·t·t·i.1:.~.: ....... .................... . 
.... 5 Scripting 

4 Authoring 

3 Painting 

2 Typing 

1 Bro.,,,sing 

Edit scripts of buttons, fields , cards, 0 Bl i nd Ty pi ng 
backgrounds, and stacks. 

Create buttons and fields. Link 
buttons to cards and stacks . 

Use the Paint tools to change the 
appearance of cards and backgrounds. 

Enter and edit text in fields. 

Exp lore stacks but make no changes. 

0 PoW'er Keys 

0 ArroW' Keys in Text 

I . . . . . I 
• -----·-----·------·------------ -- - ·················-· -- -- -- -------- --- -- ······ ... - ..................... . -

Click on level 5, Scripting, and type your name in the field provided. 

Two new menu items now appear in the menu bar: Tools and Objects. These 
menus will be used in the creation and modification of stacks and cards. 

You're ready to learn how to modify stacks, the first step toward creating your 
own. 
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UOS(! '> tnck :•:UI 
Saue a Copy ••• 

Compact Stack 
Protect Stack .•• 
Delete Stack ... 

Page Setup .•• 
Print Field ••• 
Print Card :M:P 
Print Stack .. . 
Print Report .. . 

Quit HyperCard :M:Q 

Choose Open Stack ... from the File Menu . 

A dialog box with the options for opening a stack appears. 

,.. . Go Tools Objects font Style Home 

I= Hard Disk Driue I 
O Christmas Rrt =Hard Disk Dr ••. 
D Copy of Soy Stack 
o fileMaker 111111 

o fileMaker Pro tk h1e 

~ ~~¥~.;~~;;;:, Ill 1~;~:--u · 
[ Cancel ] D Soy Stack ~ 

D Open stack in new window 

I I I 
- . - --· ··· ··· - . .. . . . . ................. -- .. ····· ... .. . ... .. .......... . 

find and select "Soy Stack", the stack you copied from your Approacliing 
Macintosh Diskette in the beginning of this module. 

Click Open. 

The first card of the Soy Stack will appear. This stack contains some of the 
elements that you will need for the remainder of the module. You'll create the 
rest of the elements. 

The stack you create will demonstrate HyperCard's ability to link information. 
You will link the diagram of the soybean to cards with more detailed text of its 
various parts. HyperCard also supports sound. You will link sound files with the 
buttons so the parts of the soybean are spoken as well as written. 
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Using 
BaclCgrounds 

Undo 8€2 

[ ut >)(cl{ 

[ 01)1.l ,)(c[ 

Pilste 8€U 
[ lf~ur 

New Cilrd 8€N 
Delete Cilrd 
Cut Cilrd 
Copy Cilrd 

Icon... HI 

s File Edit Go Tools Paint Options Patterns 

~---------foliage leaves 

1---- rndicle 

Background is where the common elements shared by a number of cards are 
stored. For instance, in the Addresses stack, the labels, buttons, and graphics 
remained the same in each of the cards. Each time a new card was created, those 
elements appeared. 

In your new Soy Stack, you will have some common background elements that 
all the cards will share. The drawing of the bean and the titles of its parts will be 
contained in all of the cards you'll create. You'll add different elements to each 
card, but the basic drawing will remain. 

Anything that you want to appear on every card in a stack and that you won't 
want to modify should be placed in the background. You'll need to add a title to 
all of the cards, so that will go in the background. 

Choose Background from the Edit menu. 

Notice the Menu bar now has dashed line around it. This lets you know that 
you're working on the background of a card. 

Pull down the Tools menu and select the capital "A" Text tool. 

The title of each of the cards will be the same, so you'll add that to the back­
ground. 

Select Text Style ... from the Edit menu. 
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KZ 

[Ut >)(<!{ 

[ o Ill.I >)(<[ 

Paste KIJ 
[ !ettr 

New Card KN 
Delete Card 
Cut Card 
Copy Card 

,...Background 
Icon ••• 

Choose Helvetica and 18. Click OK. 

... 

...... " ., ., ... " ....... 
Paint Options Patterns 

Paint TeHt Style 

Style: 
OBold 
D Italic 
D Underline 
D Outline 
D Shadow 
D Condense 
D EHtend 

Align: 
@Left 
O Center 
0 Right 

Chicago 
Courier 
Geneua 

Im 

Monaco 
Palatino 
Times 

~ 

. 

~ 

c .. 1 
(Cancel ) 

Line 
height: 

lmml .__I 24____, 

I sample 

Click about half an inch down from the top of the card. Type 0 Soybean 
Anatomy". 

s File Edit Go Tools Paint Options Patterns 

Soybean Anatom~ 

~---------foliage lenYes 

1----- radicle 

Since we are typing in the background (notice the dashed menu bar), this will 
become the title for all of the cards in this stack. 
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Creating a New 
Card 

HZ 

!:ut >l!<H 
[ O!ll.l ~(:[ 

Paste XU 

' I 

Delete Card 
Cut Card 
Copy Card 

lt?!lt S1fJl<J.,, >)(cf 

Background XB 
Icon... XI 

Use the lasso from the Tools menu to circle and move the title so it's in the 
top left comer of the card. 

s File Edit Go Tools Paint Options Patterns 

Soybean Anatomy 

---------- folioge leoves 

1---- rodicle 

The diagram of the soybean and the title you just created will make up the back­
ground of each card in this stack. Since the background is now complete, you'll 
select Background again from the Edit menu to return to the foreground. 

Select Background from the Edit menu. 

Notice the dashed lines disappear from the menu bar. 

Some people might be very well served by the diagram showing the main parts of 
the soybean. Others would want more information. By creating a new card with 
more detailed information and creating a link between it and the main card, you 
can provide more in-depth information. The reader can determine how much 
information he or she wants. 

Now you are ready to create buttons and cards that will provide more detailed 
information about the diagram. 

Choose New Card from the Edit Menu. 
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s File Edit Go Tools Paint Options Patterns 

Soybean Anatomy 

r----------foliage leaves 

t---- radicle 

Did anything happen? Yes, an exact copy of the first card and its background was 
made. Now you'll modify this card to include more information about those ever 
fascinating foliage leaves. 

First, you'll draw a box to type in the in-depth definition. 

11 11 Select the rectangle tool from the Tools menu. 

Grid 
FatBits 
Power Keys 

Line Size ... 
Brush Shape .. . 
Edit Pattern .. . 
Polygon Sides ... 

Draw Centered 
Draw Multiple 

Hotuh~ 

Sl<m1 
l}is1(11"1 

P•~rsi1<~< tiue 

You'll want the rectangle that you draw to be filled in-not transparent-or the 
diagram will show through. 

Select Draw Filled from the Options menu. 

It would look best to have it filled in with white. The text will be easier to read. 

Select the white pattern from the top left corner of the Patterns menu. 

Now you're ready to draw the box where the text will go. 

Draw a rectangular box, about 1 inch by 3 inches over the top of the words 
0 foliage leaves0 • 
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Back 
Home 
Help 
Recent 

ac-
3CH 
001 
OOR 

First 001 
Preu 002 

Last 3C4 

Find... OOF 
Message :ICM 
Scroll :ICE 
N<m1 Window *l 

Adding Text 

s File Edit Go Tools Paint Options Patterns 

Soybean Anatomy 

1----- ndicle 

Now, you'll add the definition of foliage leaves to the box you just drew. 

Choose the text tool from the Tools menu. 

Choose Text Style from the Edit menu and select Helvetica, 12, and Bold. 

s File Go Tools Paint Options Patterns 

Paint TeHt Style 

Style: Chicago 
1:81 Bold Courier 
D Italic Geneua 
D Underline 111111••1 
D Outline Monaco 
D Shadow 
D Condense Palatino 
D EHtend Times 

Rlign: 
@Left 
0 Center 
0 Right 

( .. ) 
(Cancel ) 

Line 
height: 

llfml l.__16____, 

I Saq>le 

e 
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Linking Cards 

s File Edit Go Tools Paint Options Patterns 

Soybean Anatomy 

Type the following in the box: 

Foliage Leaves: the first true leaves 
that emerge from the plant. 

1---- radicle 

Foliage Leaves: the first true leaves to emerge from the plant. 

Remember to press the Return key as you approach the right border of the box 
you drew. 

You have completed the card with the definition of foliage leaves. Now you have 
two card~ne with a broad overview, and one with more specific information. 
You need to create a way to link the information between the two cards. 

Choose First from the Go menu to return to the original card. 

You'll now create a button that will link the foliage leaf drawing of this card to the 
definition card you just created. 

The second tool from the left in the Tools menu is the Button tool. When this tool 
is selected, HyperCard is in a special mode to_ work with buttons. 

Select the Button tool from the Tools menu. 

Now, you can create a new button. 

Select New Button from the Objects menu. 

362 HYPER CARD 



• File Edit Go Tools Objects Hm1 S1~JI<~ 

Soybean Anatomy 

,,...-----------foliage leaves 

1----radicle 

A new button, aptly named New Button, appears. This button will establish the 
link between this card and the card that you created with the definition of foliage 
leaves. 

Use the pointer to drag the New Button over the top of the foliage leaves. 

Once ir s in place, drag the bottom right corner and stretch the button to 
cover the foliage leaves completely. 

s File Edit Go Tools Objects Font Style 

Soybean Anatomy 

,.----------foliage leaves 

---radicle 
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Bring Closer 38+ 
Send Farther 38-

New Button 
New Field 
New Background 

The attributes of buttons (including the name) can be modified by selecting 
Button info while a button is selected. You can tell a button is selected when its 
border moves, like a marquis. 

If the New Button's border is not moving, click on it. 

It's important to remember that when selecting buttons, you must be using the 
Button tool in the Tools menu (second over from the left, top row). 

Select Button Info ... from the Objects menu. 

Replace the name "New Button" with "Foliage Leaves". 

This will be the name used to refer to the button. 

Click on Show Name so it is NOT checked. 

If Show Name was left selected, the words "Foliage Leaves" would appear in the 
center of your button. 

By making the button transparent, you'll be able to see the diagram underneath. 

Under the Style column, click on Transparent. 

To make the button flash black when it is selected, you will select Auto Hilite. 
This is particularly useful with transparent buttons. 

Click on Auto Hilite. 

The dialog box should look like this: 

ti: File Edit Font Style 

Soybean~======================;;;;;;;;;;i 

Button Name: ~I mg~ 
Card button number: 1 

Card button ID: 8 

D Show Name 
18:1 Ruto Hilite 

Style: 
®Transparent 
0 Opaque 
0 Rectangle 

I con... 0 Shadow 
O Round Hect 

( Effect ... ) O Check BoH 
-.... 0 Radio Button 

~ e([ !!!!!!!!!!!!O!!!!K!!!!!!!!!!!!~]J ( Cancel ) 

leaves 

ocotyl 

radicle 

ledons 

364 HYPER CARD 



Back 
Home 
Help 
Recent 

K­
KH 
K? 
KR 

First Kl 
Pr P.L• "2 
NeHt 
Last 

K3 
K4 

Find... KF 
Message KM 
Scroll KE 
N<m1 n11ndou• >Jl<!. 

Now you'll create a link between the button you've defined and the card that 
includes the definition of foliage leaves. 

Click Link To ... 

The Link To dialog box comes up. This is a unique dialog box because it will 
remain active when you use other menus. 

This is the way to establish links between the Foliage Leaves button and the card 
you created with the definition. In this case the card is the previous card. You'll 
move back to it to establish the link. 

Choose Prev from the Go menu. 

The first card appears. 

Click on This Card to establish the link. 

Clicking on the Foliage Leaves button will take you to the card with the foliage 
leaves definition. This card is now in front. 

s File Edit Go Tools Objects Font Style 

Soybean Anatomy 
Foliage Leaves-the beginnings of the 
leaf and stem of the sprouting soy­
bean 

hypocotyl 

( This Stack ) ( Cancel 
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You just performed an exercise in computer programming, HyperCard style. 
While you were establishing the link between the Foliage Leaves button and the 
definition card, HyperCard was writing a simple computer program, called a 
script, to describe the actions. 

Click on the Foliage Leaves button you created. 

Choose Button Info from the Objects menu and click on Script. 

s File Edit Go Script 

Script of card button id 8 = "Foliage Leaues" 
pn mouseUp 

go to cord id 5021 
end mouseUp 

The script is a very simple one. When the mouse is clicked on the Foliage Leaves 
button, HyperCard goes to the card with the ID of 5021 (your number maybe 
different, but that's your definition card). 
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Adding Sounds These scripts can be edited so you can do your own programming. As mentioned 
in the beginning of this module, HyperCard can also use sound. Buttons can play 
sounds that have been recorded and stored in the HyperCard stack. Because the 
Macintosh system you're using might not have the ability to record sound, we've 
recorded and stored some sounds for you. 

Click just to the right of the card id number in the script and press Return. 

This will give you a blank line on which to type. 

Type 'play "Foliage Leaves'". 

s File Edit Go Script 

~ D Script of card button id 8 
pn mouseUp 

go to card id 5021 
play "Foliage Leaves" 

end mouseUp 

"Foliage Leaues" 

The command "play" followed by the name of the sound file, in this case, "Foliage 
Leaves", will cause HyperCard to play the sound. 

Now, you'll see if it worked. 

Click in the close box at the top left corner of the script window. 

Click Yes to save your changes. 

367 HYPERCARD 



s File Edit Go Script 

Script of card button id 8 = "Foliage Leaues" 
on mouseUp 

go to card id 5021 ' 
play fol i~;:;!;::=~===========;;;;;;;;;i 

end mouseUp 
Saue changes to 
Script of card button id 8 = "Foliage 
Leaues"? 

~ 
[ No ) (Cancel ) 

You're still using the button tool. Now, you'll change back to the standard 
pointer. 

Choose the pointer tool from the Tools menu. 

Although the outline of the Foliage Leave button disappeared, it's still there. 

Click on the foliage leaves in the diagram. 

s File Edit Go Tools Objects Font Style 

Soybean Anatomy 

~--------- folioge leoves 

1----rodicle 
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Finishing Up 

If things went as planned, the Foliage Leaves button should have flashed black 
(Auto Hilite), the definition should have move to the top of the stack and been 
displayed, and a sound should have been played. 

Pretty neat, huh? And you didn't think you were a programmer. 

Choose Prev from the Go menu. 

You're back to the main card. 

There are three other parts of the soybean diagram that can have exactly the 
same kind of button as the one you just created for the Foliage Leaves. 

The steps for creating these buttons are exactly the same: 

1) Start with the main card, create a new card, and add the definition of the 
soybean part .. 

2) Create a new button and place it over the plant part on the main soy-
bean card. 

3) Set the attributes for the button. 
4) Link the button on the main card to the definition card. 
5) Add the "play sound" command with the appropriate sound name to the 

script for the button you created. 
6) Try it. 

If the sound doesn't play, check to make sure the spelling is exactly as printed 
below. The names must match the sound files that were created and saved in the 
Soy Stack. 

The definitions for the other plant parts are as follows: 

Hypocotyl: the "first stem" that elongates to push the new plant through the soil. 
Sound name: hypocotyl 

Radicle: the shoot that initiates root development. 
Sound name: radicle 

Cotyledons: food source for the new seedlings. 
Sound name: cotyledon 

Optional 

Platypus: a small mammal rarely found in large cities. 
Sound name: platypus 

Complete the stack by repeating the instructions for the other three parts of 
the soybean (platypus is optional). 
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Printing 

Review 

What to Turn In 

370 

Your stack is now complete. Now you'll print a copy of all the cards you created. 

Make sure your printer is turned on, selected properly in the Chooser,. and 
ready to print. 

Choose Print Stack ... from the File menu. 

Print Stack 

-
................................. -­-~~--=..-

-

@ Rll cards 
O Marked cards 

Print order: ~ 

D Split-page format 
[gl High-quality printing 

r Dimensions: , , nches0.71 ll]: ............ i,,: 
i Uiew: 
! @Margins 

I ?~~··,;~~_::·~:~~~:~·: ! 

~~~~~~~~~==1 

_, 

Header: ~ [.!) ~ ~ ~ 

The default for printing a stack is two cards per printed page. By printing out the 
cards in half, third or quarter size, you can get up to 28 cards (very small ones) 
per page. 

Individual cards may be printed by choosing Print Card from the File menu. 

In this module, you've learned: 

• The parts of a Hypercard stack and card 
• How to add information to a stack 
• How to find a card by searching 
• How to create and modify a new card 
• How to create buttons and use them to link cards 
• How to modify scripts 
• How to print stacks 

A printed copy of all the cards in your stack. 
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The Map 

Description 

,. 9 File Edit Go Tools Objects Font Style 

Top Soy Research Universities 

• File Edit Go Tools Objects Font Style 

So~ean Research Facilities 

Annual Production I 300 m1lhon Metric Tons ~ 

Research College I Iowa slate Unlversi~ ~ 

Director of Legumes I Lisa Lenkaitis ~ 
~ 

Address I 318 Welch Avenue ~ 

City I Ames ~ 
11owa/ USA ~ 

Return to Mop 
State/Country 

Zip 1so212 ~ filrt ¢1 
I 

Home 

This HyperCard stack contains a world map with buttons linked with 
cards that contain detailed information on various universities that carry 
out soybean research. By linking the map card with the more typical 
database style card, a user can simply click on a button to find out about 
a university in a particular area. A standard database might require typing 
country names to search for until a match was made-very inconvenient. 

The map was created in MacPaint, copied to the Clipboard and pasted 
into HyperCard. 
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Exercises 1. Define card, stack, background, field, Home card, and label. 

2. Why will you never come to the end of a HyperCard stack? 

3. Give an example of when you would draw on the background and when 
you would not. How do you know if you are in the background? 

4. How would you move ahead one card in a stack? Move back one card? 
Jump directly to a card you recently viewed? 

5. Name two common elements that cards in the same stack share. Which 
one of these is absolute and which one just makes sense? 

6. How do labels and fields differ? If you wanted to search for information in 
a stack, would it be better in a label or a field? 

7. What would be the fastest way for you to locate the card that you just saw 
that had an Arizona address in a field? Another way that isn't as fast? 

8. How can you check to see where all the buttons are on a card? 

9. How could you create a stack that would only allow people to view 
information, but not change it? Enter information, but not paint or move 
buttons? Make any changes they wished? 
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absolutereferenre 
In a spreadsheet, a reference that always refers to the same cell or group of cells, 
even if you copy the formula containing the reference. For example, $C$12. 

active window 
The frontmost window on the desktop. The title bar of an active window is 
highlighted with horizontal lines . 

Apple menu 
The menu found under the 9 symbol at the far left of the menu bar. The Apple 
menu contains desk accessories such as the Chooser and Find File. 

application program 
A tool used to manipulate information. Claris MacPaint and Microsoft Word, for 
example, are application programs for the Macintosh. 

argument 
Information needed by a function or an instruction to produce a result. 

arrow keys 
The arrow keys are used to navigate through a document. 

background 
In Hypercard, information that is shared by a group of cards. Changes to the 
group's background affect all of the cards in the group. 

bitmap 
A graphic image created by selectively turning on and off pixels on a computer 
screen. A MacPaint document is a bitmap graphic. 

browse 
To move through a set of information, often used in reference to data bases and 
HyperCard stacks. 

button 
Clicking a button designates, confirms, or cancels an action .. Buttons are usually 
found in dialog boxes or HyperCard stacks. 

Cancel button 
A button which, when clicked, cancels the command that brought up the dialog 
box. 

card 
The basic set of information that makes up HyperCard. 
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at. 
The basic unit of a spreadsheet in which you store numbers, labels, and formulas. 
A cell is the intersection of a row and a column. 

choose 
To pick a command from a pull-down menu. To choose a command, press the 
mouse button in the menu title, drag the mouse until the appropriate command is 
highlighted, and release the mouse button. 

Chooser 
The Chooser is a desk accessory that you use to select resources (such as a printer 
or a file server) . 

. click 
To quickly press and release the mouse button without moving the mouse. 

Clipboard 
A temporary holding place for the most recently cut or copied selection. The 
Clipboard can be used to transfer text, graphics, or other information between 
documents. 

close 
To remove a window from the desktop. To close a window, choose the Close 
command from the File menu, or click in the window's close box at the upper left 
comer of the title bar. 

close box 
The small white box on the left side in the title bar of an active window. Clicking 
in this box closes the window. 

rommaod 
An action for the Macintosh to perform. Commands are usually found in the 
menus. 

Command key 
A special key found just to the left of the space bar on the keyboard. When held 
down while another key is pressed, the Command key may have the same effect 
as choosing a command from a menu. 

cut 
To remove a selection using the Cut command from the Edit menu. The cut 
selection is stored temporarily on the Clipboard. 

database 
An organized collection of related information (data). 
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datafile 
The name given to a Claris FileMaker document. It consists of a collection of 
records organized into a data base. 

Delete key 
A key at the upper right-hand corner of the Macintosh keyboard that moves the 
insertion point one space to the left, removing the last character typed. The 
Delete key also removes the current selection. 

desk accessories 
Small applications that can be opened from the Apple menu, at any tim~ven 
while you're using another application. The Chooser, Find File, and Note Pad are 
examples of desk accessories. 

desktop 
The area of the Macintosh screen where you do your work. The desktop includes 
the menu bar and the gray area below it. 

dialog box 
A box that appears with a message to request more information from the user. 
The message can be a warning or error message. 

Diet Coke 
A basic source of nourishment and caffeine for aspiring authors. 

dimmed icon 
An icon representing a diskette that has been ejected, or a document, folder, or 
application on a diskette that has been ejected. 

diskette 
The magnetic medium on which the Macintosh stores information. Single-sided 
diskettes store 400 kilobytes (K) of information. Double-sided diskettes store 
SOOK of information. High-density diskettes store 1,400K, or 1.4 megabytes (MB), 
of information. 

diskette drive 
The diskette drive (either internal-part of the Macintosh, or external-connected 
to the Macintosh) retrieves information from the diskette and stores information 
on it. 

document 
What you create using a Macintosh application. Macintosh remembers the 
application you used to create your document, and opens the application auto­
matically when you open your document. 
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double-click 
A mouse technique used to perfonn a short cut. To double-dick, position the 
pointer on the desired item (for example, an icon) and click the mouse button 
twice in rapid succession without moving the mouse. 

drag 
To position the pointer on an item, press and hold the mouse button, and move 
the mouse to a new location. Releasing the mouse button either confirms a 
selection or moves the item to a new location. 

Enter key 
A special key, found at the bottom right of the numeric keypad, that confirms or 
tenninates an entry or a command. 

field 
In a data base, where one specific piece of information in a record is stored. A 
field can usually only hold one specific type of information (for example, text, 
number, boolean, and picture). 

file 
A collection of information stored on a hard disk or diskette, usually a document. 

Finder 
An application used to manage hard disks, diskettes, documents, folders, and 
applications on the Macintosh desktop. 

folder 
A holder for documents and applications on the desktop. You use folders to 
organize and group your documents and applications. 

font 
A collection of typographical symbols, such as letters, numbers, and punctuation 
marks that are visually related. An example of a Macintosh font is Times. 

handles 
Small black or white boxes that surround a selection, allowing you to resize or 
reshape it. 

hard disk 
A place to store a lot of information, such as applications, documents, and 
HyperCard stacks. A hard disk is like a very, very large and very, very fast dis­
kette. 

highlight 
To make something stand out against its background. An item is usually high­
lighted to indicate that it has been selected or chosen. 
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Home card 
In HyperCard, an index to your important stacks. 

I-bar 
A special type of pointer used in entering and editing text. 

iron 
A small picture of an item on the Macintosh desktop, like a hard disk, a folder, 
and so on. 

information window 
A window that appears when you choose the Get Info command from the File 
menu. The information window contains such information as the size, type, and 
date of the currently selected diskette, application, document, or folder. 

initiali7.e 
To prepare a diskette to receive information. All diskettes must be initialized 
before they can be used. 

insertion point 
The point in a document where something will be added. The insertion point is 
usually marked by a flashing vertical bar. 

lock 
Locking a diskette prevents that diskette from being altered. Locking a document 
prevents it from being discarded. To lock a diskette, set the write protect tab at 
the upper right corner of the diskette. 

memory 
The part of the Macintosh that stores information while you work with it. When 
you turn your Macintosh off, everything stored in memory is lost. Saving transfers 
a copy of the information in memory onto your hard disk or diskette for safe­
keeping. 

menu 
A list of commands that appears when you press the mouse button while over the 
menu title in the menu bar. Dragging through the menu highlights each command 
in order. Releasing the mouse button while a command is highlighted chooses 
that command. 

menu bar 
The list of menu titles that runs across the top of the Macintosh desktop. 

mouse 
A small device that you move to control the pointer on the Macintosh screen. 
When you move the mouse, the pointer moves correspondingly on the screen. 
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mouse button 
The button on the top of the mouse. In general, pressing the mouse button 
initiates some action on whatever is under the pointer, and releasing the button 
confirms the action. 

Note Pad 
A desk accessory that allows you to enter and edit small amounts of text while 
working on another document. Use the Note Pad to store phone numbers, 
messages, and other information that might otherwise get lost when you're 
working with your Macintosh. 

open 
Opening a document, application, folder, or hard disk creates a window from its 
icon 

Option key 
A key used like the Shift key to give an alternate meaning to another key. You can 
use the Option key to type foreign characters or special symbols. 

palette 
A menu that has been "tom off" of the menu bar and is positioned somewhere on 
the screen. 

paste 
To reposition the contents of the Clipboard-whatever was last cut or copied. 

ty.lttern 
A variety of shades, simulated textures, or colors used in computerized painting 
and drawing applications. 

pixd 
Stands for picture element, the dots that make up the images on the Macintosh 
screen. 

platypus 
A small, four-legged mammal not usually found in large cities. 

point 
A unit of measure often used with text characters. One point is equivalent to 1/72 
of an inch. 

pointer 
A small shape on the screen that follows the movement of the mouse. Most often 
an arrow that points up and to the left (toward Alaska, for those in the continental 
United States. Note that if you live in Alaska, the mouse points somewhere else­
we're not quite sure where, but most probably still up and to the left). 
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pop-up menu 
A menu that can appear anywhere on the screen. 

Power On key 
Used to tum on some Macintosh computers (most modular Macintosh computers 
can be turned on this way). 

~ 
To position the pointer and then hold down the mouse button without moving 
the mouse. 

record 
One entry in a data base. A record is made up of fields that store the specific 
pieces of information. 

relative reference 
In a spreadsheet, a reference to a cell's position in relation to another cell. For 
example, if Al is the current cell, the reference "B3" refers to the cell that is one 
column to the right and two rows down from the current cell. A relative reference 
will indicate a different cell each time the formula moves. 

report 
A presentation of database information in the form of a table. A report allows you 
to perform mathematical calculations on the information. 

Return key 
A key that moves the insertion point to the beginning of the next line. It's also, in 
some cases, used to confirm a command. 

save 
To store information on a hard disk or diskette. Saving transfers a copy of 
information in memory to the hard disk or diskette. 

Scrapbook 
A desk accessory in which you save frequently-used pictures or text. 

script 
A set of commands written in HyperTalk, HyperCard's programming language. 

scroll 
To move the contents of a window so that a different part of it is visible. 

scroll arrow 
An arrow on either end of a scroll bar. Clicking a scroll arrow moves the docu­
ment or directory one line in the direction of the arrow. Pressing a scroll arrow 
scrolls the document continuously. 
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scrollbar 
A rectangular bar that appears along the right or bottom edge of a window. 
Clicking in the gray area of the scroll bar moves the contents of the window a 
screenful at a time. 

scroll box 
A small, white box found in a scroll bar that indicates the position of the 
window's contents relative to the entire document. For instance, if the scroll box 
appears at the top of the scroll bar, the current window displays the first part of 
the document. Dragging the scroll box to a position on the scroll bar moves you 
to that position in the document. 

select 
To indicate where the next action will take place. Usually, selected items are 
highlighted to set them apart. 

selection 
The information or items affected by the next command. The selection is usually 
highlighted to make it stand out from its surroundings. 

shift-click 
To extend a selection by holding down the Shift key while you click or drag to 
select additional items. 

Shift.k . ey 
A key that, when pressed, causes a typed letter to appear in uppercase. Also 
causes the upper symbol to be typed when used with a number or symbol key. 

size box 
A box on the bottom right of some active windows that lets you resize a window. 

software 
Programs or instructions for the Macintosh to carry out. 

soybean 
A small legume used, among other things, to produce tofu. 

split bar 
In some Macintosh applications, a small box that can be used to divide a window 
into two or more panes. By dividing a window into panes, you can view more 
than one part of a document at the same time. 

stack 
A collection of cards based on the same subject and of the same size. A Hyper­
Card document. 
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Trash Trash 

startup disk 
A hard disk or diskette with the system files necessary to start the Macintosh when 
it's first switched on. Usually startup disks have a system folder with the System 
and Finder files on it. 

style 
A stylistic variation of a font, such as boldface, underline, or italic. 

Tab key 
A key that, when pressed, moves the insertion point to the next tab marker. In a 
dialog box, the Tab key usually moves the insertion point to the next rectangle to 
enter information. 

ti.tie bar 
The horizontal bar at the top of a window that displays the name of what's inside 
the window. Dragging the title bar lets you move the window on the desktop. 

tofu 
A food made from soybeans. 

Trash 
A place where you can put documents or applications that you want to get rid of. 
The Trash bloats when something is in it. 

window 
An area of the desktop that displays information. You view documents through 
windows that you open on the desktop. Windows can also be moved, over­
lapped, resized, scrolled, and closed. 

zoom box 
A box in the title bar of a window. You click in the zoom box to make the 
window fill the entire screen. 
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Index 

A 

Add Legend command 276 
Alignment. .. command 212 
apple menu ... 17 
Applications 3, 7 

opening 18 
using an application 18 

Arrow keys 5 

B 

Backspace key 4 
Book icon 303 
Brush Shape command 63 
Buick 221 

rusty old 251 

c 
cancel box 188 
Cancel button 28 
category 269 
cell contents window 187 
Cell references 194 

absolute reference 230 
relative reference 230 
relative vs absolute 230 

Change ... Utility 114-116 
Charts 

cheating with 292 
Gallery menu 274 
selecting a type 273 
using a legend 276 

Chooser 21-22 
choosing commands 9-10 
Clear button 3o6 
Clipboard 59, 111 
close box 16, 46, 90 
column heading 187 
Command key 5, 11 
Compact Macintosh 2 
Copy command 25, 59 
CPU 2 
Creating a Chart 271 
current cell 187 

current cell address 187 
Cut command 110, 140 

D 

data point 269 
data series 270 
Database Management 

editing information 337 
entering data 336-337 
fields 296, 303 
number fields 321 
previewing reports 316 
records 296, 303 
saving the datafile 312 

datafile 300, 303 
Datafile Layouts 

adding titles 330 
changing the layout 313 
designing a layout 323-324 
editing field titles 328 
formatting fields 

Number Format. .. command 334 
headers and footers 324, 331 
layout tools 

Rulers command 327 
T-Squares command 327 

moving fields 325 
moving multiple fields 326 
New Layout command 313 
resizing fields 326 

default 101 
Define Name ... command 209, 233 
Delete key 4 
Desk Accessory 21 

Find File 29 
desktop 6 
dialog box 20 
dimmed commands 11 
Disk Space 

double-sided 16 
high-density 17 
kilobytes 16 
megabytes 16 
single-sided 16 

Diskette 3, 4, 6 
copying to and from 30 
ejecting 34 
erasing 31 

Displaying formulas 222 
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drawing patterns 47 
Drawing tools 44 

grabber 64 
paint can 66 
pencil 65 
rubber band 61 
text tool 73 
unfilled rectangle tool 63 

drawing window 46, 47 

E 

Editing Spreadsheets 
inserting rows 243 

Editing Text 95 
changing fonts 97 
Cut, Copy, Paste 109, 139 
deselecting text 98 
fonts 97 

Helvetica 97 
Times 97 

replacing a selection 98 
right indent marker 100 

enter box 188 
Enter key 190 
Entering Data 270 
Extra Credit 37 

F 

file server 7 
Fill Down command 249 
Fill Right command 246 
Find All Records command 311 
Find command 308 
find operators 309 
Flip Horizontal command 62 
Folders 23-27 

directory 25 
folders in folders 24 
hierarchy 25 
navigating folders 25-27 
New Folder command 23 
opei:iing 24 

Fonts 18. See also Editing Text: Fonts 
Footers 143-144 

adding a page number to 144 
creating a footer 144 

Footnotes 141-143 
Formatting 

alignment 106, 107 
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alignment icons 106 
center alignment icon 131 
left alignment icon 131 

changing column widths 195 
changing margins 101 
Document command 100 
first line indent marker 100, 102, 105 
justification icons 100 
Left indent marker 102 
left indent marker 100, 103, 132 
line spacing 105, 106, 135 
line spacing icons 100 
page breaks 145 
paragraphs 134 
right indent marker 100, 102 
rulers (MS Word) 99 
tab stop icon 100 
tab stops 113 

center-aligned tab stop 133 
decimal-aligned tab stop 136 

text styles 108 
Formatting Charts 276-278 

adding a border 288-289 
adding text labels 286 
Attach Text. .. command 286 
changing fonts 277 
moving a legend 283 
Patterns ... command 285 
resizing 276 

Formatting Spreadsheets 211 
Alignment... command 212 
changing column widths 229, 270 
changing typestyles 213 
Command key 218 
Font... command 212 
formatting a group of cells 217 
groups of cells 241 
Number ... command 214, 242 
Standard Font. .. command 228 

formula bar 187 
Formulas 187, 193 

equal sign 194 
fill commands 245, 248 

Full Menus command 126, 186, 228, 269 
Functions 197 

arguments 197, 199 
AVERAGE() 254 
COUNT() 254 
FVO 257 
IFO 254 
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MAXO 254 
MINO 254 
NOWO 256 
Paste Function ... command 197 
PMTO 198 
STDDEVO 254 
SUMO 205, 253 

future value 257 

G 

Goodies menu 47 
grabber 64 
graphics 3 

H 

hard disk 4, 6 
Hardware 2 
Hide Ruler command 107 
high resolution 3 
highlighted 22 

I 

icons 6 
ImageWriter 22 
Insert command 243 
insertion point 90 

K 

keyboard 4 

L 

LaserWriter 22 
lasso 44 
Linking Spreadsheets 235 

M 

memory 19 
menu bar 6, 9, 46, 47, 90 
Modular Macintosh 2 
monitor 2 
mouse 3, 7-9 

N 

Names 209 
Define Name ... command 209, 233 
naming rows 231 
Paste Name ... command 238 

network 7 

0 

Option key 5 

p 

Page Setup ... command 278 
landscape orientation 279, 290 
portrait orientation 279 

paint can 44 
paintbrush tool 48 
Painting 48 

changing brush shape 63 
Delete key 53 
drawing rectangles 50, 56, 63 
duplicating objects 52 
eraser 49, 50 
lasso 53-54, 68 
paintbrush 50 
paintbrush tool 48 
patterns 49, 67 
selection rectangle 51 
Zoom In command 64 
Zoom Out command 68 

Paragraph 
Creating 93 

Paste command 25, 110, 140 
Paste Function ... command 197 
Paste Name ... command 238 
Plato's Republic 2 
platypus 37 
pointer 7--8 
pop-up menu 26 
Porsche 944 220 
Power On key 5 
present value 257 
preview command 312 
Print Merge ... command 173 
Print merging 152 

"•"character 158, 159 
","character 158, 159 
data records 170 
field names 171 
header record 171 
instructions 158 

DATA 159 
IF ... ELSE ... ENDIF 165-167 
INCLUDE 167 
SET 162-164, 174 
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main document 152, 158 
merge document 152, 170 
merge fields 158 
prompts 163 

printer driver 22 
Printing 22 

R 

reference area 187 
Regions 203 

referencing 206 
selecting 203 

Return key 4 
row heading 187 

s 
saving a document 20 
Saving Changes 27 
scrapbook 59, 60, 61 
screen 3 
scroll box 90 
Scrolling 14, 104 

scroll arrows 14, 104 
scroll bars 14, 46, 60, 104 

Section ... command 146 
Sections 145-147 
Select Chart command 277 
Selecting 9 

columns 247 
lasso tool 62 
regions 244 
rows 243 

Selecting Text 95, 127 
by Dragging 96 
extending a selection 96 
selecting a paragraph 128 
selecting a sentence 128 
selecting a word 95, 128 
selecting an entire document 128 
the selection bar 127 

selection rectangle 44 
short menus 91 
Show Ruler command 108, 130 
Shut Down command 35 
size box 13, 90 
slide control 304 
Sort ... command 304 
Spell Checking 147 
Spelling ... command 148 
split bar 143 

Spreadsheet 
moving through 190 

Standard Font. .. command 189 
Startup Disks 5 
system folder 7 
system memory 17 
System Software 5 

T 

title bar 90 
Tools menu 47 
Trash 9, 32-33 

Empty Trash command 34 
retrieving from 33 

Typing Text 

u 

Backspace key 91 
Delete key 91 
insertion point 19, 91 
Redo Typing command 94 
Return key 92 
Undo Typing 94 
Word wraparound 92 

Undo Typing command 127 

v 
value 269 

w 
"What If?" analysis 201-202, 220, 250 
Windows 12 

z 

activating a window 15 
active window 14 
closing 16 
moving a window 15 
using multiple 14 

zoom box 13, 90, 276 
Zoom In command 64 
Zoom Out command 68 
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In the olden days, before 1984, not many Stanford University undergraduates 
used personal computers-for a very good reason. Not many of them knew 
how-and not very many of them wanted to learn. After all, in those days it 
meant sleeping through endless lectures, wading through computer manuals as 
thick as the Manhattan Yellow Pages, and staying awake all night memorizing 
cryptic commands and equally cryptic error messages. 

Then, on a particularly bright day in Stanford, California, some particularly bright 
undergraduates had a particularly bright idea: since only students really under­
stood what other students were all about, they could teach each other about 
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