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HyperCard® is a new kind of application-a unique information 
environment for your Apple® Macintosh® computer. Use it to look 
for and store information-words, charts, pictures, digitized 
photographs-about any subject that suits you. Any piece of 
information in HyperCard can connect to any other piece of 
information, so you can find out what you want to know in as much 
or as little detail as you need. 

What you need to use HyperCard 
HyperCard works in any Apple Macintosh computer with 1 
megabyte of memory or more, and either two 800K disk drives or 
one 800K disk drive and a hard disk. It works best in systems with a 
hard disk drive and a printer. 

•:• HyperCard and MultiFinder: To get the most out of your system 
when you're using HyperCard and any other application under 
MultiFinder™, your system should have at least 2 megabytes of 
memory. Your authorized Apple dealer can quickly upgrade your 
system with the necessary extra memory. 

About system software 

HyperCard works fine under System files with the version numbers 
in Table P-1 (or higher numbers). 

Table P-1 
System file versions 

Computer 

Macintosh Plus 
Macintosh SE 
Macintosh II 

System 

System 3.2 
System 4.0 
System 4.1 

Finder 

Finder 5.3 
Finder 5.4 
Finder 5.5 

To find out the version of the System file on your startup disks, look 
in the System file Get Info box. 
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•:• LaserWriter users take note: To use a LaserWriter® printer with 
HyperCard, you must be using LaserWriter file version 4.0 (or 
higher numbers). 

•:• Finder not necessary: You don't need a Finder on startup disks 
that you use exclusively for HyperCard. You do, however, need a 
System file . 

What you need to know 
This guide assumes you've already read and are familiar with the 
owner's guide that came with your computer. Before you use 
HyperCard, you should know how to 

o use the mouse 

o open applications and documents 

o do simple editing 

o use the Finder 

What comes with HyperCard 
Besides this manual, your HyperCard package should contain three 
disks, named as follows: 

o HyperCard and Stacks 

o I-IyperCard Help 

o HyperCard Ideas 

In the unlikely event that anything is missing, immediately contact 
your dealer for replacement. 

See Appendix B, "HyperCard Disks," for a list of the stacks (the 
name for HyperCard documents) and other files on each disk. 
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Copy your disks 
Before you do anything else, make copies of all the HyperCard disks 
to use as your working disks. Then put the originals away in a safe 
place. 

HyperCard is an inviting program to use and to experiment with. 
HyperCard documents are extremely easy to change. You might 
want to use your original HyperCard documents to replace a 
document you've experimented with; so it's important that you keep 
a set of these documents in their unaltered states. 

Copy your HyperCard disks now, before you do anything else. If 
you're not sure how to copy disks, see the owner's guide that came 
with your computer. 

Installing HyperCard on a hard disk 
This section assumes that your hard disk is already set up. If it isn't 
set up yet, see the Macintosh Utilities User's Guide that came with 
your computer and your hard disk owner's manual for instructions. 

Installing HyperCard on a hard disk system takes only a few minutes. 
If you're familiar with the procedure for copying files, simply copy 
all the files from all the disks to your hard disk. The steps below 
explain how to copy these files to your hard disk. 

• To install HyperCard on a hard disk: 

1 . Start your computer. 

2. Insert the disk labeled HyperCard and Stacks into your 
computer's built-in disk drive. 

If you have two 3.5-inch disk drives, it doesn't matter which 
drive you use. 

3. Open the HyperCard and Stacks disk. 

To open the disk, click its icon and choose Open from the File 
menu. Double-clicking the disk also opens it. 
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4. Select all the files on the HyperCard and Stacks disk . 

To select all the files, choose Select All from the Edit menu. 

5. Copy all the files by dragging them to your hard disk. 

See the owner's guide that came with your computer if you don't 
know how to drag files to a disk. 

6. Eject the HyperCard and Stacks disk by dragging it to the 
Trash . 

Dragging a disk to the Trash does not erase the disk; it ejects the 
disk and removes its icon from the desktop. 

Figure P-1 
Ejecting a disk 

7. Insert the disk labeled HyperCard Help into your 
computer's built-in disk drive. 

8. Open the HyperCard Help disk. 

9. Select all the files on the HyperCard Help disk. 

i ............. . 

l O. Copy all the files by dragging them to your hard disk. 

11. Eject the HyperCard Help disk by dragging it to the Trash. 

12. Insert the disk labeled HyperCard Ideas into your 
computer's built-In disk drive. 
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13. Open the HyperCard Ideas disk. 

14. Select all the fiiles on the HyperCard Ideas disk. 

15. Copy all the files by dragging them to your hard disk. 

16. Eject the HyperCard Ideas disk by dragging it to the 
Trash. 

HyperCard is now installed on your hard disk and ready to go. 

•:• Where's the document? HyperCard can be fussy about where 
you store the documents it needs. If it can't find a particular 
document, HyperCard displays the directory dialog box and asks 
where to find the document. (Use the techniques you learned in 
the Macintosh System Software User's Guide about using the 
directory dialog box to find the document.) You have to tell 
HyperCard where to find a document only once; it will know 
where to look after that. 

Using HyperCard with 3.5-inch disks 
To use HyperCard with 3.5-inch disks, put any startup disk into Lhe 
internal drive and a copy of the disk labeled HyperCard and Stacks 
into the external drive. 

Creating a tutorial disk 

To do Lhe tutorials in this guide using 3.5-inch disks, you'll need to 
create a special startup disk called HyperCard Startup. 

• To create a HyperCard startup disk: 

1. It you're using Macintosh System version 6.0, start your 
computer with the Macintosh Utilities Disk 1 in the internal 
drive. Otherwise, start your computer with any startup disk 
in the internal drive. 

Important The System file on your startup disk must be 335K or less. You 
can check the size of the System file by clicking its icon and 
choosing Get Info from the File menu. 

2. Insert a blank disk into the external drive. 

If you don't have a blank disk, use any disk whose contents you no 
longer need. 
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3. Initialize the blank disk as two-sided and name it HyperCard 
Startup. 

If you're using a disk that's already initialized, choose Erase Disk 
from the Special menu to clear away old files. 

4. Copy the System file from the startup disk in the Internal drive 
to HyperCard Startup. 

(The System file is probably in the System Folder.) Don't copy 
the Finder; you'll need all the room left on HyperCard Startup 
for stacks. 

5. Replace the startup disk In the Internal drive with the disk 
labeled HyperCard and Stacks. 

6. Copy the HyperCard application from HyperCard and Stacks 
to HyperCard Startup. 

7. Make sure that the HyperCard application on HyperCard 
Startup is selected; then choose Set Startup from the Special 
menu. 

(If a dialog box appears, just click OK.) Later when you restart 
your computer using HyperCard Startup as your startup disk, your 
computer will look for HyperCard instead of the Finder. 

8. Copy the Home, Address, and Quotations documents from 
the HyperCard Stacks folder on HyperCard and Stacks to 
HyperCard Startup. 

You don't have to create a folder to hold the copied documents. 

9. Make a copy of the HyperCard Startup disk and store it with 
the original HyperCard disks. 

If something goes wrong with the HyperCard Startup disk, you'll 
have the stored backup copy in reserve. 

To take the tutorials described in this guide, restart your computer 
with HyperCard Startup in the internal drive and HyperCard Help 
in the external drive. 

•:• HyperCard Startup is special: You can't use the Control Panel on 
the Apple menu when you use HyperCard Startup as the startup 
disk. (If you try to use it, your Macintosh will give you an error 
message.) Because there's no Finder on this disk, when you quit 
HyperCard a message appears telling you that a system error 
occurred: ignore the message and click the Restart button. 
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How this guide is organized 
This section describes all the chapters and appendixes in this guide. 

o Chapter 1, "Browsing and Editing," is a tutorial on getting 
around in HyperCard. It teaches you how to use some of 
HyperCard's most important features. 

o Chapter 2, "Customizing," presents two more tutorials. These 
tutorials teach you how to customize HyperCard documents for 
your own use. 

o Chapter 3, "Home," gives details about this all-important 
HyperCard document. 

o Chapter 4, "Text in HyperCard," provides information on 
HyperCard fields (the places you create to hold text), how to 
enter text into those fields, and how to control text styles. 

o Chapter 5, "Graphics in HyperCard," pulls together 
HyperCard's graphic elements and suggests ways to use various 
HyperCard tools and commands to produce finished pictures. 

o Chapter 6, "Menu Commands," gives detailed descriptions of 
every HyperCard menu command. This chapter also includes 
step-by-step instructions for carrying out HyperCard's most 
common procedures. 

o Chapter 7, "Keyboard Commands," summarizes all the 
HyperCard commands and features that you can execute directly 
from the keyboard. 

o Appendix A, "Common HyperCard Messages," lists the most 
common instructions you send to HyperCard using a feature 
called the Message box. (This appendix is for advanced 
HyperCard users.) 

o Appendix B, "HyperCard Disks," gives a listing of the 
documents and other files on each of the disks that comes with 
HyperCard. 
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Some conventions used in this guide 
Several special elements in this manual's text are designed to make 
learning easier. 

•!• By the way: A note like this presents additional information or 
interesting sidelights. 

Important Be sure to read every item that's labeled this way, with a tag in the 
margin. 

Warning 

Definitions of terms and 
references to other parts of the 
book sometimes appear in the 
margin. 

On-line help is assistance you 
can get from an application 
program whi le it's running . 

Warnings like this alert you to situations where you could damage 
software or lose data. 

Terms in boldface type are defined in the glossary. Sometimes the 
definition or additional information about such terms also appears 
in the margin. 

A special typeface indicates characters that you should type: 

It looks like this. 

• How-to sections are indicated by a red symbol. 

About on-line help 
HyperCard's Help system gives you immediate, on-line assistance 
whenever you get stuck. Use it when you've forgotten some 
procedure you read about in this book, or when you want a quick 
overview of a feature that's unfamiliar to you. 

On-line help versus this guide 

On-line help in HyperCard differs from the help you'll find in this 
user's guide in these key ways: 

o On-line help is brief; this guide is detailed. Turn to this guide 
when you need an in-depth discussion of a topic. 
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o On-line help might have information on a feature added after 
this guide was written. 

o On-line help lets you get to the information you need by clicking 
buttons and by doing electronic searches. It uses HyperCard's 
best features to explain HyperCard, and stands as an example of 
what HyperCard can do. To find information in this guide, you 
look up the subject in the table of contents or in the index and 
(alas) manually turn to the referenced page. 

Where to get HyperCard stacks 
Stacks are collections of information created by and used with 
HyperCard. You can create stacks yourself, or you can get them 
from a variety of sources. 

o You'll find HyperCard stacks for sale at your local computer 
software store. 

o Check with your local Macintosh user group to find out the 
meeting time of the HyperCard special interest group. Members 
often exchange member-created stacks with each other. 

o Most on-line electronic information services like CompuServe 
and GEnie have Macintosh special interest groups. These groups 
have (or soon will have) stacks you can get free, except for the 
service's time charges. 
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User groups 
Ask your dealer for the name of a Macintosh user group near you. If 
you live in the United States, you can call 1-800-538-9696 for the 
name, address, and telephone number of up to three Macintosh 
user groups in your geographic area. 

Outside the United States, ask your dealer or get in touch with 

The Boston Computer Society 
One Center Plaza 
Boston, Massachusetts 02108 
(617) 367-8080 

or 

Berkeley Macintosh User Group 
1442-A Walnut Street #62 
Berkeley, California 94709 
(415) 849-9114 

Either of these organizations can provide you with the name of a 
Macintosh user group near you. You can also join either of these 
groups or ask them for information on starting your own Macintosh 
user group. 

Additional documentation 
This guide covers everything you need to know to use HyperCard 
effectively up to (but not including) the scripting level. Scripts are 
programs that control the actions of HyperCard objects. For details 
about scripts and HyperTalk™, HyperCard's scripting language, see 
the HyperCard Script Language Guide: Tbe HyperTalk Language 
available from Addison-Wesley. Several other excellent books have 
been written about HyperTalk; check with your favorite bookseller to 
see what books are currently available. 
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HyperCard icon 

This chapter teaches you HyperCard® basics. It covers things 
everyone must know to use HyperCard. You'll learn how to 

o use some important HyperCard documents (called stacks) 

o roam through HyperCard stacks 

o search for information 

o edit text on cards (HyperCard's basic unit of information) 

D create places to hold new information 

Getting the most out of the tutorials 
Throughout this chapter and Chapter 2, you'll see one or more 
boldfaced sentences that begin with the symbol • · The symbol 
marks an action for you to do, to give you some experience working 
with HyperCard. Follow any numbered boldfaced steps in order. 

Getting started 
Before you can start your tutorials, you need to get HyperCard up 
and running. You start HyperCard the same way you start any 
Macintosh® application. 

• If you're starting HyperCard from a hard disk: 

1. Click the HyperCard icon in the Finder to select it. 

2. Choose Open from the File menu. 

Or double-dick the icon to open it. 

• If you're using HyperCard with 3.5-inch disk drives: 

1. Start the computer. 

If the computer is already on, choose Restart from the Special 
menu. (Ifyou"don't have Restart, choose Shut Down.) 

2. Put a copy of the HyperCard Startup disk, which you 
created earlier, into the startup drive. 

See pages xx-xxi for instructions on how to create this disk. 

Important HyperCard cannot work with a locked disk (or locked volume). 
Make sure that any disk you want to use is unlocked. 
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3. Put a copy of the disk labeled HyperCard Help into the other 
drive. 

HyperCard starts automatically. You'll see the screen in Figure 1-1. 

(!jHome Card (!j . 

~ w CJ - L5] A 
Intro Help Address Docum.;onts File Index Book Shelf 

rJJ1 ~ ~ . CJ] ~ ffiffiffi 
Phone To Do Weekly Calendar- Slide Show Hy pee Cale 

~ @) ~ X;f '' " 'i..I 
Art Ideas Clip Art Card Ideas Button Ideas: Stack Ideas Quotations 

Plots 
11.32 Al"1 

Figure 1-1 
Starting HyperCard 

Browsing 
Before you start to explore HyperCard, you'll need to know a few 
terms-specifically browsing, card, stack, button, and tool. 

Browsing is HyperCard's term for roaming around cards and 
stacks. 

A card is HyperCard's basic unit of information. A card fills the 
entire screen. (On larger-screen Macintoshes like the Macintosh II, 
a card appears in a window- you have some extra room on the 
edges.) What you see on the screen now is a card; Figure 1-2 shows 
some others. 
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Stack icon 

Browse tool 

Files 

January 4 

8 00 

9 00 

10 00 

11 :00 

12 00 

Figure 1-2 

2 00 

3:00 

4:00 

5•00 

Thr-ockrnorton Scribblernonger­
App 11? Corl? Magaz:ine 
221 5 While Rock Ii •Y 
San Francisco, CA 94131 

) 555-CORE 

Some cards-HyperCard's fundamental units of information 

A named collection of cards is called a stack. You can think of a 
stack as a HyperCard document. Cards in a stack usually (but not 
necessarily) are based on the same theme. An icon for each stack 
appears in the Finder. 

You do much of your browsing in HyperCard by clicking buttons. 
You activate buttons with the Browse tool. 

• Move the mouse around. 

The little hand you see moving around when you move the mouse is 
the Browse tool. HyperCard has many tools that you use to look for 
and to create information. The Browse tool is the tool you'll use 
most often. 

Letting HyperCard teach you 
You can learn a lot about HyperCard just by using it. This is 
especially true when you go through the on-line Introduction. 
(On-line means presented by the computer, as opposed to 
presented by this user's guide.) 
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Intro icon 

Previous card arrow 

0 

• Go through the on-line introduction: 

l . Move the mouse until the Browse tool is on the Intro Icon, 
and click. 

(It's near the screen's left corner.) In a few seconds, the card in 
Figure 1-3 appears. 

-------
- - --- -----------

Welcome to 

Hyp.C.trd 
~ [ Whotl< Hyp•'1:~d?] 
~ ( Goback _ 

Figure 1-3 
First card of the on-line Introduction 

2. Click the button labeled "What is HyperCard?" 

During the introduction you might want to review a card you've 
already seen. To do that, click the left arrow button to go back 
through the Introduction stack one card at a time. 

•:• You can always go back: Another way to see the previous card is 
to press the Tilde key. Stacks in HyperCard often link to each 
other (a concept you'll learn more about later). While the left 
arrow brings you to the previous card in the stack you're looking 
at, the Tilde key brings you to the last card you saw, no matter 
what stack it was in. 

• When you get to the card titled "What Next?" (about 15 
cards after the start of the on-line Introduction), click "Home 
to explore on my own"; then come back to this guide and 
continue reading. 
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Home 
You should be back at the Home card, the card you saw when you 
started HyperCard. You'll see Home more than any other card. 
Home is your base of operations, the jumping-off point for all your 
explorations in HyperCard. 

~ 
Intro 

~~ t®: 
Pnone 

~ J 
At-I Ideas 

l~ ..... 

Plots 

Figure 1-4 
Home card 

~Home Card~ 

w - DA 
H•lp Addr-ess D•)C1Jm.ents File lndi:-x Book Shelf 

~ 
To Do Weekly Calendar Slidt> S~1ow Hy pl?t-Ca k 

~ 
Clip Art C.;it"d Ideas 

I I 32 Al"l 

The Home card, first card in the Home stack, is a visual directory 
for your most important cards and stacks. Clicking one of the 
pictures here brings you to the card that the picture represents. 
(Each picture is actually a button.) In Chapter 2, you'll learn how to 
add pictures representing your own cards and stacks to the Home 
card. 

To get back to Home at any time, choose Home from the Go menu. 

•!• About the Go menu: The Go menu is HyperCard's navigation 
panel. You can use it to go from one card to another within a 
stack, to trace your way back through cards and stacks you've 
already seen, and to get help whenever you need it. In the early 
stages of working with HyperCard, you're likely to use the Go 

Go menu menu more than you'll use any other menu. 
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w 
Address Icon 

In a few moments you'll use the Home card to move to the Address 
stack. The Address stack is your personal telephone directory. 

As you're learning how to use the Address stack, you'll pick up a 
valuable HyperCard skill-how to look for information by searching 
for specific text rather than browsing from card to card. 

Using the Address stack 
The Address stack holds addresses and phone numbers. You look 
for a specific name, address, or phone number using the Message 
box. 

• Open the Address stack and look for a name: 

HyperCard comes with some sample Address cards; in this 
exercise, you'll look for a card with the name Steve on it. 

l . Click the button that looks like an address card. 

The card in Figure 1-5 appears. 

Figure 1-5 
First card in Address stack 
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2. Choose Find from the Go menu. 

The Message box appears near the bottom of the screen. (See 
Figure 1-6.) 

r-g,~:__~:__~---------

1 

Figure 1-6 
The Message box 

----==j 
- --- I 

---- ___ j 

3. Type Steve and press Return. 

The insertion point is already positioned between quotation 
marks for you. (You have to type between quotation marks for 
Find to work.) The card in Figure 1-7 appears. 

---------~------~----~-- ------------~,! 

Figure 1-7 
Finding a card 

;-r-1-, i 1-i! I ·11 ~ : 
lj 
I~ 

•:• ''It beeped at me!" If the Macintosh sounds a beep, reset the 
Message box by choosing Find from the Go menu and once again 
type what you want to search for. HyperCard beeps to let you 
know it can't find what you ask for. Sometimes this means that you 
spelled something incorrectly, and sometimes it means that what 
you asked for isn't in the stack. 
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HyperCard looks for the first card with text that starts with what you 
typed, and puts a box around the word. Pressing Return again makes 
HyperCard look for the next card with Steve on it. 

• Look for part of a word or name: 

HyperCard looks for what you ask, even if what you type is part of 
another word. You can see this work if you type ST into the 
Message box. 

1. Reset the Message box by choosing Find from the Go menu 
again. 

Each time you choose Find, HyperCard highlights any old text 
between quotation marks. The highlighted text will be replaced 
by any new text you type. 

2. Type ST into the Message box and press Return. 

Press Return a few more times, and see the results you get. 

Figure 1-8 

L;:irT\/ 11,:irt ine= 
i\?c:-.7 H1•;1hlStr-eetl 

Finding other words that start with ST 

You can learn more about searching later by reading the section 
called "Find" in Chapter 6. 

Using the Address stack 9 



A quick browse/search recap 
Find is another new way for you to get around in HyperCard. It's 
different from the other ways in that it's more specific-you have to 
know what words you want to find in order to use it 

You now know several ways to get around in HyperCard: 

o click buttons with the Browse tool 

o make choices from the Go menu 

o search for a specific word using the Message box 

Changing text 
In this section you'll change the information on one of the cards. 
(In the next section you'll personalize the Address stack by putting 
in the names and phone numbers of people you know.) 

• Use the Message box to reach a card; then change the 
card: 

1 . Choose Find from the Go menu. 

When the Message box is already visible, choosing Find resets 
the Message box, highlighting anything you've typed between 
quotation marks. 

2. Type Scribble and press Return. 

HyperCard looks for a card with the word "Scribble" on it. 
(Figure 1-9 shows the card.) 

3. Select the name "Throckmorton" by dragging across it. 

Dragging is a standard Macintosh technique that you're probably 
already familiar with: Position the I-beam pointer at the 
beginning of the word. Press and hold the mouse button while 
you "drag" the pointer across the word. Release the mouse 
button at the end of the word. If you've done this successfully, 
"Throckmorton" is highlighted. 

4. Type the name John. 

The new name replaces the old one. 

5. Close the Message box. 
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Figure 1-9 
Changing an address card 

You can select any text (except Paint text, described in Chapter 6) 
by dragging. Then type new text to replace it. 

For more details on editing text, see the section on the Edit menu in 
Chapter 6. 

Adding a card 
You can personalize all the cards in the Address stack by editing out 
the old text and adding new text. But you'll probably find it easier to 
create new cards to hold your information. You add a card to any 
HyperCard stack by choosing New Card from the Edit menu. 

• Add a new card to the Address stack: 

l . Choose New Card from the Edit menu. 

A new card appears, ready for you to add your own information. 
(See Figure 1-10.) 

2. Type your name and address. 

3. Press the Tab key to move the insertion point to the phone 
number line, and type your phone number. 

The Tab key moves you from field to field on a card in the 
Address stack. (A field is whe re you type text.) This card has three 
fields-name and address, phone number, and date. 
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4. Choose New Card again and add the name, address, and 
phone number of some close friend. 

Or, if you want to get down to business right away, type in contact 
information for your neighborhood pizza delivery restaurant or 
some other vital service. 

Figure 1-10 
A new address card 

Continue to add cards if you want. When you've finished, go on to 
learn about how cards are arranged in a stack. 

•!• Don't wony about alphabetical order: You can create a new card 
wherever you want in the stack. In a few moments, you'll 
alphabetize the stack with the click of a button. 

How cards are arranged in a stack 
When you choose New Card, HyperCard adds a new card to the 
stack immediately after the one that's on the screen. 

If all the cards in a stack are created at the same time, they appear in 
the order of their creation. If you choose New Card while you're 
near the middle of the stack, that's where the new card goes-in the 
middle of the stack. 
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Arrow to next card 

Sort button 

• Go through the stack one card at the time to see the 
stack's "natural order": 

1. Get to the first card in the stack by choosing First from the 
Go menu. 

2. Click the right arrow (the one that points to the right, next 
to the left arrow) to move through the stack, one card at a 
time. 

Eventually you'll come to the new cards you created. (Most cards 
in the stack are alphabetized; your cards will probably be out of 
order.) 

3. Keep clicking the right arrow until you come back to the first 
card in the stack. 

Think of the cards in a stack as being looped on a ring; when you 
reach the end, you start over again. (See Figure 1-11.) 

Figure 1-11 
Cards ringed in a stack 

4. Sort the stack by clicking the Sort button. 

A dialog box appears with buttons for sorting by first name or last 
name. (See Figure 1-12.) 

Sort all cards of thrs stack according to 11 
Fir-ilName:1 L .. ~~t ~1 K_ c~~;!Jj 

Figure 1-12 
Sort dialog box 
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Spinning beach ball 

Quick View buttcn 

Important 

5. Choose Last Name to sort alphabetically by last name. 

The pointer turns into a beach ball; it spins while HyperCard 
completes the sort. 

6. Go through the stack quickly by clicking the Quick View 
button. 

(Click the mouse to stop the display.) You'll see the new cards 
you added sorted into their proper alphabetical place. 

•:• Getting rid of unwanted cards: The Address stack comes with a 
number of sample cards. You can eliminate the cards you don't 
want: move to an unwanted card and choose Delete Card from 
the Edit menu. 

You don't have to save your changes; HyperCard does it for 
you automatically. As a result, there is no Save command in 
HyperCard. You'll read more about this in Chapter 6. 

Explore the Help stack 
Before you read any more of this book, explore the Help stack, 
HyperCard's ever-ready help system. 

• Choose Help from the Go menu to get to the Help stack. 

(See Figure 1-13.) 

The Help stack briefly explains all of HyperCard's features. It's not 
only an extremely useful information source that's always available, 
but also an excellent example of the kinds of things you can do with 
HyperCard. 

To use the Help stack, click one of the tabs along the card's bottom. 
(Each tab is actually a button.) 
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Figure 1-13 
Help stack's first card 

/ 
.. -~\ 

'· ,- -\ 

"• 

Click the Exit tab at the bottom of a card when you've finished using 
Help; you'll return to the Address stack at the card that was on the 
screen when you chose Help. 

Recent: Seeing where you've been 
When you used the Address stack, you saw how cards are arranged in 
a stack-one after the other in a loop, as if they're held together by a 
ring. You clicked the left and right arrows to move from card to 
card. 

When you chose Help from the Go menu to get to the Help stack, 
and later when you pressed the Exit button to come back to the 
Address stack, you saw that you can move between stacks as easily as 
you move between cards. 
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Click any card to go to it. ------1 

As you go from card to card and stack to stack, HyperCard 
automatically keeps a record of where you 've been. Recent shows 
(in miniature) up to the last 42 cards you looked at. It's a great place 
to go when you need to retrace your steps. (When you've passed 
through more than 42 cards, the top row of Recent rolls off to make 
room for a new row of cards at the bottom.) 

• Choose Recent from the Go menu. 

(See Figure 1-14.) 

L_ 

Figure 1-14 
Recent 

•!• Recent shows what you've seen: A stack might have hundreds of 
cards in it, but if you looked at only three cards in that stack, 
Recent shows only the three cards you looked at. 

You can go directly back to any card represented in miniature in 
Recent. Try it now. 
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• Go directly to a card shown on Recent: 

1. Click any card's miniature picture. 

(Each picture is actually a button.) You immediately go to that 
card. 

2. Choose Recent again on the Go menu. 

A rectangle encloses the image of the card you went back to. 

3. Click the Image of the card you were on when you first 
chose Recent. 

What you've learned so far 
In the short time you've used HyperCard, you've learned quite a lot. 
Among other things, you know 

o how to use the Address stack 

o how to get from card to card and stack to stack using the Browse 
tool 

o how cards are arranged in a stack 

o how to see where you've been, and how to go back there 

o how to search for text 

o how to use the Home card as your base of operations 

o how to use several menu commands 

You already know enough to use most of the stacks that come with 
HyperCard and that are available for sale and for trade. (See 
"Where to Get HyperCard Stacks" in the Preface for some specific 
places to get more stacks.) Most stacks that require further 
instructions have a card or two telling you what you need to know. 
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Browse tool 

Back ;¥' 

Home :"€:H 

Help itP 
Recent :"€:R 

First :"€:1 
PreL1 :#;2 
NeHt :"€:3 

last :#-1 

Find ... aH 
Message :#:M 

Go menu 

How to get there from here 

Here's a quick summary of the ways you've seen so far to find your 
way around HyperCard. They all come in handy at one time or 
another. 

Browse tool 

Home 

Recent 

First 

Last 

Find 

Click buttons with it to move to other cards. 

Choose Home from the Go menu to reach 
this graphical directory of stacks; then click 
the button for the stack you want to go to. 

Choose Recent from the Go menu for a 
pictorial summary of cards you've seen; then 
dick the picture of the card you want to go to. 

Choose First from the Go menu to get to the 
first card in a stack. 

Choose Last from the Go menu to get to the 
last card in a stack. 

Choose Find from the Go menu; then type 
what you want to find and press Return. 

•:• Not sure where the buttons are? Hold down the Command and 
Option keys at the same time, and HyperCard lets you peek at 
buttons on a card. 

What to do next 
You can continue to work with the Address stack; you can go on to 
explore other stacks (Appendix B has a descriptive list of all the 
stacks that come with HyperCard); or you can go on to Chapter 2 for 
tutorials on customizing stacks to your own liking. 

To explore more stacks or to go on to Chapter 2, be sure to start 
from the Home card. 

• Go back to the Home card. 

You go back to the Home card by choosing Home from the Go 
menu. (You'll learn more about the Home card in Chapter 3.) 

•:• Another way to get Home: Anytime you see a picture of a house 
on a card, you can dick the house to go to the Home card. 
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Chapter 2 

Customizing 
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Sometimes the way a stack looks isn't to your liking. The picture you 
see on a particular card isn't suited to your purposes, or a field is in 
an inconvenient place or its text is in a font or style that you don't 
like. This chapter shows you how to use HyperCard's features to 
customize cards and stacks. 

•!• Customizing isn't required: You don't have to customize a stack 
to use it. These tutorials are for people who enjoy modifying 
things to meet their specific tastes. It's OK to leave stacks as they 
are. 

This chapter has two tutorials. The first, "Painting," goes over some 
of HyperCard's features for editing pictures. You'll learn how to 

o copy pictures from one card to another 

o edit the pictures you copy 

o create new pictures using HyperCard's painting tools 

The second tutorial, "Authoring," includes the basic elements of 
stack creation. You'll learn how to 

o create new stacks 

o copy pictures, buttons and fields from existing stacks to your new 
stack 

o Move buttons around on a card 

The tutorials are separate. If you aren't interested in authoring yet, 
just do the Painting tutorial and go on to explore HyperCard. 
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Painting 
HyperCard provides a variety of tools for changing the way a card 
looks. Chief among these are the Paint tools; you use them to create 
and to change pictures. 
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Figure 2-1 
Paint tool at work 

Setting user level to see the Tools menu 
You choose the tool you need from the Tools menu. To see the 
Tools menu, you must tell HyperCard you're ready to use it. 
(HyperCard keeps menus out of sight until you need them.) 

You tell HyperCard that you're ready to work with new tools by 
changing your user level on the User Preferences card. It's the last 
card in the Home stack. 

• Move to the User Preferences card of the Home stack: 

1. Start from the Home card. 

2. Choose Last from the Go menu. 

The Last command brings you to the last card of the current 
stack. The User Preferences card appears. (See Figure 2-2.) 
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User Preferences 

user Name: Pri rno Acrn~ 

Figure 2-2 

User Leuel: 

0 Browsing 

@Typing 

0 Painting 

O Authoring 

0 Scripting 

User Preferences card 

D TeHt Arrows 

HyperCard has five user levels. Each level incorporates everything 
from previous levels, plus adds new abilities. When you first start 
HyperCard, you're at rhe Typing level. At rhis level you can wander 
through HyperCard's stacks and do searches, and you have rhe 
ability to make changes to text. 

Now you need to be able to use rhe Paint tools-an ability rhat 
comes wirh rhe next level. 

• Ciiek the button labeled Painting. 
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(HyperCard stays at your new level until you change it, even if 
you quit HyperCard and restart.) A new menu appears in the 
menu bar. 



Ignore this for now 

User Preferences 
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Figure 2-3 
Changing user levels 

Changing the way a card looks 
You use the Paint tools on the Tools menu to change a card's 
picture. 

More about these tools -----~~ 
in the next tutorial. 

Browse tool selected. ------l!lll!i. 
(It's the one you're 
using now.) 

Paint tools ----------1 
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Figure 2-4 
Paint tools 
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HyperCard comes with a stack specifically included for you to 
practice your painting on, the Quotations stack. You'll go to this 
stack using a command that's new to you-the Open Stack 
command. 

• Get to the Quotations stack: 

1. Choose Open Stack from the File menu. 

A directory dialog box appears, letting you select the stack you 
want to work with 

2. Select Quotations and click Open. 

•!• A quick diversion: The Quotations stack is a collection of 
aphorisms and famous sayings. Guess the author of the 
quotation; then click the "Who says?" button to see if you were 
right. (Click it again to hide the answer.) When you want to stop 
the game (or you run out of quotations), come back here. 

Copying a picture from another card 
Cards with pictures on them are visually more interesting than cards 
with just text. You can add a picture to a card by copying an image 
from another card, or by drawing a picture yourself. 

Copying an image is a simple operation. To get some practice 
doing it, you'll copy the images of a loaf of bread and a jug of wine 
from a card in the Art Ideas stack; then you'll paste the images onto 
a card in the Quotations stack. 
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• Copy an image from one card to another: 

1. Start with the card in the Quotations stack that reads 
"A book of verses underneath the bough." 

To find it, Choose Find from the Go menu, type book of 
verses, and press Return. Your next step is to go to the Art 
Ideas stack to copy pictures. 
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Figure 2-5 
Book of verses card 
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2. Choose Open Stack from the File menu. 

The directory dialog box appears so that you can choose the 
stack you want to open. The Art Ideas stack is in the Idea Stacks 
folder. 

If you're using HyperCard on a hard disk, use the directory 
dialog box to select the Art Ideas stack. 

If you're using HyperCard from 3.5-inch disks, you'll have to 
replace the Help disk currently in the drive with the HyperCard 
Ideas disk. To do that, click the eject button in the directory 
dialog box and swap disks. 

3. Select Art Ideas and click Open. 

You're now at the first card of the Art Ideas stack. 

4. Move to the card labeled "Restaurants, Food, Recipes." 

To get to this card, choose Find from the Go menu, type the 
word Food, and press Return. 
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Selection rectangle 

Restaurants,IF oocil. Rec1 pes 

Figure 2-6 
Food card 

5. When you find the picture you want, choose the Selection 
tool on the Tools menu. 

The Selection tool lets you select a part of a picture to work on. 
(When you choose this tool, some new menu titles appear on 
the Title bar; ignore them for now.) 

6. Drag diagonally across the images of the loaf of bread and 
the bottle of wine to select them; then release the mouse 
button. 

The dotted lines move when you release the mouse button to 
show that the selection is active. Don't worry if you select too 
much; you can edit it later. If you make a mistake, choose Undo 
from the Edit menu and start dragging again. 

Start dragging here. ------- ---+1"---':!, -- - - - - - - - - - - - -

" !:~·' 
Release the mouse button 
when you·ve selected 
what you want. 

l~I {:J I • ~-=-' I 
_ I ' H.1.;..:.· ..... I :ii 1·u~ : =-=I;·_ ·-IJ; ii: 
' - / 

Figure 2-7 
Selecting a picture 
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7. Choose Copy Picture from the Edit menu. 

What you copy goes onto the Clipboard, a holding place for cut 
or copied text and graphics. 

8. Choose the Browse tool from the Tools menu. 

9. Choose Recent from the Go menu. 

10. Go back to the Quotation card by clicking Its image on 
Recent. 

:' ... 
---· ~ :...:. ';_-- - -""-'- ::;_ !.!.l!_~_.-_ 

Cilek here to go back to Quotations.~~-------:! __ _ 
---- -·- ~=~~·---- ~.;.. ___ J=--. __ :_· 

Figure 2-8 
Going back to the Quotations stack using Recent 

11. Choose Paste Picture from the Edit menu. 

The material you copied to the Clipboard is pasted to the 
Quotation card. (See Figure 2-9.) 

12. Drag the pasted picture where you want It to go; then 
click anywhere outside the picture to set It In position. 

To drag the picture, move the pointer anywhere inside the 
selected area, hold down the mouse button, and move the 
mouse. If you make a mistake, choose Undo from the Edit 
menu. 

13. Experiment with the Paint tools to touch up your picture. 

(See "Some Paint tool tips" in the next section.) It's OK to make 
a mess; that's what this stack is for. You can't hurt any other 
stack while you're in this one. 
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Paste it here . -------------------------~ 
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Figure 2-9 
Pasting a copied Image 

You can paste as many pictures onto a card as you want. Use any of 
the Paint tools to modify the picture, or paint your own picture from 
scratch. 

Using the Paint tools 

This is a great time to experiment with the Paint tools. 

• Add a new card or two to the Quotations stack: 

1 . Select the Browse tool. 

2. Choose New Card from the Edit menu. 

A new card appears. 

3. Type your favorite quotation on the left page. 

Press Tab to set the insertion point at the top of the page. 

4. Click the Who Says button. 

An empty box appears. (It's actually a field- a place to hold 
text-ready for you to type into.) 

5. Ciiek Inside the box and type the name of the quotation's 
source or author. 

When you've finished typing, click the Who Says button again to 
hide the box. 



This draws thin. 
free-form things. 

Draw lines with this. 

This erases mistakes. 

Double-click this 
to choose a new 
brush shape. 

Use this to fill In 
a closed shape 
you've already 
drawn. 

The more you spray, 
the more the pattern 
shows. 

6. Construct a picture on the right page using the Paint tools. 

(See "Some Paint Tool Tips," below.) You can borrow from 
other stacks to do it. Don't worry if your name isn't Rembrandt; 
this is all just for practice (and for fun). 

Some Paint tool tips 

To select a Paint tool, just drag to the one you want on the Tools 
menu and then experiment. Most tools start to work when you press 
down the mouse button and drag, and stop when you release the 
mouse button. Here are some tips on using Paint tools: 

o Select a pattern from the Patterns menu to use with the Brush, 
Bucket, and Spray tools. 

o Choose Brush Shape from the Options menu and click the shape 
you want. Each shape gives a different effect, so experiment with 
them all. 

o Use the Brush or Pencil for freehand work. 

o The Eraser-erases. 

---Ciiek to choose 
a pattern for painting 
or to fill In shapes. 

----- Use these tools to 
draw clrcles, squares. 
rectangles. and other 
shapes. 

----- Choose a pattern 
to work with these tools. 

Figure 2-10 
Using the Paint tools and Pattern menu 
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Experiment with the other tools to see what they do. 

•!• Convert menus to palettes: You can "tear off' both the Tools 
menu and the Patterns menu so that you can have constant access 
to them as you work. Just drag through them, past the bottom or 
off to one side; then leave them where you want them. When they 
get in your way, move them by dragging their top bars. Click 
their dose boxes to make them go away. 

' ' ' ' ' ' ' ' ' ' 

Figure 2-11 

' ' ', 
' 

Tearing off a menu 

Experiment time 

Experiment for as long as you want with the Paint tools. Make a mess 
on the screen. Create new quotation cards or modify old ones. 
Practice copying graphics from other stacks. 

•!• A quick cleanup trick: If your screen gets really messy and you 
want to clean it up, double-click the eraser on the Tools palette: 
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Everything you painted gets erased. If you double-dick by 
mistake, choose Undo from the Edit menu. 



You can read more about the Paint tools and what they do in the 
"Tools Menu" section of Chapter 6, throughout Chapter 5, and in 
the Menus section of the Help system. 

• Go back to the Home card when you've finished 
experimenting. 

When you're ready, go on to the final lesson, Authoring, and learn 
how to create stacks of your own. 

Authoring 
You've learned how to get around in HyperCard, and you've had 
some experience in changing text and graphics on a card. In this 
section you'll learn HyperCard's real power-changing how things 
work 

•:• You don't have to be an author: It isn't necessary for you to learn 
how to change a stack radically in order to use HyperCard 
effectively. You already have all the information you need to get 
a great deal out of HyperCard. The rest of this chapter is for you if 
you have special needs that the stacks that come with HyperCard 
don't meet, or if you like to do things your own way. 

You'll need to change your user level to become a stack author. 

• Change your user level to Authoring on the User Preferences 
card: 

1. Choose Home from the Go menu. 

If you 've come here directly from the previous tutorial, the 
Home card is probably already on the screen. 

2. Choose Last from the Go menu. 

You move to the User Preference card, the last card in the Home 
stack 

3. Click the button labeled Authoring. 

A new title-Objects-appears in the menu bar. (See 
Figure 2-12.) You're now at the highest level that this guide 
takes you to. 
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Another new menu 

A high user level 

Tools 11 

Preferences 

U er Name: • r r 

u~er leuel: 

Browsinq 

T4pmg TeHt Arrows 

Pamtmq Power 11.eys 

• Authoring 

~cnptmq 

Figure 2-12 
Moving up to Authoring 

Before you continue, go back to the Home card. 

• Choose Home on the Go menu. 

Making a new stack from an existing one 
You can make a new stack based on an old one. 

When you make a new stack based on an existing one, the new stack 
takes on the basic characteristics of the current card's background. 

In this exercise, you'll make a new stack based on the To Do card. 
(You type all the things you've got to do today on the To Do card.) 

• Move to the To Do card by cllcklng Its Icon. 

•:• Where is Date book? If you 're using 3. 5-inch disks for this 
tutorial, you'll need to swap disks in one of the drives. Here's 
how: when HyperCard displays the directory dialog box asking 
for Datebook (the stack that contains the To Do Card), click the 
Drive button until you get to the Art Ideas disk. Click the button 
labeled Eject; then replace the ejected disk with the HyperCard & 
Stacks disk. 

To Do Icon The card in Figure 2-13 appears. 
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Figure 2-13 
A To Do card 

You'll use the basic design of this card for your new stack. 

• Create a new stack based on the To Do stack: 

1. Choose New Stack from the File menu. 

The directory dialog box appears, asking you to name the new 
stack. (See Figure 2-14.) 

H p f I 1 <, 

You use the current stack's ----­
design for the new stack if 

c p J cu nt b CK 

this box is checked. 

Figure 2-14 
Making a new stack 
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Button tool (in Tools menu) 

2. Type My To Do stack and click New. 

When you choose New Stade from the File menu, you can use the 
basic design of the card that's on the screen for the new stack. 
(You don't copy any of the stack's data, just the stack's template.) 

You now have a new stade, ready for you to modify and to fill with 
information. (See Figure 2-15.) 

Figure 2-15 
First card in new stack 

Moving buttons 

Customizing a stack is a matter of deciding what you like and don't 
like about a design, and then changing the design. In this exercise, 
you'll change the design by moving a button around. 

• Move the Telephone button to the top-left side of the page: 

1. Select the Button tool from the Tools menu. 

(It's the tool in the middle of the top row.) A box appears around 
all the buttons on the card. 

2. Move the pointer to the center of the Telephone button, 
and press and hold the mouse button. 
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3. Drag the Telephone button to the left until it aligns with the 
left edge. 

4. Release the mouse button. 

The moving dotted line around the button lets you know the 
button is still selected. (When you click another button or when 
you select another tool, the dotted line goes away.) 

The top of the card should look like Figure 2-16. 

Figure 2-16 
To Do card with Telephone button moved 

When you move a button, the only thing that changes is its position; 
what the button does remains the same. 

Deleting buttons 
Sometimes the buttons you find in a design don't do what you want. 
For this exercise, assume that the only buttons you want at the top of 
the card are the Telephone and Home buttons. 

• Delete all but the Telephone and Home buttons from the top 
of the card: 

1. Select the Button tool from the Tools menu. 

If you've been following along, you've already selected this tool. 

2. Click the Address stack button. 

The box around the button changes to marching ants. 

3. Choose Clear Button from the Edit menu. 

The button disappears. 

4. Repeat steps 1 and 3 for the rest of the buttons you want to 
remove. 
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Button Ideas button 
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Copying buttons from another stack 

In the Painting tutorial, you saw how to borrow pictures from other 
cards to use on your own cards. You can borrow buttons in the same 
way. 

• Add a Help button by copying it from the Button Ideas stack: 

l . Go to the Home card. 

You can select the Browse tool, then click the Home button on 
the top of the card you're on. 

2. Click the Button Ideas icon. 

(You might have to swap disks to get to this stack.) The card that 
appears is actually an index. 

3. Click the Text button. 

The card in Figure 2-17 appears. 

4. Select the Button tool. 

Now you're ready to select a button and copy it. 

5. Click the button marked Help. 

When you're using the Button tool, you click a button to select it 
rather than to make it carry out an action. 

6. Choose Copy Button from the Edit menu. 

7. Get back to your To Do card using Recent from the Go 
menu. 

Your To Do card reappears. Now you can paste the button you 
just copied. 

8. Choose Paste Button on the Edit menu. 

The button you just copied appears. 

9. Drag the button where you want it to be. 

A good place for it is next to the Home button. (See 
Figure 2-18.) 

l 0. Click the Browse tool to set the button in place. 

Whenever you need help, you can click the Help button. (Try it 
out, if you like. Press the Exit button at the bottom of any Help 
card to get back.) 



r 
' Text Buttons 

NeHt Card ) ( Home J Sort J 

Preu Card J ) ); -H;ip 
This is the button you want. ---------~ r' 

First Car Dr al 

""'"" J /~ Button tool selected ------~-----------------~ 

Field tool 

Any Card J EHpor 

Fll'ttrn J mpo 

Figure 2-17 
Assorted buttons 

Changing a field's size and position 

You add text to a card by typing into fields with the Browse tool 
selected. The new To Do stack has three fields on it. To see them, 
click the Field tool on the Tools menu. 

Three fields.------~L__~/ _____ _/ / 

all enclosed In boxes / 

Here's the Help button ---------------------~ 
you just pasted in. 

Figure 2-18 
Help button pasted, fields visible 
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You can change the size of a field or move it easily. 

• Change the size of the field on the right: 

l . With the Field tool still selected, click anywhere within the 
card's right field to select the field. 

2. Drag the lower-right corner of that field toward the left side of 
the card to make the field narrower. 

Make it about one-third the width that it is now. 

• Move the field you just changed by placing the pointer in its 
center and dragging the field to the right. 

Move it close to the right edge. (See Figure 2-19.) 

Figure 2-19 
Shrinking and moving fields 
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Copying a field 
Copying a field is as easy as moving one. And as long as you've got 
the room ... 

• Make a copy of the field on the right: 

l . Select the field on the right by clicking it. 

You know it's selected because it's surrounded by a moving 
dotted line. 

2. Choose Copy Field from the Edit menu. 

3. Choose Paste Field from the Edit menu. 

The new field is pasted directly over the original, so the screen 
appears to show only the newly pasted field. 

4. Drag the copied field to the left. 

Figure 2-20 
Copying a field 

>lf p 

You can also copy fields from other cards, just as you can copy 
buttons and pictures. 
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Background is the name for 
common elements shared by a 
number of cards. 

Cards versus backgrounds 

A number of cards can share the same background. When you 
chose New Stack to create the stack you've been working on, you 
copied the background of the card that was on the screen at the 
time. Figure 2-21 shows a card with a distinct background part. 

This is what you ' d see -----­
on the screen-a r ~·1 t/ 

11\jir. 

"I E-.,.1--,,,,--,.,. ·:~ .. ~J-c-:,,.-:--, --, r--

~1 ~~;~="'=F·-=":p __ =111 I-~, I 
combination of the background 
and the part unique 
to a given card. 

All this is on the background. 
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This part changes 
from card to card. 

A background shared by a number of cards 

Buttons, fields, and pictures can live on the background of a card, 
or on the card itself. When they're on the background, these 
objects-buttons, fields , and pictures-are shared by all cards 
associated with that background. When they're on the card, they're 
specific just to that card. 



Background fields are 
common to a number 
of cards. 

Card fields appear 
only on a specific card. 

Company 
la a, CA 94G13 

Figure 2-22 
Background versus card field 

To see what this is about, you'll first have to make a new card for the 
stack you've been working on. 

• Make a new card for the stack by choosing New Card from 
the Edit menu. 

You'll notice that the Help button you pasted appears just on the 
first card-it wasn't duplicated when you chose New Card; and the 
field you duplicated was only duplicated on the original card. You 
created a card field and a card button, objects that work only on a 
single card; contrast that with background fields and background 
buttons, objects common to all cards that share a particular 
background. (With the Browse tool selected, click the left arrow and 
right arrow buttons at the bottom of the card to go back and forth 
between cards.) 
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Background has -------------------------~ 
no Help button on it. ~ 
Copied button ------------ ~ 

Duplicated field ---------

Background has ____________________ _; 
only one field on it. 

Figure 2-23 
First card versus second card 

The card on the right in Figure 2-23 is the one you just made with 
New Card. Its features all come from the background. 

• Look at the background for these cards: 

1. Be sure you're on the first card in the stack by choosing First 
from the Go menu. 

2. Choose Background from the Edit menu. 

The background appears. (See Figure 2-24.) 

Diagonal lines te ll you ------· · .... · · · · · · · .. .. ,, .. · .. · · · ...... 
that you're looking at Ii File Edit Go Tools Ob Ji;~•.\,,.., 
the background. ;.,;o -~ 

"lit ~;,, 

Figure 2-24 
Background 

:;t3 
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If you switch back and forth between the background and the card 
by choosing the Background command several times, you'll see 
the button and the extra field disappear and reappear. (The 
Background command is like a push-button light switch-if 
you're looking at the card when you choose it, you switch to 
the background; if you're looking at the background when you 
choose it, you switch to the card.) You can tell when you're in the 
background because the menu bar in the background has diagonal 
stripes. 
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•!• You can edit background fields and buttons from the card: You 
can make an existing background field or button smaller or 
larger or delete it but you can't create new background fields or 
buttons unless you're in the background. That's why the field 
you made smaller remains smaller when you look at the 
background, and the buttons you deleted remain deleted. 

To make a field, button, or picture common to a number of cards, 
create it (or paste it or duplicate it) in the background. 

You can move the duplicated field and the Help button from the 
first card to the background. When you do that, the extra field and 
the button will show on both cards, and on any new cards that you 
create. 

• Move the duplicated field and the Help button to the 
background: 

1. With the Field tool selected, click Inside the duplicated 
field. 

Be sure you're on the card and not in the background-you 
shouldn't see any diagonal lines in the Menu bar. 

2. Choose Cut Field from the Edit menu. 

The field disappears. 

3. Choose Background from the Edit menu. 

The background appears-you see the diagonal lines again. 

4. Choose Paste Field from the Edit menu. 

The field reappears, now part of the background. 

5. Choose Background from the Edit menu again. 

You're back at the card- the diagonal lines in the Menu bar 
have disappeared. 

6. Select the Button tool and click the Help button. 

You'll know it's selected because a moving dotted line 
surrounds it. 

7. Choose Cut Button from the Edit menu. 

The button disappears. 

8. Choose Background from the Edit menu. 

The background appears- you see the diagonal lines again. 

9. Choose Paste Button from the Edit menu. 

The button reappears, now part of the background. 
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New Button button 

1 O. Choose Background from the Edit menu a final time. 

You end up with all buttons and fields in the background. To prove 
it, create a new card. 

• Choose New Card from the Edit menu. 

The new card will have two fields on the right side and a Help 
button at the top. 

•!• A final note about fields: What you type on a field created in the 
background changes from card to card, although the field's size 
and position remains constant on all cards associated with that 
background. When you create a field on a card, the field stays just 
with that card- and, of course, so does what you type in it. 
Experiment by creating a few card fields in the stack you just 
created to see what happens. 

Experiment for a while 
Continue working on this stack for a while. Make all the changes you 
want. Don't worry about messing things up; this stack is just for 
practice. 

• When you've finished experimenting, go back to the Home 
card. 

Connecting to the Home card 
You've read here and in the first chapter that Home is your base of 
operations. It makes sense, then, to put a button on the Home card 
that gets you to the stack you just made. In this final exercise, you'll 
create a new button for the Home stack, give it a name, and then 
create a connection to your new stack. 

• Create a link between the Home card and your To Do stack: 

1. From the Home card, choose New Button from the Objects 
menu. 

HyperCard selects the Button tool and a button named New 
Button appears selected in the middle of the Home card. 

2. Choose Button Info from the Objects menu. 

The dialog box in Figure 2-25 appears . 
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3. Type Things to do Into the Button Name box. 

The new name replaces the old name, New Button. (You'll find 
details on the rest of this dialog box under "Button Info" in 
Chapter 6.) 

4. Click UnkTo. 

The dialog box in Figure 2-26 appears. 

t~i:~---1~~:-~~~'G ~I ( Y~~s ~;tark :1 i:~~ ~:~~~--
l_ ~~~-~ -- ~~-~~-~~-~--~-
Figure 2-26 
LlnkTo dialog box 

5. Choose Open Stack from the File menu. 

The Directory appears. 

6. Select My To Do Stack and click Open. 

The first card in the stack you just created appears. 

7. Click This Stack In the LlnkTo dialog box. 

HyperCard completes the link and returns you to the Home card. 

8. Drag the new button to a convenient place on the Home 
card. 
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9. Test your new button. 

To do that, first select the Browse tool; then click the new button. 
You immediately go to your new stack. 

Where to go from here 
This ends your tutorials on HyperCard's basics. You know enough 
now to get off to a great start. You can go on reading in this manual 
to learn more about HyperCard or you can go off on your own, 
browsing and editing as you like. 

• To use the Help stack to learn more about tools: 

l . Choose Help from the Go menu. 

This gets you to the Help stack from anyplace in HyperCard. 

2. Click the Menus tab at the bottom of the card. 

You '11 see the Menus card. 

3. Click the Tools menu and explore. 

To learn about a specific tool, just click its icon. (See 
Figure 2-27.) 

lW 

Figure 2-27 
Exploring with the Help stack 

Happy wandering! 



Chapter 3 

Home 

47 



Home is HyperCard's central stack. Each of its cards holds 
information vital to HyperCard's performance. 

o The first card, Home, holds buttons that take you to the most 
important cards in your collection. 

o Three search path cards tell HyperCard where to find 
applications, documents, and stacks that you use frequently. 

o The User Preferences card lets you customize the way you interact 
with HyperCard. 

Warning HyperCard will not operate without a Home stack. Do not 
delete the Home stack. 
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Home card 
No matter what other cards and stacks you have, you always have 
Home. Most people use it as their starting place for moving around. 
You'll find the Home card most useful if you create a button on it 
linked to each new stack and to each of your favorite cards. 
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Figure 3-1 
Home card 
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•:• Creating a graphic button for Home: To create a graphic button, 
first paint or paste a small picture on Home representing the new 
stack; then cover that picture with a transparent button linked to the 
new stack. Or you can use icons as buttons by clicking Icon in a 
selected button's Button Info dialog box and choosing from the 
icons that appear. You can also copy predesigned buttons from 
the Button Ideas stack. "Copying Buttons From Another Stack" and 
"Connecting to the Home Card" in Chapter 2, and "Icon" in 
Chapter 6, provide step-by-step instructions for these procedures. 

For information on linking buttons, see "Button Info" in Chapter 6. 

Search paths 
A search path is the route HyperCard follows to retrieve a stack, 
application, or document. When you tell HyperCard to open 
a file-by clicking a button on the Home card, for example­
HyperCard follows its own preset search paths to find the file. 

•:• Preset search paths: HyperCard first looks for the requested file 
in the folder that's currently active; next it looks in the folder that 
the Help stacks are in; and then it looks on the root level of the 
directory-that is, on the current disk among the files that aren't 
in any folders. Finally, it checks the search path cards to see what 
route to follow. 

If HyperCard can't find a file you ask for, it displays a dialog box. 
(See Figure 3-2.) 

Where is lost stack? 

I a HyperCard Stacks I 

Home 
C: Jane's Graphics 
D MAD Stack 
[' masking demo 
[' Phone 

~~~~~~~~~ 

Figure 3-2 
Dialog box for finding a file 
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As you click your way through the directory dialog box to locate a 
file, HyperCard records your path. Once you've located the file, 
HyperCard notes the volume and folder (and if necessary, 
subfolder) in which the file resides, and records it on the 
appropriate search path card in the Home stack. The next time you 
ask for that file, HyperCard will know where to look for it without 
having to ask you to find it. 

Important HyperCard cannot work with a locked disk (or locked volume) . 
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Make sure that any disk you want to use is unlocked. 

•:• Occasional housecleaning: HyperCard keeps a search path on 
record until you erase it. It's a good idea to erase a search path 
you use infrequently, freeing up that space on the search path 
card. To erase a search path, just select it and choose Clear from 
the Edit menu. 

User Preferences 
Set the User Preferences card to customize the way you interact with 
HyperCard. From the Home card, click the left arrow to get to the 
User Preferences card (Figure 3-3). 

User Preferences 

User Name: Pri1T10 A. r'lt 

Figure 3-3 
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Click the proper user level to match what you want to do with 
HypeICard. The higher the user level you choose, the more power 
HypeICard gives you: 

Browsing Short File and Edit menus (Figure 3-4), plus 
the Go menu. Use of the Browse tool. 

Typing 

Painting 

Authoring 

Scripting 

Same as Browsing, plus ability to edit text in 
existing fields. 

Same as Typing, plus full File and Edit 
menus (Figure 3-4), Tools menu (plus Paint, 
Options, and Pattern menus when a Paint 
tool is selected), use of all Paint tools (but 
not Button and Field tools), Power Keys 
option. 

Same as Painting, plus Objects menu, use of 
Button and Field tools. 

Same as Authoring, plus ability to type into 
Message box while it's hidden (if the "Blind 
Typing" option is chosen), plus ability to 
write and edit scripts. 

g~<' l 
"''I 
Jtc I 

Undo :J€Z 1 

'~€: ~J ~ 

Cut 
Copy 
Paste TeBt 
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Browsing and Typing get short menus. 

Figure 3-4 
Short and full File and Edit menus 

l 
Dockqr~~.:ni::_1 :~gB ~ 

Painting. Authoring. and Scripting 
get full menus. 
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The Command key is marked by 
a propeller-shaped symbol. On 
some Macintosh keyboards. the 
key also has an Apple symbol. 
and some Macintosh manuals 
might call it the Apple key. Both 
names refer to the same key. 
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You can set one level now and change it to a higher one later, when 
your HyperCard skills improve or when you feel comfortable 
experimenting with more advanced abilities. 

•!• User preferences and stack protection: The preferences you set 
here apply in a general way to all HyperCard functions. The 
tools and commands you have at your disposal while you're 
using a specific stack, however, are based both upon the level 
you set on User Preferences and on the specific stack's 
protection level. When a stack is set for a different level of use 
than is set on User Preferences, the lower setting has 
precedence. (Lower means "closer to Browsing.") See "Protect 
Stack" in Chapter 6 for details. 

For information about power keys, see "Power Keys" in Chapter 5 
and Chapter 6. 

For details about the Message box, see "Message" in Chapter 6. 

Ways to go Home 
HyperCard provides several ways to get to the Home card: 

o choose Home from the Go menu 

o press Command-H (Press the Command key and, while holding 
it down, press H for Home) 

o click the house icon that appears on most stacks 

o choose Message from the Go menu, type Go Home, and press 
return. 

All these methods work equally well. 
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Field tool 

Browse tool 

HyperCard has two kinds of text: Paint text and regular text. You 
create Paint text using the Paint Text tool; you'll find details about it 
in Chapter 6. This chapter covers regular text. 

Creating regular text in HyperCard is a two-step process: 

1 . Use the Field tool to create the fields where text goes. 

2 . Use the Browse tool to type text into a specific field. 

•:• Watch your preference level: To edit text in a field, you must be 
at the Typing level or higher on the User Preferences card in the 
Home stack. To create or change a field, you must be at 
Authoring level or higher. 

In the section "Fields," you'll learn about the places where you type 
regular text. The section called "Creating Text" tells you about 
entering and editing text, and how to move it from one place in 
HyperCard to another. 

Fields 
Fields are the boxes in which you type text. You can create 
background fields and card fields. A background field appears on 
every card associated with a given background. It has the same size, 
shape, and position on every card; what changes from card to card 
is the text in a field. Fields can be empty in one card, but have text 
in another. A card field appears only on the card where you create 
it (although you can copy a card field, and then paste it onto any 
other card). 
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No card field on this card. ----------- ---

Background fields are ------~~----------­
common to a number 
of cards. 

Card fields appear only --------------~-----------~ 
on a specific card. 

Figure 4-1 
Different kinds of fields 

You can have as many fields on a card or background as will fit. 
Fields can overlap one another to any depth. 

•!• Text can overlap, too: When fields overlap, the text within the 
fields can also overlap if some of the fields are transparent. 
Although you can create some interesting special effects this 
way, you can also create quite an aesthetic mess. When you 
overlap background fields and card fields, be sure to go through 
each card associated with the background after you've entered 
text to make sure things look the way they should. 
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Move pointer here 
and click. 

Creating fields 

You create fields by using the Field tool in the Tools menu. 

D 

tJ d ·-,_ 

@DD 
1<') 0 (~J 

AO CT 

Figure 4-2 
Field tool in Tools menu 

• To create a field: 

start where you want. ------

Drag diagonally 
to create a field . 

1. Move to the card where you want the field to appear. 

2. To create a background field, choose Background from the 
Edit menu. 

3. Choose New Field from the Objects menu. 

A new field appears in the center of the screen. Alternatively, 
move the pointer where you want the field to start; then press the 
Command key and drag. (See Figure 4-3.) 

4. Choose Field Info from the Objects menu and make selections 
as appropriate in the Fields dialog box. 

The Fields dialog box is described in detail later in this chapter. 

5. Size the field appropriately. 

' - -
' 

See "Changing a Field's Size," later in this section. As you drag, a 
dotted rectangle appears showing you how wide and how long the 
field is; the lines in the rectangle show where the bottom of each 
line of text will be. 

The field pointer _____________ _._j 

is a crosshair. Figure 4-3 
Creating a new field by dragging 
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The dotted lines go away when you choose another tool. The top­
left and bottom-right corners define the size of the field; the lines 
going across show you the text lines within the field. 

•!• Changing line spacing: You can change the amount of spacing 
between lines by changing the number in the Height box of the 
Text Style dialog box. See "Setting Text Properties," later in this 
chapter. 

Important The most common mistake In creating a field Is putting It on a 
card when it's supposed to be on a background. After you've 
created one or more fields, flip to the next card; if the fields 
you've just created are on that card too, you've created 
background fields. 

Placing and moving fields 

You can place a field wherever you want, including on top of 
another field. 

• To move a field: 

1. Select the Field tool from the Tools menu. 

The Field tool appears highlighted in the Tools menu, showing 
you that it's selected. 

2. Ciiek Inside the fleld you want to move to select It. 

The field becomes surrounded by dotted lines to show it's 
selected. 

3. Drag the field by Its middle. 

When the field is where you want it, release the mouse button. When 
you move a field, any text you've typed moves with it. HyperCard 
won't let you move any part of the field off the card. 
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Changing a field's size 
You can change a field's size whether or not it has text in it. When 
you change its size, any text in it wraps appropriately to conform 
to the new size. If you shrink the size of a non-scrolling field such 
that there's not enough room for all the text, text typed toward the 
bottom of the field becomes invisible. (It's still there, though; if 
you enlarge the field, the text becomes visible again.) 
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'·· 11j 1·.:11·:.er·=: t1·1en 

Figure 4-4 
Changing a field's size 

Narrow field shows 
wrapped text. 
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Changing the size or shape of a background field changes it on every 
associated card. 

• To change a field's size: 

1 . Sel1~ct the Field tool. 

2. Click Inside the field to select It. 

The selected field is surrounded by dotted lines. 

3. Drag the field from one of its corners. 

You'll probably want to look through any cards affected by the field 
change to see how the text looks. 
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Deleting a field 
You can delete a field whether or not it has text in it. 

• To delete a field: 

1. Select the Field tool from the Tools menu. 

2. Click inside the field to select it. 

3. Choose Cut Field from the Edit menu. 

Choose Clear Field to eliminate the field without affecting the 
Clipboard (or press the Backspace or Clear key) . 

Warning When you delete a field, you delete all its text along with it. 
Nothing goes onto the Clipboard; it is all simply eliminated. 
When you delete a background field, you irrevocably delete 
text associated with that field in every card on which the field 
appears. You cannot recover the lost text by choosing Undo 
from the Edit menu. 

Moving between fields 
Knowing the position of a field on a card can be difficult 
sometimes. Depending on the field style you've selected, empty 
fields can be invisible when any tool other than the Field tool is 
selected (although any text in them will still show). 

• To move from one field to another in order to type text: 

1. Select the Browse tool from the Tools menu. 

2. Press the Tab key until you get to the field you want. 

HyperCard first tabs through the background fields and then tabs 
through the card fields of the current card. 

When you click in a text-filled area of a field, the insertion point 
appears wherever you click. When you dick in an empty area of a 
field, the insertion point appears at the start of that empty line. 
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Tabbing goes from here ... 

... to here ... 

Tab o,rder and layers 

Pressing the Tab key moves the insertion point to the field with the 
next higher field number. 

Initially, field numbers are in creation order. The first field created 
gets the number 1, the second field .gets the number 2, and so on. 
(A pasted field is treated as a newly created field, no matter what its 
number on the card or background from which it was copied or 
cut.) If the insertion point is in field number 3 and you press Tab, 
the insertion point moves to field number 4; if there are only three 
fields, the insertion point moves from field 3 to field 1. 

Field #1 .. _____ .,. ... and finally back to here. 

~---; Feld #2 

_l 
Field #3 

... to here ... 
('--< 

Figum 4-5 
Tab order 

The fayer is the order of the field relative to other fields on the 
same card and background. When the visible card and background 
have multiple fields, fields can lay over each other; the field created 
most recently is ordinarily the topmost field, said to be on the front 
layer. In Figure 4-5, field 1 is on the layer farthest away (or, if you 
prefer, in the back), field 2 is closer, and the highest numbered 
field, field 3, is on the frontmost layer. The lowest numbered field is 
always farthest away; the highest numbered field is always on the 
frontmost layer (or in front). In fact, you can think of the field 
number as being the field's layer number. 

• To see a field's number: 

1. Sellect the Field tool from the Tools menu. 

2. Click Inside the field whose number you want to see. 

3. Choose Field Info In the Object menu. 

Alternatively, just double-click in the field. 
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Field Name: ~I ~~!iiiiiiiiiilJ 
Bkgnd field number 

This determines tabbing order . -----"+-------~ 
Bkgnd field ID: 7 

OLockTeHt 

0 Show Lines 

0 Wide Margins 

Font ... 

Script ... 

Figure 4-6 

Style: 

(_·-. transparent 

C", opaque 

c' rec tangle 
C shadow 

'!. scrolling 

n OK u (Cancel :1 

Field number, Initially determined by creation order 

Changing field tab order 

You can change the tab order among background or card fields by 
changing the field's layer. (Figure 4-5 in the preceding section 
illustrates layers.) 

• To change a field's layer: 

1. Select the Field tool from the Tools menu. 

2. Click inside the field whose layer you want to change. 

3. Choose Bring Closer or Send Farther from the Objects menu. 

Each time you choose Bring Closer, the field gets closer to being 
the frontmost layer (with a correspondingly higher field number); 
each time you choose Send Farther, the field moves to a farther 
layer (with a correspondingly lower number) . And as the layer 
order changes, so does the tab order. 

Duplicating a field 

Duplicating a field makes an exact copy of the field (but it doesn't 
copy the text in the field). 

• To duplicate a field: 

1. Select the Field tool from the Tools menu. 

2. Select a field by clicking inside it. 

A doued line surrounds the field, showing that it's selected. 

3. Choose Copy Field from the Edit menu. 
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4. Choose Paste Field from the Edit menu. 

A copy of the selected field is created, laying on top of the 
original. You need to drag the new field to where you want it. 

5. Drag from within the new field. 

•:• Duplicating afield doesn't copy text: When you duplicate a 
field, you don't duplicate the field's text with it. To copy both a 
field and the field's text: First copy the field; then copy the text 
and paste it to the new field. 

Field names 
Each field can have a name associated with it. You use field names 
mostly for advanced HyperCard features such as constructing 
scripts. 

A field name can have any number of characters in it. You can use 
any character in a field's name. 

• To name a field: 

1. Select the Field tool from the Tools menu. 

2. Select the field you want to work with by clicking Inside It. 

3. Choose Field Info from the Objects menu (or just double-click 
the' field). 

The dialog box in Figure 4-7 appears. 

4. Type or change the field's name; then press OK. 

Type the name you want ---------~ 
for this field. (You can 
change it any time 
you want.) 

Figure 4-7 
Naming a field 
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•!• Script writers take note: If you change the name of a field, be 
sure also to change its name everywhere else you refer to it. For 
example, if you rename a field "Wrigley" and you use the old 
name "Chester" in a script, the script won't work properly-it 
won't be able to find the field it needs. 

Field styles 
Fields can have five styles: transparent, opaque, rectangle, shadow, 
or scrolling. You choose the style of .a field by choosing an option 
in the Field Info dialog box. (See Figure 4-8.) 

•:• About scrolling: Scrolling adds a vertical scroll bar to the 
selected field. You view text in a field with a scroll bar as you do 
text in any scrollable Macintosh window. See the guide that came 
with your computer for details. 

k TrHI 

1 nb 

0 1 

Choose one of these _________ t_o __ L•_n_e_~-----1 
styles for your field. U11de "111 q,ns 

I .. 

( 11pt... 

Figure 4-8 
Choosing a field style 

You can change a field's style even after you've typed text into the 
field. Just repeat the steps you used to choose the original style. 
Figure 4-9 shows examples of field styles. 
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Figure 4-9 
Field styles 

Scrolling field 

If you don't choose a style, HyperCard uses Transparent 

Lock Text 
Lock Text protects the text in a field from being changed. When you 
check this option on the Field Info dialog box for a selected field, 
text within the field cannot be altered in any way. ('The pointer 
doesn't change to an I-beam when it passes over a locked field.) 

To unlock a field (and to allow its text to be altered), uncheck Lock 
Text. 

Wide Margins and Show Lines 

Wide Margins and Show Lines are options you can check in the Field 
Info dialog box for a selected field. These options give you more 
control over the look of your text fields. Wide Margins, which works 
best when the field has a rectangle or shadow style, leaves more 
space in the right and left margins. (As a result, text takes up more 
space.) 
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These fields are the same size. -
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Figure 4-10 
Wide Margins 

Shadow field, 
wide margins 

Shadow field, 
no wide margins 

Show Lines lets you see where lines are as you type in text. Later, you 
can click Show Lines again to hide the lines. 

Show Lines In a shadowed 
field with wide margins 
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Figure 4-11 
Show Lines 

Creating regular text 

Show Lines in an opaque field 
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Regular text goes inside fields that you've created. To create text, 
first you use the Browse tool to set the insertion point inside the field 
you want; and then you type. 
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Select the Browse tool ----­
to start typing text. 

;J 'I 

Browse tool 

Figure 4-12 
Selecting the Browse tool 

Important Use the Browse tool, not the Paint Text tool, for entering text in 
fields. Regular text is always editable in an unlocked field; Paint 
text. however, Is not editable once you have typed It and 
clicked the mouse button. 

Entering text 
You use the keyboard to enter text in HyperCard. You must create a 
field before you can type text. (See "Creating a Field," earlier in this 
chapter.) 

• To enter text in a field: 

1. SelE1ct the Browse tool from the Tools menu. 

2. Click In the field where you want to type. 

(The insertion point appears at the left edge of the line you 
clicked on.) 

3. Click where you want the new text to start. 

Or select the text you want to replace. 

4. Start typing. 

Your new text is inserted at the insertion point, or replaces the 
selected text. 

Warning When you tab to a field that already contains text, all the text 
Is selected. Typing at this point will wipe out all the old text in 
the field, and replace it with what you type. To preserve the 
old text. move the pointer where you want to begin typing. 
and click. 
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Fields without text in them are sometimes invisible; unless you tab 
to a field, or you want to type in a field that already has some text in 
it, you'll have to estimate the field's position (or choose the Field 
tool to see where all the fields are). 

If you type more text than will fit in a non-scrolling field, the 
remaining text goes off the bottom of the field . But this invisible text 
isn't lost, it's just hidden. To see the hidden text, make the field 
bigger. 

, t Jeer 1 ~ 
t<1l nq ti e 

' f r "18 PlZ"J 

r J' al 

Text goes beyond the --------~ 
bottom of the field 
and is hidden. 

Same text in the same field , --------------~ 

but with the field size extended. 

Figure 4-13 
Revealing hidden text 

Moving and copying text 

You can move and copy text from one part of a field to another, or 
from one field to any other field anywhere in HyperCard. 

You use the same cut-and-paste techniques for moving and copying 
text in HyperCard as you use in all Macintosh applications. See your 
owner's guide for details. 

•!• Uneditable text: If you can't edit text, check the Field Info dialog 
box for that field to see if Lock Text is checked. If the field is 
unlocked, or if the text exists outside of a field, you're dealing 
with Paint text. To change Paint text, you must erase the old text 
and create new text. 
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Setting text properties 

You can determine how the text in each field looks by using the Text 
Style dialog box. 

• To set text properties: 

1. Select the field you want to work with by clicking Inside It. 

Either the Browse tool or the Field tool must be active. 

2. Choose Text Style from the Edit menu. 

The dialog box in Figure 4-14 appears. 

3. Set the properties as you prefer. 

You can set font, size, style, alignment, and line spacing Oine 
height). 

4. Cllc:k OK. 

Scroll to the font you want; - ------ ---------­
then click to select it. 

Style 

0Bold 
D Italic 
D Underline 

Check one or more styles ------m D Outline 
for all the text in a field D Shadow 
(or check nothing for plain text). D condense 

D Eutend 

The alignment you set -------++­
works on all lines in the 
same field. 

Align 

()Center 
'.- Right 

Chic ago 
Courier 
.. i 

HelL•etic a 
Monaco 
New York 
Times 

What you see ls --------------------~ 
what you'll get. 

Figure 4-1 4 
Text S1yle dialog box 

Click the size you want ... 

...or type It here. 

Line 

---, Height 

mm~~ 

This determines the space 
be1ween lines. in points. 

Important The properties you set affect all the text within a field. You 
cannot. for example. make a single word bold unless it's the 
only word in the field. 
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Font 

You can use any font that's on your startup disk. You can see all the 
available fonts by scrolling through the list at the bottom of the Text 
Style dialog box. The font of the text you've selected is highlighted. 

• To change the font, just cllck the one you want. 

A sample of what your text will look like appears in a box at the 
lower right. When you've finished with the Text Properties dialog 
box and click OK, the selected text appears in the new font. 

• To return to your work quickly, double-click the font you 
want. 

The dialog box closes immediately, and the selected text appears 
with all the properties you've set. 

Style 

Text can appear in bold, italic, underline, outline, shadow, or a 
combination of any or all of these. If the field you've selected has 
text in any style besides plain, the appropriate boxes are checked. 

• To choose a style, cllck the appropriate check box or boxes 
In the Text Style dialog box. 

An X appears in each box you've clicked. 

• To cancel a style choice, click In the check box again. 

The X goes away. 

A sample of what your text will look like appears in a box at the lower 
right. When you've finished with the Text Styles dialog box, click 
OK; the text appears in the new style. 

All text in a given field has the same style or styles. 

Align 

You can set the text in a field to align to the left side of the field, to 
the right, or to be centered within the field. The same alignment 
setting works for all lines within a field; you can't set each line 
separately. 
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Point Is a printer's term; one 
point Is equal to about 1/72 of 
an Inch. 

• To change the alignment, click the appropriate button. 

A black dot shows in the button you've clicked 

When you click the OK box and go back to your work, the text will be 
aligned properly. 

Size 

The box marked Size shows the size of the text in the field you've 
selected. The number you see is the text's size in points. Each 
point is a single dot on the Macintosh screen. 

+ Preset size and style: When you start HyperCard, the preset size 
and style is 12 point plain Geneva. The changes you make to size 
and/or style remain in effect for all fields you create until you 
change them or until you leave HyperCard. When you enter a 
field you've already created, any new text takes on the size and 
style of the rest of that field. 

When you click a font name in the Text Style dialog box, all the sizes 
that you have in the System ftle for that font come up in the 
scrollable window to the right of the font list; the closest one to the 
actual size of the text in the active field is highlighted. (If you haven't 
clicked on a font, the size you see is the size of the text in the active 
field.) The highlighted size also appears in the Size box. 

• To use a size other than the one highlighted, scroll to the 
size you want and click It. 

• To use a size not listed, replace the number In the Size box 
with the size you want. 

First select the old size by dragging across it in the size box; then 
type the new one. 

The highlighted size is the one that's closest to the actual size of the 
text in the active field. 

Height 

Height is the space allowed for each line in a field, expressed in 
points. The number you see in the Height box of the Text Style 
dialog box includes space for the height of the characters and the 
space between lines, plus a couple of points for slack. HyperCard 
sets this number automatically when the font size changes; but you 
can set it by typing whatever number you want 
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• To change Height, replace the number In the Height box 
with a new number. 

First select the old number by dragging across it; then type the 
new one. The new number replaces the old one. 

•To make lines touch or overlap, set the Height size lower 
than the Font size. 

The exact number varies from font to font; experiment until you 
get the effect you want. 

•!• Top line can get chopped: You might lose some of the top line if 
you set the Height size below the Font size. 

Summary 
In this chapter you learned about fields and text in HyperCard. You 
saw (among other things) that 

o all regular text appears in fields 

o you create fields using the Field tool 

o you can create fields both on a background and on a card 

o fields can be enlarged or made smaller, moved, copied, cut, 
deleted, and pasted 

o you enter text into fields using the Browse tool 

o you can move, copy, cut, delete, and paste text 

o all text within a field shares the same properties-font, size, 
style, alignment, and line spacing 

Chapter 6 has more details about text and fields. See especially 
"Print Report" for information on printing text in fields, and "Field 
Info" to read about protecting a field's text from being changed. 
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This chapter presents an overview of HyperCard's graphic elements 
and shows how the different elements can work together. (Chapter 6 
tells you what tools and commands you have at your disposal for 
creating pictures.) 

o "Menu Commands You Use With Graphics" provides a brief 
frame of reference for using the Paint commands in different 
menus to produce a finished picture. 

o "Power Keys" gives details on special states and commands you 
execute from the keyboard. 

o "Double-Clicking Paint Tools" summarizes what happens when 
you double-click on certain tools. 

o "Dragging With Modifier Keys" lists the effects of pressing 
Command, Option, or Shift while you drag with different Paint 
tools selected. 

o "Special Effects" shows what happens when you combine several 
features. 

o "Importing Pictures" suggests ways to bring pictures into 
HyperCard from outside sources. 

Menu commands you use with graphics 
To make finished pictures in HyperCard, you use commands from 
several menus. 

o To create the basic picture elements-shapes, patterns, 
contours-use the tools on the Tools menu and the patterns on 
the Pattern menu. 

o To borrow pictures from cards that already exist in the current or 
other stacks, use the Copy and Paste commands from the Edit 
menu. 

o To bring in a picture you created someplace else using 
MacPaint® or a MacPaint-compatible application, or that you 
brought into the computer using a digitizing camera, scanner, 
or some other peripheral device, use the Import command 
from the File menu. (You can also bring in pictures through 
the Clipboard and the Scrapbook.) 

o To create a picture common to several cards, use the Background 
command. 

o To manipulate the picture and to do finish work-rotate parts of 
it, bring up FatBits, and so on-use the commands in the Paint 
menu. 
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Power keys 
When you choose Power Keys from the Options menu, striking a 
single key does the work of selecting a specific menu command. 

The Options menu is visible only when you've selected a Paint tool. 

Table 5-1 shows a list of menu commands and their power-key 
equivalents. (Each of these commands is described in detail in 
Chapter 6 .) 

Table 5-1 
Power keys 

Command Key Menu 

Darken D Paint 
Draw Centered (on/ ofO c Options 
Draw Multiple (on/om M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (on/ ofO G Options 
Invert Paint 
Lighten L Paint 
Line size 1-4, 6, 8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate Left [ Paint 
Rotate Right I Paint 
Select s Paint 
Select All A Paint 
Select black pattern B Patterns 
Select white pattern w Patterns 
Trace Edges E Paint 
Transparent T Paint 

Listed next are descriptions of a few power keys that need special 
mention. 
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Power key P: Making a graphic cookie cutter 

Power key P chooses the Pickup command in the Paint menu. It 
works like a cookie cutter. You drag a source image (the cookie 
cutter) over the image whose pattern you want to pick up (the cookie 
dough). HyperCard uses the outline of the source image as the 
cookie cutter. Pressing power key Pis like pushing the cutter into the 
dough-when you drag the cutter away again, it's converted to the 
pattern you moved it over. 

l . This Is the shape with 
the pattern you want 
to change . 

• 
. 
. 

' 

3. Select the shape and 
move It over the pattern. 

~ 
j I 
j I 

·~ ~ 
5. Drag the shape away. 

Figure 5-1 

• 
. . . . . . . 
. 

' 
2. This is the pattern 

you want to use. 

4. Choose Pickup (or just 
press P if power keys 
are active). 

Source Image picks up pattern of overlaid image 

Power key S: Tightening the selection 

Power key S lets you lasso a picture that you've already selected with 
the Selection tool. You can also press S to select an area you've just 
drawn (or even erased) with another tool; once selected, you can 
move it or fill it, or do whatever else you want with it. 
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Use the Selection tool 
to grab the general area ... 

.. . press power key S to separate 
the graphic wheat from the chaff. 

Figure 5-2 
Refining a selection 

Power key S is especially useful when you want to select a specific 
area quickly with no white space, or if your hand isn't steady enough 
to use the Lasso tool with precision. 

Power key T: Turning a graphic transparent 

Ordinarily when you draw or paste a graphic onto a card, the 
graphic is opaque-that is, it totally covers what it's drawn or pasted 
over. Pressing power key T makes the graphic transparent so that 
what it covers shows through. 

Pasted opaque ----------,----/~ 
(default choice) ~--r 

;/Jr 
Pasted with pattern. --------,--- ----../ 
then power key T pressed 

Figure 5-3 
Opaque and transparent images 
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Doul:)le-clicking Paint tools 
Double-clicking on certain Paint tools enhances using those tools. 
Here's a list of the tools and what double-clicking does. (Chapter 6 
tells you what each tool is for, and how to use it.) 

Table !)-2 
Effects of double-clicking Paint tools 

Double··cllck ... 

Any pattern 
Brush 
Bucket 
Curve 
Eraser 
Lasso 

Lines 
Oval 
Paint Text 

Pencil 
Polygon 
Regular Polygon 
Rectangle 
Rounded Rectangle 
Selection 
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Effect 

Bring up pattern editing dialog box 
Bring up Brush Shapes dialog box 
Hide/show pattern menu 
Toggle Draw Filled command 
Erase whole picture 
Lasso every element in a picture 

Bring up line/border thickness dialog box 
Toggle Draw Filled command 
Bring up Text Style dialog box 

Set/cancel FatBits 
Toggle Draw Filled command 
Bring up shape selection dialog box 
Toggle Draw Filled command 
Toggle Draw Filled command 
Select whole picture 



Table 5-3 

Dragging with modifier keys 
Dragging with different tools selected has different effects, 
especially if you're pressing Command, Shift, or Option at the 
same time. Table 5-3 shows you what happens. Tools that aren't 
listed aren't affected by modifiers at all. 

Effects of modified dragging 

Tool Command Shift Option 

Selection Select tightly Move selection horizontal or vertical Copy selection 
Lasso Lasso everything Move selection horizontal or vertical Copy selection 
Line No effect Draw at multiples of 15° angles Draw with pattern 

Eraser Erase in white Erase straight horizontal or vertical No effect 

Pencil Get/leave FatBits Draw straight horizontal or vertical No effect 

Rectangle No effect Draw square Patterned border 

Curve No effect No effect Patterned border 

Brush Erase what you Paint straight horizontal or vertical No effect 
paint over 

Spray Erase what you Spray straight horizontal or vertical No effect 
spray over 

Rounded Rectangle No effect Draw square with round corners Patterned border 
Polygon No effect Draw at multiples of 15° angles Draw with pattern 

Oval No effect Draw circle Patterned border 

Regular Polygon No effect Rotate in 15° increments Patterned border 
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Special effects 
In many cases, holding modifier keys down in combination with 
choices from the Options menu makes combinations of effects. 
Experiment with different combinations to see what happens. 
(Figure 5-4 shows some examples.) 

Select a part of a picture. 

Draw Multiple 
and Draw Filled 

Draw Multiple. 
Grid on 

Figure 5-4 
Speciol effects 
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Use Command-Shift-Option-Drag 
with Grid checked In the Options menu 
to enlarge or shrink the selection 
keeping the pattern consistent. 

'--- -

Draw Multiple. with 
Rectangle. Grid on 

I/// 
~------

Draw Multiple with 
Line tool. Shift key 
held down 

Draw Multiple with 
Circle tool. Grid and 
Draw Center on. Shift 
key held down 

Draw Multiple with 
Line tool. Grid on 



Importing pictures 
There are many products that create pictures compatible with 
MacPaint. Some products let you create MacPaint pictures from 
scratch, others let you digitize images using a video camera 
attached directly to the Macintosh, and still others connect to the 
Macintosh through an ImageWriter® printer. However you create 
it, you can bring any MacPaint picture into HyperCard using the 
Import Paint command on the File menu. Once you've imported a 
picture, you can treat it as if you had created the imported image in 
HyperCard. 

•:• Try the Clipboard: Sometimes you might want to bring a non­
MacPaint picture into HyperCard-for example, something you 
create using MacDraw or a similar application. Try copying the 
picture to the Clipboard or to the Scrapbook first; then paste into 
a HyperCard card. 

Figure 5-5 
Imported digitized Image 

•:• Built-in screen shooter: To take a quick snapshot of the screen in 
nearly any Macintosh application, press Command-Shift-3. This 
keyboard command, built into your Macintosh's System file, 
stores a picture of the screen on disk under the name SCREEN n, 
where n is a digit from 0 through 9. (When you already have all 10 
digits used, your Macintosh beeps and you can't save more 
pictures until you rename or erase some.) 
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Summary 
In this chapter you saw how HyperCard's graphic elements work 
together. You learned 

o which menu commands to use to perform specific tasks 

o how to use power keys instead of menu commands to perform 
certain functions, and about the unique effects of certain power 
keys 

o the effects of double-clicking Paint tools 

o the effects of dragging with different Paint tools selected 

o the special effects that happen when you combine different 
elements 

Chapter 6 gives details for using all the Paint tools in the sections 
called "Tools," "Paint," and "Options." 
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This chapter gives detailed descriptions of each command on all 
the HyperCard menus. You can also find information on 
commands in the Menus section of the on-line Help system. 

•:• General versus Paint tools: Throughout this chapter you'll see 
references to General tools and Paint tools. General tools are 
those tools that appear on the first row of the Tools menu; use 
them for general HyperCard tasks (browsing, creating buttons 
and fields, entering text). Paint tools are all the other tools on 
the menu; use them to create and edit pictures. For details, see 
"Tools menu" later in this chapter. 

lio lm!Jl'I Pilint 

General tools ----------1f'? o 0 

Paint tools - - ---------i 

._, p fl 
gg--..... 
~DD 

~Ov 
AOCT 

Figure 6-1 
General and Paint tools 

Menu items are described in the order that they would appear if 
Scripting was checked in the User Preferences card of the Home 
stack. (See "User Preferences" in Chapter 3.) 

File rnenu 
The File menu holds commands that save information to, or 
retrieve information from, a disk. You can choose any command 
on the file menu while you're using a General tool (that is, any of the 
tools on the top row of the Tools menu); while you're using a Paint 
tool, you can choose only Import Paint, Export Paint, or Quit 
HyperCard. 
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The different File menus 
The level set on the User Preferences card of the Home stack, in 
conjunction with the protection level set for a particular stack, 
determines which menu appears when you press File. If either level 
is set to Browsing or Typing, you choose a command from the short 
menu (far left in Figure 6-2). Otherwise you choose from the full 
menu (middle in Figure 6-2). While you're using a Paint tool, you 
can choose only Import Paint, Export Paint, or Quit HyperCard 
(far right in Figure 6-2) no matter how high your level is. 

New Stack ... 
Open Stack... )f:O 
SaL•e a f opy ... 

Page Setup ... 
Print ( ard :tf P 
Print Stack .. . 
Print Report .. . 

Quit Hyper( ard :)fQ 

Browsing and Typing 

Figure 6-2 
Fiie menus 

:t~.i: 
New Stilck 
Open Stilfk ... #() 

SaL•e a f OPlJ ... 

Compart \tilck 
Protect Slark ... 
Delete Slark ... 

Page Setup ... 
Print Cat d WI' 

Print Stack ... 
Print Repot I ... 

Qutt HyperC at d #fl 

Painting. Authoring. 
Scripting 

Import Paint .. . 
EKport Paint .. . 

! Quit Hyper( ard "0 

Paint tool selected 

For information on user levels, see "User Preferences" in 
Chapter 3. For information on individual stack protection, 
see "Protect Stack" elsewhere in this chapter. 

See "Tools Menu" later in this chapter for a description of the tools. 

Important HyperCard has no Save command. HyperCard automatically 
saves what you create whenever you switch from one card to 
another. To save your stack under a different name, use the 
Save A Copy command. 
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New Stack ... 

New Staclc puts away the current staclc (making sure that all the work 
you've done is saved) and creates a new one. 

When you choose this command, HyperCard puts up a Directory 
dialog box and asks you to name the new staclc: 

ij =--~--- . --. ---. !j .-Cc~Hype1la1d\tark<,I 

II 

11 

II 
I ;j -------

::-:.·Har po 

I_ _ll r H:'_E'__j 

NPtll 

: ! Sr1101<" I I ,;111 »I 

'I ~.-. !11 \ {d( k llrHJ)P: 

You use the old stack's -----....,.•r--'·: 1 "Pll r u111·11t t1.11kqr011rH1 ' 

design for the new stack _______ ---_--------.,----,-~ 
If this box Is checked. 

86 

Figure 6-3 
Naming a stack 

If you cliclc New with the box next to "Copy current baclcground" 
checked, HyperCard creates a new stack with the baclcground fields, 
baclcground picture, and baclcground buttons (including all actions) 
of the last viewed card in the previous stack. If "Copy current 
background" is uncheclced, the new stack is blank. 

To choose this command you must be using a General tool. 

Open Stack ... 

Open Stack (or Command-0) opens an existing staclc for your use. 
This command brings up the Directory dialog box and waits for you 
to select a staclc. When you've made your selection, HyperCard 
closes the stack you were working with and saves any changes you 
made; then it gets the stack you asked for. The ftrst card in the 
summoned staclc appears on the screen. 
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•:• An open Stack alternative: You can also open a stack by typing 
Go stack name into the Message box and pressing either Return 
or Enter. (You get the Message box by choosing Message from 
the Go menu.) For example, to get to the Art Ideas stack, type Go 
Art Ideas and press Return. 

To choose this command you must be using a General tool. 

•!• Where the stacks are: If HyperCard can't find a stack, it will ask 
you to tell it where it is. If the stack is on a 3.5-inch disk, you'll 
need to insert the disk into one of your drives. Stacks that come 
with HyperCard are scattered among the HyperCard disks. See 
Appendix B for a listing. 

Save a Copy ... 
Save a Copy saves a copy of the stack you're working on under a 
new name. (You continue to work on the original stack.) Use it to 
preserve a stack in its unchanged condition while you experiment 
with new variations. 

----

' i :~_;,; '-. p 

Figure 6-4 
Saving a stack under a different name 

HyperCard presets the name of the copy to "Copy of (original 
stack name)." (The name is automatically selected; to change it, 
just type the new name.) 

To choose this command you must be using a General tool. 
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Import Paint 
Import Paint (available only when a Paint tool is selected) gets a 
copy of a MacPaint-compatible document from the disk and pastes 
it onto the current card. 

When you choose Import Paint, the directory dialog box appears so 
you can select a document using the hierarchical file system. 
HyperCard pastes the imported document, starting at the imported 
document's upper-left corner, onto the card. 

•:• Some picture prepping: You might want to do some preparation 
work on a document before you import it Make sure the part of 
the document you want to paste is in the document's upper-left 
corner before you bring it into HyperCard. 0l ou can't scroll 
documents in HyperCard). 

For complete information on graphics in HyperCard, see "Paint 
Menu," "Tools Menu" and "Pattern Menu" later in this chapter, 
and Chapter 5, "Graphics in HyperCard." 

Export Paint 
The Export Paint command (available only when a Paint tool is 
selected) takes a snapshot of the current card and saves the snapshot 
as a MacPaint document. 

Export Paint creates a MacPaint document from the card on the 
screen and saves it to disk under the name you give it. The image of 
the full-sized card gets saved, even if you're using FatBits. If 
Background is checked in the Edit menu, just the background 
picture is saved. 

HyperCard exports only card and background information. If you 
have a tear-off menu on the screen, its image isn't included with the 
exported picture. 

You can't save buttons and actions using Export-you only save 
an image of what's on the screen (including images of buttons 
and text). 
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For complete information on graphics in HyperCard, see "Paint 
Menu," "Tool Menu" and "Pattern Menu" later in this chapter, and 
Chapter 5, "Graphics in HyperCard." 

•:• Quick exporting: To take a quick snapshot of everything on the 
screen (including the menu bar and any torn off menus), press 
Command-Shift-3. This keyboard command, built into your 
Macintosh's System file and available any time, saves a picture of 
the screen under the name SCREEN n, where n is a digit from 0 
through 9. (When you already have all 10 digits used, your 
Macintosh beeps; to make room for more, go to the Finder and 
rename or delete some of the snapshots.) You can use this 
shortcut in almost any Macintosh application, and later import 
the picture into HyperCard using the Import Paint command. 

Compact Stack 

This command (available only when Painting, Authoring, or 
Scripting is checked in the User Preferences card of the Home stack) 
gets rid of free space in a stack. Free space gets introduced into a 
stack each time you delete a card, background, field, or button; the 
more free space in a stack, the slower and larger the stacks. 

To see the amount of free space in a stack, look at the number 
following the words "Free in Stack" in the Stack Info dialog box. 
(Stack Info is an item in the Objects menu, available when 
Authoring or Scripting is checked on the User Preferences card.) 

To use this command, you must have a General tool selected. 

Protect Stack 
Protect Stack sets levels of protection for the information in, and 
design of, the current stack. Use it to keep your personal stacks 
private, or to limit the way people can use or change your stacks. 
Choosing this command brings up the dialog box in Figure 6-5. 
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Figure 6-5 
Protect Stack dialog box 

Can't delete stack 

When this box is checked, you can't delete the stack. 

Private Access 

When this box is checked, you must type the proper password (as 
determined by Set Password, below) before HyperCard lets you use 
the stack at all. 

Set Password 

Click this button to set or change a password. You set a password 
to restrict access to the Protect Stack dialog box (thus preventing 
unauthorized changes) or to restrict access to the stack. The dialog 
box in Figure 6-6 appears. 
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i. le LU PCISSUI( I h I 

Figure 6-6 
Password dialog box 

Type the password you want to use into the "new password" text box; 
then press Tab to move the insertion point to the "verify password" 
text box, and type the password again to verify it. 

Click None to cancel the password and to put the dialog box away. 

When you use the password later, it must match character-for­
character the one you set. (Uppercase and lowercase letters don't 
have to match.) 

The•e would motch OK. ------< 
Figure 6-7 
Matching and nonmatchlng characters 

When a password is set, you can't get to the Protect Stack dialog box 
without knowing the password. When Private Access is checked, you 
must know the password to use the stack at all. 

Warning There's no way to find out a password once it's been set. If you 
forget the password, you cannot get to the Protect Stack 
dialog box again. If you've checked Private Access and you 
forget your password, you won' t be able to use the stack again 
once you leave it. 
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Umit user level 

The box you check here limits the commands and tools a user can 
employ within the current stack. When a limit you set here conflicts 
with a limit set on the User Preferences card of the Home stack, the 
lower of the two levels takes precedence. (Browsing is the lowest 
level.) Table 6-1 shows the powers inherent in each level. 

Table 6-1 
Powers associated with each user level 

Browsing 

Typing 

Painting 

Authoring 

Scripting 

Short File and Edit menus (Figure 6-8), plus 
the Go menu. Use of the Browse tool. 

Same as Browsing, plus ability to edit text in 
existing fields. 

Same as Typing, plus full File and Edit menus 
(Figure 6-8), Tools menu (plus Paint, Options, 
and Pattern menus when a Paint tool is 
selected), use of all Paint tools (but not Button 
and Field tools), Power Keys option. 

Same as Painting, plus Objects menu, use of 
Button and Field tools. 

Same as Authoring, plus ability to write and 
edit scripts. 
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Browsing and Typing get short menus. 

Figure 6-8 
Short and full File and Edit menus 
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~'' __ J) -File menu 

Important When you restrict a user's level to Browsing or Typing. Protect 
Stack doesn't appear on the File menu. (See far left, Figure 6-8.) 
To get a full File menu no matter what the user level Is set to 
(either In Protect Stack or on the User Preference card). hold 
down the Command key before you drag through the File menu. 

•!• Card and background protection: You can also protect each 
card or background individually by checking the proper box in 
the Card Info or Background Info dialog boxes. See "Card Info" 
and "Bkgnd Info" elsewhere in this chapter, for the details. 

Delete Stack 
Delete Stack (available only when Painting, Authoring, or Scripting 
is checked in the User Preferences card of the Home stack) removes 
all the cards, background pictures, background buttons, actions, 
and fields of the current stack. It's as though you had dragged the 
stack to the Trash in the Finder. Use it when you have no further use 
for a stack. 

HyperCard first asks you to confirm the deletion. After the stack is 
deleted, you end up at the Home card. (See "Home" in Chapter 3.) 

1987 
April 

Delete all 56 cards from stack 

Harpo:HyperCard Stacks:Datebook ? 

Febni; 
l':· 16 1? 1::: 19 .::i:r .:: l 

]\larch i 2 ,1 ,, ,, " 
,·, 9 1(1 11 1.::: 1 :: 1-1 

Figure 6-9 
Dialog box for deleting a stack 

Delete J ([ Cancel ~ 

10 11 1:2 1:: 1·1 1':· H' 
17 1::: 1'~ .::o .::1 .::.:: .:.;:: 

Tvlay 

i 2 " ' " June 
9 10 11 L; i:: 

To choose this command you must be using a General tool. 
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Landscape printing Icon 

Important 

Page Setup 
Page Setup lets you set paper size, orientation, and certain effects 
for printing. You see this dialog box: 

I 
,1 j ·,r:.i1;\·U!; ii. f'! 
I~=------

= ·. ~ i_,. ;.,'.~1on,::;l ~ c111:oi1: 

I;\ ii\ Hi'.' 1.__i: ' 

• 'I< 

., :i; 

.: COL-

Figure 6-10 
Page Setup dialog box 

•:• LaserWriter smoothing or flipping slows printing: If you're 
using an Apple LaserWriter® with Smoothing checked in the 
LaserWriter Page Setup dialog box, or with any of the flipping 
options checked, printing is slowed down considerably. Print 
a sample with Smoothing unchecked first to see if the results are 
acceptable. 

If you select the landscape printing Icon for horizontal printing 
on your LaserWrlter. be sure to choose Faster Laser Printing. If 
you don't. printing a stack will be extremely slow. 

•:• Some LaserWriter printing features don't work: The Reduce or 
Enlarge feature doesn't work for any printing in HyperCard. The 
Invert option works correctly only when Fast Laser Printing is 
turned off, but it takes an extremely long time to print 

To choose this command you must be using a General tool. 
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Print Card 
Print Card (or Command-P) prints the current card using the 
specifications you gave in Page Setup (except that cards are printed 
full size, no matter what reduction or enlargement you specify). Use 
it when you need a hard-copy version of any single card in any 
HyperCard stack. To print all the cards in a stack, use Print Stack 
(described immediately below). 

To choose this command you must be using a General tool. 

Print Stack ... 
Print Stack prints all the cards in the current stack in linear order. 
(With a LaserWriter, Print Stack prints the cards in reverse order so 
that the first card is on top of the pile in the output tray.) 

To choose this command you must be using a General tool. 

Print Stack brings up a dialog box. (See Figure 6-11.) 
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Figure 6-11 
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Print Stack dialog box 
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Manual paper feed 

Check the box labeled "Manual paper feed" if you're feeding the 
paper by hand; HyperCard will stop the printer after each sheet and 
wait for you to add more paper. 

Fast laser printing/Darker printing 

Check "Fast laser printing" on a LaserWriter printer to speed up 
hard-copy production. It's recommended for most printing jobs. 

Important If you select the landscape printing Icon In the Page Setup 
dialog box for horizontal printing on your Laserwrlter, be sure to 
check ·Fast laser printing: If you don't, printing a stack will be 
extremely slow. 

Check "Darker printing" on an Apple ImageWriter printer to print 
darker (useful if your ribbon is old). 

Click "No space between cards" to print cards close together (for 
printing two cards or more per page). 

Cards printed per page 

Click one of the four choices to determine how many cards are 
printed. per page. Look in the minipage window to see how many 
cards fit on a page. ('Ibe number varies with the options you've 
chosen.) 

Page formats 

"Standard format" and "Split-page format" determine how cards 
are spaced on a page when you print a stack. 

"Standard format" prints cards evenly spaced on the entire page. 
This choice leaves enough room on the left edge to put binder holes 
in the printout. 

"Split-page format" is for sheets that will be kept in a minibinder; it 
spaces cards so that the printed sheet can be folded down the 
middle without creasing any card's image. 
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standard format leaves room --­
for binder holes on the left side 
of the page. 

C!) Standard format 
()Split-page format 

Figure 6-12 

()Standard format 
(!,:.Split-page format 

Standard format and Split-page format 

Header 

Punch holes at top 
and bottom ... 

- ... and fold page on 
dotted line to 
prepare split-page 
printouts for 
mini-binders. 

Tab to the Header box and type what you want to appear as a 
heading at the top of each sheet. Click the proper icon(s) after you 
tab to add page numbers, the date, the current time, and/or the 
stack name to the header. Click icons in the order you want them to 
appear in the heading. (Use the space bar to separate them.) You 
can preview what the header will produce by looking in the 
minipage window. 

Format remembered 

Once you print a stack, HyperCard remembers the format and 
header you used for that stack so you can use the same setup next 
time you print. 
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Print Report 

Print Report gathers text out of fields from the cards in a stack and 
prints a report, using the design you specify in the Print Report 
dialog box. Use this command to get printed summaries of your 
stacks in a form most useful to you. 

To choose this command you must be using a General tool. 

•!• Reports are based on a single stack: Each report is based on 
information from a single stack. There is no way to combine 
information from two separate stacks into a single report. 

When you choose Print Report, the dialog box in Figure 6-13 
appears. 

You can print up to 99 copies -----------~ 

Click In here to feed sheets -----­
one at a time 

un 

k d . 
. al·ea-code · 
time z.one 

}·egion 

Click here to add page number, ---------\ 
time, date, and/or stack name / 

!O\:ations \. 

es of· 
I Ids 

What you type here goes ______ __,/ 
at the top of every page 

Figure 6-13 
Print Report dialog box 

You can print reports in three formats-labels, columns, or rows. 
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Table 6-2 

Here's a list of alternatives showing the various combinations of 
fields that can appear in your reports. (You can use only the last 
alternative for the column format.) 

o all card fields in the stack 

o all background fields in the stack 

o all background and all card fields in the entire stack 

o all card fields from cards with the current background 

o all card fields from cards with the current background, plus all or 
some of the current background fields 

o all or some fields from the current background 

To a print a report based on one of these alternatives, you must click 
buttons and check boxes on the Print Report dialog box in the 
proper combination. 

Table 6-2 shows you those combinations. 

Controlling the printout of a report 

To print ... 

All card fields in entire stack 

All background fields in entire stack 

All card fields & all background fields 
in entire stack 

All card fields of cards with current 
background 

•selected background fields of cards 
with current background 

Ciiek this radio button ... and ... Check only these boxes 

® In the entire stack ~ Card fields 

® In the entire stack ~ Background fields 

® In the entire stack L8:I Card fields 
~ Background fields 

® With the current background L8:I Card fields 

® With the current background ~ Selected background fields 

All card fields and selected background ® With the current background L8:I Card fields 
fields of cards with current background ~ Selected background fields 

*This is the only format available for printing in columns. 
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When you check "Selected background fields," you activate a 
selection box from which you select fields to print from the current 
background. 

• To select a field, click Its name. 

Use the Scroll bar to look through the list of field names. 

• To select more than one field, hold down the Shift key as you 
select each name. 

• To deselect a field, click Its name. 

• To deselect a field when more than one are selected, hold 
down the Shift key as you click. 

Field printing order 

The order in which you select fields determines their printing 
order. On labels, the first field you select goes on the top line of the 
label, the second field goes on the second line, and so on. In the 
column format, the order in which you select fields determines 
their left-to-right printing order. In the row format, the first field 
you select goes on the top line of the card block, the second field 
goes on the second line, and so on. 

Labels 

Clicking this button makes HyperCard print the fields you've 
selected in a format suitable for labels. Each label contains text 
from the fields of one card. HyperCard automatically centers the 
text in each label. 

You can change the number of labels per sheet and the size and 
spacing of the labels by dragging on the highlighted parts of the 
dialog box's minipage window. 

As you change the dimensions of labels by dragging in the 
minipage window, HyperCard shows you the maximum number of 
labels that will fa on a page. Changes you make in the position or 
size of the labels are reflected in the measurements at the bottom 
of the window; use the numbers that appear there as a guide. See 
Figure 6-14. 
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P1111t rep~rt . .. Cop1e\:ilM Ar dn 1e f1el1s m ([ OK J) 
"1anual paper feed • label 

( olum is 
( ancel ) 

Rows 

Drag here to change ----------~ Pr nl le>il fields from all cards. 
size of labels. In thP enti1e stack 

• lLI II' l'le current background 

IJJhH h f1 • ds: 
( a1 cl f elds 

~:· ~elec led background fields: 
Field name appears here. ------'----'-------------

Drag here to control number - - - ----=----- - ---­ J 
of labels on each sheet. plus 
the spacing between labels. 

01 r1ens10-is. rt: 0.0 ll 
• inches cm * J 0 ~ B 

J) J 0.0 

l 0.1111 
'· J 

Figure 6-14 
Print Report in label format 

If text on a line in a field is too wide for a label, HyperCard wraps the 
text onto the next line. If there are too many lines to fit on a label, 
HyperCard prints what will fit. 

•:• About LaserWriter labels: Only use labels made especially for 
LaserWriters or photocopiers. Check "Larger Print Area" under 
Options on the Page Setup dialog box for better centering of text 
on the labels that run along the left and right edges of the page. 

•!• About ImageWriter labels: Use labels that are on 8.5-by-11-inch 
tractor-feed pages. 

Columns 

In the column format, selected fields from the current background 
are printed side by side in vertical columns across the page. Each 
field has its own column. (See Figure 6-15.) 

Important You must have ·with the current background" checked for 
the column format to work. 

File menu 101 



If a column is too narrow for the entire contents of a field to fit on 
one line, HyperCard wraps the text to new lines as appropriate. 

HyperCard won't let you select more fields than will fit across the 
page. You can see how many will fit by looking at the minipage 
window. 

You c.an control the horizontal width of each column by dragging 
the dashed separation lines. 

If you check Cards under "Print the names of, n card names appear 
in their own column on the far left. If you check Fields, field names 
are printed across the top of the page above the appropriate 
column. If a column is too narrow for the entire field name to fit, 
the field name is truncated. 

Figure 6-15 
Print Report In column format 

Rows 

In the Row format, information from each card is printed as a 
block. Fields read vertically down the page for each card. 
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The 3 row layouts 

You can choose among three different layouts to determine the 
sequence of printing, and the amount of space across the page 
that's allocated to each block. 

If you click on the left layout, each field's information is printed 
across the width of the page, each field below the previous one. 
With the center and right layouts, HyperCard prints blocks of 
information for two cards side by side. (See Figure 6-16.) 

Drag here to change ---------­
printed field width . 

The numbers refer to card 
position in the stack 

Figure 6-16 
Print Report in row format 

The card sequence in which the information is printed depends on 
the layout order you select. If you select the layout order in the 
center, reports appear beneath each other in the left column until 
page bottom; The next card's report appears at the start of the right 
column. If you select the layout order on the right, the block reports 
alternate left-right down the page. (See Figures 6-17 and 6-18.) 

If you check Fields under "Print the names of' the name of each 
field is printed to the left of the field's contents. (If the field is 
empty, HyperCard skips it and doesn't print the field's name.) You 
can grab the vertical dotted line and drag it to adjust the width for 
the name. Card names are printed at the top of each card's block. 

Card blocks are printed in the order that the cards appear in the 
stack. 
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Card Nam.J· Card 1 
N3mE· and Address: Sieve Aaron 

2260 Oak Creek Drive 
Pt1on•3 Nu;nber 555. 7806 

DJ.le 2 123/87 

Card Narne. Card 2 
Namt:· and Ac!dress Katie Aict11er 

942d Middlefield Road 
Pl10n·:! Number 555-4844 
Dale· 2123157 

Card l\Jame Card 3 
:·.Jzirnt· and Address Manha 13e1ion 

8495 Jellerson SI 
f:>l10n1:-: Number 555·0934 
Dale 2123187 

C.ird Name· Card 4 

Card Name: 
Name and Address. 

Phone Number· 

Date 

Card Name 
Name and Address: 

Phone Number· 
Dale: 

Card Name: 
Name and Address 

Phone Number 
Date· 

Card10 
Emmetl Ccirdenas 
1919 Shon Slrnel 

555·8487 
2123187 

Card 11 
Joshua Carlson 
6291 Elliol Slreel 

555-3109 
2/23187 

Card12 
Karl Doly 
1964 Lundy Ln 
Chrisle. Texas 

(512) 555-8745 
2123187 

r'Jarnc· and i\ddress Marti Belisle Card Name: Card 13 
3703 Maude Ave Name and Address. Annelte Darling 

Pf1on1::? Number 555·8203 ,. .... , 400 Ohio Ave 
........... Date. 5,26187 .,.., ,...-,. ', Bristol. Pennsylvania ,,..,,,. 

............. ..,,,..;"' ..... ,, Pty ', (215) 555·0696 ,..._...,...,.., 
·~~!l cay ....... ..,../ ' 2123187 ...-""'""' 

"""i..dQ_ress. y ',, ,,,.,,." ', .,.. ........ -........ ,..... ... .... ,,,. ,,....,.. 

Figure 6-17 
Print report In row format, top to bottom order 

Card N~·nir: Card 1 
i'JJme and /\ddress Sieve Aaron 

2260 Oak Creek Drive 
f1hor.e Mumber 555· 7806 

DC1te 2123i87 

C~n:J /\.arne Card 3 
N;une .-incl Adc!r<~ss lv1aflha Belion 

8495 Jellerson St 
Pi~orie Nun1bcr 555·0934 

D::h~ 2123187 

Card 1'.,rnk! Ctud 5 
Nam1~ '."Hld 1\ddrt?Ss Hoger Benrey 

95-~ 1 Mot1nt Vernon Dr 
rt1onc Number 555·3005 
D.:it(' 2123/87 

CJrd i'..<Jrn,-: Card 7 
f'JJill(: ;mci t,cJclr.:-~ss Rictrnr~! Boyd .,. ....... 

Card Name Card 2 
Name and Address: Kalie A1ct1ler 

9•124 Middlefield Road 
Phone Number 555-4844 

Date 2123187 

Card Name· Card 4 
Name and Address Mar11 Belisle 

3703 Maude Ave 
Phone Number 555-8203 

Date 5126:87 

Card Name· CafCJ 6 
Name C!il(j AiJdres~~ Lowe0n l11~nk 

6686 M,1rtin Ave 
Prame. Texas 

Phone Number (214) 555-5-155 

2123187 

Card Name· Card8 
N:.irne lliid Address Sh;,nnon Brown•: 

......... 5686 Black h.4oupJ·" '· .... , 

......... ...,.~Q.~~nber 555-6080 r-./' '·...... Pf11)n1~ Nu~j.1l>I',......._....,, 555-1 7•35 ,,,,.~ .... ,,,,. .... 
.................. 2·23/~~_,. ... • .... ~ .......... I~-~~~~ ...... ·~· ' .. <:~i;~31a7 ,,..,,."" ---.... ~/ ·~."- ~ .... ,~~,~ 

Figure 6-18 
Print report In row format, left to right order 
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Manual paper feed 

Check the manual paper feed box if you're feeding paper by hand; 
HyperCard will stop the printer after each sheet and wait for you to 
add more paper. 

Header 

Tab to the Header box and type what you want to appear as a 
heading at the top of each sheet. Click the proper icon(s) after you 
tab to add page numbers, the date, the current time, and the stack 
name to the header. Click icons in the order you want them to 
appear in the heading. (Use the space bar to separate them.) You 
can preview what the header will produce by looking in the 
minipage window. 

Format remembered 

Once you print a report, HyperCard remembers the format and 
header you used for that stack's report so you can use the same setup 
next time you print. 

Quit HyperCard 
Quit HyperCard (or Command-Q) leaves HyperCard, 
automatically saving any changes you've made. 

Edit Menu 
The Edit menu lets you change your work. Undo, Cut, Copy, Paste, 
and Clear all work as they're described in the owner's guide that 
came with your computer. The other commands are unique to 
HyperCard. 
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l] or ['J) 

The different Edit menus 
The level set on the User Preferences card of the Home stack, in 
conjunction with the protection level set for a particular stack, 
determines which menu appears when you press Edit. If either level 
is set to Browsing or Typing, you choose a command from the short 
menu Oeft in Figure 6-19). Otherwise you choose from a full menu 
(right in Figure 6-19). 

~--- .#Z 

l ul "H 

( OPLJ " ( 
Pa<;!t> 'HI 

(le.ii 

'-ewlcllcl '*'' 
Delell' Laid 

Figure 6-19 

' 

. 
----

#:Z 

( ut "'H 
Copy *l 

Paste ¥LI 

CI ear 

New Card "''-

Deiete Card 

Cut Card 

Copy Card 

Background #8 

Short and full Edit menus 

For information on user levels, see "User Preferences" in 
Chapter 3. For information on individual stack protection, see 
"Protect Stack" earlier in this chapter. 

Undo 
Undo (or Command-Z) undoes your last action on a card or 
background. Use it when you make a mistake or when you change 
your mind about some action. 

With the Paint tools, pressing Tilde or Escape is the same as 
choosing Undo. 
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Cut 

Cut (or Command-X) removes the selected information from the 
card or background and puts it on the Clipboard. Use Cut when you 
want to move something from one place to another. 

Cutting a picture 

When you're using a Paint tool, Cut affects either the background 
picture or the card picture, depending on whether the Background 
command in the Edit menu is checked or unchecked. 

• To cut a picture: 

1 . Select the portion of the picture you want to cut. 

Use either the Lasso or the Selection tool to do it. (See "Lasso" 
and "Selection Tool" later in this chapter.) 

2. Choose Cut from the Edit menu. 

You can also press Command-X. 

Cutting buttons and fields 

When you cut a button, you also cut its associated actions. If you 
paste the button, you paste its actions along with it. 

Important Buttons and the pictures representing them are often separate. 
This is always the case if a button is transparent. Remember to 
cut and paste the picture as well as the button. (You' ll have to 
cut and paste them separately.) 

When you cut a field, all text and attributes (field name, font, and so 
on) belonging to that field are cut along with it. If you paste back that 
field in the same or another stack, you also paste back its attributes, 
but not its text. 

• To cut a button or a field: 

1. Select the button or field tool. 

2. Click the specific button or field you want to cut. 

3. Choose Cut from the Edit menu (or press Command-X). 
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Cuttir1g a card 

• To cut a card: 

1. Move to the card you want to cut. 

2. Choose Cut Card from the Edit menu. 

When you cut a card, you cut everything on it-picture, fields, text, 
buttons, actions, and a copy of that card's background. 

Cutting a background 

You can't cut a background. To remove a background from a stack, 
you must delete every card that uses that background. If there is only 
one card in the stack, you must delete the stack. 

Copy 

Copy (or Command-C) makes a copy of the selected information 
and puts it on the Clipboard. The selected information is left 
unaffected (but whatever was on the Clipboard is replaced). If 
you're using a Paint tool and nothing is selected, all the Paint 
information is copied. 

Copying a picture 

When you're using a Paint tool, Copy gets its information from 
either the background picture or the card picture, depending on 
whether the Background command in the Edit menu is checked or 
unchecked. 

• To copy a picture: 

1. Select the portion of the picture you want to Copy. 

Use either the Lasso or the Selection tool to do it. (See "Lasso" 
and "Selection Tool" later in this chapter.) 

2. Choose Copy Picture from the Edit menu. 

You can also press Command-C. 

3. Move to the card where you want the copied picture to 
appear. 

Moving between cards or stacks doesn't affect what's on the 
Clipboard, the holding place for what you copied. 
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4. Choose Paste Picture from the Edit menu. 

Or press Command-V. The copied picture appears. 

5. Drag the picture where you want it to be on the card. 

6. Click anywhere outside the pasted area. 

Copying buttons and fields 

When you copy a button, you also copy its actions. If you paste the 
button, you paste its actions along with it. 

Important Buttons and the pictures representing them are often separate . 
This Is always the case if a button is transparent. Remember to 
copy the picture as well as the button. (You' ll have to copy 
them separately.) 

When you copy a field, all you copy is the field itself; you don't 
copy the field's text. 

• To copy a button or a field: 

1 . Select the button or field tool. 

2. Click the specific button or field you want to copy. 

3. Choose Copy Button or Copy Field from the Edit menu (or 
press Command-C). 

4. Move to the card where you want the copied button or field 
to appear. 

Moving between cards or stacks doesn't affect what's on the 
Clipboard, the holding place for what you copied. 

5. Choose Paste Button or Paste Field from the Edit menu. 

Or press Command-V. The copied button or field appears . 

6. Drag the button or field where you want it to be on the 
card. 

7. Click anywhere outside the pasted area. 

Copying a card 

• To copy a card: 

1 . Choose Copy Card from the Edit menu. 

A copy of the current card is placed onto the Clipboard. 
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2. Move to the card after which you want the copied card to 
appear. 

It can be in the current stack or in any other stack. 

3. Choose Paste Card from the Edit menu. 

Or press Command-V. The pasted card becomes the current 
card. 

• To change a card's position so that it's first in a stack: 

1 . Move to the card whose position you want to change. 

2. Ch1oose Cut Card from the Edit menu. 

3. Ch1oose First on the Go menu. 

Or press Command-1. The first card in the stack appears. 

4. Ch1oose Paste Card on the Edit menu. 

Or press Command-V. The pasted card appears on the screen; it 
is now the second card in the stack. 

5. Choose First on the Go menu again. 

Or press Command-1. The first card in the stack appears. 

6. Choose Cut Card on the Edit menu. 

The card you had originally set out to reposition is now first in the 
stack. 

7. Choose Paste Card on the Edit menu. 

(Or press Command-V.) The original first card is now second in 
the stack. 

When you copy a card, you copy everything associated with 
it-background, picture, fields, text, buttons, and actions. 

Copying a background 

You copy a background by copying the card that has the 
background you want. (A copied card takes everything with it.) 

• To copy a background: 

1. Copy a card that has the background you want. 

2: Move to where you want the new background. 

3. Paste the copied card. 

4. Mc1ke new cards based on the copied card's background. 

5. Delete the original pasted card. 

You can't replace an existing card's background. 
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Paste 
Paste (or Command-V) takes a copy of the material that's on the 
Clipboard and puts it on the screen. 

o If the material is regular text, it appears at the insertion point of a 
field you've chosen. 

o If the material is a picture, it appears at the screen position at 
which it was cut. 

o If the material is a field or button, it appears at the screen 
position at which it was cut. (You can move a pasted selection by 
dragging within the selection.) Pasted buttons and fields retain 
all their original actions. 

o If the material is a card, it appears after the current card in the 
stack. A pasted card pastes its background as well (assuming the 
background is different from the ones surrounding it). 

When you're using a Paint tool, the material you're about to paste 
can be text or a picture. If the material is regular text (that is, text 
created with the Text tool), shrinking the selection by dragging the 
corners with the Command key pressed makes more or less of the 
text appear. (The text wraps at the right border of the selection.) 
The text becomes a picture after you've pasted it and clicked outside 
the selected area. 

Pictures are pasted in opaque; if you want the background to show 
through, choose Transparent from the Paint menu after you've 
pasted onto the card, but before you've clicked outside the pasted 
area to make the changes complete. 

Pasting a card in miniature 

You can paste a picture of a card in miniature, like the cards that 
appear when you choose Recent from the Go menu. 

• To paste a miniature: 

1 . Choose Copy Card or Cut Card from the Edit menu. 

2. Move to the card where you want to paste the miniature. 

3. Press and hold the Shift key while you choose Paste Card. 

Alternately, press Command-Shift-V. 

The miniature appears selected in the center of the screen. 

Note that this is a picture of a card-none of the actions from the 
original card come with the miniature. 
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Clear 
Clear removes the selected information without putting it on the 
Clipboard or affecting what's already on the Clipboard. 

When you're using a Paint tool, Clear affects either the selected 
background picture or the selected card picture, depending on 
whether the Background command in the Edit menu is checked or 
unchecked. 

When the Message box is visible and the insertion point is not 
visible, Clear empties the Message box and puts the insertion point 
in it. 

Pressing the Delete or Backspace key (or the Clear key on the 
keypad) has the same effect as Clear. 

New Card 
New Card (or Command-N) adds a card to the current stack. The 
new card automatically picks up the background picture, 
background buttons, and fields of the card you're looking at. 

The new card is inserted immediately after the card you were 
looking at. You end up looking at the card you just inserted. 

• To make the new card the first one in the stack: 

1. Ch<>ose First on the Go menu. 

Or press Command-1. The first card in the stack appears. 

2. Choose New Card on the Edit menu. 

Or press Command-N. The new card appears on the screen; it is 
now the second card in the stack. 

3. Choose First on the Go menu again. 

Or press Command-1. The first card in the stack appears again. 

4. Choose Cut Card on the Edit menu. 

The card you had originally set out to reposition is now first in the 
stack. 
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• If you want to place the cut card back into the stack, you need to 
follow two more steps: 

1. Move to the card you want to come immediately before the 
one you've just cut. 

2. Choose Paste Card on the Edit menu. 

Or press Command-V. 

The pasted card appears on the screen in its new position in the 
stack. 

Delete Card 
Delete Card (or Command-Backspace or Command-Clear) 
permanently eliminates the current card. Delete Card works exactly 
like Cut Card, except that the deleted card does not go onto the 
Clipboard and so cannot be pasted anywhere. 

You can't delete the only card in a stack. If there's only one card in 
the stack and you want to delete it, use Delete Stack from the Stack 
menu. 

Cut Card 
Cut Card (available only when Painting, Authoring, or Scripting is 
checked in the User Preferences card of the Home stack) removes 
the card on the screen, deletes it from the stack, and puts up the 
next card in the stack. HyperCard doesn't ask you to confirm the 
cut-it just does it. 

You can't cut the last card in a stack. To cut the last card, use Delete 
Stack from the Stack menu. 

Copy Card 
Copy Card (available only when Painting, Authoring, or Scripting 
is checked in the User Preferences card of the Home stack) makes a 
copy of the current card and puts it on the Clipboard. Whatever was 
on the Clipboard is replaced. 

When you copy a card, you copy everything associated with 
it-background, picture, fields, text, buttons, and actions. 

Edit Menu 113 



['=:Jl:=~n-a 

Text Style 

Text Style, or Command-T, (available only when Painting, 
Authoring, or Scripting is checked in the User Preferences card of 
the Home stack) lets you set text properties for the active field or the 
active Paint text. (Paint text is text created using the Paint Text 
tool.) Paint text is active until you 

o switch tools after you've typed, 

o click the mouse, 

o leave the card, or 

o switch into or out of the background. 

A field is active if the insertion point is in it. 

A dialog box appears, letting you choose text font, style, 
alignment, size, and the height of each line in points. 

Scroll to the font you want; -------------~ 

then click to select it. 
Click the size you want... 

r;:;e 

Check one or more styles _ ___ _..,.... 
for a ll the text in a field 
(or check nothing for plain text). 

:::::J Bold 
Italic 
Underline 

D Outline 
D Shadow 

Londense 
E ctend 

The alignment you set -------j[ 
works on all lines 
in the same field. 

g 
L •ft 
Center 
RI ht 

Chic: ago 
Courier 

Heluetica 
"1onac:o 
"Jew York 
Times 

Whatyouseeis - ----- ----------- - ---J 
what you'll get. 

Figure 6-20 
Text s1yles dialog box 

4 

113 

...or type it here. 

ff OK J) 

(cancel J 

6 

e 
g 

This determines the space 
between lines. in points. 

See "Setting Text Properties" in Chapter 4 for more information. 
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Background 
Background, or Command-B, (available only when Painting, 
Authoring, or Scripting is checked in the User Preferences card of 
the Home stack) lets you edit the background picture and create 
background buttons and fields. 

The background serves as a template; whatever's in the background 
is common to all cards associated with that background. 

Background alone With transparent card picture 

Figure 6-21 
Background versus card picture 

The background picture is hidden by any black or opaque portions 
of the card picture. (you choose Transparent and Opaque from the 
Paint menu, described later in this chapter.) 

A background button works for all cards associated with that 
background, unless it's covered by a card button; a background 
field appears in the same location on all cards associated with that 
background, unless it's covered by a card field. 

Important The most common mistake in creating a button or a field is 
putting it on a card when it's supposed to be on a background . 
After you've created one or more background buttons or fields, 
choose Background again to get back to the Card level, and 
flip to the next card; if the buttons or fields you've just created 
are on that card too, you've succeeded. 

When you're working in a background, the menu bar is striped, and 
a check mark appears to the left of the Background command in the 
Edit menu. (See Figure 6-22.) 
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Figure ·6-22 
Menu bar striped while working In background 

There's no limit (beyond disk space) to the number of backgrounds 
a stack can have. 

Go menu 
Use commands in the Go menu to navigate through stacks. You can 
look through cards in the current stack, go back through cards and 
stacks you've already seen, or immediately get to any stack 
represented on the Home card. 
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Find. ~F 
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Figure 6-23 
Go menu 

Back 
The Back command (or Tilde, Esc, or Down Arrow) takes you to the 
most recent card you've viewed. Keep choosing this command to 
review up to the last 100 cards you've seen. 
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After you've backed through cards, you can press the Up Arrow key 
to come forward again through the reviewed cards. 

When you're using a Paint tool, use Command-Tilde (or 
Command-Esc) instead of Tilde as a shortcut for the Back 
commands. (Pressing Tilde alone in a Paint tool undoes your 
last action.) 

Home 
Home (or Command-H) selects the Browse tool and takes you to 
the Home card, the first card in the Home stack. The Home card is 
special-it's meant to hold buttons that bring you to the most 
important cards in your collection. 

Figure 6-24 
Home card 
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To go to any stack represented on the Home card, click on its 
picture. (Each picture is actually a button.) 

For more details about the Home card and the rest of the Home 
stack, see Chapter 3. 
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Click any image to go to that card. 

Help 

Help (or Command-?) takes you to the first card in the Help system. 
The Help system describes everything in HyperCard, including 
some features not covered in this manual. It is the ultimate source of 
HyperCard information. 

When you use Command-? as a shortcut to choosing Help, you 
don't have to press the Shift key. 

Recent 

Recent (or Command-R) lets you backtrack through any or all of the 
last 42 cards you viewed. 

When you look at a card, HyperCard puts a miniature picture of it 
on Recent. To go back to that card, just click that card's picture. 

Although you might have looked at the same card several times, 
Recent holds only one picture of it. 

Figure 6-25 
Recent 
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You can go back through the last 100 cards you viewed in the order 
that you viewed them by using the Back command (or by pressing 
Tilde), described earlier in this section. 

To return to the card you most recently viewed, click the picture of 
the card with the box around it or press Return. 

First 
First (Command-I or Command-Left Airow) takes you to the first 
card in the current stack. 

If you're already at the first card, First does nothing. 

Prev 
Prev (Command-2 or Left Airow) takes you to the previous card in 
the current stack. If you're at the first card in the stack, Prev wraps 
you around to the last card in the stacls.:. 

+ Prev isn't Back: Prev takes you to the previous card in the current 
stack; Back takes you to the card you last looked at. The last card 
you looked at might have been in another stack. 

Next 

Next (Command-3 or Right Airow) takes you to the next card in the 
current stack. If you're at the last card, Next wraps you around to the 
first card. 
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Last 
Last (Command-4 or Command-Right Arrow) takes you to the last 
card in the current stack. Use last when you want to create a new card 
at the end of the stack. 

If you're already at the last card, Last does nothing. 

Find 
Find (or Command-F) searches for text in the fields of the current 
stack. Choosing Find brings up the Message box, as it appears in 
Figure 6-26. 

The Insertion point comes up -----­
between the quotation marks. 

Figure' 6-26 
Messoge box 

• To search for text: 

1. Ch1oose Find from the Go menu. 

2. Type what you want to find. 

Or press the Command key as you select up to a line of 
characters from any text field. (A box appears around the 
text as you select it.) 

3. Press Return or Enter. 

HyperCard searches the current stack for a series of characters in 
any field that begins with what's in the Message box. HyperCard 
looks for the first card that contains everything between the 
quotation marks, even if the words appear in a different order. 
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Matches what's in - --------; 
the Message box. 

Figure 6-27 
Finding a name 

Pressing Return after a search makes HyperCard repeat the search. 

If you choose Find again after an initial search, HyperTalk selects 
what you've typed between the quotation marks. To replace what's 
in the Message box, just type something new. 

•:• Watch those quotation marks: The text that you want to find 
must appear between quotation marks after the word "find." 

To cancel a search-in-progress, press Command-period(.). 

If HyperCard can't find the text, the Macintosh beeps. 

Searching in a specific field 

HyperCard automatically searches through all the fields on all the 
cards in the current stack. You can limit the search to one specific 
background field. 

• To limit the search to a specific field: 

• Click after the last quotation mark and type a space, the 
words in field, and the field number or name. 

Figure 6-28 shows an example. 
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Figure 6-28 
Limiting the search 

• To find the name or number of a field: 

• Ciiek In the field with the Browse tool selected and choose 
Field Info from the Objects menu. 

Alternatively, take the following steps: 

1. Ciiek the Field tool. 

To use the Field tool, you must have Authoring or Scripting 
checked on the User Preferences card in the Home stack. 

2. Click the field whose name or number you want to know. 

3. Choose Field Info from the Objects menu. 

Or just double-dick in the field you're interested in. 

Field number - ----------------< 

Figure 6-29 
Finding out a field 's number 
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Message 

Message (or Command-M) shows the Message box. Use the 
Message box to send any one-line message to HyperCard. 

• To send a message: 

1. Make sure the insertion point is in the box by clicking in it. 

2. Type the message. 

3. Press Enter or Return. 

Figure 6-30 
Sending a message 

• To stop a message-in-progress: 

• Press Command-period (.). 

To dear the Message box so you can use it again, do any of the 
following: 

o Choose Message box again from the Go menu. 

o Press Command-M. 

o Select all the text in it and press Clear or Backspace. 

o Select all the text in it and type a new message. 

To hide the Message box, dick its close box (or press 
Command-M). 

To type messages into the Message box when the box isn't visible, 
check Blind Typing on the User Preferences card in the Home stack. 

See Appendix A for a list of the most common HyperCard 
messages. 

For detailed information on all HyperCard messages and other 
advanced HyperCard topics , see the HyperCard Script Language 
Guide. 
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Toolls menu 
You use tools to browse, to edit text and pictures, and to create and 
change buttons and fields . You can have only one tool selected at a 
time. One tool-any tool-must be selected. 
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Figure 6-31 
Tools in action 

The Tools menu appears when Painting, Authoring, or Scripting is 
checked on the User Preferences card in the Home stack. 

The Tools menu holds the General and Paint tools . General tools 
are on the menu's top line; they control browsing, text creating and 
editing, and button creating and selecting. Paint tools, which fill 
the rest of the menu, control creating and editing pictures. 

Browse Button Field 

Eraser ---------~ I ~ La"a 

Selection - ~ / - Pencil 

Brush Line 

:~~~:-9-1-e ---~~~~~~~~---~--;;:-/-- I ~ :~~:ed Rectangle 

Paint Text Regular Polygon Polygon 

Figure' 6-32 
Tool names 
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General tools ---------

Paint tools -----------i 

You can "tear off' the Tools menu, creating a movable tools 
palette. 

• To create a movable Tools palette: 

• Drag down through the menu, either past the bottom or 
beyond either side. 

You can also press Option-Tab to make a Tools palette appear 
and disappear. 

Put the palette wherever you want. 

To put it away, click its close box. To move the palette around, grab 
it by its top bar or by any edge. To select a tool, click it. (You can 
also select a tool from the Tools menu in the Menu bar, even if you 
have a palette torn off; the palette will reflect the menu selection.) 

Close box 

rn DD 
''l 0 •.:_-, 

ACJ G 

Figure 6-33 

Click any tool to select it. 

Using the Tools palette 

• To select a tool, click Inside the box that holds It. 

The tool you select becomes highlighted in the menu, and, 
depending on the tool you've selected, the shape of the pointer 
might change. 

Authoring or Scripting must be checked on the User Preferences 
card in the Home stack if you want to select the Button tool or Field 
tool. 
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Browse tool 

I-beam pointer 

Button tool 

Menu bar changes 
When you choose one of the Paint tools, three new menus 
appear-Paint, Options, and Patterns. (These menus are described 
later in this chapter.) If the Objects menu was visible, it disappears; 
it reappears (and the Paint, Options, and Patterns menus all go 
away again) when you choose a General tool. 

Browse tool 
When you select the Browse tool, the pointer becomes a hand with 
the first finger extended. Use the Browse tool to click buttons, to 
edit text, and to select text for searching. The Browse tool converts 
to an I-beam when it's over editable text when any level except 
Browsing is checked on the User Preferences card in the Home 
stack. 

In its I-beam shape, the pointer lets you type and edit text in fields 
(described elsewhere in this chapter and in Chapter 4). Click in the 
field where you want to type. 

To learn about editing text in the Macintosh, see the owner's guide 
that came with your computer. 

For detailed information about text and the fields that text appears 
in, see Chapter 4 of this guide. 

For a detailed tutorial on browsing and editing, see Chapter 1, 
"Browsing and Editing." 

For information on typing text not limited to fields, see "Paint Text 
Tool" later in this chapter. 

Button tool 
Use the Button tool to make new buttons or to see buttons that 
already exist. 

To use the Button tool, make sure that Authoring or Scripting is 
checked on the User Preferences card in the Home stack. 
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When you choose the button tool, the buttons on the card and the 
card's background appear surrounded by a thin-lined box; a 
selected button is surrounded by a moving dotted line. 

~~~ 
? I EJ ~ 

Buttons enclosed 
by thin-lined boxes 

- selected button enclosed 
by moving dotted line 

Figure 6-34 
Buttons with button tool selected 

• To create a button: 

• Choose New Button In the Objects menu. 

Alternatively, select the Button tool; then press the Command 
key and drag diagonally. 

• To create a button that appears automatically on all cards that 
share a particular background: 

1. Choose Background from the Edit menu. 

2. Choose New Button in the Objects menu. 

Alternatively, select the Button tool, press the Command key, 
and drag diagonally. 

Important The most common mistake in creating a button is putting It on 
a card when it's supposed to be on a background. After you've 
created one or more buttons, flip to the next card; if the 
buttons you've just created are on that card too, you've 
created background buttons. 

• To select a button: 

1. Select the Button tool. 

2. Click the button you want to select. 
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To size a selected button, drag by any corner. 

To move a selected button, drag by any edge; or place the pointer 
inside the button and drag. 

To duplicate a selected button, press Option while you drag. 

To copy a button, select it and choose Copy Button from the Edit 
menu (or press Command-C). 

To cut a button, select it and choose Cut Button from the Edit menu 
(or press Command-X). 

To eliminate the button without affecting the Clipboard, select it 
and choose Clear Button from the Edit menu (or press Backspace or 
the Clear key). 

•:• Browse tool versus Button tool: You must be using the Browse 
tool to click buttons. After you've created a button and you want 
to test it, be sure to select the Browse tool first. 

• To bring up information about a particular button: 

1 . Select the Button tool. 

2. Cllc:k the button you're Interested In. 

3. Choose Button Info from the Objects menu. 

(Alternately, choose the button tool and double-click the button 
you 're interested in.) The Button Info dialog box appears. (See 
Figure 6-35.) 

Button Name:§!!.._.~~~~~~~~ 
Card button number: I 

Card button ID: I 

'Show name 

Auto 111 rte 

I on . 

L rr k o ... 

'>t4le: 

: Ir an~parenl 
opaque 
r c tangle 
\hi!dOlll 

•round reel 
• check boH 
• • 1ad10 button 

~ OK ~ nc el 

Figure 6-35 
New Button dialog box 
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Field tool 

To see all the buttons on a card and the background when the Button 
tool is not selected, press the Command key and the Option key at 
the same time. 

To read about labeled buttons and buttons with different shapes 
(and to get detailed information about the dialog box in Figure 
6-35), see "Button Info" in the Objects Menu section of this 
chapter. 

Field tool 

Use the Field tool to create and change text fields. You can have 
fields on a specific card as well as fields common to all cards 
associated with a given background. 

To use the Field tool, make sure that Authoring or Scripting is 
checked on the User Preferences card in the Home stack. 

You can have as many fields on a card or a background as will fit. 
The number of lines in a field depends on that field's. physical size, 
the point size of the text within the field, and on the height of a 
single line within the field. (See the Height box in the Text 
Properties dialog box, elsewhere in this chapter.) 

To create a field, choose New Field from the Objects menu. 
Alternatively, select the Field tool; then position the pointer and, 
while holding down the Command key, drag diagonally. 

• To create a field for every card associated with a particular 
background: 

1. Choose Background from the Edit menu. 

2. Choose New Field from the Objects menu. 

Alternatively, select the Field tool, press the Command key, and 
drag diagonally. 
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Important The most common mistake In creating a field Is putting It on a 
card when It's supposed to be on a background. After you've 
create•d one or more fields, flip to the next card; if the fields 
you'vE~ just created are on that card too. you've created 
background fields. 

• To select a field: 

1. Cllc:k the field tool to select It. 

2. Clic:k inside the field you want to select. 

To size a selected field, drag by any corner. 

To move a selected field, drag by any edge; or place the pointer 
inside the field and drag. 

To duplicate a selected field, press Option while you drag. 

To copy a field, select it and choose Copy Field from the Edit menu 
(or press Command-C). 

To cut a field and all its accompanying text, select the field and 
choose Cut Field from the Edit menu (or press Command-X). 

To eliminate the field without affecting the Clipboard, select it and 
choose Clear Field from the Edit menu (or press Backspace or the 
Clear key). 

Warning Deleting a background field also deletes all text In that field on 
all cards sharing that background. Once you've deleted the 
field, It and all its text are gone for good-you can't undo the 
deletion. 

• To bring up information about a particular field: 

1. Click the field tool to select it. 

2. Click the field you're interested in. 

3. Chc:>ose Field Info from the Objects menu. 

Or just double-click the field you're interested in. The dialog box 
in Figure 6-36 appears. 

Alternatively, move the insertion point to the field you want to know 
about and choose Field Info from the Objects menu. 
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Figure 6-36 
New Field dialog box 

For details about the dialog box in Figure 6-36, see "Field Info" later 
in this chapter. 

For information about fields and their uses, see "Fields" in 
Chapter 4. 

Selection tool 

Use the Selection tool to select a rectangular area of a picture. Drag 
diagonally to select. 

To select the whole picture, double-click the Selection tool on the 
torn-off Tools palette. (You can also choose Select All from the 
Paint menu.) 

To shrink the selection area to the outer perimeters of the object 
you're selecting, press the Command key while you drag; when you 
release the mouse button, the rectangle closes in and eliminates 
extra white space. 

' --------------· 

Figure 6-37 

.. .to eliminate extra 
white space in the 
selection. 

Eliminating extra white space in a selection 
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For an even tighter selection, press Option as you drag (or 
Conunand-S after you drag) to convert the rectangle to a lasso and 
to close in on the selection's dark dots. 

(• Select, but can't drag: If you've selected a picture but you can't 
drag it, you've tried to select a background picture without being 
in the background. Choose Background from the Edit menu and 
try again. 

To move a selection, position the pointer inside the selection until 
the pointer changes to an arrow; then drag. 

To move a selection straight up or down or directly left or right, 
press Shift while you drag. 

To make a copy of a selection, press Option while you drag. 

To make multiple copies, press Conunand-Option while you drag. 
(Press the Option key plus a number between 1 and 8 before you 
drag to control spacing between images.) 

To stretch or shrink a selection, press Conunand while you drag 
from a comer. 

Original Shrunk stretched 

Figur•B 6-38 
Shrunk and stretched selection 

To stretch or shrink straight up and down or straight left and right, 
drag from any edge. 
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Lasso 
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Lasso 
Use the Lasso to select a specific part of a picture when the area's too 
small for the Select tool or when you need to scoot around 
nonrectangular images. 

Figure 6-39 
Only the lassoed fish are selected 

To use the Lasso, drag around the area you want (The line trailing 
out of the lasso's tip shows you what you're lassoing.) When you 
release the mouse button, the lasso hugs the part of the picture it 
surrounds and selects it. (The lasso shrinks until it finds black dots.) 
The edges of the lassoed area will shimmer. 

To lasso an area without shrinking around black dots, press Option 
as you drag. 

To lasso an area that has no breaks in it (one surrounded by an 
unbroken line, or one composed entirely of connected black dots), 
move the lasso's tip into it, press the Command key, and click the 
mouse. This technique is especially handy for selecting small areas. 

To lasso each element in the picture (ignoring any unenclosed white 
space), double-click the Lasso in the torn-off Tools palette. 

To move a selection, position the lasso's tip within the selection 
until the lasso changes to an arrow; then drag. 

To move a selection straight up or down or directly left or right, 
press Shift while you drag. 

To make a copy of a selection, press Option while you drag. 
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To make multiple copies, press Command-Option while you drag. 
(Press the Option key plus a number between 1 and 8 before you 
drag to control spacing between images.) 
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Figure 6-40 
Multiple copies 
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To stretch or shrink a selection, press Command while you drag 
from an edge. 

_i-._ '~ 

I ' 

Ot1gi1:a! 

" r· '- ,: f' -'-

' "·-~ 

Figure 6-41 
Stretched and enlarged 
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Pencil 

Brush 

Pencil 

Use the Pencil to draw thin (one dot wide) free-form lines. Most 
people find it the most useful tool for doing detailed work in FatBits. 

Pencil draws in the opposite color of the first place you press the 
Mouse button. (See Figure 6-42.) 

starting on black 
draws In white. 

Figure 6-42 
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starting on white 
draws In black. 

Drawing the opposite color 

To draw straight horizontal or vertical lines, press the Shift key while 
you drag. 

To work with FatBits, double-click on the Pencil on the tom-off 
Tools palette (or press Command as you click with the Pencil 
selected). Click to make a single dot; click on an existing dot to 
erase it. 

For information on FatBits, see "FatBits" in the Options menu 
section of this chapter. 

Brush 
Use the Brush to paint with the current pattern. Bring up a dialog 
box of brush shapes and sizes by choosing Brush Shape from the 
Options menu (or just double-click Brush); then click the one you 
want. Different shapes create different effects. 
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Figure 6-43 
Different brush shapes create different effects when you paint 

To paint straight vertical or horizontal lines, press Shift while you 
drag. 

To erase instead of paint with a brush shape, press Command while 
you drag. Change the brush shape to change the shape of the 
"brush-eraser." 

Eraser 
The Eraser wipes out the part of a picture you drag over. 

To erase the whole picture, double-click the Eraser. HyperCard 
wipes out the picture, and then selects the tool you were using just 
before you double-clicked the Eraser. (Choose Undo from the Edit 
menu, or Revert from the Paint menu, if you double-click by 
accident.) 

•:• Magtc appearances: If you see a picture appearing under the 
eraser as you drag the eraser over a card picture, you're exposing 
a covered background picture. To erase with white paint (which 
prevents the background picture from appearing), press the 
Command key as you drag. 
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Line tool 

Line tool 
Use the Line tool to draw straight lines. Drag to draw lines in black; 
press Option while you drag to draw lines in the selected pattern. 
(See "Pattern Menu" later in this chapter.) 

To change line thickness, choose Line Size from the Options menu 
(or double-click the Lines tool on the torn-off Tools palette) and 
click one of the choices. Or press 1 through 8 (5 is the same as 4, 
7 is the same as 6) with Power Keys checked on the Options menu 
for lines that many dots wide. To keep the same line thickness, click 
the highlighted choice. 
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Figure 6-44 
Line and border width 

To change the angle of a line, with the mouse button still pressed 
move the mouse in another direction as you're creating the line. 

To constrain angle changes to 15° increments, press Shift while you 
drag. 

To draw a line centered on a given point, choose Draw Centered 
from the Options menu before you drag. 

To draw a line with a multiple image of itself, choose Draw Multiple 
from the Options menu before you drag. (Press the Option key plus 
a number between 1 and 8 before you drag to control spacing 
between images.) 

For information about power keys, see "Power Keys" in the Options 
Menu section of this chapter. 
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Spray tool 

c 
Rectangle tool 

Line widths and pattern menu 

Spray tool 
Use the Spray tool to spritz paint onto the screen in the selected 
pattern. The more you spray back and forth over the same area, the 
more the pattern becomes apparent. 

To spray straight vertical or horizontal lines, press Shift while you 
drag. 

To erase with the Spray tool, press Command while you drag. 

Rectangle tool 
The Rectangle tool draws rectangles. To draw black-bordered 
rectangles, position the crossbar pointer where you want the 
rectangle to start; then draw diagonally. 

To change the thickness for a rectangle's border before you draw it, 
choose Line Size from the Options menu (or double-click the Lines 
tool) and click one of the choices. 

To draw rectangles filled with the selected pattern, choose Draw 
Filled from the Options menu. 

To draw with borders in the selected pattern, press Option as you 
start to drag. 

A thick line lets you 
draw borders In 
the current pattern. 

Figure• 6-45 
Rectangles with patterned borders 
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Rounded Rectangle tool 

To draw centered on a given point, choose Draw Centered from the 
Options menu before you drag. 

To draw borderless rectangles, choose Draw Filled from the 
Options menu and hold down the Option key as you drag. 

To draw multiple rectangles, choose Draw Multiple from the 
Options menu before you drag. (Press the Option key plus a number 
between 1 and 8 before you drag to control spacing between 
images.) 

To draw squares, hold down the Shift key while you drag. 

Rounded Rectangle tool 
The Rounded Rectangle tool draws rectangles with rounded 
corners. To draw black-bordered rounded rectangles, position the 
pointer where you want the rectangle to start; then draw diagonally. 

To draw borders using the current pattern, hold down the Option 
key while you drag. 

Figure 6-46 

Primo Acme 
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Creating and combining rounded rectangles 

To change border thickness, choose Line Size from the Options 
menu (or double-dick the Lines tool) and click one of the choices; 
or press 1 through 8 with Power Keys checked on the Options menu 
for increasingly thicker lines. 
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Bucket 

To draw rounded rectangles filled with the selected pattern, choose 
Draw Filled in the Options menu before you drag. (Double-click 
this tool to toggle Draw Filled on and off.) 

To draw centered on a given point, choose Draw Centered on the 
Options menu before you drag. 

To draw with a multiple image, choose Draw Multiple on the 
Options menu before you drag. (Press the Option key plus a number 
between 1 and 8 before you drag to control spacing between 
images.) 

To draw squares with rounded corners, press Shift while you drag. 

Bucket 

Use the Bucket to fill solid black and enclosed white areas (including 
the hollow parts of outlined and shadowed letters) with the selected 
pattern. 

Before After 

Figure 6-47 
Using the Bucket 

If there are any gaps in the outline surrounding an area, paint will 
spill out and fill the surrounding area as well. (You can use FatBits to 
check for gaps.) 
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Oval tool 

Before After 

Figure 6-48 
Paint spilled In enclosed and unenclosed areas 

You can't use the Bucket to fill a dark area (as opposed to a black 
area) with a lighter color. Instead, select the area and use Fill from 
the Paint menu. 

•> Cleaning Up accidental spills: If you accidentally fill your screen 
with paint, immediately choose Undo from the Edit menu; then 
check carefully for gaps in your drawing before using the Bucket 
again. 

•> Bucket short cut: Double-click the Bucket to make the Patterns 
palette appear and disappear. 

Oval tool 
The Oval tool draws oval shapes. To draw black-bordered ovals, 
position the pointer where you want the oval to start; then drag 
diagonally. 

To draw borders using the current pattern, hold down the Option 
key while you drag. 

To draw circles, press Shift while you drag. 

To draw centered on a given point, choose Draw Centered on the 
Options menu before you drag. 

To draw filled with the current pattern, choose Draw Filled on the 
Options menu before you drag. 

Tools menu 141 



Curve tool 

To draw with a multiple image, choose Draw Multiple on the 
Options menu before you drag. (Press the Option key plus a number 
between 1 and 8 before you drag to control spacing between 
images.) 

To change border thickness, choose Line Size from the Options 
menu (or double-dick the Lines tool) and click one of the choices; 
or press 1 through 8 (5 is the same as 4, 7 is the same as 6) with Power 
Keys checked on the Options menu for increasingly thicker lines. 

Curve tool 
Use this tool to draw free-form shapes. Drag to draw whatever shape 
you want 

If you draw with Draw Filled checked from the Options menu, 
HyperCard draws a straight line connecting the starting and ending 
points of the shape when you release the mouse button; then it fills 
the shape with the selected pattern. (Double-clicking the Curve tool 
toggles Draw Filled on and off.) 

Curve tool, Curve tool, 
Draw Fiiied unchecked Draw Filled checked 

Figure 6-49 
Drawing filled and unfilled shapes 

To change border thickness, choose Line Size from the Options 
menu (or double-dick the Lines tool) and click one of the choices; 
or press 1 through 8 (5 is the same as 4, 7 is the same as 6) with Power 
Keys checked from the Options menu for increasingly thicker lines. 

To draw borders using the current pattern, hold down the Option 
key while you drag. 
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A 
Paint Text tool 

Paint Text tool 

Use Paint Text to type text that's part of the picture. Paint text is 
especially useful as part of a background picture: use it for labels and 
titles that you want to show on many cards. 

Set text attributes by choosing Text Style from the Edit menu or by 
double-clicking the Paint Text tool. The settings you make stay in 
effect until you change them, or until you restart HyperCard. 

Press Return to move down to a new line. 

Scroll to the font you want; ------------~ 
then click to select it. 

Ciiek the size you want... 

Style 
D Bold 
D Italic 

Chicago 
Courier ... 

...or type it here. 

r OK J) 

D Underline 
Check one or more styles -------+H D Outline 
(or check nothing for plain text). D Shadow 

D Condense 

Heluetica 
Monaco 
New York 
Times 

1: Cancel) 

Line 
Height 

D EHtend 

n·gn 

G
"', Left 

The alignment you set ------M C Center 
works on all lines. O Right 

16 
'-'-------' 

I 8 

Whatyousee ______________________ J This determines the space 
between lines, in points. is what you get. 

Figure 6-50 
Text Style dialog box 

Text you type using this tool is different from text you enter into 
fields . You don't create a field in which Paint Text appears-you just 
position the cursor and click where you want the text to start, and 
then type. As soon as you confirm what you've typed (by clicking, 
choosing another tool, choosing Keep from the Paint menu, or 
moving to another card), the text becomes part of the picture-its 
attributes become fixed. To change an attribute or to edit text, you 
have to erase the old text and start again. 

•:• Quick text pickup tip: To select text you've just finished typing, 
press Command-S. 
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Regular Polygon tool 

Important You can't use the Find command to search for Paint Text. To 
HyperCard, Paint Text Is just another picture. If you think that 
you'll want to search later for what you're typing now. create 
a field and enter text using the Browse tool. 

Each time you restart HyperCard, you reset the text attributes to 
12-point plain Geneva with a line height of 16 dots, aligned left. 
This doesn't affect already-existing text. 

Regiular Polygon tool 

The Regular Polygon tool creates polygons with regular sides . 
Unlike the other shape-making tools, Regular Polygon always starts 
drawing the shape from the center outwards (whether Draw 
Centered is checked or not on the Options menu). 

The shape gets drawn 
from the center outward. 

Figure• 6-51 
The Regular Polygon tool always draws as though you have 
Draw Centered turned on. 

To select the shape of the polygon, choose Polygon Sides from the 
Options menu (or double-dick the tool). When the dialog box 
appears, click the shape you want. To keep the same shape, click the 
highlighted choice. 

Figure 6-52 
Double-click the tool to select a shape 
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Polygon tool 

To create a shape, drag the mouse diagonally. 

To rotate the shape, turn the mouse with the mouse button still 
pressed as you're creating the shape. 

To constrain movement to 15° increments, press Shift as you rotate. 

To change border thickness, choose Line Size from the Options 
menu (or double-click the Lines tool) and click one of the choices; 
or press 1 through 8 (5 is the same as 4, 7 is the same as 6) with Power 
Keys checked on the Options menu for increasingly thicker lines. 

To draw borders using the current pattern, hold down the Option 
key while you drag. 

To draw filled with the current pattern, choose Draw Filled from the 
Options menu before you drag. 

To draw with a multiple image, choose Draw Multiple from the 
Options menu before you drag. (Press the Option key plus a number 
between 1 and 8 before you drag to control spacing between 
images.) 

Polygon tool 

Use this tool to create polygons with irregular sides. This tool works 
differently from the others in that you don't hold the mouse button 
down to draw, and you double-click when you've finished the 
shape. 

To draw, position the mouse where you want to begin; then click 
and release. Move the mouse until you've finished the first side, 
then click; roll out the second side, then click again; continue until 
you've finished all the sides, or double-click to end. (Clicking on 
the beginning point also ends the shape.) 

Figure 6-53 
Using the Polygon tool 
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•!• Watch your double clicks: After you've started drawing, clicking 
once on the starting point of the shape ends it. (Usually with this 
tool, you double-click to end a shape.) But if you double-click on 
the starting point after you've begun drawing, you'll end the first 
shape and start a second one. 

If the Draw Filled command in the Options menu is checked, 
HyperCard draws a straight line between the polygon's starting and 
ending points when you double-click to finish your polygon, 
creating an enclosed shape. The shape is then filled with the current 
pattern. 

Draw Filled unchecked Draw Filled checkerl 

Figure 6-54 
Creating an enclosed polygon 

To draw borders using the current pattern, hold down the Option 
key while you drag. 

To change border thickness, choose Line Size from the Options 
menu (or double-dick the Lines tool) and click one of the choices; 
or press 1 through 8 (5 is the same as 4, 7 is the same as 6) with Power 
Keys checked on the Options menu for increasingly thicker 
borders. 

To draw shapes constrained to 15 degree angles, start the polygon 
with the Shift key pressed. 

Objects menu 
Use the Objects menu to create, examine, and change the actions of 
and information about HyperCard objects-buttons, fields, cards, 
backgrounds, and stacks. 

To use the Objects menu, you must have the Browse, Button, or 
Field tool selected. 
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Dlllllll"~---~ 
Button Info ... 
Field Info .. . 
Card Info .. . 
Bkgnd Info .. . 
Stack Info .. . 

Bring (loser ·#:+ 
Send Farther :#:-

New Button 
New Field 
New Background 

Figure 6-55 
Objects menu 

Button Info 
Button Info brings up information about the selected button. 

• To use the Button Info command: 

1. Select the Button tool from the Tools menu. 

2. Select the button you want to work with. 

A button you've just created is automatically selected. 

3. Choose the Button Info command from the Objects menu (or 
double-click the button). 

The dialog box in Figure 6-56 appears . 

Belly 
Button Name: ~1---------~ 
( ard button number: 1 

( ard button Ill: 1 

0 Show name 

0 Auto h1lite 

le on ... 

linkTo ... 

Style : 

()transparent 
()opaque 

() rec tangle 
(!) shadow 
() round rec t 
()check boH 
()radio button 

Script . .. f OK U Cancel 

Figure 6-56 
Button Info dialog box 
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Button name 

Type the name for this button into the Button Name box. If you 
leave the box blank, your button will be nameless. If you just created 
this button using the New Button command, the button is already 
named "New Button." Button name works with Show name, 
described next. 

Show name 

Check the "Show name" box to have the button's name appear on 
the button. (Figure 6-57 shows how a button name appears with 
different styles checked.) 

Several buttons can have the same name; use the button ID, 
described below, to distinguish between them. 

Buttorn number and layers 

The button number line tells you whether the selected button is on 
the card or on the background, as well as what layer it's on. A button 
that you've just created has the highest number, and is on the 
frontmost layer on that card. The first button you create has the 
number 1, the second button the number 2, and so on. 

When you change a button's layer, you change its nutnber and the 
numbers of all buttons whose layers are also changed. (See "Bring 
Closer" and "Send Farther" later in this section.) When you delete a 
button, the numbers of any buttons closer to the front are all 
reduced by one. 

Background buttons and card buttons are numbered separately. So 
there can be both a background button and a card button with the 
same number. 

The highest number a background or card button can have is the 
total number of buttons on that background or card; the lowest 
number a background or card button can have is 1. 

Button ID 

Every button has a button ID unique in its stack. Unlike either the 
button name or button number, the ID number is permanent and 
unchangeable. When you delete a button, its ID number is 
permanently retired from the stack. Advanced HyperCard creators 
can use the ID number to create special button actions. 
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Style 

Click one of these choices to set the style for the selected button. 

o "Transparent" makes the button transparent. Use this to make an 
invisible button (perhaps one that goes over a picture), or one 
that blends in with what's behind it. 

o "Opaque" colors the button white. It's like a white rectangle 
without a border. 

o "Rectangle" makes a white rectangle with a thin black border. 

o "Shadow" makes a white rectangle with a drop shadow along the 
right and bottom sides. 

o "Round rect" makes a standard Macintosh button, like the kind 
you see in any dialog box. 

o "Check box" makes a square button with an opaque interior. 

o "Radio button" makes a small round button with an opaque 
interior. 

Figure 6-57 
Button sfyles 

Auto hiltte 

"Auto hilite" momentarily highlights any style button (except check 
box and radio button) when you click it. A button in either check 
box or radio button style toggles on and off when "Auto hilite" is 
set With "Auto hilite" unchecked, you receive no visual feedback 
when you click a button. Figure 6-58 shows how each of the different 
button styles are highlighted 
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Cheek Bott @_:>Radio Button 

Figure 6-58 
Highlighting different sfyles 

Icon ... 

Icon lets you use an icon as a button. Pressing this button brings up 
the dialog box in Figure 6-59. 

Icon ID: 0 I none I 

irl ~~;~~ [Q 9 

~ JtL "-'£] -~1 -

1I=;;11 ~ ~ 
~~ [51j ~ ~·~ -
B c= ... 

;:. r;:;,.. ;:'.J \t 1} ~;:. r;:;,..l] 

;:i y ;:'.J u I} ~ ;:i ~ 

~ ~ ~ u I) ~ ~ ~ 

None ~: OK :~ ( anc el 

Figure 6-59 
Icon dialog box 
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• To use an icon as a button: 

1 . Choose the Button tool. 

2. Create a new button or select one that already exists. 

Creating a new button automatically selects it. 

3. Choose Button Info from the Objects menu. 

Or double-click the button you want to work with. 

4. Click the Icon button In the dialog box. 

The dialog box in Figure 6-59 appears. If the button you've 
selected is already an icon, its picture is highlighted in the dialog 
box. 

5. Click the picture of the icon you want to use as your button. 

(Scroll through the choices, if necessary.) The icon whose 
picture you click replaces the selected button on your card or 
background. 

The advantage of using an icon is that picture and button are 
combined in one unit; this makes cutting, pasting, and moving 
buttons easier. 

When you use an icon, don't use either the check box or the radio 
button styles; otherwise, you won't see the icon. 

LinkTo ... 

Press this to create a link for the button you're creating. This option 
is especially important because it's the easiest way to establish 
connections between cards and stacks. Once you've made a link, 
pressing the button immediately moves you to the linked card or 
stack. 

LinkTo brings up a dialog box: 

D 

Go to destination. then aim link at: 

Figure 6-60 
Dialog box for making links 
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• To set a link between the current card and any other card in any 
stack: 

1. Choose the Button tool. 

2. Create a new button or select one that already exists. 

Creating a new button automatically selects it. 

3. Cilek Link To. 

Using a button that already exists cancels any previous link you 
might have set. 

4. Go to the card you want to link to. 

The dialog box stays on the screen while you're looking for the 
card. The card can be in the current stack or in any other stack. 

5. Cilek the choice that reflects which card you want to go to 
when you press the button. 

To link to the card you're on, click "This Card." 

To link to the first card in the current stack (no matter what card 
you're on), click "This Stack." 

After you click, HyperCard brings you back to the card with the 
selected button on it. 

If the dialog box gets in your way, grab it by its top bar and drag it 
where you want it to be. 

Warning Changing the name of a stack will break links you've made 
between any card in the renamed stack and any other card in 
any stack (Including links within the renamed stack Itself) . 
When you change the name of a stack, be sure to redo all the 
links. 

Script 

This feature, available only if Scripting is checked on the User 
Preferences card in the Home stack, brings up the script editor. You 
use the script editor to review or to write scripts that control what 
happens when the selected button is pressed. 

Writing scripts isn't covered in this guide; see your favorite 
bookseller for a selection of books on HyperTalk™, HyperCard's 
scripting language. 
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Field Info 

Field Info brings up information about the selected field. You can see 
and change the field's name, learn whether this is a background or a 
card field, find out the field's layer number (which tells you the layer 
of the field relative to other fields on this card or background), make 
the text in the field editable or locked, and determine the visual 
characteristics of both the text in the field and of the field itself. 

• To use Field Info: 

1. Select the Field tool from the Tools menu. 
2. Select the field you want to work with by clicking In It. 

3. Choose the Field Info command from the Objects menu. 

Or just double-click the field. The dialog box in Figure 6-61 
appears. 

Field Name: ~I ~·~~~ 
( ard field number: 2 

( ard field ID: 2 

0 Lock TeHt 

O Sho111 Lines 

0 lllide Margins 

Font ... 

Script ... 

Figure 6-61 
The Fie ld Info dialog box 

4. Design the field. 

Style: 

0 tran\parent 
()opaque 
0 rectangle 
()shadow 
(!::O Hrolling 

o Type or change the field's name. 

o Click Lock Text to prevent the text in the field from being 
changed. (Click it again to make the text editable.) 

o Click Show Lines so that you can see where the lines are in a field. 

o Click Wide Margins to include extra space in the left and right 
margins (useful for making text in fields easier to read). 

o Click the Font button to set or change the look of text in the field. 
(See "Text Style" elsewhere in this chapter.) 

o Click one of the style buttons to set the look of the field itself. 

5. When you're finished, click OK. 
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i :~m tr1at merr1J 'w'anderer of the night 
l _iest to Oberon, an1j make hi rn smile 
V./~1en I a fat an1j bean-fed ~1orse beguile, 
Ne1gh1n91n11 keness of a filly foal· 
And sometimes lurk in a qossi p·::: bo\v'l .. 
In the veriJ li kenes3 of a ro8steij crab 

Figure 6-62 
Field styles 

Scrolling field 

For more details on the features described here, see Chapter 4, 
"Text in HyperCard." 

Field number 

The Field number tells you what layer the field is on relative to other 
fields. A field that you've just created has the highest number, and is 
on the frontmost layer. The first field you create has the number 1, 
the second field the number 2, and so on. 

When you change a field's layer, you change its number and the 
numbers of all fields whose layers are also changed. (See "Bring 
Closer" and "Send Farther" later in this section.) When you delete a 
field, the numbers of any fields closer to the front are all reduced by 
one. 

Background fields and card fields are numbered separately. So 
there can be both a background field and a card field with the same 
number. 

The highest number a background or card field can have is the total 
number of fields on that background or card; the lowest number a 
background or card field can have is 1. (For more details, see "Tab 
Order and Layers" in Chapter 4, "Text in HyperCard.") 
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Field ID 

Every field has a field ID unique in its stack. Unlike a field's name or 
number, the ID number is permanent and unchangeable. When 
you delete a field, its ID number is permanently retired from the 
stack. Advanced HyperCard creators can use the ID number to 
create special field actions. 

Script 

This feature, available only if Scripting is checked on the User 
Preferences card in the Home stack, brings up the script editor. You 
use the script editor to review or to write scripts associated with the 
field. 

Writing scripts isn't covered in this guide; see your favorite 
bookseller for a selection of books on HyperTalk, HyperCard's 
scripting language. 

Card Info 
The Card Info command brings up information about the current 
card. 

• To use the Card Info command: 

1. Select any General tool from the Tools menu. 

2. Choose the Card Info command from the Objects menu. 

The dialog box in Figure 6-63 appears. 

Card Name: ~j T_r u_m_p _______ ~ 
Card Number: 58 out of 58 

Card 10: 32005 

Contain~ O card field~. 

Contain~ O card button~. 

D Can't delete card. 

Script .. . l: OK n 1: Cancel :1 

Figure 6-63 
Card Info dialog box 

Objects menu 155 



3. Type or change the card's name, check a box, or click one 
of the buttons. 

Click Script to look at, create, or change the card's script. 

4. Wh1en you're finished, click OK. 

Can't modify card 

When "Can't modify card" is checked, you can't make any changes 
to the card, including entering text into fields . To allow editing 
again, uncheck the box by clicking in it. 

Can't delete card 

When "Can't delete card" is checked, you can't remove the card 
from the stack. (You can, however, delete the stack, taking the 
protected card with it.) To allow the card to be removed, uncheck 
the box by clicking in it. 

Changing a card's position in a stack 

Card Number tells you the number of cards in the stack, and the 
current card's position in the stack. 

• To change a card's position in a stack: 

1. Move to the card whose position you want to change. 

2. Choose Cut Card from the Edit menu. 

3. Move to the card you want to come Immediately before the 
on'~ you've just cut. 

4. Ch1::>ose Paste Card from the Edit menu. 

Or press Command-V. 

The pasted card appears on the screen. 

To move a card to the first position in a stack requires several more 
steps. You must first make the wanted card the second one in a 
stack; then you have to move the first card in the stack out of the 
way. 
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• To change a card's position so that it's first in a stack: 

1. Move to the card whose position you want to change. 

2. Choose Cut Card from the Edit menu. 

3. Choose First from the Go menu. 

Or press Command-1. The first card in the stack appears. 

4. Choose Paste Card from the Edit menu. 

Or press Command-V. The pasted card appears from the 
screen; it is now the second card in the stack. 

5. Choose First from the Go menu again. 

Or press Command-I. The first card in the stack appears. 

6. Choose Cut Card from the Edit menu. 

Or press Command-X. The card you had originally set out to 
reposition is now first in the stack. 

7. Choose Paste Card from the Edit menu. 

Or press Command-V. The original first card is now second. 

Bkgnd Info 

Bkgnd Info brings up information about the current background. 
You can see and change the background's name, find out the 
number of cards that share the background, and learn how many 
fields and buttons this background has. 

• To use Bkgnd Info: 

1. Select any General tool from the Tools menu. 

2. Choose Bkgnd Info from the Objects menu. 

The dialog box in Figure 6-64 appears. 
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Bae kground Name: I ( rimina~ 
~~~~~~~~~ 

Background 10: 2691 

Background <,hared by 59 cards. 

( ontains 5 background field<,. 

( ontain<, O bac I< ground but tom. 

D Can't delete background. 

~:_o_K _j] 1: ca nc e I ·~ 

Figure 6-64 
Bkgnd Info dialog box 

3. Type or change the background's name, check a box, or 
cllck one of the buttons. 

4. When you're finished, click OK. 

Can't modify background 

When "Can't modify background" is checked, you can't edit the 
background in any way. To allow editing of the background again, 
uncheck the box by clicking in it 

Can't delete background 

When "Can't delete background" is checked, you can't delete the 
last card with this background in a stack. (You can, however, delete 
the stack-including the protected background). To deprotect the 
background, uncheck the box by clicking in it. 

For information on backgrounds, see "Background" earlier in this 
chapter. 
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General tools 

The General tools are Browse, 
Button. or Field. 

Stack Info 

The Stade Info command brings up information about the selected 
stade. You can see and change the stack's name, learn the number 
of cards in the stade and the amount of space the stade uses, and 
read the name of the folder and disk the stade resides on. 

• To use Stack Info: 

1. Select any general tool from the Tools menu. 

2. Choose the Stack Info command from the Objects menu. 

The dialog box in Figure 6-65 appears. 

Ulher e ~ rpo:H4per( a 

Volume or disk _____ _____ ,_t_a_ck _ _,~\~1 6-07-~-. --~ 
\lac~ , 1 y -.or 11 

Nested folder 
where stack resides I \izr 0

' ~tdcK , 
Free> in \tack: IL 11. 

Folder----------------------~ 

I .. er.pt . 

[___ 

Figure 6-65 
Stack Info dialog box 

3. Type or change the stack's name or click one of the buttons. 

4. When you're finished, click OK. 

Stack Name 

The name is the same as it appears in the Finder and in the 
Directory dialog box. You change the stack's name by typing in 
the Stack Name box. Changing the name here also changes the 
name in the Finder. 
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Warning 

[--== ~ =='.Jn -o 

Changing the name of a stack will break links you've made 
between any cara In the renamed stack and any other card 
In any stack (including links within the renamed stack Itself). 
When you change the name of a stack, be sure to redo all 
the links. 

Where 

The Where information tells you the full search path to where the 
stack resides, starting with the disk and ending with the folder that 
actually holds the stack. In Figure 6-65, the stack resides in the folder 
called Scot's stuff on the disk Harpo. A longer trail of names would 
indicate that the stack is further nested within folders. 

For more information on search paths, see "Search Paths" in 
Chapter 3. 

Free in Stack 

Free in Stack tells you the amount of extra memory space in the 
stack. (Extra space gets introduced into a stack each time you delete 
a card, background, field, or button.) Sometimes the Free number 
can be substantial, and the more extra space in a stack, the slower 
will actions be carried out, and the larger will be the stack. 

You can get rid of the extra space by using the Compact Stack 
command from the File menu. When you choose Stack Info again, 
Free in Stack will be zero K, and Size of Stack will likely be smaller. 

Bring Closer 
The Bring Closer command (or Command-plus) brings the 
selected button or field one layer closer and increases its number to 
reflect its current layer, relative to other buttons or fields. You'd 
want to bring an object closer when a second object is covering it, 
not allowing you to use the selected object. 
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Three buttons. in the order 
they were created 

Using Bring Closer. 
the farthest button 
Is now In the middle. 

[-=00 =~n-o 

.,..----------------------------------

Farthest button Closest button 

Middle button 

Farthest button Closest button 

Middle button 

Figure 6-66 
Moving a button closer 

The highest number an object can have in any case is the total 
number of objects of that type on a given card or background; the 
lowest number an object can have is 1. 

Send Farther 
The Send Farther command (or Command-minus) puts the selected 
button or field one layer further back and decreases its number to 
reflect its current layer relative to other buttons or fields . You'd 
want to move an object farther back when it's covering a second 
object. (You can't use a covered object effectively). 
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New Button 

This command automatically selects the button tool and creates a 
new button named "New Button" in the rounded rectangle style. 
The button appears in the center of the screen, selected so that you 
can move it or size it easily. 

Choosing New Button several times ---+----------<~~:!:~~_,......,[Iii!&.--..., 
produces several new buttons 
laid atop one another 
(separated here for clarity) . 

The button tool is automatically -H-rn I QI 
selected. so you see all buttons 
on the card. 

Figure 6-67 
Maklni;;i new buttons 

To change the name of the button or to change the way it looks, 
choose Button Info (described earlier in this section). 

To create a new background button, first choose Background from 
the Edit menu . 

New field 

This command automatically selects the field tool and creates a new 
transparent field. The field appears in the center of the screen, 
selected so that you can move it or size it easily. 

To name the field or to change the way it looks, choose Field Info 
(described earlier in this section). 

To create a new background field, first choose Background from the 
Edit menu. 

To read more about fields, see Chapter 4. 
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New Background 
New Background creates a new card with a new background in the 
current stack. The new background has no fields or buttons and is 
entirely blank. 

For details about backgrounds, see "Background" and "Bkgnd Info" 
earlier in this chapter. 

Paint menu 
The Paint menu commands work in conjunction with the Paint tools 
to manipulate and change pictures. You can choose these 
commands from the menu or, if you have Power Keys checked in 
the Options menu, you can use keyboard equivalents. 

The Paint menu appears only when you're using a Paint tool. 

For information on the Paint tools, see "Tools menu" earlier in this 
chapter. 

Select 3€S 
Select All 3€A 

Fill 
lnuert 
Pickup 
Darken 
Lighten 
Trace Edges 
Rotate Left 
Rotate Right 
Flip Llertical 
Flip Horizontal 

Opaque 
Tran5parent 

l Keep 
Reuert 

Figure 6-68 
Paint menu 
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Throughout this section, you'll see references to power keys. Power 
keys let you choose menu commands from the keyboard. For 
information on power keys, see "Power Keys" under the Options 
menu section of this chapter. 

Select 

Select (or either power key S or Command-S) lassos the shape you 
most recently drew. This command is particularly useful if you've 
just drawn a shape very close to or actually touching another shape, 
and you need to move the new shape. (In fact, you can draw a new 
shape on top of an old one, choose Select, and then drag the new 
shape away.) 

Draw over existing card picture. - --

Choose Select to select 
the shape you just drew. --------------- ---" 

Now you can move _ _____ __, 
or alter that shape. 

When you let go of the object, ---------------~ 
it becomes 'set' into 
the card picture. 

Figure 6-69 
Using Select 

If you've selected a shape with the Selection rectangle, choosing 
Select lassos the shape. If nothing is selected, Select lassos 
everything (the same effect as double-clicking the Lasso tool). 

The object stays selected until you select another tool, click the 
mouse, or keep the shape. (see "Keep" later in this section.) 
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Select All 

Select All (or either power key A or Command-A) selects the entire 
picture. This has the same effect as double-clicking the Selection 
tool. 

To select the entire background picture, first choose Background 
from the Edit menu; then choose Select All. 

Fill 
Fill (or power key F) colors the selected part of a picture with the 
current pattern. This command is especially useful for quickly 
changing the pattern of a large area. 

Select the picture --------r ') 
to fill. . 

·"\.: .. \~ 

Choose Fill.------------------~ 

Figure 6-70 
Using Fill 

For related commands see "Bucket" under "Tools Menu" and 
"Draw Filled" under "Options Menu" elsewhere in this chapter. 

Invert 
Invert (or power key I) reverses the color of the dots in the selected 
part of a picture, such that white dots become black and black dots 
become white. 

r-------------------------------
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Figure 6-71 
Inverting a picture 
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Warning When you Invert a lassoed area that Is not totally enclosed, 
HyperCard paints white the unenclosed part of the lassoed 
area; the whole Image seems to disappear. To get the Image 
back, choose Undo from the Edit menu. 

Pickup 

Pickup (or power key P) is like a cookie cutter for images. 

• To use Pickup: 

1. Select an Image. 

2. Drag it over a second image. 

3. Choose Pickup. 

The first image picks up the pattern of the second. 

4. Drag the first image away . 

• . 

l . This Is the shape whose 
pat~ern you want to change . 

2. This is the pattern 
you want to use. 

• 
3. Select the shape 

and move it over 
the pattern. 

Figure 6-72 
How Pickup works 

4. Choose the Pickup 5. Drag the shape 
command (or just away. 
press P if power keys 
are active) . 

See Chapter 5 for more examples using this command. 
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Darken 

Darken (or power key D) darkens the selected picture by randomly 
turning white dots black. Each time you choose Darken, a few more 
dots are changed. 

Original 

\ ,/! 
v 

Figure 6-73 
Using Darken 

Selected Darkened 

Keeping power key D pressed repeats the action until you release the 
key or until the selection is totally black. 

Lighten 

Lighten (or power key L) lightens the selected picture by randomly 
turning black dots light. Each time you choose Lighten, a few more 
dots are changed. 

1111111111111111111111111 

Origin al 

Figure 6-74 
Using Lighten 

Selected 

'I:.: 
I I p 

' " 
Lightened 

Keeping power key L pressed repeats the action until you release the 
key or until the selection is totally white. 
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Tracie Edges 

Trace Edges (or power key E) outlines black areas in a picture or in 
the selected part of a picture. Repeated tracing adds more outlines. 

• 8 
Original Edges Edges, twice Edges. three times 

Figure' 6-75 
Untraced, single-traced, and multltraced areas 

Rotate Left 

Rotate Left (or power key [ ) turns the selected portion of a picture 
90 degrees left. 

:- - --..--:- -------: 
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Figure 6-76 
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Rotating an image to the left 

Warning If any part of the picture moves off the screen during a rotation, 
you'll lose that part permanently-Undo can't save it. Try 
Revert to get back the lost portion. 
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Rotate Right 

Rotate Right (or power key J ) turns the selected portion of a picture 
90 degrees right. 

(l 
I
I_/ f"Jr, 

LI, J ... "I -· '-4_ .• 

·~ 
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Figure 6-77 
Rotating an image to the right 

Warning If any part of the picture moves off the screen during a rotation, 
you'll lose that part permanently-Undo can't save it. Try 
Revert to get back the lost portion. 

Flip Vertical 

Flip Vertical (or power key V) flips the selected portion of a picture 
vertically. 

·---------------,~,--
----------------------------------, 

! / .-, t-f 1° ·C· ,.., 1~-------
1,• t:: I I 1 I_.'-~ I 

-----------------------------------~ 

Figure 6-78 
Flipping an image vertically 
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Flip Horizontal 
Flip Horizontal (or power key H) flips the selected portion of a 
picture horizontally about its center line. 

-------------------/#'-, !~~.:-----------------] 
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Figure 6-79 
Flipping an Image horizontally 

Opaque 
Opaque (or power key O) makes the selected portion of a card 
picture opaque. (You can't see the portion of a background covered 
by an opaque foreground.) 

r, 
I I 

I I 

Selected Image ... 

Figure 6-80 
Opaque command 

...dragged and made opaque. 

To see what part of a picture is opaque, press Option-0; the opaque 
parts show as black. 
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Transparent 
Transparent (or power key T) makes the selected part of a card 
picture transparent. (You can see the background if it's covered by a 
transparent foreground.) Cards are transparent unless you make 
them opaque. 

r 1 

I I 
I I 

. - - ~· ·~ - - . 

Selected image ... 

Figure 6-81 
Transparent command 

Keep 

. .. dragged and made transparent. 

Keep (or Command-I() tells HyperCard that you want to keep the 
changes you've made to a picture. (Until you tell it differently, 
HyperCard assumes that you might want to throw away changes.) 
Use Revert to go back to the most recently kept version of the 
picture. (See "Revert" later in this section.) 

Changing cards, switching to or from Background, or clicking a 
General tool has the same effect as choosing Keep. 

Revert 
Revert (or power key R) restores the most recently kept version of 
the picture (or the selected part of it), throwing away any changes 
since the last Keep command or since you started painting on this 
picture. (HyperCard accepts a picture when you choose Keep, 
switch to or from Background, change cards, or click a General 
tool.) It's like Undo on a larger scale. 
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Options menu 
Commands on the Options menu modify the action of Paint tools. 

Grid 
F otBits 

../PowPr Keys 

Line ze ... 
Brush Shope .. . 
Fdit Pattern .. . 
Polygon SidPS ... 

Draw Filled 
Draw Centered 
Draw Multiple 

Figure 6-82 
Options menu 

The Options menu appears only when you're using a Paint tool. For 
information on the Paint tools, see "Tools Menu" earlier in this 
chapter. 

Many of these commands work when you press the appropriate 
power key. For information on power keys, see "Power Keys" later 
in this section. 

Grid 

Grid (or power key G) constrains where picture elements line up 
when you use many of the Paint tools. When Grid is on, you can 
move a selection, draw, or type only at specific intervals. These 
intervals are eight dots apart (just under 1/ 8th of an inch). 

A check appears next to Grid in the Options menu when this feature 
is on. 
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FatBits 
FatBits (or Option-F) lets you zoom in on a section of a picture to do 
close-in finish work and to edit your picture one dot at a time. Select 
an area and choose FatBits to blow up that area; then edit using any 
Paint tool. The tools work to scale. 

A movable window in the lower-left comer shows you what effect 
your editing changes have when the picture's full-sized again. (To 
move the little window, drag it by its title bar.) 

Figure 6-83 
FatBlts 
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A check appears next to FatBits in the Paint menu when FatBits 
is on. 
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Moving the picture around 

Pressing and holding the Option key in FatBits changes the tool 
you're using to a hand. As you drag the hand, you move the picture 
around so you can get to a part that might be outside your viewing 
area. When you release the Option key, the pointer changes back to 
the tool you were using. 

If you choose FatBits without first selecting an area, HypelCard 
zooms in on the part of the picture you last worked on. Hold down 
the Option key and use the grabbing hand to move to the part of the 
picture you want to work with. 

To leave FatBits, choose the FatBits command again. 

Entering and leaving FatBits quickly 

You can use any of these short ruts to enter or leave FatBits: 

o Press Option-F. 

o Double-click the Pencil tool. 

o Click in the small window. 

o With the Pencil tool selected, press the Command key while you 
click the mouse. 

Power Keys 
Power Keys lets you use the keyboard to evoke commands you'd 
ordinarily choose from a menu. When you choose Power Keys, 
pressing a single key (with or without the shift key pressed) does the 
work of choosing a menu command with the mouse. 

A power key modifies the way a particular tool acts. Table 6-3 shows 
a list of the commands that power keys invoke. 
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Table 6-3 
Power keys 

Command Key Menu 

Darken D Paint 
Draw Centered Con/om c Options 
Draw Multiple Con/om M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid Con/om G Options 
Invert I Paint 
Lighten L Paint 
Line size 1-4, 6, 8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate Left [ Paint 
Rotate Right 1 Paint 
Select s Paint 
Select All A Paint 
Select black pattern B Patterns 
Select white pattern w Patterns 
Trace Edges E Paint 
Transparent T Paint 

If you need more details, see the description of the specific 
command elsewhere in this chapter. 

A check appears next to power keys in the Options menu when this 
feature is on. To turn off power keys, choose Power Keys from the 
Options menu again. ('The check will disappear.) 

You can use several power keys in combination to create spectacular 
special effects. (Try C and M with the Oval tool, for example.) 

When you're using the Paint Text tool, power keys are temporarily 
disabled. 
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Line Size 
You use Line Size to set the thickness of lines and borders. 
Choosing this command brings up a dialog box: 

Click to confirm current size ---.,.,..---!-- -c ~-==~=---ii 
or click another size. 11 I ! ! r I: r r ~ I! 

I L_'_._. . - - ~ -
I~·-·--~ l, 

Power keys----------

Figure 6-84 
Line sizes 

To select a thickness, click on it (or use a power key equivalent). You 
can also bring up the Line Size dialog box by double-clicking the 
Line tool. 

Brush Shape 
Use Brush Shape to select a shape for the Brush. Each shape has a 
different effect when you use it To select a shape, move the pointer 
to the shape you want; then click. 

Double-clicking the Brush also brings up the Brush Shapes dialog 
box. For details on the Brush tool, see "Tools Menu" earlier in this 
chapter. 
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Edit Pattern 

Edit Pattern lets you edit the pattern currently selected on the 
Pattern menu by clicking dots on or off. When you choose Edit 
Pattern, the pattern editor appears. See Figure 6-86. 

OK [ Cancel 

Figure 6-86 
Pattern editor 

To edit a pattern, move the pointer to the dot you want to change; 
then click. Clicking where there is no dot adds one; clicking on an 
existing dot takes the dot away. 

Double-clicking a pattern on the Pattern palette also brings up the 
pattern editor. 

Using a nonstandard pattern 

You can replace a pattern on the Pattern palette with any pattern on 
the screen. (See Figure 6-87.) 

• To use a pattern already on the screen: 

1. Make sure the new pattern ls on the screen. 

2. Ciiek the pattern on the Pattern palette to be replaced. 

3. Choose Edit Pattern from the Options menu. 

(Or double-click the pattern to be replaced if you're using the 
Pattern palette.) The pattern editor appears showing the selected 
pattern. 

4. Ciiek anywhere on the new pattern In the picture. 

The old pattern in the pattern editor is replaced by the new one. 

5. Click OK. 

The new pattern replaces the selected pattern in the Pattern 
menu. 
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• Click anywhere on the 
new pattern in the picture 
to place the pattern In the 
editor. 

Select a pattern to 
be replaced. 

Bring up the pattern editor. he new pattern is saved 
with the stack when you 
click OK. 

Click the shape you want to use . 

Figure 6-87 
Switching patterns 

The new pattern is saved with the stack. 

Polygon Sides 

You use Polygon Sides to select a shape for the Regular Polygon 
tool. 

Figura 6-88 
Selecting a shape 

You can also bring up this dialog box by double-clicking the Regular 
Polygon tool. 

For details on the Regular Polygon tool, see "Tools Menu" earlier in 
this chapter. 

Draw Filled 

Draw Filled fills shapes as you draw them. It uses the current pattern 
to fill the shapes. 
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Current pattern ------------------------~ 

-(~ Draw Filled not checked ~ 

Draw Fiiied checked ----------------~ 

Figure 6-89 
Using Draw Filled 

The Tools menu looks different when Draw Filled is turned on. 
The tools that it affects (Rectangle, Rounded Rectangle, Oval, 
Curve, Polygon, and Regular Polygon) have slightly different 
representations.(See Figure 6-90.) 
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Draw Filled on 

Figure 6-90 
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Draw Filled off 

Tools menu with Draw Filled turned on and turned off 

•!• Draw Filled short cut: Double-clicking any of the tools that Draw 
Filled affects (except Regular Polygon) turns Draw Filled on and 
off. 

When Draw Filled is turned on, a check mark appears next to it in 
the menu. To turn off Draw Filled, choose the command again. 

Draw Filled with the Polygon tool 

If Draw Filled is turned on while you're using the Polygon tool, 
HyperCard draws a straight line between the polygon's starting and 
ending points when you double-click to finish your polygon. The 
resulting enclosed shape is filled with the current pattern. 
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HyperCard draws this line .------------ ----0 

~/ ~ 
Draw Filled not checked Draw Filled checked 

FigurEt 6-91 
Creating an enclosed, filled polygon 

Draw Filled with the Curve tool 

If Draw Filled is turned on while you're using the Curve tool, 
HyperCard draws a straight line connecting the.starting and ending 
points of the shape when you release the mouse button; then it fills 
the shape with the selected pattern. 

Curve tool with Draw Filled off Curve tool with Draw Filled on 

Figure 6-92 
Creating a filled, curved shape 

Draw Centered 
Draw Centered (or power key C) lets you draw out from a center 
point. (You usually draw lines, rectangles, and ovals starting from 
an edge or corner.) 
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Draw Multiple checked 
In Options menu 

Draw Multiple unchecked 

Figure 6-93 
Drawings made with Draw Centered checked 

Draw Centered affects the following tools: Line, Rectangle, 
Rounded Rectangle, Oval, Curve, Polygon, and Regular Polygon. 

When Draw Centered is turned on, a check mark appears next to it 
in the menu. To turn off Draw Centered, choose the command 
again. 

Draw Multiple 

Draw Multiple (or power key M) draws multiple images as you drag 
with the mouse. 

~~I) OIJ 1 IJI Ill 
... -~~·· 

,--\ 

\ I 
l __ 

Rectangle Rounded Rectangle Oval Regular Polygon 

Figure 6-94 
Drawing shapes with and without Draw Multiple checked 
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Draw Multiple affects the following tools: Line, Rectangle, Rounded 
Rectangle, Oval, and Regular Polygon. 

When Draw Multiple is working, a check mark appears next to it in 
the menu. To turn off Draw Multiple, choose it again. 

Patterns menu 
The Patterns menu is a palette from which you pick the pattern you 
want to use for painting. Select the paint pattern you want to use to 
fill shapes and (if you specify) to draw borders. The menu can be 
"torn off' and the palette placed anywhere on the screen. 

Figure 6-95 
Torn-off Pattern palette 

• To create a movable Pattern palette: 

• Drc::ig down through the menu, either past the bottom or 
beyond either side. 

Put the palette wherever you want by dragging. To move the palette 
around, drag it by its top bar or by any edge. To put it away, click its 
close box. If it gets stuck in an awkward place, just tear off a new 
pattern palette; the old one disappears. 
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Editing patterns 

To edit a pattern, select the pattern you want to edit and choose Edit 
Pattern from the Options menu (or double-click the pattern you 
want to edit); when the pattern editor appears, click a dot to make 
the dot go away or click where there is no dot to make one appear. 
The new pattern is saved with the stack. 
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Figure 6-96 
Pattern editor 

To fill enclosed shapes with the selected pattern as you draw them, 
check the Draw Filled command on the Options menu. 

To fill enclosed shapes after you draw them, use the Bucket 
(described earlier in this chapter). 

To fill a selected area with the current pattern, choose Fill under 
the Paint menu. 

To draw borders in the selected pattern, press the Option key as 
you drag. 

•!• Patterns menu short cut: Press Tab with any Paint tool selected 
or double-dick the Bucket tool to make the Patterns palette 
appear and disappear. 
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lcut :~:HI 

Com~and/ 
Command key 

Character key 

As in all Macintosh applications, you issue many HyperCard 
commands by making choices from menus. But HyperCard extends 
what you can do by making many commands available from the 
keyboard. In fact, there's a whole range of commands that you can 
issue only by pressing one or more keys and using the mouse at the 
same time. 

o "Command Key Menu Commands" gives a list of the commands 
you execute by first pressing and holding down the Command 
key and then a specific character. 

o "Browsing" shows you how to get around the stacks and from card 
to card quickly. 

o "Text Editing" lists the keys to press to change fonts, type sizes, 
styles, and so on. 

o "Paint Power Keys" lists the graphics commands you can issue 
with a single keystroke. 

o "Dragging With Modifier Keys" explains what happens if you 
drag both with a particular tool selected and with the Command, 
Option, or Shift key held down. 

o "Miscellaneous keyboard shortcuts" lists the shortcuts that don't 
fit easily into other areas. 

Because all these sections are really summaries, you'll also find 
information about where to look for more help. 

Command key menu commands 
As you look at a menu, you'll see some commands followed by a 
symbol and a character. The propeller-shaped symbol represents 
the Command key. You can issue such a menu command by 
pressing the Command key at the same time that you press the 
specified character key. 

•:• Command or Apple: The Command key is marked by a propeller­
shaped symbol. On some Macintosh keyboards, the key also has 
an Apple symbol, and some Macintosh manuals might call it the 
Apple key. Both names refer to the same key. 

The first chart shows the keyboard equivalent keys by menu; the 
second chart shows them in alphabetic order by command name. 
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Table 7·1 
Keyboard equivalents by menu 

Menu Keyboard equivalent Command 

Edit Command-B Background (toggle) 
Command-C Copy 
Command-N New Card 
Command-T Text Style 
Command-V Paste 
Command-X Cut 
Command-Z Undo 

File Command-0 Open Stack 
Command-P Print Card 
Command-Q Quit HyperCard 

Go Command-F Find 
Command-H Home 
Command-M Message (toggle) 
Command-R Recent 
Command-1 First 
Command-2 Prev 
Command-3 Next 
Command-4 Last 
Command-? Help 
Command-Tilde (-) Back 

Objects Command-plus ( +) Bring Closer 
Command-minus (-) Send Farther 

Paint Command-A Select All 
Command-K Keep 
Command-S Select 

Table 7-2 
Keyboard equivalents by command 

Command Keyboard equivalent Menu 

Back Command-Tilde (-) Go 
Background Command-B Edit 
Bring Closer Command-plus (+) Objects 
Copy Command-C Edit 
Cut Command-X Edit 
Find Command-F Go 
First Command-1 Go 
Help Command-? Go 
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Table 7-2 (continued) 
Keyboard equivalents by command 

Keyboard equivalent Command Menu 

Home Command-H Go 
Keep Command-K Paint 
Last Command-4 Go 
Message Command-M Go 
New Card Command-N Edit 
Next Command-3 Go 
Open Stack Command-0 File 
Paste Command-V Edit 
Prev Command-2 Go 
Print Card Command-P File 
Quit HyperCard Command-Q File 
Recent Command-R Go 
Select Command-S Paint 
Select All Command-A Paint 
Send Farther Command-minus (-) Objects 
Text Style Command-T Edit 
Undo Command-Z Edit 

For details on all these commands, see Chapter 6. 

Browsing 
You can use any of these keystrokes except Tilde ( - ) and Esc at any 
time. To use Tilde or Esc for browsing, you must be using one of the 
General tools. When a Paint tool is selected, pressing the Tilde key 
undoes the last Paint action; use Command-Tilde to move to the 
most recently viewed card. 

For combinations that require you to use the Command key, be sure 
to press and hold down the Command key before you press the 
second key. 
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Table 7-3 
Browsing from the keyboard 

Destination 

Help 

Home 

First card in stack 

Previous card in stack 

Next card in stack 

Last card in stack 

Retrace through cards viewed 

Forward through retraced cards 

Record of cards recently seen 

Select Browse tool 

Store current card's location for 
quick return (Many locations 
can be stored) 

Return to stored location 
Oast in-first out order) 

Next field on card 

Previous field on card 

Keyboard short cut 

Command-? 

Command-H 

Command-1 or 
Command-Left Arrow 

Command-2 or Left Arrow 

Command-3 or Right Arrow 

Command-4 or 
Command-Right Arrow 

Tilde(-), Esc, or Down Arrow 

Up Arrow 

Command-R 

Command-Tab 

Command-Down Arrow 

Command-Up Arrow 

Tab 

Shift-Tab 

For a tutorial on browsing, see Chapter 1. For information on 
creating buttons for browsing, see "Button Tool" and "New Button" 
in Chapter 6. 
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Text· editing 
You can use the combination keystrokes in Table 7-4 when you're 
using either the Browse tool or the Paint Text tool. Be sure to press 
and hold down the Command key before you press the character 
key. 

Table 7-4 
Text editing keys 

Function 

Font, next in system 
Font, previous in system 
Text style dialog box 
Space, less between lines 
Space, more between lines 
Text size, larger 
Text size, smaller 

Key combination 

Command-Shift-> 
Command-Shift-< 
Command-T 
Command-Option-< 
Command-Option-> 
Command-> 
Command-< 

For details on creating the fields in which regular (as opposed to 
Paint) text appears, see Chapter 4. See Chapter 6 for information 
on both regular and Paint text. 

Paint power keys 
Table 7-5, which also appears in Chapter 5, shows the Paint power 
keys. You must be using a Paint tool with Power Keys checked in the 
Options menu . "Toggle" after a command means that pressing the 
same key turns the option off. 
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Table 7-5 
Power keys ava ilable w hen using Paint tools 

Command Key Menu 

Black pattern B Patterns 
Darken D Paint 
Draw Centered (toggle) c Options 
Draw Multiple (toggle) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (toggle) G Options 
Invert I Paint 
Lighten L Paint 
Line size 1-4, 6, 8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate Left [ Paint 
Rotate Right l Paint 
Select s Paint 
Select All A Paint 
Trace Edges E Paint 
Transparent T Paint 
White pattern w Patterns 

Dragging with modifier keys 
Table 7-6 shows you what happens when you drag with different 
tools selected and you hold down different modifier keys. Tools that 
aren't listed aren't affected by modifiers. 

For detailed information on all the tools, see Chapter 6. 
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Table 7-6 
Effects of modified dragging 

Tool 

Button 
Field 
Selection 

Lasso 

Line 
Eraser 
Pencil 
Rectangle 
Curve 
Brush 

Spray 

Rounded Rectangle 
Polygon 
Oval 
Regular polygon 

With Command key With Shift key With Option key 

Create button Move button horizontal or vertical Copy button 
Create field Move field horizontal or vertical Copy field 
Select tightly Move selection horizontal 

or vertical Copy selection 
Lasso everything Move selection horizontal 

or vertical Copy selection 
No effect Draw at 15° angles Draw with pattern 
Erase white Erase straight horizontal or vertical No effect 
Get/leave FatBits Draw straight horizontal or vertical No effect 
No effect 
No effect 
Erase what you 

paint over 
Erase what you 

spray over 
No effect 
No effect 
No effect 
No effect 

Draw square Patterned border 
No effect Patterned border 
Paint straight horizontal or vertical No effect 

Spray straight horizontal or vertical No effect 

Draw square with round corners Patterned border 
Draw at 15° angles Draw with pattern 
Draw circle Patterned border 
Rotate in 15° increments Patterned border 

Miscellaneous keyboard short cuts 
The following table lists keyboard short cuts that don't fit easily into 
other categories. 

Table :7-7 
Miscel laneous actions 

Key or combination 

Comma nd-Option• 

Effect 

Show all buttons (Browse or Button tool 
selected) 

Command-Shift-Option• Show all fields (Field tool selected) 

Command-Backspace Delete current card 

192 Chapter 7: Keyboard Commands 



Table 7-7 (continued) 
Miscellaneous actions 

Key or combination 

Command-Period 

Command-Space bar 

Command-Tab 

Command-Tilde ( - ) 

Command-Shift-V 

Command-Down Arrow 

Command-Up Arrow 

Option-D 

Option-0 

Option-Tab 

Tilde (-) 

Down Arrow 

Up Arrow 

Tab 

Effect 

Cancel current action (like Printing) 

Hide and show menu bar 

Select Browse tool 

Go to most recent card displayed 
(Paint tool selected) 

Paste miniature card image (with card in 
Clipboard) 

Store current card's location for quick 
return (you can have many locations 
stored) 

Return to stored location 
(last in-first out order) 

Show card picture (with Paint tool) 

Show opaque areas (with Paint tool) 

Toggle Tools palette 

Same as Back command (General tool 
selected) 

Undo most recent action (Paint tool 
selected) 

Same as Back command (any tool 
selected) 

Come forward through reviewed cards 

Toggle Patterns palette (Paint tool 
selected) 

Advance insertion point to next 
background field (Browse tool 
selected) 

•Darker outlines indicate background fields or buttons. 

Holding down the Command key before and as you drag through 
the File menu shows the full file menu, even if Browsing or Typing is 
clicked on the User Preferences card in the Home stack and/or in a 
stack's Protect Stack dialog. 
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Appendix A 

Common HyperCard 
Messages 

You can send a one-line command (called a message) to 
HyperCard through the Message box. Use messages to save time 
traveling through stacks, to launch other applications, and to 
retrieve important information quickly. 

• To send a message: 

1. Choose Message from the Go menu. 

Or press Command-M. 

2. Type the message into the Message box. 

Use the syntax shown in the message descriptions section that 
follows. 

3. Press Return. 

You can also press Enter. 

Message descriptions 
This section describes the most common HyperCard messages that 
you might type into the Message box. The syntax is in its simplest 
form . 
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Here's an example for the Go message, followed by a list of ways you 
could type the same message to get to the same place (the first card 
of the Art Ideas stack): 

Go Art Ideas 
Go to Art Ideas 
Go stack Art Ideas 
Go to stack Art Ideas 
Go to card 1 of stack Art Ideas 

HyperTalk: The source of all messages 
The material in this appendix represents a small subset of 
HyperTalk, HypetCard's scripting language. 

Using HyperTalk, you write scripts for buttons, fields, cards, 
backgrounds, and stacks; these scripts give you much greater 
control over HypetCard than is available using only the menu 
commands. HyperTalk is an easy language to learn, and is 
especially good as a first language for novice programmers. 

Several excellent books have been written about HyperTalk; consult 
your favorite bookseller to see what's currently available. 

How to read messages 
Here are some hints to help you read the messages in this appendix 
and to use these messages: 

o A message is all on one line. 

o The first word of a message is its name. When a message is more 
than one word, you'll find a note saying so. 

o Words in italics stand for other words. For example, menultem 
means the name of any item in any menu. 

o Some parts are optional helper words; they appear in square 
brackets (but don't type the brackets into the Message box). 

o The remaining part of a message is usually a description of 
something ("with document, n for example). 

o All words can be in capital or small letters. 
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Date 
The Date 

The Long Date 

'Ibis message puts the current date into the Message box in the form 
mm/dd/yy: 

Type The Date 

You get 3/27/87 

Alternatively, Long Date produces a full date: 

Type 

You get 

The Long Date 

Friday, March 27, 1987 (or whatever the date is, in this 
form) 

You must start this message with the word "The." 

DoMenu 
DoMenu menultem 

This message does menultem as if you had chosen the command 
from a HyperCard menu: 

Type DoMenu Home 

You get the first card in the Home stack 

(Home is on the Go menu.) You must type menultem exactly as it 
appears in the menu. For example, to open a stack, type 

DoMenu Open Stack ... 

The three dots are part of the menu item name. 

Go 
Go [to J description of a card or stack 

'Ibis message brings you to the designated card in the designated 
stack. If you designate a stack without designating a card, you go to 
the first card in that stack: 

Type 

You get 

Go Art Ideas 

the first card in the Art Ideas stack 
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If the stack you specify isn't in the Help Stacks folder or the 
HyperCard Stacks folder, be sure to list the search path on the 
appropriate card in the Home stack. (See "Search Paths" in 
Chapter 3). 

Hide 

Hide tool window 
Hide pattern window 
Hide message 
Hide menubar 

This message hides what you tell it to. It's as though you'd clicked a 
close box. Hide menubar hides the menu bar, giving you more 
display space (as though you'd pressed Command-Space bar). 

Type 

You get 

Hide tool window 

Tools menu goes away 

Also see Show, later in this appendix. 

Open 
Open application 

Open document with application 

This command opens the application you've named. If you name a 
document, HyperCard opens that document with the application 
you name. 

Type Open Memo with MacWrite 

You get the document Memo opened in MacWrite 

If the document or application you specify isn't at the top level 
of the file hierarchy, be sure that the search path is listed on 
the appropriate card in the Home stack. (See "Search Paths" in 
Chapter 3). 

When you quit the application, you end up back at the card you were 
on when you sent the message. 
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Pop Card 

Pop Card 

This command retrieves a card you've marked with the Push 
Card command (described later in this appendix). Once a card is 
retrieved, you can't get it back again using Pop Card unless you 
mark it again using Push Card 

Pushed cards are popped in last-in, first-out order. 

Last In. first out---------
----- ----- -1 

'" -':_ -:~--- ----!_ 1 

'====== 
~ ~--- - = ~ 

!i~---~ 1 1 
- _ _]!I =5;_ ;:=lj[ 

First In. last out _ . 

Figure A-1 
Popping order 

Pressing Command-Up Airow does the same thing as sending a 
Pop Card command. 

•:• Unfamtliar card popped: Occasionally when you issue a Pop 
Card command, a card might appear that you didn't push. 
HyperTalk scripts can issue their own Push Card commands 
as you browse through stacks; your Pop Card commands make 
these pushed cards appear. Eventually, any card that you pushed 
will also appear; just keep popping. 

Also see Push Card, next in this appendix. 
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Push Card 

Push Card 

This command lets you mark the card you're working on for quick 
retrieval later. Use this command to mark a card, wander through 
the stacks (perhaps to find a graphic you want to paste onto the 
marked card), and then retrieve the card again using the Pop 
Card command. 

You can push any number of cards for later retrieval. 

Pushing Command-Down Arrow does the same thing as sending a 
Push Card command. 

Also see Pop Card, the immediately previous command in this 
appendix. 

Show 

Show tool window 
Show pattern window 
Show message 
Show menubar 

This message shows what you tell it to. It's as though you'd torn off a 
palette, or chosen Message from the Go menu. Show menubar 
makes the menu bar visible at the top of the window. 

Type 

You get 

Show pattern window 

The patterns palette on the screen 

If you try to show something that isn't hidden, nothing happens. 

Also see Hide, earlier in this appendix. 

Show Cards 
Show cards 

Show all cards 
Show number of cards 

This message shows the cards in the current stack in rapid 
succession. 
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Show cards shows all cards in the current stack repeatedly until 
you click the mouse. Show all cards goes rapidly through the 
stack once, starting and ending with the current card. Show 
number of cards shows as many cards as you specify, starting 
with the card following the current card. 

Type 

You get 

Show 4 cards 

next four cards in stack briefly on screen 

To stop Show Cards at any point, click the mouse. The card 
you're viewing when you click the mouse remains on the screen. 

Time 

The Time 
The Long Time 

This message puts the current time into the Message box in the form 
hh:mm AM or PM 

Type 

You get 

The Time 

2:57 PM (or whatever time it is, in this form) 

Alternatively, Long time includes seconds: 

Type 

You get 

The Long Time 

2:57:23 PM 

You have to start this message with the word "The." 
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Appendix B 

HyperCard Disks 

This appendix is a directory to the stacks and other files that come 
with HyperCard. It tells you what files come with HyperCard, what 
disk each document is on, and what each document is for. 

HyperCard and Stacks 
The HyperCard and Stacks disk contains the HyperCard 
application, the HyperCard Stacks folder, plus a folder called More 
Stacks. The HyperCard Stacks folder holds the following stacks: 

Address 
Datebook 
File Index 
Home 
HyperCalc 
Phone 
Quotations 
Version 1.2 Release Notes 

More Stacks contains the following stacks: 

Area Codes 
Clip Art 
Documents 
Plots 
Slide Show 

203 



HyperCard Help 
The HyperCard Help disk contains a single folder, Help Stacks. The 
folder contains three stacks: 

Help 
Help Index 
Help Samples 

HyperCard Ideas 
The HyperCard Ideas disk holds a single folder, Idea Stacks. The 
folder contains four stacks: 

Art Ideas 
Button Ideas 
Card Ideas 
Stack Ideas 

Abc:>ut the provided HyperCard documents 
Here's a description of the documents that come with HyperCard, 
and what you'd use them for: 

Address 

Area Codes 

Art Ideas 

Book Shelf 

Button Ideas 
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A name and address file. Keep all your 
important names and addresses here. 

A listing of all the telephone area codes in 
Canada and the United States. You can look for 
an area code if you know the city (or nearby 
city), or you can find the city served by any 
area code. 

A collection of art you can use in your own 
documents. Use these to help create pictures 
and buttons. 

An example of a graphic table of contents. 

Library of working buttons. Cut and paste these 
to your own documents. 



Card Ideas 

Clip Art 

Date book 

Documents 

File Index 

Help 

Help Samples 

Help Index 

Home 

HyperCalc 

Phone 

Plots 

Quotations 

Version 1.2 
Release Notes 

Individual cards you might include in 
documents that you create. (A card is 
HyperCard's fundamental unit of 
information.) 

Artwork you can use to dress up your own 
HyperCard documents. 

Monthly calendar, week-at-a-peek memo 
book, plus a things-to-do list. Use it to organize 
your daily chores and to keep track of 
important meetings. 

A collection of document examples. 

A set of file cards for whatever you need to file. 

On-line directions for using HyperCard. It 
provides hints and tips for using all of 
HyperCard's features. 

Part of the on-line Help system. 

Part of the on-line Help system. 

A graphic directory of all the documents that 
come with HyperCard. Use it as your "base of 
operations." You must have Home for 
HyperCard to operate. 

A mini-spreadsheet. 

A dialer for your telephone. 

A demonstration of HyperCard's ability to plot 
information in different formats. 

A collection of famous quotations, designed to 
help you learn to use HyperCard. 

Information about this version of HyperCard, 
too recent to be included in the user's guide. 
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Slide Show 

Stack Ideas 

A collection of clip art, digitally scanned into 
the Macintosh. 

Collection of cards to use as templates for 
creating new stacks. 

Important You must have the Home stack on the same disk as the 
HyperCard application for HyperCard to operate. You can 
remove all other stacks. but you must not remove the Home 
stack. 
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Glossary 

Apple key: See Command key. 

background: That which is shared by a number 
of cards; a card's basic template. The background 
is composed of the background picture, 
background fields, and background buttons. 

background button: A button that appears on, 
and whose actions are the same for, all cards with 
the same background. Contrast with card button. 

background field: A field whose size, position, 
and text attributes remain constant on all cards 
associated with a particular background, but whose 
text changes from card to card. Contrast with card 
field. 

background picture: A picture that applies to a 
series of cards. You see the Background picture 
by choosing Background from the Edit menu. 
Contrast with card picture. 

browse: To wander through HyperCard's stacks. 

Browse tool: The tool you use to click buttons and 
to set the insertion point in fields. 

button: Something that initiates a HyperCard 
action (making a connection, launching an 
application, starting a visual or sound effect, 
and so on) when you dick it. See also background 
button, card button. 

button action: That which happens when a button 
is pressed. 

Button tool: The tool you use to create, change, 
and select buttons. 

card: HyperCard's basic entity-one screenful of 
information. 

card button: A button that appears on, and whose 
actions apply to, a single card. Contrast with 
background button. 

card field: A field whose size, position, text 
attributes, and contents are limited to the card 
on which the field is created. Contrast with 
background field. 

card picture: A picture that applies to a specific 
card. Contrast with background picture. 

Command key: The key at the lower-left side of 
the keyboard that has a propeller-shaped symbol. 
On some keyboards this key also has an Apple 
symbol and might be called the Apple key. 

current: (adj.) The one you're using now. For 
example, the current card is the one you can see 
on your screen. 

field: The place where you type regular (as 
opposed to Paint) text. Also, the tool you use 
to create a field. HyperCard has two kinds of 
fields-card fields and background fields. 

Field tool: The tool you use to create, change, 
and select fields . 

General tool: Any HyperCard tool that isn't a 
Paint tool. The General tools are Browse, Button, 
and Field. 
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Home card: A special card that acts as a pictorial 
index to stacks. Choose Home from the Go menu 
to get to Home (or press Command-H). 

HyperTalk: HyperCard's built-in script language 
for HyperCard users. 

keyboard equivalent key: A key you press 
together with the Command key to issue a menu 
command. 

layer: The order of a button or field relative to 
other buttons or fields on the same card and 
background. The object created most recently 
is ordinarily the topmost object (that is on the 

front layer). 

MacPaint document: Document created by 
the Macintosh MacPaint application, or any 
application that creates MacPaint-compatible 
graphics. 

message: A command you send to HyperCard 
through a script or through the Message box. 
Some examples of HyperTalk messages are Go, 
Show, Hide, Pop Card, and Push Card. 

on-line help: assistance you can get from an 
application program while it's running. In this 
user's guide, on-line help refers to HyperCard's 
disk-based Help system. 

Paint text: Text you type using the Paint Text tool. 
Paint text can appear anywhere, while regular 
text must appear in a field created with the Field 
tool. When you finalize Paint text by clicking, it 
becomes part of a picture. 

Paint tool: Any HyperCard tool you use to make 
pictures. Tools include Lasso, Brush, Spray, 
Eraser, Paint Text, and many others. 

palette: The name for a tear-off menu when 
it's been torn off. A palette remains visible on 
the screen so you can use it without having to 
pull down the menu. HyperCard has two 
palettes-Tools and Patterns. 
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picture: Any graphic or part of a graphic created 
with a Paint tool. Also, an imported MacPaint 
document or part of a MacPaint document. 

point: In printing, the measurement of the height 
of a text character; one point is about 1n2 of an 
inch. When you select a font, you can also select a 
point size, such as 10-point, 12-point, and so on. 

power key: One of a number of keys on the 
Macintosh keyboard you can press to initiate a 
menu action when a Paint tool is active. Power keys 
are enabled when you choose Power Keys from the 
Options menu or you check Power Keys in the User 
Preferences card in the Home stack. 

Recent: A special dialog box that holds pictorial 
representations of the last 42 unique cards viewed. 
Choose Recent from the Go menu to get the dialog 
box. 

regular text: Text you type inside a field. You use 
the Browse tool to set an insertion point in a field 
and then type. Regular text is editable and 
searchable, while Paint text is not 

script: A series of commands written in 
HyperTalk and associated with a particular 
object. 

search path: The route the computer must follow 
to retrieve a f.tle you ask for. 

stack: A group of cards based on the same theme. 
A HyperCard document. See also card. 

tear-off menu: A menu that you can convert to a 
palette by dragging the pointer beyond the 
menu's edge. HyperCard has two tear-off 
menus--Tools and Patterns. 

text field: See field. 



text property: A quality or attribute of a 
character's appearance. Properties include style, 
font, and size. 

tool: An implement you use to do work. 
HyperCard has tools for browsing through cards 
and stacks, creating text fields, editing text, 
making buttons, and creating and editing pictures. 

user level: The setting on the User Preferences 
card in the Horne stack that lets you use 
HyperCard's tools and abilities. Five user levels 
are available: Browsing, Typing, Painting, 
Authoring, and Scripting. 
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A 
addresses, searching for 7-10. 

See also Address stack 
Address stack (tutorial) 7- 9, 

14. See also card(s); stack(s) 
alignment 69-70, 100-101, 114 
alphabetical order, cards and 

stacks 13. See also sorting 
angles, changing and constraining 

137. See also Line tool 
Apple key (Command key) 186 
A1t Ideas stack 24- 25 
Authoring level 51. See also User 

Preferences card; user levels 
authoring (tutorial) 31-46 

B 
Back command (Go menu) 

116-117 
background(s) 115-116. 

See also Bkgnd Info 
buttons 40-44, 115-116, 162 
changing 157-158 
copying 86, 110-111 
creating 115-116, 163 
cutting 108 
definition of 40 
deleting 93, 130, 158 
fields. See background fields 
names, changing 158 
New Card command and 112 
pictures. See background 

pictures 
selected in printing 99 

Index 

stripes on Menu bar 115-116 
versus cards 40-44 

background buttons 40-44, 
115-116, 162 

covered by card buttons 115 
creating 115-116, 162 

Background command (Edit 
menu) 115-116 

background fields 40-44, 115-116 
changing 58 
creating 56, 162, 115 
deleting 130 
description of 41, 54, 115-116 
numbers 154 
searching 121 
versus card fields 44 

background pictures 40-44 
editing 115-116 
erasing 136 
selecting 165 

Backspace key 112 
Bkgnd Info command (Objects 

menu) 157-158. See also 
background(s) 

blowing up pictures. See FatBits 
borderless rectangles 139 
borders. See also Line Size; Line 

tool; Oval tool; Regular 
Polygon tool 

changing 137-138, 145, 176 
drawing with cuITent pattern 145 
filled with current pattern 145 
in patterns 183 

Bring Closer command (Objects 
menu) 61, 160-161 

Browse tool 4, 18, 59, 65-66, 117 
creating editable text with 54, 

65-66 
versus Button 128 

browsing 3-5, 124, 188-189. See 
also Browse tool 

keyboard commands 188-189 
powers associated with 92 
recap of 10 
tutorial 3-5 

Browsing level 51. See also User 
Preferences card; user levels 

Bmsh (Tools menu) 135-136. 
See also Bmsh Shape; painting; 
Paint tools 

dragging with modifier keys 79 
erasing with 136 
painting straight or horizontal 

lines with 136 
painting with current pattern 135 

Bmsh Shape command (Options 
menu) 135, 176 

Bucket 140-141 
button(s) 147-152. See also 

Button Ideas; Button Info; 
Button tool; icons; pictures 

activating 4 
background 40-44, 115-116, 

162 
Browse tool and 126 
card 41, 115, 129 
copying 36-37, 109, 128 
creating 162 
cutting 128 
deleting 35, 128 
Help, adding 36 
highlighted 149-150 
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icons used as 150-151 
information about 147-152 
layers 148 
linking 151-152 
moving 34-35, 128, 160-161 
moving dotted line around 35 
names of 148 
numbers 148 
opaque 149 
pasting 111 
rectangle 149 
rounded rectangle 149 
selecting 35, 127-128 
shadowed 149 
shapes of 149 
sizing 128 
style of 149 
Telephone 34-35 
transparent 107, 149 
viewing 18 

Button Ideas 36 
Button Info command (Objects 

menu) 147-152. See also 
button(s); Button tool 

Auto hilite 149-151 
Button ID 148 
Button name 148 
Button number and layers 148 
dialog box 147 
Icon 150-151 
LinkTo 151-152 
Script 152 
Show name 148 
Style 149 

Button tool (Tools menu) 126-129 

c 
cameras 74, 81 
canceling actions. See cutting; 

deleting; Undo 
card(s). See also Card Info; Home; 

stack(s); User Preferences card 
adding 11-12, 112-113 
arranging 12-14 
buttons 41, 115, 129 
canceling actions on 106 
changing 23-24 
copying 113, 109-111 
creating 41, 112-113 
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cutting 108, 113 
definition of 3 
deleting 14, 93, 113, 156 
directory of. See Home 
examples of 4 
fields 41, 44, 54, 115, 154 
first card, selecting 119 
linking 151-152 
moving 156-157 
moving between. See Go menu 
names of 156 
numbers 156 
pasting 111 
position in stack 12-14 
printing 95-96 
reviewing. See Recent 
saving snapshot of 88--89 
searching See Find command 
search path 49 
sharing pictures among 74 
sorting 13-14 
To Do 32-33 
versus backgrounds 40-44 

card buttons 41, 115, 129 
card fields 41, 54 

cover background fields 115 
numbers 154 
versus background fields 44 

Card Info command (Objects 
menu) 155-157 

Can't delete card 156 
Card number 156 
changing card position in 

stack 156-157 
description of 155 
dialog box 155 

changes, saving 105, 171 
changing. See also specific topic 

address cards 10-11 
angles 137 
backgrounds 157-158 
borders 137-138, 145, 176 
cards 23-24, 156-157 
column width 102 
fields 37-38, 58, 61, 63-64, 

129-131, 154 
fonts 69, 153 
menu bar 126 
passwords 90-91 
stacks 87, 152 

tab order 61 
text 10-11, 68-71 
user level 31, 50-52 
label size 100-101 

circles, Oval tool and 141 
cleaning paint spills 141 
Clear Button command (Edit 

menu) 35, 128 
Clear command (Edit menu) 50, 

112 
Clear Field command (Edit 

menu) 130 
Clear key 112 
clicking 4, 78 
Clipboard 26-27, 111-113 

Copy command and 108, 113 
Cut command and 107 
importing graphics with 81 
non-MacPaint pictures and 81 
pasting from 111 
pictures and 74 
unaffected by Clear 112 
unaffected by Delete Card 113 

columns, printing 101-102. See 
alsoprinting;PrintReport 

Command key 186 
commands. See also keyboard 

commands; messages; power 
keys or specific topic 

Back (Go menu) 116-117 
Background (Edit menu) 

115-116 
Bkgnd Info (Objects menu) 

157-158 
Bring Closer (Objects menu) 

160-161 
Brush Shape (Options menu) 

176 
Button Info (Objects menu) 

147-152 
Card Info (Objects 

menu) 155-157 
Clear (Edit menu) 112 
Clear Button (Edit menu) 128 
Clear Field (Edit menu) 130 
Compact Stack (File menu) 89 
Copy (Edit menu) 108-110 
Copy Button (Tools menu) 128 
Copy Card (Edit menu) 113 
Copy Field (Edit menu) 130 



commands (continued) 
Copy Picture (Edit menu) 

108-109 
Cut (Edit menu) 107-108 
Cut Button (Edit menu) 128 
Cut Card (Edit menu) 113 
Cut Field (Edit menu) 59 
Darken (Paint menu) 167 
Delete Card (Edit menu) 113 
Delete Stack (File menu) 93 
Draw Centered (Options menu) 

180-181 
Draw Filled (Options menu) 

178-180 
Draw Multiple (Options menu) 

181-182 
Edit Pattern (Options menu) 

177-178 
Export Paint (File menu) 88-89 
FatBits (Options menu) 173-174 
Field Info (Object menu) 

153-155 
Fill (Paint menu) 165 
Find (Go menu) 120-122 
First (Go menu) 119 
Flip Horizontal (Paint menu) 170 
Flip Vertical (Paint menu) 169 
Grid (Options menu) 172 
Help (Go menu) 118 
Home (Go menu) 117 
Impo1t Paint (File menu) 88 
Inve1t (Paint menu) 165 
Keep (Paint menu) ! 71 
Last (Go menu) 120 
Lighten (Paint menu) 167 
Line Size (Options menu) 176 
Message (Go menu) 123 
New Background (Objects 

menu) 163 
New Button (Objects menu) 162 
New Card (Edit menu) 112-113 
New Field (Objects menu) 162 
New Stack (File menu) 86 
Next (Go menu) 119 
Opaque (Paint menu) 170 
Open stack (File menu) 86-87 
Page Setup (File menu) 94 
Paste (Edit menu) 111 
Paste Button (Edit menu) 36 
Paste Card (Edit menu) 113 

commands (continued) 
Paste Field (Edit menu) 62 
Paste Picture (Edit menu) 27 
Pickup (Paint menu) 166 
Polygon Sides (Options menu) 

178 
Power Keys (Options menu) 

174-175 
Prev (Go menu) 119 
Print Card (File menu) 95 
Print Report (File menu) 98-105 
Print Stack (File menu) 95-97 
Protect Stack (File menu) 89-93 
Recent (Go menu) 118-119 
Revert (Paint menu) 171 
Rotate Left (Paint menu) 168 
Rotate Right (Paint menu) 169 
Save, lack of 85 
Save a Copy (File menu) 87 
Select (Paint menu) 164 
Select All (Paint menu) 165 
Send Farther (Objects 

menu) 161 
Stack Info (Objects 

menu) 159-160 
Text Style (Edit menu) 114 
Trace Edges (Paint menu) 168 
Transparent (Paint menu) 171 
Undo (Edit menu) 106 

Compact Stack command (File 
menu) 89, 160 

connecting. See linking 
Control Panel xxi 
Copy Card command (Edit 

menu) 111, 113 
Copy command (Edit menu) 74, 

108-110 
copying backgrounds 110 
copying buttons and fields- 109 
copying cards 109-110 
copying pictures 108-109 

Copy Field command (Edit 
menu) 39, 61, 130 

copying. See also specific topic 
backgrounds 110-111 
buttons 36-37, 109, 128 
cards 109-110, 113 
fields 39, 61-62, 109, 130 
from Clipboard 111 
pictures 24-28, 108-109 

text 67 
Copy Pictures command (Edit 

menu) 108-109 
creating. See also specific topic 

backgrounds 115, 163 
buttons 49, 115, 124, 126-128, 

162 
cards 41, 112-113 
fields 55-57, 115, 124, 

129-131, 162 
movable Tools palette 125 
shapes 144 
stacks 32-34, 86 
startup disk xx-xxi 
text 65-71 
tutorial disk xx-xxi 

Curve tool (Tools menu) 79, 142, 
180 

customizing, tutorial 20-46 
Cut Button command (Edit 

menu) 128 
Cut Card command (Edit 

menu) 111, 113 
Cut command (Edit 

menu) 107-108 
Cut Field command (Edit 

menu) 59 
cutting. See also deleting; erasing 

cards 108, 113 
buttons 107, 128 

D 
Darken command (Paint 

menu) 167 
date, headers and 97, 105 
Date message 197 
default 

field style 64 
text attributes 144 

Delete Card command (Edit 
menu) 113 

Delete key 112 
Delete Stack command (File 

menu) 93 
deleting. See also cutting; erasing 

backgrounds 93, 130, 158 
buttons 35, 128 
cards 14, 93 , 113, 156 
fields 59 
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stacks 93 
without inserting on 

Clipboard 112 
digitized images, importing 81 
digitizing cameras 74 
disk-based help. See Help system 
disk drives. See hard disk drives; 

3.5-inch disk drives 
disks 

copying xviii 
ejecting xix 
HyperCard xvii-xxi, 203-204 
swapping 32 

documentation, advanced xxv 
documents, HyperCard 204-206. 

See also file(s); stack(s) 
DoMenu message 197 
dots, changing 135, 165, 167, 

177. See also painting 
double-clicking 78 
dragging 10-11 

modifier keys and 79, 191-192 
problems with 132 

Draw Centered command (Options 
menu) 180-181 

Draw Filled command (Options 
menu) 178-180 

Curve tool and 180 
Polygon tool and 179-180 
short cut for 179 

drawing. See painting; pictures or 
specific command or tool 

Draw Multiple command (Options 
menu) 181-182 

duplicating. See copying 

E 
edges, tracing 168 
editing (tutorial) 17-18. See also 

specific topic 
patterns 177, 183 
pictures 29 
text 66-67, 124, 126, 190 

Edit menu 105-116. See also 
commands 

description of 105 
short and full 51 , 106 

Edit Pattern command (Options 
menu) 177-178, 183 
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ejecting a disk xix 
entering text . See text 
Eraser 30, 79, 136. See also 

erasing; painting 
erasing. See also cutting; deleting; 

editing or specific topic 
background pictures 136 
dots 135 
pictures 136 
stack contents 93 
with Brush 136 
with Spray tool 138 

Export Paint 88-89 

F 
FatBits command (Options 

menu) 173-174 
fi e ld(s) 54-65 . See also 

background fields; card fields; 
text fields 

active Paint 114 
background 40-44, 54, 115, 

130, 154, 162 
card 44, 54, 115, 154 
changing 37-38, 58, 61, 63-64 , 

129-131, 154 
clearing 130 
copying 39, 61-62, 109-110, 

130 
creating 56--57, 115, 124, 

129-131, 162 
cutting 107 
definition of 11, 54-55 
deleting 59, 93 
designing 153 
ID 155 
information about 130-131, 

153-155 
invisible 59 
layers 60-61 
locking and unlocking 64 
moving 38, 57, 160-161 
moving between 59-61 
names 62-63, 103 
New Card command and 112 
number of lines in 129 
numbers 60-61, 153-154 
overlapping 55 
pasting 60, 107, 111 

placing 57 
printing 100-103 
searching in a specific 121-122 
selected, moving dotted line 

and 39 
selecting 130 
setting text properties for 114 
size, changing 58 
style, changing 63-64 
tab order and 60-61 
text and 67-70, 129-131 
transparent 162 
viewing 67 
wrapping in 58 

Field Info command (Objects 
menu) 130-131, 153-155 

description of 153 
Field ID 155 
Field number 154 
Lock Text 64, 153 
Script 155 
Show Lines 153 
Wide Margins 153 

field numbers, changing 61 
Field tool (Tools menu) 56, 67, 

129-131 
file(s) . See also System file; text 

copying xviii 
exporting 88-89 
importing MacPaint-compatible 

files 88 
retrieving 49 

File menu 84-105 . See also 
commands 

description of 84 
short and full 51, 85 

Fill command (Paint menu) 165. 
See also filling pictures 

filling pictures. See also Bucket; 
painting 

areas with selected patterns 140 
borders with current pattern 145 
Draw Filled command 

and 178-180, 183 
Fill command and 165 

Find command (Go menu) 8-9, 
120-122. See also searching 

description of 8-9, 18 
can't use with Paint Text 144 
Message box 8 



quotation marks and 8 
searching for part of a word or 

name 9 
searching specific field 121-122 

Finder 
stack icons and 4 
startup disks and xvii 
version number of xvi 

First command (Go menu) 13, 18, 
112, 119 

Flip Horizontal command (Paint 
menu) 170 

Flip Vertical command (Paint 
menu) 169 

fonts, changing 69, 153 
formats. See also printing; Print 

Report command 
column 101-102 
printing 98-105 
row 102-104 
page 96-97 

free-form shapes. See Curve tool 

G 
General tools. See also Browse 

tools; Button tool; Field tool 
Bkgnd Info command and 157 
description of 124 
versus Paint 84 

getting started (tutorial) 2-3 
Go menu 6, 116-123. See also 

commands 
Go message 197-198 
graphics 74-82. See also painting; 

Paint tools; pictures 
Grid command (Options menu) 172 

H 
hard disk drives 

installing HyperCard on xviii-xx 
starting up from 2 

headers 97, 105. See also printing; 
Print Report command 

height, text 70-71 
Help button, adding 36 
Help command (Go menu) 14, 118 
Help stack (tutorial) 14-15 

Help system xxiii-xxiv, 4-5, 
14-15, 118 

Hide message 198 
hiding Message box 123 
Horne 3, 6-7, 48-52 

creating button for 49 
definition of 6 
going to 18, 52, 117 
linking to a stack 44-46 
search paths 49-50 
stack 6, 47-52 
tutorial 6-7 
User Preferences and 50-52 

Horne command (Go menu) 18, 
52, 117 

Horne icon 18 
Horne stack 6, 47-52 

dangers of deleting 48 
User Preferences and 50-52 

horizontal pictures 170 
horizontal printing 94, 96 
HyperCard. See also specific topic 

commands to. See messages 
customizing (tutorial) 19-46 
disks xvii-xxi, 203-204 
installing xviii-xx 
introduction to xvi-xxiv 
LaserWriter and xvii 
messages 195-201 
MultiFinder and xvi 
package contents xvii 
quitting 105 
requirements for xvi-xvii 
user levels in 22-23, 50-52 

HyperCard icon 2 
HyperTalk 196 

I, J 
icons. See also button(s) 

Address 7 
as buttons 150-151 
Browse 4 
Button Ideas 36 
Home 18 
HyperCard 2 
Intro 5 
Quick View 14 

Sort 13 
Stack 4 
To Do 32 

ID, Button. See Button Info 
ID, Field. See Field Info 
images. See pictures; shapes 
IrnageWriter 81, 101 
importing pictures 74, 81, 88. See 

also pictures 
Import Paint command (File 

menu) 81, 88 
insertion point, setting 65, 66 
installing HyperCard xviii-xx 
Intro icon 5 
Invert command (Paint menu) 165 
invisible fields and text 58-59 

K 
Keep command (Paint menu) 171 
keeping changes. See saving 
keyboard commands 186-193. 

See also power keys 
browsing 188-189 
editing text 190 
modifier keys 79 
Paint tools and 190-191 
table of (by command) 187-188 
table of (by menu) 187 

keyboard short cuts (misc. table 
of) 192-193 

keys 

L 

Backspace 112 
Clear (keypad) 112 
Command 186 
Delete 112 
modifier 79-80, 191-192 
power 75-77, 190-191 
Tab 59-61, 193 

labels 100-101 
Landscape Printing icon 96 
LaserWriter xvii 

features that don't work with 
HyperCard 94 

labels and 101 
Print Stack command and 95 
smoothing or flipping 94 
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Lasso (Tools menu) 79, 133-134 
lassoing 76-77, 133-134. See also 

selecting 
area that has no breaks 133 
area without shlinking around 

black dots 133 
copying selections 133 
inverting lassoed areas 166 
making multiple copies 134 
moving selections 133 
shapes 164 

Last command (Go menu) 21, 18, 
120 

layer(s) 
button 148 
front 60 
moving closer or 

farther 160-161 
numbers, field 154 
order of 60-61 
tab 60-61 

layouts, printing 103. See also 
printing; Print Report 
command 

Lighten command (Paint 
menu) 167 

limiting user levels 92 
lines. See also painting; tool(s) or 

specific tool 
cut off text 71 
drawing 137 
height 71 
number of in fields 129 
spacing 57 
thickness of 137, 176 
viewing 64-65, 153 

Line size 13, 138, 145, 176 
Line tool (Tools menu) 79, 137 
linking 

buttons 151-152 
cards 160 
Home and stack 44 

LinkTo 45, 151-152 
locking 

fields 64 
text 153 

Lock Text 64, 67 
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M 
MacPaint 74, 81, 88 
manual paper feed 96, 105 
margins, wide 64-65, 153 
memory 

requirements xvi 
space in stacks 160 

Menu bar 115- 116, 126 
menus. See also commands; 

keyboard commands or 
specific menu 

converting to palettes 30 
power keys and 75 
tear-off 30, 125 

Message box, displaying and 
hiding 123 

Message command (Go menu) 123 
me~sages 195-201 

Date 197 
DoMenu 197 
Go 197-198 
Hide 198 
Open 198 
Pop Card 199 
Push Card 200 
Show 200 
Show Cards 200-201 
Time 201 

miniature cards, pasting 111 
mistakes, correcting See cutting; 

deleting; editing; erasing; 
problems; Undo 

modified dragging. See dragging; 
modifier keys 

modifier keys 79-80, 191-192 
mouse techniques 4, 10-11, 78 
movement, constricting 145 
moving 

between fields 59-61 
between stacks and cards 18 
buttons 34-35, 128, 160-161 
cards 112, 156-157 
fields 38, 57, 160-161 
pictures 27, 132-133 
text 57, 67 
through stacks 116-123 

MultiFinder, HyperCard and xvi 

multiple im~ges, drawing 137, 139, 
140, 142, 145, 181. See also 
Draw Multiple 

N 
names. See also renaming 

background, changing 158 
button 148 
card 102, 156 
fie!rl _,2-63, 102 
searching for 7 
sorting 13-14 
stack 85-86, 159-160 

New Background command 
robjects menu) 163 

New Button command (Objects 
menu) 162 

New Card command (Edit 
menu) 11-12, 41 , 112-113 

New Field command (Objects 
menu) 56, 129-130, 162 

New Stack command (File 
menu) 86 

Next command (Go menu) 119 
numbers 

0 

button 148 
card 156 
card layer 154 
field 60, 154 
version, System file and 

Finder xvi 

objects, list of 146 
Objects menu 146-163. See also 

commands 
on-line help. See Help system 
on-line information services xxiii 
opaque 

buttons 149 
field style 63 
pictures 77, 170 

Opaque command (Paint 
menu) 170 

Open message 198 
Open Stack command (File 

menu) 24-25, 86- 87 



Options menu 172-183. See also 
commands 

orientation, setting 94 
outlines, tracing 168 
Oval tool (Tools menu) 79, 

141-142 
overlapping text and fields 55 

p 
page(s). See also printing 

formats 96-97 
numbers, in headers 97, 105 
size 94 

Page Setup command (File menu) 
94 

painting 20-31, 74-82, 124, 
131-146, 163-183. See also 
specific command or tool 

border 183 
Brush and 135-136 
Bucket and 140-141 
centered on given point 75, 

141, 180-181 
circles 141-142 
cleaning screen 30 
Curve tool and 142 
Draw Centered command 

and 180-181 
Draw Filled command 

and 178-180 
Draw Multiple command 

and 181-182 
Eraser and 136 
filling pictures 140-141, 

178-180 
free-form shapes 142 
from a central point 180 
Line tool and 137 
Oval tool and 141-142 
paint spills 140-141 
Paint text 54 
Paint Text tool and 143-144 
patterns 177, 182 
Pencil and 135 
Polygon tool and 145-146 

painting (conttnued) 
power keys 75-77, 190-191 
powers associated with 92 
Rectangle tool and 138-139 
Regular Polygon tool and 

144-145 
Rounded Rectangle tool and 

139-140 
Spray tool and 138 
text in pictures 143-144 
tutorial 20-31 

Painting level 51. See also User 
Preferences card; user levels 

Paint menu 163-171. ~ee also 
commands 

Paint text. See also painting; Paint 
Text tool 

active 114 
can't use Find with 144 
identifying 67 
setting text properties for 114 

Paint Text tool (Tools menu) 66, 
114, 143-144 

Paint tools. See also tool(s) or 
specific tool 

Clear command and 112 
Cut command and 107 
description of 20, 23, 124 
double-clicking 78 
dragging with modifier keys 79, 

191-192 
pasting and 111 
power keys and 190-191 
tips on 28-30 
versus General tools 84 

palettes 30, 125. See also painting 
paper feed, manual 96, 105. See 

also Print Report 
passwords 90-91 
Paste Button command (Edit 

menu) 36, 111 
Paste Card command (Edit 

menu) 111, 113 
Paste command (Edit menu) 74, 

111 
Paste Field command (Edit 

menu) 39, 62 
Paste Picture command (Edit 

menu) 27, 111 

pasting 
buttons 36, 111 
cards 111-113 
fields 39, 62, 107, 111 
MacPaint-compatible files 88 
pictures 27, 111 

patterns, changing 165, 177-178, 
183. See also filling; painting; 
pictures 

Patterns menu 29, 74, 182-183. 
See also commands; painting; 
patterns or specific command 

description of 182 
editing patterns 183 
short cut for 183 
tearing off 30 

Pencil (Tools menu) 29, 79, 
135. See also painting; Paint 
tools 

peripheral devices. See specific 
devtce 

Pickup command (Paint menu) 76, 
166 

pictures. See also icons; painting; 
Paint tools; patterns or specific 
toptc 

background 40-44, 115-116, 
136, 165 

basic elements 74 
Brush Shape command and 176 
changing 124, 171 
clearing 112 
copying 24-28, 108-109 
cutting 107 
darkening 167 
erasing 136 
FatBits and 173-174 
filling 178-180 
from Clipboard 74 
from Scrapbook 74 
Home card 6 
horizontal 170 
importing 74, 81, 88 
lassoing 76-77 
lightening 167 
Line Size command and 176 
lining up elements in 172 
MacPaint 81 
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pictures (continued) 
menu commands 74 
moving 27 
multiple 181-182 
non-MacPaint 80 
opaque 77, 170 
pasting 111 
patterns, changing 165, 

177-178, 183 
rotating 168-169 
selecting 76-77, 131-134, 165 
sharing among cards 74 
shrinking 131 
special effects 80 
text as part of 143-144 
tracing edges of 168 
transparent 171 
zooming in on 173-174 

points, text size and 70 
Polygon Sides command (Options 

menu) 144, 178 
Polygon tool 144-146, 

178-180. See also Regular 
Polygon tool 

Pop Card message 199 
power keys 75-77, 174-175 

Paint 190-191 
table of 75, 175, 191 

Power Keys command (Options 
menu) 75, 174-175. See also 
power keys 

preset search paths 49 
Prev command (Go menu) 119 
Previous card button 5 
Print Card command (File 

menu) 95 
printers. See Image Writer; 

LaserWriter 
printing 95-105 

cards 95-96 
columns 101-102 
controlling printouts 99 
darker 96 
fast 96 
field names in columns 102 
field order 100 
format remembered 97, 105 
horizontal 94, 96 
labels 100-101 
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manual paper feed 96, 105 
page formats 96-97 
page setup for 94 
reports 98-105 
rows 102-104 
slowed by smoothing or 

flipping 94 
stacks 95-97 

Print Report command (File 
menu) 98-105 

Columns 101-102 
controlling printouts 99 
dialog box 98 
field combinations for 99 
Field printing order 100 
Format remembered 105 
Header 105 
Labels 100-101 
Manual paper feed 105 
Rows 102-104 

Print Stack command (File 
menu) 95-97 

Cards printed per page 96 
dialog box 95 
Fast laser printing/darker 

printing 96 
Format remembered 97 
Headers 97 
Manual paper feed 96 
Page formats 96 

private access, stacks and 89-90 
problems, common 

changing backgrounds 115, 158 
changing card positions 156-157 
creating buttons 115, 127 
creating fields 57, 115, 130 
deleting cards 156 
deleting background 158 
dragging pictures 132 
modifying background 

p ictures 158 
Protect Stack command (File 

menu) 89-93 
Can't delete 90 
Private Access 90 
Set Password button 90 
viewing full File menu with 93 

Push Card message 200 

Q 

Quick View icon 14 
quitting HyperCard 105 
quotation marks, Find command 

and 8, 120-121 
Quotation stack, adding to 24, 28 

R 
Recent command (Go 

menu) 15-17, 118-119 
rectangle field style 63 
rectangles 138-140 
Rectangle tool (Tools menu) 79, 

138-139. See also Rounded 
Rectangle tool 

Regular Polygon tool 79, 144-145, 
178. See also Polygon tool 

removing. See cutting; deleting; 
editing; erasing 

renaming . See also names 
pictures 81 
stacks 87, 159-160 

reports, printing. See Print Report 
command 

restoring last picture saved 171 
restricting user levels 92 
Revert command (Paint 

menu) 171 
reviewing cards. See Recent 
Rotate Left command (Paint menu) 

168 
Rotate Right command (Paint 

menu) 169 
rotating shapes (Regular Polygon 

tool) 145 
Rounded Rectangle tool 79, 

139-140. See also Rectangle 
tool 

rows, printing 102-104. See also 
printing; Print Report 

s 
Save a Copy command (File 

menu) 87 
Save command, lack of 85 



saving 
background 88-89 
card snapshots 89 
changes 105 
patterns 178, 183 
pictures 171 
stacks 85-87 

scanners 74 
Scrapbook, pictures and 74 
screen 

losing part of rotated pictures 
on 168-169 

removing cards from 113 
snapshots of 81, 88-89 

Script button (Field Info 
command) 152 

scripting 
HyperTalk and 196 
on User Preferences card 51 
powers associated with 92 

scripts 51, 62-63, 92, 152 
Button Info command and 152 
changing field names in 63 

scroll bar, vertical 63 
scrolling field style 63 
searches, electronic. See Help 

system 
searching for text 7-10, 120--122 
search paths 49-50 
Select All command (Paint 

menu) 131, 165 
Select command (Paint menu) 164 
selecting. See also lassoing or 

specific topic 
buttons 127-128 
fields 130 
pictures 76-77, 131-134, 165 
shapes 144, 178 
text 126, 143 

Selection tool 26, 76-77, 131-132 
Send Farther command (Objects 

menu) 61, 161 
sending a message 123, 195-201 
setting 

passwords 90--91 
user levels 21-23, 50--52 

shadow field style 63 

shapes. See commands; pictures or 
specific topic 

short cuts 
Draw Filled command 179 
keyboard (table of) 192-193 
opening stacks 87 
Patterns menu 183 
screen snapshots 89 
selecting text 143 

Show Cards message 200--201 
Show Lines (Field Info 

command) 64-65 
Show message 200 
shrinking pictures (Selection 

tool) 131-132, 134 
sizing buttons 128 
snapshots 

card 88-89 
screen 81 

software. See disks; system 
software 

Sort icon 13-14 
sorting 13-14 
space, eliminating. See shrinking 
spacing, line 57 
special effects 80 
Spray tool (fools menu) 79, 138 
stack(s). See also cards or specific 

topic 
adding cards to 112-113 
Address 7-9, 14 
arrangement of cards in 12-14 
Art Ideas 24-25 
authoring 31-46 
backgrounds, unlimited number 

of 116 
blank 86 
Button Ideas 36 
card position in 12-13, 156-157 
central. See Home 
changing 87 
compacting 89 
creating 32-34, 86. See also 

authoring 
customizing tutorial 19-46 
definition of 4 
deleting 93, 156 

stack(s) (continued) 
deleting extra space in 160 
directory of 6, 86 
free space in 160 
Help stack 14 
Home stack 48 
linking Home to 44-46 
location of 87, 203-204 
moving through 15, 18, 

116-123. See also Go menu 
names of 1-5, 152, 159-160 
obtaining xxiv-xxv 
opening 24, 86-87 
printed summaries of 98-105 
printing 95-97 
protecting 52, 89-93 
Quotation 24 
removing cards from 113 
renaming 159-160 
retrieving 118-119 
saving 85, 86, 87 
searching for text in 120-122 
search path for 49, 160 
sorting 13-14 
viewing 13 

Stack icon 4 
Stack Info command (Objects 

menu) 159-160 
description of 159 
dialog box 159 
Free in Stack 160 
Stack name 159-160 
Where 160 

starting up 2-3 
Startup disks xx-xxi 
stretching picture selections 132, 

134 
stripes on menu bar. See 

background(s) 
style 

button 149 
field 63-64 
text 69, 114 

System file, version number of xvi 
system software xvi-xvii 
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T 
Tab key 11, 59-61, 193 
tab order 60--61 
tear-off menus 30 
telephone numbers 7, 11. See 

also Address stack 
text 64-71. See also field(s) 

alignment of 69-70, 100-101, 
114 

Browse tool and 126 
changing 10-11, 68-71 
copying 67, 109 
creating 65-71 
default attributes 70, 144 
editing 65-66, 124, 126, 190 
entering 66-67, 126, 143 
finding 7-10, 120-122 
fields and 54-65, 129-131 
fonts, changing 69, 153 
height 70-71 
hidden, viewing 67 
kinds of 54 
lines cut off 71 
locking 64, 67, 153 
moving 67 
outside a field 67 
overlapping 55 
Paint 54, 67, 114 
pasting 107, 111 
properties of 68-71 
regular 65-71 
searching for 7-10, 120-122 
selected 66 
selecting 126, 143 
Show Lines 64-65 
size 70 
style 69, 114 
typing 54 
uneditable 67 
Wide Margins 64-65 
wrapping 58 

Text Style command (Edit 
menu) 68-71, 114 

3.5-inch disks xx-xxi, 2-3 
time in headers 105 
Time message 201 
To Do card 32-33 
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tool(s) 
Browse 4, 18, 59, 65-66, 117, 

126 
Brush 135-136 
Bucket 140-141 
Button 34-35, 126-129 
Curve 142 
Eraser 136 
Field 37, 56-62, 67, 129-131 
General 84, 124, 157 
Lasso 133-134 
Line 137 
menu bar changes and 126 
modifying. See Power Keys 
names of 124 
Oval 141-142 
Paint 66, 114, 143-144 
Paint Text 66, 143-144 
Pencil 135 
Polygon 145-146 
Rectangle 138-139 
Regular Polygon 144-145 
Rounded Rectangle 139-140 
selecting 125 
Selection 26, 76-77, 131-132 
Spray 138 
switching, Paint text and 114 

Tools menu 124-146. See also 
General tools; Paint tools; 
tool(s) or specific tool 

description of 124-126 
tearing off 30 
viewing 21-23 

Tools palette, movable 125, 
182. See also tool(s); painting 

Trace Edges command (Paint 
menu) 168 

transparent 
buttons 149 
fields 63, 162 
pictures 77, 171 

Transparent command (Paint 
menu) 171 

Trash 
ejecting a disk xix 

tutorials 2-46 
adding a card 11-12 
Address stack 7-9 
arranging cards in stacks 12-14 
authoring 31-46 

tutorials (continued) 
browsing 3-5 
changing text 10-11 
customizing 20-46 
getting started 2-3 
Help stack 14-15 
Home 6-7 
limiting 44-46 
painting 20-31 
Recent 15-17 
searching 7-9 
tutorial disks, creating xx-xxi 

Typing level 51. See also User 
Preferences card; user levels 

typing text. See text 

u 
Undo command (Edit menu) 26, 

106 
user groups xxv 
user levels 21-23, 50-52 

changing 31 
limiting 92 
powers associated with 92 
setting 21-22, 50-52 

User Preferences card 21-22, 48, 
50-52, 85 

v 
version numbers, System file and 

Finder xvi 
vertical pictures 169 

W, X, Y 
Wide Margins 64-65 
wrapping text 58, 101, 102 

z 
zooming in on pictures. See 

FatBits 
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Quick Reference Card 

User preference levels 
Browsing 

Typing 

Painting 

Authoring 

Scripting 

Short File and Edit menus, plus the Go menu. Use of the Browse 
tool. 

Same as Browsing, plus ability to edit text in existing fields . 

Same as Typing, but with full File and Edit menus and use of Tools 
menu (plus Paint, Options, and Pattern menus when a Paint tool 
is selected). Use of all Paint tools (but not Button and Field tools), 
plus Power Keys option. 

Same as Painting, plus Objects menu. Use of Button and Field 
tools. 

Same as Authoring, plus ability to type into Message box while it's 
hidden (if proper option checked), and ability to write and edit 
scripts. 



Your own notes 



Effects of modified dragging 

Tool 

Button 
Field 
Selection 
Lasso 
Line 
Eraser 
Pencil 
Rectangle 
Curve 
Brush 
Spray 
Rounded Rectangle 
Polygon 
Oval 
Regular polygon 

Tool 

Button 
Field 
Selection 
Lasso 
Line 
Eraser 
Pencil 
Rectangle 
Curve 
Brush 
Spray 
Rounded Rectangle 
Polygon 
Oval 
Regular polygon 

With Command key 

Create button 
Create field 
Select tightly 
Lasso everything 
No effect 
Erase white 
Get/ leave FatBits 
No effect 
No effect 
Erase what you paint over 
Erase what you spray over 
No effect 
No effect 
No effect 
No effect 

With Shift key 

With Option key 

Copy button 
Copy field 
Copy selection 
Copy selection 
Draw with pattern 
No effect 
No effect 
Patterned border 
Patterned border 
No effect 
No effect 
Patterned border 
Draw with pattern 
Patterned border 
Patterned border 

Move button horizontal or vertical 
Move field horizontal or vertical 
Move selection horizontal or vertical 
Move selection horizontal or vertical 
Draw at 15° angles 
Erase straight horizontal or vertical 
Draw straight horizontal or vertical 
Draw square 
No effect 
Paint straight horizontal or vertical 
Spray straight horizontal or vertical 
Draw square with round corners 
Draw at 15° angles 
Draw circle 
Rotate in 15° increments 



How HyperCard works: An overview 

Bernie Squi r-e 

Paula Bai l ey l<c::::o:;n1~ ... =c1;:o::ir i-l-- l--l--- Card field 

Pri mo Acme 
A button that takes --------+--.,.----.... 
you to the next card 

A button that takes --------+--'"'"""=~ 

you to the previous card 

A button that takes you -------------"" 
to another stack 

Another stack -----------< 

All this is on the background 

Pr imo Acme 

Pr es ident, 
A<';;me Dot 
Company 

Name : 

Position : 
Empl. No · 

Building : 

Stack 

Card picture 

Background picture 

Background fields 

Telephone : 

~Ii" ~--:;:¢1::-:9~=::~---l---- Background button 

This part changes from · · · _J 
card to card ----i_ 

On the screen you see 
a combination of the 
background and the part 
unique to a given card 

Bernie Squi re 
Sale-s Re-p 
234 
D-3 Homest ead 

555- 1736 

•Acme Dot Company if 123 North St.Santa Clar a, CA 940 13 

Name I Bernie Sgulre I ~ 
Position : !Sales Rep . j 

Empl. No: l?.;2=;3==4 ~=;=;;==;===! -=-
Building : I D- 3 Homestead I l ! 

Telephone : I 555 1 736 I 
.iii" <? 9 



Browsing from the keyboard 

Destination 

Help 

Home 

First card in stack 

Previous card in stack 

Next card in stack 

Last card in stack 

Retrace through cards viewed 

Forward through retrat:ed cards 

Record of cards recently seen 

Select Browse tool 

Store current card's location for 
quick return 

Return to stored location 
Oast in-first out order) 

Next field on card 

Keyboard short cut 

Command-? 

Command-H 

Command-1 or 
Command-Left Arrow 

Command-2 or Left Arrow 

Command-3 or Right Arrow 

Command-4 or 
Command-Right Arrow 

Tilde (-) , Esc, or Down Arrow 

Up Arrow 

Command-R 

Command-Tab 

Command-Down Arrow 
(Many locations can be stored) 

Command-Up Arrow 

Tab 



Miscellaneous keyboard short cuts 

Key or combination 

Command-Period 

Command-Space bar 

Command-Tab 

Command-Tilde ( - ) 

Command-Shift-V 

Command-Down Arrow 

Command-Up Arrow 

Option-D 

Option-0 

Option-Tab 

Tilde (-) 

Down Arrow 

Up Arrow 

Tab 

Effect 

Cancel current action Oike printing) 

Hide and show menu bar 

Select Browse tool 

Go to most recent card displayed 
(Paint tool selected) 

Paste miniature card image (with 
card on Clipboard) 

Store current card's location for 
quick return (you can have many 
locations stored) 

Return to stored location (last 
in-first out order) 

Show card picture (with Paint tool) 

Show opaque areas (with Paint tool) 

Toggle Tools palette 

Same as Back command (General 
tool selected); 
undo most recent action (Paint tool 
selected) 

Same as Back command (any tool 
selected) 

Come forward through reviewed 
cards 

Toggle Patterns palette (Paint tool 
selected); 
Advance insertion point to next 
background field (Browse tool 
selected) 

Holding down the Command key before and as you drag through the File menu 
shows the full file menu, even if Browsing or Typing is clicked on the User 
Preferences card in the Home stack and/ or in a stack's Protect Stack dialog. 



Keyboard equivalents by command 

Key Command Menu 

Background Command-B Edit 
Bring Closer Command-plµs Objects 
Copy Command-C Edit 
Cut Command-X Edit 
Find Command-F Go 
First Command- I Go 
Help Command-? Go 
Home Command-H Go 
Keep Command-K Paint 
Last Command-4 Go 
Message Command-M Go 
New Card Command-N Edit 
Next Command-3 Go 
Open Stack Command-0 File 
Paste Command-V Edit 
Prev Command-2 Go 
Print Card Command-P File 
Quit HyperCard Command-Q File 
Recent Command-R Go 
Select Command-S Paint 
Select All Command-A Paint 
Send Farther Command-minus Objects 
Text Style Command-T Edit 
Undo Command-Z Edit 



Text editing 

Function 

Font, next in system 
Font, previous in system 
Text style dialog box 
Space, less between lines 
Space, more between lines 
Text size, larger 
Text size, smaller 

Keyboard short cut 

Command-Shift-> 
Command-Shift-< 
Command-T 
Command-Option-< 
Command-Option-> 
Command-> 
Command-< 

Power keys available ~rhen using Paint tools 

Command Key Menu 

Black pattern B Patterns 
Darken D Paint 
Draw Centered (toggle) c Options 
Draw Multiple (toggle) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (toggle) G Options 
Invert Paint 
Lighten L Paint 
Line size 1-4, 6, 8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Select s Paint 
Select All A Paint 
Trace Edges E Paint 
Transparent T Paint 
White pattern w Patterns 
Rotate Left [ Paint 
Rotate Right l Paint 



RetumAddre$:~~~~~~~~~~~ 

S. M Application 

Apple Computer, Inc. 
P.O. Box 1143 
Cupertino, CA 95014 
USA 

Place 
First Class 

Postage 
Here 



... HyperCard 

• CJCJCJCJCJ - CJCJCJCJ - CJ 
• CJ CJ CJ CJ CJ CJ CJ CJ CJ - CJ CJ 

• CJ CJ CJ CJ - CJ CJ CJ CJ CJ CJ CJ 
• CJ CJ CJ CJ - CJ CJ CJ CJ CJ CJ CJ 
• CJ CJ CJ - CJ CJ CJ CJ CJ CJ CJ CJ 
• CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ 
• CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ 
• CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ CJ 

Please Do Not Mark Above This Line 

• 2. o:::J ITJ ITJ 

• 3 . o:::J ITJ 

• 4. o:::J ITJ ITJ CD CTJ a:J i::::z:J 

• 5. o:::J ITJ ITJ CD CTJ a:J 

• 6. o:::J ITJ ITJ 

• 7. o:::J ITJ ITJ CD 

• 8 . o:::J ITJ ITJ CD CTJ a:J 

• 9. o:::J ITJ ITJ CD CTJ 

• 10 . o:::J ITJ ITJ CD CTJ 

• 1 1. o:::J ITJ ITJ CD CTJ a:J 

• 12 . o:::J ITJ ITJ CD CTJ 

• 13. o:::J ITJ ITJ CD CTJ a:J 

- 14. o:::J ITJ ITJ CD CTJ a:J 

• 1 5. o:::J ITJ ITJ CD CTJ a:J 

16. 

17 . 
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... Tell Apple About .................................................................. . 

D Please contact your authorized Apple dealer when you have questions about your Apple products. Dealers are 
trained by Apple Computer and are given the resources to handle service and support for all Apple products. If 
you need the name of an authorized Apple dealer in your area, call toll-free: 800-538-9696. 

D Would you like to tell Apple what you think about this product? After you have had an opportunity to use this 
product, we would like to hear from you. You can help us to improve our products by responding to the 
questionnaire below and marking the appropriate boxes on the card at the right with a #2 lead pencil . If you 
have more than one response to a question, mark all the boxes that apply. Please detach the card and mail it to 
Apple. Include additional pages of comments if you wish. 

1. How would you rate the HyperCard software overall? (1 =poor. .. 6 =excellent) 

2. How long have you used HyperCard? (1 =less than 1 month, 2 = 2-6 months, 3 =over 6 months) 

3. How did you acquire HyperCard? (1 =packaged with computer, 2 =purchased separately) 

4. Where did you purchase HyperCard? (1=dealer, 2=corporate purchase, 3=education purchase, 4=university, 

5 =government purchase, 6 =Certified Developer Program, 7 =other) 
\ 

5. How much experience have you had with computers? (1=none ... 6=extensive) 

6. Which Apple computer are you using with HyperCard? (1=Macintosh Plus, 2=Macintosh SE, 3=Macintosh II) 

7. Where is HyperCard used most often? (1=work, 2=home, 3=school, 4=other) 

8. How often do you use HyperCard with your computer? (1=never . . 6=always) 

9. At what level are you using HyperCard? (1=browsing, 2=typing, 3=painting, 4=authoring, 5=scripting) 

10. At what level do you expect to use HyperCard eventually? (1=browsing, 2=typing, 3=painting, 4=authoring, 

5 =scripting) 

11. How easy is HyperCard to use? (1 =difficult. .. 6 =very easy) 

12. How did you learn to use HyperCard? (1 =Hypercard User's Guide, 2 = HyperCard Help Stacks, 3 =training class, 

4=friend, 5=other) 

13. Does HyperCard meet your expectations? (1=not at all ... 6=exceeds expectations) 

14. How would you rate the HyperCard User 's Guide overall? (1 =poor. .. 6 =excellent) 

15 . How would you rate the HyperCard Help Stacks overall? (1=poor. .. 6=excellent) 

16. Please describe any errors or inconsistencies you may have encountered. (Page numbers would be helpful.) 

1 7. What suggestions do you have for improving HyperCard? 

Thanks for your time and effort. 030-3218-A 



Tuck end flap inside back 
cover when using manual. 





Apple Computer, Inc. 
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Cupenino, CA 95014 
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