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INTRODUCTION 

This book is not just about computers. It's about a dream. Some 
fifteen years ago, a young woman shared the dream with only a few 
hundred, maybe a thousand people. She was a typical American 
college student, except that her experience in computer program­
ming had taught her the advantages and limitations of mainframe 
computer systems. She appreciated the power of the computer, 
but wanted it to be more personal. She envisioned writing books, 
keeping records, sorting and analyzing data, creating art, teaching 
her children, and playing games in her own living room. 

She investigated homemade computers and the clubs that had 
sprung up to support this new hobby. But she didn't feel comfort­
able with the technobabble of the hobbyists-nor with a soldering 
iron. She thought computers should be small, unintimidating, 
friendly; "You shouldn't have to build one-it should come right 
out of a box, ready to use. Just plug it in and compute!" 

In 1977, Apple Computer introduced the Apple II® computer. The 
dream was headed for reality: here was a personal computer with 
easy-to-use software that improved productivity and enhanced 
creativity. The Apple II microcomputer started a revolution; soon 
other manufacturers joined the market: Radio Shack, Commodore, 
Atari, and IBM. But the promises of the computer manufacturers 
still fell a bit short of the full-blown dream. Yes, the systems fit 
easily on a desktop, used normal household current, and didn't 
require the special environmental conditions of large-scale main­
frame computers. Yes, consumer-oriented software programs such 
as AppleWriter™, Visicalc®, Lotus 1-2-3®, WordPerfect®, and dBase® 
gave personal computer owners the ability to store, edit, and print 
text, keep track of their finances, and accumulate just about any 
kind of data. But the software wasn't always so friendly, and 
technical knowledge was often necessary. Users had to learn many 
special commands to use the microcomputer's operating system, 
and programming skills were essential to make it really do what its 
owners wanted. 

xvii 



xviii Introduction 

In 1984, the world of computers was changed again. Not by Big 
Brother computers watching over us, as Orwell had predicted, but 
by a new computer called the Macintosh. "A computer for the rest 
of us," the ads promised. The Apple® Macintosh® was designed to 
bring hardware and software together into a standard user interface. 
All software programs that ran on the Macintosh operated in the 
same manner. If you knew how to use one, the second, third, and 
fourth were easy to learn because 90 percent of the skills and 
techniques were shared by all programs. 

In contrast to other personal computers of the period, the 
Macintosh used a "mouse" to select functions from "menus" rather 
than making the user type complex commands. Information and 
programs were represented graphically, with icons rather than 
eight-letter names (see Figure I). Running a program was as 
simple as pointing to an icon and clicking the mouse button twice. 
But the most wonderful feature of all was that information-words, 
numbers, drawings, graphs-could be transferred easily between 
programs, printed together on the same page, and shared with 
other Macintosh computer owners regardless of their s.oftware 
packages. Market surveys by Peat Marwick and the Gartner Group 
showed that companies using the Macintosh (in comparison to 
IBM compatibles with non-Macintoshlike operating systems) re­
duced employee training time, increased the use of computing by 
employees, and increased overall employee productivity. 

The innovations that made personal computers more "user 
friendly" are now standard on systems from Apple, Atari, IBM, 
Next, and others. Microsoft Corporation, one of the largest software 
manufacturers in the United States, developed Windows™, a soft­
ware package that provided IBM owners with an operating envi­
ronment similar to the Macintosh's. 

Over the past 12 years, personal computer software has evolved 
from stand-alone programs that were often more time-consuming 
than time-saving into productivity tools that increase the quality 
and quantity of the user's work. Several manufacturers expanded 
their software products to include more functions. For example, 
Lotus Symphony® added word-processing and database capabili­
ties to the popular Lotus spreadsheet software for the IBM® PC. 
Microsoft introduced Works for the Macintosh and the IBM PC. 
This fully integrated software package included word-processing, 
spreadsheet, database, business graphics, and communications 
applications into one package. The Macintosh version also included 
drawing capabilities and desktop publishing features. The advantage 
of having several tools in one package and the ability to move 
information between the tools quickly caught the attention of the 
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xx Introduction 

nation. A survey of Macintosh retailers by InfoCorp rated Microsoft 
Works as the best-selling business software package in the nation 
in 1988 and 1989. 

Apple's advertising promoted the vision of "one person, one 
computer." Today's computers with user-friendly interfaces-such 
as the Macintosh coupled with integrated software packages like 
Works-bring this vision closer to reality. As a tool, they free the 
businessperson from tedious calculations; assist the artist in 
shaping a creation; bolster the writer in crafting and delivering 
memorable phrases; and engage the scientist in a community of 
peers. The goal of this book is to give you, as well, the knowledge 
and skills necessa.cy to use the Macintosh and Works as tools in 
developing solutions and improving your own productivity. 

This book is written for explorers, for active participants in 
educational adventures. To receive the greatest benefit from this 
book, you will need access to a Macintosh computer and Microsoft 
Works throughout the learning process. The emphasis in each 
chapter is on clearly defining your goals and helping you achieve 
them via brief, descriptive discussions of the topics and hands-on 
exercises. Posers, problems, and projects are provided at the end 
of each chapter to allow you to practice your newly acquired skills. 
Because each chapter builds on knowledge acquired in previous 
ones, the chapters should be completed in order. However, Chapter 
2, on word-processing, and Chapter 3, on drawing objects, can be 
completed in reverse order if you're unfamiliar with typing or are 
more receptive to visual learning. If you're already comfortable 
with the basic operation of the Macintosh (starting up the computer, 
pointing and clicking with the mouse, using windows, and so on), 
Chapter 1 may be skipped in order to go right to Works! 

Another use of this book is as a reference guide for your future 
projects. The Appendix provides a resource to research questions 
that may arise when you're using Works. Summaries of the Works 
menu commands for word processing, drawing, spreadsheet, da­
tabase, business graphics, and communications are included. The 
Appendix also includes a glossa.cy and information on using macros, 
fonts, and desk accessories. 

A supplemental diskette is bound in with each copy of the 
book. It includes word-processing, spreadsheet, and database files 
that are referred to in the book. Answers to selected problems are 
also included on the diskette, along with an interactive version of 
the Appendices in a HyperCard® stack. Because you may not have 
access to a host computer to complete the exercises in Chapter 8 
on data communications, a HyperCard simulation of an on-line 
catalog search also appears on the diskette. 



"Are you ready?'' 
"For what?" you ask. 
"For the power to be your bestr" the Apple metaphor exclaims. 

Turn the page and discover for yourself ... 
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H A P T E R 

THE MACINTOSH 
COMPUTER AND 

HOW TO USE IT 



"Nothing in life is to be feared. It is only to be understood." 

-Marie Curie 

"In certain trying circumstances, urgent circumstances, desperate 
circumstances, profanity furnishes a relief denied even to prayer." 

-Mark Twain 

"So look this is a book. 
But no page turns. 
Only beneath the metal burns 
Such stuffs as all newtimes are made of. 
So, cowards, what are you afraid of?" 

-Ray Bradbury 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Briefly describe the inventions that led to the development of 
the microcomputer (Section 1.1) 

2. Define the components of a typical computer system (Section 
1.2) 

3. Identify the components of a Macintosh and defme their 
function (Section 1.3) 

4. List the steps necessary to start up the Macintosh (Section 
1.4.1) . 

5. List the items on the desktop and describe their purpose 
(Section 1.4.2) 

6. Describe how to use the mouse to select and move items on 
the desktop (Section 1.4.3) 

7. Describe how to use the Macintosh menus to execute com­
mands (Section 1.4.4) 

8. Describe the features of Macintosh windows and how to use 
them (Section 1.4.5) 

9. List the steps necessary for formatting a blank diskette (Sec­
tion 1.4.6) 

3 



4 Chapter 1 The Macintosh Computer and How to Use It 

1.1 A BRIEF HISTORY OF COMPUTING 

Throughout history, men and women have continually tried to find 
better and easier ways of doing their work, including calculation. The 
idea of computing and record keeping, in fact, has evolved from 
prehistoric times. Our ancestors recorded quantities using scratches, 
marks, and drawings on cave walls. Knotted cords, clay tablets, and 
papyrus scrolls were also used to document data. 

Probably the earliest calculating device was the Chinese abacus 
(see Figure 1.1) . It is thought to have been developed around 3000 
s.c. It consists of beads strung on wires fixed inside a frame and is 
based on a system of fives, like the five fingers of our hands. The 
abacus was used all over t he world for centuries. 

Figure 1.1. The Abacus (Bonnie Hawthorne) 

As trading progressed between cultures monetary systems de­
veloped, and the need for more complex calculations became appar­
ent. During the 17th century, several tools were developed to aid in 
those calculations. One such tool. the Pascaline, was invented by a 
19-year-old Frenchman, Blaise Pascal, in 1642. He developed his 
calculator to help his father, a tax collector. Pascal's device used 
wheels and gears to add and subtract French currency. 

During the 18th and 19th centuries, many others followed 
Pascal's lead and built calculating machines. In 1801 , Joseph 
Jacquard invented the automatic loom. In his loom, rods passed 
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through holes in cardboard cards and guided the action of the 
weaving. This was the first machine to be controlled by a program 
stored on punched cards (see Figure 1.2). 

Figure 1.2. The Jacquard Loom (Courtesy of IBM Archives) 

In 1840 Charles Babbage, an English mathematician, drew up 
plans for a machine called the Analytical Engine. This engine would 
do addition, subtraction, multiplication, and division automatically 
as directed by punched cards similar to those used in Jacquard's 
loom. The engine was to be powered by steam. Unfortunately, the 
technology of the period was not advanced enough to build the 
device, and Babbage died before it was ever constructed. Ada 
Lovelace, Lord Byron's daughter, lent fmancial support to Babbage's 
research and is credited with writing programming instructions for 
the engine. She was the world's first computer programmer. 
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In 1887 Herman Hollerith, an American working for the Census 
Bureau, designed a machine that did not perform calculations but 
rather counted and sorted information (see Figure 1.3). It had been 
estimated that the 1890 census would take more than 20 years to 
tabulate by hand. Using the Hollerith Machine, census takers 
punched holes representing the characteristics of each household 
into dollar bill-sized cards. The cards were then fed into a card reader 
that dropped pins onto them. The pins that fell through the punched 
holes made an electrical contact and advanced the pointer on the 
appropriate dial. The 1890 census took only 3 years to tabulate and 
saved taxpayers an estimated $5 million. Hollerith formed the 
Tabulating Machine Company, which later became International 
Business Machines (IBM). 

The 1940s saw the first of four generations of electronic comput­
ers. Each generation is distinguished from the previous one by a 
technological advance in electronics: the vacuum tube, the transis­
tor, the integrated circuit, and the large-scale integrated circuit, or 
microprocessor chip. 

Figure 1.3. The Hollerith Machine (Courtesy of International Business Machines Corporation) 
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The First Generation. The first working computer, the Harvard-IBM 
Mark I, was designed and built by Howard Aiken using parts from 78 
accounting machines. The Mark I used mechanical relays and could 
perform only three additions per second. Scientists realized that to 
increase the computational speed of computers mechanical relays 
must be replaced by vacuum tubes (see Figure 1.4). Vacuum tubes 
had already been used in radios for years. They could be switched on 
and off electronically, much faster than a mechanical relay could , 
and they contained no moving parts. 

The first electronic computer was built in 1945 at the University 
of Pennsylvania. The ENIAC (Electronic Numerical Integrator and 
Calculator) had 18,000 vacuum tubes, drew 130,000 watts of 
electricity, and weighed 35 tons. Instructions to ENIAC had to be 
wired onto boards that were plugged into the computer. Although 
ENIAC could compute faster than the Mark I, it took a long time to 
change programs, and vacuum tubes burned out frequently. 

The Second Generation. In 1947 the transistor was invented by a 
team of researchers headed by William Shockley at Bell Laboratories. 
The transistor performed the same function as the vacuum tube but 
required less space-it was 1 /200th the size-and less electricity­
it took 1I100 the power-gave off less heat, and was more reliable 
(see Figure 1. 4) . This invention began a new generation of computers 
classified as mainframe computers, large-scale systems requiring 

Figure 1.4. The Vacuum Tube and the Transistor (Courtesy of AT&T Archives) 
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special computer rooms, power generators, and air conditioning. In 
1952, Remington Rand installed the first commercially available 
computer. By 1964, the mainframe computer had developed into the 
.. state-of-the-art" IBM System/360®. 

During this same period, computer programming languages 
were invented. A programming language is composed of Englishlike 
commands that instruct the computer to perform specific tasks 
when they are combined in the proper sequence (a computer 
program). Programming languages replaced the need to hard-wire 
instructions into the computer. Grace Hopper developed the first 
compiler, a program that compiles Englishlike commands into the 
corresponding low-level instructions (machine language) that the 
computer understands. This concept greatly expanded the function­
ality of computers because it made it easier to change programs and 
gave more people an opportunity to use them. 

The Third Generation. Transistors had a flaw. They often broke off of 
the circuit boards. Texas Instruments and Fairchild Semiconductor 
simultaneously discovered the remedy: the integrated circuit, also 
known as the IC or chip. 

The first integrated circuits contained the equivalent of 10 to 500 
transistors. The chip lacks soldered wires, reducing its possible 
points of failure and thus making it ultrareliable. Because the 
integrated circuit is so tiny (one-half of a centimeter square), electric 
signals need travel only a short distance, saving time. 

In the 1960s smaller computer systems called minicomputers 
were introduced. These systems were based on the integrated circuit 
and required less space, less power, and less air conditioning. 
Mainframe computers of the period primarily functioned in the 
batch-processing mode. This meant that they worked on one job at 
a time and never started another task until the first one was 
completed. Most minicomputers, in contrast, operated in a time­
sharing mode. Users communicated with the computer using a 
terminal, a typewriter keyboard with either a printer or a 1V-like 
screen. Minicomputers could work on several jobs at once, sharing 
time with each user-hence the term. 

The Fourth Generation. Scientists were not satisfied with a mere 
500 transistors on a chip, so they developed the Large Scale 
Integrated (LSI) circuit and later the Very Large Scale Integrated 
(VLSI) circuit. The LSI chip contains the equivalent of 500 to 20,000 
transistors and can store several thousand characters of data. VLSI 
chips contain over 20,000 transistors. However, these new chips did 
not increase in physical size; the transistor circuits were miniatur-



1.1 A Brief History of Computing 9 

Figure 1.5. The Integrated Circuit (Brooks/Cote) 

ized. Million-function chips are common today, and engineers expect 
to squeeze ten million functions onto a chip soon (see Figure 1.5). 

The LSI chip provided the foundation for the development of the 
microprocessor chip found in today's microcomputers. In 1977, Apple 
Computer introduced the Apple II, a full-function computer the size 
of a portable typewrtter, at a price ordinary people could afford. A few 
years later, International Business Machines introduced the IBM PC 
(or Personal Computer). These companies launched the microcom­
puter industry. The microcomputer was an instant success because 
its owners never had to share the computer, as a minicomputer is 
shared; they could even carry it around. making it available at all 
times in all places. 

But the success of the microcomputer was not solely the result 
of its small size and modest cost. Software, or computer programs, 
designed for nontechnical users greatly expanded the demand for 
personal computers. Spreadsheet programs such as Visicalc for the 
Apple II and Lotus for the IBM PC "sold" computers because they gave 
nonspecialists the ability to use computers to solve business, 
financial, and mathematical problems. The potential of microcom­
puters in the future lies in the ability of hardware and software to 
become more integrated and to enable individuals to use computers 
more easily. 
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1.2 THE FUNDAMENTAL HARDWARE 
UNITS OF ANY COMPUTER 

A computer is an extremely fast and accurate processor of data. In 
the simplest configuration, most computers comprise these four 
units, which are connected electronically. 

1. An input unit (such as a computer keyboard or mouse). through 
which data are entered 

2. A central processing unit and primary storage, which stores 
the data input and processes it electronically 

3. An output unit (such as a computer screen or printer), which 
shows the results of processing the data input 

4. A secondary storage/retrieval unit (such as a disk drive), 
which stores information on and retrieves information from some 
magnetic medium (such as a floppy disk) 

Figure 1.6 shows these units in chart form. 
It is very important, especially if you're new to microcomputers, 

that you become familiar with the processes needed to access, or use, 
the system. This means first gaining confidence in using the system. 
The remainder of this chapter is devoted to building that confidence. 
This book's examples and assignments assume that you have access 
to a Macintosh computer running the 6.03 (or later) version of the 
operating system and the 2.0 (or later) version of Microsoft Works. 

Output Unit 
{TV Monitor) 

Input Unit 
{Keyboard 

and Mouse) 

Central 
Processing Unit 

and Primary 
Storage 

Secondary 
Storage Unit 
{Disk Drive) 

Figure 1.6. The Components of a Computer System 

Output Unit 
{Printer) 
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1.3 THE MACINTOSH FAMILY OF MICROCOMPUTERS 

The Macintosh was first introduced in 19B4; within 5 years it had 
become one of the most popular computers in America. Among the 
reasons for this popularity are its ease of use, high-quality text and 
graphics, communications compatibility with other computer sys­
tems both small and large, and high level of personal productivity. 

Over the past 6 years, the Macintosh has seen many changes. 
The original model included only 12BK (IK = 1024 bytes, or char­
acters) of RAM (Random Access Memory), a 400K floppy disk drive, 
and a built-in 9-inch monitor. Subsequent models, such as the Mac 
Plus®. SE®. and Mac n® series, offered greatly increased RAM, 
additional disk drives, larger monitors, and even color monitors.The 
variety of Macintosh models and components makes it difficult to 
describe all the possible combinations. Therefore, this book will limit 
discussions to a "typical" system: 

1. A Macintosh Plus or SE with 1 megabyte ( 1,024,000 bytes) of RAM 
2. A standard 9-inch built-in monitor 
3. An BOOK built-in floppy disk drive 
4. A second BOOK floppy disk drive or an optional 20-megabyte hard 

disk drive 
5. An Apple keyboard and mouse 
6. An ImageWriter 11® printer 

1.3.1 Inside the Apple Macintosh 

From the exterior, the Macintosh resembles a small 1V set with a 
keyboard. Inside its case are the integrated circuits that make it 
operate. Figure 1. 7 illustrates the .. core" of the Macintosh. The 
functional work unit is the Motorola 6BOOO series microprocessor 
chip, which is centrally located on the Mac's main logic board. 
Surrounding the microprocessor are memory chips, expansion slots, 
and other electronics necessary for operation. 

1\vo types of primary memory are found in most microcomput­
ers. ROM(Read-Only Memory) has programs and instructions already 
stored in it by the manufacturer. These programs may be used (or 
read) but not changed in anyway. They are permanent and are never 
lost, even when the power is turned off. In contrast, RAM (Random 
Access Memory) is read-and-write memory. It may be read or 
changed (or written to). When the power is turned off, anything 
stored in RAM is erased. Consequently, RAM is used for short-term 
memory needs. 

The Macintosh ROM contains program routines to print text and 
graphics on the monitor's screen, to store and retrieve data from 
memocy and disk, and to perform other basic system functions. The 
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Figure 1.7. The "Core" of the Macintosh (Courtesy of Apple Computer, Inc.) 

primary storage is used for storing applications such as Microsoft 
Works, program data files, and images of text and graphics on the 
screen. One byte of RAM can store a single alphabetic character or 
a three-digit number between 0 and 255. To store a single-spaced 
typewritten page with one-inch margins would require approximately 
3,510 bytes. This chapter requires 41,000 bytes of storage, and this 
entire book, including the figures, requires more than 4 megabytes. 

Several connectors are located at the rear of the Macintosh (see 
Figure 1. 8). They connect the keyboard, mouse, external disk drives, 
printer, telephone modem, and speakers. An expansion slot on the 
main logic board allows you to add special monitors, expanded 
memory. and alternate processor boards. 

1.3.2 The Built-in Monitor 

Some microcomputers will output to any television or monitor. 
However, the resolution (the number of individual dots on the screen) 
of the Macintosh is so fine that it requires a special monitor. The 
built-in 9-inch monitor displays 175, 104 pixels, or dots. The Mac­
intosh II system requires a separate monitor of its own. 

1.3.3 The Disk Drives 

The disk drives are the "file cabinet," or secondary storage system, 
of the Macintosh. Documents are created in primary storage, RAM, 
and must be stored on hard or floppy disks if you wish to save them 



1.3 The Macintosh Family of Microcomputers 13 

Figure 1.8. The Connectors at the Back of the Macintosh (Courtesy of Apple Computer, Inc.) 

permanently. The floppy disk drive on the Macintosh is capable of 
storing 400K, BOOK, or l.44Mb of information (as programs and/or 
data) per 3.5-inch diskette. 

Helpful Hint: If a single-spaced typewritten page of text contains approximately 
3,510 bytes of storage. a 3.5-inch BOOK floppy diskette would contain 
approximately 22B pages of text. 

The 3.5 inch diskettes can be inserted into and ejected from the disk 
drive by users. which enables them to transfer information from one 
Macintosh to another by carrying or mailing diskettes. The Mac SE, 
Mac II. and Mac Classic® are also capable of reading and writing 
IBM-formatted floppy diskettes. 

The basic hard disk drive stores 20Mb of information. The hard 
disk drive is a sealed unit permanently mounted inside the Macin­
tosh cabinet. It is constantly spinning at a high rate of speed and 
consequently transfers data much faster than the floppy disk drive 
can. Obviously, the advantages of the hard disk are speed and 
storage capacity. When a hard disk drive is used, floppy diskettes are 
only needed to transfer information or for back up purposes. 
Frequently used applications and files are best stored on the hard 
disk so they can be accessed almost instantaneously. Because 
information stored on both floppy and hard disks is retained even 
when the power is off, both are used for long-term storage. 

1.3.4 The Keyboard and Mouse 

All the Macintosh keyboards have standard typewriter keys plus a 
few special keys (see Appendix I for a summary of the functions of the 
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Figure 1.9. A Typical Macintosh System (Courtesy of Apple Computer. Inc.) 

special keys). An extended keyboard contains 15 function keys and 
additional special keys that are helpful for advanced users and 
necessary for running some IBM PC software on the Macintosh (with 
appropriate hardware and software). 

The mouse (see Figure 1.9) is an input device that eliminates 
much of the typing associated with early microcomputers. Using the 
mouse you can select items, execute commands, and control what 
is displayed on the screen. 

1.3.5 The Printer 

The most common and least expensive printer used with the 
Macintosh is the Apple ImageWriter II. a type of dot matrix printer. 
These printers use a series of small pins to print dots that make up 
the image on the paper. The Macintosh is a "what you see is what you 
get" (WYSIWYG) computer system. This means that the image you 
see on the computer's screen will print exactly the same way on the 
printer-including pictures. graphics. and fancy type styles. 

The Apple LaserWriter® printer costs much more, but provides 
higher-quality output. These printers have become commonplace in 
offices, print shops, art studios, and other businesses that require 
close to typeset-quality printing. The Macintosh and LaserWriter 
printer are the foundation of desktop publishing applications. 
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1.4 HOW TO USE THE MACINTOSH 

The following sections of this chapter will explain how to start up the 
Macintosh, how to use the mouse, icons, menus, and windows, and 
how to format a blank diskette. The presentation is intended for the 
beginner, so it's not a thorough discussion of every option, com­
mand, or action available to the Macintosh user. For more detailed 
information, see the Macintosh Owner's Guide and Macintosh Sys­
tem Software User's Guide, which are included with each Macintosh. 
If you're already familiar with the operation of the Macintosh and its 
system you may wish to skip to the next chapter. 

1.4.1 Getting Started 

To begin you will need a floppy start-up diskette, unless your 
Macintosh has a hard disk drive. A start-up diskette is any diskette 
containing a systemfolder. The system folder contains the Macin­
tosh operating system that must be loaded into RAM before using the 
computer. The examples and figures in this chapter use the Macintosh 
System Tools diskette included with each Macintosh. However, any 
diskette containing a system folder will work. To begin, follow these 
simple directions. (If you have a hard disk drive, you do not need to 
use a floppy diskette. Skip Steps 2 and 3.) 

1. Tum on the Macintosh by pushing up on the switch located at 
the back of the computer on your left. The Macintosh will beep. 

2. Insert a start-up diskette into the built-in floppy disk drive. The 
diskette's label should be facing up and its metal shutter should 
be pointing toward the back of the drive. 

3. Push the diskette gently into the disk drive until it is entirely 
inside and snaps down into position. Do not force it. If it doesn't 
seem to fit, you may be inserting it upside down or backward. 
Remove the diskette and try again. 

4. After a few seconds a welcoming message will appear, and then 
the Macintosh desktop will appear (see Figure 1.10). 

Experienced users call the process of starting up the Macintosh 
booting. The booting process loads the Macintosh Operating System 
from the diskette into RAM memory. This is essential for controlling 
the screen image, disk drives, printer, keyboard, mouse, and other 
peripheral devices. 

1.4.2 The Desktop, or Icon Hardly Wait 

After successfully starting up the Macintosh you will be viewing the 
desktop, which is analogous to the top of an office desk. Just as a 
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Figure 1.10. The Macintosh Desktop 

secretary would lay out ftle folders, papers, and diagrams on top of 
a desk. so the Macintosh "displays" the necessary information that 
you need to use on the Macintosh desktop. Both systems allow items 
to be moved around on the desk, shuffling the item that is to be 
worked with onto the top. 

Look closer at the desktop. At its upper right-hand side is an icon 
representing the start-up diskette. An icon is a graphic on the 
desktop that represents computer storage accessible to you. Numer­
ous icons are used on the Macintosh, representing floppy and hard 
disks, me folders, application software such as Microsoft Works, and 
word-processing documents. Figure 1.11 shows a few of the many 
icons you will see and work with as you become more familiar with 
the Macintosh. The start-up diRkette icon will either show a floppy 
diskette or a hard disk. The name of each diskette will appear below 
the icon. In the lower right-hand comer of the desktop is a trash can 
icon. The Trash is just what its name implies: a place to discard 
unwanted desktop items. Items placed in the Trash can be retrieved 
as long as the Trash has not been emptied. You will learn how to use 
the Trash later. 
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Sy stem Folder Setup Folder 
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Figure 1.11. Examples of Macintosh Icons 

Across the top of the desktop is the Menu Bar, which contains 
the categories of commands available to you. Each categoiy contains 
several commands that can be executed; for example, the File 
menu's commands will open, close, save, and print files. The 
categories on the Menu Bar change when you switch from one 
application to another, because the commands you need, for example, 
in word processing differ from those you need in drawing. Be patient! 
You will learn how to use the Menu Bar soon. 

1.4.3 Mousing Around 

The other image on the desktop is a small arrow. This arrow is the 
pointer controlled by your mouse. Place your hand on the mouse and 
roll it around on top of your desk. The pointer on the screen will follow 
its movement. If you go to the left, the pointer goes to the left, and so 
on. If you run out of space on your desk, you can pick the mouse up, 
move it over, and put it down again. 

There is also a button on the top of the mouse. Hold the mouse 
so that your index finger gently rests on the button. Roll the mouse 
so that the pointer is pointing directly on the Trash. Press and release 
the mouse button. The Trash will become highlighted (it will change 
from black on white to white on black). This is called selecting an 
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icon. The selected icon will be the object of any action or command 
that is executed. To reverse the process. or deselect an icon, simply 
point and click on another icon or anywhere on the desktop. 

You can drag a selected icon around on the desktop with the 
mouse. When you point to the Trash icon this time, continue to hold 
down the mouse button while you roll the mouse. An outline of the 
Trash will move on the Macintosh desktop as you roll the mouse. 
When you raise your finger from the mouse button, the Trash will 
have been moved to the new location. 

Using the mouse, point to the start-up diskette icon. Click the 
mouse button twice rapidly. This action will open the start-up dis­
kette, so you can see what is available in it. Figure 1.12 shows the 
result of double clicking the System Tools icon. The new object on 
the screen is called a window; it contains more icons, which rep­
resent folders and files stored on that diskette. 

Before going on, practice mousing around-try dragging icons 
out of the window and onto the desktop. When you are done, be a 
good citizen and put the icons back where they came from. 

s File Edit Uiew Special 

§D System Tools 
4 Hems 777K in disk 
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System Folder 
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Teach Text 

Figure 1.12. Opening the Start-up Diskette 

LJ 
Setup Folder 

• ' -
Read Me 



Get Info 
Duplicate 
Put Humi_4 

1.4 How to Use the Macintosh 19 

1.4.4 Pull Down the Menu, Dear 

Now that you have experience with pointing and clicking the mouse. 
you're ready to learn to use the Menu Bar. With the mouse. point to 
the Apple logo at the far left of the Menu Bar. Hold down the mouse 
button. Voilal A list of commands and options will remain on the 
screen as long as you continue to hold down the mouse button. Still 
pressing the button. roll the mouse to your right along the Menu Bar. 
As you pass over each category, a different list of commands appears. 
Release the button and the menus will disappear. 

A menu on the Macintosh is like a menu at a restaurant: a list of 
options from which you may choose. Look closely at the commands 
(see Figure 1.13). Some of them are in solid black letters. Others are 
shaded gray. The commands in solid letters are available for execu­
tion. The shaded commands are not available at this time because 
they would be inappropriate. For example, you cannot close a folder 
that has not been opened. The Macintosh Menu Bar will be very 
helpful. You seldom have to remember or look up commands; they 
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Figure 1.1 3. Using the Menu Bar to Open a Folder 
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are always handy on the desktop. The menu also reduces errors 
because it will not let you do something inappropriate. 

Select an icon on the desktop by pointing to and clicking on it. It 
will be best if you select a folder or diskette icon. Then point to the 
File menu and hold down the mouse button. Drag the mouse toward 
you. As you do so, the commands in the menu will be selected (white 
on black). You can roll down the menu or up the menu. Stop on the 
Open command and release the mouse button. You have just 
executed the command to open the folder or diskette that was 
selected. Similarly, you can close a window by selecting the appro­
priate command from the File menu. Try it. 

The icon you selected before should still be highlighted. Choose 
the Get Info command from the File menu. A little window will 
appear, describing the contents of the icon: the kind of document, 
the date it was created, how much storage space it requires, and 
more. The easy accessibility of this information is one of the nicest 
features of the Macintosh operating system. Close the window by 
choosing the Close command in the File menu. 

Practice using the pull-down menus. If it is not already open, 
open the start-up diskette. (Clicking on the diskette icon and 
choosing Open from the File menu opens a diskette, just as double 
clicking on the diskette icon does.) Now try each of the commands in 
the View menu. These commands let you view the contents of the 
window in different ways. 

With the start-up diskette still open, execute the New Folder 
command under the File menu. This will add a folder to the start-up 
diskette. You can store applications, files, and other folders inside 
this new folder. Drag an icon on top of the New Folder. What 
happened to it? Open the new folder and find out. 

1.4.5 Windows on the Mac World 

You have seen how a window displays the contents of a disk or folder. 
When you're using word-processing, spreadsheet, and database 
applications, windows will display your work in a document or file. 
Therefore it is most important to learn to manipulate windows on the 
desktop to work efficiently. 

One of the advantages of windows is that you can have multiple 
windows open on the desktop. This allows you to switch back and 
forth easily between windows. For example, you may have a spread­
sheet and want to transfer a calculation into a word-processing 
document. Other convenient features of windows are that they can 
be moved around on the desktop and changed in shape and size. 
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The best way to learn to use windows is by hands-on practice. 
From our example in the previous section you should have the start­
up diskette's window open on your desktop. You may already have 
a folder window open too. If not, open a folder so that two windows 
are open on your desktop. (Do you remember how to open icons? If 
not, review Sections 1.4.3 and 1.4.4.) 

Look closely at the two windows (see Figure 1.14). One of them, 
the "top" one, will have six horizontal lines on either side of its title. 
This indicates that it's the active window, the only one you may 
currently use. The other window may not be completely visible; a 
portion may be hidden by the active window. To bring the other 
window to the top, like shuffling a stack of papers, place the pointer 
inside it and click the mouse button. Practice switching between 
windows on the desktop. 

To move the active window to a different location on the desktop, 
point to the title bar, the area at the top of the window with the title 
and the horizontal lines (see Figure 1.15). hold the mouse button 
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Figure 1.14. Switching Between Two Windows 
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Figure 1.15. Using the Title Bar to Move the Window 

down, and drag the window around the screen. When you lift your 
fmger from the mouse button, the window will be repositioned at the 
new location. This action is similar to dragging an icon. 

To enlarge the active window, point to the size box, the two 
interlocking small boxes in the lower right-hand comer of the window 
(see Figure 1.16). Hold down the mouse button and drag the corner 
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Figure 1.16. Using the Size Box to Resize the Window 
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Figure 1.17. Using the Zoom Box to Size the Window to the Desktop 

down and out. When you lift your finger from the button the window 
will enlarge. displaying other information that may be in it. This 
process can be reversed to make the window smaller, too. Try it. 

Another way of enlarging the window is to use the zoom box. 
With the mouse, point to the two small boxes in the upper right-hand 
corner of the window (see Figure 1.17). Click the mouse button. The 
window will zoom up to fill the desktop. If you click the zoom box 
again, the window will return to its previous size. What a memory! 

When a window is resized, there may be more information in it 
than can be displayed. When this happens, scroll bars appear on 
the right-hand side, on the bottom, or both. The scroll bars can be 
used to roll information, text, pictures, icons, and so on, up and 
down or left and right inside the window so you can get to everything 
in it. To scroll a window, point with the mouse to one of the arrows 
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Figure 1.18. The Scroll Bars 

and hold down the button. The top vertical arrow scrolls the window 
down (see Figure 1.18). The bottom vertical arrow scrolls the window 
up. The left horizontal arrow scrolls the window to the left and the 
right horizontal arrow scrolls the window to the right. Another way 
of scrolling the window is to point to the scroll box, hold down the 
mouse button, and drag (see Figure 1.19). Practice these features; 
you'll need them later. 

There is one more window feature. In the upper left-hand corner 
of the window, find the close box (see Figure 1.20). Point and click 
in this box and the window will close. Clean up your desktop by using 
the close box to remove all the windows from sight. 
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Figure 1.19. The Scroll Box 
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Figure 1.20. Using the Close Box to Close a Window 

1.4.6 Formatting a Diskette 

To effectively use this text you will need to work the examples and 
problems in the following chapters. It will be necessary for you to 
store your work on a diskette. A blank disk purchased from a 
computer store cannot be used with the Macintosh until it has been 
formatted, however. This process, also known as initializing, pre­
pares the diskette so that data can be stored on its surface. On the 
Macintosh, this process can be initiated at any time by inserting a 
blank diskette in the disk drive. 

Obtain a blank 3.5-inch floppy diskette and format it, using the 
following steps. 

1. Start up the Macintosh using the procedure described in Section 
1.4.1; wait for the desktop to appear. 

2. Insert your blank diskette into any empty disk drive. If you have 
only one disk drive and the start-up disk is in it, use the Eject 
command from the File menu. 

3. A dialog box will appear. Point to the button labeled "Two-sided" 
and click. 

4. Another dialog box will appear. Point to the button labeled 
.. Erase" and click. 
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5. After a few seconds, another dialog box will appear and ask you 
to name the diskette. Type in whatever you want to name this 
disk (for example, Michelle's Data). 

6. After a few more seconds the computer screen will return to the 
desktop, having added an icon for your diskette. 

It is very important that you have a blank diskette in the drive when 
you follow this procedure; otherwise, you will destroy any programs 
or data on the diskette. Once the diskette is formatted for the 
Macintosh it cannot be used on another brand of computer unless 
it is formatted for that system. If you need to make a start-up 
diskette, follow the procedure outlined and drag the System Folder 
icon from the start-up disk onto the icon for the newly formatted disk. 
(Note: Depending on your hardware configuration, you may be 
instructed via dialog boxes to alternately insert the start-up diskette 
and the new diskette.) More information about creating start-up 
diskettes can be found in the Macintosh Owner's Guide and Macin­
tosh System Software User's Guide. 

1.5 POSERS, PROBLEMS, AND PROJECTS 

Most of the posers, problems, and projects in this book may be 
worked on the Macintosh. When possible, you should do so, 
because it will help you arrive at the solutions. As a last resort. or 
to check your work. refer to Appendix G for answers to selected 
problems. Problems preceded by an asterisk are somewhat more 
difficult; those preceded by a dollar sign are most appropriate for 
business applications. 

1. Referring to Figure 1.6, identify the components of a com­
puter system in relation to the Macintosh. 

2. Describe how to initiate the following actions and describe 
the result. 
point drag 
click double click 

3. Define the following terms. 
RAM chip 
ROM icon 

scroll 
boot 

window 
menu 

4. When you boot the Macintosh, the desktop appears. Name 
three items that appear on the desktop after booting and 
explain what they represent. 

5. Name the features that control a Macintosh window and 
describe how they work. 
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*6. Describe the steps used to delete a file from the desktop. 

*7. Obtain a blank diskette and format it. Create a new folder on 
the diskette (hint: use the File menu). Be sure you create the 
folder on your diskette. not on the start-up diskette. Name 
the folder Works Projects. You will use this folder later to 
store your projects. 
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"Many books require no thought from those who read them, and for a 
very simple reason; they made no such demand upon those who wrote 
them." 

-Charles Caleb Colton 

"There is no such thing as a moral or an immoral book. Books are well 
written, or badly written. That is all." 

-Oscar Wilde 

"One man's letter is another man's literature." 
-Anonymous 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Describe the three major advantages of word processing on a 
microcomputer (Section 2.2.1) 

2. Start up the Macintosh computer and the Microsoft Works 
program (Section 2.2.3) 

3. Enter and edit text in the Works word processor (Section 2.3.1) 
4. Save a word-processing file on your own floppy diskette 

(Section 2.3.2) 
5. Print the Works window and print a word-processing file 

(Section 2.3.3) 
6. Find specific text anywhere in a document and replace it 

with new text (Section 2.4.2) 
7. Cut, copy. and paste blocks of text within a word-processing 

document (Section 2.4.3) 
8. Change the font, size, and style of type used in the Works 

word processor (Section 2.4.4) 
9. Format a word-processing document, justifying the text and 

setting the line spacing, margins, paragraph indentation, 
and tab stops (Section 2.4.5) 

29 
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10. Check the spelling of a Works word-processing document 
(Section 2.4.6) 

11. Add page numbers, headers, footers, and title pages to your 
word-processing documents (Section 2.4. 7) 

2.1 AN INTRODUCTION TO MICROSOFT WORKS 

One of the primacy uses of computers is in managing information. 
Businessmen, educators, and students use computers in preparing 
written communications, keeping records. calculating formulas. 
monitoring resources, developing presentation materials, and ac­
complishing many other tasks. 

Five major computer applications manage information: word 
processing, electronic spreadsheet, database, presentation graphics, 
and telecommunications. Word-processing software allows you to 
enter, edit, and print text. Spreadsheet software lets you manipu­
late numbers, do estimates, track budgets, and perform hypothetical 
what-if analyses. Database software acts like an electronic filing 
cabinet, organizing and retrieving information and printing reports. 
Graphics software gives you design tools to prepare overhead 
transparencies, posters, charts, graphs, and other visual represen­
tations of information. Telecommunications software connects your 
microcomputer with another microcomputer. minicomputer, or 
mainframe computer via telephone lines so you can share informa­
tion or access remote databases. 

Until recently, a microcomputer owner wanting to use all five of 
these applications had to purchase five separate programs on at 
least five diskettes, learn five different sets of commands and 
instructions from five manuals, and would still be unable to transfer 
data easily between programs. In recent years, however, integrated 
programs have been introduced to combine several applications in 
one software package. One of the first and still-popular integrated 
packages is the Lotus 1-2-3 for the IBM Personal Computer. It 
combines spreadsheet, database, and graphics applications. 

Microsoft Works is another integrated package, but it combines 
all five of the major applications into one program for Macintosh 
computers. Like other integrated packages, it offers the advantage of 
sharing one set of commands and having one reference manual. It is 
less expensive to purchase than five separate programs, and data 
from all five applications can be stored on one diskette and shared 
by all. For example, a proposed budget can be electronically "cut" 
from the spreadsheet and "pasted" into an annual report in the word 
processor. Microsoft Works is the most widely used integrated 
package for the Macintosh. 
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2.2 GETTING STARTED WITH WORD PROCESSING 

Word processing is one of the most practical and most popular 
computer applications. It can be used by businessmen for preparing 
memos, letters, and reports; by educators for producing lesson 
plans, tests, and handouts; and by students for improving their 
writing skills, completing homework assignments, and learning 
about computers. 

The first word-processing systems were dedicated computers. 
In other words, they were microcomputers whose sole function was 
word processing. These machines were developed primarily by 
typewriter companies and sold for thousands to tens of thousands 
of dollars. Such systems are still available but are used primarily 
by businesses having large word-processing needs, such as the 
legal profession. Today word processing is available to anyone with 
access to a general-purpose microcomputer and appropriate word­
processing software. A word-processing program can be purchased 
for almost any computer for as little as $50 or as much as $700. 

2.2.1 Advantages of Word Processing 

Basically. word-processing software does what a typewriter does: it 
puts text on a page. The main advantage of word-processing software 
is that the text on the page can be easily edited and formatted. 
Writing is not just a matter of collecting your ideas and putting them 
down on paper. Good writing means editing, correcting, and rewriting. 
If they had to retype the page, most people would not take time to 
rewrite a sentence or paragraph even if they knew it would read 
better. Word processing lets you put your ideas into words on the 
computer's screen. Then, making corrections, insertions, and dele­
tions of a single letter, a word, a sentence, or a whole paragraph is 
as simple as moving the cursor to the desired location and entering 
and deleting the appropriate material. After rewriting and corrections 
are complete, a simple command transfers the written material to the 
computer's printer. 

In addition to entering, editing,fonnatting, and printing text, 
here are some other major features of word processing. 

Find and Replace. These features allow you to search an entire 
document quickly to ji.nd the next occurrence of a word or phrase. 
Once you fmd the text, you can replace it with new text. Let's 
suppose Michelle is Director of Public Relations for the Crescent City 
Paper Clip Company and has prepared her standard press releases 
using word-processing software. She takes a new position at the 
Acme Paper Clip Company. Using the find-and-replace feature of her 
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software, she can easily change every occurrence of Crescent City to 
Acme in her press releases with just one command. 

Deleting, Moving, and Copying Text. Text can be deleted one letter 
at a time by using the Delete or Backspace key. But special functions 
will delete one word at a time, one line, or even an entire paragraph. 
Other special functions allow you to move a word, sentence. or 
paragraph from one location in a document to another. The copy 
feature allows you to duplicate text anywhere in the same document 
or to store the text and insert it into other documents at a later time. 
These electronic cut-and-paste features could be used to prepare 
customized letters to clients from a standard list of paragraphs 
appropriate to the particular business. 

2.2.2 What You Need to Process Words 

To effectively use word processing you need access to a suitable 
microcomputer and printer, appropriate word-processing software, 
and some blank floppy diskettes. This chapter will assume that you 
are using the Microsoft Works software on a Macintosh computer 
system. If you are planning to do a lot of word processing, obtaining 
a portrait monitor, which is capable of displaying an entire 8 1 /2" x 
11" page, is advisable. Another recommended addition to your 
system is a hard disk drive to eliminate the need to change diskettes 
frequently and reduce file-saving errors. If you do not have a hard 
disk drive, you'll need two floppy disks to use Works. 

You will also need a printer and the appropriate cable to print 
your creative activities. A variety of printers can be used with the 
Macintosh. Section 2.3.3 will provide a general description of how to 
use a printer if you are not familiar with using one. This text assumes 
that you will be using an Apple ImageWriter II printer. Even though 
it is a dot matrix printer and hence lacks the resolution of the 
LaserWriter, the ImageWriter is the most popular printer among 
Macintosh users because it can print different sizes of characters. 
special foreign language characters, boldface text, underlined text, 
and proportionally spaced text. 

To get the most out of this chapter, you'll need at least one 
formatted floppy diskette on which to store the examples from the 
text and your own projects. 

2.2.3 Starting Microsoft Works 

To get started processing words with Microsoft Works, follow these 
instructions. 
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Helpful Hint: If you have Microsoft Works stored on a hard disk drive, tum on the 
Macintosh and skip to Step 3 below. 

1. Start up the Macintosh using the Works Startup and Program 
diskettes. (Remember how to start up the Mac? See Section 1.4.1 
if you need help.) 

2 . If the Works window shown in Figure 2 .1 is not visible on the 
screen, open the Works Program disk icon (see Section 1.4.3). 

3. Start Microsoft Works by selecting the Works icon (point and 
click) and selecting Open from the File menu. 

Short Cut: Double click-that is, click twice-on the Works icon. 

4. The Works desktop should appear. Select Word Processor by 
pointing to the icon and clicking. Create a new document by 
pointing to and clicking on the New button (see Figure 2.2). 

5. A word-processing document will be opened and the screen 
should appear as in Figure 2.3. 

Helpful Hint: In Step 4, you may inadvertently click the Open button that opens 
an existing ftle. Close this ftle by clicking on the close box or choosing 

s File Edit Uiew Special 

§0 Works Program 
4 items 760K in disk 

Microsoft Works Tutorial 

0 
MsWorksHelp Works Tools 

Figure 2.1. Starting Up Microsoft Works 
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Close from the File menu and repeat Steps 3 and 4. You have just 
created an Untitled word-processing document. In the following 
sections you will use this document to learn and practice the word­
processing features of Works. 

File Edit Window Macro 

1; • 
Rll Works Word 

Types Processor 

I lg} Works Program I 

Data 
Base 

D Tulo11al ~ 
CJ Works Tools 

Figure 2.2. Creating a New Document 

~ ~ 
Spread Communications 
Sheet 

Open jig} Works Pr ..• 

New 1\-J I [ Eject 

Cancel J I [ Driue 

D Import File 

s File Edit Window Search Format Spell Macro 

Untitled 

Figure 2.3. An Untitled Document 
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2.3 THE MICROSOFT WORKS WORD PROCESSOR 

If you correctly followed the directions in the previous section for 
starting Microsoft Works, you now see displayed on the computer's 
screen a window representing a word-processing document (also 
known ·as ajile). Because this is a new document, the window is 
empty (there is no text) and the document is labeled Untitled. After 
you have entered text, you will save your document. The save pro­
cess will ask you to name your document and will store it on either 
a floppy diskette or a hard disk. 

As you enter text, it is stored in the Random Access Memory of 
the computer. RAM is volatile memory that is erased when the 
computer's power is turned off. Consequently, if there should be a 
sudden power outage (such as when Rover trips over the power cord, 
unplugging your Mac), the text entered in your document will be lost. 
Saving the document copies text from RAM onto a floppy or hard disk 
for more permanent storage. Always save your work at regular in­
teivals and before quitting to avoid reentering information. 

2.3.1 Entering Text (Your First Document!) 

Entering text in the Microsoft Works word processor is as simple as 
typing on a typewriter. Here are a few features of the word processor 
that simplify the task. 

Ruler. At the top of the documenfs window is a ruler. This ruler 
is used to set the left and right margins, paragraph indentation, 
and tab stops. It can also be used to align text and graphics. 
Section 2.4.5 will teach you how to use the ruler to control the 
format of your document. When you open a new document, Micro­
soft Works assumes that you want a I-inch margin on each side 
of the paper. This leaves 6 1/2 inches between the margins for 
text (see Figure 2.3). 

Cursor. Directly beneath the ruler, in the upper left-hand corner of 
the document window, is a flashing vertical bar. This is the cursor. 
The cursor indicates where text will be printed on the screen. Type 
the word Apple on the keyboard. As you type, the cursor moves ahead 
to indicate where the next character will go. 

Delete or Backspace Key. Depending on which model of Macintosh 
you are using, there will be either a Delete or a Backspace key on the 
keyboard. Either one deletes the character to the left of the cursor. 
Press the Delete or Backspace key five times slowly and watch how 
each letter of the word Apple disappears. 
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Caps Lock and Shift Keys. The Caps Lock key locks the alphabetic 
keys in uppercase mode. This eliminates the need for pressing the 
Shift key repeatedly when you desire all capitals. Caps Lock is active 
when the key is in the down position. When it is in the up position, 
the keyboard functions in lowercase mode. The numeric and 
punctuation keys are not affected by the Caps Lock key. 

Return Key. The Return key is not used at the end of each line as it 
is on a typewriter. The Return key in the word processor is used to 
indicate the end of a block of text. This means that you continue 
typing text when you reach the end of a line. Works will automatically 
"wrap" the text onto the next line. This is known as word wrap. You 
do not press the Return key until the end of a paragraph. However, 
if you are entering text that must appear on a line by itself, such as 
a line in a poem or a title, press the Return key at the end of each 
complete line. 

Using the hints provided above, enter the following quotation 
(your screen should resemble Figure 2.4 when you are fmished). 

"We're still preparing our children for the same old repetitive 
jobs in the industrial age-the very jobs that are disappearing 
daily. Instead we should be preparing them for the jobs of the 
future, jobs that will require thinking skills, not rote 
memorization and repetition. 

Computers, with their library of knowledge at student's 
fmgertips, will make it possible for children to enjoy learning 
by making them explorers, active participants in educational 
adventures." 

-John Sculley 

Helpful Hint: Perhaps you need to make corrections? When the mouse is dragged 
inside the word-processing window, the pointer will change into an 
I-bar. Position the I-bar after the character that needs correcting. 
Click the mouse. The vertical cursor will move to the location of the 
I-bar. Press the Delete or Backspace key to erase the incorrect 
character and type the correct character. 

2.3.2 Saving Your Quotation 

At this point your document containing Mr. Sculley's quotation (we 
hope it resembles Figure 2.4) exists only in RAM. You must save your 
file if you want to store it permanently on your diskette; otherwise, 
when you quit Microsoft Works and tum off the Macintosh, your file 
will be lost! To save your file, do the following. 
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"We're still preparing our children for the same old repetitive jobs in the 
industrial age-the very jobs that are disappearing daily. Instead we 
sh o u 1 d be prep a ri n g them for the j obs of the future, jobs that will require 
think i n g skill s, not rote memo ri za ti on and rep et it i on. 

Computers, with their 1 i brary of knowledge at student's fingertips, will 
make it possible for children to enjoy 1 earning by making them explorers, 
active participants in education al adventures." 

-John Sculley 

Figure 2.4. The Finished Quotation 

1. Using the mouse, select the Save option from the File menu at the 
top of the screen. 

2. Adialogboxwill appear (see Figure 2.5). Type Sculley's Quotation 
into the Save Document As box. This will be the name of your file. 
You must type in a name. Works will not let you name your file 
Untitled. 

3. Insert the blank floppy diskette that you formatted in Chapter 1 
into the vacant disk drive. (If there is no vacant disk drive, click 
the Eject button to eject the Works Program disk and insert your 
blank diskette.) The name of your diskette will now appear at the 
top of the dialog box. 

4. With the mouse, point to the button labeled Save and click the 
mouse button. In a few seconds the dialog box will disappear and 
your document window will reappear. Your document has been 
saved and is now titled Sculley Quotation. 

Short Cut: Now that you have named and saved your document, the next time 
you select Save from the File menu you will not have to type the file 
name. The Macintosh will automatically save your document under 
its name. This process will replace the old document with the latest 
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I (g} Michelle's Data I 
~ 

~ 

Saue Document Rs: (g} Michelle's ••• 
I Sculley's Quotatio~ I ( Eject ) 

( Saue I;) ( Cancel ) ( Driue ) 

®Normal 0 EHport O Stationery 

D l:Hpor1 fl~ Hkh l°(m1 rorml~t 

Figure 2.5. The Save Dialog Box 

revisions. If you do not want to replace the original document. select 
the Save As command from the File menu and give the new document 
a different name. 

2.3.3 Printing Your Document 

There are two methods of printing in Works: you can print the 
contents of the window or you can print the entire document. Before 
you print, it is a good practice to save any changes that you have 
made to your document. 

Printing a Document. Microsoft Works contains many special op­
tions that allow you to format your documents precisely the way you 
want. There are options to set the margins, to choose single or double 
spacing, to specify page numbering, to select different type styles and 
sizes, and many more. A major advantage of the Macintosh is that 
what you see on the screen is what will print on the printer (known 
as WYSIWYG, "what you see is what you get"; pronounced "wizzy­
wig"). Before printing, check the screen to verify that what you see is 
what you want. 

To print a document, follow these steps. 

1. Align the paper on the Image Writer so that the perforation is just 
above the black rollers. Turn on the Image Writer by pressing the 
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Power and Select buttons. Both the power light and the select 
light should be on. 

2. Select Print from the File menu. The Image Writer printing dialog 
box (see Figure 2.6) should appear on the screen. 

3. Select the Best, Faster, or Draft mode by pointing to the desired 
option and clicking. Draft mode is the fastest method of printing, 
but it is not WYSIWYG. It should be used for proofreading text 
material only. The Faster mode is WYSIWYG. The Best mode is 
also WYSIWYG and gives you the highest quality of print, but it's 
the slowest method of printing. 

4. As an option, you can enter the number of copies desired or a 
specific range of page numbers if you do not want to print the 
entire document. You can also hand-feed paper into the 
ImageWriter if you wish. 

5. Point to and click on the OK button and your document will be 
printed. If you wish to stop the printing, hold down the Command 
(~)key and simultaneously press the Period(.) key. 

@Best 

® Rll 

D 
® Rutoma~ic 

v2.7 n 
O Faster O Draft 

O From: D To: D ( cancel ) 

O Hand Feed 

D Print Preuiew 

Figure 2.6. The lmageWriter Printing Dialog Box 

Printing the Window. To print an exact copy of only what appears 
within the window on your screen, including the ruler, select the 
Print Window command in the File menu. Be sure that the power on 
your Image Writer printer is turned on and that the select light is on. 

2.3.4 Quitting Works 

Now that you have been introduced to the word processor in Works, 
you need to know how to quit the program properly. 

1. Select Quit from the File menu. 
2. If you have made changes to your document since the last time 

it was saved, Works will ask you if you want to save the 
document. Click on the Yes button if you want to save the 
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changes, on the No button if you do not. If you click on the Cancel 
button, you will return to the word processor. 

3. After a few seconds, you will return to the Macintosh desktop. 
Select Shut Down from the Special menu. Your disk will be 
ejected and the Macintosh's power will be shut off. 

Helpful Hint: Although there are other ways to quit a Macintosh session, it is wise 
to always use Shut Down to ensure that your disk files are not 
damaged. 

2.4 GETTING FANCY: THE ADVANTAGES 
OF WORKS ON THE MAC 

This section will provide a more detailed look at how some of the 
special features work: finding specific text in your document, moving 
blocks of text, using different type styles and sizes, formatting the 
text, and spell-checking. To practice the commands necessary for 
accessing these features, frrst type in the example letter shown in 
Figure 2.7. 

Helpful Hint: If you need help, review the following steps and refer to previous 
sections as necessary. 

1. Start up the Macintosh (Section 1.4.1). 
2. Start up Microsoft Works and open an untitled word-processing 

document (Section 2.2.3). . 
3. Enter the text in Figure 2. 7 (Section 2.3.1). Remember to use the 

Return key only at the end of each paragraph or separate block 
of text such as the date, address, and salutation. Use theTab key 
to skip across the screen when entering the table of tensile 
strengths. 

4. Save the file on your data diskette (Section 2.3.2). 

2.4.1 Editing Text 

In Section 2.3.1, you learned how to enter text and make simple 
corrections by placing the cursor after a mistake, erasing the error 
with the Delete or Backspace key, and typing the correct characters. 
There are several short cuts to editing on the Macintosh. 

Selecting Text. You can use the mouse to select or highlight text in 
the word processor and then edit the text, move it, or reformat it. 
Mastering this technique is the key to becoming proficient with 
Works and the Macintosh. Let's practice. 

When you move the mouse so that the pointer is within the 
word-processing window, the pointer will change to an I-bar. In our 



May 25, 1991 

Mr. Sidney Celmour 
Marketing Director 
Acme Paper Clip Company 
123 Main Street 
Los Angeles, California 90001 

Dear Mr. Celmour: 
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I wanted to take this opportunity to let you know how much your product has improved over the 
past year. Since our last meeting, I have had the opportunity to test your new kevlar Super Clip 
against the other national brands. I am happy to report that it is the strongest paper clip in the 
nation. 

I wish to thank you for providing us with the necessary testing samples. Your research and design 
efforts have paid off as seen in the following table of tensile strengths: 

Acme Super Clip 
United Plastics' Clip 
Mitsubishi Paper Clip 
A.O.S. Paper Clip 

11,567 lbs. 
404 lbs. 
2,054 lbs. 
1944 lbs. 

If your marketing efforts are as successful as your design efforts, I am sure that you will achieve 
the largest share of the market. 

Yours truly, 

Max Durst 
American Testing Laboratories 

Figure 2.7. Letter to Sidney Celmour 

example letter (Figure 2. 7), place the I-bar between the letter C and 
the letter a in the word California in the address. Instead of clicking 
the mouse button to place the blinking cursor, hold the mouse 
button down and drag the I-bar over the letters alifornia. The let­
ters will become highlighted-white letters on a black background. 
Now press the Delete or Backspace key. The selected letters have 
been erased. Now type the letter A. You have successfully changed 
California to CA 
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The I-bar can be used to select a single letter, several letters in 
a word, a whole word, several words in a line, a whole line, several 
lines in a paragraph, a whole paragraph, several paragraphs, or the 
whole document. To select several lines, place the I-bar at the 
beginning of a line and drag down the page instead of dragging across 
the line. This technique will select entire lines. Practice selecting 
words, phrases, and lines. 

Helpful Hint: To select a whole word, place the I-bar anywhere on the word and 
double click with the mouse. The entire word, and the space after it, 
will be selected. To replace the word with another, simply type the 
new word. The selected word will be replaced by the new one. Try it 
in our example. Select the word opportunity by placing the I-bar on 
it and double clicking. Type the word cha.nee. 

Inserting Text. Suppose you wanted to add a sentence. How would 
you do it? Place the I-bar at the location you want to insert text, click 
the mouse, and type away! Using this method, you can insert a word 
between two words, a sentence between two sentences, or even a 
paragraph. The text following your insertion will automatically be 
"pushed down" and reformatted according to your margins. 

Deleting Large Amounts of Text. If you wanted to erase an entire 
paragraph, it would be silly to use the Delete or Backspace key to 
erase each letter one at a time. Instead, select the entire paragraph 
with the mouse and press the Delete or Backspace key once. 

Oops, I Goofed! There are trying times when we humans do make 
mistakes. The Macintosh therefore has a feature to undo mistakes. 
The Undo command is an option in the Edit menu in the Menu Bar 
at the top of the screen. When it is chosen, the last action that you 
performed will be undone and the screen will return to the way it was 
before your mistake. Remember, though, that you have only one 
chance to undo your mistake. In our example, select the entire 
second paragraph ("I wish to thank ... tensile strengths:"). Press the 
Delete or Backspace key. The paragraph will be erased. Immediately 
select the Undo command from the Edit menu. The paragraph will 
reappear. 

2.4.2 Searching for Information 

You can find specific text anywhere in your document by using the 
Find option in the Search menu at the top of the screen. Find will 
locate every occurrence of the text that you specify. This is particularly 



2.4 Getting Fancy: The Advantages of Works on the Mac 43 

helpful when you have a large document. Here are the steps 
necessary for finding your way around your document. 

I. Choose Find from the Search menu. A Find dialog box will appear 
at the bottom of your screen (see Figure 2.8). 

2. Enter the text you wish to fmd in the box labeled "Find What." In 
our example letter, let's find the name of the company: enter 
Acme. 

3. If you want to Match Whole Words Only. click on the appropriate 
box. Otherwise Works will fmd the letters that you have typed as 
a separate word or as part of another word. (If you specified his 
and did not check Match Whole Words Only. Works will find this 
and history.) 

4. If you want Works to check for uppercase and lowercase exactly 
as you have specified in the Find What box, click on the Check 
Upper /Lowercase box. (If we clicked on the Check Upper/ 
Lowercase box in our example. only Acme would be found; acme 
would not.) 

5. Click on the Find Next button. The word Acme in the address will 
be selected. 

6. Click on the Find Next button again. Works will find the next 
occurrence of the specified text. In your example. Acme will be 
selected in the table. 

7. When there are no more occurrences of the specified text, the 
Macintosh will beep and a message to that effect will appear on 
the screen. 

Find What: L..-1 R_c_m_.;.~ ________________ __, 

D Match Whole Words Only D Check Upper/Lowercase 

( cancel ) ( Find NeHt~ 

Figure 2.8. The Find Dialog Box 

Once you have found the text you are looking for, you can click 
on the Cancel button. You will return to the word-processing window 
at the location of the found text. 

Microsoft Works will also allow you to find text and replace it with 
new text by using the Replace option in the Search menu. For 
example. if you were writing a paper on Tchaikowsky you could type 
$$ instead of typing Tchaikowsky over and over. When you finished 
entering the paper. you'd use the Replace option to replace every 
occurrence of$$ with Tchaikowsky. Now that's a real time saver! 
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In your example letter, change the word Celmour to Sellmore by 
doing the following. 

1. Choose Replace in the Search menu. 
2. Enter Celmour in the box labeled Find What. 
3. Enter Sellmore in the box labeled Replace With. 
4. Click the Find Next button (see Figure 2.9). Celmour in the ad­

dress section of your letter will be highlighted. 
5. Click the Replace, Then Find button. Works will replace Celmour 

with Sellmore and then find the next occurrence of Celmour. 
6. Celmourin the salutation line ("Dear Mr .... ") will be highlighted. 

Click the Replace, Then Find button again. Celmour will be re­
placed. As there are no more occurrences of Celmour, the Mac will 
beep and a message will appear informing you of this fact. 

Find What: I Celmour 
:=================================================: 

Replace With: ~ls_e_1_1m_o_r_e~~~~~~~~~~~~~~~~~~~~~ 
(2J ~ D Match Whole Words Only D Check Upper/Lowercase 

( Cancel ) (Replace Rll) lhlJll<IH~- t!H~O !'ind ( Rl~!)hU:e ) u Find NeHt ~ 

Figure 2.9. The Replace Dialog Box 

Helpful Hint: Be very careful if you use the Replace All option. This option will 
automatically replace all occurrences of the text. It will not stop to 
ask if you really want to replace them, and you may not be able to 
Undo the replacements. 

In the Find and Replace dialog boxes there are two buttons 
marked t and en (see Figure 2.9). You are probably wondering what 
they are used for. The t button will find the place in the document 
where you have typed a tab stop and the en button will find where you 
have pressed the Return key. These can be very helpful but are rarely 
used by beginners. 

2.4.3 Cut and Paste: Moving Text 

The Macintosh has some very powerful features that allow blocks of 
text and graphics to be deleted from a document: moved from one 
place to another within a document, to another document, or to 
another application: and copied (duplicated) within a document, to 
another document, or to another application. All three functions are 
performed in a similar fashion, in that they require the use of the 
Clipboard. 
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The Clipboard is a special storage area set aside in main 
memory. It can store only one block of text or graphics at a time. 
When you cut or copy, the selected information is automatically 
moved to the Clipboard. When you paste, the information will be 
moved from the Clipboard and inserted at the location of the 
cursor. Because the Clipboard contains only one item at a time, 
you must paste an item before you cut or copy again, unless you 
are willing to lose that item. 

Cutting Blocks of Text: 
1. Select the block of text-words, sentences, orparagraphs-using 

the cursor (see Section 2.4.1). 
2. Choose Cut from the Edit menu in the Menu Bar. 
3. The selected text will be cut from your document and placed on 

the Clipboard. 

Helpful Hint: To check the contents of the Clipboard, choose the Show Clipboard 
option in the Window menu. To hide the Clipboard window, click in 
the close box or choose Hide Clipboard in the Window menu. 

Copying Blocks of Text: 
1. Select the block of text-words, sentences, or paragraphs-using 

the cursor (see Section 2.4.1). 
2. Choose Copy from the Edit menu in the Menu Bar. 
3. The selected text will remain in your document and a copy will be 

placed on the Clipboard. 

Pasting Blocks of Text: 
1. Place the I-bar at the location where you want the text pasted. 

Click the mouse button. Be sure that the blinking cursor is 
exactly where you want the text. 

2. Choose Paste from the Edit menu in the Menu Bar. 
3. The selected text will be copied from the Clipboard and pasted 

into your document. 

Figure 2.10 diagrams cutting, copying, and pasting using the 
Clipboard. Let's practice moving text in our example letter. Suppose 
you want to move the last sentence below the signature line as a P .S. 

1. Select the last sentence ("If your marketing . . . share of the 
market."), using the mouse. 

2. Choose Cut from the Edit menu. The sentence will be moved to 
the Clipboard. (Do you remember how to check to see whether it's 
on the Clipboard?) 

3. Using the mouse, place the cursor after the word Laboratories in 
the signature line. Press the Return key twice. Type P.S. and press 
the Space Bar twice. 
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4. Choose Paste from the Edit menu. Your sentence has been 
successfully moved from one location to another within the 
document. 

As you become more proficient in using different applications in 
Microsoft Works, you will learn how to cut and paste between the 
spreadsheet, the word processor, and other applications. 

2.4.4 The Fontastic Mac: Fonts, Sizes, and Styles 

As mentioned earlier, one of the major advantages of the Macintosh 
is that what you see is what you get. One of the best ways to make 
an impact in print is to use different styles of type, boldface type, 
italics, underlining, and different sizes of text. All of these features 
are available in Works on the Mac. 

Fonts. The termfont comes from the printing industry and means 
the style of type. If you compare professionally printed books, 
magazines, reports, and advertisements, you will notice that different 
fonts are used for emphasis or artistic expression. For example, this 
text is printed mostly in the Bookman font. 

On the Macintosh, fonts are stored in the system files on the 
start-up disk. Consequently you can individualize your diskettes to 
contain the specific fonts that you want to use. Chicago, Geneva, New 
York, and Monaco are four common fonts. However, there are 
thousands more: fonts designed for the screen and the ImageWriter 
printer and special fonts designed for the LaserWriter printer. 
Chapter 9 will discuss the use of laser fonts in desktop publishing 
and how to load custom fonts onto your start-up disk. 

To change the font of a block of text, do the following. 

1. Select the block of text-letters, words, sentences, orparagraphs­
using the mouse. 

2. Choose Font from the Format menu in the Menu Bar. Instead of 
releasing the mouse button when Font is highlighted, continue 
to hold down the mouse button. The Font submenu will appear. 

3. Roll the mouse to the right, highlight the desired font from the 
Font submenu, and release the mouse button. (The check mark 
indicates what font is currently being used for the block of text.) 

4. The block of text will be converted to the font chosen. 

Helpful Hint: If you want to change the font of an entire document, choose the 
Select All option in the Edit menu. The entire document will be 
highlighted. Select the font using the directions above. Try it on your 
sample letter. (You should exercise caution when using Select All, 
however. The entire text could be deleted if the Backspace or Delete 
key were accidentally pressed.) 
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Sizes. In addition to changing fonts, you can also display and print 
text in different sizes. On the Macintosh, the text size is specified in 
points, another term from the printing industiy. Type that is 72 
points is 1 inch high. The standard height of text on the Macintosh 
is 12 points, or one-sixth of an inch. The smaller the number of 
points, the smaller the type. Although some applications will produce 
text of up to 400 points, Works limits text to between 4 and 72 points. 

To change the size of a block of text, do the following. 

1. Select the block of text-letters, words, sentences, orparagraphs­
using the mouse. 

2. Choose Size from the Format menu in the Menu Bar. Instead of 
releasing the mouse button when Size is highlighted, continue to 
hold down the button and roll the mouse to the right. The Size 
submenu will appear. 

3. Highlight the desired size from the Size submenu and release the 
mouse button. (The check mark indicates what size is currently 
being used for the block of text.) 

4. The block of text will be converted to the size chosen. 

Helpful Hint: You will notice that the text sizes in the Size submenu are displayed 
in two ways: in bold text (20 Point) and outlined text (ll.2 Point). 
The outlined point sizes will print the best. The bold point sizes will 
be calculated from a smaller size and will sometimes print with 
ragged edges. 

Style. On the Macintosh, text style does not mean the font, but the 
emphasis placed on the text. There are eight text styles: Normal, 
Bold, Italic, Underline, 01UltUlCl.e, Shadow, Superscript, and 
Subscript . Superscript is printed above the normal text, as the 2 in 
x2. Subscript is printed below the normal text, as the 2 in H20. And 
the styles are additive: you can select two or more styles for any block 
of text. For example, you could have a bold italic underlined text. 
(You didn't believe me?) 

To change the style of a block of text, do the following. 

1. Select the block of text-letters, words, sentences, orparagraphs­
using the mouse. 

2. Choose Style from the Format menu in the Menu Bar. Instead of 
releasing the mouse button when Style is highlighted, continue 
to hold down the mouse button and roll the mouse to the right. 
The Style submenu will appear. 

3. Highlight the desired style from the Style submenu and release 
the mouse button. (The check marks indicate what styles are 
currently being used for the block of text.) 

4. The block of text will be converted to the style chosen. 
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Practice changing fonts, sizes, and styles in your sample letter. 
If you have a color monitor, experiment with the Color option in the 
Format menu. 

2.4.5 Formatting the Document 

You've learned a lot about word processing. Now let's look at some 
of the finishing touches: justifying text, double spacing, changing 
margins, and setting tabs. 

Justifying Text. If you type a letter on a typewriter, you normally line 
up each line with the left margin. On the right side of your letter, each 
line will be of a different length. To a printer, this is known as "flush 
left, ragged right." On the Macintosh, the terminology is left justi­
fied. Look at the morning newspaper. The text in the columns lines 
up on both the left and the right side. This is known as justified text. 
The spaces between words have been filled with extra space as 
needed, to make every line the same length. 

In addition to left justified and justified, Works allows you to 
right justify text. Each line will line up on the right hand margin, 
but will be ragged on the left. This technique is useful in printing 
poems and photograph captions. You can also center justify text, 
which centers each line between the margins. Figure 2.11 gives 
examples of each type of justification. 

To change the justification of a block of text, do the following. 

1. Select the block of text-letters, words, sentences, or para­
graphs-using the mouse. 

2. Choose Justification from the Format menu in the Menu Bar. 
Instead of releasing the mouse button when Justification is 
highlighted, continue to hold down the mouse button and roll the 
mouse to the right. The Justification submenu will appear. 

3. Highlight the desired justification type from the Justification 
submenu and release the mouse button. (The check mark 
indicates which justification is currently being used for the block 
of text.) 

4. The block of text will be converted to the justification chosen. 

In our sample letter, change the entire letter to justified. Use the 
Select All option in the Edit menu to select the entire letter. Then 
choose the Justified option in the Justification submenu. 

Spacing. Most typewriters allow you to set the line spacing to 
either single or double space. Works allows both of these options 
plus 1 1/2-line spacing and 6 lines per inch. The latter is used when 
you're printing on pressure-sensitive labels and other special forms. 
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Peas 
I eat my peas with honey, 
I've done it all my life. 
It makes the peas taste funny, 
But it keeps them on my knife. 
-Anonymous 

Left Justified 

Peas 
I eat my peas with honey, 

I've done it all my life. 
It makes the peas taste funny, 
But it keeps them on my knife. 

-Anonymous 

Right Justified 

Peas 
I eat my peas with honey, 

I've done it all my life. 
It makes the peas taste funny, 
But it keeps them on my knife. 

-Anonymous 

Center Justified 

Peas 
I eat my peas with honey, I've 
done it all my life. It makes the 
peas taste funny, but it keeps 
them on my knife. 
-Anonymous 

Justified 

Figure 2.11. Examples of Justification 
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To change the spacing of a block of text, do the following. 

1. Select the block of text-letters, words, sentences, or paragraphs-­
using the mouse. 

2. Choose Spacing from the Format menu in the Menu Bar. Instead 
of releasing the mouse button when Spacing is highlighted, 
continue to hold down the mouse button and roll the mouse to 
the right. The Spacing submenu will appear. 

3. Highlight the desired option from the Spacing submenu and 
release the mouse button. (The check mark indicates what 
spacing is currently being used for the block of text.) 

4. The block of text will be converted to the spacing chosen. 

The Ruler. The ruler at the top of the Works word-processing 
window controls the left and right margins, the paragraph indentation, 
and the tab stops. The margins and paragraph indentation are set in 
a similar fashion to changing the font or size of a block of text. Select 
the text with the mouse. To change the margins, point, click, and 
drag on either of the small triangles on the ruler. When you release 
the margin icon, the text will be adjusted to fit within the new 
margins. (Note: The spacing and justification will be preserved.) Let's 
investigate the icons for the various options in the ruler. 

• This icon represents the left margin. When an untitled document 
is opened, it is positioned at 0 on the ruler. 

-4 This icon represents the right margin. When an untitled docu­
ment is opened, it is positioned at 6 1 /2 inches on the ruler. 
This icon represents the p_aragraph indentation. Unlike on a 
typewriter, you do not need to press the Tab key at the beginning 
of a new paragraph in Works. Because you type a Return key at 
the end of each paragraph, Works "knows'' to indent the next line 
automatically. When an untitled document is opened, the 
paragraph indentation icon is located at 0 on top of the left­
margtn icon. 

Tab stops are easily set using the ruler. With the mouse, point 
just below the ruler and between the margin icons at the location 
where you desire a tab stop. Click the mouse button. A tab stop icon 
( 1- ) will appear. Tty it. Click on the tab stop icon that you have just 
defined. It changes to a different icon ( -I ). Click a third time. It 
changes again ( .t ) . Click a fourth time and it changes to still another 
icon ( t ) . Click a fifth time and it changes back to the frrst tab stop 
icon that you saw. Figure 2.12 gives examples of how each of these 
tab stops is used. Normally you set the tab stops before you enter 
text. As you are entering text, press the Tab key and the cursor will 
jump to the next tab stop. This process is similar to using tab stops 
on a typewriter. 
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Figure 2.12. Examples of Tab Stops 

In your sample letter, select the entire table of tensile strengths. 
Press the Delete or Backspace key to erase the table. Set two tab 
stops; one for the name of the paper clip manufacturer and one for 
the strength of its paper clip. Reenter the table in Figure 2. 7 using 
the Tab key. Now try different tab stops for the tensile strength 
column. Select the entire table and click on the second tab stop. 
What happens? 

Helpful Hint: If you know you want to use a specific font, size, style, justification, 
spacing, margin, or tab, you may want to select each of the 
appropriate options from the menus or the ruler before you enter 
text. Then, when you enter the text, everything will be to your 
specification. This will apply at the beginning of a document or at the 
beginning of a new paragraph. You can specify your preferences 
before you type text, or you can change the text after it is typed (the 
technique demonstrated in this chapter). Many professional writers 
who use word-processing software recommend that you first concen­
trate on the task of writing and then go back to change the formatting 
of the text. 

2.4.6 Check That Spelling? 

For many, the ability of word-processing software to check for 
misspelled words is a big advantage. However, there are some 
common misconceptions about the process. Spell-checking software 
does not correct spelling automatically. It simply identifies which 
words appear to be misspelled and gives you a choice of possible 
correct spellings. Ultimately, you must decide on the correct spelling. 
It does not check for grammar or punctuation and it does not check 
for the proper use of words in context. (For example, the words there, 
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their, and they're are all correctly spelled. but spell-checking soft­
ware will not identify when they are inappropriately used.) It will 
identify as misspelled many technical terms, proper names. abbre­
viations, and slang words that are simply not in the software's 
dictionary. 

Despite these limitations, spell checking saves proofreading 
time, improves your spelling skills. and helps produce more profes­
sional documents. To spell-check a document, follow these simple 
steps. 

1. To check the spelling of a portion of a document, use the mouse 
to select the text to be checked. To check the entire document, 
make sure that no text is selected. 

2. Choose Correct Spelling from the Spell menu in the Menu bar. 
3. When (or if) a word of unknown spelling is found, the Correct 

Spelling dialog box will appear (see Figure 2.13). At the upper 
light, the Unknown word is printed. Just below it is the software's 
best guess at the correct spelling (in the Replace With box). If you 
click on the View Suggestions button, the window at the left lists 
the words in the dictionary that are closest in spelling to the 
unknown word. 

4. If the Replace With box contains the correctly spelled word, click 
the Replace button and the unknown word will automatically be 
replaced with the correctly spelled word. The software will 
continue to check the remainder of the text. 

5. If the Replace With box does not contain the correctly spelled 
word, you can either type the correctly spelled word into the 
Replace With box, or you can scroll the Dictionary window until 
you locate the correctly spelled word and click on it to place it in 
the Replace With box. When you have the correctly spelled word 
in the Replace With box, click on the Replace button to correct 
the text. 

6. If the unknown word is not misspelled, you can either Skip it or 
Add it to the dictionary. Click on the Skip button to skip the word 
and continue checking the remainder of the document. Skipped 
words will be remembered and skipped again automatically later 
in the text. Click on the Add button to add the word to your 
dictionary. Once the word is added, it will no longer be unknown. 

Helpful Hint: Be careful not to add a misspelled word to the dictionary. But if you 
add a word incorrectly, you can remove it from the dictionary. Scroll 
the dictionary window until you locate the incorrect word. Click on 
the word and then click on the Delete button. You will be asked to 
confirm that you want to delete this word from the dictionary. 
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Figure 2.13. Correct Spelling Dialog Box 

7. When the entire selection or document has been checked, you 
will return to the normal document window. If you want to quit 
the spell checker before checking the entire text, click the Cancel 
button. 

Try checking the spelling of your sample letter. See what happens 
with proper names? Did you make any spelling errors? 

2.4. 7 More About Printing 

In Section 2.3.3 you learned how to print a document in the word 
processor. But there are times when you may want to use a different 
size of paper, set up special margins, or print page numbers. These 
features are controlled by the Page Setup dialog box. Choose Page 
Setup from the File menu now. 

At the top of the Page Setup dialog box (see Figure 2.14) you will 
find Paper options. The most commonly used options are US Letter 
and US Legal. When you click on these options the Paper Width 
and Paper Height will automatically be set for 8 1 /2 x 11 inches or 
8 1/2 x 14 inches, respectively. If you click Custom Size, you will 
have to enter your paper size in the Paper Width and Paper Height 
boxes. Computer Paper, A4 Letter, and International Fanfold are 
special sizes rarely used. 

The Orientation option allows you to print vertically or horizon­
tally (this is called landscape on some other computers) on the paper. 
Tall Adjusted is a Special Effect that should be selected if you are 
printing on an ImageWriter printer. This option adjusts the text so 
that 1 inch on your screen equals 1 inch on the printed paper. The 
50% Reduction option prints your document at half its width and 
half its height (one-quarter of its normal size). The No Gaps Between 
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Figure 2.14. Page Setup Dialog Box 

Pages option will ignore top and bottom margins and print right over 
the perforations on your computer paper. This option can be used to 
save paper on draft copies. 

The Header and Footer boxes are used to enter text that will be 
printed within the top (header) and bottom (footer) margin . These are 
normally used for entering the page number, document title, date, 
and so on. The text entered into the Header and Footer boxes will be 
printed on every page. Consequently, footers should not be used for 
footnotes. 

To print page numbers, follow these steps. 

1. Choose Page Setup from the File menu. 
2. Decide whether you want the page numbers at the top (header) 

or bottom (footer) of the page. 
3. Enter &P into the Header or Footer box. &P is a code that tells 

Works to print the page number at the left margin. If you want 
the page number right justified, enter &R&P (&R represents 
Right justified). If you want the page number in the center, enter 
&C&P. If you want the word Page to appear before the page 
number. enter &RPage&P. 
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4. Select the font and size of your header or footer by selecting the 
appropriate options from the Format menu while the Page Setup 
dialog box is still displayed. 

5. Click on the OK button. You will return to the word-processing 
window. 

6. If you do not want the page number to print on your first page, 
choose the Title Page option from the Format menu. It will be 
counted as a page, but no header or footer will be printed. 

7. If you do not want to start numbering the first page as page 
number I, choose the Set Page # option from the Format menu. 
Enter the page number from which you wish to start numbering 
and click the OK button. 

8. Choose Print from the File menu. Click on the Print Preview box 
and then on the OK button to check your page numbers. 

At the bottom of the Page Setup dialog box are options for setting 
the printing margins. You can enter the left, right, top, and bottom 
margin distances in inches. These are not to be confused with the 
margins that you set in the ruler: they are the printer paper margins. 
If your left Page Setup margin is at I inch and your ruler left margin 
is at 0 inches, your text will be printed I inch from the left side of the 
paper. If your right Page Setup margin is at I inch, your right ruler 
margin should be set at 6 I /2 inches (I-inch left margin + 6 I /2 
inches of text + I-inch right margin = 8 I /2-inch paper width). The 
top and bottom margins will determine how many lines of text will be 
printed on the page. 

All these options are probably confusing right now, but as you 
become more proficient at word processing you will ask yourself how 
you can do something out of the ordinary. The word-processing 
options used in various combinations are very powerful and versatile 
tools for the experienced user. Take some time now to practice the 
basics. Then use the skills you have learned and the information in 
this text to develop solutions to your word-processing problems. 

2.5 POSERS, PROBLEMS, AND PROJECTS 

I. Using the Works word processor, write a letter to a friend or 
relative telling the person how much you like using the 
Macintosh. Include at least three fonts, two sizes of type, and 
two styles of type. Print your letter. 

2. Copy any page of this text using the Works word processor. 
Tiy to match as closely as possible the type fonts, sizes, 
styles, margins, indents, tabs, and so on. 
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$3. Sidney Celmour has asked you to respond to Mr. Max Durst 
of the American Testing Laboratories. Prepare a standard 
business letter thanking Mr. Durst for his assistance. (See 
Figure 2.7 for the original letter.) Be sure to justify your text. 

4. Create an advertising flyer using the word processor. You 
could advertise a garage sale, church picnic, club activity, or 
anything you choose. Use large type sizes, different fonts, 
and various styles for emphasis. 
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H A P T E R 

ONE PICTURE IS WORTH 
TEN THOUSAND WORDS 



"What is the use of a book," thought Alice, "without pictures or 
conversations?" 

-Lewis Carroll 

"Every artist dips his brush in his own soul, and paints his own nature 
into his pictures." 

-Rev. Henry Ward Beecher 

"Every artist was first an amateur." 
-Ralph Waldo Emerson 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Differentiate between object-oriented graphics and pixel­
oriented graphics (Section 3.1) 

2. Enter and exit the draw mode at will (Section 3.1.1) 
3. Draw rectangles, squares, ovals, circles, polygons, arcs, and 

lines (Section 3.1.2 and Section 3.1.4) 
4. Change the properties, size, location, fill pattern, line size, line 

pattern, and line type of objects (Section 3. 1.3) 
5. Align objects accurately on the screen (Section 3.1.5) 
6. Create text objects in the draw mode (Section 3.2.1) 
7. Insert, delete, and replace text in a text object (Section 3.2.2) 
8. Change the font, size, and style of text in a text object (Section 

3.2.3) 

59 
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3.1 OBJECT-ORIENTED DRAWING 

Throughout history progress has been the result of people·s ability 
to understand complex concepts. Visual tools such as drawings. 
photographs. films, and videotapes provide a medium for making 
complex concepts understandable to everyone. After the computer 
had demonstrated its ability to analyze vast amounts of data rapidly, 
the idea of portraying visual information, or graphics. with it 
naturally evolved. 

The computer screen is somewhat like a printed map. Both are 
two-dimensional surfaces with a vertical and a horizontal direction. 
Just as any point on a map may be identified by its horizontal and 
vertical coordinates (or latitude and longitude). any point on a 
computer's screen can be specified by measuring its vertical and 
horizontal distance from a comer (usually the upper left). 

In early microcomputers, drawing graphics meant writing in­
structions to the computer specifying which points on the screen 
were to be illuminated. This process was time-consuming and 
generally inhibited the user·s creativity. Later versions of microcom­
puters were designed to allow the user to concentrate on the product 
rather than on computer programming. Consequently. graphics will 
be easy to create and add to any of your projects on the Macintosh. 

The dots on a computer's screen are called pixels for picture 
elements. There are 512 horizontal columns and 342 vertical rows, 
providing 175.104 pixels. Each of these pixels can be displayed as 
black or white on a monochrome screen or as red, green. or blue on 
a color screen. Through various combinations of these little points 
of light, up to 256 shades of gray or 256 colors can be displayed on 
the screen at once. Over 16 million color combinations are available 
on Macintosh color monitors. 

Two types of graphics software are available for the Macintosh: 
paint software and draw software. Paint programs are pixel oriented. 
In other words. you "paint" designs. shapes, and so on with the 
pixels. If a change or correction needs to be made you must paint 
over the pixels. much as an artist paints over a portion of a canvas 
to be worked. Draw software is object oriented. The user draws 
objects such as boxes. circles, and lines on the screen. These objects 
are stored in the computer·s memory and can be relocated. resized, 
erased, and edited at will. You will soon learn how you can create 
object-oriented graphics with Microsoft Works. 

3.1.1 Starting Works Draw 

Microsoft Works contains drawing tools within its word processing 
and spreadsheet applications. These tools can be used to enhance 
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and emphasize text, calculations, and graphs. To get started 
drawing, follow these directions. 

1. Start up the Macintosh using the Works Startup and Program 
diskettes. (Remember how? See Section 1.4.1 if you need help.) 

2. If the Works window in Figure 3. 1 is not visible on the screen, 
open the Works Program disk icon (see Section 1.4.3). 

3 . Start Microsoft Works by selecting the Works icon (point and 
click) and selecting Open from the File menu. 

Short Cut: Double click on the Works icon. 

4. The Works desktop should appear. Select Word Processor by 
pointing to the icon and clicking. Create a new document by 
,pointing and clicking on the New button (see Figure 3.2). 

5. A word-processing document will be opened and the screen 
should appear as in Figure 3.3. 

You have just created an Untitled word-processing document. In the 
following sections you will use this document to learn and practice 

s File Edit Uiew Special 

§0 Works Program 
4 items 760K in disk 

Microsoft Works Tutorial 

IU?KJ 
MsWorksHelp Works Tools 

Figure 3.1. Starting Up Microsoft Works 
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the drawing features ofWorks. Forget about word processing for now 
and let your creative juices flow. To begin drawing, choose Draw On 
from the Edit menu. 

Short Cut: To select Draw On or Draw Off, hold down the Command ( ~ ) key 
and press the J key. 

3.1.2 The Artist Within You: Drawing Objects 

When you select Draw On from the Edit menu, the Tool Box (see 
Figure 3.4) will appear at the left edge of the screen. To select one of 
the tools, use the mouse to point to a tool and click the mouse button. 
Try it now. Select another tool by pointing to and clicking on a 
different one. The previous tool is canceled and a new one selected. 

Select the Rectangle Tool (see Figure 3.4 if you need help). If you 
move the pointer into the document window, the pointer will turn 
into a cross hair. Cross hairs are used on a variety of instruments 
to make precise alignments. In Works, the cross hair will be used to 
locate the beginning and ending corners of your object. Place the 
cross hair where you want the upper left-hand corner of your 

Tools 
Pointer Tool Rectangle Tool 

Text Tool Rounded Rectangle Tool 

Line Tool Oval Tool 

Freehand Tool Polygon Tool 

Straight Line Tool 'l Arc Tool 

Default Fill Pattern Default Line Pattern 

Nudge Tool 

... 
Line Thickness Tool 111 ... 

Line Type Tool ~-____.... 
Figure 3.4. Works Draw Tools 
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rectangle to start. Holding the mouse button down, drag the cross 
hair to the lower right-hand corner of your desired rectangle. You 
should see the rectangle's outline on the screen. When you have 
positioned the cross hair exactly where you want the rectangle, 
release the mouse button (see Figure 3.5). Think of this process as 
having four components: point, click, drag, and release. 
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Figure 3.5. Drawing an Object 

3.1.3 Properties of Objects 

Objects in this application have six properties: size, location, line 
thickness, fill pattern, line pattern, and line type. The a dvantage of 
draw objects is that you can change these properties at any time in 
th e future without affecting text or other objects. Using the single 
rectangle that you drew in the previous paragraph , explore these 
properties. 

Size. An object can be changed in size, both vertically and horizon­
tally. When you finished drawing your rectangle, the Rectangle Tool 
(the cross hair) changed back to the PointerTool (the arrow) and eight 
small boxes appeared at the comers and center of each side of the 
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rectangle (see Figure 3.5). These little boxes are called handles. The 
handles indicate when an object has been selected; they can be used 
to enlarge or shrink the rectangle. Point to any handle, hold the 
mouse button down, drag the rectangle to a new size, and release the 
mouse button. 

Figure 3.6 shows the direction that each handle controls. For 
example, if you select the handle in the middle of the right side of the 
rectangle, you can only change the width of the rectangle. Similarly, 
if you "grab" the handle in the middle of the base of the rectangle, you 
can control only its height. Grabbing a corner handle will let you 
change both height and width at the same time. Try every handle and 
observe the results. 

l / 
-

.... .,.. ___ ... (I 

---

/ l 
Figure 3.6. Resizing an Object 

Helpful Hint: If the handles of an object disappear, it means that the object is no 
longer selected: you need to select it again if you want to change any 
of its properties. Point to any side of the object and click. 

Location. An object can be relocated anywhere on the screen at any 
time. Point to any side of your rectangle (but not on a handle), hold 
the mouse button down, and drag. An outline of the object will follow 
your mouse. You can place the object anywhere on the screen by 
releasing the mouse button. Remember that the handles indicate 
that an object has been selected. None of the properties of an object 
can be changed unless the object is first selected. 
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Line Thickness. In Works, five line thicknesses are available for any 
object. The Line Thickness Tool, located in the Tool Box; indicates 
the width of the line. With an object selected, point to the line 
thickness desired and click. The line thickness will change to the 
newly selected one. Try it. What h appens when you select the line 
thickness represented by the dotted line in the Tool Box? If you are 
going to be drawing several objects with the same line thickness, you 
can choose the desired line thickness before drawing. Every object 
will be drawn with the same thickness until a different thickness is 
selected. This process is analogous to a painter choosing a paint 
brush of a certain width. 

Fill Pattern. Any object can be filled with a pattern. Point to the Fill 
Pattern menu in the Menu Bar and hold down the mouse button. The 
menu will display the 39 possible fill patterns for any object. The 
patterns include solid black, solid white, and no ftll, represented by 
the 0 icon. No ftll is transparent; objects in the background will 
show through. Solid white is opaque and will cover up background 
objects. To fill an object , select it and then choose a pattern from the 
Fill Pattern menu (see Figure 3.7) . 
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A default fill pattern can be chosen so that any object drawn will 
automatically be filled with that pattern. The Tool Box displays the 
default fill pattern (see Figure 3.4). When you first choose the Draw 
On option in the Edit menu. the default fill pattern will be no fill. To 
change the default fill pattern you must not have an object selected. 
otherwise you will ftll that object. Place the pointer outside of your 
rectangle and click the mouse. The handles should disappear. Select 
a fill pattern from the Fill Pattern menu. The default fill pattern will 
change in the Tool Box. Select the Rectangle Tool and draw another 
rectangle. Subsequent rectangles will be filled with the default fill 
pattern. 

Line Pattern. Just as you can select the fill pattern for an object. you 
can select a pattern for the lines (sides) of the object. Select the 
original rectangle that you drew. (Remember. point to any side and 
click.) Using the Line Thickness Toot choose the widest line. Using 
the Line Pattern menu, choose a new line pattern from the 39 patterns 
available (see Figure 3.8). Your object can have both a fill pattern and 
a line pattern. Just for fun, try different combinations. 

s File Edit Window Format Fill Pattern Line Pattern Macro 
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Figure 3.8. Changing an Object's Line Pattern 
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As for the fill pattern, there is a default for the line pattern: 
initially, it's solid black. You can change the default the same way 
you did for the default fill pattern. See if you can figure this one out 
for yourself. 

Line Type. The Line Type Tool in the Tool Box determines whether 
a line terminates with an arrow or is plain. Only lines drawn by the 
Straight Line Tool or the Line Tool can have arrows. This is useful 
when you're adding text to a diagram to emphasize a feature. 

Helpful Hint: If you have been following along on your Macintosh, you probably 
have several objects on your screen and are wondering how to erase 
them. Select the object that you wish to remove and press the Delete 
or Backspace key, or choose Clear from the Edit menu. 

3.1.4 Back to the Tool Box 

So far you have investigated the Rectangle Tool and the properties of 
objects. Seven other tools also draw objects. The Rounded Rectangle 
Tool, the Oval Tool, the Line Tool, and the Straight Line Tool are used 
in the same manner as the Rectangle Tool: select the tool, point, 
click, drag, and release. Try each of these tools and experiment with 
the various properties you've learned how to control. 

The Polygon Tool allows you to draw objects with three or more 
sides. It works differently from the tools you already know how to 
use. Select the Polygon Tool from the Tool Box. Using the mouse, 
point to the starting point of the first side of your polygon and click 
and release the mouse button. As you move the mouse from the 
starting point, a "rubber band" line will be stretched until you reach 
the end of the side. Click and release the mouse again. Continue the 
process until all the sides have been drawn. The ending point of the 
last side of your polygon should be the starting point of the first side, 
to completely enclose your object. If you complete your polygon 
correctly, the cross hair will change into the pointer. Polygons have 
the same properties as rectangles. 

The Arc Tool draws 90° arcs (one-quarter of an oval). Once the 
arc has been drawn, it can be resized to less than or greater than 90°. 
Select the Arc Tool. Draw an arc. Grab a handle at either end of the 
arc and drag. What happens if you fill the arc with a pattern? 

The Freehand Tool lets you draw freehand on the screen as if you 
had a pencil in your hand. When you finish the object, a handle will 
appear at every change in direction of the freehand object. These 
handles can be used to correct any minor (or major) mistake. (Don't 
be discouraged; it takes time to improve your hand-eye coordination 
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enough to easily draw freehand objects.) Some interesting effects 
can be accomplished with fill and line patterns- experiment a little. 

3.1.5 Putting Things in Their Place: 
Aligning Objects and Other Strategies 

Several features have been added to Works that will help you get the 
objects on your screen exactly where you want them. This would 
seem easy enough to do, but after you have worked with object­
oriented drawing you may become frustrated without these aids. 

Nudging Objects. If you ever want to move an object over just one 
pixel, you will find it difficult to do by dragging with the mouse. The 
Tool Box contains just the solution: the Nudge Tool (see Figure 3.4). 
In the middle of the Tool Box are four arrows. When an object has 
been selected, it can be "nudged" up, down, left, or right. Each time 
the appropriate arrow is clicked with the mouse, the object will move 
one pixel in that direction. 

Selecting Multiple Objects. Thus far, you only know how to select 
one object at a time. But at times you may want to move several 
objects together, fill several objects with the same pattern, or delete 
two or more objects. Time and effort can be saved by selecting 
multiple objects and changing their properties all at once. 

The simplest technique for selecting multiple objects is to hold 
down the Shift key while you use the Pointing Tool. Try this. Draw 
several objects on the screen. Hold the Shift key down, select two 
objects in the normal manner, and release the Shift key. The handles 
on both objects will become visible. Try moving the objects. What 
happens? 

Another method that works well when you want to select many 
objects at once uses just the Pointing Tool. This tool can designate 
an area in which all objects will be selected. Select the Pointing Tool 
and point to the upper comer of the area you want to define. Hold 
the mouse button down and drag. A dotted rectangle will appear on 
the screen. Release the mouse button. Any object that is entirely 
contained within this area will be selected. 

Freezing an Object. No this isn't computer cryogenics, but there will 
be times when you wantto prevent an object from moving. If you have 
a lot of small objects on the screen, you may accidentally select one 
and move it. Freezing it in advance will prevent this from happening. 
Select the object, hold down the F key (for Freeze), and select the 
object again. The second time the object is selected, the handles will 
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disappear. If you try to select the object. you cannot. To "thaw" the 
object, hold the F key down and select the object. The handles will 
reappear and the object will behave normally. 

Restricting Movement. If you want to move an object but want to 
keep it aligned vertically or horizontally, there is a way. 

1. Select the object. 
2. Point to the object as if you were going to move it. 
3. Hold down the mouse button, but do not move the mouse yet. 
4. Hold down the shift key. 
5. Now move the mouse. The object will move only horizontally, 

vertically, or diagonally. 

Practice this procedure. If you have trouble, be sure you're following 
the steps in the exact order. 

Helpful Hint: Using the Shift key in conjunction with the Rectangle, Rounded 
Rectangle, and Oval Tools also restricts movement. This is the 
procedure used to draw perfect squares and circles. Select the 
appropriate tool. hold down the Shift key, point, click, drag, and 
release. 

Grouping Objects. Once you have completed a drawing made up 
of several objects, you can group them into one object. This is 
helpful if you want to duplicate it, relocate it in a document, or 
resize the objects proportionately. To group several objects into 
one picture, select every object using the techniques for selecting 
multiple objects described earlier and choose the Group Picture 
option in the Format menu. They are now one. To reverse the 
process, select the grouped object and choose Ungroup Picture 
from the Format menu. Each object will have its own handles and 
can be selected individually once again. 

Aligning with the Grid. If several objects need to be aligned, the 
easiest method is to use the grid in Works. The Format menu 
contains two options: Grid Setting and Grid On or Grid Off. Grid 
Setting lets you select the spacing of the grid from 1 /32 to 1 /2 of an 
inch or from 1/14 to 1 centimeter. The Grid On or Off option lets you 
switch back and forth between using and not using the grid. 

The grid lines are transparent on the screen. If the grid is on, the 
sides of an object snap to (align with) the spacing of the grid 
automatically when it is drawn. For example, if the grid is set at 
1 /2 inch, rectangles can be drawn only with sides of 1 /2 inch, 1 inch, 
1 1 /2 inches, and so on. If an object is relocated when the grid is 
turned on, it will automatically snap to the grid. This feature is very 
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handy when you're drawing flowcharts or organizational charts. 
Boxes of the same size can quickly be drawn and aligned. 

Bringing to Front and Sending to Back. Objects are drawn like a 
collage on the screen. Any object drawn after another one that 
overlaps the original object will appear in front. Objects can be 
rearranged by sending some to the back and bringing others to 
the front. · 

The best way to understand this process is to practice it yourself. 
Delete all the objects on your screen. (Remember how? Select the 
object and press Delete or Backspace.) Draw three circles on the 
screen and fill them with three different patterns. Drag the three 
circles so that one corner of each object overlaps a corner of the other 
two (see Figure 3.9). Select a circle that is partially covered. Choose 
Bring to Front from the Format menu. That circle will now come to 
the front. Choose Send to Back from the Format menu. The circle will 
go to the back. Practice with this process until you are comfortable 
with it. Then try rearranging the three circles so they are in exactly 
the opposite order, front to back, than they are now. What is the 
minimum number of steps necessary to reverse them? 
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Figure 3.9. Using Send to Back and Bring to Front 
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Helpful Hint: To hide a portion of an object from view, draw an object with a white 
fill pattern and no line pattern and drag it on top of the original object. 
For example, to draw a crescent moon, draw a circle filled with gray. 
Draw a second circle with a white ftll pattern and no line pattern. 
Drag the white circle on top of the gray one to create the crescent. 

3.2 TEXT AS AN OBJECT 

Text can be treated two ways in Microsoft Works: as normal text in 
the word processor and as a draw object. Chapter 2 describes how 
text can be managed in the word processor. The following section 
explains its use as an object in conjunction with other graphics. 

3.2.1 Creating Text Objects 

To create a text object, select the Text Tool from the drawing Tool Box 
(see Figure 3.4). When the pointer is dragged inside the word­
processing window, it will change into an I-bar cursor. This cursor 
indicates where the text will begin. Move the mouse so that the 
cursor is located near the middle of the screen. Press the mouse 
button. A rectangle outlined with a dotted line will appear and the 
I-bar cursor will change into a flashing cursor inside the rectangle. 
Type the following poem on the keyboard. (Don't forget to press the 
Return key at the end of each line!) 

Peas 
I eat my peas with honey, 
I've done it all my life. 
It makes the peas taste funny, 
But it keeps them on my knife. 
-Anonymous 

Select the Pointing Tool from the Tool Box. Point and click on your 
poem. Handles will appear around your text just as if it were a draw 
object. You can move the text, change its size, or fill it with a pattern. 
A text object will behave in the same manner as a draw object. 

3.2.2 Editing Text Objects 

Text objects can be edited easily using the same techniques used to 
edit text in the word processor. Section 2.3 describes those tech­
niques in detail. Here is a summary of the basics. 



3.2 Text As an Object 73 

Inserting Text. Using the Text Tool. position the I-bar cursor be­
tween the characters where you want to insert the text. Click the 
mouse. Begin typing. 

Deleting Text. Using the Text Tool, position the I-bar cursor at the 
beginning of the text you wish to delete. Holding down the mouse 
button, drag the mouse to select the text you wish to delete. The text 
will change from black on white to white on black. Release the mouse 
button when all the text is selected. Press the Delete or Backspace 
key. The text will disappear. 

Replacing Text. Using the Text Tool, select the text to be replaced in 
the same manner as for deletion. Type the new text. The old will be 
replaced with the new. 

Using the Peas poem, try your skill at rewriting. Try inserting, 
deleting, and replacing text until you are comfortable with these 
techniques. They will be used frequently in all types of applications 
on the Macintosh. 

3.2.3 Formatting Text 

One of the nicest features of the Macintosh is its ability to change the 
typeface, or font, of the text and show the result on the screen. 
Similarly, any change in the size and style (bold, italic, and so on) of 
the text is also shown exactly as it will appear on the final printed 
page. Section 2.4.4 provides detailed information on the formatting 
options. 

To satisfy your curiosity, try changing the font of your poem. 
Choose the Text Tool from the Tool Box. Select the entire poem. 
(Remember how to select text? Review Section 2.4.1 if you need 
help.) Use the mouse to access the Format menu in the Menu Bar 
at the top of the screen. Select the Font option while continuing to 
hold down the mouse button. A separate Font menu will pop up to 
the right of the Format menu. Slide the mouse to the right so that 
the pointer moves into the Font submenu. An individual font in the 
Font submenu can be chosen by running the mouse up and down the 
menu until the desired font is highlighted (try New York). Release the 
mouse button. The entire poem will be converted to the selected font. 

Now make the title, Peas, bold text. Using the mouse. select the 
title. Under the Format menu there is also a Style submenu. Select 
the Bold option from the Style submenu the same way you selected 
your new font. To make the title larger, select the title and 18 Point 
from the Size submenu of the Format menu. Your text object should 
now look like this: 
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Peas 
I eat my peas with honey, 
I've done it al I my I ife. 
It makes the peas taste funny. 
But it keeps them on my knife. 
-Anonymous 

Helpful Hint: The Font, Size, and Style submenus will indicate the current 
characteristics of the selected text with a check mark in front of the 
name of the font, size, and style. 

Experiment with creating text objects in different fonts, sizes, 
and styles. As you work, keep in mind that most text Will be entered 
using the word processor, not the Text Tool from the drawing Tool 
Box. Text objects should be reserved for text that needs to be 
combined with drawings and for text that will appear in columns (as 
in a newsletter). The use of text objects in desktop publishing will be 
discussed in Chapter 9. 

Helpful Hint: To return to the word-processing function of Works, you must turn 
off the draw functions. Choose Draw Off from the Edit menu. 

3.3 POSERS, PROBLEMS, AND PROJECTS 

Be sure to complete the Acme Paper Clip Company simulation 
introduced here. This drawing and subsequent assignments will 
be used to develop additional materials in the following chapters. 
If you need help, turn to Appendix G. 

* 1. The Acme Paper Clip Company has just purchased several 
Macintosh computers and Microsoft Works for its employees. 
One of the first projects for Sidney Celmour, Acme's market­
ing director, is to design and develop catalog sheets describ­
ing Acme's newest product, Super Clip. Sidney has recruited 
the help of Art Klepp, the chief designer in the art depart­
ment. Your assignment, should you choose to accept it, is 
to draw the Super Clip for Mr. Klepp using Works' draw tools. 

Super Clip 
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Be sure to save your work for Art Klepp. After you have 
completed your drawing of the Super Clip, choose the Save 
option under the File menu. When the Save dialog box 
appears, type Super Clip and press the Return key. 

$2. Using the draw features of Works, design a company logo for 
the Acme Paper Clip Company. Use this logo to create 
letterhead stationery for the company. (You will find Acme's 
address in the letter in Figure 2.7.) 

Helpful Hint: When you save your fmished letterhead, click the Stationery box in 
the Save dialog box. When you want to type a letter on letterhead, 
open the letterhead file. It will be opened as Untitled, preventing you 
from accidentally erasing your letterhead. Type in your letter, save 
the finished letter, and print it. 

3. Design a business card for Sidney Celmour. Use only the 
draw tools, including text objects. Include two fonts, two 
sizes, and two styles of text. See if you can shrink your 
company logo and put it on the business card also. 
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H A P T E R 

FIGURES WON'T LIE, 
BUT SPREADSHEETS 

WILL FIGURE 



"Facts and Figures! Put 'em down!" 
-Charles Dickens 

"Statistics are like alienists-they will testify for either side." 
-Fiorello La Guardia 

"The difference between an accountant and a bookkeeper is a 
sizeable figure." 

-Anonymous 

OBJECTIVES 

When you've completed this chapter. you'll be able to do the 
following. 

1. Discuss the advantages of using electronic spreadsheets 
(Section 4.1.1) 

2. Start up the Works program and create a new spreadsheet file 
from scratch (Section 4.2) 

3. Enter labels. values, and formulas into a spreadsheet (Section 
4.2.2) 

4. Edit a spreadsheet by clearing cells. inserting rows and 
columns. deleting rows and columns, and editing the contents 
of a cell (Section 4.2.3) 

5. Modify the spreadsheet format by setting the cell attributes. 
changing the column width. adding borders. and changing the 
font, size. and color (Section 4.2.4) 

6. Save a spreadsheet on a data diskette and print a spreadsheet 
(Section 4.2.5) 

7. Use the future value, summation. logical If. and table Lookup 
functions in a spreadsheet formula and use the Fill Right and 
Fill Down commands to copy a formula into adjacent cells 
(Sections 4.2, 4.3. and 4.4). 

77 
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Course 
Biology 
Philosophy 
Art History 
Computer Science 
English 
Overall Average 

8. Explain the difference between a relative and an absolute cell 
reference (Section 4.3.2) 

9. Sort a spreadsheet into any order, based on multiple sort keys 
(Section 4.4). 

4.1 GETTING STARTED WITH SPREADSHEETS 

An electronic spreadsheet is a computer program that turns the 
screen into a electronic columnar pad. For years accountants have 
been using large paper worksheets, or spreadsheets, containing 
many columns for entering financial data by hand. The numbers in 
each column and row are added, averaged, or otherwise manipulated 
to provide the accountant with the desired calculations or projections. 
Today's personal computers provide an electronic means of doing the 
same thing using spreadsheet software. 

4.1.1 Advantages of Electronic Spreadsheets 

Any accounting. budgeting. projection. or tabulation problem that 
can be solved with pencil and paper can be solved faster and more 
easily using a computerized spreadsheet. The spreadsheet program 
allows you to defme each entry in its approprtate row and column. 
The entry could be a label (SALARIES, SUPPLIES, EQUIPMENT), a 
numeric value ($99.95, 250, 3.14159), or a formula or calculation 
(B 1 + B2+ B3-A5). Instead of having to manually add a row or column 
of figures, you can direct the spreadsheet to automatically solve all 
calculations. If a numeric entry is changed, all calculations related 
to that entry are recalculated. (An example of such a spreadsheet is 
shown in Figure 4.1.) 

In a large spreadsheet, once a calculation is defined for a 
particular row or column it can easily be reproduced to apply to as 
many other rows or columns as you want. This feature saves the 

Test 1 Test 2 Test 3 Test4 Avera e 
75% 80% 78% 77.7% 

73% 83% 78.0% 
95% 90% 97% 94.0% 
99% 98% 99% 98.7% 
67% 72% 69.5% 

83.6% 

Figure 4.1. Sample Spreadsheet 
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experienced user time when designing a spreadsheet. Spreadsheet 
programs also have features for editing entries, saving and loading 
worksheets on floppy or hard disks, and printing reports. 

In business contexts, spreadsheets have obvious management 
applications for budgeting, accounting, and financial modeling. But 
individuals also use spreadsheets for a variety of other purposes, 
such as calculating the board feet of lumber needed to build a room 
addition, keeping track of the value of a stamp collection, maintain­
ing an inventory of household items. and analyzing professional or 
college football scores. Figure 4.1 shows an example of how you 
might use a spreadsheet to keep track of your grades. It is abbre­
viated to fit the printed page limitations of this text but could be 
expanded to include more scores or more courses. 

Note in Figure 4.1 that Test 4 has not yet been taken in any 
course. After the exams are over and the grades received, the new 
percentages can be entered for each course. The Average for each 
course would automatically be recalculated to include the new test 
score. After each course average were updated, the Overall Average 
would also be recalculated. Notice that our student missed Test I in 
Philosophy. If the student made up this exam and entered the result, 
the Average for Philosophy would be recalculated, along with the 
Overall Average. This automatic calculation feature of spreadsheet 
software can save hours of manual work. 

4.1.2 Using Works Spreadsheet 

The Works integrated software contains an electronic spreadsheet 
in addition to word-processing, database, and other applications. 
The remainder of this chapter will assume that you are already 
familiar with the basic functioning of Works and have a floppy 
diskette initialized on which to store these examples. Be sure to 
complete the previous three chapters before continuing. If you feel 
you need a review of basic Works, reread the following sections. 

1.4 

2.1 
2.3.1 
2.3.2 
2.3.3 
2.3.4 
2.4.1 
2.4.3 
2.4.7 

How to Use the Macintosh 
An Introduction to Microsoft Works 
Entering Text 
Saving Your Quotation 
Printing Your Document 
Quitting Works 
Editing Text 
Cut and Paste: Moving Text 
More About Printing 
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This chapter will explain how to use the features of the Works 
spreadsheet by having you design and develop several example 
spreadsheets. To gain maximum benefit from this chapter, you 
should work the examples on a Macintosh while following the 
instructions in the text. 

4.2 SPREADING THE WEAL TH 
(A PERSONAL BUDGET EXAMPLE) 

In this example, you will design and develop a simple personal 
budget using Microsoft Works. You will learn how to enter data, 
calculate projected expenses, edit data, customize the layout, save 
the spreadsheet on a diskette, and print a budget report. To begin, 
start up Works and create a new spreadsheet document following 
these directions. 

1. Start up the Macintosh using the Works Startup and Program 
diskettes. (Remember how? See Section 1.4.1 if you need help.) 

2. If the Works window is not visible on the screen, open the Works 
Program disk icon (see Section 1.4.3). 

3. Start Microsoft Works by selecting the Works icon (point and 
click) and by choosing Open from the File menu. 

Short Cut: Double click on the Works icon. 

4. The Works desktop should appear. Select Spread Sheet by 
pointing to its icon and clicking. Create a new document by 
pointing to and clicking on the New button (see Figure 4.2). 

5. A spreadsheet document will be opened and the screen should 
appear as in Figure 4.3. 

4.2.1 Mousing Around the Spreadsheet 

The Works spreadsheet comprises 256 columns labeled from A to IV 
across the top of the window and 16,382 rows labeled down the left 
side of the window. Each entry in the spreadsheet is placed in a cell, 
and the cells are identified by their column-row coordinates. For 
example, the cell in the upper left-hand corner of the spreadsheet 
window (see the arrow in Figure 4.3) is identified as Al because it is 
in column A, row 1. Likewise, the cell in the lower right-hand corner 
of the window is Fl 7 (column F, row 17). 

The active cell is the cell you are currently working in; it is 
identified by a shaded border around its edges. Using the mouse, 
point to cell Al and press the mouse button. The cell location, Al, will 
appear in the cell reference box located just below the Apple menu, 
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and a border will appear around the cell . (Refer to Figure 4.4 to 
identify the features of a Works spreadsheet.) Press the Right Arrow 
key several times to move the active cell. If you keep pressing the 
Right Arrow key, the screen will scroll to the right. Try u sing the Left 
Arrow. Down Arrow. and Up Arrow keys to discover how to move the 
active cell around the spreadsheet. Notice that the identification of 
the active cell changes in the cell reference box as you move around 
the spreadsheet. 

In addition to using the arrow keys. you can move around the 
spreadsheet window using the scroll bars or scroll boxes. (If you need 
to review how to use the scrolling features of Macintosh windows. 
refer to Section 1.4.5.) You can also use lhe mouse to select an active 
cell by pointing to any cell in the window and clicking. After you have 
experimented with the arrow keys, scroll bars. and mouse, scroll the 
window to its original position. with cell Al in the upper left-hand 
corner and make cell Al the active cell (see Figure 4.3). 

4.2.2 Entering Data 

Entering data into the spreadsheet is as simple as entering text 
into the word processor. However, before entering data, you must 
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choose the appropriate active cell and determine which type of 
data you will be entering: labels, values, or formulas. To enter 
data, follow these steps. 

1. Move the active cell to the desired location using the techniques 
described in Section 4.2.1. 

2. Type in the data. Use the Delete or Backspace key to erase 
mistakes. 

3. Press the Return, Enter, Tab, or any Arrow key. 

Helpful Hint: As you type the data, they appear in the cell contents box (see Figure 
4.4). They will appear in the active cell after Step 3 is executed. 

The key you press in Step 3 will determine which cell becomes the 
next active cell. The Return key and Down Arrow key move the active 
cell to the one immediately below the one into which you just entered 
data. The Tab and Right Arrow keys move the active cell one cell to 
the right after data are entered. The Left and Up Arrow keys move the 
active cell in the direction indicated on the key. The Enter key 
"enters" the data into the cell without moving the active cell. 

Labels. Spreadsheet labels are alphabetic letters, numbers, and 
punctuation marks that help to describe the data but that are not 
used in any calculations. Examples of labels are titles, column and 
row headings, and footnotes. For your personal budget example, 
move the active cell to cell 84, type January, and press the Tab or 
Right Arrow key. You have just entered January into cell B4 and are 
ready to enter the next label into cell C4. Type February and press the 
Right Arrow key again. Continue with this procedure, entering March 
in cell D4 and Total into cell E4. You have just entered the column 
headings for your budget. Now move the active cell to AS and enter 
the following row headings. 

Cell Enter Text 
AS Rent 
A6 Groceries 
A7 Automobile 
AB Utilities 
A9 Entertainment 
AlO Total 

Finally, move to cell C2 and enter your name and the word Budget 
(for example, Michelle's Budget). Your spreadsheet should now look 
like Figure 4. S. 

Values. A value entry in a cell includes any numeric data that will 
be used for calculation purposes. In your sample budget, you need 
to budget some values for each month and expense category. Move 
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Figure 4.5. Personal Budget Labels 

to cell B5 and enter 400forJanua:ry rent. Do not enter a dollar sign, 
and do not be alarmed that the amount does not align with the 
January heading. Techniques for formatting your layout will be 
discussed later. Continue entering values for the remainder of the 
months and expenses, using Figure 4.6 as a guide. Do not enter 
totals, because you will program the spreadsheet to calculate them 
automatically. 

Formulas. You can enter a formula into a cell to program the 
spreadsheet to perform automatic calculations. To enter a formula, 
you type an equal sign (=)followed by a mathematical expression. In 
your personal budget, you need to sum the expenses for each month 
and sum the expenses for each expense category. Move to cell BIO, 
enter the formula =B5+B6+B7+BB+B9, and press the Enter key. This 
formula says that cell B 10 equals the values of B5, B6, B7, BB, and 
B9 added together. The value 900 should now appear in cell B 10 and 
the formula should appear in the cell contents box just below the 
Menu Bar (see Figure 4.4). Move to cell ClO and enterthe formula for 
February's total. 

Helpful Hint: =C5+C6+C7+C8+C9. 

Now enter the formula for March's total expenses. 
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Short Cut: To simplify typing formulas , Works allows you to use the mouse to 
identify cells to be added to a formula . In your budget example. make 
cell 010 the active cell and type the equal sign ( = ). Using the mouse, 
point to cell 05 and click the mouse. D5will be added to your formula. 
Continue us ing the mouse to point and click on cells 06, 07, 08, and 
09. One by one, each cell will be added to the formula. By default, 
Works puts the addition sign(+) between each cell reference. Press 
the enter key to complete your formula. 

Helpful Hint: If you point and click on the wrong cell as you defme your formula, 
the fom1ula will be incorrect. Be sure to look at the cell contents box 
as you define your formula. If you click on a cell by mistake, u se the 
Backspace or Delete key to erase the last entry. Sometimes the 
formula becomes totally incomprehensible as a result of accidental 
mouse clicks. Click on the cancel box (the box with the X to the left 
of the cell contents box; see Figure 4.4) and start over. 

Built-in Functions and Formula Filling. In your budget example you 
h ave only a few columns and a few rows. But what if you had all 12 
months and 20 expense categories? It would seem to take forever to 
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enter the formulas. Fortunately, Works offers several features that 
simplify the task. One of them is the use of a built-in.function to sum 
a long column or row of values. Follow these directions to use the 
Sum function to calculate the 3-month total expenses for rent in your 
sample budget. 

1. Move the active cell to the desired location (in your example, E5). 
2. Type =Sum( 
3. Using the mouse, point to the first cell in the series of cells to be 

summed (in your example, B5). 
4. Hold the mouse button down and drag the mouse toward the last 

cell in the series of cells to be summed (in your example, D5). As 
you drag the mouse, a shaded border will appear around the cells 
being summed (see Figure 4.6). 

5. When you have identified the cells to be summed, release the 
mouse button. Be sure you stop dragging the mouse when you 
reach the last cell to be summed. The formula in the cell contents 
box should read =Sum(B5:D5 If it does not. click on the Cancel 
box and repeat Steps 2 through 5. 

6. Type ) and press the Enter key. 

This technique greatly reduces the amount of typing necessary to 
enter the formula for summing a long row or column of numbers. 

Helpful Hint: For very long rows or columns of numbers it is easier not to use the 
mouse to identify the cells to be summed. Follow Steps 1 and 2; then 
type the first cell to be summed in the row or column (in your 
example, B5). Type a colon. Now type the last cell to be summed in 
the row or column (in your example, D5). Finish with Step 6. 

Now that you have entered the formula to calculate your total 
expenses for rent, you can copy that formula into the cells to total the 
other expense categories. In the Works spreadsheet, this process is 
called.filling down or filling right. This general concept of dupli­
cating the contents of a cell into other cells is common to all 
spreadsheet programs. Other programs call this function replicating 
or copying a formula. 

Follow these general directions for filling formulas to complete 
your personal budget. 

1. Using the mouse, point to the cell that contains the formula to be 
copied (in your example, E5). 

2. Click and drag the mouse down the column or across the row to 
select the cells into which the formula will be copied (in your 
example, drag down the column to cell E 10). When you release 
the mouse button, a shaded border will appear around the 
selected cells. The cell with the formula's source will be white and 
the destination cells will be black. 
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3. Choose Fill Down from the Edit menu if you are filling a formula 
down a column or choose Fill Right from the Edit menu if you are 
filling a formula across a row. (Which option should you choose 
for your budget example?) 

Using this technique, the source formula will be copied into each of 
the selected destination cells. The cell references in the source 
formula will be changed automatically to the appropriate cell ref­
erences for the destination cell. For example, the source formula for 
cell E5, =Sum(B5:D5), will be changed to =Sum(B6:D6) for destination 
cell E6. These are called relative cell references and will be dis­
cussed in greater detail later. You have now completed entering data 
for your personal budget. Your spreadsheet should look like the 
example in Figure 4. 7. 

4.2.3 Editing the Spreadsheet 

Any cell can be edited at any time by moving the active cell to the 
desired location, entering the new data. a nd pressing the Enter key. 
If any formulas in the spreadsheet use the edited cell, they will 
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automatically be recalculated. For example, make the active cell BB, 
the cost of utilities for January. The current value in BS is 85. Enter 
the value 100 and press the Enter key. Watch carefully to see the 
spreadsheet change the value of EB, total utilities, to 265; the value 
of BIO, January total, to 915; and the value of EIO, grand total. to 
2770. In actual practice, the budgeted amounts in the spreadsheet 
can be replaced monthly with actual expenditures, so you can track 
how closely you stay within your budget. 

Clearing Cells. Sometimes you need to erase the contents of a cell 
or group of cells. Select the cell to be erased as the active cell and 
choose Clear from the Edit menu. If you wish to erase the contents 
of several adjacent cells, select them by holding the mouse button 
down while dragging over all the cells until they are highlighted. 
Selecting the Clear option from the Edit menu will erase the contents 
of all cells selected. 

Helpful Hint: You can retrieve the "cleared" contents of a cell or group of cells by 
immediately choosing Undo from the Edit menu. 

Inserting Rows or Columns. If you wish to add one or more rows or 
columns between adjacent rows or columns, use the Insert option in 
the Edit menu. In your personal budget example, suppose you 
wanted to insert a row between rows 5 and 6. Click on the row 
heading for row 6, Groceries (that is, click directly on the number 6 
at the left side of the window). Choose the Insert option from the Edit 
menu. A new row will be inserted immediately above the Groceries 
row. You can insert a new column in a similar manner. Click on the 
column heading for column E and choose Insert from the Edit menu. 
A new column will be inserted between March and Total. Add the data 
for insurance in row 6 and the data for April in column E, using 
Figure 4.8 for reference. On your own, use the Fill Down and Fill 
Right options to enter the formulas for F6 and E 11. 

Deleting Rows or Columns. An entire row can be deleted by clicking 
on the row heading and choosing Cut from the Edit menu. Multiple 
rows can be selected by dragging the mouse over adjacent row 
headings and using the Cut option. Similarly, one or more columns 
can be deleted by clicking on the column heading and choosing Cut 
from the Edit menu. In both cases, Cut will remove the row or column 
and bring the adjacent rows or columns together. If you want to erase 
the contents of a row or column but not eliminate it completely, use 
the Clear option in the Edit menu. 

Editing the Contents of Cell. At the beginning of this section you 
learned how to replace the data in a cell. Another way of editing the 
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Figure 4.8. Editing a Formula 

contents of a cell is to use the basic text-editing features of the cell 
contents box. In your budget example, select B 11 as the active cell. 
The cell contents box beneath the Menu Bar will contain the formula 
for this cell (=B5+B7+B8+B9+Bl0). Notice that when you inserted 
the Insurance row, row 6 , the formula did not include the new row. 
To correct the formula, move the mouse pointer into the cell contents 
box. The pointer will change into an I-bar like the editing cursor in 
the word processor. When the cursor is an I-bar, you can use any of 
the text-editing techniques that you learned in Section 2.4.1. Place 
the I-bar cursor to the right of B5 in the formula, click the mouse 
button. type +B6, and press the Enter key. The formula will be edited 
to read =B5+B6+B7+B8+B9+Bl0. For practice, edit the formulas in 
cells C 11, D 11, and E 11. Do the formulas in F5 through F 11 need 
editing? Why not? 

Helpful Hint: When editing the contents of a cell, try out the two useful tools that 
appear in front of the cell contents box (see Figure 4.4). If the cancel 
box, indicated by a large X, is clicked on, the contents of the cell prior 
to editing will be restored, provided that you have not pressed the 
Enter key. This is similar to the Undo option but only applies to 
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editing in the cell contents box. The enter box. indicated by the check 
mark. has the same function as the Enter key. When clicked on. the 
enter box enters the edited label. value. or formula into the cell. 

4.2.4 Changing the Format 

By now you have probably noticed what seem to be limitations on the 
formatting of data entered into the spreadsheet. For example. all 
columns are 12 characters wide, values are printed as real numbers. 
labels are left justified, values are right justified, and so on. But you 
can override these default settings by using options from the Format 
menu in the Menu Bar. 

Setting the Cell Attributes. Each cell has three attributes: the dis­
play type. the alignment. and the style. Figure 4.9 shows the dialog 
box that appears on the screen when Set Cell Attributes is chosen 
from the Format menu. The display type determines how numbers 
are displayed on the screen. The following table describes each type 
and gives several examples. The default display type is General. 

General 

Fixed 

Dollar 

Percent 

Scientific 

Date Short 

Displays real numbers with the minimum num­
ber of significant digits. The number 3.00 is 
displayed as 3, the number 5. 70 as 5. 7. 
Displays decimal numbers with a fixed number of 
decimal places as defined by the Decimal Places 
option in the dialog box. The displayed values are 
rounded. The number 3.14159 is displayed as 
3.14. However. the value 3.14159 is stored and 
used in calculations. 
Displays numbers in a dollars-and-cents format 
with a leading dollar sign. Two decimal places 
are displayed unless otherwise specified in the 
Decimal Places option. Negative numbers are 
enclosed in parentheses. Examples: $99.99. $2, 
and ($854.32). 
Displays numbers as a percentage (that is, the 
numeric value entered in the cell is multiplied by 
100) and followed by a percent sign. If you enter 
.12, it is displayed as 12%. 
Displays very large or very small numbers using 
scientific notation. The number 1,230,000 is 
displayed as l.23E+06, which means 1.23 x 106• 

A small number such as .000056 is displayed as 
5.6E--05 or 5.6 x 10-s. 
Displays the date in the form 8/25/73. 
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Date Medium 

Date Long 

Time 

Displays the date in the form Aug 25, 1973. If 
the Show Day box is checked, the date is dis­
played as Sat, Aug 25, 1973. 
Displays the date in the form August 25, 1973. If 
the Show Day box is checked, the date is dis­
played as Saturday, August 25, 1973. 
Displays the time in a 12-hour format. You must 
enter AM or PM; otherwise Works will assume AM. 

Examples: 9: 10 AM and 3:55 PM. 

Alignment options include Left justify, Center justify, and Right 
justify, as in the word processor. Numeric values and the results of 
formulas are automatically set to Right justify. Labels are set to Left 
justify. Style options are limited to Bold and Underline. Clicking in 
the Commas box will position commas at the appropriate places in 
numeric values. For example, $1000000 is displayed as $1,000,000 
if the Commas box is checked. 

Helpful Hint: The cell contents box shows how data were actually entered (as 
formulas, numbers, or labels). The active cell displays the contents 
using its cell attributes. 

In your personal budget example, set the cell attributes to the 
Dollars display type. 

1. Using the mouse, select all the cells with numeric values (point 
to B5, click, and drag the mouse to Fl I). 

2. Choose Set Cell Attributes from the Format menu. 
3. Click on the Dollar display option. 
4. Click the OK button. 
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D 

Now set the column labels-January, February, and so on-to 
Right justify. 

1. Using the mouse, select all the column labels (point to B4, click. 
and drag the mouse to F4). 

2. Choose Set Cell Attributes from the Format menu. 
3. Click on the Right alignment option. 
4. Click the OK button. 

Your personal budget spreadsheet should look like Figure 4.10. 

Changing the Column Width. Follow these steps to increase or de­
crease the width of a column. 

1. Make active any cell in the column whose width you want to 
change. If you want to change the width of several columns, use 
the mouse to select the columns by dragging across the appro­
priate column headings. 

2. Choose Column Width from the Format menu. 
3. Type the number of digits for the new column width. 
4. Click the OK button. 

Use this method to change the column width of columns A through 
F to 10 digits in your personal budget example. 

Untitled (SS) BJ 

Figure 4.10. Personal Budget After Setting Cell Attributes 
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Helpful Hint: If you change the column width to be narrower than the space 
needed to display its contents, the contents will be displayed as 
####. Simply widen the column until its contents are correctly 
displayed. 

An alternative method for changing the width of one column is to 
use the column divider bars. These vertical bars are located between 
the column headings (see Figure 4.4). When the pointer is placed on 
the column divider bar it will change to a vertical bar with an arrow 
pointing away from each side (+J+). Hold down the mouse button and 
drag. A dotted line will follow the mouse in the direction dragged­
left or right. When the mouse button is released, the column will 
adjust to the newly defined width and the adjacent column will be 
shifted appropriately. In your budget example, try this method to 
change the width of column A so that cell AlO, Entertainment, is 
completely displayed. 

Adding Borders. Any cell in a Works spreadsheet can have a border. 
The border is a thin black line that can outline the entire cell or any 
combination of sides. These borders can be used to highlight 
information, draw lines under titles, or simply dress up the spread­
sheet. The Borders option is located under the Format menu. It 
contains a submenu that will let you choose from Outline, Left, 
Right Top, Bottom, and None. To demonstrate this feature, place a 
border under the column titles. 

1. Using the mouse, select cells A4 through F4. 
2. Choose Borders from the Format menu. Continue holding down 

the mouse button so that the Borders submenu appears. 
3. Choose Bottom from the Borders submenu. 

On your own, try adding a border on the right side of cells A4 
through Al 1. See Figure 4.11 for the finished spreadsheet. 

Changing the Font, Size, or Color. The Format menu also has op­
tions to change the Font, font Size, and font Color. These options 
work just as the same options in the Format menu of the word 
processor do. Select the cell or cells whose attributes you want to 
change, choose the appropriate option from the Format menu, and 
then choose the desired option from the submenu. A detailed 
description of the process can be found in Section 2.4.4. 

4.2.5 Saving and Printing a Spreadsheet 

Before printing a spreadsheet it is always a good idea to save it, just 
in case something goes wrong during the printing process. To save 
your spreadsheet, follow these directions. 
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Figure 4.11. Completed Personal Budget 

1. Using the mouse. select the Save option from the File menu at the 
top of the screen. 

2. The Save dialog box will appear. Type Personal Budget into the 
Save Document As box. This will be the name of your file. You 
must type in a name. Works will not let you name your file 
Untitled. 

3. Insert the floppy data diskette that you formatted in Chapter 1 
into the vacant disk drive. (If there is no vacant disk drive, click 
the Eject button to eject the Works Program disk and insert your 
data diskette.) The name of your diskette will now appear at the 
top of the dialog box. 

4. With the mouse, point to the button labeled Save and click the 
mouse button. In a few seconds the dialog box will disappear and 
your document window will reappear. Your spreadsheet has 
been saved and is now titled Personal Budget. 

Short Cut: Now that you have named and saved your document, the next time 
you select Save from the File menu you will not have to type the file 
name. The Macintosh will automatically save your document under 
its name. This process will replace the old document with the latest 
revisions. If you do not want to replace the original document, select 
the Save As command from the File menu and give the new document 
a different name. 



4.2 Spreading the Wealth (A Personal Budget Example) 95 

To print your spreadsheet. follow these instructions. 

1. Tum on the ImageWriter by pressing the Power and Select 
buttons. Both power light and select light should be on. Adjust 
the paper to your liking. 

2. Select Print from the File menu. The ImageWriter printing dialog 
box should appear on the screen. 

3. Select Best. Faster. or Draft mode by pointing to the desired 
option and clicking. 

4. Remember that you can enter the number of extra copies desired 
or a specific range of page numbers if you do not want to print the 
entire document. Other options allow you to hand-feed paper 
into the ImageWriter and to preview on the Macintosh·s screen 
what will print on the lmageWriter. 

5. Point to and click on the OK button and your document will be 
printed. If you wish to stop the printing. hold down the Command 
( ~ ) key and simultaneously press the Period key. 

Helpful Hint: To print an exact copy of only what appears within the spreadsheet 
window on your screen. select the Print Window command in the File 
menu. Be sure that the power for your Image Writer printer is turned 
on and that the printer is selected. 

Congratulations! You have successfully designed. entered. pro­
grammed. saved, and printed your first spreadsheet. Your printed 
output should resemble Figure 4.12. If you feel up to a more 
complicated example, continue on with the next section. If you are 
confused about any of the steps you took in creating the example 
spreadsheet, it would be a good idea to review those sections before 
continuing. 

. . . . . 
: : : : : .................................... ~ .............................. ~ ............................................................... ~ .............................. ~ .............................. , 
i iMichelle's Budget i i 

••••••••••••••••••••••••••••••••••••<1-••••••••••••••••••••••••••••··~··••••••••••••••••••••••••••••v••••••••••••••••••••••••••••••+•••••••••••••••••••••••••••••·~··•••••••••••••••••••••••••••• 

~ ~ ~ ~ ~ .................................... · .............................. ~ .............................. ~ .............................. ~ .............................. ~ ............................. . 
January l F ebru.ary i March l April! Tota 1 

Rent $400 .00 i $400 .00 i $400 .00 i $425 .00 i $1625 .00 
.................................................................. o0-.............................. o0-.............................. '°' .............................. '°' ............................ .. 
Insurance $100.00 l $100.00 i $100.00 i $100.00 i $400.00 .................................................................. '°' .............................. '°' .............................. '°' .............................. '°' ............................. .. 
Groceries $1 50 .00 l $1 75 .00 i $1 50 .00 ! $1 60 .00 i $635 .00 
.................................................................. o0-.............................. '°' .............................. o0- .............................. o0- ............................. . 

Automobile $200 .00 i $200 .00 i $200 .00 i $200 .00 i $800 .00 .................................................................. '°' .............................. o0- .............................. '°' .............................. o0- ............................. . 

utmties $85 .oo 1 $90 .oo ! $75 .oo 1 $65 .oo ! $31 5 .oo 
.................................................................. o0- .............................. o0-.............................. o0- .............................. o0-............................. . 

Entertainment $65 .00 i $1 00 .00 i $65 .00 i $70 .00 i $300 .00 .................................................................. '°' .............................. '°' .............................. '°' .............................. '°' .............................. . 
Tota 1 $1 000 .00 i $1 065 .00 i $990 .00 i $1 020 .00 i $4075 .00 

Figure 4.12. Personal Budget Printout 
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4.3 INVESTING IN YOUR FUTURE 
(A POSITIVE CASH FLOW EXAMPLE) 

In this section you'll explore some additional features of the 
Works spreadsheet that will provide you with more information 
about the use of formulas and functions. You'll work through 
another example spreadsheet, this time one that will calculate the 
future value of an investment. Instructions for commands you 
learned before will be abbreviated, but complete instructions will 
be given for new commands. 

4.3.1 Getting Down to Basics 

Your new challenge is to design and develop a spreadsheet to 
calculate the future value of your savings account and the amount 
of interest earned based on the following information. 

• The present balance in the account 
• The amount of monthly deposits 
• The number of months of saving 
• The annual interest rate 

It is best to base your design of a spreadsheet on the basic known 
information and to add the calculations later. The formatting and 
layout can be modified as you feel the need to perfect the appearance 
of the spreadsheet. In your example, assume that you currently have 
$2,000 in your savings account, that you want to save $100 per 
month for 12 months, and that your bank is paying you 6 percent 
interest. 

Start up Microsoft Works and create a new spreadsheet file (to 
review, see Section 4.2). If you are already using Works, choose New 
from the File menu, select the Spreadsheet icon, and click the OK 
button. Figure 4.13 shows the basic labels and values you need to 
enter into your spreadsheet. Use the skills you learned in prior 
sections to replicate this spreadsheet on your screen. If you have 
trouble, review the example in Section 4.2 before continuing. Your 
spreadsheet must match Figure 4.13 exactly before you can proceed 
with this exercise. 

4.3.2 Calculated Risks (More About 
Formulas and Functions) 

The Works spreadsheet contains arithmetic operators and many 
mathematical functions that can be used in formulas. In the 
previous example, your personal budget, you used the Sum function 
and the addition(+) operator to sum the columns and rows of the 



4.3 Investing in Your Future (A Positive Cash Flow Example) 97 

D Untitled (SS) BJ 

Figure 4.13. Basic Data for Savings Account Spreadsheet 

spreadsheet. Works arithmetic operators duplicate the standard 
functions on a calculator. 

Operator Function Example 

+ Addition =A5+B6 
Subtraction =A5+B6-D3 

* Multiplication =(A5+B6-D3)*Cl 
I Division =(A5+B6-D3)/F9 
/\ Exponentiation =(A5+B6-D3)"Al 

(Raise to a Power) 

Helpful Hints: Remember to use an asterisk, not an x, for multiplication. Paren­
theses should be used to specify the order of calculations. If there 
were no parentheses in the multiplication example above, a very 
differentanswerwould be obtained. Assume thatA5=2, B6=5, D3=3, 
and C1=2. The formula =(A5+B6-D3)*Cl will result in a value of 8 
because the calculations contained within parentheses are per­
formed prior to multiplying by Cl. The formula =A5+B6-D3*Cl 
would result in a value of 1 because Works always performs 
calculations in the following order: exponentiation, multiplication 
and division, addition and subtraction. 

Works functions include mathematical functions such as abso­
lute value and logarithm (Abs and Log I 0), statistical functions such 
as the sum and average of values (Sum and Average), trigonometric 
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functions such as the sine or cosine of a number (Sin and Cos), 
financial functions such as the future value and net present value 
(FV and NPV), logical functions such as .. if' statements (If), date and 
time functions such as the current date and time (Now), and special­
purpose functions such as looking up data from a table (Lookup). 

In your savings example, you need to calculate the future value 
of your investment, the interest earned, and a monthly record of 
deposits. To simplify this process, break it down into steps. 

Step 1: Calculate the Future Value 
The future value function needs to have specific data supplied to 
perform the calculation correctly. The format of the data is as follows. 

=FV(interest rate, # of periods, payment. present value, type) 

Follow along carefully to enter this function. 

1. Make C7 the active cell. 
2. Type an equal sign(=) to begin the formula. 
3. Choose Paste Function from the Edit menu. The Paste Function 

dialog box will appear on the screen. This box contains a list of 
all the Works functions. 

4. Scroll the dialog box until you locate the future value function, 
FVO. Choose the FVO function by pointing to and clicking on it. 
It should become highlighted. Click the OK button. 

5. The future value function needs to know the interest rate for the 
chosen period, which in this case is the monthly rate. With the 
mouse, point to and click on cell C5, the annual interest rate. To 
calculate the monthly rate, divide the annual rate by 12: type the 
division operator and the number 12. The formula in the cell 
contents box should read =FV(C5/ 12). 

6. Type a comma. Point to and click on cell C4. This specifies the 
number of periods (months). 

7. Type a comma. Now specify the monthly payments (deposits). 
The cash flow convention that Works uses requires cash paid 
out to be represented by a negative number. So type a minus sign 
(-) and then point to and click on cell C3. The formula in the cell 
contents box should now read =FV(C5/ 12,C4,-C3). 

8. Type a comma. To enter the present value, type a minus sign and 
then point to and click on cell C2. The minus is needed because 
you have already paid out cash into your savings account. 

9. Type a comma and type the number one. This tells the function 
that the payment or deposit occurs at the beginning of each 
period. (A zero would indicate that the payment occurred at the 
end of each period, as in a loan.) The completed formula should 
read =FV(C5/ 12,C4,-C3,-C2, 1). 

10. Press the Enter key. The future value of your savings account 
will be $3,363.08 after 12 months. 
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Step 2: Calculate the Amount of Interest Earned 
The interest earned is equal to the future value. less the present 
value. less the sum of the monthly deposits. 
1. Make CB the active cell. 
2. Type an equal sign to begin the formula. 
3. Point to and click on cell C7. the future value. 
4. Subtract the present value: type the subtraction operator and 

point to and click on cell C2. 
5. Subtract the value of all the deposits: type the subtraction 

operator. point to and click on cell C3 (the amount of each 
deposit). type the multiplication operator. and point to and click 
on cell C4 (multiply by the number of payments). The formula 
should read =C7-C2-C3*C4. 

6. Press the Enter key. You have earned $163.08 in interest. 

Step 3: Create a Monthly Record of Deposits 
To complete your savings account spreadsheet. create a monthly 
record of deposits including a column for the payment nuinber, a 
column for the deposit amount. a column for the interest earned. and 
a column for the monthly balance. 

1. Enter the labels Payment Number, Payment, Interest, and Bal­
ance in cells BIO. ClO. DlO. and ElO. respectively (see Figure 
4.14). 

2. Make E 11 the active cell. Type an equal sign (=) and point to and 
click on cell C2. This will establish the beginning account 
balance. 

3. Enter the numbers 1 through 12 into cells 812 through 823. 

Short Cut: Type the number 1 into cell 812 and press the Return key. 813 
should now be the active cell. Type =B 12+ 1 and press the Enter key. 
Use the Fill Down command in the Edit menu to copy the formula 
from 813 into B 14 through B23. This technique is extremely helpful 
for numbering a column. 

4. Put the monthly deposit amount into cells C 12 through C23. 
Move the active cell to C 12. Type an equal sign and point to and 
click on cell C3. Continue using this same process to place the 
formula =C3 into cells C13 through C23. 

Short Cut: To save time. you can use the Fill Down command again. However. 
you must make the reference to cell C3 an absolute cell reference. 
Otherwise Fill Down will use a relative cell reference and C 13 would 
contain =C4, C 14 would contain =C5, C 15 would contain =C6, and 
so on. To make the formula in cell C 12 an absolute reference, edit the 
cell contents box to read =$C$3 . A dollar sign before a column or row 
identifier indicates an absolute cell reference. Now use the Fill Down 



100 Chapter 4 Figures Won't Lie, but Spreadsheets Will Figure 

-D 

2 
3 
4 
5 
6 
7 
8 
9 

Untitled (SS) t!J 

Account Ba lance (Present Value) 

Monthly Deposit (Payment) 

Number of Months (Periods) 

Annua 1 Interest Rate 

$2000.00 

$100.00 
12 

6.00% 

tep 1 
$3363.08 :L 
$t 63.08 ••---.s ... itep 2 

Figure 4.14. Savings Account Spreadsheet-Step by Step 

command in the Edit menu to copy the formula from Cl2 into Cl3 
through C23. In your example, the value of each of these cells should 
be $100.00. 

5. Calculate the interest earned. Move the active cell to Dl2 and 
enter the formula =(El l+Cl2)*($C$5/ 12). This adds the deposit 
to the previous balance and multiplies the sum by the monthly 
interest rate. Note that the reference to the annual interest rate 
is an absolute reference. Use the Fill Down command to copy the 
formula from Dl2 into Dl3 through D23. 

6. Calculate the monthly balance. Move the active cell to El2 and 
enter the formula =El l +C 12+ D 12. This calculates the sum of the 
previous balance, the monthly deposit, and the interest earned. 
Use the Fill Down command to copy the formula from El2 into 
E13 through E23. Why are the cell references in the formula in 
El2 not absolute references? 
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Helpful Hints: Before saving and printing your spreadsheet, try some of these 
features to improve the looks of your accomplishment. 

1. Choose Show Grid from the Options menu. This feature will 
prevent the grid lines between columns and rows from showing 
on the screen and printed output. Choose Show Grid again. 
What happened? 

2. Select cells C7 and CS and choose Protected from the Options 
menu. This feature locks the contents of a cell and prevents them 
from being accidentally erased or edited. You must "unprotect" 
a protected cell before you can make any changes to its contents. 

3. Make AlO the active cell. Choose Set Page Break from the 
Options menu. A dotted page break indicator will appear above 
row 10. Everything above this indicator will print on one page, 
everything below it on another. To eliminate a page break you can 
use the Remove Page Break command. 

4. If you want to see the cell formulas instead of the cell values, 
choose the Show Formulas command from the Options menu. If 
you print the window or print the spreadsheet when Show 
Formulas is selected, the formulas will be printed. To reset the 
spreadsheet to showing values, choose Show Values from the 
Options menu. 

Congratulations! You have completed a very complicated 
spreadsheet. Your results should match the spreadsheet in Figure 
4.14. First save the spreadsheet on your data diskette entering a ftle 
name of Savings Account and then print the spreadsheet (see Section 
4.2.5 if you need help). 

4.3.3 What If? 

Now that you have completed your spreadsheet and have analyzed 
what the value of your $100-per-month investment will be, you 
might want to ask some of the following questions. 

• What if I invested $200 per month-how much would I save in 
12 months? 

• What if I changed banks and got 7 percent interest? 
• What if I saved for 18 months instead of 12? 
• What if I needed to save $5000-how long would it take? 

Once a spreadsheet has been properly designed, what-if ques­
tions can be easily answered by changing the values in the 
spreadsheet. For example, to determine the future value of your 
savings account if you invested $200 per month, make C3 the active 
cell, type 200, and press the Enter key. Your account balance is 
recalculated automatically because of the formula in cell C7. Try 
answering these four what-if questions on your own. 
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Helpful Hint: The fourth what-if question can be answered by a technique called 
successive approximations. To use this technique, make a guess at 
the number of months it might take to save $5,000 and enter that 
guess into cell C4 of the savings account spreadsheet. Adjust your 
guess upward if the future value is less than the desired amount. 
Adjust your guess downward ifthe future value is more than $5,000. 
After several guesses, you will narrow in on the answer. 

4.4 THE BIG PAYOFF (A PAYROLL EXAMPLE} 

The following example builds a payroll ledger for a fictitious company 
and demonstrates three commonly used features of the Works 
spreadsheet: the logical If function, the table Lookup function, and 
the Sort command. Start up Microsoft Works and create a new 
spreadsheet file (for a review, see Section 4.2). If you are already 
using Works, choose New from the File menu. select the Spreadsheet 
icon. and click the OK button. Figure 4.15 presents the basic labels 
and values that need to be entered into the spreadsheet. Use the 
skills you learned in prior sections to replicate this spreadsheet on 
your screen. If you have trouble, review the example in Section 4.3 
before continuing. Your spreadsheet must match Figure 4.15 exactly 
before you can proceed with this exercise. 

Our fictitious company has 15 employees (see columns A and B) 
earning from $460 to $6,020 per month (see column D). Column C 
indicates each employee's status: 1 =full-time; 2 =part-time. These 
data are important because part-time employees do not have medical 
benefits and full-time employees are required to pay $50.00 per 
month for their medical insurance. The income tax to be witheld is 
based on the following table: 

Annual Income 

under 24,000 
24,000 to 35,999 
36.000 to 49,999 

over 49,999 

Tax Rate 

.02 

.03 

.04 

.05 

Your assignment is to compute the medical deduction (column E). 
the income tax to be withheld (column F). and the monthly take­
home pay for each employee (column G). Finally. you will need to sort 
the payroll ledger into alphabetical order by name. 

The Logical If Function. The logical If function checks a logical 
comparison, testing whether it is true or false. If the result of the 
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§0 Untitled (SS) 0§ 
A B c D E F G 

1 First Name !Last Name ! Status! Salary! Medical! Income Tax! Take Home I 
2 Brian !Downing , 1 , 2540.00j , , I ...... 
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Figure 4.15. Payroll Ledger Basic Data 

comparison is true, the function performs a specified action. If the 
comparison is false. the function performs a different action. In your 
payroll ledger the If function can be used to test whether an 
employee's status (column C) equals a 1 (full-time). If the statu s is a 
1, the function can place the value of 50 in column E, the medical 
deduction for full-time employees. If the status is a 2 (part-time). the 
function can place the valu e of zero in column C. 

The If function has the following format: 

If (logical expression, value if true, value if false) 

The logical expression commonly compares two cells with one 
another or a cell with a value, but it can take many forms. The logical 
expression usually contains one of these comparison operators: 

= Equals 
< Less than 
<= Less than or equ al to 
> Greater than 
>= Greater than or equal to 
<> Not equal to 
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To compute the medical deduction on your payroll ledger. follow 
these steps. 
1. Move the active cell to E2, type an equal sign to indicate a 

formula, and enter the If function by typing IF( 
2. Type the logical expression C2=1 This will check C2 to see 

whether it equals a 1. 
3. Type a comma followed by the value 50 This places 50 into E2 

if C2=1. 
4. Type a comma followed by the value 0 This places 0 into E2 if 

C2<>1. 
5. Type a parenthesis and press the Enter key. 
6. Use the Fill Down command from the Edit menu to copy this 

formula into columns E3 to El6 (see Figure 4.16). 

The Table Lookup Function. The Lookup function is used to com­
pare a value-usually the contents of a cell-to a table to look up a 
corresponding value. In your payroll example, you need to look up 
the income tax rate based on the annual income of each employee. 
The first step is to enter the Lookup table into the spreadsheet. You 
want to choose a section of the spreadsheet that you will not be using 
for payroll data. Move the active cell to D 19 and enter the table shown 

s File Edit Window Select Format Options Chart Macro 

E2 =lf(C2= 1,50,0) 

Untitled (SS) 
B c D E F G 

1 First Name \ast Name 1 Status ! Medical! Income Taxi Take Home l 

Figure 4.16. Calculating Column Eby Using the If Function 
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Figure 4.17. Payroll Ledger Lookup Table 

in Figure 4.17. Carefully compare the data in the Lookup table with 
the table presented in the second paragraph of Section 4 .4. When 
entering a table to be used by the Lookup function, the data must be 
in ascending order (lowest to highest) . The value entered into the 
comparison column (Salary) must therefore be the lowest possible 
value for that range. The corresponding result is entered into the next 
column of the same row. 

The Lookup function has the following format: 

Lookup(lookup value, comparison range, result range) 

Move the active cell to F2 and enter the following formula: 

=Lookup(D2* 12,$D$20:$D$23,$E$20:$E$23)*02 

The monthly salary. D2, is multiplied by 12 to calculate the annual 
salary. That value is looked up in the comparison range starting with 
D20 and continuing through D23. The corresponding result will be 
found starting with E20 and continuing through E23. Finally 
multiply the Lookup result by the monthly salary, D2, to get the 
withholding. Do you remember why dollar signs are used to specify 
the cells? 

Use the Fill Down command to complete column F for each 
employee. Then calculate the take-home pay. column G, by subtract­
ing the medical and income tax from the salary. Your calculations 
should match those shown in Figure 4.18. 
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-o Untitled (SS) 0 

Figure 4.18. Completed Payroll Ledger 

The Sort Command. Now that you have fmished all the necessary 
calculations. you need to sort the employees into alphabetical order. 
Works has a built-in Sort command that will do the task. See if you 
can apply the general steps listed here to sort your payroll example. 

1. With the mouse. point and drag to highlight the entire portion of 
the spreadsheet that you want sorted. In addition to the columns 
to be sorted. you must include any with corresponding data. 
Data in cells not selected will not be rearranged. 

Helpful Hint: In your payroll example. select all the cells from A2 to G 16. Why? 

2. Choose Sort from the Edit menu. The Sort dialog box will appear 
on the screen (see Figure 4.19). 

3. A sort key tells the Works program which column to use to sort 
the data and in which order to sort them. You can define three 
sort keys. The data will be sorted by the first key. then the second. 
and fmally the third. For example. if you wanted information 
sorted alphabetically by full name the first key would be the last 
name, the second the first name, and the third the middle name. 
In the appropriate boxes, enter the column heading (A. B. C, and 
so on) for each sort key. Select whether the column should be 
sorted into ascending order (A to Z or 0 to 9) or into descending 
order (Z to A or 9 to 0). 

4. Click the OK button to perform the sort. 
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Select Sort Keys: 

1st Key Ll ®Ascending 

Column 0 Descending 

2nd Key [!] ®Ascending 

Column 0 Descending 

3rd Key D ®Ascending 

Column 0 Descending 

(Cancel ) (,oK D 

Figure 4.19. Sort Dialog Box 

Helpful Hint: If you sorted incorrectly. you can use the Undo command in the Edit 
menu to undo the sort. 

If you completed the sort correctly, your spreadsheet should resemble 
Figure 4.20. Save this spreadsheet with the file name Payroll Ledger. 
For practice, print out a copy. 

D Untitled (SS) E!J 

Figure 4.20. Payroll Ledger Sorted Alphabetically by Name 
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4.5 ON YOUR OWN 

It is the objective of this chapter to introduce you to basic spread­
sheet functions only. Consequently, many features of the spread­
sheet are not covered in its examples. Some additional features are 
briefly presented below so that you can experiment with the three 
spreadsheets that you have completed. A full listing of the spread­
sheet menu commands appears in Appendix C. 

Linking Spreadsheets. Many sophisticated spreadsheet programs 
such as Excel™ and Lotus allow the user to link a cell in one 
spreadsheet with a cell in another. When a linked cell is updated it 
is automatically changed in the linked spreadsheet if it is open or 
when it is opened. This is useful when you are producing a summary 
report whose data were computed in different spreadsheets, such as 
a profit-and-loss statement. This feature is not available in Works, 
however. 

Splitting the Window. The spreadsheet window can be split, both 
vertically and horizontally. Drag the horizontal split bar to split the 
screen into two subwindows, top and bottom (see Figure 4.21). Drag 
the vertical split bar to split the screen into two subwindows, left and 
right. Try doing both at once. How many subwindows do you have 
now? Each of the subwindows has its own scroll bar to control it. 

Helpful Hint: One reason for splitting the window is to keep row or column titles 
from scrolling when you have a large spreadsheet. Using the Payroll 
Ledger spreadsheet, drag the horizontal split bar just below row I 
(the titles). Choose Freeze Horizontal Titles from the Options menu. 
Now you can scroll the spreadsheet without losing your view of the 
titles. 

Cell Notes. Short notes can be attached to individual cells as 
reminders, like electronic Post-It™ notes. A cell note can be added to 
the active cell by choosing Open Cell Note from the Edit menu. A 
window will appear in which you can type your note. When a cell note 
has been created for a cell, a small black square will appear in the 
upper right-hand corner of the cell. To read the note, use the· Open 
Cell Note command. If you want to print the cell notes, there is an 
option in the Page Setup command. 

Draw Tools. The same draw tools you learned to use With the word 
processor in Chapter 3 are also available for the spreadsheet. Choose 
the Draw On command in the Edit menu to turn on the draw mode 
and choose Draw Off to return to the spreadsheet mode. 
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:D Untitled (SS) BJ 
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Vertical Spilt Bar Horizontal Split Bar 

Figure 4.21. The Split Bars 

Select Menu. The Select menu contains several commands to help 
you move around large spreadsheets. The best way to learn them is 
to experiment. 

Cut, Copy, Paste, and Move. As in all Works applications, you can 
cut and copy information from the spreadsheet to the Clipboard. The 
information can be a single cell, a group of cells, an entire row or 
column, or a group of rows or columns. Once it's on the Clipboard the 
information can be pasted back onto the spreadsheet, to another 
spreadsheet. to a word-processing document, to a database, or to 
just about any Macintosh file. However, the Move command is 
unique to the spreadsheet. It will let you move one or more cells to 
a new location in the same spreadsheet in one command. Cut, Copy, 
Paste, and Move can be found in the Edit menu. 

Page Setup. As it does in the word processor, the Page Setup 
command in the File menu defines the way your spreadsheet will be 
printed on paper. Refer to Section 2.4. 7 and Figure 2.14 for a review 
of this option. 
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4.6 POSERS, PROBLEMS, AND PROJECTS 

1. Using Works. create a spreadsheet to budget your own 
personal finances. Include entries for each of the 12 months 
and for rent. auto expenses, utilities. and your other ex­
penses. Enter your monthly income and calculate how much 
you save or overextend each month. Calculate the monthly 
totals and the average monthly expenditure for each expense 
category. Save your spreadsheet to be used in the next 
chapter. 

2. Create a spreadsheet to calculate the cost per mile of operat­
ing your automobile. For each month include your car pay­
ment, gasoline expenses. maintenance and repair costs, 
insurance. license fees, and any other expenses. Enter your 
monthly mileage. Sum the annual costs for all items and 
divide by the total miles driven to calculate the total cost 
per mile. 

$3. Using the savings account example in Section 4.3 as a model. 
create a spreadsheet for a loan amortization. Enter the data 
for the loan amount, number of payments. and interest rate. 
Calculate the monthly payment using the PMT function. 
Calculate a monthly ledger showing the payment number. 
payment amount, interest paid. principal paid, and loan 
balance. 

Loan Amount 
Number of Months 
Annual Interest Rate 
Monthly Payment 

$0.00 
0 

0% 

$ 0.00 

Helpful Hint: PMT(interest rate. # of periods. present value. future value. type) 

*4. Mary Dynamo, the Administrative Assistant to the President 
of Acme Paper Clip Company. needs to compare and contrast 
the company's paper clip sales over the past 2 years. She 
brings you all of the data written on little slips of paper. After 
you spend hours deciphering the slips of paper. she brings 
you a reference book reporting the paper clip sales for Acme 
and its competitors. Create a table using the Works spread­
sheet and the data below. Calculate a second table showing 
the percentage of increase in sales for each company for each 
year. Calculate a third table showing the percentage of the 
market share held by each company each year. Save the 
spreadsheet to be used later. 
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Company 1987Sales 1988 Sales 1989Sales 

Acme Paper Clip 12.376.890 14.610,923 20,387,200 
United Plastics 3,945,611 5,100,679 6,145,372 
Mitsubishi Paper Clip 9,399,789 7.290,098 10,123,533 
A.O.S. Paper Clip 7,599,000 6,777,213 3.433,678 

%Increase % Increase 
Company 1987-1988 1988-1989 

Acme Paper Clip ??? ??? 
United Plastics ??? ??? 
Mitsubishi Paper Clip ??? ??? 
A.O.S. Paper Clip ??? ??? 

%Market % Market %Market 
Company Share 1987 Share 1988 Share 1989 

Acme Paper Clip ??? ??? ??? 
United Plastics ??? ??? ??? 
Mitsubishi Paper Clip ??? ??? ??? 
A.O.S. Paper Clip ??? ??? ??? 
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"We must never forget that art is not a form of propaganda; it is a 
form of truth." 

-John F. Kennedy 

"Put all your eggs in the one basket and-WATCH THAT BASKET." 
-Mark Twain 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Differentiate among pie, line, bar, stacked, and combination 
charts (Sections 5.1.1 and 5.1.2) 

2. Draw a pie chart (Section 5.1.1) 
3. Draw a bar and line chart (Section 5.1.2) 
4. Edit, duplicate. and erase charts (Section 5.1.3) 

113 
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5.1 DRAWING CHARTS 

The old adage proclaims "It's not what you say, but how you say it." 
Although most corporate executives will not agree entirely with this 
statement, the importance of the presentation of data in the busi­
ness world cannot be overemphasized. Computers now play a vital 
role in the production of presentation graphics. The Works soft­
ware will take spreadsheet data and tum it into a meaningful visual 
presentation by means of charts and graphs. Other software can 
take the charts and add color, titles, music, animation, and even 
digitized photographs. Entire audiovisual productions can be cre­
ated with the Macintosh and displayed by means of computer 
projection equipment. Put that old slide projector in the closet and 
prepare for the 21st century! 

The Works spreadsheet application can produce pie charts, bar 
charts, and line charts from data in a spreadsheet. The charts are 
saved with the spreadsheet and can easily be updated if the 
spreadsheet data changes. They can be printed from the spreadsheet 
application or copied to the Clipboard and pasted into the Works 
word processor or any other Macintosh application. Once pasted 
into the word processor, titles, notes, arrows, borders, and other 
information can be added before printing. Several charts can be 
pasted into a word processor document and resized to print on one 
page. All you need to produce effective graphics are the skills to use 
Works and a little imagination. 

5.1.1 Drawing Pie Charts 

A pie chart is the easiest chart to draw with Works. We all remem­
ber drawing our first pie chart in school, probably with crayons. 
USA Today uses pie charts frequently to depict, for example, what 
percentage of the state or federal budget is spent on education or 
military spending. Pie charts are most effective used in that way­
to depict what percentage of a whole the components make up. 

Suppose you wanted to show what percentage of your total 
budget was spent on rent, insurance, groceries, and so on. In the 
spreadsheet you could calculate the percentages and print out a 
table. But think how much more effective it would be if you drew a 
pie chart. Follow along on your Macintosh to learn how. 

1. Open the Personal Budget spreadsheet that you saved in Section 
4.2.5. Use the Open command in the File menu. Your screen 
should resemble Figure 4.11 in the previous chapter. 

2. Choose New Pie Chart from the Chart menu. The Pie Chart 
dialog box will appear on the screen. 
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3. Type the Chart Title in the box provided. For this example, type 
My Personal Budget and press the Tab key. 

4. In the second box, enter the column in which the values you 
want to plot are located. As you want to plot your total expenses, 
type F and press the Tab key. 

5. Next enter the row number in which the values to be plotted 
begin and then the row number in which they end. As you want 
to plot from the row for rent through the row for entertainment, 
type 5, press the Tab key, type 10, and press the Tab key. 

Helpful Hint: Never include the total of the parts when defining the values to be 
plotted. The program will calculate the total for you. 

6. In the last box, enter the column in which the titles for the 
values are located. In your example, the row titles are located in 
column A. Because column A is already entered in the last box, 
do nothing. 

7. Check the dialog box for the correct entries (see Figure 5.1). 
When you are ready to plot, click the Plot It! button. 

Helpful Hint: If your data are in a row, you will need to transpose them to a 
column. Select the cells to be transposed with the mouse and 
choose Copy from the Edit menu. Click on the frrst cell in any 

§0 Personal Chart 1 

Pie Chart Definition: 

Chart Title: I My Personal Budget 

Plot Ualues in Column: LJ 
FromRow: D 

Through Row: ~ 

Column of Ualue Titles: llml 
(Cancel ) ( PlotW 

Figure 5.1. Pie Chart Dialog Box 
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s File Edit Window Macro 

D Personal Chart 

Figure 5.2. My Personal Budget Pie Chart 

My Personol Budget 

a Rent 
~ Insurance 
II Groceries 
0 Automobile 
1111 Utilities 
Ill Entertainment 

39.9% 
9 .8% 

15.6% 
19.6% 

7 .7% 
7 .4% 

empty column. Choose Paste with Options from the Edit menu. 
Click the Transpose button in the Paste with Options dialog box. 
Click the OK button. Your data will be transposed from a row to a 
column and can now be plotted. 

That's as simple as it gets! Your completed pie chart should 
resemble Figure 5.2. On your own, draw a pie chart showing your 
personal budget for the month of February. Use the Window menu 
to display your Personal Budget spreadsheet; then follow the steps 
above, substituting the data for February. Your pie chart will look 
like Figure 5.3. 

Helpful Hint: Choose the Save command from the File menu to save the charts 
with your spreadsheet. 

5.1.2 Drawing Series Charts 

Series charts include line charts, comparative bar charts, stacked 
bar charts, and combination bar-and-line charts. Figure 5.4 de-



s File Edit Window Macro 

D Personal Chart 2 

My Personol Budget for Februory 

Figure 5.3. My Personal Budget for February Pie Chart 

a Rent 
~ lnsur<mce 
II Groceries 
D Automobile 
111 Utilities 
III Entertainment 

37.6% 
9.4% 

16.4% 
18.8% 
8.5% 
9.4% 
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picts the various types of series charts. The process for drawing a 
series chart is similar to that for a pie chart: create a spreadsheet, 
choose New Series Chart from the Chart menu, enter the chart 
information into the Series Chart dialog box. and click the Plot It! 
button. A detailed explanation of the general steps follows. 

1. Create a new spreadsheet or open an existing one. 
2. Choose New Series Chart from the Chart menu. The Series 

Chart dialog box will appear on the screen (see Figure 5.5). 
3. Enter the Type of Chart by clicking on the desired chart: Line, 

Bar, Stack (stacked bar chart). or Combo (combination bar 
and line chart). 

4. Enter the Chart Title in the box provided and press the Tab 
key. 

5. Enter the Vertical Scale Title and press the Tab key. This title 
will appear on the vertical (Y) axis. 

6. Enter the Horizontal Scale Title and press the Tab key. This 
title will appear on the horizontal (X) axis. 
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Bar Chart 

Line Chart 

.............. ' ... · ............ ,.. ... -~:;~:;:::;:::;~; ... ;/.;-;. :.:::···.::~.::·~.::.::::.::;:.·.:·:·:·:.:~:::.:1:::.:.::.::: .. i:.:::::.::: .. ;::.::~.::::~.::·~_:;::.:.:1:.·.: .. ::.;.::.:·.~.::::~.::·:~.~::.:: .. i::.~:;:.: 5%0t.~f/!jf. %if t%h0;t; Stack Chart 

Combo Chart 

Figure 5.4. Types of Series Charts 
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Personal Chart 3 
Ualues to be Plotted: Uertical Scale: 

1st Row: 

2nd Row: 

3rd Row: 

4th Row: 

From Column: 

To Column: 

9 

10 

B 

~ 

®Numeric 
O Semi-Logarithmic 

MaHimum: I 
Minimum: :o=======~~~~~~~~ 

Data Legends in Column: ~ 
Horizontal Titles in Row: ~ 

D Draw Grid 
181 Label Chart 

Chart Title: Comparison of Utilities and Entertainment 

Uertical Scale Title: Dollars 
1--~~~~~~~~~~~~~~~~~~~~-1 

Horizontal Scale Title: Months 

( Cancel ) n Plot ltillJ 
Figure 5.5. Series Chart Dialog Box 

7. Next, enter the location of the Values to be Plotted. You can 
plot from one to four rows of data. Enter the row number of the 
first series to be plotted and press the Tab key. Enter the row 
numbers for the remaining series in the same manner. Enter 
the column heading (A, B, C, and so on) in which the data to 
be plotted begin and press the Tab key. Enter the column 
heading in which the data end and press the Tab key. 

Helpful Hint: Each series of data to be plotted must be located in a row and in 
adjacent columns. If your data are organized differently, use the 
Copy and Paste with Options commands to reorganize your 
spreadsheet. 

8. Enter the column heading for the location of the Data Legends 
(the labels that identify each series) and press the Tab key. 

9. Enter the row number for the Horizontal Titles (the X-axis 
labels) and press the Tab key. 

10. Choose the Vertical Scale. Numeric is the normal choice. 
Semi-Logarithmic uses a logarithmic scale on the Y axis to 
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exaggerate the size of the smaller numbers and minimize the 
size of the large ones for showing very large and very small 
numbers on the same chart. Works will automatically scale 
the vertical axis. If you want to specify the Maximum and 
Minimum value on the vertical scale, enter the values in the 
boxes provided. 

11. Check the Draw Grid box if you want grid lines drawn on the 
chart. The grid lines are sometimes helpful in reading the 
values on the vertical axis. Check the Label Chart box if you 
want the chart labeled. You may not want the chart labeled if 
you plan on adding your own labels in the word processor. 

12. Click the Plot It! button. 

Follow these instructions to create a bar chart comparing your 
budgeted expenditures for utilities with those for entertainment for 
January through April, based on your Personal Budget spread­
sheet. Try it on your own first. If you need help, refer to Figure 5.5 
for the proper information to be entered in the Series Chart dialog 
box. Compare your results with the bar chart in Figure 5.6 . 

.S File Edit Window 
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Figure 5.6. Comparative Bar Chart 
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5.1.3 Editing and Maintaining Charts 

When you save your spreadsheet, every chart that you have drawn 
is saved with it. You may have noticed that each chart drawn is 
automatically assigned a name. If you have been working the 
examples along with the text, you should have three charts associ­
ated with your Personal Budget spreadsheet. Choose Draw Chart 
from the Chart menu. The Draw Chart dialog box should appear 
(see Figure 5.7). This box lists each chart that has been created. To 
redraw any one, point fo and click on the desired chart and click 
the OK button. 

Draw Chart: 
Personal Chart 1 

Personal Chart 2 
Personal Chart 3 

( Cancel ) n OK , 

Figure 5.7. Draw Chart Dialog Box 

If you want to edit or change a chart, choose the Select Chart 
Definition command from the Chart menu. A dialog box will appear 
(see Figure 5.8). Select the chart to be edited and click OK. The 
Chart dialog box will appear, and you can change any or all of the 
chart definition information. 

In a similar fashion, the Duplicate Chart command in the Chart 
menu will duplicate the Chart dialog box for any previously drawn 
chart. This allows you to make changes to the chart without 
deleting the original one. This is analogous to the Save As com­
mand, which saves a file under a new name without deleting the 
original file. The Erase Chart command in the Chart menu will 
delete charts associated with a spreadsheet. Unwanted charts 
should be erased, because only eight charts can be saved with a 
Works spreadsheet. 

Heipful Hint: Because the automatic naming of charts does not describe their 
contents. you may want to change the assigned name. When the 
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Select Chart Definition: 
Personal (hart 1 
Personal Chart 2 
Personal Chart 3 

( Cancel ) t OK D 
Figure 5.8. Select Chart Definition Dialog Box 

Plot Chart or Series Chart dialog box is displayed on the screen, 
choose the Change Chart Name command from the Edit menu. 
Enter a more descriptive name and click the OK button. 

5.2 POSERS, PROBLEMS, AND PROJECTS 

1. Using the Personal Budget spreadsheet that you created in 
Section 4.6, Problem 1. create a bar chart comparing your 
total monthly expenditures with your monthly income. 

$2. Using the spreadsheet comparing Acme Paper Clip Com­
pany sales (see Section 4 .6, Problem 4) , create three pie 
charts-one for each year-comparing the market share of 
each company. See the following example. 

Percent Market Share 1987 

• Acme Paper Clip 37 . 1 % 
~ United Plastics 11.8% 
IB Mitsubishi Paper Clip 28.2% 
c:;J A.0.S. Paper Clip 22 .8% 
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$3. Using the spreadsheet comparing Acme Paper Clip Com­
pany sales (see Section 4.6, Problem 4), create one bar chart 
comparing the sales for each company for every year. See 
the following example. 

1987 Sales 

Annual Paper Clip Sales 

1988 Sales 

Manufacturer 
1989 Sales 

~ Acme Paper Clip ~ United Plastics [) Mitsubishi Paper Clip lllJ A.O.S. Paper Clip 

$4. Using the spreadsheet comparing Acme Paper Clip Com­
pany sales (see Section 4.6, Problem 4), create a bar chart 
comparing the percentage of increase or decrease in sales 
for each company for 1988-1989. See the following 
example. 

0.36 

0.30 

0.24 

Percent Increase/Decrease in Sales 

0· 18~mm~::1~¥AVAm:%1 
0.12 

0.06 

O.OO....µ:...:..:..:..:..:.:..:..:..:..::....:u..1:.LL.11:.LL.11:.LL.1~-----. ....... -. .................. -

-0.06 

-0.12 

-0.18 

1987-1988 

Manufacturer 
r3 Acme Paper Clip l?A United Plastics ~ Mitsubishi Paper Clip ffil A.O.S. Paper Clip 
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I KNOW IT'S HERE 
SOMEWHERE! 



"When to the sessions of sweet silent thought 
I summon up remembrance of things past, 
I sigh the lack of many a thing I sought, 
And with old woes new wail my dear times' waste." 

-William Shakespeare 

1'Things that live in memory have no visible means of support." 
-Anonymous 

"If I do not remember thee, let my tongue cleave the roof of 
my mouth ... " 

-Psalms, 137:6 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Start up the Works program and open a new database file 
(Section 6.2) 

2. Design a database file and define the fields (Section 6.2.1) 
3. Enter, edit, and save records in a database file (Section 6.2.2) 
4. Move back and forth between the form format and the list 

format, move fields around in the database window, and 
change the widths of the fields (Section 6.3.1) 

5. Sort records into alphabetical, numerical, or chronological 
order (Section 6.3.2) 

6. Search the database for information using the Find Field and 
Match Records commands (Section 6.3.3) 

7. Select records from the database that match specific criteria 
(Section 6.3.4) 

8. Design and print a database report (Section 6.4) 
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126 Chapter 6 I Know It's Here Somewhere! 

6.1 WHAT IS A DATABASE? 

A computer application that is designed to store and retrieve 
information much as you or I would use a filing cabinet is called a 
database program. These programs are also referred to as elec­
tronic filing programs. They allow you to defme what information is 
to be stored in the dataftle on the diskette. input the information 
from the keyboard. edit or correct the information as necessary. 
and print the information out on a printer. You also have the option 
of sorting the information alphabetically or numerically. selecting 
only a portion of the data. based on specific criteria. and defining a 
report to be printed out. Anyone who needs to store information. 
manipulate it. and print lists or other kinds of reports will benefit 
from database software. 

A variety of database software is available for the Macintosh 
family of computers. Some are inexpensive programs costing under 
$100. These are usually slow. have limited storage capacity. can 
only process one file at a time. and have minimal report-generating 
capabilities. At the opposite end of the complexity and price scale 
(over $500) are sophisticated database packages. including dBase 
Mac®. Double Helix®. 4th Dimension®. and Omnis 3™. These ad­
vanced database languages let you correlate information between 
files; hence they are known as relational database applications. 
Once you've defmed a relationship between information in two or 
more files, the database can look up information in the linked files. 
If you plan to manage large files and want to limit the duplication of 
information. you should consider one of the relational database 
packages. 

Microsoft Works falls in the middle of the range of database 
software available for the Macintosh. It is responsive to the user's 
needs, easy to use. and handles very large databases depending on 
the memory available in your Macintosh. Works is designed to 
manage lists of information. It works onflatji.le databases so that 
you need not understand relational databases. The real strength of 
Microsoft Works database is the ease with which it can be inte­
grated with the word processor and spreadsheet. This chapter 
explores the features of the database application; the following one 
demonstrates its expanded capabilities when integrated with the 
other applications of Works. 

6.1.1 What Can You Do with a Database? 

You probably use noncomputerized databases daily: telephone 
books. cookbooks. dictionaries. and so on. Here are a few examples 
of computerized database applications in use today. 
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Mailing Lists. The creation of mailing lists is one of the major uses 
of database programs. Names and addresses of your friends, cli­
ents, customers, prospects, or club members can easily be entered 
and updated. By integrating the database with the word processor, 
the names and addresses can be merged into a letter or into 
promotional material. Pressure-sensitive labels can be used in a 
printer, so mailing labels can be printed for applying to your mailer. 
For longer lists entries can be sorted into ZIP code order for bulk 
mailings, or subsets of lists can be selected for printing (for ex­
ample, you could choose to print only the names and addresses of 
single men over the age of 25). 

Reading Lists. Bibliographies can be stored on diskette and printed 
out as reading lists selected by author. subject matter, or call 
number. Large libraries use automated database software and 
mainframe computers to catalog their entire collections. Many 
branch and school libraries use microcomputers and programs like 
Works to provide patrons with an on-line card catalog. 

Statistics. Databases are used to store fmancial information about 
companies, personal information about prospective customers. 
sports records of favorite teams, and so on. Because computational 
features are available in the database software, you could also sort, 
select, and analyze data in order to be bullish in the market. pick 
the best prospects, or lay down that bet on Monday night's game. 

Inventories. Many small businesses use microcomputers and da­
tabase software to keep track of the quantities of goods they sell. 
Hobbyists use databases to catalog their collections of coins, stamps, 
dolls, and so on. Schools use them to keep track of audiovisual 
resources, band instruments and sheet music, and other instruc­
tional equipment. Homeowners record their household inventories 
for insurance purposes with databases. 

Record Keeping. Businesses and individuals frequently keep ac­
counting data with database software. Federal and state tax re­
ports can be prepared, printed, and submitted with less effort. Just 
about any kind of personal or business records can be stored in a 
database. 

Suppose you were organizing a community symphony. You 
might enter the names and addresses of each member, the board of 
directors, and the donors. You might also enter which instruments 
the members play, their age, when they joined the orchestra, or 
how much money donors gave and when they gave it. 

Once the data are entered, what can you do with them? Well, 
you could print mailing labels for the entire orchestra or for just the 
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brass section, just the donors, or just the board members. You 
could answer questions such as these: How long, on the average, 
have the members been playing? What is the average age of the 
string section? How much equipment does the orchestra have? 
Who gave the most money? Who gives most consistently? You could 
print a list of the orchestra members and their instruments to go 
into the program. You could merge donor information with a word 
processor letter offering season ticket reservations. The options are 
almost unlimited. 

6.1.2 Using Works Database 

The Works integrated software contains a database in addition to 
its other applications. The remainder of this chapter will assume 
that you are already familiar with the basic functioning of Works 
and have a floppy diskette initialized to store the examples. You 
should have completed the previous five chapters before continuing. 
If you feel you need a review of basic Works, see the following 
sections. 

1.4 How to Use the Macintosh 
2.1 An Introduction to Microsoft Works 
2.3.1 Entering Text 
2.3.2· Saving Your Quotation 
2.3.3 Printing Your Document 
2.3.4 Quitting Works 
2.4.1 Editing Text 
2.4.3 Cut and Paste: Moving Text 
2.4. 7 More About Printing 
4.2.2 Entering Data 
4.3.2 More About Formulas and Functions 

To gain maximum benefit from this chapter, you should work 
through its examples on a Macintosh while following the instructions 
in the text. 

6.2 CREATING A DATABASE 

Creating a database takes patience, practice, but most of all plan­
ning. It is important to identify all items of information and consider 
how you will sort or select the data before you actually enter them. 
Otherwise you may have to reenter data or, in the worst case, start 
over. The items of information are calledjlelds. For a mailing list, 
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your fields would be name, street address, city, state, and ZIP code. 
A record is a collection of related fields. For a mailing list, all the 
fields of data relating to one person would comprise a record. A file 
contains all the records in a database. In summruy, a databasejile 
is composed of records, which in turn are composed of .fields. 

The example in this chapter will teach you to design and 
develop a simple database, a personal dictionruy. You can enter a 
new and unfamiliar word, its definition, a synonym, and an antonym. 
This technique is commonly used with 3" x 5" index cards to in­
crease vocabulacy. Using a computer database instead adds a new 
dimension: quick retrieval, sorting, and reorganizing of the words. 
Through this example, you will learn how to create the database, 
enter and edit the data, customize the layout, save the file on 
diskette, and print a report. To begin, start up Works and create a 
new database document following these directions. 

1. Start up the Macintosh using the Works Startup and Program 
diskettes. (Remember how? See Section 1.4.1 if you need help.) 

2. If the Works window is not visible on the screen, open the 
Works Program disk icon (see Section 1.4.3). 

3. Start Microsoft Works by selecting the Works icon (point and 
click) and choosing Open from the File menu. 

Short Cut: Click twice on the Works icon. 

4. The Works desktop should appear. Select Database by pointing 
to the icon and clicking. Create a new document by pointing to 
and clicking on the New button. 

5. A database document will be opened and the screen should 
appear as in Figure 6.1. 

6.2.1 Creating Fields 

If you followed the instructions, the Field Name dialog box should 
appear (see Figure 6.1). The name, Untitled!, is highlighted in the 
Field Name box. You need to replace this name with the first field in 
your database and click the Add Field button or press the Return 
key. Then repeat the process for the remaining fields. In your 
dictionacy database, you will want the following fields: New Word, 
Definition, Synonym, Antonym. Field names cannot exceed 64 
characters in length, but they can contain uppercase or lowercase 
letters, numbers, and some special characters (-' ! @ # $ & _ (} [) 
I \ : ; " ' ?). A field name must begin with a letter. If you make a 
mistake before you press the Return key, you can correct the error 
by using the Delete key or any of the other Macintosh text-editing 
techniques using the mouse. After you've named the first field, your 
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Untitled (OB) 

Figure 6.1. Field Name Dialog Box 

Untitled (OB) 

INeY Yord I 

Figure 6.2. Entering a Field Name 
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Figure 6.3. Database Fields Defined 

screen should resemble Figure 6.2. After you enter the last field, 
the Field Name dialog box for the Untitiled5 field will be visible on 
the screen. Click the Done button to indicate that you are through 
defining field names (see Figure 6.3) . 

If you discover an error in a previously entered field name, point 
to and click on the field name with the mouse. Select Change Field 
Name from the Edit menu. The Field Name dialog box will reappear 
on the screen and you can edit the name. 

Short Cut: Double click on the field name. 

To add a new field, select the Add New Field command from the 
Edit menu. The Field Name dialog box will appear so that you can 
add a new field. The n ew field will be added to the bottom of the 
defin ed fields. You can rearrange the fields in the database window 
in any order that you wish: When you point the mouse at a field 

name, the cursor will tum into the hand icon (~). To relocate a 
field , hold the mouse button down while dragging the field to its 
new location and then release the button. A field can be deleted by 
clicking on the field and selecting the Delete Field command from 
the Edit menu. 
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Helpful Hint: Be very careful when using the Delete Field command. It deletes 
not only the field but also the data contained in that field. It does 
not confirm whether you really want to delete the field before it 
deletes it. If you accidentally delete a field, immediately select the 
Undo command in the Edit menu. 

Each field is made up of the field name box and the field 
contents box (see Figure 6.4). It may be desirable to increase the 
width of the box so that the entire contents are visible on the 
screen. In your dictionary example, point with the mouse to the 
right-hand border of the Definition field. The cursor will change ( + ). Hold the mouse button down and drag to resize the field. 
Practice rearranging the fields in the window and changing their 
size until you are comfortable with this process. When you have 
fmished, your screen should resemble Figure 6.5. 

Field Name Box Field Contents Box 

Active Database Field 

/ 
Drag Cursor 

l_D_e_fi_n-it-io_n_l------------------~3-t-

Changing the Width of a Field 

Drag Cursor 

"" ~-ti_o_n~I ____________________ ___. 

Moving a Field 
Figure 6.4. Customizing a Field 
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ti File Edit Window Organize Format Report Macro 

Untitled (DB) 

!New Yord I 
!Definition I 
I Antonym I 
lsynonyml 

Figure 6.5. Completed Field Definitions 

6.2.2 Creating Records 

You are now ready to enter data for the first record. Each of the field 
names you defined now appears on the screen (see Figure 6.5). 
Type the data for each field for each word in your dictionary. Press 
the Return key after each entry. If you make a mistake, select the 
field by pointing and clicking with the mouse and edit the field just 
as you would edit a cell in the spreadsheet (see Section 4 .2.3 if you 
need to review). Enter the following data for the first record. 

Record 1: 
New Word: supple 
Definition: able to be bent 
Synonym: pliable 
Antonym: sti.Jf 

After you have entered the last field (sti..ff. in this example) and 
pressed the Return key, the screen will move to the next record. 
The record box, located below the Menu Bar on the left side, will 
indicate that you are now on record number 2. Continue entering 
the following data. 
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Record 2: 
New Word: rejuvenation 
Defmition: act of making new again 
Synonym: renovation 
Antonym: destruction 

Record 3: 
New Word: abnegation 
Definition: act of self-denial 
Synonym: renunciation 
Antonym: gratification 

Record 4: 
New Word: repugnant 
Definition: arousing strong dislike 
Synonym: repulsive 
Antonym: estimable 

Record 5: 
New Word: loquacious 
Definition: given to excessive talking 
Synonym: garrulous 
Antonym: silent 

Record 6: 
New Word: alluring 
Defmition: having a quality of fascination 
Synonym: captivating 
Antonym: repulsive 

Record 7: 
New Word: abhorrent 
Definition: inspiring extreme distaste 
Synonym: repulsive 
Antonym: admirable 

Records:· 
New Word: diminutive 
Defmition: small in size or stature 
Synonym: petite 
Antonym: gargantuan 

Record 9: 
New Word: coryectural 
Definition: subject to speculation 
Synonym: hypothetical 
Antonym: factual 

Record 10: 
New Word: repellent 
Definition: tending to drive away 
Synonym: repulsive 
Antonym: attractive 
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The Up, Down, Left, and Right Arrow keys can be used to review 
the records. If the Up or Left Arrow key is pressed when the first 
field in a record is highlighted, the window will display the previous 
record. If the Down or Right Arrow key is pressed when the last field 
is highlighted, the screen will display the following record. Review 
the data for correctness. If the complete definition for a word is not 
printed in the field data box, change the width of the field using the 
technique you learned in the previous section. Save your file on 
your data diskette under the name My Dictionary. If you need to 
review the procedure for saving a file, see Section 2.3.2. 

6.3 CHANGING HOW DATA ARE DISPLAYED 

Works gives you two ways of viewing data: the list format and the 
form format. When you entered your data, the screen only showed 
one record at a time: that's the form format. If you select the Show 
List command from the Format menu, the screen will display 
several records in a list: that's the list format. You can switch back 
to the form format by selecting Show Form from the Format menu. 
nY selecting the Show List command in your dictionruy example 
(see Figure 6.6). 

Short Cut: Hold down the Command key ( ~) and simultaneously press the L 
key to switch back and forth between the Show List window and the 
Show Form window. 

Active Field Field Name 

My Dictionary (OB) 
Definition Synonym Antonym 

Scroll Box 

'· Spht Bar Scroll Bar 

Figure 6.6. The List Format 
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6.3.1 Customizing the List Format 

In Figure 6.6 you will notice that the contents of the Definition field 
in some records are cut off because the column is not wide enough. 
In the same manner that you widened the columns in a spreadsheet, 
you can customize the fields in a database to suit your needs. With 
the mouse, point the cursor arrow at the line dividing the field 
names-the Definition and the Antonym field in your example (see 
Figure 6.7). The cursor will change ( +f+ ). Hold the mouse button 
down and drag right to widen the field or drag left to shorten it. 

Unlike spreadsheet columns, database fields can easily be 
rearranged in the window. Use the mouse and point to the name of 
the field at the top of the column. The cursor will change to the 

hand icon (0 ). Hold the mouse button down and drag right or left 
to rearrange the fields. In your example, try switching the Antonym 
and Synonym fields. 

Hold mouse button down and drag 
right to widen or left to narrow. 
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Figure 6.7. Changing a Field's Width 
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The list format in the database shares another feature with the 
spreadsheet. The window can be scrolled to view all the fields and 
records or split to view different parts of the database at the same 
time. Figure 6.6 identifies the scroll and split bars. If you need to 
review how to split the window, see Section 4.5. 

6.3.2 Sorting Records 

One of the most common uses of database programs is arranging 
(sorting) records. The Works database will allow you to sort records 
in an order based on any field. The order can be alphabetical (A to Z 
or Z to A) , numerical (Oto 9 or 9 to 0). or chronological (forward or 
reverse). depending on the type of field. In your dictionary example, 
you probably want to alphabetize the record by the New Word field. 
To do so, follow these steps. 

1. Highlight the field that you wish to sort on by pointing to its 
name and clicking the mouse button. In your example, click on 
New Word. 

2 . Select Sort from the Organize menu. The Sort dialog box will 
appear on the screen (see Figure 6.8). 

3 . Select the sort order From A to Z by clicking on the appropriate 
button. Click the OK button. 

~ 
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Figure 6.8. Sort Dialog Box 
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Figure 6.9 shows the result of sorting New Word in alphabetical 
order. Note that the entire record and its associated fields are 
sorted together. In the spreadsheet you can sort a single column 
without disturbing the contents of other columns, but in the 
database the Sort command sorts entire records. 
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Figure 6.9. Sorted Dictionary Example 

Helpful Hint: To sort a database on multiple fields (last name, first name, and 
middle name, for example), you need to sort on the least important 
field first and the most important field last. For example, to sort a 
database by name, sort on the middle name, first name, and finally 
last name. The sorts must be done in this order to properly 
alphabetize a database by name. 

6.3.3 Searching for Information 

To search all the records in a database for any occurrence of a 
word, phrase, or any combination of letters and numbers, use the 
Find Field command in the Organize menu. To demonstrate this 
feature, fmd every entry in your dictionary that contains the word 
repulsive. It could be in the New Word, Definition, Synonym, or 
Antonym fields. 
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Find NeHt Field That Contains: 

I repulsiu~ 
181 Search TeHt Fields Only 

( Cancel ) lttE!!~~) 

My Dictionary (DB) 

Next occurrence of 
repulsive found 

I. Select the Find Field command in the Organize menu. The Find 
Field dialog box will appear on the screen (see Figure 6.10). 

2. Type in the comparison information. For this example, type 
repulsive and click the Find Next button. The next occurrence 
of the text repulsive will be highlighted on the screen. 

Short Cut: To find additional occurrences of the text, hold down the Com­
mand key ( ~ ) and press the F key. The Find Field dialog box will 
appear. Press the Return key. When all occurrences of the text 
have been found, a dialog box will appear to warn you. 

Did you find all four occurrences of the text repulsive? 
Another way to search for information is to use Match Records. 

This command selects and displays every record containing a field 
whose contents match the criterion. In the previous example, you 
found the four records that contained repulsive. But you had to 
locate them one at a time. To select all the records with one 
command, try the Match Records option. 
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Figure 6.11. Match Records Dialog Box 

1. Select Match Records in the Organize menu. The Match Records 
dialog box will appear on the screen (see Figure 6.11). 

2 . Type in the comparison information and click the OK button. 
(From the previous example, repulsive has already been en­
tered.) Only the records with the text repulsive in any field will 
be displayed in the window. 

Helpful Hint: To restore the window to display all records, select the Match 
Records command again. 

Yet another way to search for information is to select records 
based on certain criteria in specific fields. In your dictionary, 
suppose you wanted to locate only records with the word repulsive 
in the Synonym field. Follow these directions. 
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Figure 6.12. Record Selection Dialog Box 

1. Select the Record Selection command in the Organize menu. 
The Record Selection dialog box will appear (see Figure 6.12). 

2. In the upper left-hand corner of the dialog box, the field names 
appear in a scrolling window. With the mouse, point to and 
click on the field name you want to search. In this case, you 
want to search the Synonym field. 

3. In the upper right-hand corner of the dialog box, a list of 
comparisons appears in a scrolling window. With the mouse, 
point to and click on the desired comparison. In the example, 
you want to select records whose Synonym field equals the text 
you're searching for. 

4. Type the comparison text (repulsive) in the box provided. 
5. Click the Install Rule button to complete the comparison infor­

mation. 
6. Click the Select button. 

If you followed the directions, only those dictionary entries for 
which repulsive was a synonym were listed. After viewing the en­
tries, you can display all your records by selecting the Show All 
Records command in the Organize menu. 
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6.3.4 Selection Rules 

You can defme selection rules that are much more complex than 
those in the simple dictionary example. Suppose you had a data­
base of customer addresses and only wanted to mail an advertise­
ment to those who lived in Texas. Louisiana. and Mississippi. More 
specifically. you need to mail the ad only to female customers 
between the ages of 20 and 30 with blonde hair. The Record 
Selection rules will allow you to do this. 

Each record selection rule contains the field name, a compari­
son operator. and the comparison text. The comparison operator 
defmes the type of comparison that will be applied to test the 
comparison text. The following operators are available. 

equals 
contains 
begins with 
is greater than 
is greater than or equal to 
is less than 
is less than or equal to 

is not equal to 
is blank 
is not blank 
ends with 
does not contain 
does not begin with 
does not end with 

In your dictionary example. Synonym equals repulsive was a single­
selection rule. Complex rules can be defined by combining several 
single-selection rules with the connection operators. And and Or. 
often called boolean operators. 

And. When the And operator is used to join two selection rules. 
both rules must be satisfied for Works to select a record. For 
example. 

Sex equals female 
And Hair equals blonde 
And Age is greater than or equal to 20 
And Age is less than or equal to 30 

will select only those records that have the text female in the Sex 
field. the text blonde in the Hair field, and a number between 20 
and 30. inclusive. in the Age field. 

Or. When the Or operator is used to join two selection rules. one or 
the other. but not both. must be satisfied for Works to select a 
record. For example, 

State equals Texas 
Or State equals Louisiana 
Or State equals Mississippi 

will select those records that have the text Texas. Louisiana, or 
Mississippi in the State field. 
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Combinations of And and Or. Sometimes it is necessary to mix op­
erators to define your desired selection. This is permissible in 
Works, but you are limited to six selection rules. What would the 
following rules produce? 

Sex equals female 
And Hair equals blonde 
Or Sex equals female 
And Hair equals black 

To enter a complex set of selection rules, follow these steps. 

1. Select the Record Selection command in the Organize menu. 
The Record Selection dialog box will appear. 

2. In the upper left-hand comer of the dialog box, the field names 
appear in a scrolling window. With the mouse, point to and 
click on the field name you want to search. 

3. In the upper right-hand comer of the dialog box, a list of 
comparison operators appears in a scrolling window. With the 
mouse, point to and click on the desired comparison operator. 

4. Type the comparison text in the box provided. 
5. Click the Install Rule button to define the selection rule. 
6. Click the appropriate button to specify the And or the Or 

connection operator. 
7. Repeat Steps 2 through 6 to install the additional selection 

rules. 
8. Click the Select button when all the rules have been installed. 

Helpful Hint: If you make a mistake and need to edit a selection rule, you must 
delete the selection rules in reverse order (last to first), make the 
correction, and reinstall the deleted rules. Use the Delete Rule 
button at the bottom of the Record Selection dialog box (see Figure 
6.12) to delete the last rule installed. 

For practice, try to select the records that have the text repulsive 
in the Synonym field and have a New Word that does not begin with 
the letter R in your dictionary. If you are successful. the record for 
abhorrent should be selected. 

6.4 CREATING A REPORT 

This section will describe how to create a printed report from the 
Works database. To explore the various report-generation options, 
you will create a sample database for the Big Wheel Bicycle Shop's 
parts inventory. Information provided by the shop's owner, Ben 
Biken, includes the catalog number of each part. a description, the 
cost, and the quantity in stock. Ben needs a report showing him the 
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total inventory value for each part, the subtotal of the inventory 
value, the quantity of parts in stock for each type of part, and the 
grand total value of his inventory. Your first step is to design and 
enter the basic data that Ben provided. Figure 6.13 shows the 
completed Works database. Reviewing previous sections if necessary, 
create a new database and enter the data from Figure 6.13. 

D I nuentory (DB) E!I 
Cata log Number J Description l Cost l Quantitg J ,... 
85321 l Campagno lo Br akeset ! 1 99 .00 ! 1 i t- ............................................... i ....................................................................................... , ......................... , ......................... , .................................................. .. 

t- .~.~.Q.! .. ~ ................................ L~.~T.P..~~.~~.~~ .. ~~.~~.~~.~~ ..................................... .J.~.~.?..:~~ ........ !.~ ...................... L.. ............................................... .. 
06410 !Campagnolo Fr ont Oerailleur !49.95 ls ! t- ............................................... , ....................................................................................... , ........................ ., ......................... , .................................................. .. 
06610 jCampagnolo Rear Oerailleur ! 149.95 l4 i t- ............................................... , ....................................................................................... , ......................... , ......................... , .................................................. .. 
S4340 jCampagnolo Seat Post j56.95 j6 i t- .............................................................................................................................................................................................................................................. .. 
85302 i Oia Compe Brakeset 134.95 !4 i t- ...... .... ..................................... , .................................................................. ................ ..... , .............. ........... , ......................... , ........ .......................................... .. 
85301 !Shimano Brakeset ! 198.95 !9 ! t- ............................................. + ...................................................................................... , ......................... , ......................... , .................................................. .. 

t-g~g~.~ .............................. ).~.~!.~.~~.?. .. ~.~~.~~.~~.~ ............................................. ).!5~.:~~ ........ j.~ .................... ) .................................................. .. 
06411 !Shimano Front Oerailleur !29.95 :9 ! 

~ :~:~:~§~:: :::::::::: ::: :::::::::: ::::::J#fo~:~~:?. ::~:~~i.::~:fr~rn:~~:~::::::::::::::::: ::::::::::::::J:?:~:;~~::: ::::::::i:~: ::: :::::::::: :::::::r:::: ::: :::::::::::::::::::::::::::::::::::::::::::: 
S4342 !Shimano Seat Post !39.95 !3 ! t- ............................................... , ....................................................................................... , ......................... , ......................... , .................................................. .. 
S4301 !Specialized Seat Post !22.95 !2 ! t- ............................................... i ....................................................................................... ( ...................... i ......................... ( ............................................... .. 

t- ............................................... ~ ....................................................................................... ! ......................... ! ......................... ! .................................................. .. 

~ :::::::::.:: :::::::::::::.:::::: :::::::::::::::r ::: ::::::::::::: ::::·:: ::::::::::::: :::::::::: ::: :::: .::::::::::::.~:.::::::::: :r:::::::::::: :::::::::::r-::: ::: :::::::::::::::1:::::::· ::::: ::: ::::::::::::::::::::::::::::::::::: 
: : : : 
! : : : 

I 
Figure 6.13. Inventory Example 

6.4.1 Setting Field Attributes and Computing Fields 

If you carefully compare Figure 6.15 (on p. 14 7) with the database 
that you have just created, you will notice a difference in the way 
the data in the Cost and Quantity fields are displayed: Cost is in a 
dollar-and-cents format and Quantity is right justified. The Set 
Field Attributes command in the Format menu controls how data 
are displayed in the database. To change a field's attributes, do the 
following. 

1. Select the field whose attributes you want to change by pointing 
to and clicking on the field name. The field will become high­
lighted when selected. 

2. Choose Set Field Attributes from the Format menu. The Set 
Field Attributes dialog box will appear on the screen (see Figure 
6.14). 
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Catalog Number Description Quantity 

D661 0 
84340 
85302 
85301 ......................... 
C6032 
D6411 
D6601 
84342 ......................... 
84301 

~ ....................... ; .................................................. .. 
2 l ................ ········~·············· ..................................... . 

Set Field Attributes For Cost 

Type: 
QTeHt 
@Numeric 
O Date 
QTime 

D Computed 

Display: 
0 General 
Q FiHed 
@Dollar 
0 Percent 
0 Scientific 

D Show 01~1.l 

Align: Style: 

0 Left D Bold 
O Center D Underline 
@ Right D Commas 

1'41 Decimal Places 

( Cance I ) E~( !!!!O!!!!K!!!!~~ll 
......................... ~======================~ .................... . ............................................... i ....................................................................................... , ......................... i""""""""""""f"""""""""" """ """""""""" ""' 

Figure 6.14. Set Field Attributes Dialog Box 

3. With the mouse, click on the desired attributes for Type, Dis­
play, Align, and Style. The field attributes are the same as the 
cell attributes in the spreadsheet. Refer to Section 4.2.4 for a 
detailed description of each attribute. 

4. Type the number of decimal places desired for numeric data; if 
decimal places aren't needed, use 0. 

5. Click the OK button. 

When you enter a new field, Works assumes that all fields are 
text fields. If you have numeric, date, or time data, you must set the 
field attributes appropriately. If you plan to do any calculations 
with your data, you must set the field attributes to Numeric. In 
your inventory example, set the fields as follows. 

Cost Type: Numeric 
Display: Dollar 

Quantity Type: Numeric 
Display: Fixed 
Decimal Places: 0 

Once you've defmed the numeric fields , Works can create the 
computed fields. A computed field is a numeric field whose con­
tents are computed using a formula specified by the user. For Ben's 
inventory you need to compute the total value of the inventory for 
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each part. To do this. you must multiply the cost of each item by 
the quantity in inventory. Follow these steps. 

1. Choose Add New Field from the Edit menu. The Field Name 
dialog box will appear. 

2. Type Total in the field name box and click the Add Field button. 
A new field will be added in the database window. 

3. Select the new field by pointing to and clicking on the field 
name. The field will be highlighted on the screen. 

4. Choose Set Field Attributes from the Format menu. The Set 
Field Attributes dialog box will appear on the screen. 

5. Select the desired field attributes. When the Numeric. Date. or 
Time option is selected. the Computed box in the lower left­
hand comer will become active. (In your inventory example, 
click on Numeric and Dollar.) 

6. Click on the Computed box and then click on the OK button. 
7. The new field will be filled with zeroes and an equal sign will 

appear in the field contents box. 
8. Enter the formula for the computed field after the equal sign in 

the field contents box. You can use field names. built-in func­
tions. and arithmetic operators ( + - * I " ). the same way you do 
in the spreadsheet (see Section 4.3.2). In your inventory example, 
type Cost • Quantity. 

9. Press the Enter key. The new field will be computed for each 
record in the database. 

Figure 6.15 shows the results of Ben's parts inventory after the 
Total field has been computed. 

6.4.2 Setting Up a Report 

The relation of a Works database to a report is analogous to the 
relation of a Works spreadsheet to a chart. You can have several 
reports associated with a database just as you can have several 
charts associated with a spreadsheet. As with a chart, you can 
select, edit, delete, or print a report. This feature allows you to 
define a report once and then print it out as often as you want. For 
example, Ben Biken will probably want you to update his inventory 
data and print out a new report each month. 

Before creating a new report, take these preliminary steps. 

1. Review the display format for each field and set the field attributes . 
if necessary. 

2. Create any necessary computed fields. 
3. Sort the database, if necessary (the sort criterion will not be 

saved with the report). 
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s File Edit Window Organize Format Report Macro 

:Cost *Quant i ty 

lnuentory (DB) 
Catalog Number Descript ion Cos t Quantity 

Figure 6.15. Computing the Total Field 

For your inventory example, Ben needs a subtotal for each type 
of part (that is, all cranksets, all derailleurs, all seat posts, and so 
on). His catalog numbers begin with a letter, which is a code for the 
type of part. D stands for derailleur, C for crankset, S for seat post, 
and B for brakeset. You will need to sort the Catalog Number field 
into alphabetical order before proceeding. Your database should 
resemble Figure 6.16. 

Helpful Hint: In case you've forgotten how to sort a field , here's a brief reminder: 
select the field , choose Sort from the Organize menu, select the type 
of sort in the dialog box, and click the OK button. 

With these preliminary steps completed, choose New Report 
from the Report menu. The Report Definition window will appear on 
the screen (see Figure 6.17). This window will let you reformat your 
data for a report withou t affecting the database window. You can 
rearrange the fields, change the field widths, create record selection 
criteria, and change the font and size: the definition information is 
saved with each report . Works can store up to eight different 
reports for a single database. 
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_o lnuentory (DB) ~r 
Catalog Number lDescription l Cost l Quantityl Total J ~ 
B5301 ]Shimano Br akeset I $198 .95 i 9 i $1790 .55 i 

..... ~.~.~.Q.~ ............................... .t~:~~:~~:~P.~::~~:~~:!~:!L:::::::::::::::::::::::::::::::::::::::i::::::~~~:.:?.:~:::r::::::::::::::::::::~r:::::::::::::E~~~:~:§:::r:::::::::::: 
B5321 ! Campagno lo Br akeset ! $1 99 .00 ! 1 ! $1 99 .00 ! ..................................................................................................................................................................................................................................................... 
C6010 !Campagnolo Crankset ! $229.95 ! 2! $459.90 ! 

: :~~§:*:~::::::::::::::::::::::::::::::1~~~:~~~:?.::~f.~~~:~~:~:::::::::::::::::::::::::::::::::::::::::::::1I1:~~:.:?.:~::r ::::::::::::::::::::~c::::::::::::~~z~:.:~:§:::1:::::::::::::: 
D6410 jCampagnolo Front Derailleur i $49.95 i Si $249.75 i 

: :~~:~:~::~:::::::::::::::::::::::::::::::1~:~~~:~~?.::~~:?.~~::~~:f.~:~~:~~:~r.:::::::::::::::::::::::::::::::i::::::~~~:.:?.:~:::i::::::::::::::::::::::?.r:::::::::::::~~~~:.:~:~::r:::::::::::: 
D6601 i Shimano Rear Der ailleur i $78 .95 i 8i $631 .60 i 

1- ............................................... : ....................................................................................... : ......................... : ......................... : ..................................... : ............ .. 

D661 0 ! Campagno lo Rear Der ailleur ! $1 49. 95 ! 4 ! $599 .80 ! 1- .............................................................................................................................................................................................................................................. .. 
S4301 i Specfa lized Seat Post i $22. 95 i 2 i $45. 90 i I- .......... ._ .................................. : ....................................................................................... : ......................... : ......................... : ..................................... : ............. . 
S4340 ! Campagno lo Seat Post i $56 .95 ! 6 ! $341 .70 ! 

1- ............................................................................................................................................................................................................................................... . 

S4342 iShimano Seat Post i $39.95 i 3i $119.85 i 

I 
Figure 6.16. Inventory Sorted by Catalog Number 

Arranging the Fields. In the middle of the Report Definition window 
is a ruler with small black triangles indicating the left and right 
margins (see Figure 6.17). This is the width of your report. Any field 
that lies between the margin indicators will print on the report. Any 
field to the right of (outside) the right-margin indicator will not print 
on the report. Consequently, you must drag fields that you do not 
want to print outside that margin and fields that you do want to 
print inside it. Pointing to the field name with the mouse; the 

cursor will change into the hand icon (0). Hold the mouse button 
down and drag to the right or left as desired. Release the mouse 
button when the field is in the desired location. 

Once the fields are arranged, adjust the field widths in the same 
way you adjusted them in the database window, using the+ 
cursor. Scroll through the records to make sure that the fields are 
wide enough for all the records, not just the ones visible in the 
window. Now that the widths are adjusted, drag the right-margin 
indicator ( ~ ) with the mouse to the right edge of the last field you 
want printed in the report. 

Helpful Hint: The right-margin indicator will not move beyond the margins that 
have been defmed in the Page Setup command. For example, if you 
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s File Edit Window Organize Format TotalsPage Macro 

I nuentory Report 1 

Selection Rules: No Rules Are In Effect 

Catalog Humber 
B5301 
B5302 
B5321 
C6010 
C6032 
D6410 
D6411 
D6601 

Description 
Shimano Brakeset 
Dia Compe Brakeset 
Campegnolo Brakeset 
Campegnolo Crankset 
Shimano Crankset 
Campegnolo front Derail11 
Shimano front Derailleur 
Shimano Rear Derailleur 

$198.95 
$34.95 

$199.00 
$229.95 
$143.95 

$49.95 
$29.95 
$78.95 

Figure 6.17. Report Definition Window 

have set the paper to US Letter (8 .5 inches wide) and have set the 
left and right margins to 1 inch, your report will be 6.5 inches wide. 
The right-margin indicator in the Report Definition window will not 
move past the 6.5-inch mark on the ruler. If you want your report 
wider, choose Page Setup from the File menu and enter smaller 
margins. 

Record Selection Criteria. The next step is to define the record 
selection criteria. Choose Record Selection from the Organize menu. 
The Record Selection dialog box (see Figure 6.12) will appear on the 
screen. Review Section 6.3.4 for instructions. (In your inventory 
example, you do not need any record selection.) 

Changing the Font and Size. You can change the font in which the 
report will be printed by selecting the desired font from the Font 
submenu under the Format menu. The size of the font can be 
changed by choosing the Size submenu in the Format menu. The 
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font and size selected will affect all fields in the report. Conse­
quently, the field widths will have to be adjusted. 

Eliminating the Grid. The dotted grid lines separating each field 
and each record can be eliminated. Choose the Show Grid com­
mand in the Format menu to toggle between showing and hiding 
the grid. Remember, What You See in the Report Definition window 
Is What You Get on the printer. 

Totaling Fields. In your example, Ben wanted subtotals for each 
type of part. grand totals for the number of parts in his inventory. 
and the grand total inventory value. The TotalsPage menu has 
several commands that will make this task easy. The first step is to 
define which fields are to be totaled. 

1. Select the field to be totaled by clicking on the field name. The 
field will be highlighted on the screen. (In your example, click 
on the Total field.) 

2. Choose Sum This Field from the TotalsPage menu. 

Nothing will happen on the screen; the totals will be computed 
when you print the report. Now, on your own, total the Quantity 
field in your inventory example. 

The next step is to define which field will be the criterion for the 
subtotals. Ben wants subtotals after each type of part. You sorted 
the database on the Catalog Number field because the initial letter 
of the catalog number represented the type of part. Therefore, every 
time the letter changes. Ben wants a subtotal. 

1. Select the field that will be the criterion for the subtotals by 
clicking on the field name. The field will be highlighted on the 
screen. (In your example, click on the Catalog Number field.) 

2. Choose Take a Sub-Total on 1st Char from the TotalsPage 
menu. 

This option will compute and print a subtotal for every field to be 
totaled each time the first letter in the criterion field changes. (See 
the printed inventory report in Figure 6.18.) 

The other option is to take a subtotal whenever the criterion 
field changes. Suppose Ben had a field showing the manufacturer 
of each part. If the database were sorted on the manufacturer field 
and the Take a Sub-Total on Field Change option were chosen from 
the TotalsPage menu, the printed report would have subtotals by 
manufacturer. 

The last option in the TotalsPage menu is New Page After Total. 
If you choose this option, the printer will eject a page after each 
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Catalog Ba:mlaer Descri:P...::.::ti=o;.::;;;:a~----- Cost _Qaaatit:r.. Total 
B 5301 Shimano Brakeset $198.95 9 $1 ?90.55 
B 5 3 0 2 Dia Cornpe Brakeset $34.95 4 $139.80 
B 5 3 21 Carnpa~1o Brakeset $199.00 1 S19_9.00 

C6010 
C6032 

D6410 
D6411 
D6601 
D6610 

S4301 
S4340 
S4342 

Carnpapo1o Cratakset 
Shimano Crat'lkset 

Carnpagno1o Front Derai11ear 
Shim.at\O FrofLt Derai11ear 
Shimano Rear Derai11ear 
Carnpag;noto Rear Derai11ear 

Specialized Seat Post 
Carnpag;no1o Seat Post 
Shimano Seat Post 

$229.95 
$143.95 

$49.95 
$29.95 
$?8.95 

$149.95 

$22.95 
$56.95 
$39.95 

14 $2129.35 

2 $459.90 
4 $..51.5.80 
6 $1035.?0 

5 $249.?5 

9 $269.55 
8 $631.60 
4 $..5_9_9.80 

26 $1 ?50.?0 

2 $45.90 
6 $341.?0 

3. $119-1,5_ 
11 $50?.45 

5? $5423.20 
Figure 6.18. Inventory Report 

subtotal. This makes the subtotal the last line printed on each page 
and you get a separate page, with a subtotal, for each category. 

6.4.3 Printing a Report 

Defining a database report can be a lengthy process. Here is a 
summary of the steps. 

1. Review the display format for each field and set the field at-
tributes, if necessary. 

2. Create any necessary computed fields. 
3. Sort the database, if necessary. 
4. Choose New Report from the Report menu. 
5. Choose Page Setup from the File menu and set the paper. 

printing orientation, margins. header. and footer. 
6. Drag the desired fields inside the margins and drag unwanted 

fields outside the right margin. Adjust the field widths. Drag the 
right-margin indicator to the right edge of the last field to be 
printed. 
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7. Define the record selection criteria by choosing Record Selection 
from the Organize menu. 

8. Select the desired font and font size from the Format menu. 
Show or hide the grid lines as desired. 

9. Select each field to be totaled and choose Sum This Field from 
the TotalsPage menu. 

10. Select the criterion field for subtotals and choose the appropri­
ate subtotal options from the TotalsPage menu. 

11. Choose New Page After Total from the TotalsPage menu if you 
want each category to appear on a new page. 

You should be ready to print your inventory example. Choose Print 
from the File menu. Your results should match Figure 6.18. 

As mentioned previously, Works will allow up to eight reports to 
be defined per database. The Report menu has options to select a 
previously defined report to be printed, to duplicate a previously 
defmed report for revision, and to delete a report that is no longer 
needed. The Change Report Title command in the Edit menu will let 
you enter report titles that are more meaningful. All these options 
help you work easily with database reports. 

The report feature of the database prints only lists of the data. 
In the next chapter, you will explore integrating the Works data­
base with the Works word processor to generate other types of 
printed output, such as mailing labels. 

6.5 POSERS, PROBLEMS, AND PROJECTS 

$1. Using Works, design a database in which to store Acme 
Paper Clip Company's customers. The following fields will be 
necessary: Title (Mr., Mrs., and so on), First Name, Last 
Name, Street Address, City, State, and ZIP Code. Enter at 
least 25 names and addresses (use your imagination). Sort 
the database alphabetically by Last Name and print out a 
list. Name the database file Acme's Customers and save it on 
your disk for use in the next chapter. 

2. Acme's chief research engineer, Ben Dremin, asks you to use 
your computer to help his son fmish his science project. All 
you have to do is catalog Little Ben's collection of parrots. 
Using the data here, create a database, select out only the 
South American parrots, and print separate lists of the 
parrots by color, distribution, and species. (Ben had the 
nerve to tell you that he needs it by 4:30 today!) 
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Length 
Common Name Species (Inches) Color Distribution 

African Gray Parrot Psittacus erithacus 14 Gray Africa 
Bare-eyed Cockatoo Cacatua sangutnea 15 White Australia 
Black-headed Catque Pionites melanocephala 9 Green South America 
Blue and Gold Macaw Ara ararauna 34 Blue South America 
Blue-fronted Amazon Amazona aestiva 15 Green South America 
Bronze-winged Parrot Pionus chalcopterus 11 Blue South America 
Eclectus Parrot Eclectus roratus 14 Green South Pacific 
Finsch's Amazon Amazona ftnschi 13.5 Green Mexico 
Goffin's Cockatoo Cacatua gofflni 12.75 White South Pacific 
Great Green Macaw Ara ambigua 34 Green Central America 
Greater Sulfur Cockatoo Cacatua galerita 20 White Australia 
Green-cheeked Amazon Amazona viridigenalis 13.5 Green Mexico 
Green-winged Macaw Ara chloroptera 36 Red South America 
Hyacinth Macaw Andorhynchus hyacinthinus 40 Blue South America 
Illiger's Macaw Ara maracana 17 Green South America 
Jardine's Parrot Poicephalus gulielmi 11 Green Africa 
Lesser Sulfur Cockatoo Cacatua sulphurea 13.5 White South Pacific 
Maximilian's Parrot Pionus maximiliani 11.5 Green South America 
Mealy Amazon Amazona farinosa 16 Green South America 
Meyer's Parrot Poicephalus meyeri 8.5 Gray Africa 
Military Macaw Ara militaris 28 Green Central America 
Moluccan Cockatoo Cacatua moluccensis 22 White South Pacific 
Noble Macaw Ara nobills 12 Green South America 
Orange-winged Amazon Amazona arnazonica 13 Green South America 
Red-vented Parrot Pionus menstruus 11 Green South America 
Rose-breasted Cockatoo Eolophus roseicapillus 14 Gray Australia 
Scarlet Macaw Aramacao 34 Red South America 
Senegal Parrot Poicephalus senegalus 9 Gray Africa 
Severe Macaw Ara severa 18 Green South America 
Umbrella-crested Cockatoo Cacatua alba 18 White South Pacific 
White-bellied Caique Pionites leucogaster 9 Yellow South America 
White-fronted Amazon Amazona albifrons 10.5 Green Mexico 
Yellow-cheeked Amazon Amazona autumnalis 13.5 Green Central America 
Yellow-fronted Amazon Amazona ochrocephala 14 Green South America 
Yellow-naped Macaw Ara auricollis 15.5 Green South America 

3. Using Works, design a database for one of the example 
applications listed in Section 6.1. l and print out meaningful 
reports. Choose something useful to you: the best way to 
learn a computer application is to do something practical and 
of immediate personal value. 

*4. Using the Big Wheel Bicycle Shop inventory database you 
created in Section 6.4, design and print a report sorted by 
the manufacturer of each part. Print subtotals for the quan­
tity of parts by manufacturer and for the total value of the 
inventory. The report will resemble Figure 6.18, but it will be 
organized by manufacturer instead of by type of part. 
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"The young do not know enough to be prudent and therefore they 
attempt the impossible-and achieve it, generation after generation." 

-Pearl S. Buck 

"The opportunities of man are limited only by his imagination. But so few 
have imagination that there are ten thousand fiddlers to one composer." 

-Charles F. Kettering 

"Man's mind stretched to a new idea never goes back to its original 
dimensions." 

-Oliver Wendell Holmes 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. List the general steps for copying and pasting information 
(Section 7.2.1) 

2. Copy information from the Works spreadsheet and database 
into the word processor (Section 7 .2.2) 

3. Copy information from the Works word processor and data­
base into the spreadsheet (Section 7 .2.2) 

4. Copy information from the Works word processor and spread­
sheet into the database (Section 7.2.2) 

5. Copy information from the Works communications and graph­
ics applications into the word processor. spreadsheet, and 
database (Section 7.2.2) 

6. Paste information into and copy information from the Scrap­
book (Section 7.2.3) 

7. Merge data from the database with the word processor using 
the Prepare to Merge and Print Merge functions (Section 7 .3) 

8. Print labels (Section 7.3.3) 
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7.1 THE POWER OF WORKS: 
INTEGRATING APPLICATIONS 

The ability to combine information from word processor, spread­
sheet, database, and communications applications is a powerful 
tool that can increase your personal productivity. Suppose your 
boss assigned you to analyze the company's sales. With the Works 
tools available you could log on the company's mainframe computer 
and retrieve the sales figures for the past 3 years, copy the data 
from the communications application into a spreadsheet, calculate 
statistics on sales growth, create several pie and bar charts, write 
your report using the word processor, copy the charts into your 
report, and merge your report with a database of company executives, 
printing up a personalized memo to each. Pretty impressive! Yet, all 
this is easy to do with a knowledge of each of the Works applications 
and the techniques to integrate them. 

This chapter covers the two techniques of integrating informa­
tion in Works: using Copy and Paste to move information between 
two different documents and using the Print Merge feature to 
combine information from the database with the word processor. 
Once you master these techniques, the capabilities of Works with 
the Macintosh are limited only by your imagination. 

7.2 COPYING INFORMATION 
BETWEEN APPLICATIONS 

In Chapter 2 you learned how to copy text from one location in a 
word-processing document and paste it into another location in the 
same document (Section 2.4.3). Similar concepts are used in mov­
ing text and graphics between the word processor, spreadsheet, 
database, and communications applications. 

7 .2.1 Cut and Paste 

The Macintosh has some very powerful features that allow blocks of 
text and graphics to be copied from one place to another within a 
document, to another document in the same application, or to 
another application. All three functions are performed in similar 
fashion in that they require the use of the Clipboard. 

The Clipboard is a special storage area set aside in main 
memory and accessible from all the Works applications. It can store 
only one block of text, one block of text with graphics, or one single 
graphic at a time and is limited by the amount of main memory 
your Macintosh has and the number of ftles open in Works. When 
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you select the information and choose Copy from the Edit menu, 
the information selected is moved to the Clipboard. When you 
choose Paste from the Edit menu, the information is moved from 
the Clipboard and inserted at the location of your cursor. Because 
the Clipboard contains only one item at a time, you must paste an 
item before you can copy the next one. Figure 7 .1 diagrams copying 
and pasting to and from the Clipboard. 

Sample 
Text 

Original Document 

Sample 
Text 

Original Document 

Sample 
Text 

Clipboard 

Before Copy 

After Copy 

After Paste 

Figure 7.1. Using the Clipboard to Copy and Paste 

Clipboard 

Sample 
Text 

Clipboard 

Sample 
Text 

New Document 
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General Steps for Copying Information 
I. Open the document you wish to copy from (the source) and the 

document you wish to paste to (the destination). In the Window 
menu, choose the name of the document from which you wish 
to copy. This will bring that document to the foreground of your 
screen. 

2. With the cursor, select the text, graphics, cells, or fields that 
you wish to copy. 

3. Choose Copy from the Edit menu in the Menu Bar. 
4. The selected data will remain in your source document and a 

copy will be placed on the Clipboard. 

Helpful Hint: To check the contents of the Clipboard, choose the Show Clipboard 
option in the Window menu. To hide the Clipboard window, click its 
close box or choose Hide Clipboard in the Window menu. 

General Steps for Pasting Information 
5. Choose the name of the destination document from the Window 

menu to bring it to the foreground. 
6. Place the cursor at the exact location where you want the 

information pasted. Click the mouse button. (In the database 
and spreadsheet, you need only select the upper left-hand cell 
or field in the area to be pasted.) 

7. Choose Paste from the Edit menu in the Menu Bar. 
8. The data will be copied from the Clipboard and pasted into your 

destination document. 

Helpful Hint: If you are only pasting graphics, you do not need to position the 
cursor. When the Paste command is chosen, the graphic will be 
pasted in the center of the screen. You can then use the Pointer tool 
to drag the graphic into place and change its size if desired. 

7.2.2 Considerations When Copying 
Between Applications 

Because of natural differences between the word processor, 
spreadsheet, database, and communications data, some consider­
ations must not be ignored when copying information between 
certain applications. The procedure for copying all information is as 
outlined in the previous section; however, the results may differ. 
The following sections describe these special circumstances. 

Helpful Hint: Regardless of the source or the destination, you will probably have 
to change the appearance of the information copied. This could 
mean changing the font, size, style, justification, and spacing; 
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moving tab stops, margins, and paragraph indentations; inserting 
Returns, tabs, and page breaks; relocating and sizing drawings 
and charts; and adding headers, footers, and other Page Setup 
information. 

Copying to the Word Processor. Information copied to the word 
processor maintains the format of the source document. In other 
words, the pasted text will have the same font, style, size, and 
justification as the original text. Text copied from one word­
processing document to another will also have the same spacing 
and ruler settings (margins, paragraph indentation, and tab settings). 

When information is copied from the spreadsheet to the word 
processor, the data that were separated in columns will be sepa­
rated by tabs. Because the word processor automatically sets tab 
stops evecy 1 /2 inch, the information may be too wide or improperly 
spaced when it is pasted. The solution is simple: add, delete, or 
move tab stops in the ruler (see Section 2.4.5). When information is 
pasted, it remains selected (highlighted); the ruler settings can be 
changed until the pasted selection is formatted properly. Figure 7.2 
illustrates copying information from the spreadsheet to the word 
processor. 

Information copied from the database to the word processor is 
handled in the same manner, with tabs separating the fields. 
However, the field names are automatically copied to the top of 
each column. If you do not want the field names pasted to the word 
processor, hold down the Option key while choosing the Paste 
command. Refer to Figure 7.3 for an example of copying from the 
database to the word processor. 

If formulas are part of the information copied from either the 
spreadsheet or the database, only the value of the formula is pasted 
to the word processor. The relationship between cells that existed 
in a spreadsheet formula will not exist in the word processor. For 
example, if a value is changed after pasting data from the spread­
sheet to the word processor, the total of the column will not be re­
calculated, as it would have been in the spreadsheet. 

Copying to the Spreadsheet. In contrast to the word processor, the 
spreadsheet will adjust information copied to match the font, size, 
style, cell attributes, and border of the cell into which it is pasted. 
The word processor, then, uses the attributes of the source infor­
mation; the spreadsheet uses the attributes of the destination cells. 
Works pastes information into adjacent cells if the source information 
is separated by either a tab or two or more spaces. Whenever a 
Return character appears in the source information, Works pastes 
the information following the Return into the next row. A blank line 
in the word processor will skip a row in the spreadsheet. 
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E F 
I 1 .................................... , .................. .. 

3 
4 
5 
6 
7 
8 
9 

Selected cells are copied to the Clipboard. 

Information is pasted at the location of the cursor. 

l::ompan11 Sales 1987 
12,376,890 
3,945,611 
9,399,789 

Sales 1988 Sales 1989 
20,387,200 

6,145,372 
10,123,533 
3 ,433,678 

Acme Paper Clip 
United Plastics 
Mitsubishi Paper Clip 
A .0 .S . Paper Clip 

~! 
Tabs are inserted between columns. 

14,610,923 
5 , 100,679 
7 ,290,098 
6 ,777,213 

Figure 7.2. Copying Information from the Spreadsheet to the Word Processor 

\ 
Returns are inserted 
at the end of each row. 

Short Cut: In the spreadsheet, the destination location can be specified by 
clicking on the cell in the upper left-hand corner of the area to be 
pasted. When the information is pasted, any existing data in the 
destination cells is lost. A dialog box will warn you that you will lose 
data and will let you cancel the paste if you so desire. 
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Information is pasted at the location of the cursor. 

~ompany Sales 1988 
Acme Paper Clip 
United Plastics 
Mitsubishi Paper Clip 
A .0 .S. Paper Clip 

Sales 1987 
12,376,890 
3 ,945,611 
9,399,789 

~! 
14,610 ,923 
5,100,679 
7,290,098 
6,777,213 

Sales 1989 
20,387,200 

6, 145,372 
10 , 123,533 
3,433,678 

\ 
Tabs are inserted between columns. Returns are inserted 

at the end of each row. 

Figure 7.3. Copying Information from the Database to the Word Processor 

When information is copied from the database to the spread­
sheet, the source information should be copied from the List 
window, as opposed to the Form window. Information in adjacent 
fields in the database will be pasted to adjacent cells in the 
spreadsh eet; information in adjacent records in the database will 
be pasted to adjacent rows in the spreadsheet. Works automatically 
pastes the field names across the top of the spreadsheet columns 
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4 
5 
6 

7 
8 
9 

\Soloolod '"' ;, coplod to lho CHpboa'd. 

Information is pasted at the location of the cursor. 

B 

A tab or two or more spaces 
indicates a new column. 

Untitled (SS) 
c D E 

Return indicates beginning 
of a new row. 

F 

Figure 7.4. Copying Information from the Word Processor to the Spreadsheet 

unless you h old down the Option key while choosing the Paste 
command. Figures 7.4 and 7.5 illustrate copying information from 
the word processor and database to the spreadsheet. 

Copying to the Database. Copying information to the database is 
very similar to copying to the spreadsheet. Information copied to 



7.2 Copying Information Between Applications 163 
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Selected text is copied to the Clipboard. 

Information is pasted at the location of the cursor. 

Untitled (SS) 
B 

The number of columns created will equal the 
number of fields copied. 

c D E F 

Figure 7.5. Copying Information from the Database to the Spreadsheet 

the database takes on the attributes (font, size, style, and so on) of 
the destination field, a tab (or two or more spaces) indicates that 
data should go into the next field , and a Return character indicates 
the start of a new record . Graphics, however , cannot be pasted into 
the database. Refer to Figures 7 .6 and 7. 7 for examples of copying 
information to the database. 
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\ Selected te•t Is copied to the Cllpboa.d. 

Information is pasted at the location of the cursor. 

Create the same number of fields as columns in the source. 

A tab or two or more spaces 
indicates a new field. 

Figure 7.6. Copying Information from the Word Processor to the Database 

Return indicates beginning 
of a new record. 

Helpful Hint: It is important to define the same number of fields in the database 
as there are columns of information to be pasted. That is, to copy a 
spreadsheet with data in six columns, you need to defme six fields 
in the database. 

Copying and Pasting Communications Information. The communi­
cations application combines with the other Works applications in 
several ways. Word-processing, spreadsheet, and database files 
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~n 

Selected text is copied to the Clipboard. 

Information is pasted at the location of the cursor. 

Create the same number of fields as columns in the source. 

Figure 7.7. Copying Information from the Spreadsheet to the Database 

can be sent and received by following the instructions in Section 
8.2. The Capture Text command (see Section 8.2.2) stores an entire 
communications session in a word processor file. In both cases, the 
information received in the communications application can be 
dealt with as a word-processing, spreadsheet, or database docu­
ment and copied to another application using the instructions in 
this section. 

The Clipboard can be used in the normal manner to copy 
information from a source or paste it to a destination during a 
communications session. Graphics, however , cannot be pasted to 
the communications application. 
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Copying Graphics. Graphics. objects created with draw tools and 
spreadsheet charts. are copied and pasted using the Clipboard in 
the normal manner with the following restrictions. You can copy 
only from word processor to word processor. from spreadsheet to 
spreadsheet, from word processor to spreadsheet, and from 
spreadsheet to word processor. Charts are copied to the Clipboard 
by choosing Copy when the chart window is active. 

7 .2.3 Using the Scrapbook 

Because the Clipboard can contain only one item at a time, a 
Macintosh desk accessory is available to store information more 
permanently. The Scrapbook is a special storage area set aside on 
the start-up disk. Information from any of the applications can be 
stored in the Scrapbook and retrieved from it. using the Clipboard 
as an intermediate storage area. The number of items stored in the 
Scrapbook is limited only by the amount of memory available on 
the start-up disk. 

The Scrapbook is a useful tool when several different pieces of 
information or drawings need to be copied from one or more source 
documents. Some people design their Scrapbook to store items that 
they frequently paste into documents: company logos, special 
symbols, illustrations. their return address, contractual disclaim­
ers, and so on. The steps necessary to use the Scrapbook are 
outlined below. 

To Copy Information to the Scrapbook 
1. Open the document from which you wish to copy. 
2. With the mouse, select the text, graphics, cells, or fields you 

wish to copy. 
3. Choose Copy from the Edit menu in the Menu Bar. 
4. The data selected will remain in your source document and a 

copy will be placed on the Clipboard. 
5. Choose Scrapbook from the Apple menu. 
6. Choose Paste from the Edit menu. The information on the 

Clipboard will be copied into the Scrapbook. 
7. Close the Scrapbook by clicking the close box or choosing Close 

from the File menu. 

To Copy Information from the Scrapbook 
1. Open the document into which you wish to copy information. 
2. Choose Scrapbook from the Apple menu. 
3. Scroll the Scrapbook using the scroll box and bars at the 

bottom of the window until the information you wish to copy is 
in view. Do not worry if all the information is not visible in the 
window. The entire contents of the Scrapbook item will be 
copied to the Clipboard. 
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4. Choose Copy from the Edit menu. 
5. Close the Scrapbook by clicking the close box or choosing Close 

from the File menu. 
6. Place the cursor at the exact location where you want the 

information pasted. Click the mouse button. (In the database 
and spreadsheet, you need only select the first cell or field in 
the area to be pasted.) 

7. Choose Paste from the Edit menu in the Menu Bar. 
8. The data will be copied from the Clipboard and pasted into your 

destination document. 

To Delete Information from the Scrapbook 
1. Choose Scrapbook from the Apple menu. 
2. Scroll the Scrapbook using the scroll box and bars at the 

bottom of the window until the information you wish to delete is 
in view. 

3. Choose Cut from the Edit menu. 
4. Close the Scrapbook by clicking the close box or choosing Close 

from the File menu. 

Because the Scrapbook is kept on the start-up disk, the infor­
mation is more permanent than information stored in the Clipboard. 
Consequently, it is useful for copying information from Works to 
other Macintosh programs. To do so, follow these steps. 

1. Start up Works and open the source documents. 
2. Copy the desired drawings, charts, text, and tables to the 

Scrapbook. 
3. Close the Scrapbook and quit Works. 
4. Start up the other application and open the destination docu­

ment. 
5. Copy each item, one by one, from the Scrapbook and paste it 

into the destination document. 

7.3 MERGING DATA FROM THE DATABASE 
WITH THE WORD PROCESSOR 

One of the most powerful features of Microsoft Works is its ability to 
merge fields from the database with the word processor. This allows 
you to extend the report-generation capability of the database to 
include form letters, labels, business forms, and other customized 
documents. For example, a letter in the word processor can be 
individualized by addressing each person on a mailing list in the 
database, gummed price labels can be printed in the word processor 
using an inventory database, or a statement form can be designed in 
the word processor and merged with the company's accounts 
receivable database to print monthly statements for each customer. 
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The merge process can be broken down into five general steps. 

1. Design the database and type in the information. 
2. Create the word-processing document: letter, label, or form. 
3. Use the Prepare to Merge command to merge the desired fields 

from the database into the word processor. 
4. Perform any desired sorting or record selections in the database. 
5. Use the Print Merge command to print the documents. One 

document will print for every record selected in the database. 

A practical example is probably the best teacher. The letter in 
Figure 7.8 announces Acme's new Super Clip to its customers. 

~© [jiji}@ [¥)~[p)®rr ©a D 1PJ ©@[jiji} IPJ~mlW 
123 Main Street 

Los Angeles, California 90001 

April 1, 1990 

Dear 

I am pleased to announce to our valued customers the new Super Clip. This 
revolutionary paper clip is made from kevlar, the bulletproof vest material used by all 
major metropolitan police forces. This new paper clip will not bend, break, or rust. Yet 
it costs only pennies more than standard paper clips. I have enclosed a sample for 
your inspection. Put it to the test and see if you don't agree that the Super Clip 
is the best paper clip ever designed I 

Super Clip 

To introduce the Super Clip to our customers, I am offering special introductory 
prices. I hope that you will stock the Super Clip, for obvious reasons. Thank you for 
your patronage. 

Sincerely, 

Sidney Celmour 
Marketing Director 

Figure 7.8. Sample Form Letter 
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D Heme's Customers (DB) t!le 
Title}First Name }Last Name }street Address }city JstatelZip ,... 
Mr. ! Abraham !Jones !987 First St. !Riverside !CA 192502 l H ............... ; ................................... ; ................................................. ; ................................................... ; ......................................... ; ................ .; ......................... ; 
Mrs. !Mary jSweet !2000 Hershey Ave. jSan Bernardino jCA j92401 j H ... ............ , ................................... ,. ................................................ ,. .................................................. , ......................................... , ................. , ........................ ., 

H-~.~~.!: .. .L~.?.! .. ~: .................... .L~.~.1~ ...................................... ..!.~.~.~ .. ~~.~.~!.~ .. ~.~ ................. .L~.~~.1~.~~.~ .. ~.!!.9.~.~.~ .. .L~.~ ........ ..!.~. ! .. ?.~.~ .......... ! 
Mr. i Al !Heart !555 Cardiao Dr . !Long Beach !CA !90840 i H ............... ,. .................................. , ................................................ .,. ................................................. ., ........................................ ., ................. , ......................... , 
Miss ! Ima !Darling !6969 Pacifio Grove !Monterey !CA j93950 j 

l-fam_...f::::::::::::::::::::::::::::::::1::::::::::::::::::::::::::::::::::::::::::::::::r::::::::::::::::::::::::::::::::::::::::::::::::r:::::::::::::::::::::::::::::::::::::::r::::::::::::::r:::::::::::::::::::::::1 

Figure 7.9. Acme's Customers Database 

Figure 7.9 contains a partial list of those customers. The merge 
feature of Works will allow you to print a customized letter to each 
individual on the mailing list. Before continuing with the remainder 
of this chapter, follow these steps to set up the example. (Note: If 
you already created a database of Acme customers in Section 6.5, 
Problem l, skip Steps 4 and 5.) 

1. Create a New word-processing document by typing and editing 
the text in Figure 7.8. Follow the spacing very carefully. 

2. Optional: If you drew Acme's Super Clip in Section 3.4, Prob­
lem 1, use the Clipboard to Copy and Paste the drawing into 
your letter. (If you need help, see Section 7.2 ; the Super Clip is 
also on the diskette that accompanies this text.) 

3. Save the document as Super Clip Letter. 
4. Create a New database file defining seven fields: Title, First 

Name, Last Name, Street Address, City, State, ZIP. 
5. Type the customer names shown in Figure 7.9 into the data­

base and save the file as Acme's Customers. 

7 .3.1 Preparing to Merge 

The object of the Prepare to Merge command in the Edit menu is to 
define which fields from the database are to be merged and where 
the fields will be located in the word-processing document. The first 
step requires positioning the cursor at the exact location where the 
data are to appear in the word-processing document. Next choose 
the Prepare to Merge command and select the field to be merged. 
This process is repeated for every field that needs to be merged. A 
field that is not wanted in the word-processing document can be 
skipped, or a field can be selected more than once if you want it to 
appear multiple times in the document. 

Follow these steps to merge Acme's Customers with the Super Clip 
Letter. 

1. Open the database (Acme's Customers). if it is not already open. 
2. Open the word-processing document (Super Clip Letterj, if it is 

not already open. 
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3. Position and click the cursor at the beginning of the blank line 
immediately above the word Dear. 

4. Choose Prepare to Merge from the Edit menu. A dialog box will 
appear (see Figure 7 .10). 

5. Select Acme's Customers database and select the Title field. 
Click the Merge button. 

Prepare to Merge: 

Select Merge Data Base: 
Ac me·s Customers 

Figure 7 .1 O. Prepare to Merge Dialog Box 

Select Merge Field: 
Title :'B 
First Name 
Last Name 
Street Address 
City 
State 
Zip 

Cancel ) {(;Merge )J 

Helpful Hint: Choose the Show Field Names command in the Edit menu to 
display the names of the merged fields in the word processor. 

6. Because you want a space between Title and First Name, press 
the Space Bar once. 

7. Choose Prepare to Merge and select the First Name field. Click 
the Merge button. Press the Space Bar again to add a space 
between First Name and Last Name. Choose Prepare to Merge 
and select the Last Name field. Click the Merge button. Your 
screen should look like Figure 7 .11. 

Helpful Hint: Do not be alarmed that the Last Name field is displayed on the line 
below the Title and First Name fields. There simply is not enough 
room for the field names to print on the same line. However, the 
data will be printed on the same line. Choose Show Field Data in 
the Edit menu and view the data. 

8. Press the Return key to start the address on a new line. Choose 
Prepare to Merge and merge the Street Address field. 

9. Press the Return key to start the City, State, and ZIP on a new 
line. Merge the City field in the same manner as you merged the 
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123 Main Street 
Lo P.ngeles, California 

!Acme's c ustomers:T1tlellAcme 's customers:F1rst Name I 
!Acme's customers:Last Name I 
Dear 

I am pleased to announce to our va I ued customers the new super Clip. This 
revolutionary paper clip is made from kevlar, the bulletproof vest material used by all 
major metropo I ita n po I ice forces. Th is new paper clip will not bend, break, or rust. Yet 
it costs only pennies more than standard paper clips. I have enclosed a sample for 
your inspection. Put it to the test and see if you don't agree that the Super Clip is the 
best paper clip ever designed! 

Figure 7.11. Super Clip Letter After Merging First Address Line with Show Field Names in Effect 

other fields. This time, however, type a comma and press the 
Space Bar to place a comma between City and State. Merge 
the State field. Press the Space Bar twice and merge the ZIP 
field. Press the Return key to add a blank line between the 
address and the salutation. 

10. Click the cursor immediately after the salutation Dear. Press the 
Space Bar once and merge the Title field. Press the Space Bar 
and merge the Last Name field. Type a colon. Your final 
merged document should look like Figure 7.12. 

11. Save your merged document. The reference or link to the 
database fields will be saved, not the data showing in the 
window. 

You can preview how a document will look for a specific data­
base record by selecting any field in the record. For example, if 
you wanted to review how the letter to Professor Joe K. Stir would 
look, click on any field in his record in the database window and 
choose the word-processing window to view the customized letter. 
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·123 Main Street 
Los Angeles, California 90001 

April 1, 1990 

Mr. Abraham Jones 
987 First St. 
Riverside, CA 92502 

Dear Mr. Jones: 

I am pleased to announce to our valued customers the new Super Clip. This 
revolutionary paper clip is made from kevlar, the bulletproof vest material used by all 
major metropolitan police forces. This new paper clip will not bend, break, or rust. Yet 
it cos.ts only pennies more than standard. paper clips. I have enclosed a sar:ip.le for 

Figure 7.12. Acme's Customers Database After Merging Entire Address with Show Field Data in Effect 

(Remember to choose the Show Field Data option in the Edit 
menu to see the data in the merged document.) 

Helpful Hint: You can change the font, style, and size of the merged fields by 
selecting fields with the cursor just as you would any other text and 
choosing the desired attributes. 

7.3.2 Printing Merged Documents 

There are two ways to print documents with merged database 
fields: as a single document with the data from one specific record, 
or as multiple documents-one for each record in the database. 
The Print command in the File menu will print only one document. 
If the Show Field Names option has been chosen from the Edit 
menu, the printed document will contain the names of the fields. If 
the Show Field Data option has been chosen from the Edit menu, 
the printed document will contain the data showing in the document 
window. Take the following steps to print a single document. 

1. Open the database and word-processing documents. 
2 . Choose the Show Field Data option in the Edit menu. 



7.3 Merging Data from the Database with the Word Processor 173 

3. Choose the database in the Window menu. Click on any field in 
the record that you want to merge. 

4. Choose the word-processing document in the Window menu. 
5. Review the document, checking to see that the merged fields 

have been selected properly, the correct record was selected, 
and the spacing and type attributes are correct. 

6. Choose Page Setup in the File menu to specify printing features. 
7. Choose Print from the File menu. 

The second printing technique uses the Print Merge command 
in the File Menu. This command will be available only when a word­
processing document has merged database fields and the database 
has been opened. This feature will print one document for each 
record in the database. For example, if Acme's Customers con­
tained 500 names, 500 letters would be printed. Note that the 
Record Selection and the Sort commands can be used in the 
database prior to Print Merge to select a subset based on certain 
criteria and to sort the data into a specific order. The printed 
documents will be merged and printed in the order of the database. 
The general steps to use the Print Merge command follow. 

1. Open the database and word-processing documents. Choose 
the database as the active window. 

2. Perform any sorting or record selection that needs to be done. 
3. Choose the word-processing document from the Window menu. 

Review the document, checking to see that the merged fields 
have been selected properly and the spacing and type attributes 
are correct. 

4. Choose Page Setup in the File menu to specify printing features. 
5. Choose Print Merge from the File menu. 

Follow these steps to Print Merge Acme's Customers with the Super 
Clip Letter. Your result: a personalized letter to each of the five 
customers in the database! 

7.3.3 Setting Up Labels 

Printing labels is similar in concept to printing form letters or 
business forms. However, more than one record is usually printed 
on a page because there are usually twelve l" x 3 1 /2" labels to each 
page. The Multiple Labels option in the Edit menu provides the 
means to print 12 labels to a page. 

One challenge in printing labels is aligning the vertical spacing 
(the number of lines on the page). Given the variety of fonts and 
sizes on the Macintosh, getting the correct number of lines to flt on 
a label is difficult. In the Spacing submenu of the Format menu is 
an option for 6 Lines per inch. This option will print six lines per 
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I mageWriter 

inch regardless of the font size selected. Therefore, you should use 
a font size of 12 points or less to avoid lines printing over each 
other. As most computer labels are exactly 1 inch apart on the 
continuous forms, five lines can be printed on each label, with a 
blank line separating each one (6 lines = 1 inch). 

An example may best explain how to print labels. Ben Biken 
needs to print price labels for each bicycle part in the Big Wheel 
Bicycle Shop's inventory. He wants to include on the label the name 
of the store, the part number, the description of the part, and its 
price. To try this out, you will need to use the Inventory database 
that you created and saved in Section 6.4. 

1. Open the Inventory database. 
2. Create a New word-processing document. 
3. Choose Page Setup from the File menu. Select Custom Size paper 

and type 12 in the Paper Height box. Select No Gaps Between 
Pages to print on continuous label forms. Remove all margins. 
(See Figure 7 .13 for an example of the Page Setup dialog box.) 

4. Choose 6 Lines per inch from the Spacing submenu in the 
Format menu, and choose Center from the Justification submenu 
in the Format menu. Set the right-margin indicator at 3.5 inches 
(the width of the label). 

Paper: O US Letter 
0 US Legal 

0 R4 Letter 
v2.7 U._! iiiiOiiiiK~I 

O International Fanfold ( Cancel ) 
O Computer Paper ® Custom Size 

Orientation Special Effects: 181 Tall Adjusted 
D 50 3 Reduction 
181 No Gaps Between Pages 

D Pr~nt Hom nnd [ olumn Nmnb(~r~ 
D Pr~n1 C(~n No h~s 

Paper Width: l.._a_.s __ __. 

Paper Height: .._I 1_2 __ __. 

Header: 

Footer: 

Left Margin: I ___ _ Right Margin: 

Top Margin: I ___ _ Bottom Margin: 

Figure 7 .13. Page Setup for Computer Labels 
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5. Type Big Wheel Bicycle Shop and press the Return key twice. 
6 . Choose Prepare to Merge and select the Catalog Number field. 

Press the Space Bar once. Choose Prepare to Merge and select 
the Description field . Press the Return key twice. 

7. Choose Bold from the Style submenu in the Format menu. 
Choose Prepare to Merge and select the Cost field. Press the 
Return key twice. Your screen should resemble Figure 7.14. 

8. Choose Select All from the Edit menu. Choose Copy from the 
Edit menu. Point and click the mouse in the empty part of the 
window below your first label. This will locate the cursor after 
the first label. 

9. Choose Paste from the Edit menu. Another label will appear 
immediately below the first one. Continue pasting labels until 
you have 12 on the page. (Stop when you see the cursor 
immediately below the page break indicator.) Press the Back­
space or Delete key to eliminate the page break indicator. 

10. Choose Multiple Labels from the Edit menu. Your completed 
label page will resemble Figure 7 .15. 

11. Put label forms into the printer and choose the Print Merge 
command. 

8530 1 Shi ma no Brakeset 

s 198.951 

Figure 7.14. Label Document After One Label Is Defined 
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Shi ma no Brakeset 

s 196.95 

Big Wheel Bicycle Shop 

B5302 Dia Compe Brakeset 

$34.95 

Big Wheel Bicycle Shop 

B5321 Campagnolo Brakeset 

s 199.00 

Big Wheel Bicycle Shop 

C601 O Campagnolo Crankset 

Figure 7.15. Label Document with Multiple Labels 

A variety of sizes of computer labels are available. They can be used 
in many creative ways with Works databases and word-processing 
documents. 

Mailing Labels. Another technique for printing labels allows the 
user to use different fonts, sizes. and styles of text on the labels. As 
mailing labels are the most common type of label printed, the 
following example will produce labels from any database with name 
and address information. 

1. Open the database. 
2 . Create a New word-processing document. 
3. Choose Page Setup from the File menu. Select Custom Paper 

and type 1 for Paper Height and 3.5 for Paper Width. Select No 
Gaps Between Pages and Tall Adjusted. Set all four margins to 
.125 (1/8 inch). Click the OK box. 

4. Using the Prepare to Merge option, select and position the fields 
for name, street address, city, state, and ZIP code. Select the 
appropriate fields and choose Font, Style, and Size as desired. 
The dotted page break line will indicate the bottom of the label, 
and the right-margin indicator will determine the right edge of 
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the label. Adjust the spacing as necessaiy to fit the fields on a 
single label. 

5. Align label forms in the printer and choose the Print Merge 
command. (Do not choose Multiple Labels from the Edit Menu!) 

7.4 POSERS, PROBLEMS, AND PROJECTS 

$1. Create 1" x 3 1/2" mailing labels for the Acme's Customer 
database. If you do not have access to computer labels, 
Print eleven I -inch labels on each page of plain computer 
paper. 

$2. Write a memo to Acme's customers describing Acme's sales 
performance over the past 3 years. Copy the pie charts 
showing Acme's market share (see Section 5.2, Problem 2) 
into your memo. 

$3. Revise the memo in Problem 2, including the data from the 
spreadsheet (see Section 4.6, Problem 4) instead of the pie 
charts. Format the data into a table that is visually attrac­
tive. 

$4. Use the memo from either Problem 2 or Problem 3 and 
merge it with the Acme's Customers database. Print out at 
least five letters. 

*5. Using the database that you created in Section 6.5, Problem 
2, print 3" x 5" cards for each of the parrots in Little Ben's 
collection. Include all the information in the database. 
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H A P T E R 

SHARING THE WEALTH 
(OF INFORMATION) 



"What hath God wrought!" 
-Samuel F. B. Morse, first telegraph message on May 24, 1844 

"I never received more than one or two letters in my life ... that were 
worth the postage." 

-Henry D. Thoreau 

"As cold waters to a thirsty soul, so is good news from a far country." 
-Proverbs, 25:25 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Define the terms modem, host, e-mail. electronic bulletin board, 
and baud (Sections 8.1.1 and 8.1.2) 

2. List the five items needed to communicate with an informa­
tion se~ce (Section 8.1.2) 

3. Define in Works the communications settings: terminal type, 
baud rate, data size, stop bits, parity, handshake, and phone 
type (Section 8.1.3) 

4. Get on-line with an information service using Works and a 
modem (Section 8.1.4) 

5. Send and capture text (Sections 8.2.1 and 8.2.2) 
6. Send and receive files (Sections 8.2.1 and 8.2.2) 

179 
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8.1 GETTING STARTED WITH COMMUNICATIONS 

Communication between a microcomputer and another computer 
can greatly expand the information resources available to you. 
From the limited data capacity of floppy diskettes to complete 
libraries stored on large mainframe systems, it can aid the traveling 
salesperson in placing orders from hotels thousands of miles from 
the home office, or it can support a dialog between two microcom­
puter owners with similar interests. This chapter explores the 
communications application of Microsoft Works and how it can be 
used to access information on remote computers. Getting actual 
practice will mean locating an information service in your own 
locale. Suggestions and sources for locating these services are 
provided in Section 8.3. 

8.1.1 A Brief Background in Data Communications 

Data communications refers to the process by which two comput­
ers pass information between themselves over telephone lines or 
cables. To transmit digital data over telephone lines, they must be 
converted into voice frequencies. When the data are received, they 
must be converted back into a digital signal for the computer to 
understand. This translation is done by a modem. On the source 
computer, the modem MODulates the electrical signal into a voice 
signal and transmits it; at its destination. another modem 
DEModulates the voice signal back into an electrical signal that can 
be interpreted by the computer. Two computers can also be directly 
connected via a cable or dedicated telephone line that is rented 
from the phone company. In such cases, modems may not be 
necessary if the distance is short (under a few thousand feet). 
Otherwise, modems must be placed at both ends of the cable. 
Figure 8.1 shows the typical Macintosh data communications 
scheme. 

In most data communications situations, the Macintosh will 
access a host computer, which is a mini- or mainframe computer 
that provides timesharing services. From a few to hundreds of 
microcomputer owners can access these services at the same time. 
Each microcomputer acts as a terminal polling information from 
the host. The range of resources available is evident from checking 
the offerings of one of the largest commercial services in the United 
States. CompuServe®. 

Electronic-Mall. Electronic-mail (also known as e-mail) is a soft­
ware program run on the host computer that allows you to write, 
edit, and send messages to others with access to the same host. 
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Telephone Line 

Macintosh to Macintosh 

Telephone Line 

Macintosh to Other Microcomputer 

Telephone Line 

Macintosh to Information Service 

Modem 

Modem 

Modem 

D 

Minicomputer 
--- or Mainframe 

Figure 8.1. Macintosh Data Communications Diagram 

Received messages can be read, printed, deleted, stored, or for­
warded to other users. Messages can also be sent to multiple users 
by using mailing lists made up by either the user or the e-mail 
manager. The advantage is instantaneous delivery of your message 
anywhere in the world. The disadvantage is that your recipient 
must access the host to learn whether any mail is waiting. But once 
users get accustomed to checking in, e-mail saves them time that 
might be spent playing phone tag or trying to coordinate schedules 
so several people can meet to share their opinions. It has another 
advantage over phone conversations, too, in allowing time for more 
reflection prior to responding. 

Bulletin Boards. An electronic bulletin board is a service via which 
you can post messages for anyone to read (as opposed to e-mail, in 
which you send a message to a specific person or group of people). 
The bulletin board can be general or limited to specific topics, such 
as Macintosh problems. Users can browse the bulletin board to 
pick up useful information, such as the location of the next Grateful 
Dead concert, or to answer someone's question about setting the 
tabs in Works. Many local bulletin boards are operated by computer 
clubs. These services are typically free and offer the beginner a 
good chance to practice. Check with the computer stores in your 
local area for information on bulletin boards. 
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Financial Information. One of the earliest uses of data communica­
tions was in the stock market field. From the comfort of your home 
or office, you can get current quotes on stocks, access fmancial 
data on a company. read current business news, manage a portfolio, 
and even buy and sell stocks 24 hours a day. Many banks now offer 
banking services for their computer-literate customers. Through 
them you can check your account balance, transfer funds, and 
even pay bills. 

Reference Information. Most university libraries and many public 
ones now have electronic card catalogs. Patrons can search by 
author, title, subject, or any key word to develop their own bibliog­
raphies. CompuSeIVe also provides electronic access to the follow­
ing reference materials: Academic American Encyclopedia, Con­
sumer Reports, Dissertation Abstracts, Who's Who, Books in Print, 
and Book Review Digest. 

News. Several news services (Executive News Service, Associated 
Press Online, McGraw-Hill News Snapshot, OTC NewsAlert, and 
others) provide up-to-the-minute information on major news sto­
ries, sports, and weather. You can thus search news databases for 
specific information, eliminating the necessity of reading through 
several newspapers. News articles can be transferred from the host 
to your computer for future reference. 

Recreation, Entertainment, and Travel. Users can play games with 
other users, exchange information with hobbyists, research and 
make airline, hotel, and rental car reseivations, or visit an elec­
tronic shopping mall to purchase merchandise. Some well-known 
companies offering electronic catalogs and ordering are Sears, 
Spiegel, Waldenbooks, and Ford Motor Company. 

Unfortunately, access to these services is not usually free. Basic 
hourly rates are charged, with additional surcharges for special 
services such as stock quotes. In addition, long-distance phone 
charges may apply if a toll-free telephone number is not available in 
your area. Despite the costs, the access to information may well be 
worth the investment. 

8.1.2 What You Need to Communicate 

It should be obvious by now that you will need a modem connected 
to your Macintosh. A variety of modems are available, at prices 
starting below $100. The cost of the modem primarily depends on 
its transmission speed, or baud rate. The baud rate is the number 
of bits per second in which data are transmitted over the telephone 
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line. As there are 8 to 10 bits per character depending on the 
transmission protocol, a 1200-baud modem will transmit approxi­
mately 120 to 150 characters per second. Most common are 1200-
baud modems, though 300-baud and 2400-baud modems are 
available for regular phone lines. Higher baud rates can be used 
with direct cables or leased telephone lines. 

In addition to a modem, you will need a telephone line with a 
modular phone jack accessible to your Macintosh. This jack, known 
as an RJ 11 jack, is the standard method of connecting telephones 
in the United States. You will also need communications software 
such as Microsoft Works and the phone number for an information 
service such as CompuServe, a university library, or a user group 
bulletin board. Many of these services give an account number and 
password to each authorized user. The password protects your 
account from unauthorized access, so you won't be charged for 
others' use. 

8.1.3 Defining the Settings 

Once you have acquired a modem, phone line, and account number, 
you are ready to begin-almost. Unfortunately, there are different 
standards for transmitting data between computers. These trans­
mission protocols are like a handshake between visiting dignitar­
ies. Your Macintosh must greet the host computer in a language 
and ritual that it understands. Consequently, you must define 
what the communications settings are for each host computer that 
you wish to access. 

1. Start up the Macintosh using the Works Startup and Program 
diskettes. (Remember how? See Section 1.4.1 if you need help.) 

2. If the Works window is not visible on the screen, open the 
Works Program disk icon (see Section 1.4.3). 

3. Start Microsoft Works by selecting the Works icon (point and 
click) and choosing Open from the File menu. 

Short Cut: Click twice on the Works icon. 

4. The Works desktop should appear. Select Communications by 
pointing to the icon and clicking. Create a new document by 
pointing to and clicking on the New button. 

5. The Communications Settings dialog box will appear on the 
screen (see Figure 8.2). 

When you get an account number from the information ser­
vice, you will also get a list of the handshake settings. The Com­
munications Settings dialog box in Works allows you to define the 
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Communications Settings: 

Type: @TTY 0 UT-100 0 UT-52 

Baud Rate: O 300 O 2400 O 9600 
® 1200 0 4800 019200 

Delete Key Means: 

O Delete 
Data Size: @ 8 Bits 

Stop Bits: @ 1 Bit 

Parity: @None 

Handshake: QNone 

01 Bits 

0 2 Bits 

QOdd 

®Backspace 

Number of screens: Ll 
OEuen 

®Hon/Hoff O Hardware OBoth 

Phone Type: ®Touch-Tone® O Rotary Dial 

Line Delay: l•I Character Delay: @=] 
181 Capture TeHt When Document Opens 

Connect To: ®~O~ ( Cancel ) U~[ iiiiiiOiiiiiKiiiiiiiiiiiii") 

Figure 8.2. Communications Settings Dialog Box 

appropriate settings. The most commonly used settings are de­
scribed briefly below. 

Type. In Works you can emulate, or make your Macintosh work 
like, three types of terminals: TIY, VTlOO, and VT52. The most 
commonly used terminal type is VTlOO, because it has more 
advanced features than the other types. 

Baud Rate. Choose the appropriate data transmission rate: 300, 
1200, 2400, 4800, 9600, or 19200 baud. This rate must be consistent 
with the modem and information service you are using. In other 
words, you cannot transmit at 2400 baud if you have a 1200-baud 
modem. Likewise, a 1200-baud information service cannot receive 
your 2400-baud transmission, nor can a 1200-baud modem com­
municate with Works if the settings are set for 2400 baud. 

Data Size. This refers to the number of data bits transmitted per 
character of information. It can be either seven or eight. 
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Stop Bits. The stop bits identify the end of each character trans­
mitted. There are either one or two stop bits. 

Parity. Because data can get garbled in transmission through 
telephone line interference, some information services use a "parity" 
bit to check for transmission errors. Parity can be Even, Odd, or 
None. 

Handshake. The handshaking protocol determines how the host 
computer and the user's computer know whose tum it is to send or 
receive data. The handshaking can be done through hardware or 
software. Normally it is done with software, using the Xon/Xoff 
protocol. 

Phone Type. Two types of dialing systems are used in the United 
States: rotary dial and touch tone. Check with your telephone 
company if you are not sure of the type used in your area. 

In addition to the transmission protocol settings, several special 
features can be chosen from the Communications Setting dialog 
box. The Capture Text When Document Opens option will auto­
matically store your communications session in a file on your hard 
disk or floppy diskette. This file can be used by the word processor 
to review or extract information at a later date. The Connect To 
option allows you to define where the modem is connected on your 
Macintosh: to the telephone port or the printer port. The Number of 
screens option allows you to select how many screens of data will 
be kept in memory during your session. These screens can be 
retrieved by scrolling the communications window. 

Helpful Hint: The communications settings can be redefined by choosing the 
Settings command from the Communications menu. 

8.1.4 Getting On-line 

In order to get on-line to the information service, you will have to 
dial the appropriate phone number from the Works phone book. 
Here's how to do it. 

1. Make sure your modem is turned on and connected to the 
phone line. 

2. Choose the Dial command from the Communications menu. 
The phone book will appear on the screen (see Figure 8.3). 

3. Type the name of the information service and press the Tab key. 
4. Type the appropriate phone number. Include area codes, access 

codes, or billing codes. 
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( Oh~l) 

loh~n 

( Oinl) 

( Oil~U 

( Oh~l) 

(Dint) 

( Oinl) 

( Oil~f) 

Name: Phone Number: 

( C1mcel ) I~( iiiiiiiOiiiiiiiK___,J 

Figure 8.3. Communications Phone Book 

5. Click the Dial button next to the information service that you 
want. The message Dialing ... will be displayed on the screen 
and you will hear the modem dialing if it has a speaker. 

6. When you are on-line, the message CONNECT will be displayed 
in the communications window. 'fype the commands necessary 
to gain access to the information service that you are using. 
This process, known as logging on. validates your use of the 
service. Follow the directions provided by the information service. 

Short Cut: You can save the communications settings and the phone book so 
that you don't have to redefine the settings and reenter the phone 
number each time you want to get on-line. Do it like this. 

1. Open a communications document. 
2. Choose Settings from the Communications menu, define your 

settings. and click the OK button. 
3. Choose Dial from the Communications menu, type in the phone 

number(s). and click the OK button. 
4. Choose the Save As command in the File menu. Give the file a 

name appropriate to the service. 

When you want to use that service. open the me. choose the Dial 
command, and click the appropriate Dial button. 



8.1 Getting Started with Communications 187 

Helpful Hint #1: If, after you log on to the information service, you see two charac­
ters on the screen instead of one (HHEELLOO, for example), choose 
Echo Off from the Communications menu. If you see no characters 
on the screen when you type, choose the Echo On command from 
the Communications menu. 

Helpful Hint #2: Many information services use some keys that do not appear on the 
Macintosh keyboard. The following key sequences can be used with 
Works to transmit the equivalent keys. 

Break Command ( ~) + Option + 3 
Delete Command ( ~) + Option + Delete 
Escape Command ( ~) + Option + [ 

Whenever the information service requires a control key sequence 
(Control+ C, for example), hold down the Command key(~), si­
multaneously pressing the other key. 

Helpful Hint #3: The Keypad menu provides a VT52 or VTlOO terminal keypad (see 
Figure 8.4). Use the mouse with this keypad to type special codes 
when using either of these terminal emulations. 

Figure 8.4. The Keypad Menu 

Here is a step-by-step account of the process of accessing the 
CompuServe information service. 

1. Turn on your modem. 
2. Open a New communications document. 
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3. Define the settings (CompuServe uses 7 data bits, 1 stop bit, 
and even parity). 

4. Enter the phone number listed for your area in the CompuServe 
directory. 

5. Click the Dial button. 
6. When the connection has been made, type Command ( ~) + C. 
7. When the message USER ID appears in the window, type your 

CompuServe ID number and press the Return key. 
8. When the message PASSWORD appears in the window, type 

your CompuServe password and press the Return key. As a 
security precaution, the password will not appear on the screen 
as you type it. 

When you are finished communicating with the host computer, 
you must log off. For example, type OFF when quitting CompuServe. 
After you have logged off, choose Hang Up from the Communica­
tions menu. This will disconnect the modem from the host computer. 
It is important to note that hanging up alone does not log you off 
the host. You should log off and then hang up to properly end a 
session and reduce your cost. 

8.2 SENDING AND RECEIVING INFORMATION 

Once you become experienced in using information services, you 
will eventually want to send or receive large amounts of data. 
Perhaps you wish to write a long letter to a friend using e-mail. You 
can write the letter in the Works word processor and send the text 
rather than typing the text in an e-mail session. Not only will this 
allow you to edit your text easily, but it will cost less because Works 
can send text faster than you can type it. Or perhaps you want to 
share a spreadsheet or database with an associate in another city. 
Using Works you can send or receive a file between two Macintoshes, 
a Macintosh and another (non-Macintosh) microcomputer, or a 
Macintosh and an information service. 

8.2.1 Sending Information 

Two commands send information in the Works communications 
application: Send Text and Send Files. Both are found in the 
Communications menu. Use the Send Text option when you want 
to send text just as if you typed it on-line. Use the Send File option 
when you want to send a ftle such as a formatted word-processing 
document, a spreadsheet with graphs, or a database with reports. 
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Send Text 
1. Using the word processor, enter the text and save the file. (Make 

sure that the diskette with the file on it is ln the Macintosh disk 
drive when you're ready to send it.) 

2. Access the receiving computer and enter any necessary com­
mands to get to the point at which you wish to substitute text 
for typing. 

3. Choose Send Text from the Communications menu. The Send 
Text dialog box will be displayed (see Figure 8.5). 

4. From the list, select the file that contains the text to be sent and 
click the Send button. The text will be printed on the screen as 
it is transmitted to the receiving computer. 

Send Te1n: 

.I lg) Michelle's Data I 
D Sculley's Quotation ~ 

Figure 8.5. Send Text Dialog Box 

Send File 

(g} Michelle' •.. 

[ Eject ] 

( Driue ) 

( Send ) 

( Cancel ] 

1. Make sure that the diskette with the file on it is ln the Macin­
tosh disk drive when you're ready to send it. 

2. Access the receiving computer and enter any necessary com­
mands to prepare it to receive the ft.le. 

3. Choose Send File from the Communications menu. The Send 
File dialog box will be displayed (see Figure 8.6). 

4. From the list, select the file to be sent. 
5. Select a protocol option. 
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Send File: 

I lg} Michelle's Data I 
D Desktop ~ 
Cl I nuentory 
Cl My Dictionary 
Cl Payroll Ledger 
Cl Personal Budget 
Cl Sauings Recount 
Cl Sculley's Quotation 

Send Protocol: ® MacBinary 

lg} Michelle' ... 

Eject 

Driue 

Send 

Cancel 

O Hmodem TeHt (Insert LF Hfter CR) 
O Hmodem Data 

Figure 8.6. Send File Dialog Box 

Helpful Hint: If you are sending a Macintosh file to another Macintosh, use the 
MacBinary protocol. If you are sending a ftle with alphanumeric 
characters and no formatting information (an ASCII or text-only 
file) from a Macintosh to another computer, select the Xmodem 
Text protocol. If you are sending a formatted file from a Macintosh 
to another computer, use the Xmodem Data protocol. 

6. Click the Send button. The ftle will be sent to the receiving 
computer. Works will print a message when the transmission is 
complete. 

8.2.2 Receiving Information 

There are also two ways of receiving information in the Works 
communications application: Capture Text and Receive File. Both 
options are found in the Communications menu. Use the Capture 
Text option when you want to save a complete copy of your on-line 
session. Works will capture everything you type and everything the 
host computer prints on your screen. Use the Receive File option 
when you only want to receive a word-processing document, a 
spreadsheet, or a database. 
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I (g] Michelle's Data I 
D l rw(~n1 or~J 
D M~J m( t~onan.~ 
D P<l~_won l.•~di.~•~r 
D Pel~onalBudget 
D Sauini.~S fl( C(mn1 

Saue Captured TeHt Rs: 

Captured TeHt 

( Capture ) ( Cancel ) 

Figure 8.7. Capture Text Dialog Box 

Capture Text 

(g] Michelle's D. 

( Eject ) 

( Driue ) 

1. Access the sending computer and start your communications 
session. 

2. When you wish to capture text, choose Capture Text from the 
Communications menu. The Capture Text dialog box will be 
displayed (see Figure 8. 7). 

3. Type the name of the file in which the text will be saved and 
click the Capture button. 

4. When you are finished capturing text, choose the End Text 
Capture command from the Communications menu. No more 
text will be saved in the file, but your communications session 
will continue. 

Short Cut: To automatically save your entire communications session, click 
the Capture Text When Document Opens box in the Settings dialog 
box before accessing the host computer. 

Receive File 
I. Make sure that the diskette with the file on it ts in the Macin­

tosh disk drive when you're ready to receive it. 
2. Access the sending computer and enter any necessary com­

mands to receive the file. 
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Receiue Protocol: 

Figure 8.8. Receive File Dialog Box 

® MacBinary 
O Hmodem TeHt (Remoue LF) 
O Hmodem Data 

3. Choose Receive File from the Communications menu. The Re­
ceive File dialog box will be displayed (see Figure 8.8). 

4. fype the name of the file to be saved on your computer. 
5. Select a protocol option. 

Helpful Hint: If you are receiving a Macintosh file from another Macintosh or an 
information service, use the MacBinary protocol. If you are receiv­
ing a file with alphanumeric characters and no formatting infor­
mation (an ASCII or text-only file) from another computer, select 
the Xmodem Text protocol. If you are receiving a formatted file from 
another computer, use the Xmodem Data protocol. 

6. Click the Receive button. Works will print a message when the 
transmission is complete. 
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8.3 POSERS, PROBLEMS, AND PROJECTS 

*l. Find out if your university library has an on-line card catalog 
system accessible by modem. Research the appropriate com­
munications settings and phone number. Using Works, log on 
to the system and do a subject search on Macintosh. If your 
university library has an on-line card catalog but you don't 
have access to a modem, visit the library and learn how to use 
the card catalog terminals. Do the same search. 

*2. Find out the local phone number for CompuSeive. Following 
the step-by-step instructions in Section 8.1.4, attempt to log 
on to CompuSeive with Works and a modem. (You will not be 
able to log on completely without an account number and 
password. However, you can practice defining the settings, 
dialing the modem, and connecting with a host.) 

3. Research the appropriate communications settings and phone 
number for a free local user group bulletin board. Using 
Works, log on to the system and browse. 

4. If neither a modem nor an information seIVice is available to 
you, you can simulate logging on to an on-line card catalog by 
"launching"-that is, opening-the file LUCI Simulation on the 
diskette that came with this text. This file requires HyperCard; 
Appendix J describes the exercise in detail. 
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"Journalism consists of producing headlines against deadlines." 
-Anonymous 

"Some books are to be tasted, others to be swallowed, and some few to 
be chewed and digested: that is, some books are read only in parts, 
others to be read, but not curiously, and some few to be read wholly, and 
with diligence and attention." 

-Francis Bacon 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Create text columns, resize them, and reposition them on the 
page as desired (Section 9.1.1) 

2. Link two or more text columns and flow text into them (Sec­
tion 9.1.2) 

3. Paste text from a word processor document into text columns 
in another document (Section 9.1.3) 

4. Add heads, borders, boxes, rules, and shading to a page 
layout (Section 9.2.1) 

5. Add an illustration to a page layout (Section 9.2.2) 
6. Use laser fonts and print a document on the Apple Laser­

Writer (Sections 9.3.1 and 9.3.2) 
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9.1 DESKTOP PUBLISHING WITH WORKS 

Desktop publishing (DTP) is the art of designing and producing 
camera-ready copy with the assistance of a microcomputer. This 
area of microcomputer applications is growing rapidly: market 
analysts predict that the already $I -billion desktop publishing 
industry will increase fivefold over the next 2 years. The reason is 
quite simple: every business needs to publish. 

Before desktop publishing was available, businesses wanting 
to publish a newsletter to be mailed to their customers embarked 
on a time-consuming process involving many professionals. After 
the articles were written, the copy was sent to a typesetting ser­
vice to be formatted into columns using the desired type fonts. 
Headlines also had to be typeset and fit to the proper column 
width. Graphic artists were hired to illustrate the articles. The 
illustrations had to be photographically reduced or enlarged to flt 
the space available. Finally, a layout artist took the typeset ar­
ticles and illustrations and pasted them onto a master that was 
photographed and printed. Throughout the process, proof copies 
of the articles, illustrations, and layout were sent back .and forth 
between the typesetter, illustrator, graphic artist, and the busi­
nesses' executives for approval. This process took time, person­
nel, and money. 

Desktop publishing allows both large and small businesses to 
be their own publishing company. Articles can be typed into the 
word processor by in-house writers; illustrations can be pur­
chased on diskette or drawn with graphics software by employees; 
and pasteup can be done electronically on the computer screen. 
The camera-ready master can be printed on a laser printer for a 
typeset appearance and sent to the printer. Once the copy is 
written, the entire production process can be reduced to a few 
hours with an experienced staff. Some large companies have their 
own desktop publishing and printing departments, so the entire 
process is done in-house. 

The Macintosh lends itself to DTP applications because of its 
WYSIWYG features. Several high-quality page layout packages, 
such as PageMaker®, QuarkXPress®, and ReadySetGo®, are avail­
able for the Macintosh. These packages are used by companies 
such as the one that publishes USA Today to design advertise­
ments, articles, books, pamphlets, flyers, and so on. Microsoft 
Works contains some of the features of page layout software but 
is not practical for production DTP applications. This chapter will 
provide a simple introduction to desktop publishing by exploring 
the features Works does offer. 
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9.1.1 Entering Text in Columns 

One of the piimary requirements of desktop publishing is to fit 
multiple columns of text on a page. For example, your morning 
newspaper probably has as many as six columns of text wrapped 
around photographs and illustrations. The Works word processor 
creates these text columns using the Draw Tools. 

1. Start up Works and create a new word-processing document. 
(See Section 2.2.3 if you need help.) 

2. Choose the Draw On command from the Edit menu. 
3 . Select the Text Tool from the drawing Tool Box (see Figure 3.4). 

The cursor will change to an I-bar cursor (I). 
4. Position the cursor where you want the upper left-hand corner 

of the text column to be. 
5. Hold down the Option key and the mouse button while dragging 

the cursor. A rectangle with dashed lines will appear on the 
screen. When the mouse button is released, the text column 
will be defined and the heading Col 1 Link None will appear at 
the top (see Figure 9.1). 

s File Edit Window Format Fill Pattern Line Pattern Macro 

-o Untitled (WP) BJ-
l~ii iii]~iiliiil~iiliiil~iiliiil~iiliiil~iiliiil~iililQ. 
Tools ~ 

~ D 
~o 
"'-. 0 
_) G. 
+ """') 
Fill . 

a 
••• + ... 
11111 ..... 

.. l;.9LUjn~J!Q_l:l.L _____________ ______ , 
! 
I 
I 
i 

I 
: 
I 
! 

----------------------------------------· I 

Figure 9.1. Creating a Text Column 
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.... 

11111 

Text can only be typed into a text column using the Text Tool 
with Draw On. Section 3.2 describes the way Works treats text as 
an object. It would be wise to review that section before continuing 
if you are not familiar with using the Text Tool. 

Once a text column is defmed, text can be typed into the 
column or pasted into the column from the Clipboard. The text will 
conform to the width of the column and take on the properties of 
the column: the font, size, style, and justification. If there is more 
text than the column can hold, the additional text will extend below 
the bottom of the column (see Figure 9.2). The text can be short­
ened by editing with the features described in Section 3.2.2, or the 
text column can be expanded in width or length. 

1. Using the Pointer Tool Cl\). select the text column. Handles will 
appear in the comers and along the sides of the column. 

i-QU_Jiit~-~-QNJ __ =---------------------~ 
iit has been said that New OrleaniaN 
! don't eat to 1i ve but rather 1i ve to 
! eat. There are more fine restaurants 
!here th.an anywhere in the country 
!and the service is always excellent. 
! (Competition is the reason. As 
!tocals eat out-and frequently- the 
Qrestaurants must cater to more than ~ 
! tourists if they want to stay in 
!business .) 
I 
I 
I 

! Dining out is an entire evening's 
!pastime. Dinner can easily take 3 
! hours or more, and you will never be 
!rushed. 11ost establishments 
~e<iuire-e:«>aliiana-:aes-iina·------------G 
reservstiortS. Bon Appetit! """' 

Handles can be used to 
resize the text column. 

If there is too much tex1, it will 
extend below the text column. 

Figure 9.2. Entering Text into Text Column 
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2. With the Pointer Tool, click on a handle and drag to resize the 
text column. (See Figure 3.5 and Section 3.1.3 to review sizing 
an object.) 

3. The text will automatically fill the resized column. 

Sometimes there is no additional room on the page to resize the 
column and/ or no text can be deleted. But if the point size of the 
letters is changed, more text will fit into the column. 

1. Using the Pointer Tool, select the text column. 
2. Choose the Size command from the Format menu. The Size 

submenu will appear on the screen. 
3. Choose the desired text size from the submenu. 

The font, style, and justification of text can also determine the 
amount that will fit into a column. These options can be changed in 
the same way as you altered the text size. 

Helpful Hint: Text pasted into a text column from the Clipboard will have the 
same font, size, and style of the text in the source document. It will, 
however, take on the justification of the text column once it is 
pasted. To force the pasted text to conform to the text column's 
properties, hold down the Option key while pasting the text from 
the Clipboard. 

9.1.2 Flowing Text: Linking Columns 

Another way of dealing with more text than a column can hold is to 
create a second text column and flow the text from the first column 
to the second. Newspapers do this frequently to continue articles 
onto other pages. In Works you must create two or more columns 
and then link them. The columns do not have to be adjacent or even 
on the same page. However, they must be in the same document. 
To flow text into additional columns, follow these steps. 

I. Create two or more columns using the procedure outlined in 
the last section. 

2. Choose the Pointer Tool from the Tool Box. 
3. Hold down the Option key while selecting each text column in 

the order that the text is to be flowed. The column headings will 
indicate the links. If there is sufficient text, it will flow into the 
columns (see Figure 9.3). 

9.1.3 All the News That Fits Will Print 
(A Newsletter Example) 

To learn the techniques of desktop publishing, in this chapter 
you'll design and print a newsletter describing some of the many 
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• 

Column heading indicates linkage. 

i-PlJ_1iit~-i---•------------------n 
!It has been said that New ! 
I Or1eard.afl8 don't eat to 1i ve but ! 
I I 

!rather 1ive to eat. There are 1 
lmore fine restaurants here ! 
I I 

!than anywhere in the country I 
! and the service is a1 ways ! 
!exoe11ent. (Competition is the ! 
6'.reason. As 1ooals eat out-and n 
!trequentl y-the restaurants 
! rrwst oater to more than 
I 

I tourists if they want to stay in 
! business.) 
I 
I 
I 

f-QL?..-~iD.k-~Qfil---------------n 
I easily take 3 hours or more, ! 
I and you wi11 :never be rushed. I 
! Host establishments require 
I coats and ties and 
lreserwtiofl8. Bon Appetit! 
I 
I 

I 
I 
I 

¥ 

i 1111 
! DiN.r&g out is an entire 
!everd.r&g's pastime. Dinner oan 
~-----------------·-----------------.. a.----------------·----------------41 

A 

Figure 9.3. Linking Text Columns 

restaurants in New Orleans. The diskette that came with this 
book contains two files titled New Orleans Text and New Orleans 
Art. They contain an article and artwork you'll use in preparing 
·the newsletter. If you are curious about how the completed news­
letter will appear, look ahead to Figure 9.10. 

Helpful Hint: If you do not have handy the diskette that came with this book, the 
text for the article appears in Figure 9.4. Open a new word­
processing document, enter the text, and save the document as 
New Orleans Text. The text must be in the New York font with a size 
of 9 points for your newsletter to match the figures in the remain­
der of this chapter. 

The first task in designing your New Orleans restaurant guide 
is to create several text columns, link them, and paste the desired 
text into the columns. The remaining sections of this chapter will 
use the restaurant guide to demonstrate how to add borders, 
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It has been said that New Orleanians don't eat to live but rather live to eat. There are more fine 
restaurants here than anywhere in the country and the service is always excellent. (Competition 
is the reason. As locals eat out-and frequently-the restaurants must cater to more than tourists 
if they want to stay in business.) 

Dining out is an entire evening's pastime. Dinner can easily take 3 hours or more, and you will 
never be rushed. Most establishments require coats and ties and reservations. Bon Appetit! 

[About the ratings: *is poor;***** is excellent;$ is cheap;$$ is moderate; and$$$ is expensive.] 

*****Andrea's. If you like Northern Italian food (it always reminds me of San Francisco), 
Andrea's is the place for you. It has been awarded five stars by many of the world's best food 
critics. If you ask Roberto, the Maitre d' and co-owner, for a bottle of peach champagne, he will be 
sure to give you a good table and great service. $$$ 

**** Brightson's. This excellent Uptown restaurant is owned by the understudy of Paul 
Prudhomme. I think he's surpassed his mentor. $$$ 

** Cafe Du Monde. This French Quarter coffeehouse is located across from Jackson Square. It is 
famous for beignets, New Orleans-style doughnuts. Great for late-night sobering up in the 
Quarter. $ 

** Camellia Grill. This famous grill is right out of the 40s. No tables here, only counter service. 
They also serve no liquor. But the food is great ... sandwiches, burgers, fries, onion rings, 
homemade pies, and chocolate freezes. This is one of many late-night spots frequented by locals. 
No reservations are taken: expect to wait at any time, day or night. Easily reached via the St. 
Charles streetcar. $ 

** Central Grocery. If you like sandwiches, try the Central Grocery, home of the muffaletta. Hard 
to describe, the muffaletta is very Italian. Central Grocery has been operated by the same family 
for over 100 years and is located across from the French Market. Take-out only. $ 

*****Commander's Palace. One of the most famous Creole restaurants in New Orleans, 
Commander's has a big local following. The food is always good, the service excellent, and the 
rooms crowded. Be sure to make a reservation. $$$ 

****Mr. B's. There are lots of French Quarter restaurants, but Mr. B's is one of my favorites. Try 
the duck! $$$ 

Figure 9.4. Example Newsletter Article 



202 Chapter 9 Publish or Perish! 

drawings, and headlines and how to prtnt out the fmal product on a 
laser prtnter. The detailed steps that follow will guide you through 
the first part. 

1. Create a new word-processing document. 
2. Press the Return key repeatedly until a dashed line appears, 

indicating the end of the page (see Figure 9 .5). As our newslet­
ter is one page long and will be designed entirely with the 
Draw Tools, it is necessary to fill the page with blank lines. For 
a four-page document, you would fill four pages with blank 
lines. 

1 

End-of-page marker 

Figure 9.5. End-of-Page Marker 

3. Scroll the window to the top of the page. Choose Draw On from 
the Edit menu. The drawing Tool Box will appear on the 
screen. Select the Text Tool. 
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4. Create a text column starting approximately 2 inches from the 
top and extending to the end-of-page marker by holding down 
the Option key while clicking and dragging the cursor. The 
text column should begin at the left margin (0 on the ruler) 
and end at the 3 1/8-inch mark on the ruler. If you do not 
draw the text column to the correct size on the first tcy, select 
the Pointer Tool, select the text column, and drag at its 
handles to get it to the correct size and location. 

5. Create a second text column adjacent to the first. Column 2 
should begin approximately at the 3 3/8-inch mark on the 
ruler and extend to the right margin (at 6 1 /2 inches.) The top 
of Column 2 should be aligned with the top of Column 1, but it 
should only extend down 2 1 /2 inches. This will leave room for 
a drawing. 

6. Create a third text column about 2 inches below Column 2. It 
should be the same width and extend to the end-of-page 
marker. 

7. Link all three columns. Holding down the Option key, click on 
Column 1, Column 2, and then Column 3. Your page should 
resemble Figure 9.6. 

8. Choose the Open command in the File menu. Select the file 
titled New Orleans Text. 

~. Choose Select All from the Edit menu. The text will be high­
lighted. Choose Copy from the Edit menu. Bring the restau­
rant guide window into view by choosing Untitled (WP) from 
the Window menu. 

10. Select the Text Tool and click inside Column 1. A cursor 
should blink in the upper left-hand comer of Column 1. 
Choose Paste from the Edit menu. The text will appear in 
Column 1. Select the Pointer Tool and the text will flow into 
Column 2 and Column 3. 

11. Using the Pointer Tool, adjust with the handles until the text 
in your columns looks like Figure 9.7. 

If this process seems somewhat tedious, remember that Works is 
not a true DTP program. This process is much easier in a program 
such as PageMaker. 

Helpful Hint: If you wish to remove from view the dashed lines around the text 
columns, choose Show Column Boxes from the Format menu. 
This will give you a better idea of what the printed page will look 
like. 
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·-------------------------------------------------------- r-------------------------------------------------------

Figure 9.6. Restaurant Guide Text Columns 

,.-------------------------------------------------------
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i 
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I 
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!it-~-;-i;;;~-;~i"d-t-,;t-ii;;-c,~i-;;;-~;;-d~;t;-;~-t--

1 to 1i w but rather 1i w to eat. There are more 
j fine restaarents here than anywhere in the 
I coantry and the service is al wsys excellent. 
I (Competition is the reason. As locals eat 
j oat-and frequent! y-t:he restaurants must cater 
I to more than toarists i1 they wsnt to stay in 
!business.) 
I 
I 
I 

I Di:l:'li:ng out is an entire ew:l:'li:ng's pastime. 
I DiN'ler can easily take 3 ti.oars or more, and 
j yoa will never be rushed. Host 
I establishments require coats and ties and 
lreserwtiot'IB. Bon Appetit! 
I 
I 

hAbout the ratitiga: • is poor; ••••• is 
!excellent;$ is cheap;$$ is moderate; and$$$ 
I is expet'IBi w .] 
I 
I 

!••H• Andrea's. If you like Northern Italian 
!food. (it alwsys reminds m.e of San Francisco), 
!Andrea's is the place for you. It has been 
jawsrded five stars by many of t:he world's best 
!food critics. If yoa ask Roberto, the Haitre d' 
j and co-ow:ner, for a bottle of peach c:h.ampap, 
j :he will be sure to gj w yoa a good table and 
I gx-eat service. $$$ 
I 
!•••• Brigl\tson's. This excellent Uptown 
!restaurant is ow:ned by the understady of Paul 
!Prudhomme. I think :he's surpassed his 
I mentor. $$$ 
I 
I 

! •• Cafe Du Honde. This Fre:nch Quarter 
!coffeehouse :is located across from Jackson 
jsquare. It is famous for beipts, New 
I Orleat'IB-style doughtu.cts. Great for late-:l:'light 
lsoberi:ng up in the Quarter. $ 
I . 
I 

i •• Camellia Grill. This famous gx"i11 is right 
I oat of the 4 Os. No tables :here, 01'11 y counter 
I 

L--------------------------------------------------------· 
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r--------------------------------------------------------
1 service. They also serve rio liquor. But t:he 
I food :is gx-eat ... sand wic:hes, burgers, fries, 
j o:l:'lion ritiga, homemade pies, and chocolate 
j freezes. This :is one of many late-:l:'light spots 
! freqaented by locals. No reserwtiot'IB are 
j taken: expect to wsi t at any time, day or :l:'light. 
I Basil y reached via the St. Charles streetcar. $ 
I 
I 

j•• Central Grocery. If you like sari.dwic:hes, try 
I the Central Grocery, home of the m.tdfaletta. 
I Hard to describe, the m.affaletta is wry 
jitalian. Central Grocery has been operated by 
jt:he same family for over 100 years ari.d is 
! located across from the French Harket. 
!Take-out oruy. $ 
I !.--------------------------------------------------------

r-------------------------------------------------------• 
I 
! ••••• Commander's Palace. Orie of the m.ost 
!famous Creole restaurants in New Orleat'IB, 
!Comm.sri.der's has a big local followi:ng. The 
jtood is al wsys good, the service excellent, art.d 
! the rooms crowded. Be sure to make a 
jreserwtion. $$$ 
I 
I 

!••••Hr. B's. There are lots of Fre:nch Quarter 
!restaurants, but Hr. B's is one of my 
I favor:i. tes. Try the duck! $$$ 
I '--------------------------------------------------------· 

Figure 9.7. Restaurant Guide with Text Flowed into Linked Columns 
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9.2 ADDING GRAPHICS 

One way that graphic artists make an impact with a printed page is 
to use large text, borders, lines, boxes, shading, pictures, and 
drawings. It is amazing what a single drawing or a shaded column 
of text will do for an otherwise plain page of text. The location of the 
graphics and the use of areas devoid of text or graphics, called 
white space, also contribute to the impact of the page. If you want 
more information on page layout and designing effective pages, 
many helpful books on the topic are available in the Computers 
section of most bookstores. 

9.2.1 Heads, Borders, Boxes, Rules, and Shading 

The Tool Box provides the tools necessary to create heads, bor­
ders, boxes, and rules (or lines). Chapter 3 contains detailed in­
structions on using each of the Draw Tools. Heads or headlines 
can be added to the page using the Text Tool to create text 
objects. Once the head is typed in, the size, font, style, and justifi­
cation of the text can be set. The head can be resized, reposi­
tioned, or otherwise edited until it looks on the screen the way you 
want it to look on paper. 

A variety of options is available to the desktop publisher. A 
simple box drawn around text or another object will set it off from 
the rest of the page. A box made up of two rules-one bolder than 
the other-is even more effective. Try using rounded corners or 
drawing a box around the entire page. Vertical rules between 
columns separate the text, making it easier to read. 

Shading can be accomplished in two ways. Select a text col­
umn using the Pointer Tool. Choose the desired shading from the 
Fill Pattern menu. The text in the t~xt column will be printed on a 
shaded background. A second method to shade a portion of the 
text in a text column (a single paragraph, for instance) uses the 
Rectangle Tool. Draw a rectangle around the paragraph to be 
shaded. Choose the desired shading from the Fill Pattern menu 
and the desired border from the Line Pattern menu. Finally, 
choose Send to Back from the Format menu to place the shaded 
box behind the text. For fun, try all these features of Works after 
creating a new document. Figure 9.8 shows some ideas for special 
effects using the Draw Tools. 

The following instructions will add a head, several lines, and a 
box to the design of your restaurant guide. 

1. Select the Text Tool from the Tool Box. Choose New York from 
the Font submenu. Choose 24 Point from the Size submenu. 



Example of a 
Sha~ded Text 

·umn to 
phasize 

Important 
Information 

Figure 9.8. Borders, Boxes, Rules, and Shading 
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Example of 
a Double 
Box with 
Rounded 
Corners 

~ ....-:: 

Various Types of Rules 

Choose Center from the Justification submenu. Click the Text 
Tool at the top center of the page. Type New Orleans and press 
the Return key. Type Restaurant Guide. Select the Pointer Tool 
and position the head to match to Figure 9.9. 

2. Select the Straight Line Tool and draw a vertical rule between 
the left and right columns. Use the smallest line thickness and 
draw the line the full length of Column 1. 

3. Again using the Straight Line Tool, draw a line from the left to 
the right margin just above Column 1 and Column 2. Above this 
draw a second line, slightly thicker than the first. 

4. Select the Rectangle Tool and the smallest line thickness. Draw 
a rectangle in the empty space between Columns 2 and 3. You 
will place a drawing in this location later. Again, compare your 
page with Figure 9 .9. 
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New Orleans 
Restaurant Guide 

It has been said that New Orleamat'IS don't eat 
to live but rather live to eat. There are more 
fine restaurants here than anywhere in the 
country and the service is always excellent. 
{Com.petition is the reason. As locals eat 
out-and frequently-the restaurants must cater 
to more than tourists if they want to stay in 
business.) 

Dimttg out is an entire evemttg's pastime. 
DiN"&er can easily take 3 :hours or more, al\4 
you wi1111ever be rushed. Host 
establishments require coats al\4 ties al\4 
reservatiot'IS. Bon Appetit! 

[About the rati~: • is poor; ••••• is 
excellent;$ is cheap;$$ is moderate; and$$$ 
is expeNi ve .] 

••••• Ari4rea's. 11 you like Northern Italian 
food (it always remiri4s me of San Frartaisco), 
Ari4rea's is the place for you. It has been 
awarded five stars by many of the world's best 
food critics. If you ask Roberto, the Haitre d' 
al\4 co-owner, for a bottle of peach champagne, 
he will be sure to give you a good table aNI 
great service. $$$ 

•••• Brightson's. This excellent Uptown 
restaurant is owned :by the uri4erstud y of Paul 
Prad:homm.e. I thi:nk he's surpassed his 
mentor. $$$ 

•• Cafe Du Hori4e. This Frert0h Quarter 
co11ee:house is located across from. Jackson 
Square. It is famous for beigrt.ets, New 
Orleat'IB-style doug,Nwts. Great for late-mg.ht 
soberittg up in the Quarter. $ 

•• Camellia Grill. This famous grill is right 
·out of the 4 Os. No tables here, o:nl y counter 

service. They also serve flO liquor. But the 
food is great ... sa:ndwiches, burgers, fries, 
omon ri~, :homemade pies, a:nd chocolate 
freezes. This is one of many late-mg.ht spots 
frequented by locals. No reservatiot'IB are 
taken: expect to wait at any time, day or mght. 
Easily reached via the St. Charles streetcar. $ 

••Central Grocery. 11 you like sa:ndwiches, try 
the Central Grocery, :home of the rmdfaletta. 
Hard to describe, the muffaletta is very 
Italian. Central Grocery has been operated by 
the same family tor over 1 O O years ad is 
located across from. the Frertah Harket. 
Take-oat o:nly. $ 

••••• Comm.a:nder's Palace. 011e of the most 
famous Creole restaurants in New OrleaNJ, 
Comm.a:nder's has a big local followittg. The 
food is always good, the service excellent, ad 
the rooms crowded. Be sure to make a 
reservation. $$$ 

•••• Hr. B's. There are lots of Frert0h Quarter 
reistaurari.ts, but Hr. B's is one of m.y 
fsvori tes. Try the duck! $$$ 

Figure 9.9. Restaurant Guide with Head, Rules, and Box Added 
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9.2.2 Pictures and Drawings 

Photographs and illustrations make text interesting and improve 
comprehension. However, the Macintosh user is not limited to the 
draw features of Works to illustrate a document. The Mac has the 
ability to copy illustrations from a large number of draw and paint 
programs and paste them into Works or other DTP software pack­
ages. In addition to do-it-yourself graphics packages, ready-made 
commercial art is available on diskettes. These clip art disks con­
tain a variety of illustrations for typical newsletter applications. To 
use the clip art diskettes, you will need a paint program like 
MacPaint or SuperPaint. The clip art is usually saved on the 
diskette in MacPaint files. The files can be opened and the art 
selected, copied to the Clipboard, and pasted into your Works word 
processor document. 

Photographs can also be added to Works documents, using 
special hardware and software. An optical scanner is a device that 
converts a drawing or photograph into dots corresponding to the 
resolution of the Macintosh screen or laser printer. Photographs 
can thus be scanned and saved on diskette. Once saved, the 
digitized photograph can be added to your document in the same 
manner as clip art. 

On the diskette that came with this book is a clip art file titled 
New Orleans Art. 1\vo clip art drawings have previously been trans­
ferred from a MacPaint file to a Works file so that they can be used 
in the restaurant guide. Follow the steps below to add the illustra­
tions. 

1. Choose Open from the File menu. Select the New Orleans Art 
file. 

2. Choose Draw On from the Edit menu. Select the Pointer Tool. 
3. Click on the alligator drawing. Choose Copy from the Edit 

menu. 
4. Bring the restaurant guide window into view using the Window 

menu. 
5. Choose Paste from the Edit menu. The alligator will appear on 

the screen. Drag the drawing to its desired location (see Figure 
9.10). 

6. Repeat Steps 1 through 5, copying the saxophone drawing from 
the same file into your restaurant guide. Refer to Figure 9.10 for 
positioning. 

Helpful Hint: Illustrations can easily be adjusted to fit the available space. Using 
the Pointer Tool, click on and drag any of the illustration's handles. 



210 Chapter 9 Publish or Perish I 

New Orleans 
Restaurant Guide 

It has been said that New Orleanians don' t eat 
to live but rather live to eat. There are more 
fine restaurants here than anywhere in the 
country and the service is always excellent. 
(Competition is the reason. As locals eat 
out-and frequently-the restaurants must cater 
to more than tourists if they want to stay in 
business.) 

Dining out is an entire evening's pastime. 
Dinner can easily take 3 hours or more, and 
you will never be rushed. Most 
establishments require coats and ties and 
reservations. Bon Appetit! 

[About the ratings: * is poor; ***** is 
excellent; $ is cheap; $$ is moderate; and $$$ 
is expensive.] 

*****Andrea's. If you like Northern Italian 
food (it always reminds me of San Francisco), 
Andrea's is the place for you. It has been 
awarded five stars by many of the world's best 
food critics. If you ask Roberto, the Maltre d ' 
and co-owner, for a bottle of peach champagne, 
he will be sure to give you a good table and 
great service. $$$ 

**** Brightson's. This excellent Uptown 
restaurant is owned by the understudy of Paul 
Prudhomme. I think he's surpassed his 
mentor. $$$ 

** Cafe Du Monde. This French Quarter 
coffeehouse is located across from Jackson 
Square. It is famous for beignets, New 
Orleans-style doughnuts. Great for late-night 
sobering up in the Quarter. $ 

**Camellia Grill . This famous grill is right 
out of the 40s. No tables here, only counter 

Figure 9.10. Completed Restaurant Guide 

service. They also serve no liquor. But the 
food is great . .. sandwiches, burgers, fries, 
onion rings, homemade pies, and chocolate 
freezes. This is one of many late-night spots 
frequented by locals. No reservations are 
taken: expect to wait at any time, day or night. 
Easily reached via the St. Charles streetcar. $ 

** Central Grocery. If you like sandwiches, try 
the Central Grocery, home of the muffaletta. 
Hard to describe, the muffaletta is very 
Italian. Central Grocery has been operated by 
the same family for over JOO years and is 
located across from the French Market. 
Take-out only. $ 

*****Commander's Palace. One of the most 
famous Creole restaurants in New Orleans, 
Commander's has a big local following. The 
food is always good, the service excellent, and 
the rooms crowded. Be sure to make a 
reservation. $$$ 

**** Mr. B's. There are lots of French Quarter 
restaurants, but Mr. B's is one of my 
favorites. Try the duck! $$$ 
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9.3 LASER PRINTING 

The Apple LaserWriter printer is commonly used in place of the 
ImageWriter printer for desktop publishing. The ImageWriter is a 
dot matrix printer that prints documents suitable for personal 
correspondence, internal documents, and schoolwork. The 
ImageWriter LQ printer is also a dot matrix printer, but it over­
prints the image so that letter-quality text is produced. The 
LaserWriter contains a built-in Macintosh computer that controls 
a copy machine engine. The built-in computer converts the data 
sent to the printer from the user's Macintosh and creates an 
electrostatic image of each page on the printing drum with a laser. 
The drum picks up dry ink and transfers it to plain paper. The 
result is high-quality text and drawings resembling the output 
from expensive typesetting machines. 

The ImageWriter and the Macintosh screen print with a reso­
lution of 72 dots per inch. The LaserWriter prints 300 dots per 
inch. which is suitable for many publications. If higher quality is 
necessary, the Macintosh can interface with Linotronic® and 
Compugraphic® typesetters having resolutions of 1,240 to 2, 7 40 
dots per inch. Many typesetting services now offer high-resolution 
printing from a customer's Macintosh diskettes. Figure 9.11 com­
pares the output from an ImageWriter and a LaserWriter. 

This text was printed 
on the Apple lmageWriter in 

Geneva font. 

This text was printed 
on the Apple ImageWriter 

in New York font. 

This text was printed 
on the Apple LaserWriter 

in Helvetica font. 

This text was printed 
on the Apple LaserWriter 

in Times font. 
Figure 9.11. Comparison of lmageWriter and LaserWriter Printing 



212 Chapter 9 Publish or Perish! 

9.3.1 How to Use Laser Fonts 

Two different types of fonts are used on the Macintosh: screen fonts 
and laser fonts. Thus far you have been exposed to screen fonts 
only. Screen fonts were designed for the 72-dots-per-inch resolu­
tion of both the Macintosh screen and ImageWriter printer. Conse­
quently, they print with ragged edges on the higher-resolution 
LaserWriter. Common screen fonts are Chicago, Geneva, London, 
Monaco, New York, and Venice. 

Laser fonts are designed to be used with Apple LaserWriter 
printers. The edges of these fonts print cleanly and crisply, even 
when they are blown up to vei:y large sizes. They should be used 
when the best-quality printing is needed on the LaserWriter. Laser 
fonts should not be used on the ImageWriter, for the same reason 
that ImageWriter fonts should not be used on the LaserWriter­
poor print quality. 

There are two types of laser fonts: built-in and down-loaded. 
The built-in fonts are stored in ROM in the LaserWriter. Down­
loaded fonts are stored on the Macintosh, an external hard disk, or 
a CD ROM (compact disc read-only memory) attached to the printer. 
A down-loaded font is transferred to the printer only when that font 
is needed. Common built-in laser fonts are Courier, Helvetica, New 
Century Schoolbook, Symbol, Times, and Zapf Chancery. 

Laser fonts are used the same way as screen fonts. Choose the 
desired font from the Font submenu of the Format menu. What if 
there are no laser fonts in the submenu? Then the laser fonts have 
not been installed in the system folder of your start-up disk. You 
can do this by using the Font/DA Mover program found on the 
Macintosh Utilities Disk 2 to copy the laser fonts into the system 
folder. Detailed instructions for this process can be found in the 
Macintosh Utilities User's Guide published by Apple Computer. The 
user's guide and utilities disk are shipped with every Macintosh. 

Helpful Hint: A laser font and a screen font of the same size will have different 
character spacing. For this reason you should choose a laser font 
from the Font submenu before you enter the text, if you are pre­
paring a word-processing document to be printed on a laser printer 
and want to see on the screen what you will get on the printer. If a 
laser font is not available in the Font submenu, the LaserWriter will 
substitute another laser font. This option is controlled by the Page 
Setup dialog box and will be described in the next section. If font 
substitution is selected, the laser font Helvetica is substituted for 
the screen font Geneva, Times for New York, and Courier for 
Monaco. 
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9.3.2 Printing on the Apple LaserWriter 

Printing on the LaserWriter is similar to printing on the ImageWriter. 
The frrst step is to select the LaserWriter, using the Chooser desk 
accessory in the Apple menu. The next step is to choose Page Setup 
from the File menu. The LaserWriter Page Setup dialog box will 
appear. 

At the top of the Page Setup dialog box (see Figure 9.12), you 
will find the Paper options. The most commonly used paper options 
are US Letter and US Legal. When you click on these options, the 
Paper Width and Paper Height will automatically be set for 8 1 /2 x 
11 inches and 8 1/2 x 14 inches, respectively. Tabloid is one-half 
the size of a standard newspaper page, or approximately 11 x 14 
inches. A4 Letter and B5 Letter are international mail sizes that are 
rarely used. 

The Orientation option allows you to print vertically or horizon­
tally (this is called landscape on some computers) on the paper. The 
Reduce or Enlarge option allows you to enter a percentage of 
reduction or enlargement. At 50 percent your document prints at 
half its width and half its height (one-quarter of its normal size): 

=L=as=e=r=W=r=it=e=r=P=a=g=e=S=e=t=u=p=======================s.=2==( OK D 
Paper: ® US Letter O H4 Letter O Tabloid .. .. 

O US Legal O 85 Letter ( Cancel ) 

Reduce or jllmil% 
Enlarge: 

Orient a ti on 

Printer Effects: 
181 Font Substitution? 
181 TeHt Smoothing? 
181 Graphics Smoothing? 
181 Faster Bitmap Printing? 

(Options) 

Help 

D Pr~n t Hom ~md [ ohmrn Nmnb<ff~ 

Header: 

Footer: 

Left Margin: _j 1 __ __ Right Margin: _I 1 __ __ 

Top Margin: _I 1 __ __ Bottom Margin: 1_1 __ _ 

Figure 9.12. LaserWriter Page Setup Dialog Box 
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200 percent prints your document at twice its width and twice its 
height (four times its normal size). Same size is 100 percent. 

The Printer Effects include Font Substitution, Text Smoothing, 
Graphics Smoothing, and Faster Bitmap Printing. Normally you 
will want to select all of these options. Clicking the Options button 
will display a dialog box with additional options such as Flip 
Horizontal, Flip Vertical, and Invert Image. The Help button will 
display a dialog box that explains the printer effects and the 
additional options. 

The Header and Footer boxes are used to enter text that will be 
printed within the top (header) and bottom (footer) margin. These 
are normally used for the page number, document title, date, and 
so on. The text entered into the Header and Footer boxes will be 
printed on every page. Consequently, footers should not be used for 
footnotes. (Section 2.4. 7 describes how to enter page numbers.) 

At the bottom of the Page Setup dialog box are options for 
setting the printing margins. You can enter the left, right, top, and 
bottom margin distances in inches. Do not confuse them with the 
margins that you set in the ruler. These are the printer paper 
margins. If your left Page Setup margin is at 1 inch and your ruler 
left margin is at 0 inches, your text will be printed 1 inch from the 
left side of the paper. If your right Page Setup margin is at 1 inch, 
your right ruler margin should be set at 6 1 /2 inches ( 1 inch left 
margin+ 6 1/2 inches of text+ 1 inch right margin= 8 1/2-inch 
paper width). The top and bottom margins will determine how 
many lines of text will be printed on the page. 

To print a document on the LaserWriter, follow these steps. 

1. Tum on the LaserWriter. After it has warmed up, a test page 
will be printed. You must wait until the test page is printed 
before continuing. 

2. Select Print from the File menu. The LaserWriter printing dialog 
box (see Figure 9.13) should appear on the screen. 

LaserWriter "LaserWriter" Il D ===============================================s=.2=== ~K 
Copies:l•I Pages:® Hll 0 From: CJ To: CJ ( Cancel ] 

Couer Page: ® No O First Page 0 Last Page ( Help ) 

Paper Source:® Paper Cassette O Manual Feed 

D Print Preuiew 

Figure 9.13. LaserWriter Print Dialog Box 
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3. Enter the number of copies desired or a specific range of page 
numbers if you do not want to print the entire document. 

4. Select either Paper Cassette or Manual Feed. 
5. Point to and click on the OK button. and your document will be 

printed. If you wish to stop the printing. hold down the Com­
mand (~)key and simultaneously press the Period(.) key. 

9.4 POSERS, PROBLEMS, AND PROJECTS 

1. Print your New Orleans Restaurant Guide on a laser printer. 
$2. Art Klepp is the chief designer in Acme Paper Clip's art 

department. He has been asked to work with Sidney 
Celmour, the marketing director, to design and develop a 
catalog sheet that not only has a detailed drawing of Acme's 
new Super Clip but also describes its virtues. 

Help out Art and Sidney by designing an advertisement 
for Acme's Super Clip. Use the Super Clip drawing that you 
saved in Section 3.3.l and the Acme logo that you drew in 
Section 3.3.2. Write copy that convinces customers to buy 
the new Super Clip. Combine this material using the Works 
DTP features. Print the ad using a laser printer if one is 
available. 

3. Using Works, develop a newsletter for a school, church, or 
community organization or for a business. 
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H A P T E R 

A SYSTEMS APPROACH 
TO MICROCOMPUTER 

PROBLEM SOLVING 



"The trouble with not having a goal is that you can spend your life 
running up and down the field and never scoring." 

-Bill Copeland 

"It takes less time to do a thing right than to explain why you did it 
wrong." 

-H. W. Longfellow 

"Garbage in, garbage out." 
-Anonymous 

OBJECTIVES 

When you've completed this chapter, you'll be able to do the 
following. 

1. Identify the steps of a systems approach to the design of a 
microcomputer solution (Section 10.1) 

2. Outline a rationale, a set of performance objectives, and a 
sequence of events for a microcomputer solution (Section 
10.2) 

3. Identify the developmental steps of the systems approach 
(Section 10.3) 

4. Design and develop microcomputer solutions using Microsoft 
Works on the Macintosh and the information discussed in 
Chapters 1 through 9 

217 
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10.1 WHAT ARE YOUR INTENTIONS? 

The working knowledge of Microsoft Works and the Macintosh that 
you have gained in the previous chapters will take you only a small 
step toward using the computer as a productivity tool and actually 
employing microcomputer software to solve problems. In fact, 
problem solving using computer applications is often done by 
persons with no computing experience whatsoever! In these cases, 
the solution analysis (or design) is passed on to a computer expert 
(who often knows very little about the specific field) to develop a 
microcomputer software application. The chosen software and 
process are tested, refined, and eventually put to use in a real-life 
situation. Thus the key to the development of valid microcomputer 
solutions rests initially in their design. 

The design-and-development process can be expedited if both 
designer and developer have more than a casual awareness of the 
other's area of expertise. In the past it was unusual for the designer 
and developer to be the same person, with expertise in both com­
puters and a given application area. Very few people were highly 
proficient in software techniques and strategies. Likewise. few 
computer experts knew the intricacies of accounting. finance, 
banking, real estate, and so on. The wide acceptance and use of 
microcomputers is bringing about a gradual change. however. 
More and more students and workers are gaining computer literacy 
in addition to their area of expertise. This combined knowledge will 
increase the use of a medium for problem solving that literally is at 
our fingertips. 

Design! If you're like most of us, you probably think you've 
never designed anything. But if you've ever wanted anything at all 
that you eventually created through your own efforts. you have in 
fact experienced the design process. The process is really common 
to most people, and it has a fringe benefit: It makes us think 
logically and creatively. That is. the procedure-from the identifi­
cation of an objective to its attainment-breaks down into a series 
of steps. 

10.1.1 The Systems Approach 

One approach to using microcomputers for problem solving is to 
apply the process used in the overall development of computer 
software. Although this process is known by several names. and its 
steps may differ slightly among versions, it may be summarized in 
the following ten steps. 
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1. Statement of the rationale for use 
2. Statement of the performance objectives 
3. Defmition of the sequence of events 
4. Application software construction 
5. Debugging 
6. Pilot testing 
7. Revision 
8. Use in a real-life situation 
9. Further revision 

10. Evaluation 

These steps comprise a process often called a systems approach to 
software design. But as it does involve logic. another name for it 
might be a commonsense approach to problem solving. 

10.2 THE DESIGN PROCESS 

The frrst three steps constitute the design stage, which will be 
discussed in this section. The next seven steps, the developmental 
stage, will be discussed in Section 10.3. Note that, though all these 
steps are important, the contents of each are determined solely by 
the specific problem requiring a microcomputer solution. In other 
words, the steps and general procedures for each can be outlined in 
this book, but the reason behind any given solution-what is done 
and how it is done-can only be determined by its designer. To 
illustrate how the systems approach can be used in problem solving, 
we'll develop an example using the Acme Paper Clip Company. 

10.2.1 The Rationale 

Assume you have a problem that you suspect might be solved by 
the design and development of microcomputer software. Can you 
explain why this problem should be solved in the frrst place? Can 
you explain why a microcomputer should be used? In other words, 
your rationale answers why: Why does the problem need solving, 
and why use a computer in the solution process? If either question 
cannot be answered, the design stage should be terminated. 

10.2.2 Performance Objectives 

To make sure you get to where you want to go, you must set 
objectives. Performance objectives should outline the prerequi­
sites for a solution, what will comprise the solution itself, and, 
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specifically, what constitutes the successful completion of the 
solution. That is, what do you expect before, during, and after you 
use the microcomputer? What are the goals of the microcomputer 
application and how will you know when those goals are attained? 

Here are some examples of performance objectives. 

1. The application will merge a mailing list of up to 4,000 names 
with a letter. The salutation will use the first name ("Dear 
Mary"). The letters will be printed in ZIP code order and ad­
dressed appropriately for mailing in window envelopes. 

2. The spreadsheet will compute an estimated monthly loan pay­
ment to within a .2 percent accuracy. based on the bank's 
mainframe computers. 

3. Data will be collected from at least 98 percent of the stores and 
entered into the database application by 5:00 P.M. every Friday. 
Sales reports will be printed and distributed by 11 :00 A.M. the 
following Monday. 

10.2.3 The Sequence of Events 

This design step is probably the most difficult. Obviously, the 
sequence of events is determined in part by the type of application 
(word processing, spreadsheet, database, communications, graph­
ics, and so on) used. This in turn is determined by your rationale 
and objectives. Regardless of the type of application you've chosen, 
this step should include, at a minimum, answers to such questions 
as the following. 

1. Is any process necessary prior to using the microcomputer? Is 
any material or information specifically related to the solution 
needed prior to using the microcomputer? If so, what is the 
process, who will perform it, when will it be completed, and 
what will it provide? 

2. What data are required for the microcomputer application? 
Must the information be entered into the microcomputer in a 
specific order? 

3. Will the information be reorganized once it's entered? What 
sorting criterion will be used? 

4. Will all the information be used, or will selections be made? 
What selection criteria will be used? 

5. What formatting options should be chosen? What font, style, 
size, and justification will be used? Are graphics to be included? 

6. What printed reports will be generated and how will they be 
printed? Will a dot matrix or a laser printer be used? What type 
of paper will they print on? 
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7. How and where will the files be saved? Will the files be updated 
in the future? Will back-up copies be maintained? 

8. What problems are anticipated? What are the contingency 
plans, should something go wrong? 

9. Are multiple application programs needed? How will the data be 
integrated between the applications? In what order must the 
applications be executed? 

Answers to these and perhaps many other questions, depending on 
the design, must be outlined on paper prior to translating the se­
quence into spreadsheet, database, or other computer applications. 

Most importantly, as you design the application you must 
outline each sequential step necessary from the beginning to the 
end of the process. Think of the total sequence of events necessary 
to complete the process. 

10.2.4 Designing a Solution for 
the Acme Paper Clip Company 

Suppose the Acme Paper Clip Company needed to mail each stock­
holder notification of its quarterly dividend and wished to illustrate 
in the letter its percentage of the market share in 1990. Here's how 
the systems approach could be applied to design a solution to this 
problem. 

Rationale. Acme Paper Clip Company, like all publicly owned 
companies, is required by federal law to notify stockholders of 
quarterly dividends. The advantage of using the computer in this 
process is that it can quickly print customized letters to each 
stockholder. With the aid of computer software, the letter can 
combine the required dividend notification with a pie chart showing 
the percentage of market share. This may encourage stockholders 
to purchase additional stock. 

Performance Objectives. The microcomputer solution will merge a 
database of Acme's shareholders with a word-processing document 
containing the dividend notification and a pie chart showing the 
1990 percentage of market share. The letters must be pririted and 
mailed within the time limitations set by federal law. 

Sequence of Events. The following sequence of events generally 
outlines the process necessary to solve Acme's problem. A written 
sequence of events can be as general as this one or more specific, 
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including instructions on how to accomplish each event. The level 
of detail will depend on the user's needs. 

1. Up-to-date stockholder information, including name, street 
address, city, state, and ZIP code is obtained from the company's 
accountants. 

2. A Microsoft Works database is designed and developed, using 
the five fields identified in Event 1. 

3. The stockholder information is entered into the database and 
saved. 

4. Data on the 1990 percentage of market share are entered into 
a Works spreadsheet and saved. 

5. A letter is composed and typed using the Works word processor. 
6. A pie chart is drawn based on the market share data ln the 

spreadsheet. 
7. The pie chart is copied from the spreadsheet application into 

the letter in the word processor. 
8. The database is sorted into ZIP code order. 
9. The name, street address, city, state. and ZIP code fields are 

added to the letter in the word processor using the Prepare to 
Merge command. These fields are aligned to show the address 
through a window envelope, so mailing labels needn't be 
generated. 

10. Using the Print Merge command, the database is merged with 
the letter in the word processor printing a customized notifica­
tion letter for each stockholder. 

11. In ZIP code order, each letter is folded and inserted in envelopes 
so that the address shows through the window. 

12. The letters are maned. 

10.3 THE DEVELOPMENTAL PROCESS 

The design segment. the first three steps of the systems approach, 
is essentially a mental, paper-and-pencil process. Once the rationale. 
objectives. and sequence of events have been defined. the remain­
ing developmental steps-the actual application of microcomputer 
software, debugging. testing. refinement. use, and evaluation­
may be carried out. 

The total process, from rationale to evaluation, for a micro­
computer solution may require tens to hundreds of person hours. 
This would include the development of any accompanying training 
materials for the user's guidance. Of course, if an existing solution 
were used as a model and simply adapted to a user's specific needs, 
the time required for development would be significantly reduced. 
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10.3.1 Application Software Construction 

Actually the next step is still a mental, paper-and-pencil process for 
the most part. It primarily involves translating the sequence of 
events into computer software such as spreadsheets, databases, 
and integrated documents. This is the first step in which some 
degree of computer expertise is required of the designer. Microcom­
puter software techniques and strategies must be used in trans­
ferring the design concepts from paper to microcomputer files. This 
may be as trivial as adapting a model spreadsheet or as involved 
and time-consuming as translating an original, detailed design into 
a comprehensive database. 

10.3.2 Debugging 

Even after the spreadsheet, database, or other application has been 
designed, the data entered, and the files saved, chances are that 
the solution will not work as expected. Problems, commonly called 
bugs in "computerese," may emerge: anything from simple errors 
(misspelled words, syntax errors, and so on) to technical or con­
ceptual errors (incorrect use of a formula, sorting on the wrong 
field, incorrect selection of criteria, and so on). Debugging (exter­
mination of the errors) is then done until the software is satisfactory 
from the designer's point of view. 

10.3.3 Pilot Testing 

Pilot testing the solution is the next step. Generally this is done 
with "dummy" data-or with colleagues' and volunteers' work, if 
persons other than the designer will use the software in real life. 
Ideally, the designer should literally look over their shoulders as 
others perform the process on the microcomputer, as it is a rare 
case in which something unanticipated does not occur. These 
problems may be as trivial as the user inadvertently typing a 
comma that the spreadsheet is not designed to handle. Alternatively, 
a major reworking of the conceptual and/ or procedural strategy 
may be required. Of course, the main point of pilot testing is for the 
designer to get feedback about the solution. 

10.3.4 Revision 

The feedback provided during pilot testing frequently leads to 
revisions. These revisions are normally fairly minor: redefining the 
text format, making cosmetic improvements to the layout, and so 
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on. However, they could be as major as returning to the design 
stage for refinement of the process or, in extreme cases, discarding 
the application. (If the design steps are thought out carefully, this 
probably will not be necessary!) Note that the pilot testing and 
revision steps may be repeated several times prior to actually using 
the application. 

10.3.5 Use in an Actual Situation and Further Revision 

Using the microcomputer solution in a real-life situation may 
supplement a manual process, serve as a prerequisite to another 
microcomputer application, or comprise the only step left to a 
successful solution. Regardless of the application it is safest to 
anticipate continued minor revision of the materials, if for no other 
reason than that the number of users testing the software or seeing 
the output will have increased. In some applications, the software 
will never get to a point at which no additional revisions (however 
minor) are needed. Thus, use in real-life situations and revision are 
cyclical, continuing as long as the application is in use. 

10.3.6 Evaluation 

The evaluation of microcomputer solutions may be divided into two 
categories. The first is an analysis of objective attainment, to 
determine whether the defined objectives are indeed being met. 
This analysis varies depending on the design of the solution, but it 
is often based on preapplication and postapplicatlon results. If 
negative results are obtained, a return to Step 1 of the systems 
approach may be appropriate. 

The second evaluation is the analysis of the concept of using 
the microcomputer and the software. Did this approach prove 
suitable in solving the problem? This question is answered in part 
by the analysis of objective attainment. Further evaluation may be 
based on customer or employee feedback through attitudinal 
questionnaires, overall software performance, and the designer's 
own observation and intuition. 

Note: In general, the success or failure of any given microcom­
puter solution rests heavily on the first three design steps: the 
importance of thoughtful design merits emphasis one last time. If 
the rationale, objectives, and sequence of events are very carefully 
defined, the likelihood of a successful solution is greatly increased. 
In other words, think it through, folks! 
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10.3. 7 The Developmental Process 
for Acme's Stockholder Letter 

To achieve a solution to Acme's need to notify stockholders, follow 
the developmental process of the systems approach by completing 
the stages outlined here. Little benefit will be gained from just 
reading the material that follows. Actually completing the project 
on the computer will help you understand the process and let you 
practice the skills you learned in previous chapters. 

Application Software Construction. Using the sequence of events 
detailed in Section 10.2.4, design and develop the Acme stockholder 
database, the notification letter, the market share spreadsheet, and 
the pie chart. Sample stockholder data are provided in Figure 10. 1. 
The text for the notification letter appears in Figure 10.2. The data 

;o Acme's Stockholders (DB) BJ 
Name lStreet Address lCity 1 State ]Zip J ~ 
Robert Morris ! 8820 Edinburgh St. ! Cupertino ! CA ! 9501 4 l ~ H ......................................................... : ................................................................. : ................................................. : ................... : ......................... :. 
Danie 1 Nob le i 111 Veter ans Blvd. i Washington i DC i 20036 i mm; 

1--1-........................................................ : ................................................................. : ................................................. : ................... :······· .................. :·:::::: 

Mary Pearson i 6050 Curr an Dr. i Boston i MA i 0216 7 i i:i!ii 
H ........................................................ +···· .. ······· ................................................... ; ................................................ +·················+····· ................... ;. !!!:;: 

Carrie Potter i 393 Bellaire Dr. i Buff a lo i NY i 14208 i mm 
H ......................................................... ; ................................................................. ; ................................................. ; ................... ; ......................... ;.::!:!: 

Tommy Rosen !6919 Colbert St. !Omaha !NE !68178 i mm H ......................................................... ; ................................................................. ; ................................................. ; ................... ; ......................... ;.::!:!: 

Stacie Sanford i 1 901 Per dido Way ! Spokane ! WA ! 99258 i mm H ......................................................... :··· .............................................................. : ................................................. : ................... : ......................... :·:::::: 
Cheryl Kitt i5004 Tartan Dr. !Baltimore !MD !21210 i !!!iii 

1--1 ......................................................... : ................................................................. ; ................................................. ; .................. .;. ....................... + l!i!i! 
Leonard Hughes !3717 Cypress Ave. jlos Angeles !CA j90045 ! Hiiii H ......................................................... : ................................................................. : ................................................. : ................... : ......................... :·:::::: 
Curtis Green i 1830 Franklin Ave. !Chicago ill !60626 i iiiiil H ......................................................... ! ................................................................. ; ................................................. ; ................... ; ......................... !·l!l!l! 
Olga Fletcher i 112 27th St. i Denver i CO i 80221 i iiliii 

H ......................................................... ; ................................................................ +···························· .. ················ .. ; ................... ; ........................ .;.;:!:!: 
John Vincent !111 Mark Twain Dr. iSanta Clara !CA i95053 i ii!iii 

1--1 ......................................................... : ................................................................. : ................................................. : ................... ; ......................... :.:::::: 

Tiffany Duran !407 Josephine Way !Mobile i AL j36608 j mm 
H"""""'"'"""""''''"''""""""""""""':""'""""'••oo•OOOOOOOOO"""""""""'""•'""'"""'l""'"""""'"'""""'•"""""""'"'""":"""""""""""""""'"':••oo••oo•••"""••""":':l:l;! 

Scott Davis i 3618 Nashville Ave. i PM lade lpMa i PA i 1 91 31 i iliili 
1--1 ....... .-............................................... : ................................................................. : ................................................. ; .................. .;. ....................... .;. !:!:!: 

Lisa Cherry i816 Sumner Ave. !Detroit iMI 148221 i ililii H ......................................................... ; ................................................................. : ................................................. : ................... ; ......................... ;.;:!:!: 
Grace Becker i2008 Kentucky Pkwy. iSan Francisco jCA j94117 i mm 

H ......................................................... :········· ........................................................ : ................................................. : ... ················:·· ....................... :·:;:!:! 
Carl Waddell 1217 Dodge Ct. !Scranton iPA i 18510 i iiliii 

l--l••••n•••••••••u•oono••n•"'''""""'"''""'"""'"!••••"•••••••••••••••••••••••••••••n•••"''''"'''''"''"'"'"i""""'''''''''''"'""""''''''''''"'''''''!•••••••••,.•••••••+"••••••••••••H•"""+ !:!:!: 
Brenda Stein i 551 0 Holly Lane i Whee ling i WV l 26007 i ii!li! H ......................................................... : ................................................................. : ................................................. : ................... : ......................... :.:::::: 
Sidney Schwartz i2016 2nd Ave. !Cincinnati iOH i45207 i i!i!i! 

H ......................................................... ; ................................................................. : ................................................. ; ................... ; ......................... ;.!!l!l! 

H ·t~~.~~h·~·ii~:r..~.~~-~ ................... l·~·~·6·~9f ~·1:!-?. .. ~.~ ............................. l·~·~~·~~·~ .. ~1i~·· .. ··········· .. ·····l·~ii·· .. ····· .. ·l·~If ·¥·6 ........ +~ 
I ~ 
Figure 10.1. Acme's Stockholder Database 
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June 1, 1991 

Dear Stockholder: 

I am pleased to announce that the Acme Paper Clip 
Company is issuing a dividend of $1.23 per share for the 
first quarter of 1991. This is a 230 percent increase over 
the dividend for the same quarter in 1990. I attribute our 
increase in profits to an increase in the market share. 
The following chart depicts Acme's percentage of market 
share in 1990. 

I also wish to point out that we have recently introduced a 
new Kevlar unbreakable paper clip. If our marketing 
efforts are successful for this product, I am sure that we 
will achieve an even larger share of the market. 

Yours truly, 

Emily Acme 
President 

Figure 10.2. Text for Acme's Stockholder Letter 

for the spreadsheet appear in Section 4.6, Problem 4, and help in 
producing the pie chart can be found in Section 5.2, Problem 2. The 
completed stockholder letter should resemble Figure 10.3. 

Debugging. As you design and enter the letter, database, and 
spreadsheet, correct your errors. After the files are complete, check 
again for errors and make any necessary corrections. 

Piiot Testing. Having completed Steps 1 through 9 in the sequence 
of events, you can now pilot test Step 10, the Print Merge process. 
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~©!1ilil® 1¥>©1f)®ll ©OD!?) ©©!1ilillf)©l1ilW 
123 Main Street 

June 1, 1991 

Robert Morris 
8820 Edinburgh St. 
Cupertino, CA 95014 

Dear Stockholder: 

Los Angeles, California 90001 

I am pleased to announce that the Acme Paper Clip Company is issuing a dividend of $1.23 per 
share for the first quarter of 1991 . This is a 230 percent increase over the dividend for the same 
quarter in 1990. I attribute our increase in profits to an increase in the market share. The 
following chart depicts Acme's percentage of market share in 1990. 

1990 Percentage of Market Share 

• Acme Paper Clip 50.9% 
'3 United Plastics 15.3% 
II Mitsubishi Paper Clip 25.3% 
r;J A.O.S. Paper Clip 8.6% 

I also wish to point out that we have recently introduced a new Kevlar unbreakable paper clip. If 
our marketing efforts are as successful for this product, I am sure that we will achieve an even 
larger share of the market. 

Yours truly, 

Emily Acme 
President 

Figure 10.3. Acme's Stockholder Letter 



228 Chapter 1 O A Systems Approach to Microcomputer Problem Solving 

Choose the Print Preview option in the Print dialog box and review 
the merge operation on the screen. Test your printer by using the 
Print (not the Print Merge) command. A single letter will be printed 
rather than one for every entry in the database. Better yet, do a 
Record Selection just for the stockholders who live in California. 
Use the Print Merge command to test the process. 

Revision. If any errors are discovered during pilot testing, make 
the necessary revision and pilot test again. 

Use In a Real-life Situation. With the software construction, de­
bugging, testing, and revision completed, use the Print Merge 
command and print out a letter for each of Acme's Stockholders. 
(For this example, you can skip Steps 11 and 12.) 

Further Revision. If any other errors are noted, revise and Print 
Merge again. 

Evaluation. Ask yourself the following questions. Were the defined 
objectives attained? Was the notification letter successfully gener­
ated? Was it completed on time? Did stockholders buy more stock? 
Did using the Macintosh and Microsoft Works prove suitable in 
solving the problem? As you can see, though the answers to some 
of these questions may be obvious, others may require additional 
research and testing. Based on your evaluation, should Acme 
continue to use this process each quarter to notify stockholders? 

10.4 A FINAL PROJECT 

As a final project, demonstrate your skills in using the Macintosh 
and Microsoft Works to provide a solution to a real problem. 
Identify a problem in an area of interest to you. It could relate to 
another college course, to your hobby, to your job or profession, 
or to your favorite charity, community group, or church. What­
ever the problem, you will learn more if its solution has some 
practical value to you. 

Design and develop an application that integrates at least 
three of the Works features (word processing, spreadsheet, data­
base, communications, graphics, and desktop publishing). 

• Outline on paper the rationale, performance objectives, and 
sequence of events. 
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• Follow the developmental steps: construct the software, debug 
it, pilot test it, revise it, use it in an actual situation, and revise 
it further. 

• Evaluate on paper the success of applying Works and the 
Macintosh to the solution of your problem. 
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SUMMARY OF 
WORD PROCESSOR 

COMMANDS 

A.1 THE FILE MENU 

New ... 

New ••• 
Open ••• 380 

Close 38W 
Close Rll .•• 
Saue HS 
Saue Rs ••• 
Delete ••• 

Make Works Desktop •.. 

Page Setup ••• 
Print... HP 
Print Window 
Eject Page 
Print Merge ••• 

Quit HQ 

Creates a New file of any Works application type. A dialog box lets 
you select word-processing, database, spreadsheet, or communi­
cations files. 

231 
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Open ... 
Opens an existing word-processing file to be edited or added to. A 
dialog box lets you select files and disks. 

Close 
Closes the active file window. If the file has been changed but not 
saved, a warning and an option for saving the file will appear in a 
dialog box. 

Close All ... 
Closes all the file windows. For each file that has been changed but 
not saved, a warning and an option for saving the file will appear in 
a dialog box. 

Save 
Saves the active file window. If the file is untitled, a dialog box 
requires that a file name be entered and provides options for 
changing disks. If the file has been named previously, the edited 
file will be saved over the original file with the same file name. 

Save As ... 
Saves an edited file with a new file name. The original file is kept 
intact. A dialog box allows you to enter the new file name and 
change disks. 

Delete ... 
Deletes a file. A dialog box lets you select files and disks. This 
function is identical to dragging the file icon into the trash and 
emptying the trash from the Macintosh desktop. 

Make Works Desktop ... 
Creates a Works desktop file that contains a list of all files cur­
rently open on the desktop. When this desktop file is opened, all 
the Works ftles will be opened automatically. A dialog box lets you 
enter a file name and change disks. 

Page Setup ... 
Lets you define the page setup parameters, including paper type, 
paper orientation, header, footer, and margins. Options vary de­
pending on the printer selected from the Chooser desk accessory. 

Print ... 
Prints the document in the active window on the printer selected 
from the Chooser desk accessory. A dialog box provides options, 
including number of copies, range of page numbers, manual feed, 
and print preview. 
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Print Window 
Prints the visible contents of the active window on the printer 
selected from the Chooser desk accessory. 

Eject Page 
Issues a form feed command to the printer, ejecting a page. 

Print Merge ... 
Merges fields from a Works database with a Works word-process­
ing file. The fields to be merged must be defined using the Prepare 
to Merge command in the Edit menu. A document will be printed 
for every record selected in the database. This is used to print form 
letters, mailing labels, and other reports. 

Quit 
Stops Works, closes all files, and returns to the Macintosh desk­
top. For each file that has been changed but not saved, a warning 
and an option for saving the file will appear in a dialog box. 

A.2 THE EDIT MENU 

Undo 

Undo 

Cut 
Copy 
Paste 
Clear 
Select Rll 

Draw On 

HZ 

HH 
KC 
HU 

HJ 

Prepare to Merge... HM 
Show Field Names 
Multiple Labels 

Undoes the action of the previous command. It is used to reverse 
mistakes but can only undo one command. Multiple commands or 
mouse movements cannot be undone. 
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Cut 
Removes the highlighted text or drawing from the document and 
places it on the Clipboard. The text or drawing can later be pasted 
into another location in the same document or into another docu­
ment. 

Copy 
Copies the highlighted text or drawing from the document and 
places it on the Clipboard. The original text or drawing remains in 
the document. The text or drawing on the Clipboard can later be 
pasted into another location in the same document or into another 
document. 

Paste 
Copies the text or drawing on the Clipboard into the document at 
the location of the cursor. The text or drawing on the Clipboard is 
not erased and can be pasted again. 

Clear 
Erases the highlighted text or drawing from the document. The 
text or drawing is not copied to the Clipboard. 

Select All 
Highlights the entire document providing a shortcut for changing 
the font or other characteristics. 

Draw On-Draw Off 
Turns on the draw mode, with which you can add lines, boxes, 
shading, and other graphics to the document. Draw On displays 
the Draw Tool box. Draw Off turns off the draw mode and returns 
to text mode (see Appendix B for details). 

Prepare to Merge ... 
Defines database fields to be merged with the word-processing 
document. A dialog box lists the databases available on the desktop 
and the fields that can be merged. A database field selected in the 
dialog box will be inserted at the location of the cursor. The Print 
Merge command in the File menu will merge the database infor­
mation into the document for printing. 

Show Field Names-Show Field Data 
Displays the database field names of the merged fields in the word­
processing window. Show Field Data displays the actual data 
contained in the database fields. 

Multiple Labels 
Allows data from more than one record in a database to be merged 
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on a single page of a word-processing document. This is useful in 
printing mailing labels and lists of information. 

A.3 THE WINDOW MENU 

Window 

Show Clipboard 

Help 

Show Clipboard-Hide Clipboard 
Displays the current contents of the Clipboard in a window on the 
screen. Hide Clipboard will close the Clipboard window. 

Help 
Opens the Help window, which can be scrolled to get information 
on the various Works commands. The cursor will change to a 

question mark (?). Selecting a menu command with this cursor 
will scroll the Help window to information on that command. 

Open File Windows 
Shows a list of every open file below the Help command. Choosing 
a file window from this list will make that window active and bring 
it to the front. 

A.4 THE SEARCH MENU 

Find... 3€F 
Replace... 3€R 

Go To Page # ••• 3€6 

Find .•. 
Locates text anywhere in the document. A dialog box lets you enter 
a search string and choose among search options. 

Replace .•• 
Locates selected text anywhere in the document and replaces it 
with new text. A dialog box lets you enter search strings and 
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replacement strings and choose replacement options. One option 
replaces all occurrences of the text string automatically, in the 
entire ftle. Another option replaces the text only when it is con­
firmed manually. 

Go to Page# ... 
Scrolls the active window automatically to the page number speci­
fied in the associated dialog box. 

A.5 THE FORMAT MENU 

Format 
Hide Ruler 

Font 
Size 
Style 
Color 

Copy Format 3€K 
Paste Format 3€Y 

Justification ~ 

Spacing ~ 

Insert Page Break 
Title Page 
Set Page # ... 

Hide Ruler-Show Ruler 
Hides the ruler at the top of the word processor window from view. 
Show Ruler returns the ruler to view. The ruler settings are not 
affected. 

Font 
Displays a submenu listing the fonts (typefaces) available. Choos­
ing a font from the submenu will select that font for the text. 
Additional fonts can be added using the Font/DA Mover program 
on the Macintosh Utilities Disk. 



9 Point 
1 O Point 
12 Point 
14 Point 
18 Point 
20 Point 
24 Point 
Other ... 

Normal 
Bold 
Italic 
Underline 
mmnaomm 
~[iJQJCilCDl!D 

Black 
IIlJ[llDQm 
Red 
Green 
Blue 
Cyan 
Magenta 
Yellow 

Left 
Center 
Right 
Justified 
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Size 
Displays a submenu listing the font sizes available. Choosing a 
size from the submenu will select that size for the text. Sizes 
appearing in outline (]. 2) will print best on the screen and the 
ImageWriter printer. Sizes are listed in points (72 points= 1 inch). 
The Other option provides for sizes other than those listed in the 
submenu. 

Style 
Displays a submenu listing the font styles available: Normal, Bold, 
Italic, Underline, Outline, Shadow, Superscript, and Subscript. 
Choosing a style from the submenu will select that style for the 
text. 

Color 
Displays a submenu listing the colors available. Choosing a color 
from the submenu will select that color for the text on the screen. 

Copy Format 
Copies the format (ruler settings) to a special format clipboard. The 
format copied will be the format for the line on which the cursor is 
located. This action will not affect the contents of the regular 
Clipboard. 

Paste Format 
Pastes the format (ruler settings) from the format clipboard to the 
line on which the cursor is located. This action changes the exist­
ing format to the one on the format clipboard. A format can be 
changed on several adjacent lines simultaneously by highlighting 
the text with the mouse and then pasting the format. 

Justification 
Displays a submenu listing the justification options. Choosing a 
justification from the submenu will select that justification for the 
text. Left aligns the text on the left margin. Center centers the text 
within the margins. Right aligns the text on the right margin. 
Justified fills the text between the margins, aligning both left and 
right margins. 
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Spacing 
Displays a submenu listing the spacing options. Choosing a spac­
ing from the submenu will select that spacing for the text. Spacing 
options include single spacing, 1 1 /2 spacing, double spacing, and 
6-lines-per-inch spacing. The latter is used with data-processing 
forms and continuous feed labels. 

Single 
1 1 /2 Spaces 
Double 

6 Lines per inch 

Insert Page Break-Remove Page Break 
Inserts a page break (top of page or form feed) command above the 
line on which the cursor is located. It is used to force the line the 
cursor is on to begin a new page. Remove Page Break removes a 
page break above the line on which the cursor is located. 

Title Page 
Specifies the frrst page of the document as a title page. No header 
or footer information (including page numbering) will print on this 
page. However, the title page will be counted in the numbering. 

Set Page# ... 
Sets the starting page number for the first page of the document. 
The starting page number is entered in the associated dialog box. 
This is useful in consecutively numbering two or more documents. 

A.6 THE SPELL MENU 

Correct Spelling ... 

Correct Spelling ... 

Options ... 
Dictionary ... 

Compares each word in the entire document or highlighted text 
with a dictionary. Text not found in the dictionary is assumed to be 
misspelled and is displayed in a dialog box along with the program's 
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best guess about the correct spelling. Options are available to 
replace the misspelled word, to scan the dictionary for the cor­
rectly spelled word, to skip the word, to add the word to the 
dictionary, and to correct the spelling manually. A dictionary of 
skipped words can be saved at the end of the Correct Spelling 
process. 

Options ... 
Displays the Spell Options dialog box that defines the correct 
spelling rules. 

Dictionary ... 
Selects a dictionary of skipped words saved previously. Words from 
this dictionary will be skipped in the document to speed the 
process. A dialog box lets you select dictionary files and disks. 

The Macro menu is described in Appendix K. 



p p 

Pointer Tool 

E N D x 

SUMMARY OF 
DRAW COMMANDS 

Selects objects by pointing and clicking with the mouse. 

Text Tool 
Enters text and creates columns. Place the text cursor at the 
location where text is to be inserted, click the mouse button, and 
type the text. 

241 
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Line Tool 
Draws straight lines between any two points. Point to the starting 
point, click, and drag the mouse to the ending point while holding 
down the mouse button. 

Freehand Tool 
Draws freehand lines. Point to the starting point, click, and drag 
the mouse to the ending point while holding down the mouse 
button. 

Straight Line Tool 
Draws straight lines horizontally or vertically. Point to the starting 
point, click, and drag the mouse to the ending point while holding 
down the mouse button. 

Rectangle Tool 
Draws rectangles and squares. Pointing to the upper left-hand 
corner, click and drag the mouse to the lower right-hand corner 
while holding down the mouse button. To draw squares, hold 
down the shift key while drawing. 

Rounded Rectangle Tool 
Draws rectangles and squares with rounded corners. Pointing to 
the upper left-hand corner, click and drag the mouse to the lower 
right-hand corner while holding down the mouse button. To draw 
squares, hold down the shift key while drawing. 

Oval Tool 
Draws ovals and circles. Pointing to the upper left-hand corner, 
click and drag the mouse to the lower right-hand corner while 
holding down the mouse button. To draw circles, hold down the 
shift key while drawing. 

Polygon Tool 
Draws polygons. Point to the starting point of the first side of the 
polygon and click the mouse button. Point to each of the comers of 
the polygon and click the mouse button. Close the polygon by 
pointing to the starting point and clicking the mouse button again. 

Arc Tool 
Draws 90° arcs. Pointing to the starting point of the arc, click and 
drag the mouse to the ending point while holding down the mouse 
button. To draw arcs from circles, hold down the shift key while 
drawing. 

Default Fill Pattern 
Displays the default pattern, selected from the Fill Pattern menu, 
that will be used to fill objects. 



Left 
Center 
Right 
Justified 
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Default Line Pattern 
Displays the default pattern, selected from the Fill Line menu, that 
will be used to draw lines. 

Nudge Tool 
Moves (nudges) a selected object up, down, left, or right one pixel 
at a time on the screen. 

Line Thickness Tool 
Shows the current thickness of the line. Pointing to and clicking on 
another thickness will change the current thickness. 

Line Type Tool 
Shows whether the current line type has arrows or not. Point to 
and click on the desired line type. 

B.2 THE DRAW FORMAT MENU 

Justification 

Form cit 

Justification • 
Font • 
Size • 
Style • 
Color - Black Dots • 
Color - White Dots • 

Group Picture 886 
Ungroup Picture 88U 
Grid Setting ... 
Grid On 
Bring to Front 8€F 
Send to Back 388 
Show Column BoHes 
Spread TeHt 

Displays a submenu listing the justification options. Choosing a 
justification from the submenu will select that justification for the 
text. Left aligns the text on the left margin. Center centers the text 
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Chicago 
Geneua 
Monaco 
New York 

9 Point 
1 O Point 
12 Point 
14 Point 
18 Point 
20 Point 
24 Point 
Other ... 

Normal 
Bold 
ltB/Jc 
Underline 
ffimtlDDm@ 
'1lilfDt!JOJl!D 
Black 
[J]JlllDtl@ 
Red 
Green 
Blue 
Cyan 
Magenta 
Yellow 

within the margins. Right aligns the text on the right margin. 
Justified fills the text between the margins, aligning both left and 
right margins. 

Font 
Displays a submenu listing the fonts (typefaces) available. Choos­
ing a font from the submenu will select that font for the text. 
Additional fonts can be added using the Font/DA Mover program 
on the Macintosh Utilities Disk. 

Size 
Displays a submenu listing the font sizes available. Choosing a 
size from the submenu will select that size for the text. Sizes 
appearing in outline (]. 2) will print best on the screen and the 
ImageWriter printer. Sizes are listed in points (72 points= 1 inch). 
The Other option provides for sizes other than those listed in the 
submenu. 

Style 
Displays a submenu listing the font styles available: Normal, Bold, 
Italic, Underline, Outline, Shadow, Superscript, and Subscript. 
Choosing a style from the submenu will select that style for the 
text. 

Color-Black Dots 
Displays a submenu listing the colors available. Choosing a color 
from the submenu will select that color for the black dots on the 
screen. 

Color-White Dots 
Displays a submenu listing the colors available. Choosing a color 
from the submenu will select that color for the white dots on the 
screen. 

Group Picture 
Combines several objects selected into a group. Once the objects 
have been selected by pointing and clicking while holding down the 
Shift key, choose the Group Picture command. Grouped objects 
are treated as a single object by Works. 
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Ungroup Picture 
Undoes the group feature for a selected object. Once ungrouped, 
the original objects can be moved or otherwise modified. 

Grid Setting ... 
Sets the spacing for the transparent grid that controls the align­
ment of objects both horizontally and vertically. The Grid On 
command must be chosen for the grid to be in effect. A dialog box 
lets you change the Grid Setting from the default value of 1/8 inch. 

Grid On 
Turns on the grid feature that helps align objects horizontally and 
vertically. A check mark (~ indicates that the option is in effect. To 
toggle the grid off, choose the Grid On command again. 

Bring to Front 
Moves the selected object to the foreground of the drawing layer. 

Send to Back 
Moves the selected object to the background of the drawing layer. 

Show Column Boxes 
Displays dotted lines around columns on screen. A check mark (.I) 
indicates that the option is in effect. 

Spread Text 
Aligns text along a line or around an arc. Copy the selected text to 
the Clipboard, draw the line or arc or select the desired line or arc, 
and choose Spread Text. 

B.3 THE FILL PATTERN MENU 

The Fill Pattern menu (see p. 246) provides 39 patterns for filling 
objects. To fill an object, select it and then choose a pattern from 
the Fill Pattern menu. If you do not select an object, the Default Fill 
Pattern will be changed to your new choice and all subsequent 
objects drawn will be filled with the new default fill pattern. An 
object will be transparent if the transparent (0) pattern is chosen. 

8.4 THE LINE PATTERN MENU 

The Line Pattern menu (see p. 246) provides 39 patterns for draw­
ing lines. To change the line pattern of an object, select it and then 
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choose a pattern from the Line Pattern menu. If you do not select 
an object, the Default Line Pattern will be changed to your new 
choice and all subsequent objects will be drawn with lines using 
the new default line pattern. An object will be drawn without a line 
pattern if the transparent ( 0l pattern is chosen. 
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SUMMARY OF 
SPREADSHEET 

COMMANDS 

C.1 THE FILE MENU 

New ••• 

New ••• 
Open ••• 8€0 

Close 3€W 
Close Rll •.• 
Saue 8€S 
Saue Rs ••• 
Delete •.• 

Make Works Desktop ••• 

Page Setup ..• 
Print... 8€P 
Print Window 
Eject Page 
Print Merge .•. 

Quit 3€Q 

Creates a New file of any Works application type. A dialog box lets 
you select word-processing, database, spreadsheet, or communi­
cations files. 
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Open ... 
Opens an existing spreadsheet file to be edited or added to. A 
dialog box lets you select files and disks. 

Close 
Closes the active file window. If the file has been changed but not 
saved. a warning and an option for saving the file will appear in a 
dialog box. 

Close All ... 
Closes all the file windows. For each file that has been changed but 
not saved, a warning and an option for saving the file will appear in 
a dialog box. 

Save 
Saves the active file window. If the file is untitled. a dialog box 
requires that a file name be entered and provides options for 
changing disks. If the file has been named previously, the edited 
file will be saved over the original file with the same file name. 

Save As ... 
Saves an edited file with a new file name. The original file is kept 
intact. A dialog box allows you to enter the new file name and 
change disks. 

Delete ... 
Deletes a file. A dialog box lets you select files and disks. This 
function is identical to dragging the file icon into the trash and 
emptying the trash from the Macintosh desktop. 

Make Works Desktop ... 
Creates a Works desktop file that contains a list of all files currently 
open on the desktop. When this desktop file is opened, all the 
Works files will be opened automatically. A dialog box lets you 
enter a file name and change disks. 

Page Setup ... 
Lets you define the page setup parameters. including paper type, 
paper orientation. header, footer, and margins. Options vary de­
pending on the printer selected from the Chooser desk accessory. 

Print ... 
Prints the document in the active window on the printer selected 
from the Chooser desk accessory. A dialog box provides options, 
including number of copies, range of page numbers. manual feed, 
and print preview. 
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Print Window 
Prints the visible contents of the active window on the printer 
selected from the Chooser desk accessory. 

Eject Page 
Issues a form feed command to the prtnter, ejecting a page. 

Print Merge ••• 
The Print Merge feature is not available in the spreadsheet. 

Quit 
Stops Works, closes all files, and returns to the Macintosh desktop. 
For each file that has been changed but not saved, a warning and 
an option for saving the file will appear in a dialog box. 

C.2 THE EDIT MENU 

Undo 

Cut 
Copy 
Paste 
Clear 
Select Rll 
Paste with Options ••• 

Draw On 88J 
Moue ••• 
Insert 8€ I 
Paste Function ••• 
Absolute Cell Ref 88 R 
Fill Right 3€ R 
Fill Down 88 D 
Open Cell Note •.• 

Sort ••• 
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Undo 
Undoes the action of the previous command. It is used to reverse 
mistakes but can only undo one command. Multiple commands or 
mouse movements cannot be undone. 

Cut 
Removes the highlighted cell or drawing from the document and 
places it on the Clipboard. The cell or drawing can later be pasted 
into another location in the same spreadsheet, into another 
spreadsheet, or into another type of document. 

Copy 
Copies the highlighted cell or drawing from the spreadsheet and 
places it on the Clipboard. The original cell or drawing remains in 
the spreadsheet. The cell or drawing on the Clipboard can later be 
pasted into another location in the same spreadsheet, into another 
spreadsheet, or into another type of document. 

Paste 
Copies the cell or drawing on the Clipboard into the spreadsheet at 
the location of the cursor. The cell or drawing on the Clipboard is 
not erased and can be pasted again. 

Clear 
Erases the contents of the highlighted cell or erases a selected 
drawing from the spreadsheet. The cell content or drawing is not 
copied to the Clipboard. 

Select All 
Highlights all the cells in the spreadsheet, providing a shortcut for 
changing their font or other characteristics. 

Paste with Options ... 
Copies the cells on the Clipboard into the spreadsheet at the 
location of the cursor, using special options. A dialog box provides 
the options, which include pasting the values only, pasting the 
formulas only, or transposing rows to columns or columns to rows. 

Draw On-Draw Off 
Turns on the draw mode, with which you can add lines, boxes, 
shading, and other graphics to the spreadsheet. Draw On displays 
the Draw Tool box. Draw Off turns off the draw mode and returns 
to the spreadsheet mode (see Appendix B for details). 

Move ... 
Moves the contents of the cells selected with the mouse to a new 
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location in the same spreadsheet. Both relative and absolute cell 
references remain unchanged. Cut and Paste should be used when 
moving cells from one spreadsheet to another. 

Insert 
Inserts a new row of cells above a row selected by clicking on the 
row heading (row number). Insert can also insert a new column to 
the left of a column selected by clicking on the column heading 
(column letter). 

Paste Function ... 
Pastes a built-in function at the location of the cursor when you 
enter a formula in the cell contents box. You select the built-in 
function from a scrolling list of available functions when the option 
is chosen. 

Absolute Cell Ref 
Converts a relative cell reference (for example, G5) to an absolute 
cell reference (for example, $G$5) when you're entering a formula 
into a cell. 

Fill Right 
Copies the contents (including formulas) from the leftmost cell in a 
series of highlighted cells into the cells to its right. If a formula is 
copied. relative cell references (such as KS) are revised appropriately; 
absolute cell references (such as $K$S) are not changed. 

Fill Down 
Copies the contents (including formulas) from the topmost cell in a 
series of highlighted cells into the cells beneath it. If a formula is 
copied. relative cell references (such as KS) are revised appropriately; 
absolute cell references (such as $K$S) are not changed. 

Open Cell Note ... 
Opens a scrolling window in which a note can be typed documenting 
the contents of the cell. Once a cell note has been created. a small 
box appears in the right-hand corner of the cell. An existing cell 
note can be reopened, using the Open Cell Note command. and 
read or edited. 

Sort ... 
Sorts the contents of the cells selected with the mouse into row 
order as specified in the Sort dialog box. The dialog box allows up 
to three sort keys (columns) to be specified. Each sort can be done 
in ascending or descending order. The Sort command handles 
both alphabetic and numeric data. Note: Adjacent cells containing 
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data that relate to the Sort key column must also be selected with 
the mouse: otherwise the contents of the adjacent columns will not 
be sorted along with the Sort key column. 

C.3 THE WINDOW MENU 

Window 

Show Clipboard 

Help 

Show Clipboard-Hide Clipboard 
Displays the current contents of the Clipboard in a window on the 
screen. Hide Clipboard will close the Clipboard window. 

Help 
Opens the Help window, which can be scrolled to get information 
on the various Works commands. The cursor will change to a 
question mark ( ? ) . Selecting a menu command with this cursor 
will scroll the Help window to information on that command. 

Open File Windows 
Shows a list of every open file below the Help command. Choosing 
a file window from this list will make that window active and bring 
it to the front. 

C.4 THE SELECT MENU 

Rll Cells 
Last Cell 

Find Cell... 3€F 
Go To Cell... 3€6 

Show Rctiue Cell 
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All Cells 
Selects all cells in the spreadsheet from Al to the last cell in which 
data are entered. Ifs similar to Select All in the word-processing 
application. 

Last Cell 
Selects the last cell in which data were entered. 

Find Cell ... 
Locates and selects a cell either by its row and column reference 
(for example, 06) or by matching its contents. A dialog box lets you 
enter the cell or the cell's contents to be matched. 

Go To Cell ... 
Locates a cell specified in the dialog box. The cell is located by its 
row and column reference (for instance, J2). and the cell is not 
selected. 

Show Active Cell 
Scrolls the spreadsheet to show the active cell within the window. 

C.5 THE FORMAT MENU 

Format 

Set Cell Attributes ... 

Set Cell Attributes ... 

Borders 

Font 
Size 
Color 

Column Width ... 

Specifies the way in which information is displayed in a cell. A 
dialog box lets you select the display type (general, fixed, dollar, 
percent, scientific, date, or time), the alignment Oeft, center, or 
right), and the style (bold, underline, or commas). 
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Outline 
Left 
Right 
Top 
Bottom 
None 

Chicago 
Geneua 
Monaco 
New York 

9 Point 
1 o Point 
12 Point 
14 Point 
18 Point 
20 Point 
24 Point 
Other ... 

Black 
IIlllllDtl© 
Red 
Green 
Blue 
Cyan 
Magenta 
Yellow 

Borders 
Displays a submenu listing the available border options. Outline 
draws a line around each edge of the selected cells. A border can 
also be drawn only on the left, right, top, bottom, or any combina­
tion of edges. 

Font 
Displays a submenu listing the fonts (typefaces) available. Choos­
ing a font from the submenu will select that font for the text. 
Additional fonts can be added using the Font/DA Mover program 
on the Macintosh Utilities Disk. 

Size 
Displays a submenu listing the font sizes available. Choosing a 
size from the submenu will select that size for the text. Sizes 
appearing in outline (ll.2) will print best on the screen and the 
lmageWriter printer. Sizes are listed in points (72 points= 1 inch). 
The Other option provides for sizes other than those listed in the 
submenu. 

Color 
Displays a submenu listing the colors available. Choosing a color 
from the submenu will select that color for the text on the screen. 

Column Width ... 
Sets the width of the selected column to a specified amount. A 
dialog box lets you enter a column width from 1 to 40 spaces. 
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C.6 THE OPTIONS MENU 

Show Grid 

Options 

Show Grid 
Show Notes Indicator 

Show Formulas 
Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now 88= 
Manual Calculation 
Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

Displays and plints the row and column glid lines. Show Giid is 
the default option when a new spreadsheet is opened. A check 
mark (v") indicates that the option is in effect. 

Show Notes Indicator 
Displays and prints a small box in the light-hand corner of any cell 
that has a cell note associated with it. Show Notes Indicator is the 
default option when a new spreadsheet is opened. A check mark 
(v") indicates that the option is in effect. 

Show Formulas 
Displays and prints the unformatted cell contents or cell formula 
rather than the formatted value or value resulting from the calcu­
lation of the formula. If Show Formulas is in effect when you Copy 
or Cut a cell, the formula will be placed on the Clipboard. A check 
mark (yl') indicates that the option is in effect. 
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Show Values 
Displays and prints the formatted value or calculated value in 
each cell. If Show Values is in effect when you Copy or Cut a cell, 
the values will be placed on the Clipboard. Show Values is the 
default option when a new spreadsheet is opened. A check mark 
(rv/) indicates that the option is in effect. 

Protected 
Protects the selected cell from accidental entry of new data. If an 
attempt is made to enter data in a protected cell, access is denied 
and a warning is printed on the screen. A check mark (rv/) indi­
cates that the option is in effect. Choosing the Protected command 
will eliminate existing protection and allow you to modify the cell 
contents. 

Set Page Break 
Sets a page break above and to the left of the active cell. This is 
used to force the active cell to begin the top left corner of a new 
page. 

Remove Page Break 
Removes an existing horizontal page break above or a vertical page 
break to the left of the active cell. A vertical and horizontal page 
break can be removed simultaneously by selecting the cell in the 
upper left-hand corner of the page and choosing Remove Page 
Break. 

Calculate Now 
Recalculates all the formulas in the spreadsheet. This command is 
used when you're working in the Manual Calculation mode. 

Manual Calculation 
Sets the calculation mode to manual. Formulas will not be recal­
culated unless the Calculate Now command is chosen. You '11 use 
this for spreadsheets with a large number of formulas that are 
revised frequently, to speed data entry. A check mark (rv/) indicates 
that the option is in effect. 

Automatic Calculation 
Sets the calculation mode to automatic. Each time data are en­
tered or the contents of a cell are edited, all the formulas in the 
spreadsheet are recalculated. Automatic Calculation is the default 
option when a new spreadsheet is opened. A check mark (rv/) indi­
cates that the option is in effect. 
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Freeze Titles Horizontal 
Prevents column titles from scrolling. After the window is split 
using the horizontal split bar (see Section 4.5), choose Freeze Titles 
Horizontal to freeze the column titles above the split bar. 

Freeze Titles Vertical 
Prevents row titles from scrolling. After the window is split using 
the vertical split bar (see Section 4.5), choose Freeze Titles Vertical 
to freeze the row titles to the left of the split bar. 

The Chart menu is described in Appendix E, the Macro menu 
in Appendix K. 
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SUMMARY OF 
DATABASE COMMANDS 

D.1 THE FILE MENU 

New •.. 

New ••• 
Open ••• 

Close 
Close Hll ••• 
Saue 
Saue Hs ••• 
Delete ••• 

8€W 

Make Works Desktop ••• 

Page Setup ••• 
Print... 8€P 
Print Window 
Eject Page 
Print Merge ..• 

Quit 8€Q 

Creates a New file of any Works application type. A dialog box lets 
you select word-processing. database. spreadsheet, or communi­
cations files. 

259 



260 Appendix D Summary of Database Commands 

Open ... 
Opens an existing database file to be edited or added to. A dialog 
box lets you select files and disks. 

Close 
Closes the active file window. If the file has been changed but not 
saved, a warning and an option for saving the file will appear in a 
dialog box. 

Close All ... 
Closes all the file windows. For each file that has been changed but 
not saved, a warning and an option for saving the file will appear in 
a dialog box. 

Save 
Saves the active file window. If the file is untitled, a dialog box 
requires that a file name be entered and provides options for 
changing disks. If the file has been named previously, the edited 
file will be saved over the original file with the same file name. 

Save As ... 
Saves an edited file with a new file name. The original file is kept 
intact. A dialog box allows you to enter the new file name and 
change disks. 

Delete ... 
Deletes a file. A dialog box lets you select files and disks. This 
function is identical to dragging the file icon into the trash and 
emptying the trash from the Macintosh desktop. 

Make Works Desktop ... 
Creates a Works desktop file that contains a list of all files currently 
open on the desktop. When this desktop file is opened, all the 
Works files will be opened automatically. A dialog box lets you 
enter a file name and change disks. 

Page Setup ... 
Lets you define the page setup parameters, including paper type, 
paper orientation, header, footer, and margins. Options vacy de­
pending on the printer selected from the Chooser desk accessory. 
The Page Setup command is only available after a report has been 
selected from the Report menu. 

Print ... 
Prints the document in the active window on the printer selected 
from the Chooser desk accessory. A dialog box provides options, 
including number of copies, range of page numbers, manual feed, 
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and print preview. The Print command is only available after a 
report has been selected from the Report menu. 

Print Window 
Prints the visible contents of the active window on the printer 
selected from the Chooser desk accessory. The Print Window com­
mand is not available after a report has been selected from the 
Report menu. 

Eject Page 
Issues a form feed command to the printer, ejecting a page. 

Print Merge ... 
The Print Merge feature is not available in the database. 

Quit 
Stops Works, closes all files, and returns to the Macintosh desktop. 
For each file that has been changed but not saved, a warning and 
an option for saving the file will appear in a dialog box. 

D.2 THE EDIT MENU 

Undo 

Cut 
Copy 
Paste 
Clear 
Select All 

Draw On 

Paste Function 

Insert Record 3€1 

Change Field Name ... 
Add New Field ... 
Delete Field 
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Undo 
Undoes the action of the previous command. It is used to reverse 
mistakes but can only undo one command. Multiple commands or 
mouse movements cannot be undone. 

Cut 
Removes the highlighted text from the document and places it on 
the Clipboard. The text can later be pasted into another location in 
the same database, into another database, or into another type of 
document. 

Copy 
Copies the highlighted text from the database and places it on the 
Clipboard. The original text remains in the database. The text on 
the Clipboard can later be pasted into another location in the 
same database, into another database, or into another type of 
document. 

Copy Totals 
Copies the subtotals and grand total from the report selected to 
the Clipboard. This lets you copy report totals to a spreadsheet. 
The Copy Totals command is only available after a report has been 
selected from the Report menu. 

Paste 
Copies the text on the Clipboard into the database at the location 
of the cursor. The text on the Clipboard is not erased and can be 
pasted again. 

Clear 
Erases the contents of the selected (highlighted) field. The field 
contents are not copied to the Clipboard. 

Select All 
Selects all the fields in the database, providing a shortcut for 
changing their font or other characteristics. Select All is available 
only when the Show List option is in effect. 

Draw On 
The Draw feature is not available in the database. 

Paste Function ... 
Pastes a built-in function at the location of the cursor in the entry 
bar when you enter a formula for a computed field. You select the 
built-in function from a scrolling list of available functions when 
the option is chosen. 
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Insert Record 
Inserts a blank record immediately above the selected record in the 
list window or immediately before the currently displayed record in 
the form window. 

Change Fleld Name ••• 
Changes the name of the selected field. A dialog box lets you 
modify the field name. 

Add New Field ••• 
Adds a new field to the database for every record. The contents of 
the new field will be blank. A dialog box lets you enter the name of 
the new field. 

Delete Fleld 
Deletes the selected field and its contents from every record in the 
database. If the Delete Field command is accidentally chosen. the 
field can be restored by immediately choosing Undo from the Edit 
menu. 

Change Report Title ••• 
Changes the title of the selected report. A dialog box lets you 
modify the titles of the current report. The Change Report Title 
command is only available after a report has been selected from 
the Report menu. 

D.3 THE WINDOW MENU 

Window 

Show Clipboard 

Help 

Show Clipboard-Hide Clipboard 
Displays the current contents of the Clipboard in a window on the 
screen. Hide Clipboard will close the Clipboard window. 

Help 
Opens the Help window. which can be scrolled to get information 
on the various Works commands. The cursor will change to a 
question mark(?). Selecting a menu command with this cursor 
will scroll the Help window to information on that command. 
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Open File Windows 
Shows a list of evecy open file below the Help command. Choosing 
a file window from this list will make that window active and bring 
it to the front. 

D.4 THE ORGANIZE MENU 

Find Field ... 

Organize 

Find Field... 88F 

Match Records... 88M 

Record Selection ... 
Show Rll Records 

Sort ... 

Finds evecy field, one at a time, that contains specific text. A dialog 
box allows the matching text to be entered and offers an option to 
search only text fields, which speeds up the searching process. 

Match Records ... 
Locates and displays all records that contain specific text in any 
field. If Match Records is chosen from the list window, only the 
matching records appear in the window. If Match Records is cho­
sen from the form window, only the matching records can be 
scrolled through. 

Record Selection ... 
Selects records based on up to six selection rules. These rules are 
defined in the Record Selection dialog box and let you select 
records by matching text in one or more specific fields. See Section 
6.3.4 for details on selection rules. If Record Selection is chosen 
from the list window, only the selected records appear in the 
window. If Record Selection is chosen from the form window, only 
the selected records can be scrolled through. 

Show All Records 
Reverses the effect of the Record Selection or Match Records com­
mands displaying all records in the list window and allowing all 
records to be scrolled through in the form window. 
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Sort ... 
Sorts all the records in the database in alphabetical or numerical 
order based on the data in the selected field. The database can be 
arranged in A-to-Z, Z-to-A, O-to-9, 9-to-O, chronological, or reverse 
chronological order as specified in the dialog box. 

D.5 THE FORMAT MENU 

Format 
Show List 

Bold Field Name 
Bold Field Data 

Border Field Name 
Border Field Data 

Font 
Size 
Color 

HL 

Set Field Attributes ... 

Show List-Show Form 
Specifies the format for displaying the database. Show List dis­
plays multiple records, one line per record, in a scrolling list 
window. Show Form displays one record on the screen in the form 
window. 

Show Grid 
Displays and prints grtdlines between each field and each record 
when a report has been selected. Show Grid is the default option 
when a new report is defined. A check mark (tr/") indicates that the 
option is in effect. 

Bold Fleld Name 
Makes the field name of the selected field in the form window bold. 

Bold Field Data 
Makes the contents of the selected field in the form window bold. 
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Chicago 
Geneua 
Monaco 
New York 

9 Point 
1 O Point 
12 Point 
14 Point 
18 Point 
20 Point 
24 Point 
Other •.. 

Black 
IIlllbnam 
Red 
Green 
Blue 
Cyan 
Magenta 
Yellow 

Border Field Name 
Displays a border around the field name of the selected field in the 
form window. 

Border Field Data 
Displays a border around the contents of the selected field in the 
form window. 

Font 
Displays a submenu listing the fonts (typefaces) available. Choos­
ing a font from the submenu will select that font for the text. 
Additional fonts can be added using the Font/DA Mover program 
on the Macintosh Utilities Disk. 

Size 
Displays a submenu listing the font sizes available. Choosing a 
size from the submenu will select that size for the text. Sizes 
appearing in outline ( ll 2) will print best on the screen and the 
ImageWriter printer. Sizes are listed in points (72 points= 1 inch). 
The Other option provides for sizes other than those listed in the 
submenu. 

Color 
Displays a submenu listing the colors available. Choosing a color 
from the submenu will select that color for the text on the screen. 

Set Field Attributes .•. 
Specifies the way in which information is displayed in a field. A 
dialog box lets you select the type of data (text, numeric, date, or 
time), display type (general, fixed, dollar, percent, scientific, or 
computed), alignment Oeft, center, or right), and style (bold, under­
line, or commas). 

D.6 THE REPORT MENU 

Select Report .•. 
New Report ••• 
Duplicate Report .•• 
Erase Report ••• 
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Select Report ... 
Selects a previously defmed report from a list of available report 
defmitlons. 

New Report ... 
Creates a new report definition. Up to eight reports can be defined 
for a database. 

Duplicate Report ... 
Duplicates a previously defmed report specified from a list of 
available report defmitlons. This is useful for modifying an existing 
report without permanently changing the original. 

Erase Report ... 
Erases a previously defined report specified from a list of available 
report defmitions. 

D.7 THE TOTALSPAGE MENU 

TotalsPage 

Sum This Field 

Take a Sub-Total on Field Change 
Take a Sub-Total on 1st Char 

New Page After Total 

The TotalsPage menu is displayed when a report has been selected 
from the Report menu. 

Sum This Field 
Computes a sum for the selected field and prints its total at the 
end of the report. A check mark (../) indicates that the option is in 
effect for the selected field. 

Take a Sub-Total on Field Change 
Computes and prints subtotals for each summed field every time 
there is a change in the data in the selected field. The data in the 
selected field (criterion field) should be sorted into a specific order 
before you defme the report. The fields to be summed must also be 
selected and the Sum This Field command chosen. A check mark 
(../) indicates that the option is in effect for the selected field. 
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Take a Sub-Total on 1st Char 
Computes and prints subtotals for each summed field every time 
there is a change in the first character of the data in the selected 
field. The data in the selected field (criterion field) should be sorted 
into a specific order before you define the report. The fields to be 
summed must also be selected and the Sum This Field command 
chosen. A check mark (v") indicates that the option is in effect for 
the selected field. 

New Page After Total 
Prints the next record following a subtotal on the top of a new 
page. A check mark (v") indicates that the option is in effect. 

The Macro menu is described in Appendix K. 
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SUMMARY OF 
BUSINESS GRAPHICS 
(CHART) COMMANDS 

This appendix describes the charting commands in the Works 
spreadsheet. When a command from the Chart menu is chosen, 
the Menu Bar and the menu commands change as indicated 
below. 

E.1 THE FILE MENU 

New ••• 
Open •.• 3€0 

Close 3€W 
Close All ••• 
Saue 3€S 
Saue Rs ••• 
Delete ••• 

Make Works Desktop ••• 

Page Setup ••• 
Print... 3€P 
Print Window 
Eject Page 
Print Merge ••• 

Quit 3€Q 
269 
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New ... 
Creates a New file of any Works application type. A dialog box lets 
you select word-processing. database. spreadsheet. or communi­
cations files. 

Open ... 
Opens an existing spreadsheet file and its associated charts. A 
dialog box lets you select files and disks. 

Close 
Closes the active file window. If the file has been changed but not 
saved. a warning and an option for saving the file will appear in a 
dialog box. 

Close All ... 
Closes all the file windows. For each file that has been changed but 
not saved. a warning and an option for saving the file will appear in 
a dialog box. 

Save 
The Save command is not available when a Chart window is active. 
Charts are automatically saved with the associated spreadsheet. 

Save As ... 
The Save As command is not available when a Chart window is 
active. 

Delete ... 
Deletes a file. A dialog box lets you select files and disks. This 
function is identical to dragging the file icon into the trash and 
emptying the trash from the Macintosh desktop. 

Make Works Desktop ... 
Creates a Works desktop file that contains a list of all files currently 
open on the desktop. When this desktop file is opened. all the 
Works files will be opened automatically. A dialog box lets you 
enter a file name and change disks. 

Page Setup ... 
The Page Setup command is not available when a Chart window is 
active. 

Print. .. 
The Print command is not available when a Chart window is active. 
Use the Print Window command to print a chart or copy and paste 
the chart into a word-processing document for printing. 
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Print Window 
Prints the visible contents of the active window on the printer 
selected from the Chooser desk accessory. 

Eject Page 
Issues a form feed command to the printer, ejecting a page. 

Print Merge ... 
The Print Merge command is not available when a Chart window is 
active. 

Quit 
Stops Works, closes all files, and returns to the Macintosh desktop. 
For each ftle that has been changed but not saved, a warning and 
an option for saving the ftle will appear in a dialog box. 

E.2 THE EDIT MENU 

Undo 

Undo 

Cut 
Copy 
Paste 
Clear 

Change Chart Name ... 

The Undo command is not available when a Ch~ window is 
active. 

Cut 
The Cut command is not available when a Chart window is active. 

Copy 
Copies the chart from the active chart window and places it on the 
Clipboard. The chart on the Clipboard can later be pasted into a 
spreadsheet or word-processing document. 
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Paste 
The Paste command is not available when a Chart window is 
active. 

Clear 
The Clear command is not available when a Chart window is 
active. 

Change Chart Name ... 
Changes the name of the selected chart. A dialog box lets you 
modify the name of the current chart. The Change Chart Name 
command is only available when a chart definition has been selected 
from the Chart menu. 

E.3 THE WINDOW MENU 

Window 

Show Clipboard 

Help 

Show Clipboard-Hide Clipboard 
Displays the current contents of the Clipboard in a window on the 
screen. Hide Clipboard will close the Clipboard window. 

Help 
Opens the Help window, which can be scrolled to get information 
on the various Works commands. The cursor will change to a 

question mark (? ). Selecting a menu command with this cursor 
will scroll the Help window to information on that command. 

Open Fiie Windows 
Shows a list of evecy open file below the Help command. Choosing 
a file window from this list will make that window active and bring 
it to the front. 

E.4 THE CHART MENU 

Draw Chart ... 
Draws a previously defined chart. A dialog box lets you choose 
from existing charts associated with the active spreadsheet. 



Draw Chart ... 
New Series Chart ... 
New Pie Chart ... 
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Select Chart Definition ... 
Duplicate Chart ... 
Erase Chart ... 

New Serles Chart ... 
Opens the Series Chart dialog box, which defines the chart and 
then draws it. Options include line, bar, stacked bar, and combi­
nation line and bar charts. You can also define the location of the 
data in the spreadsheet, titles, legends. and other chart features. 
See Section 5.1.2 for details on drawing series charts. 

New Pie Chart ... 
Opens the Pie Chart dialog box. which defines the pie chart and 
then draws it. You can define the location of the data in the 
spreadsheet, titles, legends, and other chart features. See Section 
5.1.1 for details on drawing pie charts. 

Select Chart Definition ... 
Opens a previously defined chart's dialog box. A list of existing 
chart definitions associated with the active spreadsheet is dis­
played. Use this command to select a chart definition when you 
want to modify and redraw a chart. 

Duplicate Chart ... 
Duplicates an existing chart definition. A list of existing chart 
definitions associated with the active spreadsheet is displayed. Use 
this command to modify a chart definition without affecting the 
original chart definition. 

Erase Chart ... 
Erases a previously defmed chart. A dialog box lets you choose 
from the existing charts associated with the active spreadsheet. A 
maximum of eight charts may be associated with a spreadsheet. 

The Macro menu is described in Appendix K. 
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SUMMARY OF 
COMMUNICATIONS 

COMMANDS 

F.1 THE FILE MENU 

New ••• 

New ..• 
Open ••. 880 

Close M:W 
Close Hll ..• 
Saue M:S 
Saue Rs .•. 
Delete ..• 

Make Works Desktop ••• 

Page Setup •.. 
Print... OOP 
.,rint Window 
Eject Page 
Print Merge ... 

Quit 000 

Creates a New file of any Works application type. A dialog box lets 
you select word-processing. database. spreadsheet. or communi­
cations ftles. 
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Open ... 
Opens an existing communications file and its associated settings. 
A dialog box lets you select ftles and disks. 

Close 
Closes the active file window. If the file has been changed but not 
saved, a warning and an option for saving the file will appear in a 
dialog box. 

Close All ... 
Closes all the file windows. For each file that has been changed but 
not saved, a warning and an option for saving the file will appear in 
a dialog box. 

Save 
Saves the active file window. If the file is untitled, a dialog box 
requires that a file name be entered and provides options for 
changing disks. If the file has been named previously, the edited 
file will be saved over the original file with the same file name. 

Save As ... 
Saves an edited file with a new file name. The original file is kept 
intact. A dialog box allows you to enter the new file name and 
change disks. 

Delete ... 
Deletes a file. A dialog box lets you select files and disks. This 
function is identical to dragging the ftle icon into the trash and 
emptying the trash from the Macintosh desktop. 

Make Works Desktop ... 
Creates a Works desktop file that contains a list of all files currently 
open on the desktop. When this desktop file is opened, all the 
Works files will be opened automatically. A dialog box lets you 
enter a file name and change disks. 

Page Setup ... 
The Page Setup command is not available in the communications 
application. 

Print ... 
The Print command is not available in the communications appli­
cation. Use the Print Window command to print the text in the 
communications window. If the Capture Text option is active, the 
text file can later be opened in the word-processing application 
and printed. 



Undo HZ 

Cut 8€H 
Copy 38[ 
Paste 38U 
Clear 
Select Rll 
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Print Window 
Prints the visible contents of the active window on the printer 
selected from the Chooser desk accessocy. 

Eject Page 
Issues a form feed command to the printer. ejecting a page. 

Print Merge ... 
The Print Merge command is not available in the communications 
application. 

Quit 
Stops Works. closes all files. and returns to the Macintosh desktop. 
For each file that has been changed but not saved. a warning and 
an option for saving the file will appear in a dialog box. 

F.2 THE EDIT MENU 

Undo 
Undoes the action of the previous command. It is used to reverse 
mistakes but can only undo one command. Multiple commands or 
mouse movements cannot be undone. 

Cut 
Removes the highlighted text from the document and places it on 
the Clipboard. The text can later be pasted as if typed from the 
keyboard in the communications application or pasted into an­
other type of document. 

Copy 
Copies the highlighted text and places it on the Clipboard. The 
original text remains in the communications window. The text can 
later be pasted as if typed from the keyboard in the communications 
application or pasted into another type of document. 

Paste 
Copies the text on the Clipboard into the communications window 
at the location of the cursor. The text on the Clipboard is not 
erased and can be pasted again. 

Clear 
Erases the contents of the selected (highlighted) text. The text is 
not copied to the Clipboard. 

Select All 
Selects all the text in the communications window. 
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F.3 THE WINDOW MENU 

Window 

Show Clipboard 

Help 

Show Clipboard - Hide Clipboard 
Displays the current contents of the Clipboard in a window on the 
screen. Hide Clipboard will close the Clipboard window. 

Help 
Opens the Help window, which can be scrolled to get information 
on the vartous Works commands. The cursor will change to a 
question mark ( ?1. Selecting a menu command with this cursor 
will scroll the Help window to information on that command. 

Open File Windows 
Shows a list of every open file below the Help command. Choosing 
a file window from this list will make that window active and bring 
it to the front. 

F.4 THE COMMUNICATIONS MENU 

Echo On 
Allows characters to "echo" in the communications window. Some 
host computers send the characters they receive back to the send­
ing terminal; others do not. If characters do not appear in the 
communications window when they are typed, choose Echo On. A 
check mark(.,./) indicates that the option is in effect. 

Echo Off 
Prevents characters from echoing in the communications window. 
Some host computers send the characters they receive back to the 
sending terminal; others do not. If duplicate characters appear in 
the communications window when they are typed, choose Echo 
Off. A check mark(.,./) indicates that the option is in effect. 

Dial ... 
Displays a dialog box in which to record names and telephone 
numbers of host computers. The Dial button in the dialog box will 
dial the host computer from the Macintosh's modem. 



Hang Up 
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Communiciltions 

Echo On 
Echo Off 

Dial... SCD 
Hang Up SC= 
Answer Phone 

Capture TeHt ... 
Send TeHt ... 

Receiue File ... 
Send File ... 

Settings ... 

Disconnects the Macintosh's modem from the host's telephone 
line, ending the communications session. 

Answer Phone 
Instructs Works to answer incoming telephone calls to the 
Macintosh's modem, making the Macintosh act as a host com­
puter. A check mark (v') indicates that the option is in effect. 

Capture Text ... -End Capture Text 
Saves everything sent to and received from the host computer in a 
file specified in the dialog box. End Capture Text stops saving text 
to the file. 

Send Text ... 
Sends the text from a word-processing file to the host computer. A 
dialog box lets you choose the appropriate file. This command 
sends text only; to send graphics and other types of data, use the 
Send File command. 

Receive Fiie ... 
Receives a ftle from a host computer. A dialog box lets you name 
the file, identify where it is to be saved, and specify the transmis­
sion protocol. 
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Send Fiie ... 
Sends a file from the Macintosh to the host computer. A dialog box 
lets you specify the file and the transmission protocol. 

Settings ... 
Sets the communication parameters in the Settings dialog box. 
The settings must match those of the host computer; otheIWise, a 
proper connection will not be made. See Section 8.1.3 for a detailed 
discussion of the communications settings. 

F.5 THE KEYPAD MENU 

The Keypad menu is used with the Vf52 and VflOO terminal 
modes to emulate the standard Vf52 and Vfl 00 keypad. They are 
used with Macintosh keyboards that do not have numeric key­
pads. 

PF1,PF2,PF3,PF4 
Serve as function keys having variable codes depending on the 
software of the host computer. 

Arrow Keys 
Move the cursor left or right one space or up or down one line. 

Numeric Keys 
Type the appropriate number or punctuation at the location of the 
cursor in the communications window. 
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Enter Key 
Signals the end of data to be transmitted to the host computer. On 
some host computers the Enter key is identical to the Return key. 
On others, the Enter key and the Return key have different func­
tions. 

The Macro menu is described in Appendix K. 
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CONTENTS OF 
SUPPLEMENTAL 
DISKETTE WITH 

ANSWERS TO 
SELECTED POSERS, 

PROBLEMS, AND 
PROJECTS 

The Supplemental Diskette is designed to give you completed 
examples from the text, the files necessary to complete the more 
advanced examples, answers to selected problems from each chap­
ter, an interactive reference guide to Works commands, and a 
simulation of the Works communications application. 

G.1 EXAMPLES FOLDER 

This folder contains files used for the main examples in the text. 
Files for Chapters 2 through 6 are provided for reference purposes. 
If you are having difficulty. open the appropriate file and review the 
correct document, spreadsheet, or database. Files for Chapters 7. 
9, and l 0 are provided to help you complete the examples in the 
text. Although you can work the examples without recourse to 
these files, they will eliminate considerable data entry time. 

File Name Type 

Sculley's Quotation WP 
Letter to Sidney Celmour WP 
Savings Account SS 
Payroll Ledger SS 
Personal Budget SS 
Personal Budget 

Chapter 

2 
2 
4 
4 
4 
5 

Description of Example 

Word-processing 
Business letter 
Built-in function 
Table lookup 
Budget spreadsheet 
Pie and bar chart 
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File Name Type Chapter Description of Example 

My Dictionary DB 6 Basic database 
Inventory DB 6 Database report 
Super Clip Letter WP 7 Merging fields 
Acme's Customers DB 7 Database for merging 

fields 
New Orleans Guide WP 9 Desktop publishing 

(DTP) 
New Orleans Art WP 9 Art for DTP 
New Orleans Text WP 9 Text for DTP 
Acme's Stockholders DB 10 Database for 

application 
integration 

G.2 SELECTED ANSWERS FOLDER 

This folder contains answers to selected problems from the Posers, 
Problems, and Projects section that ends each chapter. The files 
show the completed answers to the problems and should be used 
only when you are stumped: no cheating! 

File Name Type Chapter Description of Problem 

Ch. 3, Problem 1 WP 3 Drawing 
Ch. 4, Problem 4 SS 4 Spreadsheet 
Ch. 5, Problems 2, 3, 4 SS 5 Pie chart 

Bar chart 
Bar chart 

Ch. 6, Problem 2 DB 6 Database 
Ch. 7, Problem 1 WP 7 Mailing labels 

G.3 WORKS COMMAND REFERENCE 

The Works Command Reference file is a HyperCard stack giving 
you the information in Appendices A, B. C, D. E. F, K, and Min 
interactive form. To run the Works Command Reference you will 
need the HyperCard application that came with the Macintosh 
you 're using. 

If you have two floppy disk drives on your Macintosh, start up 
the Mac with the HyperCard start-up diskette. Insert the Supple­
mental Diskette in the empty disk drive. Launch the Works Com­
mand Reference by double clicking on the icon. If you have a hard 
disk drive and HyperCard is not already on the disk, drag the 
HyperCard application icon from the HyperCard diskette onto the 
hard disk. Drag the Works Command Reference icon from the 



New .. . 
Open .. . 

Close 
Close Rll ... 
Saue 
Saue Rs .. . 
Delete .. . 
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Supplemental Diskette onto the hard disk. Launch the Works 
Command Reference by double clicking on the icon. 

Once the Works Command Reference has been launched, you 
can pull down any Works menu from any Works application. The 
menu will remain on the screen while you scroll through brief 
descriptions of the available commands in the text window (see 
Figure G. l). If you choose a menu item with the mouse, the 
corresponding dialog box or submenu is displayed. 

3€0 

3CS 

New ... 

Creates a New file of any Works application type. A 
dialog box lets you select between "WOrd-processing, 
database, spreadsheet or communications files . 

Open ... 

Opens an existing 'W'Ord processing file to be edited 
or added to. A dialog box lets you select files and 
disks. 

Make Works Desktop ... 

Page Setup ... 
Print ... 
Print Window 
Eject Page 
Print Merge ... 

Quit 

3CP 

Close 

Closes the active file window. If the file has been 
change~ but not saved, a warning and an option for 
saving the file will appear in a dialog box. 

Close All... 

Closes all the file windows. for each file that has 
been chan ed but not saved a warnin and an 

Figure G.1. HyperCard Works Command Reference Stack 

G.4 COMMUNICATIONS SIMULATION 

The Communications Simulation file is also a HyperCard stack. 
This stack is a simulated Works communications session for those 
of you who lack access to a modem or an information service. It 
simulates logging on to the Loyola University Library's on-line 
catalog system. You can complete the simulation (Problem 5 in 
Chapter 8) by following the directions in Appendix J. 



absolute cell 
reference: 

active cell: 
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GLOSSARY 

A reference to a specific cell in a formula in the spreadsheet. The 
cell reference will not be affected by copying, moving, or filling. 
In the spreadsheet, the most recently selected cell, designated by 
a highlighted box. 

active window: The most recently selected window, appearing in the foreground 
in front of any other open window. 

baud: The speed at which data are transmitted between two computers. 
Baud is measured in bits per second. 

bit: A Binary digiT. The smallest memory component that stores a 1 
or 0. Eight bits combine to form a byte. 

boolean 
operators: 

booting: 
bug: 
byte: 

cell: 

center 
justification: 

central 
processing unit 

(CPU): 

Operators, including AND and OR, that are used to test the truth 
of logical expressions on a computer. 
Starting up a computer ("She booted her Macintosh"). 
An error in a computer program. 
The amount of memory necessary to store one alphabetic, nu­
meric, or punctuation character. A byte comprises eight bits. 
The functional component of a spreadsheet, in which values, 
labels, or formulas are stored. 
An alignment of text centered between the margins. 

The main hardware component of a computer system, processing 
instructions provided by software. 

chip: A slang term for integrated circuit, or IC. 
clip art: Professional drawings, borders, and other art available on dis­

kette that can be used to enhance newsletters, flyers, and other 
documents. 

Clipboard: A temporary storage area used when cutting or copying text and 
graphics. 
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close box: 

copying: 

cursor: 

cutting: 

data bits: 

debugging: 
desktop 

publlshlng: 

digitizing: 

double cllcklng: 

dragging: 

emulating: 

field: 

flle: 

fllllng down: 

fllllng right: 

finding: 

The small box in the upper left-hand comer of a window. Pointing 
to and clicking in this box with the mouse will close the window. 
Copying selected text or graphics from a document to the Cllp­
board. The contents of the Clipboard can later be pasted into a 
different location or document without deleting the text or graph­
ics from the original. 
The indicator on the screen that is controlled by the mouse. The 
cursor will take different shapes (an arrow, hand, I-bar, pencil, 
and so on), depending on the software and current function. 
Removing selected text or graphics from a document and placing 
in the Clipboard. The contents of the Clipboard can later be 
pasted into a different location or document. 
The number of bits used to transmit data between two computers 
(either seven or eight, depending on the host computer). 
Locating and correcting bugs (errors) in computer software. 
The use of microcomputers and laser printers to produce camera­
ready copy for in-house publications. The result is a professional­
looking publication in less time, at less cost. 
Converting a drawing or photograph to binary data capable of 
being stored and displayed on a computer. 
Pressing the mouse button twice. Double clicking on an icon 
opens the file or launches the application. 
Moving an object on the computer's screen by pointing to the 
object, clicking and holding down the mouse button. and rolling 
the mouse. 
Duplicating the function of another computer device with soft­
ware. For example, the Works communications appllcation emu-
lates a VTlOO terminal. 
The smallest data component of a database. A database is com­
posed of records containing data fields. 
A document stored on a computer disk. The document may 
contain word-processing, spreadsheet, database. graphics, or 
other types of data. 
Copying the contents (values, labels, or formulas) from a spread­
sheet cell or cells to directly below. 
Copying the contents (values, labels. or formulas) of a spread­
sheet cell or cells to those immediately to its right. 
Locating specific text in a document, usually to locate and then 
replace text (Find and Replace). 

flat file database: A nonrelational database file that contains the same number of 
fields for each record in the database and is not linked with any 
other file. 
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font: A typeface, or style of type, such as Geneva or Times. 
formatting: Initially preparing a blank diskette to be used on a computer (also 

known as initializing). 
function: A built-in calculation that can be used in a formula in the spread­

sheet or a computed field in the database. Many functions are 
available that perform mathematical, trigonometric, statistical, 

handles: 

host: 

icon: 

inputting: 

integrated 
circuit (IC): 

integrated 
program: 

justification: 

laser printer: 

left justification: 
logging on: 

mainframe: 

menu bar: 

microcomputer: 

minicomputer: 

modem: 

logical, date-and-time, and financial calculations. 
Small squares that appear on a draw object when it's selected. 
The handles can be dragged on to change the size of the object. 
A computer that responds to the inquiries of a terminal device (a 
microcomputer plus modem). Usually the host computer is a 
mainframe or minicomputer that makes information available to a 
large number of users. 
A graphic representation of a document, application, or function. 
For example, the trash can icon represents the function of delet­
ing (throwing away) a file. 
Providing data from peripheral devices to the central processing 
unit (opposite of outputting). 
A very small electronic circuit that provides the equivalent of 
hundreds to millions of transistors. 
A computer program having features of several different applica­
tions and allowing them to work as one program and easily share 
information. 
An alignment of text spaced equally between the margins so that 
it aligns both left and right. It is used to create columns of text, as 
in newspapers. 
A printer that uses laser technology to print high-quality text and 
graphics on plain paper. 
An alignment of text along the left margin. 
Accessing a host computer by dialing the modem and entering an 
account number and password. 
A large-scale computer system that can process and store a large 
amount of data very rapidly. 
A bar at the top of the screen that contains a list of the major 
commands available in the software. 
A small desktop computer system used as a tool for personal 
productivity. 
A medium-sized computer system used for applications requiring 
more processing power than a microcomputer but less than a 
mainframe. 
A peripheral device that Modulates (converts) computer data 
into voice signals that can be transmitted over standard tele-
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moving: 

object 
oriented: 

on-line: 

opening: 

optical scanner: 

outputting: 

pasting: 

pixels: 

pointing and 
clicking: 

point: 
presentation 

graphics: 

programming: 

protocol: 

RAM: 

record: 

relational 
database: 

relative cell 
reference: 

phone lines to another computer. The receiving modem then 
DEModulates the voice signals back into computer data. 

Cutting and pasting data from one location in a document to 
another location in the same document. 
A feature of some graphics programs that stores the graphic data 
(drawings) as objects rather than as individual dots (pixels). 

Connected to a host computer ("He is on-line to CompuServe"). 

Making an existing file accessible for editing or revision. 

A peripheral device that digitizes text and graphics for storage 
and display on a computer. 

Moving data from the central processing unit to peripheral de­
vices (opposite of inputting). 

Copying the contents (text or graphics) of the Clipboard to a 
document. The contents will be pasted at the location of the 
cursor. The contents of the Clipboard are not erased and can be 
pasted again. 
The smallest unit on the computer's screen: individual dots that 
make up the text and graphics. 

Rolling the mouse to move the cursor to a location, icon, or object 
on the screen and then pressing the mouse button. 
A measurement of the size of text. There are 72 points per inch. 

Charts and graphs prepared with the aid of a computer and used 
primarily for business presentations. 

Designing a spreadsheet to perform a specific function ("She 
programmed the spreadsheet to calculate her income tax"). 

The rules each computer follows when transmitting information 
to another. The protocol establishes the way data will be trans­
mitted. 
Random Access Memory: a memory chip used as primary storage 
in a microcomputer system. This memory can be written to and 
read from and only functions when the computer is turned on. 
The component of a database that is made up of a collection of 
fields. For example, each record in a customer database would 
represent a customer, and the fields would contain information 
about that customer. 

A database that contains fields having linkages or relationships to 
fields in another database (opposite of a flat file database). 
A reference to a relative cell location in a formula in the spread­
sheet. The relative cell reference will be adjusted as appropriate 
by copying, moving, or filling. 
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replacing: Exchanging new text for old text once the old has been located in 
a document using the Find feature. 

right justification: An alignment of text along the right margin. 
ROM: Read Only Memory: a memory chip on which program instruc­

tions have been stored by the manufacturer. These instructions 
cannot be erased. 

saving: Recording data stored in temporary memory onto a permanent file 
on disk. 

Scrapbook: A permanent storage area used to collect data when cutting or 
copying text and graphics. It is used in conjunction with the 
Clipboard when copying multiple items. 

scrolling: Moving the contents of a window either up and down or left and 
right to view all the contents. The scroll bars and scroll box 
perform this function. 

scroll bar: The bar at the bottom right area of a window that controls the 
scrolling of the data in the window. Clicking on the appropriate 
arrow in the scroll bar will move the data up, down, left, or right 
within the window. 

scroll box: The box inside the scroll bar that indicates the position of the 
data in the window relative to the entire contents of the document 
or file. Dragging on the scroll box will also scroll the data in the 
window. 

size box: The small box in the lower right-hand corner of a window. Drag­
ging on this box with the mouse will change the vertical and 
horizontal size of the window. 

sorting: Arranging data in alphabetical, numerical, or chronological order. 
stop bits: The number of bits used to separate the data bits in a transmis­

sion between two computers. Either one or two stop bits are used, 
depending on the host computer. 

system folder: The folder located on a start-up disk that contains the operating 
system files. 

terminal: A device used to communicate with a host computer. 
timeshare: A type of mainframe and minicomputer operating system that 

allows multiple users to gain access to the computer and share 
processing time on it. 

title bar: A bar at the top of a window that contains the name of the docu­
ment, file. or window. The title bar can be dragged on with the 
mouse to relocate the window on the screen. 

undoing: Erasing the immediately preceding action. The Undo command in 
the Edit menu offers this option to reverse your mistakes. 

user: A person using a computer. 
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white space: Blank space in a publication or other printed matter used to 
provide an artistic effect. 

window: A rectangle on the computer screen used to display the active 
contents of a file or document. The size and location of the win­
dow can be changed and its contents scrolled. Multiple windows 
can be open on the screen at the same time. 

word wrap: A feature that automatically moves a word to the beginning of a 
new line of text when ifs too long to fit within the margins. 

WYSIWYG: What You See Is What You Get: the feature that allows you to see 
on the screen exactly what will be printed on the printer. 

zoom box: The small box in the upper right-hand comer of a window. Point­
ing to and clicking in this box with the mouse will expand (zoom) 
the window to fit the Macintosh screen. Once you·ve zoomed the 
material. clicking again will reduce the window to its previous size 
and location. 
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SPECIAL KEYS 

There are four Macintosh keyboards: the Macintosh Plus key­
board, the Apple standard keyboard, the Apple extended keyboard, 
and the Macintosh Classic keyboard. In addition to normal type­
writer keys, a number of special keys appear on the Macintosh 
keyboards (see Figures 1.1, 1.2, 1.3, and 1.4). This appendix de­
scribes the functions of those special keys. 

For more information about special keys, see the Macintosh 
System Software User's Guide that came with the Macintosh 
you're using. 

1.1 SPECIAL KEYS COMMON TO ALL KEYBOARDS 

Tab 
Moves the cursor horizontally to the next tab stop in the word 
processor, the next cell in the spreadsheet, or the next field in the 
database. The Tab key also moves the cursor to the next data entry 
field in a dialog box. 

Caps Lock 
Locks the keyboard into the uppercase mode for letters only. 
Numbers and punctuation symbols are not affected by the Caps 
Lock key. 

Shift 
Produces, in combination with a letter or number key, the upper­
case letter or the upper character printed on the key. For example, 
holding down the Shift key and pressing the 4 key will produce a 
dollar sign ($). 

Option 
Produces, in combination with other keys on the keyboard, spe­
cial characters or special functions. Most fonts have a variety of 
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Tab Delete 

Return 

Shift 

Up Arrow 

Option Command Left Arrow Right Arrow Down Arrow 

Clear 

u--;-+-~-:-+i-r--~--+--:-11'1i lia--__ Numeric Keypad 

4 

: ~ + .... 1 ·~1 __ Enter 

0 -,, 

Figure 1.1. Macintosh Plus Keyboard's Special Keys 

symbols that can be typed by holding down the Option key while 
pressing a letter or number key. For example, the Option key and 
the R key produces the registered trademark symbol(®) in many 
fonts. 

Command~ 
Offers, when used in combination with another key, a shortcut to 
choosing a menu command or dialog box function. For example, 
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holding down the Command key and pressing the S key duplicates 
the function of the Save command in the File menu and will save 
the current document. 

Delete/Backspace 
Deletes the character to the left of the cursor. The Delete key can 
also be used to delete selected (highlighted) text and draw objects. 
The Backspace key on the Macintosh Plus keyboard serves the 
same function. 

Return 
Sends the cursor to the beginning of the next line and signals the 
beginning of a new paragraph in the word processor. In the 
spreadsheet and database, the Return key signals the end of text 
in a cell or field. In a dialog box, the Return key performs the same 
function as clicking on the outlined (default) button. 

Arrow Keys 
Move the cursor up, down, left, or right as an alternative to using 
the mouse. 

Numeric Key Pad 
The arrangement of the keys on the numeric keypad matches that 
of a desk calculator. They can be used in place of the number and 
arithmetic operator keys on the main keyboard to speed data entry 
when typing numbers and formulas. 

Clear 
Clears the calculator desk accessory under the Apple menu. In 
Works, the Clear key functions as the PFl key when you're emu­
lating a vn 00 in the communications application. In other appli­
cations, the Clear key may or may not serve a function. 

Enter 
Performs the same function as the Return key. However, the cur­
sor is not advanced to the next cell in the spreadsheet application. 
In the communications application, the Enter key has special 
functions in interaction with some host computers. 

1.2 SPECIAL KEYS COMMON TO THE 
APPLE STANDARD, APPLE EXTENDED, 
AND MACINTOSH CLASSIC KEYBOARDS 

Power 
Tums on the computer (on the Macintosh II only). Choose Shut 
Down from the Special menu to tum off the computer. 
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Esc Power 

Tab Delete 

Control Return 

Shift 

Option Command Left Arrow Right Arrow Down Arrow 

Clear 

Numeric Keypad 

Figure 1.2. Apple Standard Keyboard's Special Keys 
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Power 

Tab Delete 

Caps'Lock Return 
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Option Command Escape Left 
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Figure 1.4. Macintosh Classic Keyboard's Special Keys 
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Esc 
Esc stands for Escape. This key has a variety of functions. but 
only with certain software. In the Works communications applica­
tion the Esc key has special functions. depending on the host 
computer. 

Control 
Works in combination with other keys to provide shortcuts, as 
does the Command key. In the communications application the 
Control key is used in combination with other keys for various 
special functions, depending on the host computer. 

1.3 SPECIAL KEYS UNIQUE TO THE 
APPLE E~ENDED KEY~OARD 

Function Keys (F1 through F15) 
The 15 function keys' are used 41 the communications application 
to wprk With host compµters tunning UNIX or IB~ 'operating 
systems. These keys ·are also· 1.i&ed with special Macintosh pro­
grams that emulate the ~S-DOS operating system ~sed on IBM 
personal computers. Ttiey can also be used with the Macro menu 
to define Wor~s ~acros. 

MS DOS Keys 
These special keys are used o~ly witjl alternative operating sys­
tems like· MS DOS. Their function varies according to the applica­
tion. They have no function in Works. 
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HYPERCARD 
COMMUNICATIONS 

SIMULATION 

The Communications Simulation file is a HyperCard stack located 
on the Supplemental Diskette (see Appendix G). To run the simu­
lation you will need the HyperCard application that came with the 
Macintosh you're using. This stack is a simulated Works commu­
nications session for those of you who lack access to a modem or 
an information service. It simulates logging on to the Loyola Uni­
versity Library's on-line catalog system. You can complete the 
simulation (Problem 5 in Chapter 8) by following the directions 
here. 

The steps you're about to take are identical to the real-life 
process of using Works communications application. However, if 
you make a mistake the simulation will print a warning on the 
screen telling you what it was. You must correct the mistake before 
continuing. Only general directions are provided here; you should 
review Chapter 8 to determine which settings to change and to 
review the process for logging on. 

Directions 
If you have two floppy disk drives. start up the Macintosh with the 
HyperCard start-up diskette. Insert the Supplemental Diskette in 
the empty disk drive. Launch the Communications Simulation by 
double clicking on the icon. If you have a hard disk drive and 
HyperCard is not already on the disk, drag the HyperCard applica­
tion icon from the HyperCard diskette onto the hard disk. Drag the 
Communications Simulation icon from the Supplemental Diskette 
onto the hard disk. Launch the Communications Simulation by 
double clicking on the icon. 

1. Open a new communications file. The Settings dialog box will 
appear. 

2. The Loyola University Library on-line catalog (LUCI) requires 
the following communications protocol: 
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Terminal Type 
Baud Rate 
Data Bits 
Stop Bits 
Parity 

VflOO 
1200 
7 
1 
Odd 

In our example, we do not want to capture the text when the 
document opens; adjust the settings in the dialog box appro­
priately. 

3. Choose Echo Off from the Communications window. 
4. Choose Dial from the Communications window. Enter Loyola 

in the Name field and 865-3990 in the Phone Number field. 
Click the appropriate Dial button. 

5. Listen for the modem. When the connection is complete, the 
following text will appear in the Communications window: 

CONNECT 1200 
GANDALF PACX 2000 
SERVICE? 

Type LUCI and press the Return key. 
6. The LUCI welcome menu will appear. Read the directions on 

the screen carefully. Do a subject search by typing the num­
ber 1. Enter Macintosh as the subject to be searched. Press 
the Enter key to initiate the search. 

7. The next screen indicates that there are 36 references found 
for Macintosh. Type the number 1 to see a list of the refer­
ences. Review the references by pressing the N key (for Next 
screen) or the P key (for Previous) until you find a book titled 
Personal Publishing with the Macintosh. Review the full cita­
tion for this book by typing the number 8. Check to see 
whether it is on the library's shelf by pressing the C key. 

8. Press the S key to return to the main LUCI menu. 
9. Do an author search by typing the number 2. Enter Nickles, 

Herbert as the author to be searched. Press the Enter key to 
initiate the search. The full entry for The Practical Apple will 
appear on the screen. 

10. To end the communications session, choose Hang Up from 
the Communications menu and then Quit from the File menu. 
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USING THE 
MACRO MENU 

A macro is a recorded set of mouse and keyboard actions stored in 
a macro file on disk. A macro can be played back at any time to 
recreate the original mouse and keyboard commands. This Works 
feature lets you safeguard against errors in repetitive tasks, create 
shortcuts for frequently performed functions, and perform com­
plex Works commands even if you are new to the system. 

One key on the keyboard is associated with each macro. Play­
ing back the macro is as simple as holding down the Option key 
and pressing the appropriate companion key. Perhaps you always 
end your correspondence with Sincerely Yours, followed by your 
name and title. Instead of typing this hundreds of times a year, 
you can record the keyboard actions in a macro and associate the 
C key with it. To end your future correspondence, you just press 
the C key while holding down the Option key. Works will type in 
the exact text and spacing for you. 

Mouse commands are also recorded in sequence along with 
keyboard actions in a macro. You can change fonts or styles. or 
perform any other feature accessible from the Menu Bar with the 
mouse. You can even cue Draw On and quickly add boxes, shad­
ing. or other graphics to a document. In the spreadsheet, you can 
record a macro to automatically draw a chart; in the database you 
can sort, select records, and print a report with a macro. As you 
can imagine, the macro feature can become a very powerful pro­
ductivity tool once you've mastered it. 

K.1 RECORDING A MACRO 

A few simple steps must be followed in recording a macro. 

1. Choose Macro On from the Macro menu, if it is not already 
checked. 

2. Choose Start Recording from the Macro menu. 
3. Type the key you want to associate with the macro. 
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Helpful Hint: You can use any key, including the function keys (Fl through F15) · 
on the Macintosh extended keyboard, with the following exceptions: 
accent keys (e, i, ft, ii, and e), Shift, Option, Command, Caps Lock, 
Delete, Backspace, ·, =. -, +, and _. 

4. Press the Tab key and enter a short description of the macro. 
5. Click on the Record button. 
6. Perform the function you wish to record, using the mouse and 

the keyboard in the normal way. 

Helpful Hint: Certain mouse actions should not be used when recording a macro 
because they may not play back properly. These include drawing 
with the Freehand tool in the draw mode and using scroll bars, 
scroll boxes, and scroll arrows. 

7. When the function has been completed, choose Stop Recording 
from the Macro menu. When the Stop Recording dialog box is 
displayed, click on the Stop button. 

K.2 PLAYING BACK A MACRO 

Once a macro has been recorded it can be played back at any time, 
in any window, and at any location in the window. There are three 
ways to play back a macro. 

1. Check Macros On in the Macro menu, if it is not already 
checked. 

2. Choose Playback And from the Macro menu. 
3. The Playback dialog box will display a list of available macros. 

Select the desired macro with the mouse or type the associated 
key. 

4. Click on the Play button. Works will execute the macro exactly 
as you recorded it. 

OR 

1. Check Macros On in the Macro menu, if it is not already 
checked. 

2. Choose Playback And from the Macro menu. 
3. The Playback dialog box will display a list of available macros. 
4. Double click on the desired macro. Works will execute the 

macro exactly as you recorded it. 

OR 

1. Check Macros On in the Macro menu, if it is not already 
checked. 
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2. In your document, hold down the Option key and press the key 
associated with the desired macro. Works will execute the 
macro exactly as you recorded it. 

K.3 HANDLING MACRO FILES 

When the Macros On command is chosen from the Macro menu, 
Works automatically opens the default macro file, Microsoft 
Works(keys). If this file is not on the same disk as the Works 
program, a new Microsoft Works(keys) file is created. When a macro 
is recorded, the Stop Recording command saves the macro to the 
Microsoft Works(keys) macro file. Consequently, macros are not 
associated with a particular spreadsheet, word-processing, or da­
tabase file. Rather, they are associated with the user, who can 
build a macro file for customized functions in several applications. 

If you wish to store macros in a macro file other than Microsoft 
Works(keys}, use the Open Macro File, Save Macro File, and Save 
Macro File As commands in the Macro menu. These commands 
resemble the normal Open, Save, and Save As commands in the 
File menu, but they work only with the current macro file. 

K.4 SUMMARY OF MACRO MENU COMMANDS 

Macros On 
Turns on the macro feature in Works and opens the default macro 
file, Microsoft Works(keys). If the Microsoft Works(keys) file is not on 
the Works disk, a new Microsoft Works(keys) file is opened. A check 
mark (.,/) indicates that the option is in effect. 

Macros Off 
Turns off the macro feature. Choosing this command does not save 
the current macro file. A check mark (Y"") indicates that the option 
is in effect. 

Playback And ... 
Plays back previously recorded macros. The Playback dialog box 
lets you select the desired macro and play it back using the Play 
button. The dialog box also lets you maintain macro files. Macro 
files can be opened, saved, and renamed (Save As); individual 
macros can be deleted from or added to any macro file. 

Start Recording ... 
Starts the recording of mouse and keyboard commands. A dialog 
box lets you describe the new macro and assign a key to it. When 
you want to play back the macro, hold down the assigned key 
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Macros On 
Macros Off 

Playback And ... 

Start Recording .. . 
Stop Recording .. . 

Record Pauses 

Open Macro File ... 
Saue Macro File 
Saue Macro File As ... 

simultaneously with the Option key to initiate it. The following 
keys cannot be associated with a macro: accent keys (e, i, ii, ii, and 
e), Shift, Option, Command, Caps Lock, Delete, Backspace,',=, -, 
+,and_. 

Stop Recording ... 
Stops the recording of mouse and keyboard commands and saves 
the recorded macro to the macro file. Dialog box options let you go 
back and record previous delays, record future delays, and/ or 
continue recording. 

Record Pauses 
Records all pauses and delays along with the mouse and keyboard 
commands. Works plays back a macro as fast as possible, making 
it difficult to see what is happening on the screen. Recording 
pauses in the macro will slow down the playback to the speed at 
which it was recorded. A check mark (.._/') indicates that the option 
is in effect. 

Open Macro File ... 
Opens a new or existing macro file and its associated macros. A 
dialog box lets you select files and disks. 

Save Macro File 
Saves the open macro file to the disk. If the file has not been saved 
previously, a dialog box requires that a file name be entered and 
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provides options for changing disks. If the file has been named 
previously, the current file will be saved over the original file with 
the same file name. 

Save Macro File As ... 
Saves the open macro file with a new file name. The original file is 
kept intact. A dialog box lets you enter the new file name and 
change disks. 
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USING THE DESK 
ACCESSORIES 

The Macintosh desk accessories are utilities that can be chosen in 
the Apple menu. located at the far left of the Menu Bar. This menu 
is available from all Macintosh applications. For example. the 
calculator can be used from the Works word processor. MacWrite. 
MacDraw. or any other Macintosh program. 

Rbout the Finder ... 

Calculator 
Chooser 
Control Panel 
Find File 
Key Caps 
Scrapbook 

The Desk Accessories reside in the Macintosh system file on 
the start-up disk. You can add or remove desk accessories from 
the system file using the Font/DA Mover (see Appendix M). 

For more information about individual desk accessories, see 
the Macintosh System Software User's Guide that came with the 
Macintosh computer you're using. 

L.1 ABOUT THE FINDER ... 

When you choose this command. you'll see a window containing 
information about the Finder. The version of the Finder and the 
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~D -· About the Macintosh™ Finder 

Finder: 6.1 Larrg ~ John~ Steve~ .and Bruce 
Sgstem: 6.0.3 0 App le Computer~ Inc. 1983-88 

Total Hemorg : 1 ,024K 

~ F;nder 731K -:::::::::::::::::::::::::::::::::::::::::::::::::::1 

~System 293K -
system files, the total memory available, and the amount of memory 
used by the Finder and the System are displayed. Use the close 
box to close the About the Finder window. 

L.2 CALCULATOR 

D Calculator 

A standard calculator appears on the screen wheh you choose the 
Calculator from the Apple menu. This desk accessory is used like 
a normal hand-held calculator. Use the mouse to point to and 
click on the calculator keys or use the corresponding keys on the 
keyboard. The C key clears the Calculator's display and the = 
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(equals) key displays the result of the calculation. For example, to 
add the numbers 9 and 4 press the C key followed by the 9 key, the 
+key, the 4 key, and the= key. 

L.3 CHOOSER 

The Chooser lets you select among available peripheral and net­
work devices such as printers, file servers, and modems. Accessible 
from the Apple menu, the Chooser's dialog box displays icons 
representing all available devices attached to the Macintosh-or to 
the network, if your Macintosh is connected to an AppleTalk net­
work. Select the device you want by pointing to and clicking on its 
icon· with the mouse. If more than one device of that type is 
available, you can select the appropriate one from the displayed 
list. The Chooser can also be used to connect the Mac with or 
disconnect it from an AppleTalk network. Chooser selections go 
into effect when the Chooser window is closed. 

In the first screen that follows, the ImageWriter printer icon was 
selected. The user also had to specify whether the printer were 
attached to the printer port or the telephone modem port. 

=D 

~ ~. 
App le Share App le Talk I ... 

a. ::! 
iill@&MM LaserWriter 

Chooser 
Select a printer port: 

User Name: 

Appl eTal k 
®Active 
0 Inactive 

3.3.1 
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-D Chooser 

~ ~' 
Select a LaserWri ter: 
L;:i:::er-v./ri ter 11 NT :B 

App leShare App le Talk I ... 
Faclab 

~ --~ . .::I 
lmage'Wr;ter 14@HM 

Background Printing: O On® Dtf 

User Name: 
r·-·1ichelle 

AppleTalk ®Active 
0 Inactive 

3.3.1 

In the second screen, the user wished to print on a LaserWriter 
printer attached to an AppleTalk network. The LaserWriter icon 
was selected and the LaserWriter II NT printer selected from the 
LaserWriter printers available on the network. AppleTalk must be 
Active to print on a network printer. 

L.4 CONTROL PANEL 

The Control Panel lets you control aspects of many Macintosh 
features, such as the keyboard, mouse, monitor, desktop, and 
speaker. The Control Panel window displays a scrolling field of 
icons representing those features. When an icon is selected with 
the mouse, its settings are displayed on the Control Panel. The 
General icon lets you change the desktop pattern, the cursor's and 
menus' blinking rate, the time and date, and the speaker volume. 
You change the current settings by pointing and clicking with the 
mouse on the buttons provided. 

You can customize the Control Panel by modifying the system 
folder on the start-up diskette. For further information, see the 



• -@MM! 

Keyboard 

... ""). 

[OJ 
Mouse 

Sound 

3.3.1 

Control Panel 

• Desktop Pattern 

Menu Blinking Time (9 
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Rate of Insertion 
Point Blinking 

····I···· 
O@O 

Slow Fast 

4:46: 19 PM 
7 -
6-
5-
4 
3-
2-
1 -
0 -

@ 12hr. Q 24hr. 

0 O@O Date IIfiJ 
Off 1 2 3 

RAM Cache j 32K 

6/27/90 

I 11) 0 On 

@Off 

Speaker 
Volume 

Macintosh System Software User's Gui.de that came with the Mac 
you're using. 

L.5 FIND FILE 

The Find File command searches through the file names on a 
particular disk and lists all names containing the elicited text. The 
dialog box allows you to change disks by clicking on the disk 
name, to enter the target text in the Search for box, and to begin 
the search by clicking on the Search icon: 

Each file name containing the target text is printed in the Find 
File window. When one of these files is selected with the mouse, 
information pertaining to it is printed at the bottom of the window: 
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G::l Hard Disk 

Search for: 

1.3 

[) Works Desktop 

CJ Works Dictionary 

the folder that the ftle is located in, the ftle's creation date, its 
modification date, and its byt~ size. In the following example, all 
the files on the Hard Disk containing the word Works were found. 

Find File 

I ..___Work_s ___ ______.1 I 

Created: Fri, Feb 3, 1989; 8 :57 PM 'CS) MS Works 
G::l Hard Disk Modified: Fri, Mar 16, 1990; 5 :40 PM 

Size : 603804 bytes; 
591 Kon disk 

L.6 KEY CAPS 

The Key Caps command portrays the Macintosh keyboard. When a 
key is selected by the mouse or by typing a key on the keyboard, 
the corresponding letter, number, or symbol is typed in the Key 
Caps window. This lets you easily identify which keys print special 
characters. 

Key Caps 

= I 
8 g 

4 5 6 

1 2 3 

0 
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Most Macintosh fonts contain several special characters. For 
example, the following characters can be printed using the Helvetica 
font and holding down the Option key in conjunction with the 4, 5, 
7, R, and G keys, respectively: ¢ oo en ® © (see the Key Caps screen 
on the previous page). Holding down the Shift or Option key will 
display the special characters on the Key Caps simulated keyboard. 
Special characters in different fonts can be compared by choosing 
the desired font from the Key Caps menu in the Menu Bar. 

L.7 SCRAPBOOK 

The Scrapbook stores data from the Clipboard for use at a later 
time. Unlike the Clipboard, which can store only one item at a 
time, the Scrapbook stores multiple items-text, graphics, charts, 
and so on-until you remove them. The Edit menu commands Cut. 
Copy, and Paste are used to move items in and out of the Scrap­
book. Cut deletes an item from the Scrapbook and places it on the 
Clipboard; Copy duplicates an item on the Clipboard; and Paste 
copies an item from the Clipboard into the Scrapbook. A scroll bar 
at the bottom of the Scrapbook window controls which Scrapbook 
item is being selected. The following example shows a clip art 
graphic stored in the Scrapbook. See Section 7 .2.3 for more details 
on using the Scrapbook. 

§0 Scrapbook 
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USING THE 
FONT/DA MOVER 

The Font/DA Mover is a utility program used to add or remove 
fonts and desk accessories (DA's). Fonts reside in the system file 
located in the system folder on a Macintosh start-up disk. Because 
so many fonts are available, a utility program, the Font/DA Mover, 
was designed to move fonts into the System file from a font file. 
Desk accessories are other utilities accessible from all Macintosh 
applications (see Appendix L); they are handled by the Macintosh 
just as fonts are. Consequently. the Font/DA Mover must also be 
used to move a desk accessocy into the system file. The Font/DA 
Mover is found on the Utilities 2 diskette that came with the 
Macintosh you're using. 

M.1 STARTING THE FONT/DA MOVER 

The Macintosh should be started up using the start-up diskette on 
which you want the font or desk accessocy installed. For example, 
to add a font for use with Microsoft Works you should start up the 
Macintosh with the Works start-up diskette. If you wanted to use 
that font with other application programs, such as MacDraw or 
MacPaint, you would also have to install that font on their start-up 
diskettes. If you have a hard disk Macintosh. the font or desk 
accessory need only be installed on the hard disk. 

The Font/DA Mover is an application program, just like Mi­
crosoft Works. It is launched (started up) much as you launched 
Microsoft Works. 

I. Start up the Macintosh using the Works start-up diskette. 

Helpful Hint: If you have a hard disk drive, just turn on the Macintosh and skip 
to Step 2. 

2. Insert the Utilities 2 diskette into an empty floppy disk drive. 
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5 items 

3. If the Utilities 2 window in Figure M. l is not visible on the 
screen, open the Utilities 2 disk icon. 

4. Start the Font/DA Mover by double clicking on the Font/DA 
Mover icon (see Figure M. l). 

5. The Font/DA Mover dialog box should appear (see Figure M.2). 

697K in disk 

§0~ Font/ DR Mouer Folder ~t!l§ 

Apple Fil i 3 items 697K in disk 88K available Map 

00 

m~ 
lifflii!il&Mi 

Desk Accessories 

older 

C1JJ 
Fonts 

Figure M.1. Launching the Font/DA Mover from the System Utilities Disk 

M.2 INSTALLING A FONT IN THE SYSTEM FILE 

When the Font/DA Mover is launched, a list of the fonts in the 
system file of the start-up diskette is displayed on the left side of 
the window (see Figure M.2). This list can be scrolled to review the 
fonts currently in the system. To add a font. you must open the 
font file containing the desired font. A font file is simply a file that 
contains fonts. This file could be a system file on another start-up 
diskette, a commercially purchased font file, or a font file you've 
created as back-up storage. 

Click the Open button on the right side of the window. A dialog 
box will allow you to select the desired font file. In the example in 
Figure M.3, the file named Fonts on the Utilities 2 disk is used. 



@Font 
O Desk Accessory 

Au ant Garde 1 O 
Auant Garde 1 2 
Auant Garde 1 4 
Auant Garde 18 
Ruant Garde 24 
Bookman 1 O 
Bookman 12 

System 
on Hard Driue 
6310K free 

Help 

M.2 Installing a Font in the System File 319 

Mauer 

............. ~ ............. ~.~-~-~-~ ................................................ ~-~-~-~ .............................................. ~.~-~-~.:.:.: ...... ~ ........... . 

Figure M.2. The Font/DA Mover Dialog Box 

This file contains the standard Macintosh fonts provided by Apple 
Computer. When the font file has been opened, its contents are 
displayed in the scrolling field on the right side of the window. 

To copy a font from the font file into the system me. select the 
one you want from the font me (the list on the right in Figure M.3). 
A sample of the font will be printed at the bottom of the window 
and the amount of disk space needed will be printed between the 
two lists. (In the Figure M.3 example, the font chosen, London 18, 
needs 3,420 bytes.) The size of the font is important, because each 
font you add will increase the size of the system me. In some cases 
there may not be enough room on the diskette to install another 
font. The amount of free space available is indicated beneath the 
disk's name. 

You may also have noticed that several sizes of each font are 
available. The numbers after the font name indicate the point size 
of that font. Helvetica 14 is the Helvetica font in 14 points. For 
superior printing, you want as many sizes of a particular font as 
possible in your system file. However, some trade-offs must be 
made between maintaining a large selection of fonts and leaving 
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®Font 
O Desk Accessory 

Auont Garde 1 O 
Auont Garde 12 
Auont Garde 1 4 
Auont Garde 1 8 
Auont Garde 24 
Bookman 1 O 
Bookman 12 

System 
on Hord Disk 
4550K free 

( Close ) 

!~II 
«Copy« 

Remoue 

3420 bytes 
selected 

Help 

Quit 

Mauer 

Heluetico 14 
Heluetico 18 

Los Angeles 12 
Los Angeles 24 
Mobile 18 

Fonts 
on Utilities 2 

BOK free 

Close 

London 10: -Wbt (}Uick btobJtt fox jumps o\>tt tb 

Figure M.3. Copying a Font from a Font File into the System File 

enough space available on the start-up disk. If you require a large 
number of fonts and font sizes, you should use a hard disk 
Macintosh. 

Once you've chosen the font you want from the font file, click 
the Copy button to install it in the system file. Multiple fonts can 
be copied by holding down the Shift key while selecting the fonts: 
when the Copy button is clicked, evexy font selected will be copied. 
Additional fonts from other font files can be copied to the system 
by closing the font file and opening another. Click the Quit button 
to quit the Font/DA Mover. 

M.3 REMOVING A FONT FROM THE SYSTEM FILE 

To remove a font from the system file , select the desired font and 
click on the Remove button (see Figure M.4). 

Caution: Removing a font from the system folder deletes it permanently. 
Unless you have stored the font in another font file, you will not be 
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@Font 
0 Desk Accessory Mouer 

Auant Garde 1 o 
Auant Garde 12 

Bookman 1 O 
Bookman 12 

System 
on Hard Disk 
4550K free 

( Close 

[opq 

Remoue ;J 
4620 bytes 

selected 

Help 

Quit Open ... 

Athens 1 a: The quick brown fox jumps over the 

Figure M.4. Removing a Font from the System File 

able to add it back into the system. To create a back-up font file, 
click the Open button, create a New font file, Copy the desired font 
to the new file, and then Remove the font from the system file. 

M.4 INST ALLING A DESK ACCESSORY 
IN THE SYSTEM FILE 

Installing a desk accessory is similar to installing a font. When the 
Font/DA Mover is launched, the Font button is automatically 
selected at the top of the window (see Figure M.2) . Click the Desk 
Accessory button instead, and a list of the desk accessories cur­
rently installed in the system file will appear. To add a desk 
accessory (DA). open the file containing the DA you want. A DA file 
is simply a file that contains desk accessories . It could be a system 
file on another start-up diskette, a commercially purchased DA 
file, or a DA file you have created as back-up storage. 

Click the Open button on the right side of the window. A dialog 
box will a llow you to select the desired DA file. In the example in 
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O Font 
® Desk Accessory 

Mou er 

Calculator 
Chooser 
Control Panel 

System 
on Hard Disk 
4490K free 

( Close 

« Copy « l Alarm Clock 
~ Calculator 

Remoue ) 

11944 bytes 
selected 

Help 

Quit 

Desk Accessories 
on Utilities 2 

BOK free 

Close 

Figure M.5. Copying a Desk Accessory into the System File 

Figure M.5, the Desk Accessories file on the Utilities 2 disk is used. 
This file contains the standard Macintosh DA's provided by Apple 
Computer. When the DA file has been opened, its contents are 
displayed in the scrolling field on the right side of the window. 

To copy a DA from the DA file into the system file, select the DA 
you want from the DA file (the list on the right in Figure M.5). The 
amount of disk space needed will be printed between the two lists. 
(In the Figure M.5 example, the DA chosen, Find File, needs 
11 ,944 bytes.) The size of the DA is important, because each one 
you add will increase the size of the system file. 

Once you've chosen a DA from the DA ftle, click the Copy 
button to install the DA in the system file. Additional fonts from 
the same DA file or from other DA files can be copied to the system. 
Click on the Quit button to quit the Font/DA Mover. 

M.5 REMOVING A DESK ACCESSORY 
FROM THE SYSTEM FILE 

To remove a desk accessory from the system me, select the desired 
DA and click on the Remove button. 
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Caution: Removing a DA from the system folder deletes it permanently. 
Unless you stored the DA in another DA file, you will not be able to 
add it back into the system. To create a back-up DA file, click the 
Open button, create a New DA file, Copy the desired DA to the new 
file, and then Remove the DA from the System file. 

For more information on the use of the Font/DA Mover, see the 
Macintosh Utilities User's Guide, published by Apple Computer and 
included with each Macintosh computer. 
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