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Preface to the Second Edition

In the 17 months since the first edition, a flood of new Macintosh
products has appeared. To cope with the flood, this second edition has
much new and greatly revised material:

* Software and hardware developments in all areas.

* A dot-matrix printer comparison, including speed and
printing resolution measurements.

* How the LaserWriter and its PostScript graphics language
processor works.

* A chapter on graphic arts, including information on scan-
ners and typography.

* Expanded discussion of programming languages, including
a comparative programming example in 16 languages.

* A comparison of the Macintosh design strategy versus the
IBM PC-AT.

* Expanded coverage of communications.

* Networks and AppleTalk.

* The Technical Topics chapter, now with wiring information
for all ports, internal display adjustments, an annotated list
of system error messages, and an explanation of why the
Macintosh should not be operated above 15,000 feet—and
what to do about it.

The first edition included much introductory material for readers
who might not have even seen a Macintosh. To save space in this sec-
ond edition, I have shortened the introductory portions and elimi-
nated most material that can be found in Apple’s manuals.

Although I describe many specific products, my main goals are to
explain how and why things work—or don’t work—and to discuss
future developments. Because the future will bring many improve-
ments, I use stringent standards, standards that will not suffer from
inflation. In printer resolution, for example, I consider the Image-
writer in its “high resolution” mode to be low resolution (very low
resolution in standard mode), and the LaserWriter to be medium reso-
lution. Everyone should understand that, at present, only typesetting
equipment is capable of quality printing; everything else is a compro-
mise. In graphics, as in all areas, computers should make things better,
not merely easier.

Cary Lu

July 1985
Boston, Massachusetts
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INTRODUCTION

More than any other computer, the Macintosh has changed peo-
ple’s minds about how these machines should work. It is the first
widely used computer that does not force us to change our language
and work habits for its sake. Learning to use the Macintosh does re-
quire some practice, but since most steps are analogous to the way we
already work, learning is quick and easy.

The Macintosh is a visual computer, one operated as much with
symbols and pictures as with words. The ideas behind it were orig-
inally developed at XEROX’s Palo Alto Research Center and, in 1981,
led to the landmark XEROX Star, the first commercial computer
with a visual interface. Apple’s Lisa, launched in 1983, brought the
price of such machines below $10,000—much less than the Star, but
still too high for most individuals and many businesses. Now the
Macintosh offers a visual interface for considerably less, enabling
many more people to enjoy its benefits.

In fact, the advantages of a visual interface are so compelling that all
future microcomputers will have one. Macintosh imitations are al-
ready appearing and, by 1986, graphic Mac-style software will be
available for the IBM Personal Computer AT. (The PC and PC-XT
will also have such programs, but these older machines lack the com-
puting horsepower to run visual software effectively.)

Before the Macintosh, even people who liked computers accepted
an initial period of suffering before they became productive or had
any fun. Not so with the Mac. Whether you’re new to computers or
an old hand, Mac’s visual technology means those periods of frustra-
tion are over.

HOW TO USE THIS BOOK

xvi

This book is not intended to be read straight through. Instead, it is
divided into four main sections. The brief opening section, Chapters 1
and 2, introduces you to the Mac and describes its basic operations.
You can skip these two chapters if you already have a Macintosh.

The second section, Chapters 3 through 10, describes specific types
of software. You need not read these chapters in order; just read about
the programs that interest you. If you are already using a Mac, you
may also want to pass over the introductory sections in some chapters
and concentrate on the software comparisons. Although I have kept
technical jargon to a minimum in these chapters, some terms are un-
avoidable. Check the glossary for definitions of any you don’t under-
stand, or read Chapter 11 for full explanations.



Computers Should Work Like People

The third section, beginning with Chapter 11, takes up each part of
the Macintosh in detail, explaining how each component works and
interacts with the others. This section also describes the inner work-
ings of Mac software. Other topics include graphic arts, maintenance,
the Macintosh versus the IBM PC-AT, and future developments.

Section Four is for those interested in specialized topics, such as
photography and advanced communications techniques, including
AppleTalk.

A glossary and an index complete the book.

In my comments, I list the version number of the product that I
looked at. Many products will change in time, adding new features, so
some comments may no longer apply. Products that were substantially
complete but not yet available for sale when I wrote about them are de-
scribed as pre-release. Products in the planning stage but not neces-
sarily operational are described as “The Acme Company plans to re-
lease. . .,” or “The Beta company has announced. . . .”

Some of the products described here may not be available and oth-
ers will have been superseded by better products. A few companies
mentioned here were technically operating in bankruptcy as I wrote
this. Use this book as a guide, but check with magazines and user
groups for the latest information.

xvii









Getting

Acquainted

ill you save time using a computer? Maybe. In many
situations, the time savings with a computer are surprisingly hard to
measure. Often the total amount of work remains much the same, be-
cause any potential time savings are lost in redoing and polishing your
first effort. When you typed a memo on a typewriter, you probably
didn’t bother to retype it for small errors; you simply wrote a correc-
tion in the margin. With a computer, you will be tempted to edit the
memo and reprint it—several times. The results are probably cleaner,
but did you save time?

Sometimes a computer is too easy to use. You can fiddle with num-
bers so effortlessly that their underlying meaning can become ob-
scured. In contrast, if you must work through the numbers by hand,
on paper, you may start more carefully, choosing realistic figures for a
financial projection.

For some tasks, computers do save time; performing many repeti-
tive calculations or maintaining complex inventory lists, for example,
are best done with a computer.

?hapter



SECTION ONE: IN THE BEGINNING

HOW MUCH DO YOU NEED TO LEARN?

WHAT YOU NEED

Depending on your situation, you may only need to learn a single
program—a word processor, perhaps. And you may not even need to
learn everything about that program. As you become more comfort-
able with Mac, you’ll probably want to learn more, but set your own
pace. Learn only as much as you want, when you need to.

Whatever you do, though, don’t just read this or other books; get a
Mac and use it.

When you buy a Macintosh, you need:

* The Macintosh hardware package.

* Some applications software; for many people, the MacPaint
and MacWrite combination will be the best starting package.

* A box of blank disks.
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A computer’s physical parts—keyboard, screen, printer, wires,
and so on—constitute the hardware. You can touch hardware.

Software, or programs, are the instructions you need to turn a col-
lection of hardware into a word processor, a number cruncher, or a
game machine. You can’t touch software, although you can touch the
hardware it is stored on. Hardware is useless without software and
vice versa.

You can choose from hundreds of programs, each turning your
Macintosh into something different. Some of the Macintosh pro-
grams vying for your attention may be exactly what you need.
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WRITING YOUR OWN PROGRAMS

If you find programming interesting and want to learn to program
the Macintosh, by all means do so. But don’t feel that you have to.
Most people who use computers will never write a program. Afterall,
excellent programs have already been written, so why duplicate the
effort? Good word-processing software can take one skilled person
several years to prepare; you may well prefer to do other things with
that time.

As microcomputers become more common, chances are that a pro-
gram meeting your specific needs will appear. But if you have a special
requirement for which no program exists, you can write the program
or have someone else write it for you. (Chapter 10 discusses program-
ming languages.)

IS MACINTOSH RIGHT FOR YOU?

No computer can be all things to all people, and the Macintosh will
not suit everyone. You may not find it suitable if you must have:

* Complete compatibility with another microcomputer
model.

* Specific software that runs on another microcomputer
but not on Mac.

* Specialized accessories that only work on a different
computer.

* A color display screen.

Some of these restrictions will change as more software and accesso-
ries appear for the Macintosh.

In addition, all computer designs reflect compromises. If you use a
Macintosh, you will have to live with certain design decisions, some
of them a little painful (see Chapter 21 for details).

Which Macintosh?

This book focuses on the 512 kilobyte Macintosh, and for most
people, this model will be the best choice. Avoid the 128 KB Mac; if
you have one, upgrade it. The cost of additional memory is dropping
rapidly, and there is no point in suffering from memory limitations.
If you need more than 512 KB, you can get your Mac modified (see
Chapter 22).
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If you have a choice, get double-sided disk drives; their greater
storage capacity helps tremendously.

The next section shows you how to set up the Macintosh com-
puter. If you have one already set up and are familiar with basic terms
like keyboard, disk drive, and mouse, go to Chapter 2; if you have al-
ready used a Macintosh, skip to Section Two.

Apple supplies an excellent manual with the Macintosh that ex-
plains how to set it up, so this section will only present supplementary
information.

When you set up a Macintosh, the first thing you will need is a
comfortable, properly lit place for it. You will probably want the key-
board at typing height, a little lower than your desk or dining table.
Adjust your chair so you're seated comfortably; the fatigue some peo-
ple feel when working for long periods at a computer usually comes
from poor lighting or an uncomfortable chair or desk setup. If two
people of different heights share the computer, use an adjustable chair
or keep a cushion handy.

Avoid placing your Macintosh next to a heating vent or radiator.
Exposure to high temperatures might damage it or, more likely, its
magnetic information-storage disks. Generally, if you can stand the
temperature, so can Mac.

Don’t put the computer in direct sunlight, and make sure the area
behind it is neither brilliantly lit nor very dark; otherwise your eyes
will have to readjust constantly for the difference. No lights should
shine directly on the screen; position them to avoid glare. If you have
bright overhead office lights, a shade or hood over the screen may
help. (See Chapter 12 for more information about reducing glare.)

As you assemble the computer, the only problem you are likely to
have is with the plugs. If you have trouble pushing a plug in, you have
the wrong jack or the wrong orientation. Never force a plug! Small,
knurled knobs secure all plugs to the computer.

Getting Acquainted

FIRST STEPS
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If the power supply is irregular in your area or if you’ve had prob-
lems with other equipment, see Chapter 20 for suggestions. Outside
of North America, make sure that the electrical supply is the correct
voltage. The power-line frequency (50 or 60 Hz) doesn’t matter, but
the voltage must be correct. Any transformer you use should have a
capacity of 150 watts or 150 VA.

There is a little plastic piece labeled INTERRUPT RESET. It fits
on the left side of the computer. You won’t need to install this piece for
now, so you can put it away for another time.

If you ever need to move your Macintosh, the safest way is to dis-
connect all the cables and move each unit separately.

TAKING CARE OF THE MACINTOSH

Although you should give your computer the same care and respect
that you’d give any other valuable object, it is no more fragile than a
television set and fairly hard to damage.

You cannot harm Macintosh hardware by any combination of typ-
ing on the keyboard or handling of the mouse. Generally, you can
only alter or erase software or lose data by deliberate choice. We’ll go
over simple safekeeping steps as they come up.

TAKING CARE OF YOU

Don’t work steadily at any computer for hours on end; plan to
stretch your legs at least every hour or so. Don't forget to eat, and re-
member to talk occasionally with your fellow workers or your family
and friends.

USING NEW PRODUCTS

Whenever you work with hardware or software for the first time,
take a little extra care. Don’t invest a lot of time entering data at the be-
ginning; make sure that the program does what you need first. Enter a
little data and check the results; print from the program to make sure
everything works. Only after you are confident of both the program
and your ability to use it should you invest the time in intensive work.
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KEEPING UP WITH NEW PRODUCTS

You may find yourself caught up in the craze to get the latest and
greatest of each software or hardware accessory. If you enjoy doing
this, fine; but remember, familiar products that work well may be
enough. Glamorous features may be irrelevant to your needs. Re-
member, too, that every time you change programs, your work will
inevitably be disrupted until you learn the new one. Although the
Macintosh design makes this period short compared with other com-
puters, you should weigh the potential benefits against the liabilities.
In a business, be especially sure before changing programs and work-
ing procedures.

A FEW WORDS ABOUT EACH COMPONENT

Here’s a quick rundown on each component. You won’t need more
information to operate a Macintosh successfully, but you may want to
learn more after you have some experience; you will find more detail
starting in Chapter 11.

The Main Computer Unit

For now, you need to know only two things about the main unit:
how to turn it on and how to adjust the screen brightness. You can
leave the machine on constantly if you wish; just turn the brightness
down whenever you're not going to use it for long periods.

Disks and the Disk Drive

10

The disks store information magnetically. They fit, one at a time,
into the disk-drive slot just below the display screen. They can only go
in right side up; the plastic disk jacket has a small arrow showing the
correct orientation.

When you are finished working, you should use the Finder to eject
all disks. I’ll explain this shortly; for now, just note you should eject all
disks before turning off the power.

Disks store several kinds of information in units called files. Func-
tionally, a computer’s files resemble the paper file folders in your filing
cabinet. Stored information includes:

System and Finder information. When you first turn on the Macin-
tosh, you must insert a start-up disk in the disk drive. The computer
transfers System and Finder information from the disk into its mem-
ory and onto the screen. (We’ll see what these terms mean in the next
chapter.)
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Application programs. In most cases, programs such as MacPaint
and MacWrite that turn your Macintosh into a graphics tool or word
processor will be on the same disk as the System and Finder informa-
tion. Once the Finder is in memory, you’ll need to indicate the pro-
gram you want, and it, too, will be transferred into memory.

Data. Information you enter when using a program, and other in-
formation needed by a program, are stored in data files. Data files
don’t always have to be on the same disk with the program, although
some programs will be easier to use if the data files are handy. You can
keep these different kinds of information on the same disk, but if they
must share space with application programs, as well as the System and
Finder, you may run out of disk storage space. Chapter 9 explains
how to set up disks to avoid this problem.

Don’t be concerned if you don’t follow all the subtleties of this dis-
cussion just yet. We’ll take up these topics again, and you’ll soon be
fluent with disks and files.

You'll use the keyboard (and mouse) to enter information and to
tell the Macintosh what to do with that information. The Macintosh
keyboard has all the familiar typewriter keys and a few extra ones. The
typewriter-like keys produce all the familiar letters and symbols. If
you hold a key down, the character will repeat automatically.

The Keyboard

e S ARG Y R T
L = W o ] W T el gty
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The Macintosh Shift key works just like a typewriter’s; when you
hold it down, you get capital letters and punctuation marks instead of
lowercase letters and numbers. But the Caps Lock key works a little
differently than a typewriter’s shift lock: It stays engaged when you
press it and releases on a second press. When the Caps Lock key is en-
gaged, you get capital letters as you would expect, but you still get
numbers, not the punctuation marks above them. For punctuation
marks, you must press the Shift key and the number key at the same
time, even if Caps Lock is engaged.

Two keys you won’t find on a typewriter, the Option and Com-
mand (38) keys, work like two more shift keys. You press them at the
same time as another key. The Option key serves several purposes, in-
cluding generating special symbols for foreign languages or scientific
equations. The Command key shouldn’t concern you if you are just
starting out; it is a shortcut for telling the computer to do something
like eject the disk or delete a word. We'll cover its functions when we
discuss software.

The last non-typewriter key is the Enter key. You’ll use it most
often to tell your Macintosh you’ve finished with some typing.

A last word of warning: If you are in the habit of typing the letter
“1” for the number 1, or a letter “O” for zero, you'll have to change
your ways. Sorry. The difference is very important to computers.

Along with the keyboard, the mouse lets you work with the Mac-
intosh. We'll cover it in Chapters 2 and 15.

ADDING ON: HARDWARE ACCESSORIES

12

There are four add-on accessories you should consider buying. All
are simple plug-in units; two are probably essential:

A second disk drive makes computing much easier by providing
more storage for programs and data. Although you can limp along
with a single disk drive, a second one makes many tasks so much
easier that you should consider it a necessity rather than an option.
For example, with two disk drives you can copy disks or move infor-
mation from disk to disk without constantly swapping disks during
the operation. The Macintosh will accept only one additional micro-
floppy disk drive.
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Many users should consider a hard disk drive, which gives greatly
increased storage and much faster operation.

A printer produces text and graphics on paper, and nearly every
Macintosh owner will need one.

Two other accessories are useful but may not be essential.

A numeric keypad provides an adding machine-like set of keys,
handy if you work with numbers. The keypad also improves some
Macintosh operations by giving you more keyboard options but it is
not necessary for most software.

A modem lets you communicate with other computers by tele-
phone. It converts information from your computer into sounds that
can travel by an ordinary telephone line; it also does the reverse,
changing sounds generated by a distant computer and its modem back
into information your computer can understand.

You are ready to start using the Macintosh.

13



Starting Chapter
g 3"

f you have used a Macintosh already, you should probably
skip this chapter, which covers basic information but does not replace
Apple’s excellent manuals. If you are new to the Macintosh, I suggest
you read the manuals and use this chapter as a supplement.

STARTING UP THE MACINTOSH

Any disk that will start up a Macintosh has all the features you need
to perform the operations described in this chapter. A disk that can
start up a Macintosh is called a system, or start-up, disk.

Insert a system disk into the disk-drive slot.

The disk drive whirs as it loads start-up information from the disk
into the computer’s electronic memory. A little wristwatch appears on
the screen, telling you to wait. E)

LOOKING AT THE DESKTOP

After the disk drive stops, you see the Desktop on the screen; this
is part of the Macintosh’s visual interface. The icons, or pictures, on
the Desktop represent places for finding, storing, and discarding in-
formation. The first icons you see are:

+ The disk you've just inserted.
+ A trash can.

15
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A window may open as well. If so, try to ignore it for the next five
minutes. If it gets in the way, scan ahead to “Closing a Window.”

& File Edit View Special

USING THE MOUSE

Pointing

Clicking
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Move the mouse around your desk.

The pointer on the screen follows the mouse movements. You can-
not move the pointer off the screen.

The pointer you see now is shaped like an arrow, but it can take on
other shapes, as we'll see later.

Move the pointer over an icon.

The exact spot you are pointing at depends on the pointer’s shape.
When the pointer is an arrow, position the arrow tip over the object.

Point at the Trash icon.

Press and release the mouse button once.
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This action is called clicking. When you click the white Trash icon,
it turns black. The black color indicates you have selected that icon.
Selecting an icon means your next action will apply to that icon.

Move the mouse to the disk icon and click it.

The Trash icon turns white again, and the disk icon turns black.
Click anywhere on the Desktop outside the icons.

This cancels your previous selection. Now none of the icons on the
Desktop is selected.

Dragging

Move the pointer over the Trash icon.
Press and hold down the mouse button.
Move the mouse while holding the button down.

You use this essential operation, called dragging, in many ways. As
you move the mouse, the icon’s outline moves with it.

Release the mouse button.

When you release the button, the icon pops over to the location of
its outline.

17
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Pressing
Pressing means that you position the pointer and then press the
mouse button, holding it until an action is complete. Pressing differs
from dragging because you don’t move the mouse while pressing the
button. We will get to an operation that requires pressing shortly (in
the section on scrolling).
OPENING AN ICON

18

To find out what information an icon represents, you must open
the icon; you can think of this as opening a drawer in a filing cabinet.

Click the disk icon (the system disk).

Move the pointer to the words (menu bar) at the top of the screen.
Point at File.
& File Edit View S

S 2

Press and hold down the mouse button without moving the mouse.

You've “pulled down” the File menu. The menu entries are things
you can do with the icon you've selected—in this case, the system
disk. Available menu choices appear in black letters; unavailable ones,
such as Close, appear in dimmed or gray letters.

[{ICIR Edit  Uiew Special
Now Folder =N

Open ;

Print

Get Info
Duplicate

Page Setup
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Still holding down the mouse button, move the pointer down the menu.
The available choices are highlighted in turn.

Position the pointer over Open.
The word Open is highlighted.

New Folder =N

Print
flose

Get Info %1
Buplicate =i

Page Setup
Print Latalog

Eject RE

Release the mouse button.

You select a menu item by releasing the mouse button when the
item is highlighted. In Macintosh terms, you have chosen Open from
the File menu.

The disk window now opens up.

Double-Clicking

To open an icon faster, point at it and quickly click the mouse but-
ton twice; this action is called double-clicking.

LOOKING AT THE DISK WINDOW

Each icon in the disk window represents a file on the disk. Some
files may be application programs; others may be documents or draw-
ings; still others may represent information needed by the Macintosh
or used by a program. The operations described here apply to most
Macintosh windows, not just the disk window.

19
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Moving a Window

You may need to reorganize your Desktop by moving windows
around on it.

Point at the black-banded bar at the top of the window and drag it with
the mouse.

Close box Title bar

& File Edit-UView Special

= System Disk ==
235K in disk 164K avaoilable

Ko

Font Mover

System Folder Emply Folder

The area with the black bands is the window’s title bar. Dragging
the title bar moves the entire window.

Release the mouse button.

The window moves to the location of its outline.

Changing a Window's Size

To reduce clutter on your Desktop, you can make a window
smaller; if you want to see more of a disk’s contents, you can make its
window larger.



Chapter 2:  Starting Up

Point at the size box at the lower right corner of the window and drag it with
the mouse.

System Disk Sr=
235K in disk 164K available

K

Font Mover

oy Femnrorrns
L] el

System Folder Empty Folder

Size box

Notice that some of the icons drop out of sight as the window is
dragged smaller.

Scrolling the Disk Contents

Sometimes a disk may contain more files, represented by icons, than
you can see in the window at one time; to move the invisible icons into
view you need to scroll the disk contents past the window.

& File Edit Diew Special

System Disk
- 235K in disk 164K available |

‘ Scroll arrow

Font Mover

Scroll box
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Click one of the scroll arrows.

Clicking the arrows moves the disk’s contents past the window by a
small increment (a line if you're looking at text).

Click in the gray area of one of the scroll bars.

Clicking in the gray area instead of the arrow moves a larger incre-
ment (a screenful if you're looking at text).

Position the pointer over a scroll arrow and press the mouse button without
moving the mouse.

Remember, this action is called pressing; it’s a fundamental mouse
operation.

The disk contents scroll by the window until you release the button
or until there is nothing more to scroll.

Drag the scroll box.

This action brings hidden icons into view. The scroll box indicates
the relative location of a window with respect to the contents.

Some windows do not permit resizing or scrolling and therefore
lack a size box or one or both scroll bars. If a disk window is big
enough to display all the contents of a disk, the scroll bars turn solid
white, and you can’t scroll the window.

OPENING MORE THAN ONE WINDOW

You can have several windows open on the screen at the same time.
Double-click the Trash icon.

Double-clicking is a fast way to open an icon. (Remember, point at
the icon and quickly click twice on the mouse button.)

This opens another window. It’s empty because there is nothing in
the trash.
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System Disk
235K in disk 164K available

OK in Trash

The window with black bands across its title bar is the active win-
dow. The black bands have disappeared from the disk window’s title
bar, showing that it is no longer active. (You might have to hunt
around for the disk window if the Trash window has covered it up.
Move or resize the Trash window if necessary.)

Click anywhere in the disk window.

The black bands are back in the disk window’s title bar, showing
that the disk window is again active.

Drag the disk window's size box so that the window overlaps but does not
obscure the Trash window.

Click anywhere in the Trash window.

The Trash window moves on top of the disk window and black
bands appear in the Trash window’s title bar. If you have several over-
lapping windows on your Desktop, the active window will always be
in front.

Chapter 2:  Starting Up
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Closing a Window

You may close your windows in either of two ways:

New Folder 3N )
Open Choose Close from the File menu; or
Print
ose Click the close box in a window's upper left corner.

Get Info 81

Duplicate %D Close box

Page Setup : —

Print Catalog =  Teash 8

Eject RE \ 5
o

Close the Trash window; leave the disk window open.

WHAT THE DISK WINDOW TELLS YOU

Now that you can manipulate windows, let’s take a closer look at
the system disk window.

Click the disk window to make it active.
Drag its size box to make a large window.

The words and icons you see tell you which items you have stored
on the system disk and how much space they take up.

A disk can hold only a finite amount of information. The top line
in a disk window tells you how many items are on the disk, the total
storage taken up by the files on that disk, and how much space is still
available for additional items. The units are thousands of characters,
or kilobytes.

The icons represent individual files of information on the disk.
Some of these files are application programs; others contain software
the Macintosh itself needs to operate; still others contain resources
that you will find useful once you start working with the application
programs.

You can use the menus to find out more information about the files
on the disk.
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Choose by Name from the View menu. View

(Point at View on the menu bar, drag the mouse to highlight by FiName

Name, and release the button.) The icons disappear, and a list of files

appears in alphabetical order. Along with each file’s name, you have its
size and kind, and the date the file was last modified.

EE==——=—=== system Disk |
Size HName Kind Last Modified

OK  Empty Folder folder Tue, Jan 24, 1984
13K  Font Mover application Tue, Jan 24, 1984
146K System Folder folder Wed, Jan 18, 1984

]

<

3] [

Pull down the View menu again, holding down the mouse button.

These choices represent ways you can organize the list of files. If .
you choose by Date, for example, the files are listed starting with the | New Folder 3N
one most recently changed. L

Print

Close
Drag to by lcon and release the mouse button.
Click any file icon. I]l:lpllco;e ;en
Choose Get Info from the File menu. Page Setup

Print Catalog

A new window opens, showing information about the file.

Eject %E

D% Information about Font Mover 00c0——=|

Font Mover
Kind: application

Size: 13312 bytes, accounts for 13K on disk
Where: System Disk, internal drive

Created: Tuesday, January 24, 1984 at 10:06 AM
Modified: Tuesday, January 24, 1984 at 5:14 PM

[J Locked

[use Font Mover to free up space on your disk by
moving fonts into and out of the System file.
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To close the Get Info window, you can either:
Click the close box in the Get Info window; or

Choose Close from the File menu.

TAKING A BREAK

Choose Close All from the File menu.
Choose Eject from the File menu.

After a few seconds, the Macintosh pushes the disk out of the disk
drive. Turn off the power if you wish.
To restart, simply turn on the power and insert the disk again.

DESK ACCESSORIES

ﬂblou( the Finder...

Scrapbook
Alarm Clock
Note Pad
Calculator
Key Caps
Control Panel
Puzzle

The Apple menu in the menu bar opens the way to the Macintosh
desk accessories. You can use the desk accessories at any time, re-
gardless of other activity—whether you are using a program or not,
whether any windows are open or not.

Point at the Apple symbol at the far left of the menu bar.
Press and hold the mouse button.

Drag the mouse down to highlight About the Finder...
Release the button.

Some information about an important program called the Finder
appears on the screen. The Finder creates your Desktop, shows you
which files are on the disk, copies files from disk to disk, and much
more. You've been using the Finder throughout this chapter.

Click anywhere to get rid of the Finder information.
Go back to the Apple symbol and pull down its menu again.

The rest of the items in the menu are desk accessories. (Your menu
may not be in the order shown.)

Choose each accessory in tumn.

Click the accessory’s close box to put it away.
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What Do the Accessories Do?

Scrapbook saves material from one program and lets you move the
information to another program or within the same program.

EDE-__' Scrapbook

Alarm Clock displays a small box with the current time. Click the
small symbol on the right to add a calendar. Now click the small alarm-
clock icon. You can set the alarm by moving the cross-hair pointer
over either the hours or minutes and clicking; then click the up or
down arrow to set the time. Turn the alarm on by clicking the bell
icon on the left.

Note Pad gives you a place to type text notes. You can tear off sheets
(the Note Pad gives you eight) by clicking the upturned corner. Click-
ing the lower left corner below the diagonal line flips the Note Pad
back a page. Mac beeps if you try to put too much text on a sheet.
We’ll use the Note Pad in the next section.

Calculator is a general-purpose, four-function calculator with ex-
ponentiation. It uses standard algebraic entry. Use the mouse to click
the numbers or functions you want; the results appear in the cal-
culator’s display panel. You can also enter numbers from Mac’s key-
board. The * symbol denotes multiplication.

Key Caps displays a miniature Macintosh keyboard that tells you
which characters your real keyboard generates. Press a few keys on the
real keyboard or click them on the Key Caps display with the mouse
and watch what happens; the keys are highlighted on the Key Caps
display and appear in the blank bar above it.

O011:34:43AM ¢
12/11/85

O o

[ calculato
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EDITING TEXT

Hold down Shift, Option, Caps Lock, or a combination of these
keys on the real keyboard and watch what happens; the display key-
board is instantly transformed into a variety of symbols and graphics
characters.

Puzzle will look familiar; you can play with it when the boss isn’t
looking.

Control Panel lets you adjust the speaker volume (drag the sliding
control up or down), set the repeat rate of the keys (turtle for slow,
hare for fast), adjust the rate the pointer flashes, set the clock/calendar,
and other features; see your manual for details.

=—— Control Panel

In this section we've looked at standard accessories supplied by
Apple with the Macintosh. Many others are available from other soft-
ware sources; these are described in Section Two.

Again, you may want to close everything to take a break before we
move on to practice a major operation: editing text.

For most Macintosh application programs, you will use the same
general methods for entering and editing text. We’ll practice these op-
erations using the Note Pad, since all system disks have one.

Choose Note Pad from the Apple menu.



If the first page has writing on it, turn to the next clean sheet by
clicking the upturned left corner.

([}

O Note Pad Ba—=|

Click here to
turn sheets forward

or backward

S

You should now see a blinking vertical bar at the top left of the
Note Pad page; this bar marks the text insertion point. Anything you
type appears at this point. This insertion point is used by all applica-
tion programs for text entry.

Type two or three lines.

If you make a mistake, hit Backspace and retype.

Your text appears on the Note Pad, pushing the insertion point
ahead of it. Notice how the words wrap around to the next line when
you get to the edge of the page. You don’t have to hit Return at the end
of each line as you do on a typewriter; the Macintosh software does it
for you.

Suppose you have left out a phrase in the second line of the text you
just typed. You want to go back and insert the phrase where it belongs.

Move the mouse so the pointer lies somewhere within the text.

Notice how the pointer changes shape as it moves onto the Note
Pad, becoming an I-beam. You can use the I-beam pointer to mark
where in the text you wish to insert the phrase you left out.

Chapter 2:  Starting Up

Inserting Text
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Deleting Text

IN THE BEGINNING

Move the I-beam pointer to anywhere on your second line of text and click.

S(J=——— Note Pad

Tuype two or three lines. If you
make a mislake,Ihit Backspace
and retype.

The blinking insertion point, which was at the end of your text,
moves to the location of the I-beam pointer. If you now type in the
missing phrase, it will be inserted in that location, pushing the inser-
tion point and the existing text ahead of it.

Practice moving the insertion point around your text.

Move the I-beam pointer to a blank area at the end of a line and click.
The insertion point appears at the end of the text in that line.

Move the |-beam pointer to the blank area following all the text you have
typed and click.

The insertion point appears at the end of the last line.

Click so the insertion point appears somewhere within the text.
Press the Backspace key.

Using the Backspace key is the simplest way to delete something;
backspacing removes the character to the left of the insertion point.

You can also use Backspace to delete more than one character at a
time. But first, you have to use the I-beam pointer to select what you
want to delete.



Move the I-beam pointer to the beginning of the text you wish to delete.

Drag the i-beam pointer to the end of the text you want to delete and release
the button.

Note that the text is now highlighted.

EO=—= Note Pad =——=

Type two or three lines.
LG G hit Backspace
and retype.

Hit Backspace.

Gone!

E0E==—= Note Pad =——=|

Type two or three lines. | hit
Backspace and retype.

Once you've selected text with the I-beam pointer, you also have
three other ways of deleting it:

Choose Cut from the Edit menu; or
Choose Clear from the Edit menu; or
Hold down the Command key (38) while typing x.

Using the Command key is a shortcut to an operation; you simply
hold down the Command key and type a letter instead of using the
mouse to pull down and choose from a menu. The Command key
equivalents for menu items are shown next to each item. From now
on, this kind of instruction will be given as: Type Command-x.

Chapter 2:

Starting Up
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Changing Your Mind

If you delete the wrong thing, the Macintosh gives you two ways to
repair your mistake:

Choose Undo from the Edit menu; or

Type Command-z.

I ——

Cut %H b ines. | ERTTR

Copy #C | hit Backspace
Paste U
Clear

Select AU 3B

Show Clipboard

Either operation restores your last deletion.

Choose Undo again.

The selection is deleted again. Undo reverses whatever your last
move was; if your last move was to restore a deletion, then Undo de-
letes the restoration. You cannot undo more than one previous step.

In some programs, the Undo menu item changes to reflect your last
action. It might say Restore Row if you've just deleted a row, but the
item will always be in the same menu location.

Erasing the Note Pad

Select the entire text by dragging the mouse down over all the lines.
Choose Cut or Clear from the Edit menu.

These actions erase the entire practice sheet.
Closing the Note Pad

Click the Note Pad's close box.

FQE Note Pad =S|
|
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If you don’t erase what you've written, your text is stored in a file
on the disk named Note Pad when the window closes. The next time
you use the Note Pad, you'll find your notes on the page where you
typed them. Try it. To end this practice session:

Close the Note Pad window.
Close any other windows you might have opened.
Close the system disk window.

You can close windows one at a time by clicking each close box or
all together by choosing Close All from the File menu.

Choose Eject from the File menu.
The disk drive ejects the disk.

Chapter 2:  Starting Up

TURNING OFF THE MACINTOSH

Do not turn Mac off before using the File menu to eject your disk.
If you turn off the computer before ejecting the disk, you may lose
some information that Mac has not yet stored on the disk (see Chapter
14 for details).

A NOTE ABOUT PHILOSOPHY

As you learn more about the Macintosh, you will find that the best
programs use a consistent philosophy. Such programs will have no un-
pleasant surprises.

For most Macintosh operations, you always select something first,
then choose what you want the computer to do with it. Thus you se-
lect a file, then choose Get Info; you select a portion of text, then
choose Cut or Copy.

A few programs, by their nature, don’t work quite in this fashion.
In the MacPaint program (Chapter 4), you select a tool first, and then
you do something with it. Yet selections of an area within MacPaint
follow the normal rule: Select first, then choose what to do with it.

Most application programs will also use the same two ways of find-
ing out more specifically what you want them to do: conversational
dialog boxes and more urgent alert boxes.



SECTION ONE:

Dialog Boxes

Alert Boxes

IN THE BEGINNING

As you work with the Macintosh, application programs will at
times put dialog boxes on the screen in response to your actions. For
example, a dialog box might ask you the size of paper in your printer.
Some dialog boxes merely ask a yes/no question.

Save changes before closing?

In most dialog boxes, you make choices by clicking buttons or
items on a list. The next step depends on the dialog box. Often, you
click a button labeled Yes or OK when you are satisfied with your
choices, or you click a button labeled Cancel to close the box and re-
turn to the previous step. You cannot proceed past a dialog box unless
you click an appropriate button.

One special form of dialog box is a2 mini-finder—a listing of the
files on the disk that were created by the application program you are
using. A related form is a mini-list, which might, for example, con-
tain the font choices available for a particular program.

An alert box is similar to a dialog box, but is used to warn you of a
potentially serious problem. An alert box might tell you that your
word-processing document is getting too long to store on the disk, for
example. In most cases, you must acknowledge the alert box by click-
ing an OK button.

Please Insert the nent sheet of paper.
m Click OK to continue, Cancel to terminate ‘




Chapter 2:  Starting Up

WHAT TO READ NEXT

The next seven chapters describe some major software types. Most
Macintosh users will want to read the sections on MacPaint and Mac-
Write in the next two chapters. Read the other chapters if you are in-
terested in the software.

Since this chapter has covered only the essential operations to get
started, you may want to skip to Chapter 9, which covers disk organi-
zation. The information in Chapter 9 is important for any productive
work on a Macintosh.









Word Chapter
Processing 3

. Imost everyone who buys or uses a computer eventually
does some form of word processing on it. In fact, many people use
their machines for nothing but word processing. With a computer,
writing and editing anything from a letter to a book becomes easier,
faster, and far less messy.

Instead of scrawling out drafts by hand or banging out innumerable
versions on a typewriter, you type your text into the computer only
once, changing words and phrases on the screen as you type. The
computer allows you to move paragraphs, delete sections, and add
new sections—all without having to retype pages over and over.
When you like what you’ve written, you can print a precisely format-
ted copy immediately.

At least that’s the way it should be. A major challenge for word-
processing program developers has been to give you on paper exactly
what you see on the screen—not an easy task. With traditional word
processing, you could rarely be sure exactly where new pages of text
began, much less see italics or headlines on the screen.

The Macintosh has changed all that. At last, what you see really is
what you get.
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MACWRITE
This chapter begins with MacWrite. If you are already familiar
with this program, skip ahead to later sections, which describe and
compare other word-processing software for the Macintosh.
Starting MacWrite

For this practice session, you’ll need any start-up or system disk
containing the MacWrite program.

%\ Double-click the MacWrite icon to open it.
v The Desktop clears and the wristwatch appears, telling you to wait

MacWrite  for the MacWrite document window to open. After a few seconds the
wristwatch disappears and the window, labeled Untitled, opens.

Left margin and paragraph indent ~ Right margin
Ruler

Decimal tab

No. of lines 1

Tab ;
Spacing

Insertion point

Center
Justification  Right
Full

Notice the blinking vertical bar at the top left margin; this marks
the insertion point (equivalent to the cursor in other word processors)
where the text you type will appear.

Type a few sentences—anything.
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Imagine that you are typing on a long paper scroll that advances
past your window as you add text. Notice what happens when you get
to the end of a line: MacWrite automatically bumps words to the next
line without your having to press Return; this is called word wrap.
The only time you have to press Return is at the end of a paragraph.

& File Edit Search Format Font Style

L P BT

(I P L G D |
e -~
@A @& Oslinessinen B =] .
To MacWrite, any text typed into the window is called & document.
Imagine that you are typing on a long paper scroll that advances past your
window as you add text|

Word Processing

Inserting and Adding Text

With the mouse, you can move the pointer anywhere within the
text. You use it to position the insertion point so you can add text.

The insertion point will only appear within or at the end of your
text; you cannot put it in the white space following the text or in the
margins.

Move the pointer into the text area.

The pointer changes shape when it’s in the text, becoming an
I-beam pointer. Whenever you’re working with text on a Macintosh,
you will see the I-beam pointer and can use the same basic operations

described here.
Position the I-beam pointer between two words and click.

The blinking bar marking the insertion point appears wherever you
click within the text.

Type a few words.

The extra text you add is inserted at the insertion point, between
the two words.

typing on & long[paper scroll

typing on a long papyrus or paper

41
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What if you change your mind? You can undo your last step.
Choose Undo Typing from the Edit menu; or
Type Command-z.

Undo reverses your last action, back to the last click of the mouse.

Saving a Document

New
Bpen...
Close
Save fis...
Page Setup

Print...
Quit

Nge

fpena.
Close

Save

Save fis...
Page Setup
Print...

42

Choose Save from the File menu.
A dialog box comes on screen, asking you to name the file.
Type a file name.

Click the Save button.

Save Current Document RS | ,yrite scr...
masterpiecq

| y
(save ) (_cCencel ] ' ([ orive )

@ Entire Bocument QO Texnt Only

The disk drive turns on, and your document is saved on the disk.
After the file is stored, you can resume working on your docu-
ment. If you want to leave the MacWrite program completely:

Choose Quit from the File menu.

If you have made any changes since the last Save, adialog box asks if
you want to save your current work. If you are just experimenting,
click No, and nothing will be saved. But if you want to save the latest
version:

Click Save.

If the file has no name (“untitled”), a new dialog box asks you for a
file name.

Type in a file name and click Save.

After you save the document, the Desktop with the disk window
reappears.
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Word Processing

Reading in an Existing Document

In the disk window, locate a file you want to work with. Make sure
that the file you select is a MacWrite document.

If you open a file icon, the system will automatically start the pro-
gram that generated the file and read in the file information.

Double-click the file icon.

The contents of the file you have chosen now appear in the docu-
ment window.

Formatting with MacWrite

With conventional word processors, setting the format of your
document—the margins, tabs, line spacing, and alignment—often
takes more effort than typing the text. MacWrite uses visible rulers
with special markers to make setting formats easy and elegant.

When you start a document, MacWrite supplies a ruler with a pre-
set format that you can keep or change. The ruler corresponds to the
text area on a standard 8%2- by 11-inch sheet of paper; the full margins
do not appear in Mac’s document window.

T A T T T T Y -
* -

. ! -y
AaE Osievinen EEE E EGE E)

Notice the format of the text on your screen. Changing this format
simply requires moving the margin or indentation markers and select-
ing the spacing and justification, or alignment, icons.

Margins and paragraphs

There are two markers at the left edge of the ruler. They are super-
imposed in the preceding illustration, but can move independently, as
you’ll see in a moment. The triangle marks the left margin and affects
any word-wrapped text; the arrow marks the paragraph indent and
affects only the first line of each paragraph (any line immediately fol-
lowing a Return). The triangle at the right edge of the ruler marks the

right margin.
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To drag a margin marker, position the pointer carefully on the tri-
angle and drag.

Drag the right-margin marker to the 6-inch mark on the ruler.

6-1nch mark on the ruler. .

Drag the left-margin marker to the 1%2-inch mark on the ruler.

T T 18 4iden
r S

1
@ 8 06 ines/inch
Dreg the right-margin marker to the
Then dreg the left-margin

Notice what happens to your text.

Drag the paragraph-indent arrow so that it is on top of the left-margin
marker.

If you drag both the left-margin and indentation markers to the
same position, all your text lines up on the left margin with no para-
graph indents.

T A T

@00 O lnes/inch ==

Drag the right-margin marker to the
Then dreg the 1eft-meargin mearker to the

Mgt oo 15.,  Dragthe indent arrow first to the left and then to the right of the left-margin

i
@ & 0O eskines/inch marker.
Drag the righ
mark on the ruler. The Dragging and placing the indentation marker to the right of the

left-margin marker gives you normal paragraph indents; dragging it to
the left gives you hanging indents—the first line of each paragraph ex-
tends farther left than the rest of the text.

Tabs

LN S You set tabs by dragging the little triangles at the left, under the
@ Osrtines/incn  ruler. The triangle on the leftis a standard tab; the other triangle (with
You cen set tebsbymo:  the dot) is a decimal tab. The decimal tab is used for entering numbers

in a column; decimal points will line up on the tab position.

[ Lt 12 ‘; L...15..  Drag atab triangle to any position on the ruler.
@ @& O e6Rines/inch . . . .
= voucon sel tabs by Mo’ You must drag a tab triangle to the ruler; the tab icon disappears if

you drag it to any other location.
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If you press the Tab key while typing text, the insertion point will
move to the next tab position, just as on a typewriter. You can drag as
many tabs as you need from their boxes.

Drag the tab triangle away from the ruler and release the mouse button.
The tab icon disappears and the tabs are cleared.
Spacing and justification

The two sets of icons under the ruler in the center and to the right
represent pages with different spacing and justification. The choice of
6 lines/inch forces the standard vertical spacing used on mailing labels
and many forms.

Position the pointer in the double-spaced page icon and click.

lines/inch  [E=] Eg [ B3

Spacing and justification. The two sets of icons under the

ruler in the center and to the right represent pages with

Your document is double spaced.
Click the single-spaced page icon.
Your document is single spaced.

Click the page icon with center alignment.

lines/inch E E [EE] %

Spacing end justification. The two sets of icons under the

ruler in the center and to the right represent psges with

different spacing end justification. Position the pointer in
the double-spaced page icon and click]|

Click the other page icons in turn.

Your text lines change justification instantly on screen: left justi-
fied, centered, right justified, and both margins justified.
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Changing the format within the text

A ruler sets the format for any text that follows it, until you insert
another ruler. You can insert a new ruler anywhere.

Choose Insert Ruler from the Format menu

Format

Insert Ruler
Hide Rulers

Open Header
Open Footer
Display Header
Display Footer
Set Page #...
Insert Page Break
Title Page

Align Left BN
Align Center %M
Rlign Right %R
Justify %8J
Use Ruler %D

You can make any changes you wish to the new ruler. If the rulers
are too intrusive, you can make them invisible by choosing Hide
Rulers from the Format menu.

Editing by Selecting

Editing means changing—anything from correcting a typo to
doing a wholesale cut-and-paste operation. Before you can alter text,
you must select it. To select text:

Position the painter just before the text.

BT wou  Drag the pointer across the text you wish to select.
must select it.

Release the mouse button.

The selected text is highlighted in reverse color. Your next com-
mand will affect only the selected text.

You can select an individual word quickly by pointing at it and
double-clicking.

You can change the selected text in many ways. Three fundamental
editing operations will copy, move, and delete it.
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Choose Copy from the Edit menu.

The selected text is copied into the Clipboard, which is an elec-
tronic scratch pad.

Move the pointer to another part of the text and click.
The blinking insertion point appears in the new location.
Choose Paste from the Edit menu.

The selected text is copied into the new location; it also remains in-
tact in its original location.

Select another portion of text.
Choose Cut from the Edit menu.
The selected text is deleted and disappears into the Clipboard.
Move the pointer to another part of the text and click.
Cho;se Paste from the Edit menu.

The text is moved from the Clipboard into the new location. The
Clipboard can hold one item at a time. Any time you choose Cut or
Copy from the Edit menu, you replace the previous Clipboard con-
tents with the new selection. So if you want to get rid of some text en-
tirely, you can simply cut it to the Clipboard and leave it there until it
is replaced by something new.

| Eoit I

Undo Copy 382

Cut 8R

Paste Il 23 )

Show Clipboard

Before you can alter text, you
must select it. Before you can
alter text,

Choosing Typefaces and Type Sizes

MacWrrite lets you choose the typeface, or font, in which your text
is displayed and printed; you can also choose the size and style (bold,
italic, outlined, shadowed, and so on).

Font choices are stored with the text. Whenever you move the in-
sertion point and add new text, MacWrite automatically uses the font
of the adjoining text.

Select some text by dragging through it so it is highlighted.

Choose any font from the Font menu.

The highlighted text is now displayed in that font.

Seattlie
Cairo
Chicago
vGeneva
Monaco E
Uenice

London
Athens

a
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CHOOSING A WORD PROCESSOR

You can choose from several different word processors for the
Macintosh:

» MacWrite is a simple, handy word processor. Versions 4.2
and later probably have all the functions that the average user
needs for straightforward tasks, and as long as it comes with
the Macintosh, the price is right. MacWrite can now deal
with long documents.

* Microsoft Word (version 1.05) offers a full complement of
features that rival and surpass those of dedicated word pro-
cessors. For major editing projects, Word supplies much
more power than MacWrite or Jazz.

* Jazz (Release 1), from Lotus Development Corporation,
includes a word processor that is essentially the same as
MacWrite, but it works smoothly with the Jazz spreadsheet
and business graphics. See Chapter 7 for more information
about Jazz.

How They Compare

_ All these programs are fine for ordinary word-processing tasks.
Their basic functions are similar enough that you can switch from one
to another with only minor difficulty. But since they use different file
formats, you will be better off choosing one as your principal word
processor. Here’s how they compare (the specifics may change as fea-
tures are added; for an explanation of technical terms, see the glossary

or Chapters 11and 14):
Size of file
MacWrite: Limited by disk capacity.
Word: Limited by disk capacity.
Jazz: Limited to RAM available; normally not a problem but
depends on other documents in RAM.
Windows

MacWrite: Single window, cannot be split or scrolled horizontally.

Word: ~ Up to four windows with horizontal scrolling. Any win-
dow can be split so you can see two parts of the same file.

Jazz: Up to eight windows with horizontal scrolling.
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Setting margins and tabs

Ruler on screen shows indents, margins, and two types

of tab (left-aligned and decimal).

Ruler displayed temporarily on screen upon request;
shows indents, margins, and four types of tab (left-, cen-
ter-, and right-aligned, as well as decimal). Can automat-
ically fill spaces between tabs with hyphens, underlines,
or periods.

Same as MacWrite.

Pictures and graphics

Can include MacPaint images or other graphics in text,
but not on the same line as text.

Same as MacWrite.

Same as MacWrite; includes live links to spreadsheets and
graphics from within Jazz, so if you update information

in a spreadsheet or graph, the document is automatically
updated as well.

Visual page display

Nearly complete display, includes running headers and
footers at the top and bottom of each page. Page breaks
always automatically appear in the correct position.

Does not show running headers and footers on each
page; page breaks displayed only on command and man-
ual re-display is necessary after changes.

Same as MacWrrite.
File types
Uses its own compressed file type to save disk storage

space. Can read and write standard ASCII files.

Uses its own file type. Can read and write ASCII files as
well as MacWrite files, including formatting information.

Uses its own file type. Cannot read ASCII files directly,
only through the Clipboard and Scrapbook.
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Learning time
MacWrite: About an hour for basic functions.
Word: Two or three hours for basic functions; if you know Mac-
Write, 15 minutes. Complex functions take more time.
Jazz: Starting from scratch, about an hour; if you know Mac-
Write, two minutes.
Additional features

Microsoft Word includes many features not in MacWrite or Jazz:

* A glossary function that lets you type short codes in your
text in place of frequently occurring words or phrases. You
can, for example, define a glossary entry so that every time
you type MC and Command-Backspace, Word expands it to
Macintosh.

* Footnotes that can be placed automatically at the end of text
or along the bottom of the page.

* You can set any font size from 4 to 127 points; you are not
limited to the sizes installed in the System file.

* Multiple printing formats, including multicolumn printing
and adjustable gutter margins (text on odd- and even-num-
bered pages shifts to the right and left, respectively, to allow
for binding). You can format at three different levels in
Word: individual characters, paragraphs, and divisions. You
can define a division to be any size; for example, the intro-
duction, body, and appendices of a book can each have a
distinct format.

* Form letters can be generated with a separate mailing list or
Microsoft File; the function can perform conditional assem-
bly-checking for a name or numeric value before printing a
particular sentence.

» Additional keyboard support: Word has many functions
defined as keystroke combinations; it also makes use of the
numeric keypad for cursor-control keys and function keys.

* Word can drive common daisy-wheel printers directly with-
out special driver software.

* With a conversion utility program, Word can read files, in-
cluding formattting information, produced with versions of
Word on MS-DOS and UNIX/XENIX computers.



Chapter3:  Word Processing

OTHER WORD PROCESSORS
AND RELATED PROGRAMS

MockWrite (version 4 from CE Software; available from user
groups) is a simple text editor that runs as a desk accessory; you can
use it at any time, while using another program. It’s much more useful
than the Note Pad accessory that comes with the Macintosh; files cre-
ated by MockWrite can be read as ASCII text files by other word-pro-
cessing programs.

Foreign-Language Word Processors

For European languages and other alphabetic languages rendered in
left-to-right, top-to-bottom form, any Macintosh word processor
will work. The standard fonts include the diacritical marks necessary
for many European languages. Some languages will need a slightly
modified font (you can add them yourself with a font editor, see
Chapter 15); Russian and Bulgarian will need a Cyrillic font, which is
available from several companies. Fonts for other scripts will appear or
you can create your own if you have the skill and patience.

For languages that read right-to-left, the standard word processors
are nearly impossible to use. AlKaatib (Arabic Software Associates,
Inc., Provo, UT) not only does right-to-left word processing but han-
dles the Arabic character set appropriately, changing a letter’s shape
according to its position at the beginning, middle, or end of a word,
and forming ligatures (connected letters) as needed. Although sup-
plied with a font for Arabic and Persian, AlKaatib can process such
languages as Hebrew, Urdu, Pashto, and Sindhi with suitable fonts.
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Ergo Soft (Tokyo) has announced a Japanese kanji word processor,
EgWord. You enter the words on the keyboard in kana or romaji and
the software offers the likely matching kanji characters, which you se-
lect with the keyboard or the mouse.

Scientific Word Processors

Conventional programs cannot cope with the specialized needs of
scientific or mathematical word processing. You need to be able to
pick up and move individual characters, create special symbols, and
overlap those symbols to build formulas and equations. You should
also be able to define a set of symbols as a block and move all of them
together.

MacAuthor (pre-release; from Icon Technology, Leicester, Eng-
land) is a full-function word processor with special features for scien-
tific and academic use. According to announced specifications, you
can design your own symbols, up to a one-inch square. A nondestruc-
tive backspace option lets you overlap two or more characters. Text
and pictures can be on the same line; the program will run (or wrap)
the text around the picture. You can define formats for any portion of
text, recalling them with command keys. The MacAuthor file format
is not compatible with other word processors but the program can
read and write standard ASCII text.

Fonts with scientific, mathematical, and other specialized symbols
are widely available from many sources including Apple; you should
invest in one if you use these symbols often. The subscript and super-
script functions in MacWrite and Word come in handy but you can’t
put a superscript and a subscript on top of one another (example: x3).
You could adjust the characters with a font-editor program (for exam-
ple, put accent marks over letters), but this is not very flexible. Mac-
Write is somewhat less convenient than Word, since it always puts at
least one line of pixels between lines of characters. You can also create
the occasional equation with MacPaint or MacDraw and then move it
to the word processor via the Clipboard or Scrapbook.

Outline Processors

Think Tank, from Living Videotext, deals not with long, linear
documents but with outlines.

Any word processor can deal with an outline, of course. But word
processors can only show a screenful at a time; most of the time you
can see details in only one part of the outline—only the trees in the
midst of a forest.
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Think Tank tracks the relative importance of outline entries by the
indentation level. The program preferentially keeps the main head-
ings—the most important entries—on the screen. When you look at
an outline, you first see only main headings. You can then select any
heading and expand it, showing its subheadings. And, in turn, you
can select a subheading and expand it to show the sub-subheadings,
and so on. Because only the entries you select are expanded, the major
entries remain on screen. In effect, you can always see both the forest
and the nearby trees.

Think Tank comes in two versions, one for the 128-KB and one for
the 512-K B Macintosh. The 512-K B version adds the ability to include
pictures and graphics in the outline and has more traditional word-
processing functions. Think Tank uses nonstandard window scroll-
ing, a nuisance.

Spelling Checkers

Spelling programs compare your text against a stored word list and
flag all mismatches. Spellers generally come in two forms. Literal
spellers use a word list containing only complete words; singular and
plural forms are stored separately. Root-word spellers combine root
words with many standard prefixes and suffixes; plurals are con-
structed by adding -s or -es to the root words. Root-word spellers
take up much less storage space but will not catch many wrong words,
such as sheeps.

Spellers cannot check for homonym errors (peace of cake for piece
of cake) or for grammar, so you should never trust a speller to find all
errors; you must proofread the final text. Spellers ought to find dou-
bled words (the the) but most can’t.

Spellers are designed to work with specific word-processing pro-
grams; the one you choose must not disturb or be disturbed by the
formatting information in your files. Most spellers will let you add
words—such as a specialized vocabulary or names you use often—to
the spelling list. Some will help you with corrections, displaying close
matches to mismatched words and saving you the trouble of looking
up possible spellings. In general, the larger the spelling list, the more
useful—but only up to a point: Immense spelling lists will include so
many archaic and obscure words that some typos will be considered

valid words.
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The early Macintosh spelling programs are not impressive. Hay-
den: Speller (version 1.00) can check both MacWrite and Microsoft
Word files and you can edit the dictionary with the word processor.
The speller works as a freestanding program, separate from the word
processor, so you cannot switch quickly between editing and check-
ing spelling; during checking you see the suspect word and the previ-
ous line. Assimilation’s Mac Spell Right (first released version) is a
root-word speller specific to the word-processing program and in-
cludes a simple thesaurus function. Mac Spell Right works within
MacWrite so you can always see the full context and switch to normal
editing at any time, but its spelling list is inferior to Hayden’s.

Grammar Checkers

Grammar-checking programs are still primitive. They look for a
fixed set of common problems—stock phrases indicating wordy
prose, doubled words, or sexist phrases. If you write in view of the fact
that, the program might suggest because. Although simple-minded in
design, such programs can help clean up poor writing. A perceptive
user can even extract value from a simple word-frequency analysis. In
typical business writing, for example, of is more common than and;;
good writing reverses the order.

Much good writing bends the rules, however; grammar programs
won’t improve Shakespeare. Nevertheless, combining a grammar pro-
gram’s analysis with common sense will usually help. You’ll soon learn
to avoid many simple grammatical errors and can concentrate on mak-
ing complicated errors that no software can detect.

Language-Translation Programs

Programs that assist translation from one language to another are
beginning to appear. At this stage, these programs can only look up
word equivalents and do rudimentary sentence analysis; all require the
services of a skilled human translator to produce a finished product.
Nevertheless, these programs can speed up a translator’s work, par-
ticularly when specialized vocabularies are involved. True translating
programs that can give intelligible results on their own through syn-
tactic and semantic analysis are still some years away, though.
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acPaint and MacDraw, Apple’s two main graphics
programs, take different approaches to creating graphics and are best
suited to different tasks. MacPaint is unstructured, creating and stor-
ing the picture as a collection of pixels (or picture elements); a line in
MacPaint is a group of independent pixels, so you can change one pixel
without affecting the others. MacDraw, in contrast, is structured and
stores attributes. In other words, it stores information that places a
line of a particular length and thickness at a certain location with a cer-
tain orientation; when you make a change, you are changing the line
as a whole. In MacDraw one picture component can overlie another
and you can alter one without affecting the other. Thus MacPaint is
excellent for free-form drawing, but MacDraw is better for precise de-
sign work such as planning a room layout.

Objects created with either MacPaint or MacDraw can be incor-
porated via the Clipboard or Scrapbook in pictures created with the
other. On a 512 KB Mac you can even run both programs at the same
time with Apple’s Switcher utility (see Chapter 9). This chapter is
based on MacPaint version 1.5 and MacDraw version 1.7.

Note: For business graphs like pie charts and plotting data, see
Chapter 5; for graphic arts, see Chapter 17.
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MACPAINT

The superb MacPaint program by Bill Atkinson is the essence of
Macintosh. You can use it to create designs— your company logo, for
example—that you can incorporate into documents created by other
programs. You can print your logo along with the text you write with
your word-processing program or create an illustration to dress up a
business chart. Conversely, with suitable techniques or accessories,
you can turn a graphics image from virtually any source into a Mac-
Paint drawing,

What’s more, MacPaint is fun. Even people with no tolerance for
computer games find MacPaint absorbing and rewarding.

Starting the Program

&

MacPaint

Insert the MacPaint disk.

Double-click the disk icon to open the disk window (if necessary).
Double-click the MacPaint icon; or

Click the MacPaint icon and choose Open from the File menu.

The screen turns grey, with the word MacPaint replacing the desk-
top menu selections. After a few seconds, MacPaint appears and gives
you a blank drawing window labeled Untitled. You'll give it a title
when you are ready to save your drawing on your disk.

Tool boxes
File /Edit Goodies Font FontSize Style

I=—=mmmee———— untitled

Current pattern

Border palette Pattern palette
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The boxes on the left contain several drawing tools—a pencil, a
paintbrush, an eraser, a can of paint, and so on, plus a number of open
and filled shapes.

The border palette at the lower left shows lines of different thick-
nesses; you select these to control the border width of the open and
filled shapes.

The boxes along the bottom make up the pattern palette. The cur-
rent pattern selected from the palette is shown in the large leftmost
box. We’ll see how these patterns are used in a moment.

The best way to learn what each tool does is to experiment. Some
tools are self-explanatory: The pencil lets you draw free-form; the
paintbrush paints with lines and patterns; and the eraser erases.

Click the pencil to select it from the tools.
You can select any tool by clicking it.
Move the pointer to the drawing window.

The pointer changes shape in the drawing window depending on
which tool you're using. Now it’s a pencil.

Drag the pencil to draw something— anything.

When you've finished drawing, release the button. Drag the pencil
again to draw another line.

Click the straight line in the boxes to the left of the drawing window.
Move the pointer into the window.

The pointer changes shape to a crosshair.
Drag anywhere in the window and release the mouse button.

The line tool permits you to draw only straight lines (at some an-
gles the line is a little bumpy because each line is made up of discrete
points).

Press Shift and drag another line.

The Shift key is a “constrain” key; when it is depressed, you can
only draw vertical, horizontal, and diagonal (45-degree angle) lines.
Any line you draw will automatically be adjusted to one of these three
orientations.

Starting Out
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Drawing predefined shapes

Click the open rectangle in the center left tool box.

[

Point anywhere in the drawing window and drag to another point.
Release the mouse button.

| | 1 The starting and finishing points of the dragging action mark the

diagonal corners of the rectangle.

Similarly, you can select other open shapes and indicate what size
they should be by dragging.

If you press the Shift key while you drag the rectangle, it will be
drawn as a square; pressing the Shift key while dragging the ellipse will
draw a circle.

Moving part of the drawing

You can move any part of your drawing if you select it first.

Click the dotted-line rectangle in the top tool box.

1
|
a

The dotted-line rectangle is called the selection rectangle.
Move the pointer into the drawing window.

Drag the selection rectangle so it surrounds the part of your drawing you
want to move.

Position the pointer inside the selection rectangle.
Drag the rectangle and its contents to the new location.
-~ Release the mouse button.

This action deposits the rectangle’s contents in the new location.
P g

Click in a blank area, or choose another tool to get rid of the selection
rectangle.

Erasing part of the drawing

There are four ways to erase part of a drawing.

il / Click the eraser icon, and drag it over what you want to erase; or

2] T




Chapter 4:  Graphics Software

Select an area using the lasso (in the top left tool box) or the selection
rectangle and hit Backspace; or

Select an area with the lasso or selection rectangle and choose Clear from
the Edit menu; or

Choose the white pattern and use the paintbrush to paint over what you
wish to erase.

o

l_IP

Erasing the whole drawing

Getting rid of your doodles is easy; simply:

Double-click the eraser.

You can always undo your last step—but only the last step.

Choose Undo from the Edit menu; or

Type the * (top left) key.

Undoing the changes

Adding text to the drawing

You can add titles, labels, and captions to your drawings simply
and quickly with MacPaint.

Click the letter A to select it from the tools.
Choose New York from the Font menu.
Choose 18 point from the FontSize menu.

Points are a measure of type size; ordinary printed text is generally
10 or 12 point.

Choose Bold from the Style menu.
Style ]5[(31!? “{()l‘]{
.
Bold el 1 &8 point
1t6l/ic
Underline bold
Outline %0
Shadom %S
vAlign Left 8L
Align Middle
fAlign Right %R

A

Font

Chicago
vGeneva
New York
Monaco
Uenice

London
Athens

O point
10
712

14
08
24

36
48
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Click an open area in the drawing window.
Type aftitle or a label.

You can change the font and size by making a different choice from
the menus.

Moving to Another Part of the Page

Wi

Learning to Paint

The drawing window shows you only part of the whole drawing
page, which is 7%- by 9%2 inches. If you fill the drawing window and
want to move to another portion of the page:

Click the hand icon.
Drag the hand in the drawing window.

If you drag the hand upward, the drawing moves upward, exposing
a fresh portion of the page below it; if you drag the hand downward,
the window moves downward, exposing a fresh portion above it; and
so on.

On large drawings, it works best to move the drawing half a win-
dow at a time.

On a 128K Mac it takes a little time to bring a fresh portion of the
page into view, so the wristwatch icon appears to tell you to be patient
while Mac finishes its task.

MacPaint’s tool boxes contain three tools for painting: a paint-
brush, a regular can of paint, and a spray can of paint. We’ll experi-
ment with them here.

Click the paintbrush.
Move the pointer to the drawing window and drag the paintbrush.
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To select a brush of a particular size and shape:

Double-click the paintbrush; or

Goodies
Grid
FatBits

Show Page
Edit Pattern
Brush Shape [\
Brush Mirrors
Introduction
Short Cuts

Choose Brush Shape from the Goodies menu.

A window appears with the size and shape of the current brush
outlined by a box.

Click any brush size or shape.

You cannot continue painting until you make a choice; if you don’t
want to change the brush, you must click the size and shape already
selected in the box.

When you click a size and shape, the window disappears.

Drag the paintbrush in the drawing window.

The brush paints with the current pattern.

crCcCacC

Using the MacPaint palettes

Choose another pattern from the palette along the bottom of the screen.

Choose the filled rectangle from the tools to the left.

Move the pointer to the drawing window.

61
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Drag the pointer diagonally across the window and admire the results.
Choose a different border width from the border palette.
Drag across the drawing window again.

Choose a different shape (for example, the filled oval) and again drag the
pointer.

Experiment with different tools and patterns; try the paintbrush
and spray can, using different patterns.

Filling an area with a pattern

&

D4
X

Choose the open rectangle from the tools.
Draw a rectangle.

Choose the paint can.

Move the paint can into the rectangle and click.

If the white pattern is selected, nothing will happen; click another
pattern and try again.

Creating a new pattern

Double-click a pattern that is close to the one you'd like to create.

T VES =
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A dialog box comes up with the pattern detail greatly magnified on
the left and the overall pattern on the right.

Click individual squares of the pattern in the left box.

Each individual square represents a dot on the screen. Clicking in-
dividual squares changes their color; black squares become white,
white ones become black. The box on the right shows what the overall
pattern looks like when you change individual dots. When you are sat-
isfied with the new pattern:

Click the OK button.

When you click OK, the modified pattern replaces the pattern you
originally double-clicked. The pattern change is saved with the draw-
ing on disk.

If you change your mind, click Cancel.
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A Macintosh Self-Portrait

Let’s put some of these techniques together and have the Macintosh
draw a self-portrait. (Whether you, the hardware, or the software is
actually doing the drawing is a semantic question I will ignore.)

Double click the eraser to clear the window. ( )

Choose the rounded-comner open rectangte from the tools, and the second
border from the border palette.

Move the pointer to the drawing window and drag from top left to bottom

right to form the body of the Macintosh. N
Draw the screen the same way, using a smaller, square-comer open T
rectangle.

Choose the straight-line icon from the tools.

Hold down the Shift key while dragging a horizontal line to indicate Mac's
recessed lower front face. ! /

Choose the filled rectangle.

Choose a uniform gray dot pattemn.

Drag to form the keyboard connector. )

Choose the open rectangle.

Drag and build the disk-drive slot from two rectangles.

Using the selection rectangle (top right tool box), select the area where the r ==
two disk-drive rectangles overiap. - . :

Choose FatBits from the Goodies menu.

FatBits shows you a magnified portion of the drawing, surrounded
by the flickering selection rectangle. Each black square represents a
dot on the screen. You need to remove some dots to create the shape
you want.

Choose the pencil from the tool boxes.

Move the pencil into the drawing window and click on each dot you wish to
remove; drag the pencil to remove several dots at a time.

Clicking the pencil changes a square from black to white or white
to black; if you click in a white area, you create dots. If you take out
too many dots, use the pencil to put them back in.



SECTION TWO: A MACINTOSH SOFTWARE SURVEY

Macintosh

The results appear in proper scale in the inset at the upper left cor-
ner of the drawing window.

Click in the inset to restore the original drawing window.
Choose a suitable pattern for Mac's screen—horizontal lines, perhaps.

Choose the paint can, move it to the rectangle that represents the screen,
and click to fill in the screen.

For some finishing touches:
Choose the filled rectangle and drag a small rectangle for Mac’s Apple logo.
To make the Apple logo:

With the selection rectangle, surround the Apple logo and choose FatBits
from the Goodies menu.

Use the pencil to remove dots so you end up with something that looks like
an apple.

Label the drawing; try the Venice font at 14 point:
Choose Venice from the Fonts menu.
Choose 14 from the FontSize menu.
Choose Plain from the Style menu.
Select a location and type in the label.

One last touch. If something isn’t positioned just right:
Choose the selection rectangle from the tool boxes.
Surround the misplaced part of your drawing.

Use the pointer to drag the surrounded part of your drawing to precisely
where you want it.

Click in a blank area to clear the selection rectangle.
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Choose Show Page from the Goodies menu to see where your drawing
will appear on the 8Y%2- by 11-inch page.

The dotted rectangle represents your drawing window.

Press the mouse button inside the drawing window and drag to move it
anywhere you want it on the page.

Dragging any where else will reposition your drawing on the page.
The printed version will match your final choice.

Choose Save As. .. from the File menu to name and save your handiwork.

Type in an appropriate name and click the Save box.

save document as: [ paint

[macintosh self-portraif | ;
H

o (o) | Come)

Your Macintosh self-portrait will be saved as a file and will be given
a special icon that will appear in your disk window on the desktop.

Choose Print from the File menu to print your picture.

What you see in the MacPaint drawing window is only about a
third of a single 8%2- by 11-inch page. What you get when you print is
the whole page. If you've been experimenting, you may have mis-
cellaneous doodling on parts of the page outside the drawing window.

Notes on MacPaint

The active area of a MacPaint drawing window is 3% inches high
by 5% inches wide (14.2 by 8.6 cm). The active area can be moved
anywhere in a 7%- by 9Y-inch area on an 8%2- by 11-inch page, so a
full page of artwork can be created in separate sections but printed out
as a complete page.

One limitation in MacPaint is the size of the image you can select—
only as large as a MacPaint active window. Sometimes you need to
select a larger area, such as for a wide letterhead. The supporting soft-
ware for the ThunderScan image scanner and Paint Cutter (Silicon
Beach Software) lets you make such large selections.

6rid

FatBits
Show Page
Edit Pattern

Brush Shape
Brush Mirrors
Introduction
Short Cuts
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Close
Save
Save As...
Revert

Print Catalog
Quit
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For the best results, draw MacPaint images in the correct size from
the beginning. MacPaint lets you resize an object along the horizontal
or vertical axis, or both, but the resizing process distorts the image. If
you are making an object larger, the program at times doubles the
number of pixels to maintain the same relative weight; conversely, it
must delete dots if you reduce the size.

When you save pictures in MacPaint, each file includes some over-
head information. To save disk space, combine pictures into a single
file when possible.

For some enhancements to MacPaint, see Table 4-1.

MACDRAW

If you have experience with MacPaint, you won’t have much trou-
ble learning MacDraw. The tools are at the left side of the screen, but
the line weights are under the Lines menu and the patterns are found
under the Fill menu.
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You select objects rather than regions, and you can overlap objects.
Bring to Front and Send to Back under the Arrange menu let you
choose which objects are on top and visible. If you have trouble select-
ing an object, you can move obscuring objects temporarily. You can
treat a group of objects as a unit by selecting each one individually
(hold the Shift key down as you select them) and choosing Group
from the Arrange menu; you can also Ungroup the objects. To change
the position of any object, you click on the object so it is marked by
small black squares, and then drag the object to where you want it.

The MacDraw window scrolls in the usual way; you can have up
to four windows open at a time and can cut and paste between the
windows.

Here is how to draw a Macintosh with MacDraw:

Choose Turn Grid Off from the Layout menu.
This gives you more freedom in positioning objects.
Choose the rounded-corner rectangle tool and draw out a suitable shape.

The selected tool automatically switches back to the selection ar-
row after you use other tools.

Choose the square-corner rectangle tool and draw the screen.

Choose the straight-line tool and drag a horizontal line to indicate Mac's
recessed lower front face.

Choose the square-corner rectangle tool to draw the keyboard-connector
outline and then choose a suitable pattern from the Fill menu.

To get rid of the connector outline, choose the dotted line from the Lines
menu.

Creating a disk-drive slot that looks the same as the one created
with MacPaint is difficult. You have to create each line individually
and then group them, so fudge the slot with a single rectangle and fill it
with a dark pattern; you could also create the slot in MacPaint and
move it to MacDraw.

T )
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MacDraw has no FatBits function, so creating details like the
Apple logo is impossible. But you can go back to the MacPaint pic-
ture, copy the logo to the Clipboard, and paste it into the MacDraw
picture.

% File Edit Style Font Layout Arrange Fill Lines Pen &
om=—  — ——  JUMENE——— ==

TEZ000

Notes on MacDraw

Unlike MacPaint, MacDraw can scale drawings smoothly because
it recalculates each element from basic attributes. MacDraw can also
create large, multiple-page drawings.

Although MacDraw deals with objects effectively, it lacks some
features necessary for precise design work; supplementary software
may add these features to MacDraw and other programs under de-
velopment will include them.

Structured graphics, such as graphs from other programs, can usu-
ally be transferred to MacDraw via the Clipboard or Scrapbook.
Generally the pasted image appears with all objects selected. You can
immediately group all the objects into a single entity or you can group
them selectively.

MacDraw objects moved to MacPaint lose their structures and be-
come collections of pixels. If you move a MacPaint picture to Mac-
Draw, you will no longer be able to manipulate picture components;
the entire picture becomes a single MacDraw object. (If created by
early versions of MacPaint, large objects may be split into several
bands; if so, choose Group from the Arrange menu to keep the image
together.)
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For more professional design work, MacDraft (pre-release, from
Innovative Data Designs) is similar to MacDraw but contains many
additional features for precision design—you can zoom in and out,
rotate objects by 1-degree increments on-screen, and attach numerical
values to an object’s size.

PRINTING FROM MACPAINT AND MACDRAW

In standard-resolution printing on the Imagewriter, both MacPaint
(Print Draft) and MacDraw generate exact pixel-for-pixel correspon-
dence between the screen and printer. In the high-resolution mode on
the Imagewriter, MacPaint (Print Final) interpolates pixels with an
algorithm (group of instructions). The algorithm examines adjacent
pixels; if they are in a vertical or horizontal line, additional dots are
filled in. Since this won’t always be what you want, you will have to
experiment.

When you print MacPaint images on the LaserWriter, Print Final
performs 45-degree interpolation to smooth the corners between di-
agonally adjacent pixels. If the MacPaint picture is included in a Mac-
Write or other program document, selecting Smoothing in the Page
Setup dialog box adds the interpolation. MacDraw documents can be
printed smoothly at higher than screen resolution, since interpolation
of the pixels is based on the drawing attributes.
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Graphs 5

B preadsheet programs are the most popular business appli-
cation for microcomputers. They are powerful tools for calculation
and projection. Graphing programs take numeric input, either from
another program, such as a spreadsheet, or from the keyboard, and
generate charts in standard formats—bar graphs, pie charts, line
graphs, and so on.

USING SPREADSHEETS

Suppose you want to calculate the difference in cost between two
new cars. One model has better fuel economy but a higher price. Is it
cheaper in the long run to buy this model than one that consumes
more fuel but costs less? To do this calculation carefully without a
computer, you would take out a sheet of ledger paper and systemati-
cally enter each cost item. To get a total, you must make many as-
sumptions about the cost of gasoline, how many miles you expect to
drive each year, the interest rate on the car loan, and so on. Since you
can’t be sure how many miles a year you will drive, you have to repeat
the entire calculation several times for high, medium, and low esti-
mates. The process is so laborious that even an accountant would stop
calculating and start guessing after one or two repetitions.

You can set up the same analysis with a spreadsheet. A spreadsheet
works like a ledger sheet; it is organized in rows and columns. You can
link the value of any entry to that of any other entry with a mathe-
matical or logical formula. Once you have entered the values, the

4
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computer performs all the calculations. For a single calculation, a
spreadsheet may not be any faster than a calculator. But for repeated
calculations with changing values, called variables, the spreadsheet
shines. If you change any number—the number of miles you drive
each year, for example—the rest of the calculation is performed auto-
matically. The process is so much easier with a spreadsheet that you
can run dozens or hundreds of calculations painlessly. In the process,
you will come to learn the true cost of owning a car—where the
money really goes and which costs are essentially irrelevant to your
comparison.

Spreadsheets give you the power you need to plan ahead in your
business, too. For example, you can construct a spreadsheet model of
your income and expenses, using formulas to add tax and shipping au-
tomatically to each purchased item and to calculate discounts for vol-
ume purchases.

Spreadsheets aren’t just for calculations, though. If you need to
produce an organization chart or other textual material that is ar-
ranged in columns and rows, a spreadsheet works much better than a
word processor.

Macintosh Spreadsheets

On the Macintosh, you can choose among a half dozen spreadsheet
programs. First, I will illustrate a sprcadsheet application usmg Mi-
crosoft’s Multiplan spreadsheet. With minor changes, these instruc-
tions also apply to the other spreadsheets.

If you have used a spreadsheet program on another computer, you
will find that the Macintosh spreadsheets are a revelation. To begin
with, the screen is far easier to read. Instead of typing endless key-
strokes to perform such simple tasks as changing a column width, you
simply point at the line dividing two columns, grab it with your
mouse, and drag the column wider or narrower. If you want to have
two windows showing different parts of the spreadsheet, you grab a
split bar, and drag the column until the windows are set to your satis-
faction. It’s a lot easier to do than to describe. A conventional spread-
sheet on an ordinary computer is archaic and clumsy by comparison.

Microsoft Multiplan

In this Multiplan profile, we will build a spreadsheet model to ana-
lyze the cost of buying and owning a car. Although building the model
takes many steps, you should be able to have it running in 20 minutes.



Chapter 5:

I've included the complete model because it shows the power of a
spreadsheet, and because the results are interesting; most car owners
don’t really know where their money goes.

Put the Multiplan disk into the Macintosh.
Double-click the Multiplan icon.

& File Edit Select Formatl Options Calculate

e u"”"ed =

An Untitled window opens up, displaying an array of cells. The
pointer is shaped like a fat cross when moving over the cells.

Click any cell.

The cell color reverses. Clicking a cell selects that cell.

Each cell has an address: a row number down the left side and a col-
umn number across the top; R1C1, for example, is the address of the
cell at the intersection of row 1 and column 1. The selected cell’s ad-
dress is displayed in the formula bar along the top of the window. As
you click on different cells, the cell address in the formula bar changes.

The formula bar displays not only the cell address but also the con-
tents of the current cell.

Spreadsheets and Graphs

Starting Multiplan

Multiplan
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Entering labels

(D
I r3cr |@®| price

74

Click the first cell at the upper left (address: R1C1).
Type CAR COSTS.

The label appears in the first cell as you type it. If you make a mis-
take, backspace and retype.

Press the Return key.
The next cell down (R2C1) becomes the active cell.
Press the Return key again.

This step moves the active cell down one more (R3C1). You could
also have just clicked the next cell down.

Type Price and press Return.

If you make a mistake but don’t notice it until after you have
pressed Return, you can go back and correct the mistake in the usual
Macintosh way:

Click the cell with the mistake.
The formula bar at the top shows the active cell’s contents.
Drag through all or part of the contents to select it.
Delete the selection by pressing the Backspace key; or
Type a new entry.
Another method: Undo your last step.
Choose Undo Typing from the Edit menu.

If necessary, you can always retrace your steps. For a more com-
plete guide, see the Multiplan manual.
And now, back to entering labels:

Click cell R4C1.

Type Down Payment and press Return.
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Continue with:
Loan Value
Monthly Payment
1st Yr Cost
2nd-3rd Yr Cost
Fixed Costs
MPG
Running Costs
3YrTotal
Salvage Value
3 Yr Cost

After each entry, press Retum.

Some of the labels may be a little wider than the column. Until you
enter something in the cell to the right, you can still read the entire
cell’s contents; however, entries in column 2 may partially obscure
long labels in column 1, so let’s widen column 1 now:

Point at the line just above the first row dividing columns 1 and 2.
The pointer changes to a line with arrows.
Drag the pointer to the right until the column division clears all the labels.

Dragging to the right makes the column wider; dragging to the left
makes it narrower. All of the other columns move right or left, their
widths unchanged.

Click the first cell in the second column (R1C2).
Type Gas Cost and press the Tab key.

If you press Tab rather than Return after the entry, the active cell
moves to the right.

Type Miles Yr and press Tab.
Type Interest and press Tab.

Type Loan Term and press Return.

Spreadsheets and Graphs
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Entering variables

:Gas Cost :
1.3

Format
Dollar
Percent
No Decimal
Decimal
Scientific
Bar Graph

Number Of Decimals...

Rlign Left 8F
Align Center 86
filign Right %H
Commas

Column Width...
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Click the cell under Gas Cost (R2C2).
Type the cost of gasoline, say 1.30, and press Enter.

The entry appears as 1.3. Since most of this spreadsheet will show
dollar values, you can change the format of column 2 to display the
amount in dollars:

Select the entire column of celis by clicking the column heading.
The entire column is highlighted.
Choose Dollar from the Format menu.

Now all numeric values in the second column will appear with a
dollar sign and two decimal places.

Click the cell under Miles Yr (R2C3).
Type 12000 and press Tab.

We’ll use 12,000 miles driven in a year as a starting point. Because
this cell was not selected for the dollar format, there is no dollar sign.

Pressing Tab moved the selection to R2C4, the cell under Interest.
To enter the interest rate:

Type 0.14 and press Enter.

0.14 is 14 percent interest. As with the other variables, we can
change the loan interest later. To display it in percent format, make

sure that R2C4 is still the selected cell (pressing Enter doesn’t move
the selected cell):

Choose Percent from the Format menu.

The entry now reads 14.00%.
Click the cell under Loan Term (R2C5).
Type 36 and press Enter.

This sets a three-year, or 36-month, loan term.

1 I 2 [ 3 1
‘Miles Yr

4« | s T &

‘Interest ‘Loan Term !
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For convenience, name the four variables you have just entered.
You can then build up formulas with easy-to-understand names in-
stead of cell addresses like R2C2.

Click the cell containing $1.30 (R2C2).
Choose Define Name. .. from the Select menu.

A dialog box asks you for the name of this cell. Multiplan proposes
the name Gas_Cost, so you don’t have to type it. When you choose
Define Name for a particular cell, the program will automatically
look at adjacent cells for possible names.

Define Name

Name:

Press Enter.

This names the cell value. Pressing Enter does the same thing as
clicking the OK button in the dialog box.

Follow the same procedure to define names for the cells containing
12000 (R2C3), 14.00% (R2C4,) and 36 (R2C5). Now you can start
building up the formulas for the main calculation.

Click the cell to the right of Price (R3C2).
Type 6000 and press Retumn.

$6000 is the price of an economy car.

The active cell is now R4C2, the cell to the right of Down Pay-
ment. The down payment is a quarter of the price. In the following in-
structions, use the mouse to perform the action given in [brackets].

Spreadsheets and Graphs

Naming variables

All Celis %A
Last Cell

Nae...

Lipk...

Show Active Cell $8S
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Entering formulas
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Type =.25x[click R3C2, the cell above] and press Enter.

You have told Multiplan to multiply (computers use * instead of X
to avoid confusion with the letter X) the price in R3C2 ($6000) by
0.25 and put the result ($1500) in R4C2.

Click the cell to the right of Loan Value (R5C2).
For the loan value, subtract the down payment from the price:
Type =[click R3C2, price]—[click R4C2, down payment] and press Return.
The monthly payment formula is the most complex:

Type =([click R5C2, loan value] * Interest/12)/(1—(1+interest
/12)*(—Loan_Term)) and press Enter.

Untitled : =

2 | 3 I 4 | 5
| 1 _|CARCOSTS interest Loan Term |
2| _14,00%, EL T s |
| 3 [proce -
|_4_|Cown Payment  :
| S [Loan Value .00 .
L"“Q!‘.!"!‘Y.F'“Y?T!e"{‘

This is the standard formula for monthly loan payments; your bank
may use a slightly different one. The * symbol indicates an exponent.

Check the entry for accuracy.
The formula bar should show:

=(R[—1]C=*Interest/12)/(1—(1+Interest/12) * (—Loan_Term))

If you put in spaces around the symbols, Multiplan removes them.
The R[—1]C is the address of the loan value cell you clicked relative to
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the address of the cell where you were entering the formula (up one
row, same column).

Edit the line if necessary to correct mistakes.

The first-year cost of the loan is the down payment plus 12 monthly
payments:
Click the celi to the right of 1st Yr Cost (R7C2).

Type =[click R4C2, down payment]+12x[click R6C2, monthly payment]
and press Retum.

If you see ##### in the cell, the column is too narrow. Open it
up as described earlier, dragging the divider between columns 2 and 3
to the right.

The selected cell (R8C2) is now the one to the right of the label,
2nd-3rd Yr Cost.

Type =24x[click R6C2, monthly payment] and press Retumn.

The next item, Fixed Costs, includes car registration, insurance,
and maintenance.

Type 800 and press Return.
The next item is MPG—miles per gallon.
Enter 30 and press Enter.

Since miles per gallon isn’t a dollar value, you need to delete the $
sign. Make sure cell R10C2 s still selected:

Choose General from the Format menu.
The cell contents change from $30 to 30.

For Running Costs, click R11C2, then type =Gas_Cost*Miles_Yr/[click
R10C2, mpg] and press Return.

For 3 Yr Total, type =[click R7C2, 1st yr cost]+[click R8C2, 2nd-3rd yr
cost]+3=*[click R9C2, fixed costs]+3+click R11C2, running costs] and
press Return.

Spreadsheets and Graphs
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1 [z ] The next item, Salvage Value, is the expected selling price of the car
after three years. A $6000 car might sell for $4500 after three years.

3 lprice
| 4 |Down Payment  °
| S |Loan Value

Type 4500 and press Return.

For 3 Yr Cost, type =[click R12C2, 3 yr total]—[click R13C2, salvage value]
and press Return.

10
11 |Running Costs

|12 |3 Yr Total :$10998
13 |salvage value ' $4500. 0 Now you're ready to see the power of a spreadsheet. You can
14 |3 ¥r Cos $6496.7

e T change any variable—the price of gasoline, the price of the car, the in-
terest rate—and all the affected numbers will change. What if the
price of gasoline were to decrease or, more likely, increase dramat-
ically? Click R2C2, gas cost; vary the gas cost from $1.30 to $4.00
and watch how the 3 Yr Cost changes. The total cash outlay for a car
at the end of three years (3 Yr Total) is sobering; think how many
Macintoshes you could buy.

Duplicating the model

If you want to compare several cars, you can change the price and
other entries, but then you won’t be able to compare two cars directly
because the new entries will erase the old.

The better way to make a comparison is to build up a second col-
umn. You could retype everything, but Multiplan lets you duplicate a
column quickly.

i [ =2 | = 1|

CAR COSTS :Gas Coat Miles ¥r

[elelso]of 4]

o

l

i

N

|

| $9736.76 !
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Drag in the second and third columns starting at R3C2 (price) and going
down to R14C3 (3 yr cost).

This selects the cells in column 2 that you want to copy and tells
Multiplan where to put them. If you wanted to copy column 2 more
than once, you would simply select more columns.

Choose Fill Right from the Edit menu.

Voila! The contents of column 2 are cloned into column 3.

Now change the appropriate figures—price, fixed costs, mpg, and
salvage value—for a second car.

You can repeat this duplication for as many columns as you like.
You can then see what happens if the price of gasoline goes up to $5.00
per gallon. Or if you drive 30,000 miles a year. Or the interest rate
drops to 10 percent. If you are interested in what your present car is
costing you, you might as well treat its current value as its price. This
strategy adds interest charges to the cost and thus reflects true costs,
since if you had the money instead of the car, you could invest the
money and earn interest on it.

With the model you've created, you can calculate the real difference
between a $6000 car with 30 miles to the gallon and a $9000 car with
40 miles to the gallon. The model will tell you what the break-even
point is for holding on to an older gas guzzler and buying a new
econobox.

1 I 2 | 3 |

CARCOSTS ' Gas Cost iMiles ¥r

Price 3
Down Payment
| 5 |Loon Value ° §
| 6 [Monthly Payment

Ist¥rCost

0.00
.00
. 'un

o 70 3

FEFEERE

10 |MPG

11 [Running Costs
3yr Total

13 |Sdlvage Value
[ 14 |3 ¥r Cost

15

3g
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To make this model easy to enter, I've kept it all on one screen. To
enlarge your model, read the Multiplan manual about how to freeze
the labels (titles) and make a split window. You can then elaborate the
fixed costs to include license fees, use taxes, and insurance, and have
the maintenance costs go up year by year.

CHARTS AND GRAPHS

A spreadsheet generates tables of numbers, the kind we’ve all seen
in annual reports and statistical summaries. But the meanings of num-
bers are all too often obscured when they are printed in tables.

We can recognize and interpret graphics much more easily than
numbers. For the same reason that the icons in the Macintosh Finder
work more effectively than the massed text that passes for file direc-
tories on other computers, spotting trends or comparing two num-
bers is much quicker on a graph than itis in a gray column of numbers.

You could use programs like MacPaint or MacDraw to create
charts, but those programs cannot take numeric input and automat-
ically turn it into charts. Graphing programs can.

On the Macintosh, most graphing programs are a part of a spread-
sheet program; they plot numbers from the spreadsheet. Whether you
need its computational power or not, the spreadsheet provides a useful
vehicle for entering and checking your numbers before graphing.

The quality of the charts is not only a matter of personal taste. A
presentation-quality chart not only pleases the eye but is easier to un-
derstand. Different data values must be easy to discriminate; you
should be able to add numerical values to a graph for convenient refer-
ence. A good graphing program gives you many choices; programs
with limited choices force you to accept a few rigid notions of what a
graph should look like.

Many spreadsheet programs can accept data from several sources.
Microsoft Chart is a freestanding program, able to take information
either directly or from Multiplan and some other programs.
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COMPARING SPREADSHEETS

The first half-dozen spreadsheet programs for the Macintosh all do
at least an adequate job. They are listed here, beginning with the larg-
est spreadsheet size, and summarized in Table 5-1.

Microsoft Excel (version 1). This is among the most powerful spread-
sheets developed for computers so far and takes exceptional advantage
of the Macintosh interface; it includes comprehensive graphing capa-
bilities and a simple database function. You can define your own func-
tions and consolidate multiple spreadsheets. Excel is the only Macin-
tosh spreadsheet thus far to include a keyboard macro feature, which
means you can assign a series of commands and spreadsheet entries to
a simple keystroke combination. (A much more limited keyboard
macro function is possible for the other spreadsheets if you use an ac-
cessory utility program, but there may be compatibility problems; see
Chapter 9.)
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Crunch (version 1.0 from Paladin Software). This program includes
graphmg, a simple data base, and a 2¥2-page text editor. Twenty-one
icons give you direct access to common operations including format-
ting and graphing. You can define your own functions, change the text
style (plain, italic, bold, underlined) cell by cell, and consolidate
spreadsheets. Crunch does not have an Undo command. The graph-
ing function creates the most common types of graph, but you cannot
add annotations to your graphs.

iG] lEF S b DEEI=IB UMkt Q=]

The spreadsheet component of Jazz (release 1) from Lotus. Although
not as powerful a spreadsheet as Excel, Jazz includes word processing
and communications, as well as graphing and a simple data base. Jazz’s
most outstanding feature is live links to the word processor, but Jazz
cannot split a spreadsheet window, an annoying oversight. See Chap-
ter 7 for more information and a comparison with Microsoft products
for multiple tasks.

Quartet (version 1.0). This program from Haba Systems includes
business graphics, a simple data base, and a rudimentary but useful
text editor. The text editor can handle a maximum of 1000 characters
ata time—good for annotations but not for word processing. Quartet
employs an unusual system with arrow icons for moving around the
spreadsheet; this frees some space on screen for the data but makes
rapid movement around large spreadsheets awkward. Quartet lacks
an Undo command and does not automatically figure out whether you
are entering text or a number/formula; you must preface text entries
with an apostrophe.

Microsoft Multiplan (version 1.02). The first spreadsheet for the
Macintosh, Multiplan still works well even compared to newer com-
petitors. Multiplan’s main limitations are its maximum spreadsheet
size of 255 rows by 63 columns (although you can consolidate separate
files) and the necessity for a separate program, Microsoft Chart, to
create graphs.

ClickOn Worksheet (first released version). This is a spreadsheet
desk accessory from T/Maker Graphics. Despite the necessary re-
strictions of a desk accessory, ClickOn manages surprisingly com-
plete features, including simple graphs. For some people, ClickOn
may be all the spreadsheet they need; others might use it in addition to
a conventional spreadsheet. You cannot, however, move ClickOn
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spreadsheet formulas to another program. You cannot scroll or split
the spreadsheet window or split the screen, but you can overlap col-
umns. ClickOn has manual calculation only and it lacks an Undo
command.

Spreadsheets and Graphs

Notes on Spreadsheets

All spreadsheets can perform the common functions. The two Mi-
crosoft products work in similar ways, but other spreadsheets differ
enough in details that you probably should select one program and
stick with it. You can move information between some programs, but
many specific features will be lost. If you need to move data to or from
an IBM PC, see Chapter 27.

Although ordinarily used for numeric calculations, spreadsheets
work much more effectively than a word processor for creating tables
of text. Moving an entry from one portion of a table to another is dif-
ficult with a word processor, but is easy with a spreadsheet. Most
spreadsheets distinguish between text and values by the characters
you type, but you can force them to treat a number as text; check the
manual for details. When you have finished, you can copy the table to
the Clipboard and then paste it into a word-processing document.



Business
Programs

icrocomputers have been much more successful and
useful in business than in the home. This chapter surveys a wide range
of programs aimed at business and professional users.

A data base is an organized collection of information, or data; for
example, an address book is a data base. A specific database file is
made up of records (such as a complete address), each of which is in
turn made up of fields (name, street address, zip code, and so on). You
index a data base by a field; most address books are indexed by name,
as are telephone directories.

One reason computerized data bases are so powerful is that you
can change the index field; you can index on zip codes instead of
names when you are preparing a mailing. You can also index on more
than one field. And you could select only those records with fields
that meet specific criteria; for example, you can request all the Jack-
sons who live in Chicago.

A database program lets you enter, sort, update, find, and print
your data quickly and easily. Although the idea of a data base is simple,
database programs are the most complex of the common microcom-
puter applications. The most powerful go far beyond simple func-
tions, letting you define relationships between data entries, perform
statistical and accounting calculations, extract and reorganize the
data, and much more.

Chapter
5 P

DATA BASES

87
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Traditionally, the problem for the user has been deciding how
much power to buy; the more powerful the database program, the
more difficult it has been to use. The Macintosh interface has helped,
and the best database programs for the Mac are easier to use than their
equivalents on other computers, but programs boasting great power
are thus far still troublesome and difficult to learn.

Certain database programs have been the poorest of all Macintosh
programs so far. Several were converted from earlier versions designed
to run on other microcomputers, and these take minimal or no advan-
tage of the Macintosh interface. You should examine a program with
special care if it runs on the Macintosh in the same way that it runs on
older computers.

Selecting a Data Base

First, the essential requirements; a database program should offer
all of these features:

» Field types. The very simplest data bases use only text fields.
But if a data base only recognizes text, not numbers, the
program cannot perform any calculations on fields. Nearly
all programs let you define text and numeric fields, and
many also include date fields for time-dependent financial
calculations and logic fields for true-false information.

¢ Data entry. You should be able to edit any text entry just as
you do in MacWrite—double-click to select a word, shift-
click to extend a selection, and so on. You should be able to
select a portion of any entry and where valid cut, copy, or
paste it to any other entry (pasting a text entry into a purely
numeric field doesn’t make sense, of course). For conve-
nience, you should also be able to create a custom form on-
screen for data entry.

* Sorting. The program should let you select a field and sort
on it. For most alphabetic applications, the sorting should be
a dictionary sort, sorting the letters regardless of whether
they are upper- or lowercase. For either alphabetic or nu-
meric sorts, you should be able to choose whether you want
to sort from lowest to highest or vice versa.

» Queries and reports. You should be able to ask for all
records meeting some criteria—for example, every sales-
person who sold over 500 widgets in a month.
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Output forms. All database programs should let you
organize and print out the information any way you want.
You should be able to do the positioning and sizing with
the mouse, so that you can change quickly from an address
directory to mailing labels. The reports should have an
optional six-lines-per-inch mode for printing onto stan-
dard mailing labels.

Print merge option. Information in the data base should be
easily combined with text from a word processor for form
letters. And more generally, you should be able to use the
Clipboard or Scrapbook to move information between

the data base and other programs.

Other features are useful to look for but, depending on your needs,
they are a