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LIMITED W ARRAN1Y ON MEDIA AND REPLACEMENT 

If you discover physical defects in the manuals distributed with an Apple product or in the 
media on which a software product is distributed, Apple will replace the media or manuals 
at no charge to you, provided you return the item to be replaced with proof of purchase to 
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software. In addition, Apple will replace damaged software media and manuals for as long 
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upgrade or update method, this program offers additional protection for up to two years or 
more from the date of your original purchase. See your authorized Apple dealer for 
program coverage and details. In some countries the replacement period may be different; 
check with your authorized Apple dealer. 

All IMPLIED WARRANTIES ON TIIE MEDIA AND MANUAIS, INCLUDING IMPLIED 
WARRANTIES OF MERCHANTABWIT AND FITNESS FOR A PARTICULAR PURPOSE, 
ARE LIMITED IN DURATION TO NINE1Y (90) DAYS FROM TIIE DATE OF TIIE 
ORIGINAL RETAIL PURCHASE OF TlDS PRODUCT. 

Even though Apple has tested the software and reviewed the documentation, APPLE 
MAKES NO WARRANTY OR REPRESENTATION, EITIIER EXPRESS OR IMPLIED, 
WI'm RESPECT TO SOFTWARE, ITS QUAIITY, PERFORMANCE, MERCHANTABWIT, 
OR ~ FOR A PARTICULAR PURPOSE. AS A RESULT, THIS SOFTWARE IS SOLD 
"AS IS," AND YOU, TI1E PURCHASER, ARE ASSUMING TIIE ENTIRE RISK AS TO ITS 
QUAIITY AND PERFORMANCE. 

IN NO EVENT Wll.L APPLE BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, 
INCIDENTAL, OR CONSEQUENTIAL DAMAGES RESULTING FROM ANY DEFECT IN 
TIIE SOFTWARE OR ITS DOCUMENTATION, even if advised of the possibility of such 
damages. In particular, Apple shall have no liability for any programs or data stored in or 
used with Apple products, including the costs of recovering such programs or data. 

TIIE WARRANTY AND REMEDIES SET FORTII ABOVE ARE EXCLUSIVE AND IN LIEU 
OF All OTIIERS, ORAL OR WRITTEN, EXPRESS OR IMPLIED. No Apple dealer, agent, 
or employee is authorized to make any modification, extension, or addition to this warranty. 

Some states do not allow the exclusion or limitation of implied warranties or liability for 
incidental or consequential damages, so the above limitation or exclusion may not apply to 
you. This warranty gives you specific legal rights, and you may also have other rights which 
vary from state to state. 
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p R E F A c E 

Preface 

YPERCARD® IS A NEW KIND OF SOffiVARE-A UNIQUE INFORMATION 

environment for your Apple® Macintosh® computer. Use it to look for and 

store information-words, charts, pictures, digitized photographs-about 

any subject that suits you. Any piece of information in HyperCard can 

connect to any other piece of information, so you can find out what you 

wanr to know in as much or as little detail as you need. 

xiii 



xiv Preface 

How to use this guide 

This guide covers everything you need to know to use HyperCard (except 
writing your own instructions-or scripts-to HyperCard). Begin by reading 
Chapter 1 to determine what hardware, software, and experience you need. 
Then, to learn the basics of HyperCard, work through the tutorials in 
Chapters 2 and 3. The remainder of this guide can be used for reference. Use 
the table of contents and the index to locate instructions for specific tasks 
and commands. 

The chapters and appendixes in this guide are described in detail below. 

• Chapter 1, "Getting Ready," helps you prepare to use HyperCard. It 
explains what you need to use HyperCard and gives instructions for 
installing HyperCard on a hard disk. 

• Chapter 2, "Browsing and Editing," is a tutorial on getting around in 
HyperCard. It teaches you how to use some of HyperCard's most 
important features. 

• Chapter 3, "Customizing," presents two more tutorials. These tutorials 
teach you how to customize HyperCard documents (called stacks) for 
your own use. 

• Chapter 4, "Home," gives details about this all-important HyperCard 
stack. 

• Chapter 5, "Text in HyperCard," provides information on HyperCard fields 
(the places you create to hold text), how to enter text into those fields, 
and how to control text styles. 

• Chapter 6, "Graphics in HyperCard," pulls together HyperCard's graphic 
elements and suggests ways to use various HyperCard tools and 
commands to produce finished pictures. 

• Chapter 7, "Menu Commands," gives detailed descriptions of every 
HyperCard menu command. This chapter also includes step-by-step 
instructions for carrying out HyperCard's most common procedures. 

• Chapter 8, "Keyboard Commands," summarizes all the HyperCard 
commands and features that you can execute directly from the keyboard. 

• Appendix A, "Common HyperCard Messages," lists the most common 
instructions you send to HyperCard using a feature called the Message 
box. (This appendix is for advanced HyperCard users.) 



• Appendix B, "HyperCard Disks," gives a listing of the documents and 
other files on each of the disks that comes with HyperCard. 

• Appendix C, "Using HyperCard Without a Hard Disk,' gives instructions 
for building the startup disk you need to use HyperCard with SOOK disk 
drives. This appendix also explains the special requirements and 
considerations for using HyperCard without a hard disk. 

Conventions used in this guide 

Several special elements in this manual's text are designed to make learning 
easier. 

Additional information and helpful hints are presented in notes like the one 
below: 

•:• By the way: A note like this presents additional information or 
interesting sidelights. 

Important information that you'll need to know is presented as follows: 

6. Important Be sure to read everything that's labeled this way. 6. 

Critical information is presented in Warning notes. These notes warn you 
about situations in which you can lose valuable data or damage software: 

.A. Warning Warnings like this alert you to situations where you 
could damage software or lose data. .A 

Terms in boldface type are defined in the glossary. 

In the tutorial chapters, Chapters 2 and 3, a special red symbol indicates 
procedures that you should follow: 

.,.. This symbol indicates procedures you should perform in the tutorial. 

Conventions used in this guide 
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Throughout this manual, numbered steps in boldface type give step-by-step 
instructions for a procedure. 

A special typeface indicates characters that you should type: 

It looks like this. 

Getting help in HyperCard 

While you're working with HyperCard, you have two primary sources of help 
and information-this user's guide and HyperCard's on-line Help system. (On­
line help is assistance you can get from a software program while it's 
running.) Although both of these sources provide a lot of information about 
HyperCard and cover the same topics, they give different kinds of help: 

• This guide gives more detail than HyperCard's on-line Help system. Turn 
to this guide when you need an in-depth discussion of a topic. To find 
information quickly, look up the subject or command in the index or table 
of contents. 

• On-line Help provides immediate assistance presented on your computer's 
screen and gives a brief discussion of each topic. You get to the 
information you need by clicking buttons and by doing electronic 
searches. You can use on-line Help when you've forgotten some 
procedure you read about in this book, or when you want a quick 
overview of a feature that's unfamiliar to you. On-line Help uses 
HyperCard's features to explain HyperCard, and stands as an example of 
what HyperCard can do. 

•:• If you're using HyperCard without a hard disk: You'll have to do some 
disk swapping to use HyperCard's on-line Help system. (See Appendix C 
for instructions on using Help without a hard disk.) You may find it's 
faster and easier to use this guide to get the information and help you 
need. 



Where to get HyperCard stacks 

Stacks are collections of information created by and used with HyperCard. 
(See Chapters 2, 3, and 4 for examples of HyperCard stacks and their use.) You 
can create stacks yourself, or you can get them from a variety of sources, 
including the following: 

• You'll find HyperCard stacks for sale at your local computer software 
store. 

• Check with your local Macintosh user group to find out the meeting rime 
of the HyperCard special interest group. Members often exchange 
member-created stacks with each other. 

• Most on-line electronic information services like CompuServe and GEnie 
have Macintosh special interest groups. These groups have stacks you can 
get free, except for the service's time charges. 

User groups 

Macintosh user groups can be a great source of information about HyperCard, 
and about Macintosh in general. Members of user groups meet to share ideas, 
discuss problems, and exchange software and information. By attending user 
group meetings, you can learn more about HyperCard and see how others are 
using it. 

Ask your dealer for the name of a Macintosh user group near you. If you live 
in the United States, you can call 1-800-538-9696 for the name, address, and 
telephone number of up to three Macintosh user groups in your geographic 
area. You can also get information about user groups from: 

The Boston Computer Society 
One Center Plaza 
Boston, Massachusetts 02108 
(617) 367-8000 

or 

Berkeley Macintosh User Group 
1442-A Walnut Street #62 
Berkeley, California 94709 
(415) 849-9114 

xvii 



xviii Preface 

Either of these organizations can provide you with the name of a Macintosh 
user group near you. You can also join either of these groups or ask them for 
information on starring your own Macintosh user group. 

Outside the United States, ask your dealer for information on user groups, or 
contact either of the organizations listed above. 

Additional documentation 

This guide covers everything you need to know to use HyperCard effectively 
up to (but not including) the scripting level. Scripts are programs that 
control the actions of HyperCard objects. See the HyperTalk Beginner's 
Guide: An Introduction to Scripting (included with HyperCard) for an 
introduction to scripting and a tutorial on HyperTalkrn, HyperCard's 
scripting language. 

For detailed reference information about scripts and HyperTalk, see the 
HyperCard Script Language Guide: 7he HyperTalk Language, available from 
Addison-Wesley Publishing Company. Several other excellent books have been 
written about HyperTalk; check with your favorite bookseller to see what 
books are currently available. 



c H A P T E R 

Getting Ready 

HIS CHAPTER HELPS YOU PREPARE TO USE HYPERCARD® SOffiVARE. IT 

explains what you need to use HyperCard and gives instructions for installing 

HyperCard on a hard disk. 

1 



About system software 

2 Chapter 1: Getting Ready 

What you need to use HyperCard 

HyperCard works in any Apple Macintosh computer with 1 megabyte of 
memory or more, and either two SOOK disk drives or one SOOK disk drive and a 
hard disk. If you use HyperCard with two SOOK disk drives (and no hard disk), 
you'll encounter special problems and limitations (explained in Appendix C, 
"Using HyperCard Without a Hard Disk"). HyperCard works best in systems 
with at least one SOOK disk drive and a hard disk drive. 

•!• HyperCard and MultiFinder: To get the most out of your system when 
you're using HyperCard and any other application under MultiFinder™, 
your system should have at least 2 megabytes of memory. Your 
authorized Apple dealer can quickly upgrade your system with the 
necessary extra memory. 

HyperCard works under System files with the version numbers in 
Table 1-1 (or higher version numbers). 

Table 1-1 System ftle versions 

Computer 

Macintosh Plus 
Macintosh SE 
Macintosh II 
Macintosh llX 
Macintosh IICX 
Macintosh SE/30 

System 

System 4.1 
System 4.1 
System 4.1 
System 6.0.2 
System 6.0.2 
System 6.0.3 

Finder 

Finder 5.5 
Finder 5.5 
Finder 5.5 
Finder 6.0.2 
Finder 6.0.2 
Finder 6.0.3 

To find out the version of the System file on your startup disk, look in the 
System file Get Info box. 

•:• LaserWriter users take note: To use a LaserWriter® printer with 
HyperCard, you must be using LaserWriter pnnter resource version 4.0 (or a 
version with a higher number). 



What you need to know 

What comes with 
HyperCard 

This guide assumes that you've already mastered the basics of your 
Macintosh. Before you use HyperCard, you should know how to: 

• use the mouse 

• initialize a 3.5-inch disk 

• copy files and disks 

• open disks, folders, applications, and documents 

• do simple editing 

• work with the Finder 

• use the directory dialog box to locate files 

If these are unfamiliar tasks, consult the Macintosh System Software User's 
Guide, the Macintosh Utilities User's Guide, or your Macintosh owner's guide 
for instructions. 

Besides this manual, your HyperCard package should contain the manual 
HyperTa/k Beginner's Guide: An Introduction to Scripting (a HyperTalk 
tutorial) and three disks, named as follows: 

• HyperCard and Stack<; 

• HyperCard Help 

• HyperCard Ideas 

In the unlikely event that anything is missing, contact your dealer 
immediately for a replacement. 

For a list of the stacks and other files on each disk, see Appendix B, 
"HyperCard Disks." 

What you need to use HyperCard 3 
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Copy your disks 

Before you do anything else, make copies of all the HyperCard disks to use as 
your working disks. Then put the originals away in a safe place. (You'll find 
instructions for copying disks in the Macintosh System Software User's Guide 
or your Macintosh owner's guide.) 

HyperCard is an inviting program to use and to experiment with. HyperCard 
documents are extremely easy to change- any changes you make to a 
HyperCard document are saved automatically, as soon as you make them. 
You might want to use your original HyperCard documents to replace a 
document you've experimented with; so it's important that you keep a set of 
these documents in their unaltered states . 

..,. If you're using HyperCard with a hard disk, proceed to the next section, 
"Installing HyperCard on a Hard Disk." · 

..,. If you're using HyperCard with two SOOK disk drives (and no hard disk), 
skip the next section and proceed to the section "Using HyperCard 
Without a Hard Disk," later in this chapter. 

Installing HyperCard on a hard disk 

This section assumes that you're using HyperCard with a hard disk and that 
your hard disk is already set up. If it isn't set up yet, see the Macintosh 
Utilities User's Guide that came with your computer and your hard disk 
owner's manual for instructions. 

To install HyperCard on a hard disk system, you simply copy all the files from 
all the HyperCard disks to your hard disk. The instructions below explain how 
to copy the HyperCard files to your hard disk. 

..,. Firsc, copy the files from the HyperCard and Stacks disk onto your hard 
disk: 

1. Start your computer. 



[d 
HyperCard &Stacks 

2. After the Finder desktop appears, insert the disk labeled 
Hyper<Ard and Stacks into your computer's built-in SOOK disk 
drive. 

If you have two BOOK disk drives (in addition to your hard disk), you can 
use either drive. 

3. Open the HyperCard and Stacks disk icon. 

To open the disk icon, click to select it and choose Open from the File 
menu. Double-dicking the disk icon also opens it. 

4. Choose Select All from the Edit menu to select all the files on 
the disk HyperCard and Stacks. 

5, Copy all the files by dragging them to your hard disk icon, or to 
the directory window of your hard disk. 

If you don't know how to drag files to a disk, see the Macintosh System 
Software User's Guide or the owner's guide that came with your 
computer. 

6. Eject the Hyper<Ard and Stacks disk by dragging its icon to the 
Trash. 

Dragging a disk to the Trash does not erase the disk; it ejects the disk 
and removes its icon from the desktop. 

Figure 1-1 Ejecting a disk 
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..,. Copy the HyperCard Help files onto your hard disk: 

1. Insert the disk labeledHyperCard Help into your computer's 
built-in disk drive. 

2. Open the HyperCard Help disk icon. 

3. Copy the Help Stacks folder and its contents by dragging the 
folder's icon to your hard disk icon or to the directory window 
of your hard disk. 

4. Eject the HyperCard Help disk by dragging its icon to the Trash. 

..,. Copy the files from the HyperCard Ideas disk onto your hard disk: 

1. Insert the disk labeledHyperCard Ideas into your computer's 
built-in disk drive. 

2. Open the HyperCard Ideas disk icon. 

3. Copy the Idea Stacks folder and its contents by dragging the 
folder's icon to your hard disk icon or to the directory window 
of your hard disk. 

4. Eject theHyperCard Ideas disk by dragging its icon to the Trash. 

HyperCard is now installed on your hard disk and ready to go. 

•:• \Vhere's the document? If HyperCard can't find a particular document, it 
displays the directory dialog box and asks where to find the document. 
(The techniques for using the directory dialog box are given in the 
Macintosh Utilities User's Guide or in your owner's guide.) You have to 
tell HyperCard where to find a document only once; it will know where to 
look after that. 



Using HyperCard with MultiFinder 

MultiFinder is an operating system for the Macintosh that makes it 
possible to have several applications open at the same time. MultiFinder 
comes with Macintosh system software version 5.0 and versions with higher 
numbers. (See the MultiFinder User's Guide or the Macintosh System Software 
User's Guide for information about MultiFinder.) 

To use HyperCard under MultiFinder, your system should have at least 2 
megabytes of memory. If you're using HyperCard with MultiFindcr, you can 
change the amount of memory set aside for HyperCard before you begin (as 
explained in the steps below). Normally, HyperCard is allotted lOOOK of 
memory-unless you change the memory allotment. HyperCard works well 
with MultiFinder when HyperCard is allotted lOOOK of memory or more. If 
you set aside less than 700K of memory for HyperCard, scripts using Paint 
tools won't work and you won't be able to paste graphics. (Other unexpected 
problems may also occur.) 

If you want to change the memory allotted for HyperCard to use, follow 
these steps: 

1. In MultiFinder, click to select the icon for HyperCard. 

2. Choose Get Info from the File menu. 

3. Double-dick to select the number in the box labeled 
Application Memory Size. 

4. Type any number higher than 699. 

HyperCard works best when the number in this box is 1000 or higher. 

5. Click the close box. 

Using HyperCard with MultiFinder 7 
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Using HyperCard without a hard disk 

HyperCard and the stacks that come with it require a lot of disk space. When 
you use HyperCard with SOOK disk drives (and no hard disk), you'll be affected 
by the limited disk space in a number of ways. The special considerations, 
requirements, and procedures for using HyperCard without a hard disk are 
explained in Appendix C. 

.,. If you're using HyperCard without a hard disk, proceed as follows: 

1. First go to Appendix C and follow the instructions there in the 
section "Creating a 3.5-Inch Startup Disk" to create the startup 
disk you need to run HyperCard. 

2. If you're using HyperCard with MultiFinder, read the section 
"Using HyperCard with MultiFinder," earlier in this chapter. 

3. When you're ready to begin the HyperCard tutorials, go on to 
Chapter 2. 
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Browsing and Editing 

LIS CHAYfER TEACHES YOU HYPERCARD BASICS. IT COVERS TIIINGS 

everyone must know to use HyperCard. You'll learn how to: 

• use some important HyperCard documents (called stacks) 

• look through HyperCard stacks 

• search for information 

• edit text on cards (HyperCard's basic unit of information) 

• create places to hold new information 

9 



6. Important 

Getting the most from the tutorials 

Throughout this chapter and Chapter 3, you'll see sentences that begin with 
the red symbol .,.. . This symbol marks actions for you to take co gain 
experience with HyperCard. Follow any numbered steps in order. 

Getting started 

Before you can start your tutorials, you need to get HyperCard up and 
running. 

Make sure your Home stack is either in the same folder as HyperCard, or in 
the HyperCard Stacks folder. Otherwise, you'll have to specify where it is 
each time you start HyperCard. !::,. 

.,.. To start HyperCard from a hard disk, select and open the HyperCard icon. 

Click the HyperCard icon to select it. Then choose Open from the File 
menu. (You can also double-dick the icon to open it.) 

.,.. If you're using HyperCard with 800K disk drives (and no hard disk): 

1. Start the computer. 

If the computer is already on, choose Restart from the Special menu. (If 
you don't have Restart, choose Shut Down.) 

2. Put a copy of your HyperCard Startup disk into the internal drive. 

See Appendix C for instructions on how to create this disk. 
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6 Important Although you can use HyperCard with a locked disk (or a locked volume), 
changes you make to stacks on a locked disk won't be saved. If you want 
your changes saved, make sure that any disk you use is unlocked. 6 

3. Put a copy of the HyperCard and Stacks disk into the other drive. 

4. When the Finder desktop appears, double-click the HyperCard 
icon (in the HyperCard and Stacks window) to open it. 

You see the screen in Figure 2-1. 

Figure 2-1 Starting HyperCard 
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What is HyperCard? 

HyperCard is an information toolkit You can use HyperCard to gather, 
organize, present, search, and customize information. 

In HyperCard, you can link together related information so that a single 
mouse click takes you to just the information you want to see- you can 
define the relationships between pieces of information. 

You can also use HyperCard to access information assembled by others, and 
add your own information to what's already there. 
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Some definitions 

Stack icon 

Before you start to explore HyperCard, you'll need to know a few tenns­
specifically card, stack, tool, browsing, and button. 

In HyperCard, infonnation appears on cards. On a Macintosh Plus or SE, a card 
fills the entire screen. On larger-screen Macintoshes (like the Macintosh II) 
and on larger monitors, a card appears in a window-you have some extra 
room on the edges. Cards can have both text and pictures. What you see on 
the screen now is a card; Figure 2-2 shows some others. 

Figure 2-2 Some cards-HyperCard's fundamental units of information 

A named collection of cards is called a stack. Cards in a stack are usually (but 
not necessarily) based on the same theme-they usually share the same look 
and contain similar information. An icon for each stack appears in the Finder. 

..,. Move the mouse around. 

HyperCad has many tools that you use to look for and to create 
infonnation. The little hand you see moving around when you move the 

Browse tool mouse is the Browse tool The Browse tool is the tool you'll use most 
often. 
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Letting HyperCard teach 
you 

Browsing is HyperCard's tenn for moving through cards and stacks. 

You can browse through cards- within the same stack or among different 
stacks-by clicking buttons with the Browse tool. By clicking buttons, you 
can also do a lot more than go to other cards and stacks-you can dial a 
phone, keep track of money, learn a new subject, or even control a video 
disk player. 

You can learn a lot about HyperCard just by using it. 

You can begin to learn more about HyperCard by going through the on-line 
Introduction. (On-line means presented on the screen by the computer, as 
opposed to presented by this user's guide.) Go through the on-line 
introduction now . 

.,.. To start the on-line introduction from a hard disk, move the mouse until 
the Browse tool is on the Intro icon (it's near the screen's upper-left 
comer), and then click. 

The card in Figure 2-3 appears . 

.,.. If you're using HyperCard with SOOK disk drives (and no hard disk): 

1. Move the mouse until the Browse tool is on the Intro icon (near 
the screen's upper-left comer), and then click. 

The directory dialog box appears and asks where the Help stack is. 

2. Click the Drive button until you see the name of your startup disk 
above the Eject button. 

3. Click Eject to eject the startup disk. Insert the HyperCard Help 
disk into the disk drive. 

4. Insert the HyperCard Help disk into the disk drive. 

5. Double-click the Help Stacks folder in the directory dialog box 
to open it. 

What is HyperCard? 13 



Previous 
card arrow 

6. Double-dick the Help stack in the directory dialog box to 
open it. 

After you do this, your Macintosh ejects the HyperCard Help disk and 
prompts you to insert the startup disk. Follow the instructions you see 
on the screen. (You might have to repeat this process once or twice. Just 
keep following the instructions on the screen.) 

The card in Figure 2-3 appears. 

Figure 2-3 The first card of the on-line introduction 
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.,.. Click the button labeled "What is HyperCard?" 

During the introduction you might want to review a card you've already 
seen. To do that, click the left-arrow button to go back through the 
Introduction stack one card at a time. 

•:• You can always go back Another way ro see the previous card is to press 
the Tilde key. Stacks in HyperCard often link to each other (a concept 
you'll learn more about later). While the left arrow brings you to the 
previous card in the stack you're looking at, the Tilde key brings you to 
the last card you saw, no matter what stack it was in. 
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II>- When you get to the card titled "What Next?" (about 15 cards after the 
start of the on-line introduction), click "Home to explore on my own"; 
then come back to this guide and continue reading. 

If you're using HyperCard with SOOK disk drives (and no hard disk), tum 
off your computer when you're finished with the on-line Introduction. 
Then restart the computer using a copy of your HyperCard Startup disk, 
as described in "Getting Started," earlier in this chapter. Otherwise, you 
may have to go through a lengthy succession of screen prompts asking 
you to insert different disks in the disk drive. 

Home 

When you start HyperCard, you see the Home card. You'll see Home more 
than any other card. Home is your base of operations, the jumping-off point 
for your explorations in HyperCard. 

Figure 2-4 The Home card 
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Go menu 

The Home card, first card in the Home stack, is a visual directory for your 
most important cards and stacks. Clicking one of the pictures here brings you 
to the card that the picture represents. (Each picture is actually a button.) In 
Chapter 3, you'll learn how to add to the Home card pictures representing 
your own cards and stacks. 

To get back to Home at any time, choose Home from the Go menu. 

•:• About the Go menu: The Go menu is HyperCard's navigation panel. You 
can use it to go from one card to another within a stack, to trace your 
way back through cards and stacks you've already seen, and to get help 
whenever you need it. In the early stages of working with HyperCard, 
you're likely to use the Go menu more than you'll use any other menu. 

In a few moments you'll use the Home card to move to the Address stack. 
The Address stack is your personal telephone directory. 

As you learn how to use the Address stack, you'll pick up a valuable 
HyperCard skill-how to look for information by searching for specific text 
rather than browsing from card to card. 

Using the Address stack 

The Address stack holds addresses and phone numbers. You look for a 
specific name, address, or phone number using the Message box . 

..,. Open the Address stack and look for a name: 

HyperCard comes with some sample Address cards; in this exercise, you'll look 
for a card with the name Steve on it. 

1. Click the button that looks like an address card. 

The card in Figure 2-5 appears. 
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Figure 2-5 The first card in the Address stack 
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2. Choose Find from the Go menu. 

' r 

The Message box appears near the bonom of the screen. (See Figure 2-6.) 
The insertion point is positioned between the quotation marks for you. 

Figure 2-6 The Message box 

3. Type Steve and press Return. 

(You have to type between the quotation marks for Find to work.) The 
card in Figure 2-7 appears. 
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Figure 2-7 Finding a card 
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•!• "It beeped at me!" If the Macintosh sounds a beep, reset the Message box 
by choosing Find from the Go menu and once again type what you want 
to search for. HyperCard beeps to let you know it can't find what you ask 
for. Sometimes this means that you spelled something incorrectly, and 
sometimes it means that what you asked for isn't in the stack. 

HyperCard looks for the first card with text that starts with what you 
typed, and puts a box around the word. Pressing Return again makes 
HyperCard look for the next card with Steve on it. 

~ Look for part of a word or name: 

HyperCard looks for what you ask, even if what you type is part of another 
word. You can see this work if you type ST in the Message box. 

1. Reset the Message box by choosing Find from the Go menu again. 

Each time you choose Find, HyperCard highlights any old text between 
quotation marks. The highlighted text will be replaced by any new text 
you type. 

2. Type s T into the Message box and press Return. 

Press Return a few more times, and see the results you get. 
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Figure 2-8 Finding other words that start with ST 

You can learn more about searching later by reading the section called "Find" 
in Chapter 7. 

A quick browse/ search recap 

Find is another new way for you to get around in HyperCard. It's different 
from the other ways in that it's more specific- you have to know what 
words you want to find in order to use it. 

You now know several ways to get arourid in HyperCard: 

• click bunons with the Browse tool 

• choose from the Go menu 

• search for a specific word using the Message box 

Using the Address stack 19 



Changing text 

In this section you'll change the information on one of the cards. (In the next 
section you'll personalize the Address stack by putting in the names and 
phone numbers of people you know.) 

~ Use the Message box to reach a card; then change the card: 

1. Choose Find from the Go menu. 

When the Message box is already visible, choosing Find resets the Message 
box, highlighting anything you've typed between quotation marks. 

2. Type Scribble and press Return. 

HyperCard looks for a card with the word "Scribble" on it. (Figure 2-9 
shows the card.) 

3. Select the name Throckmorton by dragging across it. 

Dragging is a standard Macintosh technique that you're probably already 
familiar with: Position the I-beam pointer at the beginning of the word. 
Press and hold the mouse button while you "drag" the pointer across the 
word. Release the mouse button at the end of the word. If you've done 
this successfully, Throckmorton is highlighted. 

4. Type the name John. 

The new name replaces the old one. 

5. Close the Message box. 
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Figure 2-9 Changing an address card 
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You can select any text (except Paint text, described in Chapter 7) by dragging. 
Then type new text to replace it. 

For more details on editing text, see the section "Edit Menu" in Chapter 7. 

Adding a card 

You can personalize all the cards in the Address stack by editing out the old 
text and adding new text. However, you'll probably find it easier to create 
new cards to hold your information. You add a card to any HyperCard stack 
by choosing New Card from the Edit menu . 

.,.. Add a new card to the Address stack: 

1. Choose New card from the Edit menu. 

A new card appears, ready for you to add your own information. (See 
Figure 2-10.) 

2. Type your name and address. 
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3. Press the Tab key to move the insertion point to the phone 
number line, and type your phone number. 

The Tab key moves you from field to field on a card in the Address stack. 
(A fie ld is where you type text.) This card has three fields-name and 
address, phone number, and date. 

4. Choose New Card again and add the name, address, and phone 
number of some close friend. 

Or, if you wane to get down to business right away, type in contact 
information for your neighborhood pizza delivery restaurant or some 
other vital service. 

Figure 2-10 A new address card 
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Continue to add cards if you want. \Vhen you've finished, go on to learn 
about how cards are arranged in a stack. 

•!• Don't wony about alphabetical order: You can create a new card wherever 
you want in the stack. In a few moments, you'll alphabecize the stack 
with che click of a button. 
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How cards are arranged in a stack 

When you choose New Card, HyperCard adds a new card to the stack 
immediately after the one that's on the screen. 

If all the cards in a stack are created at the same time, they appear in the order 
of their creation. If you choose New Card while you're near the middle of the 
stack, that's where the new card goes-in the middle of the stack. 

..,. Go through the stack one card at the time to see the stack's "natural 
order": 

1. Get to the first card in the stack by choosing First from the 
Go menu. 

2 Click the right arrow (the one that points to the right, next to the 
left arrow) to move through the stack, one card at a time. 

Eventually you'll come to the new cards you created. (Most cards in the 
stack are alphabetized; your cards will probably be out of order.) 

3. Keep clicking the right arrow until you come back to the first 
card in the stack. 

Think of the cards in a stack as being looped on a ring; when you reach 
the end, you start over again. (See Figure 2-11.) 

Figure 2-11 Cards ringed in a stack 

Adding a card 23 



Sort button 

Quick View 
button 

6 Important 

4. Sort the stack by clicking the Sort button (shown at the left). 

A dialog box appears with buttons for sorting by first name or last name. 
(See Figure 2-12.) 

Figure 2-12 The Sort dialog box 
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5. Choose Last Name to sort alphabetically by last name. 

The pointer turns into a beach ball; it spins while HyperCard completes 
the sort. 

6. Go through the stack quickly by clicking the Quick View button. 

(Click the mouse to stop the display.) You'll see the new cards you added 
sorted into their proper alphabetical place. 

•!• Getting rid of unwanted cards: The Address stack comes with a number 
of sample cards. You can eliminate the cards you don't want: move to an 
unwanted card and choose Delete Card from the Edit menu. 

You don't have to save your changes; HyperCard does it for you 
automatically. As a result, there is no Save command in HyperCard. You'll read 
more about this in Chapter 7. 6 
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Exploring the Help stack 

.,.. When you want to explore the Help stack, choose Help from the Go 
menu. 

You see the card shown in Figure 2-13. 

The Help stack briefly explains all of HyperCard's features. It's a useful 
information source and an excellent example of the kinds of things you can 
do with HyperCard. 

To use the Help stack, click one of the tabs along the card's bottom. (Each 
tab is actually a button.) 

•:• If you're using HyperCard without a hard disk: You'll have to do some 
disk swapping to use the Help stack. Appendix C gives instructions for 
using on-line help without a hard disk. 

Figure 2-13 The Help stack's first card 
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Click the Exit tab at the bottom of a card when you've finished using Help; 
you'll return to the card that was on the screen when you chose Help. 
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Recent: Seeing where you've been 

When you used the Address stack, you saw how cards are arranged in a 
stack-one after the other in a loop, as if they're held together by a ring. You 
clicked the left and right arrows to move from card to card. 

When you chose Help from the Go menu to get to the Help stack, and later 
when you pressed the Exit button to come back to the Address stack, you 
saw that you can move between stacks as easily as you move between cards. 

As you go from card to card and stack to stack, HyperCard automatically 
keeps a record of where you've been. The Recent command shows (in 
miniature) up to the last 42 cards you looked at. Choose Recent when you 
need to retrace your steps . 

.... Choose Recent from the Go menu. 

Figure 2-14 Recent card 
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A stack might have hundreds of cards in it, but if you've looked at only three 
cards in that stack, Recent shows only the three cards you looked at. 
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You can go directly back to any card represented in miniature in Recent. Try it 
now . 

.,... Go directly to a card shown on Recent: 

1. Click any card's miniature picture. 

(Each picture is actually a bunon.) You immediately go to that card. 

2. Choose Recent again on the Go menu. 

A rectangle encloses the image of the card you went back to. 

3. Click the image of the card you were on when you first chose 
Recent 

What you've learned so far 

In the short time you've used HyperCard, you've learned quite a lot. Among 
other things, you know: 

• how to use the Address stack 

• how to get from card to card and stack to stack using the Browse tool 

• how cards are arranged in a stack 

• how to see where you've been, and how to go back there 

• how to search for text 

• how to use the Home card as your base of operations 

• how to use several menu commands 

You already know enough to use most of the stacks that come with 
HyperCard and that are available for sale and for trade. (See "Where to Get 
HyperCard Stacks," in the Preface, for some specific places co get more 
stacks.) Mose sracks that require further instructions have a card or two 
telling you whac you need to know. 
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How to get there from 
here 

What to do next 

Here's a quick summary of the ways you've seen so far to find your way 
around HyperCard. They all come in handy at one time or another. 

Browse tool 

Home 

Recent 

First 

Last 

Click buttons with it to move to other cards. 

Choose Home from the Go menu to reach this graphic 
directory of stacks; then click the button for the stack 
you want to go to. 

Choose Recent from the Go menu for a pictorial 
summary of cards you've seen; then click the picture of 
the card you want to go to. 

Choose First from the Go menu to get to the first card in 
a stack. 

Choose Last from the Go menu to get to the last card in a 
stack. 

Find Choose Find from the Go menu; then type what you 
want to find and press Return. 

•!• Not sure where the buttons are? Hold down the Command and Option 
keys at the same time, and HyperCard lets you peek at buttons on a card. 

You can continue to work with the Address stack; you can go on to explore 
other stacks (Appendix B has a descriptive list of all the stacks that come 
with HyperCard); or you can go on to Chapter 3 for tutorials on customizing 
stacks to your own liking. 

To explore more stacks or to go on to Chapter 3, be sure to start from the 
Home card. 

~ Go back to the Home card. 

You go back to the Home card by choosing Home from the Go menu. 
(You'll learn more about the Home card in Chapter 4.) 

•!• Another way to get Home: Anytime you see a picture of a house on a card, 
you can click the house to go to the Home card. 
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c H A p T E R 3 

Customizing 

s OMETIMES THE WAY A STACK LOOKS ISNT TO YOUR LIKING. THE PICTURE YOU 

see on a particular card isn't suited to your purposes, or a field is in an 

inconvenient place or its text is in a font or style that you don't like. This 

chapter shows you how to use HyperCard's features to customize cards 

and stacks. 
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30 Chapter 3: Customizing 

Customizing isn't required. You don't have to customize a stack to use it. 
These tutorials are for people who enjoy modifying things to meet their 
specific tastes. It's OK to leave stacks as they are. 

This chapter has two tutorials. The first, "Painting," goes over some of 
HyperCard's features for editing pictures. You'll learn how to: 

• copy pictures from one card to another 

• edit the pictures you copy 

• create new pictures using HyperCard's painting tools 

The second tutorial, ·Authoring," includes the basic elements of stack 
creation. You'll learn how to: · 

• create new stacks 

• copy pictures, bunons, and fields from existing stacks to your new stack 

• move burtons around on a card 

The tutorials are separate. If you aren't interested in authoring yet, just do 
the Painting tutorial and go on to explore HyperCard. 

Painting 

HyperCard provides a variety of tools for changing the way a card looks. 
Chief among these are the Paint tools; you use them to create and to change 
pictures. 

Figure 3-1 The Tools menu 
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Setting the user level to 
see the Tools menu 

You choose the tool you need from the Tools menu. To see the Tools menu, 
you must tell HyperCard you're ready to use it (HyperCard keeps menus out 
of sight until you need them.) 

You tell HyperCard that you're ready to work with new tools by changing 
your user level on the User Preferences card. It's the last card in the Home 
stack . 

.,... Move to the User Preferences card of the Home stack: 

L Start from the Home card. 

2. Choose Last from the Go menu. 

The Last command brings you to the last card of the current stack. The 
User Preferences card appears. (See Figure 3-2.) 

Figure 3-2 The User Preferences card 
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HyperCard has five user levels. Each level incorporates everything from 
previous levels, and adds new capabilities. When you first start HyperCard, 
you're at the Typing level. At this level you can move through HyperCard's 
stacks and search for information, and you can make changes to text. 
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Changing the way a card 
looks 

32 Chapter 3: Customizing 

Now you need to be able to use the Paint tools-a capability that comes with 
the next level. 

..,. Click the button labeled Painting. 

(HyperCard stays at your new level until you change it, even if you quit 
HyperCard and restart.) A new menu appears in the menu bar. 

Figure 3-3 Changing user levels 
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You use the Paint tools on the Tools menu to change a card's picture. 

Figure 3-4 The Paint tools 

,...---Browse tool selected. 
(It's the one you're using now.) 

~W.£z-- More about these tools 
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Copying a picture from 
another card 

HyperCard comes with a stack specifically included for you to practice your 
painting on, the Quotations stack. You'll go to this stack using a command 
that's new to you-the Open Stack command . 

..,.. Get to the Quotations stack: 

1. Choose Open Staclc from the File menu. 

A directory dialog box appears, letting you select the stack you want to 
work with. 

2. Select Quotations and cliclc Open. 

•:• A quick diversion: The Quotations stack is a collection of aphorisms and 
famous sayings. Guess the author of the quotation; then click the "Who 
says?" button to see if you were right. (Click it again to hide the answer.) 
When you want to stop the game (or you run out of quotations), come 
back here. 

Cards with pictures on them are visually more interesting than cards with 
just text. You can add a picture to a card by copying an image from another 
card, or by drawing a picture yourself. 

Copying an image is a simple operation. To get some practice doing it, you'll 
copy the images of a loaf of bread and a jug of wine from a card in the Art 
Ideas stack; then you'll paste the images onto a card in the Quotations stack. 

illJ> Copy an image from one card to another: 

1. Start with the card in the Quotations stack that reads "A book of 
verses underneath the bough." 

To find it, Choose Find from the Go menu, type book of verses, 
and press Return. Your next seep is to go to the Art Ideas stack to copy 
pictures. 

Painting 33 



34 Chapter 3: Customizing 

Figure 3-5 Book of verses card 
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2. Choose Open Stack from the File menu. 

The directory dialog box appears so that you can choose the stack you 
want to open. The Art Ideas stack is in the Idea Stacks folder. Use the 
directory dialog box to locate the Art Ideas stack. 

If you're using HyperCard with 800K disk drives (and no hard disk), you'll 
have to click the Drive button in the directory dialog box to find the Art 
Ideas stack. 

3. Select Art Ideas and click Open. 

You're now at the first card of the Art Ideas stack. 

4. Move to the card labeled "Restaurants, Food, Recipes." 

To get to this card, choose Find from the Go menu, type the word 
Food, and press Return. 



Figure 3-6 Food card 

5. When you find the picture you want, choose the Selection tool 
from the Tools menu. 

The Selection tool lets you select a part of a picture to work on. (When 
you choose this tool, some new menu titles appear in the menu bar; 
ignore them for now.) 

Figure 3-7 Choosing the Selection tool 
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6. Drag diagonally across the images of the loaf of bread and the 
bottle of wine to select them; then release the mouse button. 

The dotted lines move when you release the mouse button to show 
that the selection is active. Don't worry if you select too much; you can 
edit it later. If you make a mistake, choose Undo from the Edit menu 
and start dragging again. 

Figure 3-8 Selecting a picture 
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Release the mouse button when 
you've selected what you want. 

7. Choose Copy Picture from the Edit menu. 

What you copy goes onto the Clipboard, a holding place for cut or copied 
text and graphics. 

8. Choose the Browse tool from the Tools menu. 

9. Choose Recent from the Go menu. 

10. Go back to the Quotation card by clicking its image on Recent 



Figure 3-9 Going back to the Quotations stack using Recent 

'------------~1...-- Click here 10 

go back lo 
Quotations. 

----- - -

11. Choose Paste Picture from the Edit menu. 

The material you copied to the Clipboard is pasted to the Quotation card. 
(See Figure 3-10.) 

Figure 3-10 Pasting a copied image 
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Using the Paint tools 
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12. Drag the pasted picture where you want it to go; then click 
anywhere outside the picture to set it in position. 

To drag the picture, move the pointer anywhere inside the selecred area, 
hold down the mouse burron, and move the mouse. If you make a 
mistake, choose Undo from the Edir menu. 

13. Experiment with the Paint tools to touch up your picture. 

(See "Some Painr Tool Tips" in the next section.) Ir's OK to make a mes.s; 
that's what this stack is for. You can't inadvertently change any other 
stack while you're in this one. 

You can pasre as many pictures onro a card as you want Use any of the Paint 
rools ro modify the picture, or painr your own picture from scrarch. 

This is a great rime to experiment with the Paint rools. The Paint rools are 
shown in Table 3-1. 

.... Add a new card or two ro the Quotations stack: 

1. Select the Browse tool. 

2. Choose New Card from the Edit menu. 

A new card appears. 

3. Type your favorite quotation on the left page. 

Pres.s Tab to set the insertion point at the top of the page. 

4. Construct a picture on the right page using the Paint tools. 

(See the next section, "Some Painr Tool Tips.") You can borrow from other 
stacks to do ir. Don't worry if you aren't Rembrandt; this is all just for 
practice (and for fun). 



Table 3-1 The Paint tools 

Paint 
Tool What it's for 

Use the Selection tool to 
select pictures, or parts of 
pictures, for copying, 
moving, or deleting. 

Use the Brush to paint. 
You can double-dick the 
Brush to choose a new 
brush shape 

The more you spray with 
the Spray tool, the more 
the panem shows. 

Use the Bucket to fill in a 
closed shape you've 
already drawn. 

Use the Paint Text tool to 
type text that's part of the 
picture. 

Use the Lasso to select 
nonrectangular images for 
copying, moving or 
deleting. 

The Eraser erases the part 
of the picture you drag it 
over. 

Some Paint tool tips 

Paint 
Tool What it's for 

The Rectangle tool draws 
rectangles. 

The Oval tool draws ovals 
and circles. 

The Regular Polygon tool 
draws polygons with equal 
sides. 

Use the Pencil to draw 
thin, free-form lines. 

Use the Line tool to draw 
straight lines. 

The Rounded Rectangle 
tool draws rectangles with 
rounded corners. 

Use the Curve tool co draw 
free-form shapes. 

Use the Polygon tool to 
draw polygons with 
irregular sides. 

To select a Paint tool, just drag to the one you want on the Tools menu and 
then experiment. Most tools start to work when you press down the mouse 
button and drag, and stop when you release the mouse button. Here are 
some tips on using Paint tools: 

• Select a pattern from the Patterns menu to use with the Brush, Bucket, 
and Spray tools. 
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• Choose Brush Shape from the Options menu and click the shape you 
want. Each shape gives a different effect, so experiment with them all. 

• Use the Brush or Pencil for freehand work. 

• 111e Eraser-erases. 

Figure 3-11 Using the Paint tools and the Patterns menu 

Click to choose a 
pattern for painting. 

m G 
' 

Use these tools 
to draw shapes. 

Choose a pattern to 
work with these tools. 

Experiment with the other tools to see what they do. 

•:• Convert menus to palettes: You can "tear off' both the Tools menu and 
the Patterns menu so that you can have constant access to them as you 
work. just drag through them, past the bottom or off to one side; then 
leave them where you want them. When they get in your way, move 
them by dragging their top bars. Click their close boxes to make them 
go away. 



Experiment time 

Figure 3-12 Tearing off a menu 

Experiment for as long as you want with the Paint tools. Make a mess on the 
screen. Create new quotation cards or modify old ones. Practice copying 
graphics from other stacks. 

•:• A quick cleanup trick: If your screen gets really messy and you want to 
clean it up, double-click the eraser on the Tools palette: Everything you 
painted gets erased. If you double-click by mistake, choose Undo from 
the Edit menu. 

You can read more about the Paint tools and what they do in the "Tools 
Menu" section of Chapter 7, throughout Chapter 6, and in the Menus section 
of the Help system . 

..,. Go back to the Home card when you've finished experimenting. 

When you're ready, go on to the final lesson, "Authoring," and learn how to 
create stacks of your own. 
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Authoring 

You've learned how to get around in HyperCard, and you've had some 
experience in changing text and graphics on a card. In this section you'll learn 
HyperCard's real power-changing how things work. 

•:• You don't have to be an author: It isn't necessary for you to learn how to 
change a stack radically in order to use HyperCard effectively. You already 
have all the information you need to get a great deal out of HyperCard. 
The rest of this chapter is for you if you have special needs that the 
stacks that come with HyperCard don't meet, or if you like to do things 
your own way. 

You'll need to change your user level to become a stack author . 

..,. Change your user level to Authoring on the User Preferences card: 

1. Choose Home from the Go menu. 

If you've come here directly from the previous tutorial, the Home card is 
probably already on the screen. 

2. Choose Last from the Go menu. 

You move to the User Preference card, the last card in the Home stack. 

3. Click the button labeled Authoring. 

A new title-Objects-appears in the menu bar. (See Figure 3-13.) You're 
now at the highest level that this guide takes you to. 



Making a new stack from 
an existing one 

Figure 3-13 Moving up to Authoring 
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Before you continue, go back to the Home card . 

..,. Choose Home on the Go menu. 

You can make a new stack based on an old one. 

When you make a new stack based on an existing one, the new stack takes on 
some of the characteristics of the current card. 

In this exercise, you'll make a new stack based on the To Do card. (You type 
all the things you've got to do today on the To Do card.) 

..,. Move to the To Do card by clicking its icon. 

The card in Figure 3-14 appears. 
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Figure 3-14 A To Do card 

You'll use the basic design of this card for your new stack . 

.,.. Create a new stack based on the To Do card: 

1. Choose New Staclc from the File menu. 

The directory dialog box appears, asking you to name the new stack. (See 
Figure 3-15.) 

Figure 3-15 Making a new stack 

,.--- ---- - - --- - - - - ----You use the current stack's 
design for the new stack 
if this box is checked. 



Moving buttons 

2. Type My To Do stack andclickNew. 

When you choose New Stack from the File menu, you can use the basic 
design of the card that's on the screen for the new stack. (You don't 
copy any of the stack's data, just the stack's template.) 

You now have a new stack, ready for you to modify and fill with 
information. (See Figure 3-16.) 

Figure 3-16 The first card in the new stack 

Customizing a stack is a maner of deciding what you like and don't like 
about a design, and then changing the design. In this exercise, you'll change 
the design by moving a button around. 

~ Move the Telephone bunon to the top-left side of the page: 

1. Select the Button tool from the Tools menu. 

(it's the tool in the middle of the top row.) A box appears around each 
bunon on the card. 
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Figure 3-17 Choosing the Bunon tool 
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2. Move the pointer to the center of the Telephone button, and 
press and hold the mouse button. 

3. Drag the Telephone button to the left until it aligns with the 
left edge. 

4. Release the mouse button. 

The moving dotted line around the button lets you know the button is 
still selected. (When you click another button or when you select another 
tool, the dotted line goes away.) 

The top of the card should look like Figure 3-18. 

Figure 3-18 To Do card with the Telephone bunon moved 

When you move a button, the only thing that changes is its position; what 
the button does remains the same. 



Deleting buttons 

Copying buttons from 
another stack 

~ \j 
Button ld>?.~s 

Sometimes the buttons you find in a design don't do what you want. For 
this exercise, assume that the only buttons you want at the top of the card 
are the Telephone and Home buttons . 

..,. Delete all but the Telephone button from the top of the card: 

1. Select the Button tool from the Tools menu. 

If you've been following along, you've already selected this tool. 

2. Click the Address stack button. 

The box around the button changes to marching ants (a moving outline 
made up of dashes). 

3. Choose Clear Button from the Edit menu. 

The button disappears. 

4. Repeat steps 2 and 3 for the remaining buttons, except for the 
Telephone button. 

In the Painting tutorial, you saw how to borrow pictures from other cards to 
use on your own cards. You can borrow buttons in the same way. 

..,. Add a Home button by copying it from the Button Ideas stack: 

L Choose Home from the Go menu to go to the Home card. 

2. Click the Button Ideas icon. 

If you're using HyperCard without a hard disk, you have to click the 
Drive button in the directory dialog box to find the Button Ideas stack. 

The card that appears is actually an index. 

3. Click the Text button. 

The card in Figure 3-19 appears. 
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4. Select the Button tool from the Tools menu. 

Now you're ready to select a bunon and copy it. 

s. Click the button marked Home. 

When you're using the Bunon tool, you click a button to select it rather 
than to make it carry out an action. 

Figure 3-19 Assorted buttons 

( l ext Bu ti on:. 

( 
!"lot•HI f dltl J Hr turn ) \OJ 1 ) 

-
) f ) PICll Ct.:trf1 llornt• f111tJ 

--
I 11 ' ' Cd>d J llt•ltJ J lllllHlfl ) 

-
J f 11po1 t lt•HI) I ,1,1 ( .11 d ) UMI 

I 
) \hnw r llr1h) fllJHll I Udld J H1111 ! did 

I, ~ ~/ 

6. Choose Copy Button from the Edit menu. 

lntlPH) :~ J 

This is the 
button you 
want 

7. Get back to your To Do card using Recent from the Go menu. 

Your To Do card reappears. Now you can paste the button you just 
copied. 

8. Choose Paste Button from the Edit menu. 

The button you just copied appears. 



Changing a field's size and 
position 

9. Drag the button where you want it to be. 

10. Click the Browse tool to set the button in place. 

\Vhenever you want to return to the Home card, you can click the Home 
button. (Try it out, if you like.) 

You add text to a card by typing into fields while the Browse tool is selected. 
The new To Do stack has three fields on it. To see them, choose the Field 
tool from the Tools menu. 

Figure 3-20 Choosing the Field tool 

Field tool 

\Vhen you choose the Field tool, you can see the fields on your To Do card. 
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Figure 3-21 The Home button pasted, fields visible 

r--- --- --r------r----- Three fields, 

You can change the size of a field or move it easily . 

..,. Change the size of the field on the right: 

all enclosed 
in boxes 

- - Here's the 
Home button 
you just 
pasted in. 

1. With the Field tool still selected, click anywhere within the 
card's right field to select the field. 

2. Drag the lower-right comer of that field toward the left side of 
the card to make the field narrower. 

Make it about one-third the width that it is now . 

..,. Move the field you just changed by placing the pointer in its center and 
dragging the fie ld to the right. 

Move it close to the right edge. (See Figure 3-22.) 



Copying a field 

Figure 3-22 Shrinking and moving fields 

;J 

Copying a field is as easy as moving one. And as long as you've got 
the room . . . 

..,,. Make a copy of the field on the right: 

1. Select the field on the right by clicking it 

You know it's selected because it's surrounded by a moving dotted line. 

2. Choose C.Opy Field from the Edit menu. 

3. Choose Paste Field from the Edit menu. 

The new field is pasted directly over the original, so the screen appears to 
show only the newly pasted field. 

4. Drag the copied field to the left. 
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Figure 3-23 Copying a field 
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You can also copy fields from other cards, just as you can copy buttons and 
pictures. 

A number of cards can share the same background-a common set of 
elements. When you chose New Stack to create tl1e stack you've been 
working on, you copied the background of the card that was on the 
screen at the time. Figure 3-24 shows a card with a distinct background part. 



Figure 3-24 A background shared by a number of cards 
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This is what you see on the screen­
a combination of the background and 
the part unique to the given card. 
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This part is unique to the care!. 

Buttons, fields, and pictures can Jive on the background of a card, or on the 
card itself. When they're on the background, these objects-buttons, fields, 
and pictures-are shared by all cards associated with that background. When 
they're on the card, they're specific just to that card. 
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Figure 3-25 Background fields versus card fields 
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Background fields - - - -----; 
are common to a 
number of cards. 

Card fields appear only 
on a specific card. 

L i 

No card field --- - ---" 
on this card. 

To see what this is about, you'll first have to make a new card for the stack 
you've been working on . 

..,. Make a new card for the stack by choosing New Card from the Edit 
menu. 

You'll notice that the Home button you pasted appears just on the first 
card-it wasn't duplicated when you chose New Card; and the field you 
duplicated was only duplicated on the original card. You created a card field 
and a card button, objects that work only on a single card; contrast that 
with background fields and background buttons, objects common to all 
cards that share a particular background. (With the Browse tool selected, click 
the left arrow and right arrow buttons at the bottom of the card to go back 
and forth between cards.) 



Figure 3-26 The first card versus lhe second card 
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1 
Background has 
only one field on it. 

The card on the right in Figure 3-26 is the one you just made with New Card. 
Its features all come from the background . 

.,.. Look at the background for these cards: 

1. Be sure you're on the first card in the stack by choosing First from 
the Go menu. 

2. Choose Background from the Edit menu. 

The background appears. (See Figure 3-27.) 

Figure 3-27 In the background 
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Diagonal lines tell you chat you're 
looking at the background. 
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If you switch back and forth between the background and the card by 
choosing the Background command several times, you'll see the button and 
the extra field disappear and reappear. (The Background command is like a 
push-button light switch-if you choose it while you're looking at the card, 
you switch to the background; if you choose it while you're looking at the 
background, you switch to the card.) You can tell when you're in the 
background because the menu bar in the background has diagonal stripes. 

•!• You can edit background fields and buttons from the card: You can make 
an existing background field or bunon smaller or larger or delete it but 
you can't create new background fields or buttons unless you're in the 
background. That's why the field you made smaller remains smaller when 
you look at the background, and the buttons you deleted remain deleted. 

To make a field, button, or picture common to a number of cards, create it (or 
paste it or duplicate it) in the background. 

You can move the duplicated field and the Help button from the first card to 
the background. When you do that, the extra field and the button will show 
on both cards, and on any new cards that you create. 

liJ>- Move the duplicated field and the Home button to the background: 

1. With the Field tool selected, click inside the duplicated field. 

Be sure you're on the card and not in the background-you shouldn't see 
any diagonal lines in the Menu bar. 

2. Choose Cut Field from the Edit menu. 

The field disappears. 

3. Choose Background from the Edit menu. 

The background appears-you see the diagonal lines again. 

4. Choose Paste Field from the Edit menu. 

The field reappears, now part of the background. 

5. Choose Background from the Edit menu again. 

You're back at the card-the diagonal lines in the Menu bar have 
disappeared. 



Experiment for a while 

6. Select the Button tool and click the Home button. 

You'll know it's selected because a moving dotted line surrounds it. 

7. Choose Cut Button from the Edit menu. 

The button disappears. 

8. Choose Background from the Edit menu. 

The background appears-you see the diagonal lines again. 

9. Choose Paste Button from the Edit menu. 

The button reappears, now part of the background. 

10. Choose Background from the Edit menu a final time. 

You end up with all buttons and fields in the background. To prove it, create 
a new card . 

.., Choose New Card from the Edit menu. 

The new card will have two fields on the right side and a Home button at 
the top. 

•:• A final note about f ields: What you type on a field created in the 
background can change from card to card, although the field's size and 
position remains constant on all cards associated with that background. 
When you create a field on a card, the field stays just with that card- and, 
of course, so does what you type in it. Experiment by creating a few card 
fields in the stack you just created to see what happens. 

Continue working on this stack for a while. Make all the changes you want. 
Don't worry about messing things up; this stack is just for practice . 

.., When you've finished experimenting, go back to the Home card. 
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You've read here and in the first chapter that Home is your base of 
operations. It makes sense, then, to put a button on the Home card that gets 
you to the stack you just made. In this final exercise, you'll create a new 
button for the Home stack, give it a name, and then create a connection to 
your new stack. 

.... Create a link from the Home card to your To Do stack: 

1. From the Home card, choose New Button from the Objects menu. 

HyperCard selects the Button tool and a button named New Button 
appears selected in the middle of the Home card. 

2. Choose Button Info from the Objects menu. 

The dialog box in Figure 3-28 appears. 

Figure 3-28 The Button Info dialog box 
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3. Type Things to do into the Button Name box. 

The new name replaces the old name, New Button. (You'll find details on 
the rest of this dialog box under "Button Info" in Chapter 7.) 



4. Click Link.To. 

The dialog box in Figure 3-29 appears. 

Figure 3-29 The LinkTo dialog box 

Go to lle'>tinat1on, then aim lmk at: 

This This Stack C.anc el 

5. Choose Open Stack from the File menu. 

The directory dialog box appears. 

6. Select My To Do Stack and click Open . 

The first card in the stack you just created appears. 

7. Click This Stack in the LinkTo dialog box. 

HyperCard completes the link and returns you to the Home card. 

8. Drag the new button to a convenient place on the Home card 

9. Test your new button. 

To do that, first select the Browse tool; then click the new button. You 
immediately go to your new stack. 

Where to go from here 

This ends your tutorials on HyperCard's basics. You know enough now to 
get off to a great start. You can go on reading in this manual to learn more 
about HyperCard or you can go off on your own, browsing and editing as 
you like. (Use the table of contents and the index of this manual to locate 
instructions for specific tools, tasks, and commands.) 
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You can also use the Help stack ro learn more about tools: 

1. Choose Help from the Go menu. 

This gets you to the Help stack from anyplace in HyperCard. 

If you're using HyperCard without a hard disk, you'll have to do some disk 
swapping ro use Help. (This process is explained in Appendix C.) 

2 Click the Menus tab at the bottom of the card. 

You'll see the Menus card. 

3. Click the Tools menu and explore. 

To learn about a specific tool, just click its icon. (See Figure 3-30.) 

Figure 3-30 Exploring with the Help stack 
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c H A p T E R 4 

Home 

H OME JS HYPERCARD• CENTRAL STACK. EACH OF ITS CARDS HOLDS 

infonnation vital to HyperCard's perfonnance. 

• The first card, Home, holds buttons that take you co the most 

important cards in your collection. 

• Three search path cards cell HyperCard where to find applications, 

documents, and stacks that you use frequently. 

• The User Preferences card lets you customize the way you interact 

with HyperCard. 
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stack. .A. 
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Home card 

No matter what other cards and stacks you have, you always have Home. 
Most people use it as their starting place for moving around. You'll find the 
Home card most useful if you create a button on it linked to each new stack 
and to each of your favorite cards. 

Figure 4-1 The Home card 
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•:• Creating a graphic button for Home: To create a graphic button, first 
paint or paste a small picture on Home representing the new stack; then 
cover that picture with a transparent button linked to the new stack. Or 
you can use icons as buttons by clicking Icon in a selected button's 
Button Info dialog box and choosing from the icons that appear. You can 
also copy predesigned buttons from the Butron Ideas stack. "Copying 
Buttons From Another Stack" and "Connecting to the Home Card" in 
Chapter 3, and "Icon" in Chapter 7, provide step-by-step instructions for 
these procedures. 

For information on linking buttons, see "Button Info" in Chapter 7. 

Search paths 

A search path is the route HyperCard follows to retrieve a stack, application, 
or document. When you tell HyperCard to open a file-by clicking a button on 
the Home card, for example-HyperCard follows its own preset search paths 
to find the file. 

•:• Preset search paths: HyperCard first looks for the requested file in the 
folder that's currently active; next it looks in the folder that the Help 
stacks are in; and then it looks on the root level of the directory-that is, 
on the current disk among the files that aren't in any folders. Finally, it 
checks the search path cards to see what route to follow. 

If HyperCard can't find a file you ask for, it displays a directory dialog box. 
(See Figure 4-2.) 
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Figure 4-2 The dialog box for finding a file 

Where is lost stack? 

la HyperCard Stacks I 
IDIJ]o I 

~ 
c::>Harpo 

D Rrea Codes r D Dalebook I ) (!< t 

D File l ndeH 
,, 

Driue 
D Home 
D Jane's Graphics 
D MRO Stack Open 
D masking demo 

~ Cancel D Phone 

As you click your way through the directory dialog box ro locate a file, 
HyperCard records your path. Once you've located the file, HyperCard notes 
the volume and folder (and if necessary, subfolder) in which the file resides, 
and records it on the appropriate search path card in the Home stack. The 
next time you ask for that file, HyperCard will know where to look for it 
without having to ask you to find it. 

D. Important Although you can use HyperCard with a locked disk (or a locked volume), 
changes you make to stacks on a Jocked disk won't be saved. If you want 
your changes saved, make sure that any disk you use is unlocked. 6 
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•:• Occasional housecleaning: HyperCard keeps a search path on record until 
you erase it. Ir's a good idea to erase a search path you use infrequently, 
freeing up that space on the search path card. To erase a search path, just 
select it and choose Clear from the Edit menu. 



User Preferences 

Set the User Preferences card to customize the way you interact with 
HyperCard. From the Home card, dick the left arrow to get to the User 
Preferences card (Figure 4-3). 

Figure 4-3 Setting preferences 
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Click the proper user level to match what you want to do with HyperCard. 
The higher the user level you choose, the more power HyperCard gives you: 

Browsing 

Typing 

Painting 

Short File and Edit menus (Figure 4-4), plus the Go menu. Use 
of the Browse tool. 

Same as Browsing, plus ability to edit text in existing fields 
and check the Text Arrows option (explained in the next 
section). 

Same as Typing, plus full File and Edit menus (Figure 4-4), 
Tools menu (plus Paint, Options, and Pattern menus when a 
Paint tool is selected), use of all Paint tools (but not Button 
and Field tools), Power Keys and Text Arrows options. 
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Authoring Same as Painting, plus Objects menu, use of Button and Field 
tools. 

Scripting Same as Authoring, plus ability to type into Message box 
while it's hidden (if the Blind Typing option is chosen), plus 
ability to write and edit scripts. (The Message box is explained 
in the section "Message" in Chapter 7.) 

Figure 4-4 Short and full File and Edit menus 
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Painting, Authoring, and Scripting get full menus. 

You can set one level now and change it to a higher one later, when your 
HyperCard skills improve or when you feel comfortable experimenting with 
more advanced abilities. 



The Text Arrows option 

•!• User preferences and stack protection: The preferences you set here apply 
in a general way to all HyperCard functions. The tools and commands you 
have at your disposal while you're using a specific stack, however, are 
based both upon the level you set on the User Preferences card and on the 
specific stack's protection level. When a stack is set for a different level of 
use than is set on the User Preferences card, the lower setting has 
precedence. (Lower means "closer to Browsing.") See "Protect Stack" in 
Chapter 7 for details. 

For information about power keys, see "Power Keys" in Chapter 6 and 
Chapter?. 

When you click any user level button except Browsing on the User 
Preferences card, a check box labeled Text Arrows appears (as shown in Figure 
3-3). The Text Arrows option lets you use the arrow keys when you edit text 
fields or text in the Message box. (See the section "Message" in Chapter 7 for 
an explanation of the Message box.) 

Figure 4-5 Moving through cards when Text Arrows is checked 

Previous card 

Next card 

Forward 

Backward 

With Text Arrows checked, the Left Arrow and Right Arrow keys move the 
insertion point to the left and right over text in a field or in the Message box; 
the Up Arrow and Down Arrow keys move up and down through lines in a 
field. (When Text Arrows is checked, the Up Arrow moves the insertion point 
to the beginning of the line in the Message box, and the Down Arrow moves 
the insertion point to the end of the line.) 
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When Text Arrows is checked, if you want to move to the previous or next 
card, or to go back and forward through cards you've seen, hold down the 
Option key as you press the appropriate arrow (as shown in figure 4-5). 

When Text Arrows is unchecked, the arrow keys move you through the cards 
(not over text)-you don't need to hold down the Option key. 

Ways to go Home 

HyperCard provides several ways to get to the Home card: 

• Choose Home from the Go menu. 

• Press Command-H (Press the Command key and, while holding it down, 
press H for Home). 

• Click the house icon that appears on most stacks. 

• Choose Message from the Go menu, type Go Home, and press return. 

All these methods work equally well. 



C H A P T E R 5 

Text in HyperCard 

H YPERCARD HAS TWO KINDS OF TEXT: PAINT TEXT AND REGUIAR TEXT. 

You create Paint text using the Paint Text tool; you'll find details about it in 

Chapter 6. This chapter covers regular text. 
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Creating regular text in HyperCard is a rwo-step process: 

1. Use the Field tool to create the fields where text goes. 

2. Use the Browse tool to type text into a specific field. 

•:• Watch your preference level: To edit text in a field, you must be at the 
Typing level or higher on the User Preferences card in the Home stack. To 
create or change a field, you must be at Authoring level or higher. 

In the next section, "Fields," you'll learn about the places where you type 
regular text. The section called "Creating Regular Te>.1" tells you about 
entering and editing text, and how to move it from one place in HyperCard to 
another. 

Fields 

Fields are the boxes in which you type text. You can create background 
fields and card fields. A background field appears on every card associated 
with a given background. It has the same size, shape, and position on every 
card; what changes from card to card is the text in a field. Fields can be empty 
in one card, but have text in another. A card field appears only on the card 
where you create it (although you can copy a card field, and then paste it 
onto any other card). 

Figure 5-1 Different kinds of fields 
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Creating fields 

You can have as many fields on a card or background as will fit. Fields can 
overlap one another to any depth. 

•:• Text can overlap, too: When fields overlap, the text within the fields can 
also overlap if some of the fields are transparent. Although you can create 
some interesting special effects this way, you can also create quite an 
aesthetic mess. When you overlap background fields and card fields, be 
sure to go through each card associated with the background after you've 
entered text to make sure things look the way they should. 

You create fields by using the Field tool in the Tools menu. 

Figure 5-2 The Field tool in the Tools menu 

Field tool 

Follow these steps to create a field: 

1. Move to the card where you want the field to appear. 

2. To create a background field, choose Background from the Edit 
menu. 

3. Choose New Field from the Objects menu. 

A new field appears in the center of the screen. Alternatively, move the 
pointer where you want the field to start; then press the Command key 
and drag. (See Figure 5-3.) 
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4. Choose Field Info from the Objects menu and make selections as 
appropriate in the Fields dialog box. 

The Fields dialog box is described in detail lacer in chis chapter. 

5. Size the field appropriately. 

See "Changing a Field's Size," lacer in chis section. As you drag, a dotted 
rectangle appears showing you how wide and how long the field is; the 
lines in the rectangle show where the bottom of each line of text will be. 

Figure 5·3 Creating a new field by dragging 

~----- Start where you want. 

Drag diagonally 
to create a field. 

The dotted lines go away when you choose another cool. The upper-left and 
lower-right comers define the size of the field; the lines going across show 
you the text lines within the field. 

•:• Changing line spacing: You can change the amount of spacing between 
lines by changing the number in the Height box of the Text Style dialog 
box. See "Setting Text Properties," lacer in chis chapter. 

6 Important The most common mistake in creating a field is putting it on a card when it's 
supposed to be on a background. After you've created one or more fields, flip 
to the next card; if the fields you've just created are on that card coo, you've 
created background fields. !::::. 
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Placing and moving fields 

Changing a field's size 

You can place a field wherever you want, including on top of another field. 
Follow these steps to move a field: 

1. Select the Field tool from the Tools menu. 

The Field tool appears highlighted in the Tools menu, showing you that 
it's selected. 

2. Click inside the field you want to move to select it. 

The field becomes surrounded by dorted lines to show it's selected. 

3. Drag the field by its middle. 

When the field is where you want it, release the mouse button. 

When you move a field, any text you've typed moves with it. HyperCard 
won't let you move any part of the field off the card. 

You can change a field's size whether or not it has text in it. When you change 
its size, any text in it wraps appropriately to conform to the new size. If you 
shrink the size of a non-scrolling field such that there's not enough room for 
all the text, text typed toward the bottom of the field becomes invisible. 
(Ir's still there, though; if you enlarge the field, the text becomes visible 
again.) 

Figure 5-4 Changing a field's size 

When 111 U-1e c i:•tir ;,;, 
1 1·1w1 .;1 "'"-'o?nts 1t 

t~·crn.:. rei:t? :iPJ 

1, ,j1c ··ciJ. e 1.he 
r•ul11.11:.;1 bo'lf11j 111.'Jl. 
11:i""" pt.;1~etJ tcq.-!11>?1· 

'· "'· .-11 .;t l 1b.,ral 

nur11.:,11 ":'' 1?r' 

1 ·. tn-?C on1t- _. 
nect' s-.. :ir1~ t1J 

d1·;.~.01v.- 111 .. 

pol1t11 .,1 t•·Jrt•j. 
' 1111j r.;1·;.er·;. u·1.-n t_h.;t ll·J"" 

(tl·:JJ':'J. 1"'ll o"\" 

-/ 
Short field makes some text invisible. 

'tio?n 111 U1t­

.;01.w "'01 

tt nn:u1 ... '='r1t: 

1 • ti.:-corni:-; 
nt-1: t-·:.s1Jn~ l.1:i 

1j1 :solvt? t.110: 
prtl I I I( 'll t1.;r11j·;. 

(•1 ~1~;;1J 1.oqo:1.1·1er 
... :it 

I 1t•"l":il 1 un1j 

/ r·:i' ""' 11·1e11 
Narrow field shows wrapped text. ----~ 

Fields 73 



Deleting a field 

.&. Warning 

Moving between fields 
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Changing the size or shape of a background field changes it on every 
associated card. 

To change a field's size: 

1. Select the Field toot 

2. Click inside the field to select it. 

The selected field is surrounded by dotted lines. 

3. Drag the field from one of its comers. 

You'll probably want to look through any cards affected by the field change 
to see how the text looks. 

You can delete a field whether or not it has text in it. Follow these steps to 
delete a field: 

1. Select the Field tool from the Tools menu. 

2. Click inside the field to select it. 

3. Choose Cut Field from the Edit menu. 

Choose Clear Field to eliminate the field without affecting the Clipboard 
(or press the Backspace or Clear key). 

When you delete a field, you delete all its text along with it. Nothing goes 
onto the Clipboard; it is all simply eliminated. When you delete a background 
field, you irrevocably delete text associated with that field in every card on 
which the field appears. You cannot recover the lost text by choosing Undo 
from the Edit menu. • 

Knowing the position of a field on a card can be difficult sometimes. 
Depending on the field style you've selected, empty fields can be invisible 
when any tool other than the Field tool is selected (although any text in them 
will still show). 



To move from one field to another in order to type text: 

1. Select the Browse tool from the Tools menu. 

2. Press the Tab key until you get to the field you want 

HyperCard first tabs through the background fields and then tabs through 
the card fields of the current card. 

When you click in a text-filled area of a field, the insertion point appears 
wherever you click. When you click in an empty area of a field, the insertion 
point appears at the start of that empty line. 

Tab order and layers 

Pressing the Tab key moves the insertion point to the field with the next 
higher field number. 

Initially, field numbers are in creation order. The first field created gets the 
number 1, the second field gets the number 2, and so on. (A pasted field is 
treated as a newly created field, no matter what its number on the card or 
background from which it was copied or cut.) If the insertion point is in field 
number 3 and you press Tab, the insertion point moves to field number 4; if 
there are only three fields, the insertion point moves from field 3 to field 1. 

Figure 5-5 Tab order 

Tabbing goes from here ... 

d . .. and finally 
back to here. c=::;: ~ Qld n 

... to here .. . 

. . . to here ... 
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The layer is the order of the field relative to other fields on the same card -
and background. When the visible card and background have multiple fields, 
fields can Jay over each other; the field created most recently is ordinarily the 
topmost field, said to be on the front layer. In Figure 5-5, field 1 is on the layer 
farthest away (or, if you prefer, in the back), field 2 is closer, and the highest 
numbered field, field 3, is on the frontmost layer. The lowest numbered field 
is always farthest away; the highest numbered field is always on the 
frontmost layer (or in front). In fact, you can think of the field number as 
being the field's layer number. 

To see a field's number, follow these steps: 

1. Select the Field tool from the Tools menu. 

2. Click inside the field whose number you want to see. 

3. Choose Field Info in the Object menu. 

Alternatively, just double-dick in the field. 

Figure 5-6 The field number, initially determined by creation order 
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Duplicating a field 

Changing field tab order 

You can change the tab order among background or card fields by changing 
the field's layer. (Figure 5-5 in the preceding section illustrates layers.) 

To change a field's layer: 

1. Select the Field tool from the Tools menu. 

2. Click inside the field whose layer you want to change. 

3. Choose Bring Closer or Send Farther from the Objects menu. 

Each time you choose Bring Closer, the field gets closer to being the 
frontmost layer (with a correspondingly higher field number); each time you 
choose Send Farther, the field moves to a farther layer (with a 
correspondingly lower number). And as the layer order changes, so does the 
tab order. 

Duplicating a field makes an exact copy of the field. You can duplicate a field 
either with or without its text. 

To duplicate a field only (without its text): 

1. Select the Field tool from the Tools menu. 

2. Select a field by clicking inside it. 

A dotted line surrounds the field, showing that it's selected. 

3. Choose Copy Field from the Edit menu. 

4. Choose Paste Field from the Edit menu. 

A copy of the selected field is created, laying on top of the original. You 
need to drag the new field where you want it. 

5. Drag from within the new field to move it where you want it 
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Follow these steps to duplicate both a field and its text: 

1. Select the Field tool from the Tools menu. 

2. Select the field you want to copy by clicking in it. 

3. Choose Copy Field from the Edit menu to duplicate the field (or, 
if you want to delete the field from its current location, choose 
Cut Field). 

4. Hold down Shift and choose Paste Field from the Edit menu, or 
type Shift-Command-V, to paste the text along with the field 

5. Drag from within the new field to move it where you want it. 

•:• HyperCard only pastes text from the current card. If you cut or copy a 
background field and paste it in the background, only text from the 
current card is pasted-text from other cards is nor. 

Each field can have a name associated with it. You use field names mostly for 
advanced HyperCard features such as constructing scripts. 

A field name can have any number of characters in it. You can use any 
character in a field's name. 

To name a field: 

1. Select the Field tool from the Tools menu. 

2. Select the field you want to work with by clicking inside it. 

3, Choose Field Info from the Objects menu (or just double-click 
the field). 

The dialog box in Figure 5-7 appears. 

4. Type or change the field's name; then press OK. 



Field styles 

Figure 5· 7 Naming a field 
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•!• Script wn·ters take note: If you change the name of a field, be sure also to 
change its name everywhere else you refer to it. For example, if you 
rename a field "Wrigley" and you use the old name "Chester" in a script, 
the script won't work properly-it won't be able to find the field it needs. 

Fields can have five styles: transparent, opaque, rectangle, shadow, or 
scrolling. You choose the style of a field by choosing an option in the Field 
Info dialog box. (See Figure 5-8.) 

•!• About scrolling: Choosing the scrolling option adds a vertical scroll bar to 
the selected field. You view text in a field with a scroll bar as you do text 
in any scrollable Macintosh window. (For details about scrolling in 
windows, see the Macintosh System Software User's Guide or the owner's 
guide that came with your computer.) 
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Figure 5-8 Choosing a field sryle 
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You can change a field's style even after you've typed text into the field. Just 
repeat the steps you used to choose the original style. Figure 5-9 shows 
examples of field sryles. 

Figure 5·9 Field sryles 
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Lock Text 

Wide Margins and Show 
Lines 

Lock Text protects the text in a field from being changed. When you check 
this option on the Field Info dialog box for a selected field, text within the 
field cannot be altered in any way. (The pointer doesn't change to an I-beam 
when it passes over a locked field.) 

To unlock a field (and to allow its text to be altered), uncheck Lock Text. 

Wide Margins and Show Lines are options you can check in the Field Info 
dialog box for a selected field. These options give you more control over the 
look of your text fields. Wide Margins, which works best when the field has a 
rectangle or shadow style, leaves more space in the right and left margins. (As 
a result, text takes up more vertical space.) 

Figure 5-10 Shadow fields with and without wide margins 
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Show Lines lets you see where lines are as you type in text. Later, you can click 
Show Lines again to hide the lines. 

Figure 5-11 Show Lines 
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Creating regular text 

Regular text goes inside fields that you've created. To create text, first you 
use the Browse tool to set the insertion point inside the field you want; and 
then you type. 

Figure 5-12 Selecting che Browse tool 

,,.--- - Select the Browse tool 
to start typing text. 

A [I CT 

Use the Browse tool, not the Paint Text tool, for entering teA1 in fields. 
Regular text is always editable in an unlocked field; Paint text, however, is not 
editable once you have typed it and clicked the mouse button. !:::. 

You use the keyboard to enter text in HyperCard. You must create a field 
before you can type text. (See "Creating a Field," earlier in this chapter.) The 
following steps explain how to enter text in a field: 

1. Select the Browse tool from the Tools menu. 

2. Click in the field where you want to type. 

(The insertion point appears at the left edge of the line you clicked.) 



3. Click where you want the new text to start. 

Or select the text you want to replace. 

4. Start typing. 

Your new text is inserted at the insertion point, or replaces the selected 
text. 

_. Warning When you tab to a field that already contains text, all the text is selected. 
Typing at this point will wipe out all the old text in the field, and replace it 
with what you type. To preserve the old text, move the pointer where you 
want to begin typing, and click. A 

Fields without text in them are sometimes invisible; unless you tab to a field, 
or you want to type in a field that already has some text in it, you'll have to 
estimate the field's position (or choose the Field tool to see where all the 
fields are). 

If you type more text than will fit in a non-scrolling field, the remaining text 
goes off the bottom of the field. But this invisible text isn't lost, it's just 
hidden. To see the hidden text, make the field bigger. 

Figure 5-13 Revealing hidden text 
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You can move and copy text from one part of a field to another, or from one 
field to any other field anywhere in HyperCard. 

You use the basic Macintosh cut-and-paste techniques for moving and 
copying text in HyperCard. (For details, see the Macintosh System Software 
User's Guide or your Macintosh owner's guide.) 

•:• Uneditable text: If you can't edit text, check the Field Info dialog box for 
that field to see if Lock Text is checked. If the field is unlocked, or if the 
text exists outside of a field, the text is Paint text. To change Paint text, 
you must erase the old text and create new text. 

The section "Duplicating a Field," earlier in this chapter, explains how to copy 
a field along with its text. 

You can determine how the text in each field looks by using the Text Style 
dialog box. 

To set text properties: 

1. Select the field you want to work with by clicking inside it. 

Either the Browse tool or the Field tool must be active. 

2. Choose Text Style from the Edit menu. 

The dialog box in Figure 5-14 appears. 

3. Set the properties as you prefer. 

You can set font, size, style, alignment, and line spacing (line height). 

4. Click OK. 



Figure 5-14 The Text Style dialog box 
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6. Important The properties you set affect all the text within a field. You cannot, for 
example, make a single word bold unless it's the only word in the field. !:::. 

Font 

You can use any font that's on your startup disk. You can see all the available 
fonts by scrolling through the list at the bottom of the Text Style dialog box. 
The font of the text you've selected is highlighted. 

To change the font, just click the one you want. A sample of what your text 
will look like appears in a box at the lower right. When you've finished with 
the Text Properties dialog box and click OK, the selected text appears in the 
new font. 
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To return to your work quickly, double-click the font you want. The dialog 
box closes immediately, and the selected text appears with all the properties 
you've set. 

Style 

Text can appear in bold, italic, underline, outline, shadow, or a combination of 
any or all of these. lf the field you've selected has text in any style besides 
plain, the appropriate boxes are checked. 

To choose a style, click the appropriate check box or boxes in the Text Style 
dialog box. An X appears in each box you've clicked. 

To cancel a style choice, click in the check box again. The X goes away. 

A sample of what your text will look like appears in a box at the lower right. 
When you've finished with the Text Styles dialog box, click OK; the text 
appears in the new style. 

All text in a given field has the same style or styles. 

Align 

You can set the text in a field to align to the left side of the field, to the right, 
or to be centered within the field. The same alignment sening works for all 
lines within a field; you can't set each line separately. 

To change the alignment, click the appropriate bunon. A black dot shows in 
the bunon you've clicked. 

When you click the OK box and go back to your work, the text will be aligned 
properly. 

Size 

The box marked Size shows the size of the text in the field you've selected. 
The number you see is the text's size in points. (Point is a printer's term; one 
point is equal to about 1/72 of an inch.) Each point appears as a single dot on 
the Macintosh screen. 



•:• Preset size and style: When you start HyperCard, the preset size and sryle 
is 12 point plain Geneva. The changes you make to size and/or sryle remain 
in effect for all fields you create until you change them or until you leave 
HyperCard. When you enter a field you've already created, any new text 
rakes on the size and sryle of the rest of that field. 

When you click a font name in the Text Sryle dialog box, all the sizes that you 
have in the System file for that font family come up in the scrollable window 
to the right of the font list; the closest one to the actual size of the text in 
the active field is highlighted. (If you haven't clicked a font name, the size 
you see is the size of the text in the active field.) The highlighted size also 
appears in the Size box. 

To use a size other than the one highlighted, scroll to the size you want and 
click it. 

To use a size not listed, replace the number in the Size box with the size you 
want. First select the old size by dragging across it in the size box; then rype 
the new one. 

The highlighted size is the one that's closest to the actual size of the text in 
the active field. 

Height 

Height is the space allowed for each line in a field, expressed in points. The 
number you see in the Line Height box of the Text Sryle dialog box includes 
space for the height of the characters and the space between lines, plus a 
couple of points for slack. HyperCard sets this number automatically when 
the font size changes; but you can set it by typing whatever number you 
want. 

To change the line height, replace the number in the Line Height box with a 
new number. First select the old number by dragging across it; then rype the 
new one. The new number replaces the old one. 

To make lines touch or overlap, set the Line Height size lower than the Font 
size. The exact number varies from font to font; experiment until you get the 
effect you want. 

•:• Top line can get chopped: You might lose some of the top line if you set 
the Line Height size below the Font size. 
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You can also vary the space between lines in a field using the following two 
Command-key sequences: 

To increase the space between lines of text in a field, select the field and type 
Shift-Option-Command->. 

To decrease the space between lines of text in a field, select the field and type 
Shift-Option-Command-<. 

Summary 

In this chapter, you learned about fields and text in HyperCard. You saw that: 

• all regular text appears in fields 

• you create fields using the Field tool 

• you can create fields both on a background and on a card 

• fields can be enlarged or made smaller, moved, copied, cut, deleted, and 
pasted 

• you enter text into fields using the Browse tool 

• you can move, copy, cut, delete, and paste text 

• all text within a field shares the same properties-font, size, style, 
alignment, and line spacing 

Chapter 6 has more details about text and fields. See especially "Print Report" 
for information on printing text in fields, and "Field Info" to read about 
protecting a field 's text from being changed. 



c H A P T E R 6 

Graphics in HyperCard 

t lS CHAPTER PRESENTS AN OVERVIEW OF HYPERCARD'S GRAPHIC ELEMENTS 

and shows how the different elements can work together. (Chapter 7 

tells you what tools and commands you have at your disposal for creating 

pictures.) 

89 



This chapter contains the following sections: 

• "Menu Commands You Use With Graphics" provides a brief frame of 
reference for using the Paint commands in different menus to produce a 
finished picture. 

• "Power Keys" gives details on special states and commands you execute 
from the keyboard. 

• "Double-Clicking Paint Tools" summarizes what happens when you 
double-click on certain tools. 

• "Dragging With Modifier Keys" lists the effects of pressing Command, 
Option, or Shift while you drag with different Paint tools selected. 

• "Special Effects" shows what happens when you combine several 
features. 

• "Importing Pictures" suggests ways to bring pictures into HyperCard 
from outside sources. 

Menu commands you use with graphics 

To make finished picrures in HyperCard, you use commands from several 
menus. 

• To create the basic picture elements-shapes, panems, contours-use the 
tools on the Tools menu and the panerns on the Pattern menu. 

• To borrow pictures from cards that already exist in the current or other 
stacks, use the Copy and Paste commands from the Edit menu. 

• To bring in a picture you created someplace else using MacPaint® or a 
MacPaint-compatible application, or that you brought into the computer 
using a digitizing camera, scanner, or some other peripheral device, use the 
Import command from the File menu. (You can also bring in pictures 
through the Clipboard and the Scrapbook.) 

• To create a picture common to several cards, use the Background 
command. 

• To manipulate the picture and to do finish work- rotate parts of it, bring 
up FatBits, and so on-use the commands in the Paint menu. 
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Power keys 

When you choose Power Keys from the Options menu, striking a single key 
does the work of selecting a specific menu command. 

The Options menu is visible only when you've selected a Paint tool. 

Table 6-1 shows a list of menu commands and their power-key equivalents. 
(Each of these commands is described in detail in Chapter 7.) 

Table 6-I Power keys 

U>m.mand Key Menu 

Darken D Paint 
Draw Centered (on/oft) c Options 
Draw Multiple (on/oft) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (on/oft) G Options 
Invert Paint 
Lighten L Paine 
Line size 1-4,6,8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate Left [ Paint 
Rotate Right J Paint 
Select s Paint 
Select All A Paint 
Select black pattern B Patterns 
Select white pattern \YI Patterns 
Trace Edges E Paint 
Transparent T Paint 

Listed ne>.t are descriptions of a few power keys chat need special mention. 
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Power key P: Making a 
graphic cookie cutter 

Power key P chooses the Pickup command in the Paint menu. It works like a 
cookie cuner. You drag a source image (the cookie cuner) over the image 
whose pattern you want to pick up (the cookie dough). HyperCard uses the 
outline of the source image as the cookie cutter. Pressing power key P is like 
pushing the cutter into the dough-when you drag the cutter away again, 
it's converted to the pattern you moved it over. 

Figure 6-1 The source image picks up the pattern of the overlaid image 

1. This is the shape with the 
panem you want to change. 

• 
. 

. . 
3. Select the shape and move 

it over the pattern. 

~ 
I I 
f I 

~~ 
5. Drag the shape away. 

• 
. 
' 
' . . 
. . 

2. This is the pauem you 
want to use . 

4. Choose Pickup (or just press P 
if power keys are active). 
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Power key S: Tightening 
the selection 

Power key S lets you lasso a picture thac you've already selecced with the 
Selection cool. You can also press S co selecc an area you've jusc drawn (or 
even erased) with another cool; once selected, you can move ic or fill it, or do 
whatever else you want with it. 

Figure 6-2 Refining a selection 

Use the Selection tool 
to grab the general area ... 

. . . press power key S to separate 
the graphic wheat from the chaff. 

Power key S is especially useful when you want to select a specific area 
quickly with no white space, or if your hand isn't steady enough to use the 
Lasso tool wich precision. 
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Power key T: Turning·a 
graphic transparent 

Ordinarily when you draw or paste a graphic onto a card, the graphic is 
opaque-that is, it totally covers what it's drawn or pasted over. Pressing 
power key T makes the graphic transparent so that what it covers shows 
through. 

Figure 6-3 Opaque and transparent images 
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Double-clicking Paint tools 

Double-clicking certain Paint tools enhances using those tools. Here's a list of 
the tools and what double-clicking does. (Chapter 7 tells you what each tool 
is for, and how to use it.) 

Table 6-2 Effects of double-clicking Paint tools 

Double-dick ... 

Any pattern 
Brush 
Bucket 
Curve 
Eraser 
Lasso 
Lines 
Oval 
Paint Text 
Pencil 
Polygon 
Regular Polygon 
Rectangle 
Rounded Rectangle 
Selection 

Effect 

Bring up Pattern Edit dialog box 
Bring up Brush Shapes dialog box 
Hide/show pattern menu 
Toggle Draw Filled command 
Erase whole picture 
Lasso every element in a picture 
Bring up Line/Size dialog box 
Toggle Draw Filled command 
Bring up Text Style dialog box 
Set/cancel FatBits 
Toggle Draw Filled command 
Bring up Polygon Sides dialog box 
Toggle Draw Filled command 
Toggle Draw Filled command 
Select whole picture 
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Dragging with modifier keys 

Dragging with different Paint tools selected has different effects, especially 
if you're pressing Command, Shift, or Option at the same time. Table 6-3 
shows you what happens. Paint tools that aren't listed aren't affected by 
modifiers at all. 

Table 6-3 Effects of dragging Paint tools while holding down modifier keys 

Tool Command Shift Option 

Selection Select tightly Move selection horizontal or vertical Copy selection 
Lasso Lasso everything Move selection horizontal or vertical Copy selection 
Line No effect Draw at multiples of 15° angles Draw with pattern 
Eraser Erase in white Erase straight horizontal or vertical No effect 
Pencil Get/leave FatBits Draw straight horizontal or vertical No effect 
Rectangle No effect Draw square Patterned border 
Curve No effect No effect Patterned border 
Brush Erase what you Paint straight horizontal or vertical No effect 

paint over 
Spray Erase what you Spray straight horizontal or vertical No effect 

spray over 
Rounded Rectangle No effect Draw square with round comers Patterned border 
Polygon No effect Draw at multiples of 15° angles Draw with pattern 
Oval No effect Draw circle Patterned border 
Regular Polygon No effecr Rorate in 15° increments Patterned border 
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Special effects 

In many cases, holding modifier keys down in combination with choices 
from the Options menu makes combinations of effects. Experiment with 
different combinations to see what happens. (Figure 6-4 shows some 
examples.) 

Figure 6-4 Special effects 

Select part of a picture. 

Draw Multiple and 
Draw Filled 

,, c-
Draw Multiple, Grid on 

Hold down Command-Shift-Option 
and drag with Grid checked in 
the Options menu to enlarge or shrink 
the selection. 

Draw Multiple with 
Rectangle, Grid on 

I l I ,, 
I/ 
I . 
k_- -------

Draw Multiple with Line tool, 
Shift key held down 

,,,...-- ......... 
/,,,. --~' . - ....... 

'(~)'i' 
·'--"· ·,,. ==· ·/ ...._ __ _ 

Draw Multiple with Circle tool, 
Grid and Draw Center on, 
Shift key held down 

Draw Multiple with 
Line tool, Grid on 
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Importing pictures 

There are many products that create pictures compatible with MacPaint. 
Some products let you create MacPaint pictures from scratch, others let you 
digitize images using a video camera attached directly to the Macintosh, and 
still others connect to the Macintosh through an ImageWriter® printer. 
However you create it, you can bring any MacPaint picture into HyperCard 
using the Import Paint command on the File menu. Once you've imported a 
picture, you can treat it as if you had created t11e imported image in 
HyperCard. 

•!• Try the Clipboard: Sometimes you might want to bring a non-MacPaint 
picture into HyperCard- for example, something you create using 
MacDraw or a similar application. Try copying the picture to the Clipboard 
or to the Scrapbook first; then paste into a HyperCard card. 

Figure 6-5 An imported digitized image 

•!• Built-in screen shooter: To take a quick snapshot of the screen in nearly 
any Macintosh application, press Command-Shift-3. This keyboard 
command, built into your Macintosh's System file, stores a picture of the 
screen on disk under the name SCREEN n, where n is a digit from 0 
through 9. (When you already have all 10 digits used, your Macintosh 
beeps and you can't save more pictures until you rename or erase some.) 
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Summary 

In this chapcer you saw how HyperCard's graphic elements work cogecher. 
You learned 

• which menu commands to use to perform specific tasks 

• how co use power keys instead of menu commands to perform certain 
functions, and about the unique effects of certain power keys 

• the effects of double-clicking Paint tools 

• the effects of dragging with different Paint tools selected 

• the special effects that happen when you combine different elements 

Chapter 7 gives details for using all the Paint tools in the sections called 
"Tools Menu," "Paint Menu," and "Options Menu." 
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c H A P T E R 7 

Menu Commands 

Tms CHAYrER GIVES DETAILED DESCruPTIONS or EACH COMMAND IN THE 

HyperCard menus. You can also find information on commands in the Menus 

section of the on-line Help system. 
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•:• General tools versus Paint tools: Throughouc chis chapcer you'll see 
references co General tools and Paint cools. General tools are those tools 
that appear on the first row of the Tools menu; use them for general 
HyperCard casks (browsing, creacing buttons and fields, entering text). 
Paint tools are all the other tools on the menu; use them to create and edit 
pictures. For details, see "Tools Menu," later in this chapter. 

Figure 7-1 General tools and Paint tools 
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General tools 

Pain! tools 

Menu iterns are described in che order that they would appear if Scripting was 
checked in the User Preferences card of the Home stack. (See "User 
Preferences" in Chapter 4.) 

File menu 

The File menu holds commands that save information to, or retrieve 
informacion from, a disk. You can choose any command on the file menu 
while you're using a General tool (thac is, any of the tools on the top row of 
the Tools menu); while you're using a Paint tool, you can choose only Import 
Paint, Export Paint, or Quit HyperCard. 



The different File menus The level ser on the User Preferences card of the Home stack, in conjunction 
with the protection level ser for a particular stack, determines which menu 
appears when you press File. If either level is set to Browsing or Typing, you 
choose a command from the short menu (far left in Figure 7-2). Otherwise 
you choose from the full menu (middle in Figure 7-2). While you're using a 
Paint tool, you can choose only Import Paint, Export Paint, or Quit HyperCard 
(far right in Figure 7-2) no matter how high your level is. 

Figure 7-2 File menus 

p 
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For Browsing and Typing 

01 II 11 

For Painting, Authoring, 
and Scripting I I ,, 

With Paint tool selected 

For information on user levels, see "User Preferences" in Chapter 4. For 
information on individual stack protection, see "Protect Stack," later in this 
chapter. 

See "Tools Menu," later in this chapter, for a description of the tools. 

6 Important HyperCard has no Save command. HyperCard automatically saves what you 
create whenever you switch from one card to another. To save your stack 
under a different name, use the Save A Copy command. 6. 
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New Stack. .. 

Open Stack. .. 
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New Stack puts away the current stack (making sure that all the work 
you've done is saved) and creates a new one. 

When you choose this command, HyperCard puts up a directory dialog box 
and asks you to name the new stack. 

Figure 7-3 Naming a stack 
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if this box is checked. 

If you click New with the box next to "Copy current background" checked, 
HyperCard creates a new stack with the background fields, background 
picture, and background buttons (including all actions) of the last viewed 
card in the previous stack. If "Copy current background" is unchecked, the 
new stack is blank. 

To choose this command, you must be using a General tool. 

Open Stack (or Command-0) opens an existing stack for your use. This 
command brings up the Directory dialog box and waits for you to select a 
stack. When you've made your selection, HyperCard closes the stack you 
were working with and saves any changes you made; then it gets the stack 
you asked for. The first card in the summoned stack appears on the screen. 



Save a Copy ... 

•:. An Open Stack alternative: You can also open a stack by typing Go 
"stack name" into the Message box and pressing either Return or Enter. 
(You get the Message box by choosing Message from the Go menu.) For 
example, to get to the Art Ideas stack, type Go "Art Ideas" and 
press Return. 

To choose this command you must be using a General tool. 

•:• Where the stacks are: If HyperCard can't find a stack, it displays the 
directory dialog box and asks you to tell it where the stack is. If the stack 
is on a 3.5-inch disk, you'll need to insert the disk into one of your drives 
and click the Drive button in the directory dialog box until the name of 
that disk appears in the upper-right comer. Stacks that come with 
HyperCard are scattered among the HyperCard disks. See Appendix B for a 
listing. 

Save a Copy saves a copy of the stack you're working on under a new name. 
(You continue to work on the original stack.) Use it to preserve a stack in its 
unchanged condition while you experiment with new variations. 

Figure 7-4 Saving a stack under a different name 

I·- · Fast Eddie I 
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Import Paint ... 

Export Paint ... 

106 Chapter 7: Menu Commands 

HyperCard presets the name of the copy to "Copy of (original stack name)." 
(The name is automatically selected; to change it, just type the new name.) 

To choose this command you must be using a General tool. 

Import Paint (available only when a Paint tool is selected) gets a copy of a 
MacPaint-compatible document from the disk and pastes it onto the current 
card. 

When you choose Import Paine, the directory dialog box appears so you can 
select a document using the hierarchical file system. HyperCard pastes the 
imported document, starting at the imported document's upper-left corner, 
onto the card. 

•!• Some picture prepping: You might want to do some preparation work on 
a document before you import it. Make sure the part of the document 
you want to paste is in the document's upper-left corner before you bring 
it into HyperCard. (You can't scroll documents in HyperCard). 

For complete information on graphics in HyperCard, see "Paint Menu," "Tools 
Menu," and "Pattern Menu," later in this chapter, and Chapter 6, "Graphics in 
HyperCard." 

The Export Paint command (available only when a Paint tool is selected) takes 
a snapshot of the current card and saves the snapshot as a MacPaint 
document. 

Export Paint creates a MacPaint document from the card on the screen and 
saves it to a disk under the name you give it. The image of the full-sized card 
gets saved, even if you're using FatBits. If Background is checked in the Edit 
menu, just the background picture is saved. 

HyperCard exports only card and background information. If you have a tear­
off menu on the screen, its image isn't included with the exported picture. 

You can't save buttons and actions using Export-you only save an image of 
what's on the screen (including images of buttons and text). 

For complete information on graphics in HyperCard, see "Paint Menu," "Tool 
Menu," and "Pattern Menu," later in this chapter, and Chapter 6, "Graphics in 
HyperCard." 



Compact Stack 

Protect Stack ... 

•:• Quick exporting: To take a quick snapshot of everything on the screen 
(including the menu bar and any tom off menus), press Command-Shift-3. 
This keyboard command, built into your Macintosh's System file and 
available any time, saves a picture of the screen under the name SCREEN n, 
where n is a digit from 0 through 9. (When you already have all 10 digits 
used, your Macintosh beeps; to make room for more, go to the Finder and 
rename or delete some of the snapshots.) You can use this shortcut in 
almost any Macintosh application, and later import the picture into 
HyperCard using the Import Paint command. 

This command (available only when Painting, Authoring, or Scripting is 
checked in the User Preferences card of the Home stack) gets rid of free space 
in a stack. Free space gets introduced into a stack each time you delete a card, 
background, field, or button; the more free space in a stack, the slower and 
larger the stacks. 

To see the amount of free space in a stack, look at the number following the 
words "Free in Stack" in the Stack Info dialog box. (Stack Info is an item in 
the Objects menu, available when Authoring or Scripting is checked on the 
User Preferences card.) 

To use this command, you must have a General tool selected. 

Protect Stack sets levels of protection for the information in, and design of, 
the current stack. Use it to keep your personal stacks private, or to limit the 
way people can use or change your stacks. Choosing this command brings up 
the dialog box in Figure 7-5. 

Figure 7-5 The Prorect Stack dialog box 

P•olec l \I HI: 

di l II d hj \ l 11 k 

ant t•let '''' I: 

P11 •dll' II I'\\ 

\ Pd\\ I "' 

l1m11 L\PI " 1111 

llrou \II J 

llJP J 
P 11nt 111 

lluthc 1 111 

• 11 l 1 J 

( OK ) u 

File menu 107 



Can't modify stack 

This option allows you to set write-protection for your stacks. When this 
box is checked, you can't change the stack in any way. This means that you 
can't change the design of any background or card in the stack, enter or 
change text in any field, or delete the stack. (When "Can't modify stack" is 
checked, the "Can't delete stack" box is automatically checked.). You can, 
however, copy anything from the stack. 

•!• It's easy to tell when you're using a write-protected stack- a padlock 
appears to the right of the rightmost menu title on the menu bar, and the 
commands Compact Stack and Delete Stack in the File menu are 
unavailable. 

When a stack is on a write-protected medium (a locked disk, CD-ROM, or 
locked folder on a ftle server), HyperCard automatically puts a check in the 
"Can't modify stack" box; you can't uncheck it. To make permanent changes 
to such a stack, you first have to unprotect it. In many cases, copying a stack 
to an unlocked disk makes the stack modifiable. (But if "Can't modify stack" 
is checked or the Locked box is checked in the stack's Get Info box, you have 
to uncheck these boxes before you can make changes to the stack.) 

.A. Warning Some stacks are designed so that, when the stack is locked, you can type into 
a field or paint a picture on a card or background; but the changes disappear as 
soon as you leave the current card. .& 

Using stacks on a file server 

When a stack is on a locked medium (a locked disk, CD-ROM, or a locked 
folder on a file server) or its Locked box is checked in Get Info, any number of 
users can have read-only access to it via a ftle server. When a stack is unlocked 
on a ftle server, only one user has access to it. 

6 Important Checking "Can't modify stack" in the Protect Stack dialog box is not 
sufficient to make the stack available to more than one user on a file server. 
6. 
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Can't delete stack 

When this box is checked, you can't delete the stack. 

Private Access 

When this box is checked, you must type the proper password (as determined 
by Set Password, below) before HyperCard lets you use the stack at all. 

Set Password 

Click this button to set or change a password. You set a password to restrict 
access to the Protect Stack dialog box (thus preventing unauthorized 
changes) or to restrict access to the stack. The dialog box in Figure 7-6 
appears. 

Figure 7-6 The Password dialog box 

Enter· new password her·e: 

IJoe sent m~ 

lier 1fy new password here: 

None l n OK u ( Cancel ., 

Type the password you want to use into the "new password" text box; then 
press Tab to move the insertion point to the "verify new password" text 
box, and type the password again to verify it. 

Click None to cancel the password and to put the dialog box away. 

When you use the password later, it must match character-for-character the 
one you set. (Uppercase and lowercase letters don't have to match.) 
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Figure 7-7 Matching and nonmatching characters 
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When a password is set, you can't get to the Protect Stack dialog box 
without knowing the password. When Private Access is checked, you must 
know the password to use the stack at all. 

.A Warning There's no way to find out a password once it's been set. If you forget the 
password, you cannot get to the Protect Stack dialog box again. If you've 
checked Private Access and you forget your password, you won't be able to 
use the stack again once you leave it. .t. 
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Limit user level 

The box you check here limits the commands and tools a user can employ 
within the current stack. When a limit you set here conflicts with a limit set 
on the User Preferences card of the Home stack, the lower of the two levels 
takes precedence. (Browsing is the lowest level.) Table 7-1 shows the powers 
inherent in each level. 



Table 7-1 Powers associated with each user level 

Browsing Short File and Edit menus (Figure 7-8), plus the Go menu. Use of 
the Browse tool. 

Typing Same as Browsing, plus ability to edit text in existing fields. 

Painting Same as Typing, plus full File and Edit menus (Figure 7-8), Tools 
menu (plus Paint, Options, and Panem menus when a Paint cool is 
selected), use of all Paint cools (but not Button and Field tools), 
Power Keys option. 

Authoring Same as Painting, plus Objects menu, use of Button and Field tools. 

Scripting Same as Authoring, plus ability to write and edit scripts. 

Figure 7-8 Short and full File and Edit menus 
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6. Important When you restrict a user's level to Browsing or Typing, Protect Stack doesn't 
appear on the File menu. (See far left, Figure 7-8.) To get a full File menu no 
matter what the user level is set to (either in Protect Stack or on the User 
Preference card), hold down the Command key before you drag through the 
File menu. b. 

Delete Stack ... 

112 Chapter 7: Menu Commands 

•!• Card and background protection: You can also protect each card or 
background individually by checking the proper box in the Card Info or 
Background Info dialog boxes. See "Card Info" and "Bkgnd Info," later in 
this chapter, for the details. 

Delete Stack (available only when Painting, Authoring, or Scripting is checked 
in the User Preferences card of the Home stack) removes all the cards, 
background pictures, background buttons, actions, and fields of the current 
stack. It's as though you had dragged the stack to the Trash in the Finder. 
Use it when you have no further use for a stack. 

HyperCard first asks you to confirm the deletion. After the stack is deleted, 
you end up at the Home card. (See Chapter 4, "Home.") 

Figure 7-9 The dialog box for deleting a stack 
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To choose this command you must be using a General tool. 



Page Setup ... 

Landscape 
printing icon 

Page Setup lets you set paper size, orientation, and certain effects for 
printing. You see this dialog box: 

Figure 7-10 The Page Setup dialog box 
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•:• Laser\Vriter smoothing or orientation flipping slows printing: If you're 
using an Apple LaserWriter® with Smoothing checked in the LaserWriter 
Page Setup dialog box, or with any of the orientation options checked, 
printing is slowed down considerably. Print a sample with Smoothing 
unchecked first to see if the results are acceptable. 

6. Important If you select the landscape printing icon for horizontal printing on your 
LaserWriter, be sure to choose Fast Laser Printing. If you don't, printing a 
stack will be extremely slow. 6 

•:• Some Laser Writer printing features don't work: The Reduce or Enlarge 
feature doesn't work for any printing in HyperCard. The Invert option 
works correctly only when Fast Laser Printing is turned off, but it takes 
an extremely long time to print. 

To choose this command you must be using a General tool. 
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Print Card 

6. Important 

Print Stack ... 
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Print Card (or Command-P) prints the current card using the specifications 
you gave in Page Setup (except that cards are printed full size, no matter what 
reduction or enlargement you specify). Use the Print Card command when 
you need a hard-copy version of any single card in any HyperCard stack. (To 
print all the cards in a stack, use Print Stack, described in the next section.) 

To choose the Print Card command, you must be using a General tool. 

To print from HyperCard without a hard disk, you must have (in one of your 
drives) a disk with a System Folder containing the appropriate printer 
resource for your printer. 6 

Print Stack prints all the cards in the current stack in linear order. (With a 
LaserWriter, Print Stack prints the cards in reverse order so that the ftrst card 
is on top of the pile in the output tray.) 

To choose the Print Stack command, you must be using a General tool. 

Print Stack brings up a dialog box. (See Figure 7-11.) 

Figure 7-11 The Print Stack dialog box 

}-
Click here to change 
the number of cards 
that will appear 
on the page. 



Manual paper feed 

Check the box labeled "Manual paper feed" if you're feeding the paper by 
hand; HyperCard will stop the printer after each sheet and wait for you to 
add more paper. 

Fast laser printing/Darker printing 

Check "Fast laser printing" on a LaserWriter printer to speed up hard-copy 
production. It's recommended for most printing jobs. 

6 Important If you select the landscape printing icon in the Page Setup dialog box for 
horizontal printing on your Laserwriter, be sure to check "Fast laser printing." 
If you don't, printing a stack will be extremely slow. 6 

Check "Darker printing" on an Apple ImageWriter printer to print darker 
(useful if your ribbon is old). 

Click "No space between cards" to print cards close together (for printing 
two cards or more per page). 

Cards printed per page 

Click one of the four choices to determine how many cards are printed per 
page. Look in the minipage window to see how many cards fit on a page. 
(The number varies with the options you've chosen.) 

Page formats 

"Standard format" and "Split-page format" determine how cards are spaced 
on a page when you print a stack. 

"Standard format" prints cards evenly spaced on the entire page. This choice 
leaves enough room on the left edge to put binder holes in the printout. 

"Split-page format" spaces cards so that the printed sheet can be folded 
down the middle without creasing any card's image. This choice leaves room 
for binder holes at the top and bottom of the page. 
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Figure 7-12 Standard format and Split-page format 
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Print Report ... 

Header 

Tab co the Header box and cype what you want to appear as a heading at the 
top of each sheet Click the proper icon(s) after you cab to add page numbers, 
the date, the current time, and/or the scack name to the header. Click icons in 
the order you want them to appear in the heading. (Use the space bar to 
separate them.) You can preview what the header will produce by looking at 
the miniature represencation of the page, which is shown at the left of the 
dialog box. 

Format remembered 

Once you print a stack, HyperCard remembers the format and header you 
used for that scack so you can use the same setup next time you print 

Print Report gathers text out of fields from the cards in a stack and prints a 
report, using the design you specify in the Print Report dialog box. Use this 
command co get princed summaries of your scacks in a form most useful 
to you. 

To choose this command you must be using a General tool. 

•!• Reports are based on a single stack: Each report is based on information 
from a single stack. There is no way to combine information from two 
separate stacks into a single report. 

When you choose Print Report, the dialog box in Figure 7-13 appears. 
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Figure 7-13 The Print Report dialog box 
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You can print reports in three formats-labels, columns, or rows. 

Here's a list of alternatives showing the various combinations of fields that 
can appear in your reports. (You can use only the last alternative for the 
column format.) 

• all card fields in the stack 

• all background fields in the stack 

• all background and all card fields in the entire stack 

• all card fields from cards with the current background 

• all card fields from cards with the current background, plus all or some of 
the current background fields 

• all or some fields from the current background 

To a print a report based on one of these alternatives, you must click buttons 
and check boxes on the Print Report dialog box in the proper combination. 

Table 7-2 shows you those combinations. 



Table 7-2 Controlling the printout of a report 

To print. .. 

All card fields in entire stack 

All background fields in entire stack 

All card fields & all background fields 
in entire stack 

All card fields of cards with current 
background 

•selected background fields of cards 
with current background 

All card fields and selected background 
fields of cards with current background 

Click this radio button 

In the entire stack 

In the entire stack 

In the entire stack 

With the current background 

With the current background 

With the current background 

... and ... Check only these boxes 

Card fields 

Background fields 

Card fields 
Background fields 

Card fields 

Selected background fields 

Card fields 
Selected background fields 

'This is the only format available for printing in columns. 

When you check "Selected background fields," you activate a selection box 
from which you select fields to print from the current background. 

To select a field, click its name. Use the Scroll bar to look through the list of 
field names. 

To select more than one field, hold down the Shift key as you select each 
name. 

To deselect a field, click its name. 

To deselect a field when more than one are selected, hold down the Shift key 
as you click. 

Field printing order 

The order in which you select fields determines their printing order. On labels, 
the first field you select goes on the top line of the label, the second field 
goes on the second line, and so on. In the column format, the order in which 
you select fields determines their left-to-right printing order. In the row 
format, the first field you select goes on the top line of the card block, the 
second field goes on the second line, and so on. 
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Labels 

Clicking this button makes HyperCard print the fields you've selected in a 
format suitable for labels. Each label contains text from the fields of one card. 
HyperCard automatically centers the text in each label. 

You can change the number of labels per sheet and the size and spacing of the 
labels by dragging on the highlighted parts of the dialog box's minipage 
window. 

As you change the dimensions of labels by dragging in the minipage window, 
HyperCard shows you the maximum number of labels that will fit on a page. 
Changes you make in the position or size of the labels are reflected in the 
measurements at the bottom of the window; use the numbers that appear 
there as a guide. See Figure 7-14. 

Figure 7-14 Print Report in label format 
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Drag here to change 
the size of labels. 

Field name appears 
here. 

Drag here to control 
number of labels on 
each sheet and the 
spacing between 
labels. 

If text on a line in a field is too wide for a label, HyperCard wraps the text 
onto the next line. If there are too many lines to fit on a label, HyperCard 
prints what will fit. 

•!• About LaserWriter labels: Only use labels made especially for LaserWriters 
or photocopiers. Check "Larger Print Area" under Options in the Page 
Setup dialog box for better centering of text on the labels that run along 
the left and right edges of the page. 



•!• About Image Writer labels: Use labels that are on 8.5-by-11-inch tractor­
feed pages. 

Columns 

In the column format, selected fields from the current background are 
printed side by side in vertical columns across the page. Each field has its own 
column. (See Figure 7-15.) 

6. Important You must have "With the current background" checked for the column 
format to work. !:::. 

If a column is too narrow for the entire contents of a field to fit on one line, 
HyperCard wraps the text to new lines as appropriate. 

HyperCard won't let you select more fields than will fit across the page. You 
can see how many will fit by looking at the minipage window. 

You can control the horizontal width of each column by dragging the dashed 
separation lines. 

If you check Cards under "Print the names of,• card names appear in their 
own column on the far left. If you check Fields, field names are printed across 
the top of the page above the appropriate column. If a column is too narrow 
for the entire field name to fit, the field name is truncated. 
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Figure 7-15 Print Report in column format 

......... , 

Rows 

In the Row format, information from each card is printed as a block. Fields 
read vertically down the page for each card. 

You can choose among three different layouts to determine the sequence of 
printing, and the amount of space across the page that's allocated to each 
block. 

If you click on the left layout, each field's information is printed across the 
width of the page, each field below the previous one. With the center and 
right layouts, HyperCard prints blocks of information for two cards side by 
side. (See Figure 7-16.) 



Figure 7-16 Prine Report in row format 
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]1--- - The numbers refer 
to card position 
in the stack. 

- ---- - --- --- --- -- Drag here to change 
printed field width. 

The card sequence in which the information is printed depends on the layout 
order you select. If you select the layout order in the center, reports appear 
beneath each other in the left column until page bottom; The next card's 
report appears at the start of the right column. If you select the layout order 
on the right, the block reports alternate left-right down the page. (See Figures 
7-17 and 7-18.) 

If you check Fields under "Print the names of," the name of each field is 
printed to the left of the field's contents. (If the field is empty, HyperCard 
skips it and doesn't print the field's name.) You can grab the vertical dotted 
line and drag it to adjust the width for the name. Card names are printed at 
the top of each card's block. 

Card blocks are printed in the order that the cards appear in the stack. 
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Figure 7-17 A printed report in row format, top to bottom order 

Figure 7-18 A printed report in row format, left to right order 

Manual paper feed 

Check the manual paper feed box if you're feeding paper by hand; HyperCard 
will stop the printer afrer each sheet and wait for you to add more paper. 



Quit HyperCard 

The different Edit menus 

Header 

Tab to the Header box and type what you want to appear as a heading at the 
top of each sheet. Click the proper icon(s) after you tab to add page numbers, 
the date, the current time, and the stack name to the header. Click icons in the 
order you want them to appear in the heading. (Use the space bar to separate 
them.) You can preview what the header will produce by looking in the 
minipage window. 

Format remembered 

Once you print a report, HyperCard remembers the fonnat and header you 
used for that stack's report so you can use the same setup next time you 
print. 

Quit HyperCard (or Command-Q) leaves HyperCard, automatically saving any 
changes you've made. 

Edit menu 

The Edit menu lets you change your work. Undo, Cut, Copy, Paste, and Clear 
all work as they're described in the Macintosh System Software User's Guide 
(or your Macintosh owner's guide). The other commands are unique to 
HyperCard. 

The level set on the User Preferences card of the Home stack, in conjunction 
with the protection level set for a particular stack, detennines which Edit 
menu appears when you press Edit. If either level is set to Browsing or 
Typing, you choose a command from the short menu (left in Figure 7-19). 
Otherwise you choose from a full menu (right in Figure 7-19). 
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Figure 7·19 Short and full Edit menus ... 
Undo 
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For information on user levels, see "User Preferences" in Chapter 4. For 
information on individual stack protection, see "Protect Stack" earlier in this 
chapter. 

Undo (or Command-Z) undoes your last action on a card or background. Use 
it when you make a mistake or when you change your mind about some 
action. 

With the Paint tools, pressing Tilde ( -) or Escape is the same as choosing 
Undo. 

Cut (or Command-X) removes the selected information from the card or 
background and puts it on the Clipboard. Use Cut when you want to move 
something from one place to another. 

Cutting a picture 

When you're using a Paint tool, Cut affects either the background picture or 
the card picture, depending on whether the Background command in the Edit 
menu is checked or unchecked. 



Follow these steps to cut a picture: 

1. Select the portion of the picture you want to cut. 

Use either the Lasso or the Selection tool to do it. (See "Lasso" and 
"Selection Tool," later in this chapter.) 

2. Choose Cut from the Edit menu. 

You can also press Command-X. 

Cutting buttons and fields 

When you cut a button, you also cut its associated actions. If you paste the 
button, you paste its actions along with it. 

6 Important Buttons and the pictures representing them are often separate. This is 
always the case if a button is transparent. Remember to cut and paste the 
picture as well as the button. (You'll have to cut and paste them separately.) 
6 

When you cut a field, all text and attributes (field name, font, and so on) 
belonging to that field are cut along with it. If you paste back that field in 
the same or another stack, you also paste back its attributes, but not its text. 

To cut a button or a field: 

1. Select the button or field tooL 

2. Click the specific button or field you want to cut 

3. Choose CUt from the Edit menu (or press Command-X). 
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Cutting a card 

To cut a card: 

1. Move to the card you want to cut. 

2. Choose Cut Card from the Edit menu. 

When you cut a card, you cut everything on it-picture, fields, text, buttons, 
actions, and a copy of that card's background. 

Cutting a background 

You can't cut a background. To remove a background from a stack, you must 
delete every card that uses that background. If there is only one card in the 
stack, you must delete the stack. 

Copy (or Command-C) makes a copy of the selected information and puts it 
on the Clipboard. The selected information is left unaffected (but whatever 
was on the Clipboard is replaced). If you're using a Paint tool and nothing is 
selected, all the Paint information is copied. 

Copying a picture 

When you're using a Paint tool, Copy gets its information from either the 
background picture or the card picture, depending on whether the 
Background command in the Edit menu is checked or unchecked. 

To copy a picture: 

1. Select the portion of the picture you want to Copy. 

Use either the Lasso or the Selection tool to do it. (See "Lasso" and 
"Selection Tool," later in this chapter.) 

2. Choose Copy Picture from the Edit menu. 

You can also press Command-C. 



3. Move to the card where you want the copied picture to appear. 

Moving between cards or stacks doesn't affect wha~s on the Clipboard, 
the holding place for what you copied. 

4. Choose Paste Picture from the Edit menu. 

Or press Command-V. The copied picture appears. 

5. Drag the picture where you want it to be on the card. 

6. Click anywhere outside the pasted area. 

Copying buttons and. fields 

When you copy a button, you also copy its actions. If you paste the button, 
you paste its actions along with it 

6. Important Buttons and the pictures representing them are often separate. This is 
always the case if a button is transparent. Remember to copy the picture as 
well as the button. (You'll have to copy them separately.) 6 

Follow these steps to copy a button or a field: 

L Select the button or field toot 

2 Click the specific button or field you want to copy. 

3. Choose Copy Button or Copy Field from the Edit menu (or press 
Command-C). 

4. Move to the card where you want the copied button or field to 
appear. 

Moving between cards or stacks doesn't affect what's on the Clipboard, 
the holding place for what you copied. 
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5. Choose Paste Button or Paste Field from the Edit menu. 

Or press Command-V. The copied button or field appears. 

If you're pasting a field, pressing Command-Shift-V pastes the text along 
with the field. 

6. Drag the button or field where you want it to be on the card. 

7. Click anywhere outside the pasted area. 

Copying a card 

To copy a card: 

1. Choose Copy Card from the Edit menu. 

A copy of the current card is placed onto the Clipboard. 

2. Move to the card after which you want the copied card to appear. 

It can be in the current stack or in any other stack. 

3. Choose Paste Card from the Edit menu. 

Or press Command-V. The pasted card becomes the current card. 

To change a card's position so that it's first in a stack: 

1. Move to the card whose position you want to change. 

2. Choose Cut Card from the Edit menu. 

3. Choose First on the Go menu. 

Or press Command-1. The first card in the stack appears. 

4. Choose Paste Card on the Edit menu. 

Or press Command-V. The pasted card appears on the screen; it is now the 
second card in the stack. 



5. Choose First on the Go menu again. 

Or press Command-I. The first card in the stack appears. 

6. Choose Cut Card on the Edit menu. 

The card you had originally set out to reposition is now first in the stack. 

7. Choose Paste Card on the Edit menu. 

(Or press Command-V.) The original first card is now second in the stack. 

When you copy a card, you copy everything associated with it-background, 
picture, fields, text, buttons, and actions. 

Copying a background 

You copy a background by copying the card that has the background you 
want. (A copied card takes everything with it.) 

To copy a background, follow these steps: 

1. Copy a card that has the background you want. 

2. Move to where you want the new background. 

3. Paste the copied card. 

4. Make new cards based on the copied card's background. 

5. Delete the original pasted card. 

You can't replace an existing card's background. 
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Paste (or Command-V) takes a copy of the material that's on the Clipboard 
and puts it on the screen. 

• If the material is regular text, it appears at the insertion point of a field 
you've chosen. 

• If the material is a picrure, it appears at the screen position at which it 
was cut. 

• If the material is a field or button, it appears at the screen position at 
which it was cut. (You can move a pasted selection by dragging within 
the selection.) Pasted buttons and fields retain all their original actions. 

• If the material is a card, it appears after the current card in the stack. A 
pasted card pastes its background as well (assuming the background is 
different from the ones surrounding it). 

When you're using a Paint tool, the material you're about to paste can be text 
or a picrure. If the material is regular text (that is, text created with the Text 
tool), shrinking the selection by dragging the comers with the Command key 
pressed makes more or less of the text appear. (The text wraps at the right 
border of the selection.) The text becomes a picture after you've pasted it and 
clicked outside the selected area. 

Pictures are pasted in opaque; if you want the background to show through, 
choose Transparent from the Paint menu after you've pasted onto the card, 
but before you've clicked outside the pasted area to make the changes 
complete. 

Pasting a card in miniature 

You can paste a picture of a card in miniarure, like the cards that appear when 
you choose Recent from the Go menu. Follow these steps to paste a 
miniature: 

1. Choose Copy Card or Cut Card from the Edit menu. 

2. Move to the card where you want to paste the miniature. 

3. Press and hold the Shift key while you choose Paste Card. 

Alternately, press Command-Shift-V. 



Clear 

New Card 

The miniature appears selected in the center of the screen. 

Note that this is a picture of a card-none of the actions from the original 
card come with the miniature. 

Clear removes the selected information without putting it on the Clipboard 
or affecting what's already on the Clipboard. 

\Vhen you're using a Paint tool, Clear affects either the selected background 
picture or the selecced card picture, depending on whether the Background 
command in the Edit menu is checked or unchecked. 

When the Message box is visible and the insertion point is not visible, Clear 
empties the Message box and puts the insertion point in it. 

Pressing the Delete or Backspace key (or the Clear key on the keypad) has the 
same effect as Clear. 

New Card (or Command-N) adds a card to the current stack. The new card 
automatically picks up the background picture, background buttons, and 
fields of the card you're looking at. 

The new card is inserted immediately after the card you were looking at. You 
end up looking at the card you just inserted. 

To make the new card the first one in the stack: 

1. Choose First on the Go menu. 

Or press Command-I. The first card in the stack appears. 

2. Choose New Card on the Edit menu. 

Or press Command-N. The new card appears on the screen; it is now the 
second card in the stack. 

3. Choose First on the Go menu again. 

Or press Command-I. The first card in the stack appears again. 

4. Choose Cut Card on the Edit menu. 

The card you had originally set out to reposition is now first in the stack. 
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If you want to place the cut card back into the stack, you need to follow 
two more steps: 

1. Move to the card you want to come immediately before the one 
you've just cut 

2. Choose Paste Card on the Edit menu. 

Or press Command-V. 

The pasted card appears on the screen in its new position in the stack. 

Delete Card (or Command-Backspace or Command-Clear) permanently 
eliminates the current card. Delete Card works exactly like Cut Card, except 
that the deleted card does not go onto the Clipboard and so cannot be pasted 
anywhere. 

You can't delete the only card in a stack. If there's only one card in the stack 
and you want to delete it, use Delete Stack from the Stack menu. 

Cut Card (available only when Painting, Authoring, or Scripting is checked in 
the User Preferences card of the Home stack) removes the card on the screen, 
deletes it from the stack, and puts up the next card in the stack. HyperCard 
doesn't ask you to confirm the cut-it just does it. 

You can't cut the last card in a stack. To cut the last card, use Delete Stack 
from the Stack menu. 

Copy Card (available only when Painting, Authoring, or Scripting is checked in 
the User Preferences card of the Home stack) makes a copy of the current 
card and puts it on the Clipboard. Whatever was on the Clipboard is replaced. 

When you copy a card, you copy everything associated with it-background, 
picture, fields, text, buttons, and actions. 



Text Style ... Text Style, or Command-T, (available only when Painting, Authoring, or 
Scripting is checked in the User Preferences card of the Home stack) lets you 
set text properties for the active field or the active Paint text. (Paint text is 
text created using the Paint Text tool.) Paint text is active until you 

• switch tools after you've typed, 

• click the mouse, 

• leave the card, or 

• switch into or out of the background. 

A field is active if the insertion point is in it. 

A dialog box appears, letting you choose text font, style, alignment, size, and 
the height of each line in points. 

Figure 7-20 The Text Style dialog box 
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For more information, see "Setting Text Properties" in Chapter 5. 
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Background Background, or Command-B, (available only when Painting, Authoring, or 
Scripting is checked in the User Preferences card of the Home stack) lets you 
edit the background picture and create background buttons and fields. 

The background serves as a template; whatever's in the background is 
common to all cards associated with that background. 

Figure 7-21 Background versus card 
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With transparent card picture 

The background picture is hidden by any black or opaque portions of the card 
picture. (You choose Transparent and Opaque from the Paint menu, described 
later in this chapter.) 

A background button works for all cards associated with that background, 
unless it's covered by a card button; a background field appears in the same 
location on all cards associated with that background, unless it's covered by a 
card field. 

6 Important The most common mistake in creating a button or a field is putting it on a 
card when it's supposed to be on a background. After you've created one or 
more background buttons or fields, choose Background again to get back to 
the Card level, and flip to the next card; if the buttons or fields you've just 
created are on that card too, you've succeeded. 6. 

When you're working in a background, the menu bar is striped, and a check 
mark appears to the left of the Background command in the Edit menu. (See 
Figure 7-22.) 
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Figure 7-22 The Menu bar is striped while working in a background 
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There's no limit (beyond disk space) to the number of backgrounds a stack 
can have. 

Go menu 

Use commands in the Go menu to navigate through stacks. You can look 
through cards in the current stack, go back through cards and stacks you've 
already seen, or immediately get to any stack represented on the Home card. 

Figure 7-23 The Go menu 
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The Back command (or Tilde, Esc, or Down Arrow) takes you to the most 
recent card you've viewed. Keep choosing this command to review up to the 
last 100 cards you've seen. 

After you've backed through cards, you can press the Up Arrow key to come 
forward again through the reviewed cards. 

When you're using a Paint tool, use Command-Tilde (or Command-Esc) 
instead of Tilde as a shortcut for the Back commands. (Pressing Tilde alone in 
a Paint tool undoes your last action.) 

Home (or Command-H) selects the Browse tool and takes you to the Home 
card, the first card in the Home stack. The Home card is special-it's meant to 
hold bunons that bring you to the most important cards in your collection. 

To go to any stack represented on the Home card, click its picture. (Each 
picture is actually a bunon.) 

For more details about the Home card and the rest of the Home stack, see 
Chapter4. 



Help 

Recent 

Help (or Command-?) takes you to the first card in the Help system. The Help 
system describes everything in HyperCard. 

When you use Command-? as a shortcut to choosing Help, you don't have to 
press the Shift key. 

Recent (or Command-R) lets you backtrack through any or all of the last 42 
cards you viewed. 

When you look at a card, HyperCard puts a miniature picture of it on Recent. 
To go back to that card, just click that card's picture. 

Although you might have looked at the same card several times, Recent holds 
only one picture of it. 

Figure 7-25 Recent-click any image to go to that card 

You can go back through the last 100 cards you viewed in the order that you 
viewed them by using the Back command (or by pressing Tilde), described 
earlier in this section. 

To return to the card you most recently viewed, click the picture of the card 
with the box around it or press Return. 
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First (Command-1 or Command-Left Arrow) takes you to the first card in 
the current stack. 

If you're already at the first card, First does nothing. 

Prev (Cornrnand-2 or Left Arrow) takes you to the previous card in the 
current stack. If you're at the first card in the stack, Prev wraps you around 
to the last card in the stack. 

•:• Prev isn't Back: Prev takes you to the previous card in the current stack; 
Back takes you to the card you last looked at. The last card you looked at 
might have been in another stack. 

Next (Cornrnand-3 or Right Arrow) takes you to the next card in the current 
stack. If you're at the last card, Next wraps you around to the first card. 

Last (Cornrnand-4 or Command-Right Arrow) takes you to the last card in 
the current stack. Use last when you want to create a new card at the end of 
the stack. 

If you're already at the last card, Last does nothing. 

Find (or Command-F) searches for text in the fields of the current stack. 

Choosing Find brings up the Message box, as it appears in Figure 7-26. 

Figure 7-26 The Message box 

The insertion point 



To search for text, follow these steps: 

1. Choose Find from the Go menu. 

2. Type what you want to find. 

Or press the Command key as you select up to a line of characters from 
any text field. (A box appears around the text as you select it.) 

3. Press Return or Enter. 

HyperCard searches the current stack for a series of characters in any field 
that begins with what's in the Message box. HyperCard looks for the first 
card that contains everything between the quotation marks, even if the 
words appear in a different order. 

' .. 
1-.--- - Matches what's 

in the Message 
box 

Pressing Return after a search makes HyperCard repeat the search. 
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If you choose Find again after an initial search, HyperTalk selects what 
you've typed between the quotation marks. To replace what's in the 
Message box, just type something new. 

•!• Watch those quotation marks: The text that you want to find must 
appear between quotation marks after the word "find.• 

To cancel a search-in-progress, press Command-period(.). 

If HyperCard can't find the text, the Macintosh beeps. 

Searching in a specific field 

HyperCard automatically searches through all the fields on all the cards in the 
current stack. You can limit the search to one specific background field. 

To limit the search to a specific field, click after the last quotation mark and 
type a space, the words in field, and the field number or name. 

Figure 7-2B shows an example. 

Figure 7-28 limiting the search 
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To find the name or number of a field, click in the field with the Browse tool 
selected and choose Field Info from the Objects menu. 



Alternatively, take the following steps: 

1. Click the Field tool 

To use the Field tool, you must have Authoring or Scripting checked on 
the User Preferences card in the Home stack. 

2. Click the field whose name or number you want to know. 

3. Choose Field Info from the Objects menu. 

Or just double-dick in the field you're interested in. 

Figure 7-29 Finding out a field's number 
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Find Whole 

Find Whole (or Command-Shift-F) lets you search for a specific whole word 
or phrase (including spaces) anywhere in a stack. 

For HyperCard to find a match, all the characters must be in the same field on 
a card, and they must be in the same consecutive order as they appear in Find 
Whole's argument: 

Find Whole "Apple Computer" 
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The command shown above tells HyperCard to find cards that have the 
phrase "Apple Computer" on them; it won't find "Apple Computers" or "This 
apple is a computer.• (The Find command without Whole would find 
matches for all three cases.) 

Find Whole won't stop on cards that have only partial matches: for example, 

Find Whole "Ed" 

won't match "Edward." 

Find Whole pays no attention to case or to diacritical marks when it looks for 
matches: "apple C0mputer," "apple computer," and "Apple Computer" are all 
considered the same by this command. 

When you use the Find command without Whole, HyperCard looks for cards 
that contain everything between the quotation marks, even if the words 
appear in a different order or in different fields. 

As with Find, you can use Find Whole to search in a specific background field. 

Message (or Command-M) shows the Message box. Use the Message box to 
send any one-line message to HyperCard. 

To send a message: 

1. Make sure the insertion point is in the box by clicking in it 

2. Type the message. 

3. Press Enter or Return. 

Figure 7-30 Sending a message 

To stop a message-in-progress, press Command-period (.). 



To clear the Message box so you can use it again, do any of the following: 

• Choose Message box again from the Go menu. 

• Press Command-M. 

• Select all the text in it and press Clear or Backspace. 

• Select all the text in it and type a new message. 

To hide the Message box, click its close box (or press Command-M). 

To type messages into the Message box when the box isn't visible, check 
Blind Typing on the User Preferences card in the Home stack. 

See Appendix A for a list of the most common HyperCard messages. 

For detailed infonnation on all HyperCard messages and other advanced 
HyperCard topics, see the HyperCard Script Language Guide (available from 
Addison-Wesley Publishing Company). 

Tools menu 

You use tools to browse, to edit text and pictures, and to create and change 
buttons and fields. You can have only one tool selected at a time. One tool­
any tool-must be selected. 

Figure 7-31 Tools in action 
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The Tools menu appears when Painting, Authoring, or Scripting is checked on 
the User Preferences card in the Home stack. 

The Tools menu holds the General and Paint tools. General tools are on the 
menu's top line; they control browsing, text creating and editing, and 
button creating and selecting. Paint tools, which fill the rest of the menu, 
control creating and editing pictures. 

Figure 7-32 General tools and Paint tools 
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Menu bar changes 

You can "tear off' the Tools menu, creating a movable tools palette. 

To create a movable Tools palette, drag down through the menu, either past 
the bottom or beyond either side. You can also press Option-Tab to make a 
Tools palette appear and disappear. 

Put the palette wherever you want. 

Figure 7·33 Using the Tools palette 

~Closebox 

_ Drag here. 

To put it away, click its close box. To move the palette around, grab it by its 
top bar or by any edge. To select a tool, click it. (You can also select a tool 
from the Tools menu in the Menu bar, even if you have a palette tom off; the 
palette will reflect the menu selection.) 

To select a tool, click inside the box that holds it. The tool you select becomes 
highlighted in the menu, and, depending on the tool you've selected, the 
shape of the pointer might change. 

Authoring or Scripting must be checked on the User Preferences card in the 
Home stack if you want to select the Button tool or Field tool. 

When you choose one of the Paint tools, three new menus appear-Paint, 
Options, and Patterns. (These menus are described later in this chapter.) If the 
Objects menu was visible, it disappears; it reappears (and the Paint, Options, 
and Patterns menus all go away again) when you choose a General tool. 
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When you select the Browse tool, the pointer becomes a hand with the first 
finger extended. Use the Browse tool to click buttons, to edit text, and to 
select text for searching. The Browse tool converts to an I-beam when it's 
over editable text when any level except Browsing is checked on the User 
Preferences card in the Home stack. 

In its I-beam shape, the pointer lets you type and edit text in fields. Click in 
the field where you want to type. Chapter 5 gives detailed infonnation about 
text fields and editing text. 

To learn about editing text in the Macintosh, see the Macintosh System 
Software User's Guide or your Macintosh owner's guide. 

For a detailed tutorial on browsing and editing, see Chapter 2, "Browsing and 
Editing." 

For information on typing text not limited to fields, see "Paint Text Tool," 
later in this chapter. 

Use the Button tool to make new buttons or to see buttons that already 
exist. 

To use the Button tool, make sure that Authoring or Scripting is checked on 
the User Preferences card in the Home stack. 

When you choose the Button tool, the buttons on the card and the card's 
background appear surrounded by a thin-lined box; a selected button is 
surrounded by a moving dotted line. 

Figure 7-34 Buttons with the Button tool selected 
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To create a button, choose New Button in the Objects menu. Alternatively, 
select the Button tool; then press the Command key and drag diagonally. 

To create a button that appears automatically on all cards that share a 
particular background, follow these steps: 

1. Choose Background from the Edit menu. 

2. Choose New Button in the Objects menu. 

Alternatively, select the Button tool, press the Command key, and drag 
diagonally. 

6 Important The most common mistake in creating a button is putting it on a card when 
it's supposed to be on a background. After you've created one or more 
buttons, flip to the next card; if the buttons you've just created are on that 
card too, you've created background buttons. 6 

To select a button: 

1. Select the Button tool. 

2. Click the button you want to select 

To size a selected button, drag by any comer. 

To move a selected button, drag by any edge; or place the pointer inside the 
button and drag. 

To duplicate a selected button, press Option while you drag. 

To copy a button, select it and choose Copy Button from the Edit menu (or 
press Command-C). 

To cut a button, select it and choose Cut Button from the Edit menu (or 
press Command-X). 

To eliminate the button without affecting the Clipboard, select it and choose 
Clear Button from the Edit menu (or press Backspace or the Clear key). 

•:• Browse tool versus Button tool: You must be using the Browse tool to click 
buttons. After you've created a button and you want to test it, be sure 
to select the Browse tool first. 
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To bring up information about a particular button: 

1. Select the Button tool 

2. Click the button you're interested in. 

3. Choose Button Info from the Objects menu. 

(Alternately, choose the button tool and double-dick the button you're 
interested in.) The Button Info dialog box appears. (See Figure 7-35.) 

Figure 7-35 The New Button dialog box 
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To see all the buttons on a card and the background when the Button tool is 
not selected, press the Command key and the Option key at the same time. 

To read about labeled buttons and buttons with different shapes (and to get 
detailed information about the dialog box in Figure 7-35), see "Button Info" in 
the Objects Menu section of this chapter. 



Field tool r=-::i 
E::.J 

Use the Field tool to create and change text fields. You can have fields on a 
specific card as well as fields common to all cards associated with a given 
background. 

To use the Field tool, make sure that Authoring or Scripting is checked on the 
User Preferences card in the Home stack. 

You can have as many fields on a card or a background as will fit. The number 
of lines in a field depends on that field's physical size, the point size of the 
text within the field, and the height of a single line within the field. See the 
Line Height box in the Text Style dialog box, shown in Figure 7-20 (earlier in 
this chapter). 

To create a field, choose New Field from the Objects menu. Alternatively, 
select the Field tool; then position the pointer and, while holding down the 
Command key, drag diagonally. 

To create a field for every card associated with a particular background: 

1. Choose Background from the Edit menu. 

2. Choose New Field from the Objects menu. 

Alternatively, select the Field tool, press the Command key, and drag 
diagonally. 

6. Important The most common mistake in creating a field is putting it on a card when it's 
supposed to be on a background. After you've created one or more fields, flip 
to the next card; if the fields you've just created are on that card too, you've 
created background fields. 6 
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To select a field: 

1. Click the field tool to select it. 

2. Click inside the field you want to select. 

To size a selected field, drag by any comer. 

To move a selected field, drag by any edge; or place the pointer inside the field 
and drag. 

To duplicate a selected field, press Option while you drag. 

To copy a field, select it and choose Copy Field from the Edit menu (or press 
Command-C). 

To cut a field and all its accompanying text, select the field and choose Cut 
Field from the Edit menu (or press Command-X). 

To eliminate the field without affecting the Clipboard, select it and choose 
Clear Field from the Edit menu (or press Backspace or the Clear key) . 

.A Warning Deleting a background field also deletes all text in that field on all cards 
sharing that background. Once you've deleted the field, it and all its text are 
gone for good-you can't undo the deletion. .& 
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To bring up information about a particular field, follow these steps: 

1. Click the field tool to select it. 

2. Click the field you're interested in. 

3. Choose Field Info from the Objects menu. 

Or just double-click the field you're interested in. The dialog box in Figure 
7-36 appears. 

Alternatively, move the insertion point to the field you want to know about 
and choose Field Info from the Objects menu. 



Selection tool 

Figure 7-36 The New Field dialog box 
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For details about the dialog box in Figure 7-36, see "Field Info," later in this 
chapter. 

For infonnation about fields and their uses, see "Fields" in Chapter 5. 

Use the Selection tool to select a rectangular area of a picture. Drag diagonally 
to select. 

To select the whole picture, double-click the Selection tool on the tom-off 
Tools palette. (You can also choose Select All from the Paint menu.) 

To shrink the selection area to the outer perimeters of the object you're 
selecting, press the Command key while you drag; when you release the 
mouse button, the rectangle closes in and eliminates extra white space. 

Figure 7-37 Eliminating extra white space in a selection 

Press the Command 
key as you drag .. . 

... to eliminate extra white 
space in the selection 
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For an even tighter selection, press Option as you drag (or Command-S after 
you drag) to convert the rectangle to a lasso and to close in on the selection's 
dark dots. 

•:• Select, but can't drag: If you've selected a picture but you can't drag it, 
you've tried to select a background picture without being in the 
background. Choose Background from the Edit menu and try again. 

To move a selection, position the pointer inside the selection until the pointer 
changes to an arrow; then drag. 

To move a selection straight up or down or directly left or right, press Shift 
while you drag. 

To make a copy of a selection, press Option while you drag. 

To make multiple copies, press Command-Option while you drag. (Press the 
Option key plus a number between 1 and 8 before you drag to control spacing 
between images.) 

To stretch or shrink a selection, press Command while you drag from a 
comer. 

Figure 7-38 A shrunk and stretched selection 

Original Shrunk Stretched 

To stretch or shrink straight up and down or straight left and right, drag 
from any edge. 



Lasso Use the Lasso to select a specific pan of a picture when the area's too small 
for the Select tool or when you need to scoot around nonrectangular images. 

Figure 7-39 Only the lassoed fish are selected 

To use the Lasso, drag around the area you want. (The line trailing out of the 
lasso's tip shows you what you're lassoing.) When you release the mouse 
button, the lasso hugs the part of the picture it surrounds and selects it. (The 
lasso shrinks until it finds black dots.) The edges of the lassoed area will 
shimmer. 

To lasso an area without shrinking around black dots, press Option as you 
drag. 

To lasso an area that has no breaks in it (one surrounded by an unbroken line, 
or one composed entirely of connected black dots), move the lasso's tip into 
it, press the Command key, and click the mouse. This technique is especially 
handy for selecting small areas. 

To lasso each element in the picture (ignoring any unenclosed white space), 
double-dick the Lasso in the torn-off Tools palette. 

~ To move a selection, position the lasso's tip within the selection until the 
lasso changes to an arrow; then drag. 

To move a selection straight up or down or directly left or right, press Shift 
while you drag. 

To make a copy of a selection, press Option while you drag. 

To make multiple copies, press Command-Option while you drag. (Press the 
Option key plus a number between 1 and 8 before you drag to control spacing 
between images.) 
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Figure 7-40 Multiple copies 

To stretch or shrink a selection, press Command while you drag from an edge. 

Figure 7-41 A stretched and enlarged selection 
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Pencil ,.q Use the Pencil to draw thin (one dot wide) free-form lines. Most people find 
i-" it the most useful tool for doing detailed work in FatBits. 

Pencil draws in the opposite color of the first place you press the Mouse 
bunon. (See Figure 7-42.) 

Figure 7-42 Drawing in the opposite color 

Starting on black 
draws in white. 

Starting on white 
draws in black. 

To draw straight horizontal or vertical lines, press the Shift key while 
you drag. 

To work with FatBits, double-click on the Pencil on the tom-off Tools 
palene (or press Command as you click with the Pencil selected). Click to 
make a single dot; click on an existing dot to erase it. 

For information on FatBits, see "FatBits" in the Options menu section of this 
chapter. 
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Use the Brush to paint with the current pattern. Bring up a dialog box of 
brush shapes and sizes by choosing Brush Shape from the Options menu (or 
just double-dick Brush); then click the one you want. Different shapes create 
different effects. 

Figure 7-43 Different brush shapes create different effects when you paint 

1 . . / " . . / ' 

D 

To paint straight vertical or horizontal lines, press Shift while you drag. 

To erase instead of paint with a brush shape, press Command while you drag. 
Change the brush shape to change the shape of the "brush-eraser." 



Eraser 

Line tool 

0 The Eraser wipes out the part of a picture you drag over. 

To erase the whole picture, double-click the Eraser. HyperCard wipes out the 
picture, and then selects the tool you were using just before you double­
clicked the Eraser. (Choose Undo from the Edit menu, or Revert from the 
Paint menu, if you double-click by accident.) 

•:• Magic appearances: If you see a picture appearing under the eraser as you 
drag the eraser over a card picture, you're exposing a covered background 
picture. To erase with white paint (which prevents the background 
picture from appearing), press the Command key as you drag. 

·····... Use the Line tool to draw straight lines. Drag to draw lines in black; press 
Option while you drag to draw lines in the selected pattern. (See "Patterns 
Menu," later in this chapter.) 

To change line thickness, choose Line Size from the Options menu (or double­
click the Lines tool on the torn-off Tools palette) and click one of the choices. 
Or press 1 through 8 with Power Keys checked on the Options menu for lines 
that many dots wide (5 gives the same line thickness as 4, 7 gives the same 
line thickness as 6). To keep the current line thickness, click the highlighted 
choice. 

Figure 7-44 Line and border width 
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To change the angle of a line, with the mouse button still pressed move the 
mouse in another direction as you're creating the line. 

To constrain angle changes to 15° increments, press Shift while you drag. 
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To draw a line centered on a given point, choose Draw Centered from the 
Options menu before you drag. 

To draw a line with a multiple image of itself, choose Draw Multiple from the 
Options menu before you drag. (Press the Option key plus a number between 
1 and 8 before you drag to control spacing between images.) 

For information about power keys, see "Options Menu," later in this chapter. 

Use the Spray tool to spritz paint onto the screen in the selected pattern. The 
more you spray back and forth over the same area, the more the pattern 
becomes apparent. 

To spray straight vertical or horizontal lines, press Shift while you drag. 

To erase with the Spray tool, press Command while you drag. 

The Rectangle tool draws rectangles. To draw black-bordered rectangles, 
position the crossbar pointer where you want the rectangle to start; then 
draw diagonally. 

To change the thickness for a rectangle's border before you draw it, choose 
Line Size from the Options menu (or double-dick the Lines tool) and click one 
of the choices (as shown in Figure 7-44). 

To place a rectangle while you're drawing it, first drag to create the rectangle, 
and then press Command before you release the mouse button. This allows 
you to drag the rectangle anywhere on the card. You can release the 
Command key to continue creating the rectangle, and press the Command 
key again to move the shape. Once you release the mouse button, you need 
to select the rectangle to move it. 

To draw rectangles filled with the selected pattern, choose Draw Filled from 
the Options menu. 

To draw with borders in the selected pattern, press Option as you start 
to drag. 



Rounded 
Rectangle tool 

L 

Figure 7-45 Reciangles with patterned borders 

A thick line lets you draw borders 
in the current panem. 

To draw centered on a given point, choose Draw Centered from the Options 
menu before you drag. 

To draw borderless rectangles, choose Draw Filled from the Options menu 
and hold down the Option key as you drag. 

To draw multiple rectangles, choose Draw Multiple from the Options menu 
before you drag. (Press the Option key plus a number between 1 and 8 before 
you drag to control spacing between images.) 

To draw squares, hold down the Shift key while you drag. 

The Rounded Rectangle tool draws rectangles with rounded comers. To draw 
black-bordered rounded rectangles, position the pointer where you want the 
rectangle to start; then draw diagonally. 

To place a rounded rectangle while you're drawing it, first drag to create the 
shape, and then press Command before you release the mouse button. This 
allows you to drag the shape anywhere on the card. You can release the 
Command key to continue creating the shape, and press the Command key 
again to move the shape. Once you release the mouse button, you have to 
select the rounded rectangle to move it again. 

To draw borders using the current pattern, hold down the Option key while 
you drag. 
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Figure 7-46 Creating and combining rounded rectangles 
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To change border thickness, choose Line Size from the Options menu (or 
double-click the Lines tool) and click one of the choices; or press 1 through 8 
with Power Keys checked on the Options menu for increasingly thicker lines. 

To draw rounded rectangles filled with the selected pattern, choose Draw 
Filled in the Options menu before you drag. (Double-click this tool to toggle 
Draw Filled on and off.) 

To draw centered on a given point, choose Draw Centered on the Options 
menu before you drag. 

To draw with a multiple image, choose Draw Multiple on the Options menu 
before you drag. (Press the Option key plus a number between 1 and 8 before 
you drag to concrol spacing between images.) 

To draw squares with rounded comers, press Shift while you drag. 

Use the Bucket to fill solid black and enclosed white areas (including the 
hollow parts of outlined and shadowed letters) with the selected pattern. 



Figure 7-47 Using the Bucket 
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If there are any gaps in the outline surrounding an area, paint will spill out and 
fi ll the surrounding area as well. (You can use FatBits to check for gaps.) 

Figure 7-48 Paint spilled in enclosed and unenclosed areas 

Before After 

You can't use the Bucket to fill a dark area (as opposed to a black area) with a 
lighter color. Instead, select the area and use Fill from the Paint menu. 

•:• Cleaning up accidental spills: If you accidentally fill your screen with 
paint, immediately choose Undo from the Edit menu; then check carefully 
for gaps in your drawing before using the Bucket again. 

•!> Bucket short cut: Double-dick the Bucket to make the Patterns palette 
appear and disappear. 
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Curve tool 
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The Oval tool draws oval shapes. To draw black-bordered ovals, position the 
pointer where you want the oval to start; then drag diagonally. 

To draw borders using the current panem, hold down the Option key while 
you drag. 

To draw circles, press Shift while you drag. 

To draw centered on a given point, choose Draw Centered on the Options 
menu before you drag. 

To draw filled with the current panern, choose Draw Filled on the Options 
menu before you drag. 

To draw with a multiple image, choose Draw Multiple on the Options menu 
before you drag. (Press the Option key plus a number between 1 and 8 before 
you drag to control spacing between images.) 

To place the oval while you're drawing it, first drag to create the oval, and 
then press Command before you release the mouse bunon. This allows you 
to drag the shape anywhere on the card. You can release the Command key to 
continue creating the shape, and press the Command key again to move the 
shape. Once you release the mouse bunon, you have to select the oval to 
move it again. 

To change border thickness, choose Linc Size from the Options menu (or 
double-click the Lines cool) and click one of the choices; or press 1 through 8 
(with Power Keys checked on the Options menu) for increasingly thicker lines 
(5 gives the same line thickness as 4, and 7 gives the same line thickness as 6). 

Use this tool co draw free-form shapes. Drag to draw whatever shape you 
wa nt. 

If you draw with Draw Filled checked from the Options menu, HyperCard 
draws a straight line connecting the starting and ending points of the shape 
when you release the mouse button; then it fills the shape with the selected 
panem. (Double-dicking the Cuive tool toggles Draw Filled on and off.) 



Paint Text tool A 

Figure 7-49 Drawing filled and unfilled shapes 

Original art Draw Filled unchecked Draw Filled checked 

To change border thickness, choose Line Size from the Options menu (or 
double-click the Lines tool) and click one of the choices; or press 1 through 8 
with Power Keys checked from the Options menu for increasingly thicker 
lines (5 gives the same line thickness as 4, and 7 gives the same line thickness 
as6). 

To draw borders using the current pattern, hold down the Option key while 
you drag. 

Use Paint Text to type text that's part of the picture. Paint text is especially 
useful as part of a background picture: use it for labels and titles that you 
want to show on many cards. 

Set text attributes by choosing Text Style from the Edit menu or by double­
clicking the Paint Text tool. The settings you make in the Text style dialog 
box (shown in Figure 7-50) stay in effect until you change them, or until you 
restart HyperCard. 

Press Return to move down to a new line. 
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Figure 7-50 The Text Style dialog box 

Check one or more styles or 
check nothing for plain text. 

Style 
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The alignment you set works 
on all lines in the field. 

Scroll to the font you want; 
then click to select it. 

~===:--tr-Click the size 
you want ... 

- ----- .. . or type it 
here. 

---.--1+-- This detennini 
:====--=====: the space 

between lines 
in points. 

What you see here is what you'll get. 

Text you type using this tool is different from text you enter into fields. You 
don't create a field in which Paint Text appears- you just position the cursor 
and click where you want the text to start, and then type. As soon as you 
confirm what you've typed (by clicking, choosing another tool, choosing 
Keep from the Paint menu, or moving to another card), the text becomes part 
of the picture-its attributes become fixed. To change an attribute or to edit 
text, you have to erase the old text and start again. 

•!• Quick text pickup lip: To select text you've just finished typing, press 
Command-S. 

6 Important You can't use the Find command to search for Paint Text. To HyperCard, 
Paint Text is just another picture. If you think that you'll want to search 
later for what you're typing now, create a field and enter text using the 
Browse tool. 6. 
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Regular Polygon 
tool 

() 

Each time you restart HyperCard, you reset the text attributes to 12-point 
plain Geneva with a line height of 16 dots, aligned left. This doesn't affect 
already-existing text. 

The Regular Polygon tool creates polygons with regular sides. Unlike the 
other shape-making tools, Regular Polygon always starts drawing the shape 
from the center outwards (whether Draw Centered is checked or not on the 
Options menu). 

Figure 7-51 The Regular Polygon tool always draws as though you have Draw 
Centered curned on 

The shape gets drawn from the center outward. 

To choose the shape of the polygon, choose Polygon Sides from the Options 
menu (or double-click the tool). When the dialog box appears, click the shape 
you want. To keep the same shape, click the highlighted choice. 

Figure 7-52 Double-dick !he Regular Polygon tool to select a shape 

D [Q]u - .._ 
I 

Click the shape 
you want to use. 
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To create a shape, drag the mouse diagonally. 

To rotate the shape, tum the mouse with the mouse button still pressed as 
you're creating the shape. 

To constrain movement to 15° increments, press Shift as you rotate. 

To place the polygon while you're drawing it, first drag to create the shape, 
and then press Command before you release the mouse button. This allows 
you to drag the polygon anywhere on the card. You can release the Command 
key to continue creating the shape, and press the Command key again to 
move the polygon. Once you release the mouse button, you need to select 
the polygon to move it again. 

To change border thickness, choose Line Size from the Options menu (or 
double-click the Lines cool) and click one of the choices; or press 1 through 8 
(with Power Keys checked on the Options menu) for increasingly thicker lines 
(5 gives the same line thickness as 4, and 7 gives the same line thickness as 6). 

To draw borders using the current pattern, hold down the Option key while 
you drag. 

To draw filled with the current pattern, choose Draw Filled from the Options 
menu before you drag. 

To draw with a multiple image, choose Draw Multiple from the Options 
menu before you drag. (Press the Option key plus a number between 1 and 8 
before you drag to control spacing between images.) 



Polygon tool Use this tool to create polygons with irregular sides. This tool works 
differently from the others in that you don't hold the mouse button down 
to draw, and you double-dick when you've finished the shape. 

To draw, position the mouse where you want to !)egin; then click and release. 
Move the mouse until you've finished the first side, then click; roll out the 
second side, then click again; continue until you've finished all the sides, or 
double-click to end. (Clicking on the beginning point also ends the shape.) 

Figure 7-53 Using the Polygon tool 
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•:• Watch your double clicks: After you've started drawing, clicking once on 
the starting point of the shape ends it. (Usually with this tool, you 
double-dick to end a shape.) But if you double-click on the starting point 
after you've begun drawing, you'll end the first shape and start a second 
one. 

If the Draw Filled command in the Options menu is checked, HyperCard 
draws a straight line between the polygon's starting and ending points when 
you double-click to finish your polygon, creating an enclosed shape. The 
shape is then filled with the current pattern. 
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Figure 7-54 Creating an enclosed polygon 

Draw Filled unchecked Draw Filled checked 

To draw borders using the current panem, hold down the Option key while 
you drag. 

To change border thickness, choose Line Size from the Options menu (or 
double-dick the Lines tool) and click one of the choices; or press 1 through 8 
with Power Keys checked on the Options menu for increasingly thicker 
borders (5 gives the same line thickness as 4, and 7 gives the same line 
thickness as 6). 

To draw shapes constrained to 15° angles, start the polygon with the Shift 
key pressed. 

Objects menu 

Use the Objects menu to create, examine, and change the actions of and 
information about HyperCard objects-bunons, fields, cards, backgrounds, 
and stacks. 

To use the Objects menu, you must have the Browse, Burton, or Field tool 
selected. 



Button Info 

Figure 7-55 The Objects menu 
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Button Info brings up information about the selected button. To use the 
Button Info command, follow these steps: 

1. Select the Button tool from the Tools menu. 

2. Select the button you want to work with. 

A button you've jusr created is automatically selected. 

3. Choose the Button Info command from the Objects menu (or 
double-click the button). 

The dialog box in Figure 7-56 appears. 
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Figure 7-56 The Button Info dialog box 
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Button name 

Type the name for this button into the Button Name box. If you leave the 
box blank, your button will be nameless. If you just created this button using 
the New Button command, the button is already named "New Button." 
Button name works with Show name, described next. 

Show name 

Check the "Show name" box to have the button's name appear on the 
button. (Figure 7-57 shows how a button name appears with different styles 
checked.) 

Several buttons can have the same name; use the button ID, described below, 
to distinguish between them. 

Button number and layers 

The button number line tells you whether the selected button is on the card 
or on the background, as well as what layer it's on. A button that you've just 
created has the highest number, and is on the frontmost layer on that card. 
The first button you create has the number 1, the second button the number 
2, and so on. 



When you change a button's layer, you change its number and the numbers 
of all buttons whose layers are also changed. (See "Bring Closer" and "Send 
Farther," later in this section.) When you delete a button, the numbers of any 
buttons closer to the front are all reduced by one. 

Background buttons and card buttons are numbered separately. So there can 
be both a background button and a card button with the same number. 

The highest number a background or card button can have is the total 
number of buttons on that background or card; the lowest number a 
background or card button can have is 1. 

Button ID 

Every button has a button ID unique in its stack. Unlike either the button 
name or button number, the ID number is permanent and unchangeable. 
When you delete a button, its ID number is permanently retired from the 
stack. Advanced HyperCard creators can use the ID number to create special 
button actions. 

Style 

Click one of these choices to set the style for the selected button. 

• "Transparent" makes the button transparent. Use this to make an 
invisible button (perhaps one that goes over a picture), or one that blends 
in with what's behind it. 

• "Opaque" colors the button white. It's like a white rectangle without a 
border. 

• "Rectangle" makes a white rectangle with a thin black border. 

• "Shadow" makes a white rectangle with a drop shadow along the right 
and bottom sides. 

• "Round rect" makes a standard Macintosh button, like the kind you see in 
any dialog box. 

• "Check box" makes a square button with an opaque interior. 

• "Radio button" makes a small round button with an opaque interior. 
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Figure 7-57 Button styles 
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Auto hllite 

"Auto hilite" momentarily highlights a button of any style (except check box 
and radio button) when you click it. A button in either check box or radio 
button style toggles on and off when "Auto hilite" is set. With "Auto hilite" 
unchecked, you receive no visual feedback when you click a button. 
Figure 7-58 shows how each of the different button styles is highlighted. 

Figure 7-58 Highlighting different styles 
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Icon 

Icon lets you use an icon as a bunon. Clicking this bunon brings up the 
dialog box in Figure 7-59. 

Figure 7-59 The Icon dialog box 
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To use an icon as a bunon: 

l. Choose the Button tool 

2. Create a new button or select one that already exists. 

Creating a new bunon automatically selects it. 

3. Choose Button Info from the Objects menu. 

Or double-click the button you want to work with. 

4. Click the Icon button in the dialog box. 

The dialog box in Figure 7-59 appears. If the bu non you've selected is 
already an icon, its picture is highlighted in the dialog box. 
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5. Click the picture of the icon you want to use as your button. 

(Scroll through the choices, if necessary.) The icon whose piccure you click 
replaces the selected bunon on your card or background. 

The advantage of using an icon is that picture and bunon are combined in 
one unit; this makes cucting, pasting, and moving bunons easier. 

When you use an icon, don't use either the check box or the radio bunon 
styles; otherwise, you won't see the icon. 

LinkTo 

Click this to create a link for the bucton you're creating. This option is 
especially important because it's the easiest way to establish connections 
between cards and stacks. Once you've made a link, pressing the bucton 
immediately moves you to the linked card or stack. 

LinkTo brings up a dialog box. 

Figure 7-60 The dialog box for making links 
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Follow these steps to set a link between the current card and any other card 
in any stack: 

1. Choose the Button tool 

2 Create a new button or select one that already exists. 

Creating a new button automatically selects it. 

3. Click LinkTo. 

Using a button that already exists cancels any previous link you might 
have set. 



Field Info 

4. Go to the card you want to link to. 

The dialog box stays on the screen while you're looking for the card. The 
card can be in the current stack or in any other stack. 

5. Click the choice that reflects which card you want to go to when 
you press the button. 

To link to the card you're on, click "This Card." 

To link to the first card in the current stack (no matter what card you're 
on), click "This Stack." 

After you click, HyperCard brings you back to the card with the selected 
button on it. 

If the dialog box gets in your way, grab it by its top bar and drag it where 
you want it to be. 

A Warning Changing the name of a stack will break links you've made berween any card 
in the renamed stack and any other card in any stack (including links within 
the renamed stack itself). When you change the name of a stack, be sure to 
redo all the links. A. 

Script 

This feature, available only if Scripting is checked on the User Preferences card 
in the Home stack, brings up the script editor. You use the script editor to 
review or to write scripts that control what happens when the selected 
button is clicked. (Writing scripts isn't covered in this guide. For information 
on scripting, see the HyperTalk Beginner's Guide: An Introduction to 
Scripting.) 

Field Info brings up information about the selected field. You can see and 
change the field's name, learn whether this is a background or a card field, find 
out the field's layer number (which tells you the layer of the field relative to 
other fields on this card or background), make the text in the field editable or 
locked, and determine the visual characteristics of both the text in the field 
and of the field itself. 
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The following seeps explain how to use Field Info: 

1. Select the Field tool from the Tools menu. 

2. Select the field you want to work with by clicking in it. 

3. Choose the Field Info command from the Objects menu. 

Or just double-dick the field. The dialog box in Figure 7-61 appears. 

Figure 7-61 The Field Info dialog box 
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4. Design the field. 

• Type or change the field's name. 

• Click Lock Text to prevent the text in the field from being changed. 
(Click it again to make the text editable.) 

• Click Show Lines so that you can see where the lines are in a field. 

• Click Wide Margins to include extra space in the left and right margins 
(useful for making text in fields easier to read). 

• Click the Font button to set or change the look of text in the field. 
(See "Text Style," earlier in this chapter.) 



• If you click Auto Tab for a nonscrolling field, pressing Return with the 
insertion point in the last line of chat field moves the insertion poinr 
ro the next field on the card. (This movement follows normal tabbing 
order, as described in "Tab Order and Layers" in Chaprer 5.) 

• Click one of the sryle burtons ro ser rhe look of the field itself. 

S. When you're finished, click OK. 

Figure 7-62 Field styles 
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For more details on the features described here, see Chaprer 5, "Text in 
HyperCard." 

Field number 

The Field number cells you what layer the field is on relative to other fields. A 
field that you've just created has the highest number, and is on the 
frontmost layer. The first field you create has the number 1, the second field 
the number 2, and so on. 
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When you change a field's layer, you change its number and the numbers of all 
fields whose layers are also changed. (See "Bring Closer" and "Send Farther," 
later in this section.) When you delete a field, the numbers of any fields closer 
to the front are all reduced by one. 

Background fields and card fields are numbered separately. So there can be 
both a background field and a card field with the same number. 

The highest number a background or card field can have is the total number 
of fields on that background or card; the lowest number a background or card 
field can have is 1. (For more details, see "Tab Order and Layers" in Chapter 5.) 

Field ID 

Every field has a field ID unique in its stack. Unlike a field's name or number, 
the ID number is permanent and unchangeable. When you delete a field, its 
ID number is permanently retired from the stack. Advanced HyperCard 
creators can use the ID number to create special field actions. 

Script 

This feature, available only if Scripting is checked on the User Preferences card 
in the Home stack, brings up the script editor. You use the script editor to 
review or to write scripts associated with the field. (Writing scripts isn't 
covered in this guide. For information on scripting, see the HyperTalk 
Beginner's Guide: An Introduction to Scripting.) 

The Card Info command brings up infom1ation about the current card. To 
use the Card Info command: 

1. Select any General tool from the Tools menu. 

2. Choose the Card Info command from the Objects menu. 

The dialog box in Figure 7-63 appears. 



Figure 7-63 The Card Info dialog box 
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3. Type or change the card's name, check a box, or click one of the 
buttons. 

Click Script to look at, create, or change the card's script. 

4. When you're .finished, click OK. 

Can't modify card 

When "Can't modify card" is checked, you can't make any changes to the 
card, including entering text into fields. To allow editing again, uncheck the 
box by clicking in it. 

Can't delete card 

When "Can't delete card" is checked, you can't remove the card from the 
stack. (You can, however, delete the stack, taking the protected card with it.) 
To allow the card to be removed, uncheck the box by clicking in it. 

Changing a card's position in a stack 

Card Number tells you the number of cards in the stack, and the current 
card's position in the stack. 
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To change a card's position in a stack, follow these steps: 

1. Move to the card whose position you want to change. 

2. Choose Cut Card from the Edit menu. 

3. Move to the card you want to come immediately before the one 
you've just cut. 

4. Choose Paste Card from the Edit menu. 

Or press Command-V. 

The pasted card appears on lhe screen. 

To move a card to the first position in a stack requires several more steps. 
You must first make the wanted card lhe second one in a stack; then you 
have to move the first card in lhe stack out of lhe way. 

To change a card's position so that it's first in a stack: 

1. Move to the card whose position you want to change. 

2. Choose Cut Card from the Edit menu. 

3. Choose First from the Go menu. 

Or press Command-I. The first card in lhe stack appears. 

4. Choose Paste Card from the Edit menu. 

Or press Command-V. The pasted card appears from lhe screen; it is now 
the second card in lhe stack. 

5. Choose First from the Go menu again. 

Or press Command-I. The first card in lhe stack appears. 

6. Choose Cut Card from the Edit menu. 

Or press Command-X. The card you had originally set out to reposition is 
now first in the stack. 



Bkgnd Info 

7. Choose Paste Card from the Edit menu. 

Or press Command-V. The original first card is now second. 

Bkgnd Info brings up information about the current background. You can 
see and change the background's name, find out the number of cards that 
share the background, and learn how many fields and bunons this 
background has. 

To use Bkgnd Info: 

1. Select any General tool from the Tools menu. 

2. Choose Bkgnd Info from the Objects menu. 

The dialog box in Figure 7-64 appears. 

Figure 7-64 The Bkgnd Info dialog box 
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3. Type or change the background's name, check a box, or click one 
of the buttons. 

4. When you're finished, click OK. 
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Can't modify background 

When "Can't modify background" is checked, you can't edit the background 
in any way. To allow editing of the background again, uncheck the box by 
clicking in it. 

Can't delete background 

When "Can't delete background" is checked, you can't delete the last card 
with this background in a stack. (You can, however, delete the stack­
including the protected background). To unprotect the background, uncheck 
the box by clicking in it. 

For information on backgrounds, see "Background," earlier in this chapter. 

The Stack Info command brings up information about the selected stack. 
You can see and change the stack's name, learn the number of cards in the 
stack and the amount of space the stack uses, and read the name of the 
folder and disk the stack resides on. 

Figure 7-65 The General tools are Browse, Button, and Field 
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To use Stack Info: 

1. Select any General tool from the Tools menu. 

The General tools are Browse, Button, and Field. 



2 Choose the Stack Info command from the Objects menu. 

The dialog box in Figure 7-06 appears. 

Figure 7-66 The Stack Info dialog box 
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3. Type or change the stack's name or click one of the buttons. 

4. When you're finished, click OK. 

Stack Name 

The name is the same as it appears in the Finder and in the directory dialog 
box. You change the stack's name by typing in the Stack Name box. Changing 
the name here also changes the name in the Finder. 

A Warning Changing the name of a stack will break links you've made becween any card 
in the renamed stack and any other card in any stack (including links within 
the renamed stack itself). When you change the name of a stack, be sure to 
redo all the links. .A. 
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Where 

The Where information tells you the full search path to where the stack 
resides, starting with the disk and ending with the folder that actually holds 
the stack. In Figure 7-66, the stack resides in the folder called Scot's stuff on 
the disk Harpo. A longer trail of names would indicate that the stack is 
further nested within folders. 

For more information on search paths, see "Search Paths" in Chapter 4. 

Free in Stack 

Free in Stack tells you the amount of extra memory space in the stack. (Extra 
space gets introduced into a stack each time you delete a card, background, 
field, or bunon.) Sometimes the Free number can be substantial, and the 
more extra space in a stack, the slower will actions be carried out, and the 
larger will be the stack. 

You can get rid of the extra space by using the Compact Stack command 
from the File menu. When you choose Stack Info again, Free in Stack will be 
zero K, and Size of Stack will likely be smaller than it was. 

The Bring Closer command (or Command-plus) brings the selected bunon or 
field one layer closer and increases its number to reflect its current layer, 
relative to other buttons or fields. 

You'd want to bring an object closer when a second object is covering it, not 
allowing you to use the selected object. 



Send Farther 

New Button 

Figure 7-67 Moving a button closer 
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Middle button 

Using Bring Closer, the fanhest button is now in the middle. 

The highest number an object can have in any case is the total number of 
objects of that type on a given card or background; the lowest number an 
object can have is 1. 

The Send Farther command (or Command-minus) puts the selected button or 
field one layer further back and decreases its number to reflect its current 
layer relative to other buttons or fields. You'd want to move an object 
farther back when it's covering a second object (You can't use a covered 
object effectively.) 

This command automatically selects the button tool and creates a new 
button named "New Button" in the rounded rectangle style. The button 
appears in the center of the screen, selected so that you can move it or size 
it easily. 
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Choosing New Button several times produces several new buttons laid on 
top of one another. When you choose New Button, the button tool is 
automatically selected, so you see all the buttons on the card (as shown in 
Figure 7-68). 

Figure 7-68 Making new buttons 
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To change the name of the button or to change the way it looks, choose 
Button Info (described earlier in this section). 

To create a new background button, ftrst choose Background from the Edit 
menu. 

This command automatically selects the field tool and creates a new 
transparent field. The field appears in the center of the screen, selected so 
that you can move it or size it easily. 

To name the field or to change the way it looks, choose Field Info (described 
earlier in this section). 

To create a new background field, first choose Background from the Edit 
menu. 

To read more about fields, see Chapter 5. 



New Background New Background creares a new card wirh a new background in the current 
stack. The new background has no fields or buttons and is enrirely blank. 

For details about backgrounds, see "Background" and "Bkgnd Info," earlier in 
this chapter. 

Paint menu 

The Paint menu commands work in conjuncrion wirh the Paint tools to 
manipulate and change pictures. You can choose these commands from the 
menu or, if you have Power Keys checked in rhe Options menu, you can use 
keyboard equivalents. 

The Paint menu appears only when you're using a Paint tool. 

For information on the Paint tools, see "Tools Menu," earlier in this chapter. 

Figure 7-69 The Paint menu 
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Throughout this section, you'll see references to power keys. Power keys let 
you choose menu commands from the keyboard. For information on power 
keys, see "Power Keys" under the Options menu section of this chapter. 

Select (or either power key S or Command-S) lassos the shape you most 
recently drew. 

This command is particularly useful if you've just drawn a shape very close to 
or actually touching another shape, and you need to move the new shape. (In 
fact, you can draw a new shape on top of an old one, choose Select, and then 
drag the new shape away.) 

Figure 7-70 Using Select 

1. Draw over existing card picture. 

3. Now you can move or alter that shape. 

2. Choose Select to sdt:~L 

the shape you just drew. 

4. When you let go of the object, it 
becomes "set" into the card picture. 

If you've selected a shape with the Selection rectangle, choosing Select lassos 
the shape. If nothing is selected, Select lassos everything (the same effect as 
double-clicking the Lasso tool). 

The object stays selected until you select another tool, click the mouse, or 
keep the shape. (see "Keep," later in this section.) 

Select All (or either power key A or Command-A) selects the entire picture. 
This has the same effect as double-clicking the Selection tool. 



Fill 

Invert 

To select the entire background picture, first choose Background from the 
Edit menu; then choose Select All. 

Fill (or power key F) colors the selected part of a picture with the current 
pattern. This command is especially useful for quickly changing the pattern 
of a large area. 

Figure 7-71 Using Fill 

1. Select the picture to fill. 2. Choose Fill. 

For related commands see "Bucket" under "Tools Menu" (earlier in this 
chapter) and "Draw Filled" under "Options Menu" (later in this chapter). 

Invert (or power key I) reverses the color of the dots in the selected part of a 
picture, such that white dots become black and black dots become white. 

Figure 7-72 Inverting a picture 

- -I 
.-···-

I 

.6. Warning When you invert a lassoed area that is not totally enclosed, HyperCard paints 
white the unenclosed part of the lassoed area; the whole image seems to 
disappear. To get the image back, choose Undo from the Edit menu. A 
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Pickup (or power key P) is like a cookie cucrer for images. Here's how you use 
Pickup: 

1. Select an image. 

2. Drag it over a second image. 

3. Choose Pickup. 

The first image picks up the pacrem of the second. 

4. Drag the first image away. 

Figure 7-73 How Pickup works 

1. This is the shape with the 
pattern you want to change. 

• 
. 

. . 
3. Select the shape and move it 

over the pallem. 

5. Drag the shape away. 

2. This is the pattt:m you want 
to use . 

4. Choose Pickup (or just press P 
if power keys are active). 



Darken 

Lighten 

See Chapter 6 for more examples using this command. 

Darken (or power key D) darkens the selected picture by randomly turning 
white dots black. Each time you choose Darken, a few more dots are 
changed. 

Figure 7-74 Using Darken 

' l 

Original Selected Darkened 

Keeping power key D pressed repeats the action until you release the key or 
until the selection is cotally black. 

Lighten (or power key L) lightens the selected picture by randomly turning 
black dots light. Each time you choose Lighten, a few more dots are changed. 

Figure 7-75 Using Lighcen 

Original Selected 

... 
I 't ' . ' ' 

' 

Lightened 
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Trace Edges 

Rotate Left 

Keeping power key L pres.sed repeats the action until you release the key or 
until the selection is totally white. 

Trace Edges (or power key E) outlines black areas in a picture or in the selected 
part of a picture. Repeated tracing adds more outlines. 

Figure 7-76 Untraced, single-traced, and multitraced areas 

• Original Edges Edges, twice Edges, three times 

Rotate Left (or power key [ ) turns the selected portion of a picture 90° left. 

Figure 7-77 Rotating an image to the left 
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..6. Warning If any part of the picture moves off the screen during a rotation, you'll lose 
that part permanently-Undo can't save it. Try Revert to get back the lost 
portion . .A. 

194 Chapter 7: Menu Commands 



otate Right 

.A. Warning 

:lip Vertical 

Rotate Right (or power key] ) turns the selected portion of a picture 90° right. 

Figure 7-78 Rocating an image to !he righc 
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If any part of the picture moves off the screen during a rotation, you'll lose 
that part permanently-Undo can't save it. Try Revert to get back the lost 
portion . .& 

Flip Vertical (or power key V) flips the selected portion of a picture vertically. 

Figure 7-79 Flipping an image vertically 
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Flip Horizontal 

Opaque 
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Flip Horizontal (or power key H) flips the selected portion of a picture 
horizontally about its center line. 

Figure 7-80 Flipping an image horizontally 

. , r-

• ..... 
Opaque (or power key O) makes the selected portion of a card picture opaque. 
(You can't see the portion of a background covered by an opaque 
foreground.) 

Figure 7-81 The Opaque command 

•, __ J 
. -

'" ... 1 
C..' 'J 

Selected image . . . . .. dragged and made opaque. 

To see what part of a picture is opaque, press Option-0; the opaque parts 
show as black. 



~rans parent 

Keep 

Revert 

Transparent (or power key D makes the selected part of a card picture 
transparent. (You can see the background if it's covered by a transparent 
foreground.) Cards are transparenc unless you make them opaque. 

Figure 7-82 The Transparent command 
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Selected image .. . ... dragged and made transparent. 

Keep (or Command-K) tells HyperCard that you want to keep the changes 
you've made to a picrure. (Until you tell it differently, HyperCard assumes 
that you might want to throw away changes.) Use Revert to go back to the 
most recently kept version of the picture. (See "Revert," later in this section.) 

Changing cards, switching to or from Background, or clicking a General tool 
has the same effect as choosing Keep. 

Revert (or power key R) restores the most recently kept version of the 
picrure (or the selected part of it), throwing away any changes since the last 
Keep command or since you started painting on this picture. (HyperCard 
acceprs a picrure when you choose Keep, switch to or from Background, 
change cards, or click a General tool.) It's like Undo on a larger scale. 
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Options menu 

Commands on the Options menu modify the action of Paint tools. 

Figure 7-83 The Options menu 
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The Options menu appears only when you're using a Paint tool. For 
infonnation on the Paint tools, see "Tools Menu," earlier in this chapter. 

Many of thes~ commands work when you press the appropriate power key. 
For information on power keys, see "Power Keys," later in this section. 

Grid (or power key G) constrains where picture elements line up when you 
use many of the Paint tools. When Grid is on, you can move a selection, draw, 
or type only at specific intervals. These intervals are eight dots apart (just 
under 1/8th of an inch). 

A check appears next to Grid in the Options menu when this feature is on. 



FatBits FatBits (or Option-F) lets you zoom in on a section of a picture to do close-in 
finish work and to edit your picture one dot at a time. Select an area and 
choose FatBits to blow up that area; then edit using any Paint tool. The tools 
work to scale. 

A movable window in the lower-left comer shows you what effect your 
editing changes have when the picture's full-sized again. (To move the little 
window, drag it by its title bar.) 

Figure 7-84 Fat Bits 

A check appears next to FatBits in the Paint menu when FatBits is on. 
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Moving the picture around 

Pressing and holding the Option key in FatBits changes the tool you're using 
to a hand. As you drag the hand, you move the picture around so you can get 
to a part that might be outside your viewing area. When you release the 
Option key, the pointer changes back to the tool you were using. 

If you choose FatBits without first selecting an area, HyperCard zooms in on 
the part of the picture you last worked on. Hold down the Option key and 
use the grabbing hand to move to the part of the picture you want to work 
with. 

To leave FatBits, choose the FatBits command again. 

Entering and leaving FatBits quickly 

You can use any of these short cuts to enter or leave FatBits: 

• Press Option-F. 

• Double-dick the Pencil tool. 

• Click in the small window. 

• With the Pencil tool selected, press the Command key while you click the 
mouse. 

Power Keys lets you use the keyboard to evoke commands you'd ordinarily 
choose from a menu. When you choose Power Keys, pressing a single key 
(with or without the shift key pressed) does the work of choosing a menu 
command with the mouse. 

A power key modifies the way a particular tool acts. Table 7-4 shows a list of 
the commands that power keys invoke. 



Table 7-4 Power keys 

Command Key Menu 

Darken D Paint 
Draw Centered (on/off) c Options 
Draw Multiple (on/oft) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (on/oft) G Options 
Invert I Paint 
Lighten L Paint 
Line size 1-4,6,8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate Left [ Paint 
Rotate Right I Paint 
Select s Paint 
Select All A Paint 
Select black panem B Patterns 
Select white pattern w Patterns 
Trace Edges E Paint 
Transparent T Paint 

If you need more details, see the description of the specific command 
elsewhere in this chapter. 

A check appears next to power keys in the Options menu when this feature is 
on. To turn off power keys, choose Power Keys from the Options menu 
again. (The check will disappear.) 

You can use several power keys in combination to create spectacular special 
effects. (Try C and M with the Oval tool, for example.) 

When you're using the Paint Text tool, power keys are temporarily disabled. 
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Line Size ... 

Brush Shape ... 
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You use Line Size to set the thickness of lines and borders. Choosing this 
command brings up a dialog box: 

Figure 7-85 Line sizes 

Click to confirm current 
size or click another size. 

2 3 " 6 a --- Power keys 

To select a thickness, click on it (or use a power key equivalent). You can also 
bring up lhe Line Size dialog box by double-clicking the Line tool. 

Use Brush Shape to select a shape for lhe Brush. Each shape has a different 
effect when you use it. To select a shape, move the pointer to the shape you 
want; then click. 

Figure 7-86 The Brush Shapes dialog box 

. . / ' 

. D -

Double-clicking the Brush also brings up the Brush Shapes dialog box. For 
derails on the Brush tool, see "Tools Menu," earlier in this chapter. 



Edit Pattern ... Edit Pattern lets you edit the pattern currently selected on the Pattern menu 
by clicking dots on or off. When you choose Edit Pattern, the pattern editor 
appears. See Figure 7-87. 

Figure 7-87 The pattern editor 

D 
OK '. Cancel ) 

To edit a pattern, move the pointer to the dot you want to change; then 
click. Clicking where there is no dot adds one; clicking an existing dot takes 
the dot away. 

Double-clicking a pattern on the Pauern palette also brings up the pattern 
editor. 

Using a nonstandard pattern 

You can replace a pattern on the Pattern palette with any pattern on the 
screen. (See Figure 7-88.) 

To use a pattern that's already on the screen, follow these steps: 

1. Make sure the new pattern is on the screen. 

2. Click the pattern on the Pattern palette to be replaced. 

3. Choose Edit Pattern from the Options menu. 

(Or double-click the pattern to be replaced if you're using the Pattern 
paleue.) The pattern editor appears showing the selected pattern. 
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4. Click anywhere on the new pattern in the picture. 

The old panern in the panern editor is replaced by the new one. 

5. Click OK. 

The new pattern replaces the selected panern in the Pattern menu. 

Figure 7-88 Switching patterns 

OK ( Cancel 

• 

1. Select a pattern to be replaced. 

2. Bring up the pattern editor. 

3. Click anywhere on the new pattern in the 
picture to place the pattern in the editor. 

4. The new pattern is saved with 
the stack when you click OK. 

The new pattern is saved with the stack. 



Polygon Sides ... 

Draw Filled 

You use Polygon Sides to select a shape for the Regular Polygon tool. 

Figure 7-89 Selecting a shape 

Click the shape you want to use. 

You can also bring up this dialog box by double-clicking the Regular Polygon 
tool. 

For details on the Regular Polygon tool, see "Tools Menu," earlier in this 
chapter. 

Draw Filled fills shapes as you draw them. It uses the current pattern to fill 
the shapes. 

Figure 7-90 Using Draw Filled 

0 Draw Fillo! off 

The Tools menu looks different when Draw Filled is turned on. The tools 
that it affects (Rectangle, Rounded Rectangle, Oval, Curve, Polygon, and 
Regular Polygon) have slightly different representations. (See Figure 7-91.) 
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Figure 7-91 The Tools menu with Draw Filled turned on and turned off 
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•!• Draw Filled short cut: Double-clicking any of the tools that Draw Filled 
affects (except Regular Polygon) turns Draw Filled on and off. 

When Draw Filled is turned on, a check mark appears next to it in the menu. 
To tum off Draw Filled, choose the command again. 

Draw Filled with the Polygon tool 

If Draw Filled is turned on while you're using the Polygon tool, HyperCard 
draws a straight line between the polygon's starting and ending points when 
you double-dick to finish your polygon. The resulting enclosed shape is filled 
with the current pattern. 

Figure 7-92 Creating an enclosed, filled polygon 

Draw Filled 
turned off 

Draw Filled 
turned on 



Draw Centered 

Draw Filled with the Curve tool 

If Draw Filled is turned on while you're using the Curve tool, HyperCard 
draws a straight line connecting the starting and ending points of the shape 
when you release the mouse button; then it fills the shape with the selected 
pattern. 

Figure 7-93 Creating a filled, curved shape 

Curve tool with Draw Filled off Curve tool with Draw Filled on 

Draw Centered (or power key C) lets you draw out from a center point. (You 
usually draw lines, rectangles, and ovals starting from an edge or comer.) 

Figure 7-94 Drawings made with Draw Centered turned on 
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Draw Multiple 
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Draw Centered affects the following tools: Line, Rectangle, Rounded 
Rectangle, Oval, Curve, Polygon, and Regular Polygon. 

When Draw Centered is turned on, a check mark appears next to it in the 
menu. To tum off Draw Centered, choose the command again. 

Draw Multiple (or power key M) draws multiple images as you drag with the 
mouse. 

Figure 7-95 Drawing shapes with and without Draw Multiple turned on 

Draw Multiple 
turned on 

Draw Multiple 
turned off 
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Draw Multiple affects the following tools: Line, Rectangle, Rounded 
Rectangle, Oval, and Regular Polygon. 

When Draw Multiple is working, a check mark appears next to it in the menu. 
To tum off Draw Multiple, choose it again. 

Patterns menu 

The Patterns menu is a palette from which you pick the pattern you want to 
use for painting. Select the paint pattern you want to use to ftll shapes and (if 
you specify) to draw borders. The menu can be "tom off" and the palette 
placed anywhere on the screen. 



Editing patterns 

Figure 7-96 Torn-off Patterns menu 

To create a movable Patterns palette, drag down through the menu, either 
past the bottom or beyond either side. 

Put the palette wherever you want by dragging. To move the palette around, 
drag it by its top bar or by any edge. To put it away, click its close box. If it 
gets stuck in an awkward place, just tear off the Patterns menu again; the old 
palette disappears. 

To edit a pattern, select the pattern you want to edit and choose Edit Pattern 
from the Options menu (or double-click the pattern you want to edit); when 
the pattern editor appears, click a dot to make the dot go away or dick where 
there is no dot to make one appear. The new pattern is saved with the stack. 

Figure 7-97 The pattern editor 
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To fill enclosed shapes with the selected panern as you draw chem, check the 
Draw Filled command on the Options menu. 

To fill enclosed shapes after you draw them, use the Bucket (described earlier 
in chis chapter). 

To fill a selected area with the current panern, choose Fill under the Paint 
menu. 

To draw borders in the selected pattern, press the Option key as you drag. 

•:• Patterns menu shortcut: Press Tab with any Paint tool selected or double­
click the Bucket cool co make the Panerns palette appear and disappear. 



c H A p T E R 8 

Keyboard Conunands 

T 

OU ISSUE MANY HYPERCARD COMMANDS BY MAKlNG CHOICES FROM MENUS. 

But HyperCard extends what you can do by making many commands 

available from the keyboard. In fact, there's a whole range of commands 

that you can issue only by pressing one or more keys and using the mouse at 

the same time. This chapter lists these commands. 
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I~ Command 

Command key 

Character key 

This chapter contains the following sections: 

• "Command Key Menu Commands" gives a list of the commands you 
execute by first pressing and holding down the Command key and then a 
specific character. 

• "Browsing" shows you how to get around the stacks and from card to 
card quickly. 

• "Text Editing" lists the keys to press to change fonts, type sizes, styles, 
and soon. 

• "Paint Power Keys" lists the graphics commands you can issue with a 
single keystroke. 

• "Dragging With Modifier Keys" explains what happens if you drag both 
with a particular tool selected and with the Command, Option, or Shift 
key held down. 

• "Miscellaneous Keyboard Shortcuts" lists the shortcuts that don't fit 
easily into other areas. 

Because all these sections are really summaries, you'll also find information 
about where to look for more help. 

Command key menu commands 

As you look at a menu, you'll see some commands followed by a symbol and 
a character. The propeller-shaped symbol represents the Command key. You 
can issue such a menu command by pressing the Command key at the same 
time that you press the specified character key. 

•:• Command or Apple: The Command key is marked by a propeller-shaped 
symbol. On some Macintosh keyboards, the key also has an Apple symbol, 
and some Macintosh manuals might call it the Apple key. Both names 
refer to the same key. 
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Table 8-1 shows the keyboard equivalent keys by menu; Table 8-2 shows 
them in alphabetic order by command name. 

Table 8-1 Keyboard equivalents by menu 

C.Ommand Keyboard equivalent Menu 

Edit Command-B Background (toggle) 
Command-C Copy 
Command-N New Card 
Command-T Text Style 
Command-V Paste 
Command-X Cut 
Command-Z Undo 

File Command-0 Open Stack 
Command-P Print Card 
Command-Q Quit HyperCard 

Go Command-F Find 
Command-H Home 
Command-M Message (toggle) 
Command-R Recent 
Command-1 First 
Command-2 Prev 
Command-3 Next 
Command-4 last 
Command-? Help 
Command-Tilde H Back 

Objects Command-plus ( +) Bring Closer 
Command-minus (-) Send Farther 

Paint Command-A Select All 
Command-K Keep 
Command-S Select 
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Table 8-2 Keyboard equivalents by command 

C.Ommand Keyboard equivalent Menu 

Back Command-Tilde (-) Go 
Background Command-B Edit 
Bring Closer Command-plus ( +) Objects 
Copy Command-C Edit 
Cut Command-X Edit 
Find Command-F Go 
First Command-1 Go 
Help Command-? Go 
Home Command-H Go 
Keep Command-K Paint 
Last Command-4 Go 
Message Command-M Go 
New Card Command-N Edit 
Next Command-3 Go 
Open Stack Command-0 File 
Paste Command-V Edit 
Prev Command-2 Go 
Print Card Command-P File 
Quit HyperCard Command-Q File 
Recent Command-R Go 
Select Command-S Paint 
Select All Command-A Paint 
Send Farther Command-minus (-) Objects 
Te>.1 Style Command-T Edit 
Undo Command-Z Edit 

For details on all these commands, see Chapter 7. 

Browsing 

You can use any of the browsing keystrokes shown in Table 8-3, except Tilde 
(-)and Esc, at any time. To use Tilde or Esc for browsing, you must be using 
one of the General tools. When a Paint tool is selected, pressing the Tilde key 
undoes the last Paint action; use Command-Tilde to move to the most 
recently viewed card. 
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For combinations that require you to use the Command key, be sure to press 
and hold down the Command key before you press the second key. 

Table 8-3 Browsing from the keyboard 

Destination 

Help 

Home 

First card in stack 

Previous card in stack 

Next card in stack 

last card in stack 

Retrace through cards viewed 

Forward through retraced cards 

Record of cards recently seen 

Select Browse tool 

Store current card's location for 
quick return (many locations 
can be stored) 

Return to scored location 
(last in-first out order) 

Next field on card 

Previous field on card 

Keyboard shortcut 

Command-? 

Command-H 

Command-1 or 
Command-Left Arrow 

Command-2 or Left Arrow 

Command-3 or Right Arrow 

Command-4 or 
Command-Right Arrow 

Tilde ( - ) , Esc, or Down Arrow 

Up Arrow 

Command-R 

Command-Tab 

Command-Down Arrow 

Command-Up Arrow 

Tab 

Shift-Tab 

For a tutorial on browsing, see Chapter 2. For infonnation on creating 
bunons for browsing, see "Button Tool" and "New Button" in Chapter 7. 
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Text editing 

You can use the combination keystrokes in Table 8-4 when you're using either 
the Browse tool or the Paint Text tool. Be sure to press and hold down the 
Command key before you press the character key. 

Table 8-4 Text editing keys 

Function 

Font, next in system 
Font, previous in system 
Text style dialog box 
Space, less between lines 
Space, more between lines 
Text sire, larger 
Text sire, smaller 

Key combination 

Command-Shift-> 
Command-Shift-< 
Command-T 
Command-Option-Shift-< 
Command-Option-Shift-> 
Command-> 
Command-< 

For details on creating the fields in which regular (as opposed to Paint) text 
appears, see Chapter 5. See Chapter 7 for information on both regular and 
Paint text. 
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Paint power keys 

Table 8-5 shows the Paint power keys. You must be using a Paint tool with 
Power Keys checked in the Options menu. "Toggle" after a command means 
that pressing the same key turns the option off. 

Table 8-5 Power keys available when using Paint tools 

Command Key Menu 

Black pattern B Patterns 
Darken D Paint 
Draw Centered (toggle) c Options 
Draw Multiple (toggle) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (toggle) G Options 
Invert I Paint 
Lighten L Paint 
Line size 1-4,6,8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Rotate 90° Left [ Paint 
Rotate 90° Right J Paint 
Select s Paint 
Select All A Paint 
Trace Edges E Paint 
Transparent T Paint 
White pattern w Patterns 
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Table 8-6 Effects of modified dragging 

Dragging with modifier keys 

Table 8-6 shows you what happens when you drag with different tools 
selected and hold down different modifier keys. Tools that aren't listed aren't 
affected by modifiers. 

For detailed information on all the tools, see Chapter 7. 

Tool With Command key With Shift key With Option key 

Button Create button Move button horizontal or vertical Copy button 
Field Create field Move field horizontal or vertical Copy field 
Selection Select tightly Move selection horizontal 

or vertical Copy selection 
Lasso Lasso everything Move selection horizontal 

or vertical Copy selection 
Line No effect Draw at 15° angles Draw with pattern 
Eraser Erase white Erase straight horizontal or vertical No effect 
Pencil Get/leave FatBits Draw straight horizontal or vertical No effect 
Rectangle No effect Draw square Patterned border 
Curve No effect No effect Patterned border 
Brush Erase what you Paint straight horizontal or vertical No effect 

paint over 
Spray Erase what you Spray straight horizontal or vertical No effect 

spray over 
Rounded Rectangle No effect Draw square with round comers Patterned border 
Polygon No effect Craw at 15° angles Draw with pattern 
Oval No effect Draw circle Patterned border 
Regular polygon No effect Rotate in 15° increments Patterned border 

4 
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Miscellaneous keyboard shortcuts 

The following table lists keyboard shortcuts that don't fit easily into other 
categories. 

Table 8-7 Miscellaneous keyboard shortcuts 

Key or combination Effect 

Command-Option• Show all buttons (Browse or Button tool 
selected) 

Command-Shift-Option• Show all fields (Field tool selected) 

Command-Backspace Delete current card 

Command-Period Cancel current action (like Printing) 

Command-Space bar Hide and show menu bar 

Command-Tab Select Browse tool 

Command-Tab-Tab Select Button tool 

Command-Tab-Tab-Tab Select Field tool 

Command-Tilde (- ) Go to most recent card displayed 
(Paint tool selected) 

Command-Shift-V Paste miniature card image (with card in 
Clipboard) 

Paste a field along with its text 

Command-Down Arrow Store current card's location for quick 
return (you can have many locations 
stored) 

Command- Up Arrow Return co stored location 
(last in-first out order) 

Option-D Show card picture (with Paint tool) 

Option-0 Show opaque areas (with Paint tool) 

Option-Tab Toggle Tools palette 

•Darker outlines indicate background fields or buttons. 

.. 
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Table 8-7 Miscellaneous keyboard shortcuts (conlinued) 

Key or combination 

Tilde (-) 

Down Arrow 

Up Arrow 

Tab 

Command-Option-C 

Command-Option-B 

Command-Option-S 

Effect 

Same as Back command (General 1001 

selected) 
Undo most recent action (Pain! tool 

selected) 

Same as Back command (any tool 
selected) 

Come forward through reviewed cards 

Toggle Panems palette (Paint tool 
selected) 

Advance insertion point to next 
background field (Browse tool 
selected) 

Edit script of current card 

Edit script of current background 

Edit script of current stack 

Holding down the Command key before and as you drag through the File 
menu shows the full File menu, even if Browsing or Typing is clicked on 
the User Preferences card in the Home stack and/or in a stack's Protect Stack 
dialog. 
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Common HyperCard Messages 

Yu CAN Sl!ND A ONE-LINE COMMAND (CALLED A MESSAGE) ro HYPER CARD 

through the Message box. Use messages co save time traveling through 

stacks, to launch applications, and to retrieve important information quickly. 
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HyperTaJk: The source of 
all messages 

To send a message: 

1. Choose Message from the Go menu. 

Or press Command-M. 

2. Type the message into the Message box. 

Use the syntax shown in the message descriptions section that follows. 

3. Press Return. 

You can also press Enter. 

Message descriptions 

This section describes the most common HyperCard messages that you 
might type into the Message box. The syntax is in its simplest form. 

Here's an example for the Go message, followed by a list of ways you could 
type the same message to get to the same place (the first card of the A.rt 
Ideas stack): 

Go "Art Ideas " 
Go to "Art Ideas" 
Go stack "Art Ideas " 
Go to stack "Art Ideas " 
Go to card 1 of stack "Art Ideas" 

The material in this appendix represents a small subset of HyperTalk, 
HyperCard's scripting language. 

Using HyperTalk, you write scripts for buttons, fields, cards, backgrounds, 
and stacks; these scripts give you much greater control over HyperCard than 
is available using only the menu commands. HyperTalk is an easy language to 
learn, and is especially good as a first language for novice programmers. 

For a tutorial on HyperTalk, see the HyperTalk Beginner's Guide: An 
Introduction to Scripting. Several other excellent books have been written 
about HyperTalk; consult your favorite bookseller to see what's currently 
available. 

222 Appendix A: Common HyperCard Messages 



How to read messages 

Date 

Here are some hinrs to help you read the messages in this appendix and to use 
these messages: 

• A message is all on one line. 

• The first word of a message is its name. When a message is more than 
one word, you'll find a note saying so. 

• Words in italics stand for other words. For example, menultem means the 
name of any item in any menu. 

• Some parts are optional helper words; they appear in square brackets (but 
don't type the brackets into the Message box). 

• The remaining part of a message is usually a description of something 
("with document," for example). 

• All words can be in capital or small leners. 

The Date 

The Long Date 

This message puts the current date into the Message box in the form 
mm/dd/yy: 

Type 

You get 

The Date 

Alternatively, Long Date produces a full date: 

Type 

You get 

The Long Date 

Friday, March 27, 1989 (or whatever the date is, in this 
form) 

You must start this message with the word "The." 
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Do Menu 

Go 

Hide 

DoMenu menu/tern 

This message does menu/tern as if you had chosen the command from a 
HyperCard menu: 

Type DoMenu Home 

You get the first card in the Home stack 

(Home is on the Go menu.) You must type menuitem exactly as it appears in 
the menu. For example, to open a stack, type 

DoMenu Open Stack .. . 

The three dots are part of the menu item name. 

Go [to] description of a card or stack 

This message brings you to the designated card in the designated stack. If 
you designate a stack without designating a card, you go to the first card in 
that stack: 

Type Go "Art Ideas" 

You get the first card in the Art Ideas stack 

If the stack you specify isn't in the Help Stacks folder or the HyperCard 
Stacks folder, be sure to list the search path on the appropriate card in the 
Home stack. (See "Search Paths" in Chapter 4.) 

Hide tool window 
Hide pattern window 
Hide message 
Hide menubar 

This message hides what you tell it to. It's as though you'd clicked a close 
box. Hide menubar hides the menu bar, giving you more display space (as 
though you'd pressed Command-Space bar). 

Type Hide tool window 

You get Tools menu goes away 

Also see Show, later in this appendix. 
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Open 

Pop Card 

Open application 

Open document with application 

This command opens the application you've named. If you name a 
document, HyperCard opens that document with the application you name. 

Type Open Memo with MacWrite 

You get the document Memo opened in MacWrite 

If the document or application you specify isn't at the top level of the file 
hierarchy, be sure that the search path is listed on the appropriate card in the 
Home stack. (See "Search Paths" in Chapter 4.) 

When you quit the application, you end up back at the card you were on 
when you sent the message. 

Pop Card 

This command retrieves a card you've marked with the Push Card 
command (described later in this appendix). Once a card is retrieved, you can't 
get it back again using P op Card unless you mark it again using Push 
Card. 

Pushed cards are popped in last-in, first-out order. 

Figure A-1 Popping order 
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Push Card 

Show 

Pressing Command-Up Arrow does the same thing as sending a Pop 
Card command. 

•:• Unfamiliar card popped: Occasionally when you issue a Pop Card 
command, a card might appear that you didn't push. HyperTalk scripts 
can issue their own Push Card commands as you browse through 
stacks; your Pop Card commands make these pushed cards appear. 
Eventually, any card that you pushed will also appear; just keep popping. 

Also see the previous command, Push Card. 

Push Card 

This command lets you mark the card you're working on for quick retrieval 
later. Use this command to mark a card, wander through the stacks (perhaps 
to find a graphic you want to paste onto the marked card), and then retrieve 
the card again using the Pop Card command. 

You can push any number of cards for later retrieval. 

Pushing Command-Down Arrow does the same thing as sending a Push 
Card command. 

Also see the previous command, Pop Card. 

Show tool window 
Show pattern window 
Show message 
Show rnenubar 

This message shows what you tell it to. It's as though you'd torn off a 
palene, or chosen Message from the Go menu. Show menubar makes 
the menu bar visible at the top of the window. 

Type 

You get 

Show pattern window 

The patterns palette on the screen 

If you try to show something that isn't hidden, nothing happens. 

Also see Hide, earlier in this appendix. 
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;bow Cards 

fime 

Show cards 
Show all cards 
Show numberof cards 

This message shows the cards in the current stack in rapid succession. 

Show cards shows all cards in the current stack repeatedly until you 
click the mouse. Show all cards goes rapidly through the stack 
once, starting and ending with the current card. Show number of cards 
shows as many cards as you specify, starting with the card following the 
current card. 

Type Show 4 cards 

You get next four cards in stack briefly on screen 

To stop Show Cards at any point, click the mouse. The card you're 
viewing when you click the mouse remains on the screen. 

The Time 
The Long Time 

This message puts the current time into the Message box in the form hh:mm 
AM or PM 

The Time Type 

You get 2:57 PM (or whatever time it is, in this form) 

Alternatively, Long time includes seconds: 

Type The Long Time 

You get 2:57:23 PM 

You have to start this message with the word "The." 
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A p p E N D x B 

HyperCard Disks 

t IB APPENDIX IS A DIRECTORY TO THE STACKS AND OTHER Fil.ES THAT COME 

with HyperCard. It tells you what files come with HyperCard, what disk 

each document is on, and what each document is for. 
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HyperCard and Stacks 

The HyperCard and Stacks disk contains HyperCard, the HyperCard Stacks 
folder, plus a folder called More Stacks. The HyperCard Stacks folder holds the 
following stacks: 

Address 
Date book 
File Index 
Home 
HyperCalc 
Phone 
Quotations 
Version 1.2.2 Release Notes 

The More Stacks folder contains the following stacks: 

Area Codes 
Clip Art 
Documents 
Plots 
Slide Show 

HyperCard Help 

The HyperCard Help disk contains a single folder, Help Stacks. The folder 
contains three stacks: 

Help 
Help Index 
Help Samples 



HyperCard Ideas 

The HyperCard Ideas disk holds a single folder, Idea Stacks. The folder 
contains four stacks: 

Art Ideas 
Button Ideas 
Card Ideas 
Stack Ideas 

About the provided HyperCard stacks 

Here's a description of the stacks that come with HyperCard, and what you'd 
use them for: 

Address 

Area Codes 

Art Ideas 

Book Shelf 

Button Ideas 

Card Ideas 

Clip Art 

Dacebook 

A name and address file. Keep all your important 
names and addresses here. 

A listing of all the telephone area codes in Canada and 
the United Scates. You can look for an area code if 
you know the city (or nearby city), or you can find 
the city served by any area code. 

A collection of arc you can use in your own 
documents. Use these to help create pictures and 
buccons. 

An example of a graphic cable of contents. 

Library of working buttons. Cuc and paste these co 
your own documents. 

Individual cards you might include in documents 
that you create. (A card is HyperCard's fundamental 
unit of information.) 

Artwork you can use to dress up your own 
HyperCard documents. 

Monthly calendar, week-at-a-peek memo book, plus 
a things-co-do list. Use ic to organize your daily 
chores and to keep track of important meetings. 
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Documents 

File Index 

Help 

Help Samples 

Help Index 

Home 

HyperCalc 

Phone 

Plots 

Quotations 

Version 1.2.2 
Release Notes 

Slide Show 

Stack Ideas 

A collection of document examples. 

A set of file cards for whatever you need to file. 

On-line directions for using HyperCard. It provides 
hints and tips for using all of HyperCard's features. 

Part of the on-line Help system. 

Part of the on-line Help system. 

A graphic directory of all the documents that come 
with HyperCard. Use it as your "base of operations." 
You must have Home for HyperCard to operate. 

A mini-spreadsheet. 

A dialer for your telephone. 

A demonstration of HyperCard's ability to plot 
information in different formats. 

A collection of famous quotations, designed to help 
you learn to use HyperCard. 

Information about this version of HyperCard. 

A collection of clip art, digitally scanned into the 
Macintosh. 

A collection of cards to use as templates for creating 
new stacks. 

6 Important For HyperCard to operate, you must have the Home stack on the same disk 
as HyperCard and in the same folder (or at the same level). You can remove all 
other stacks, but you must not remove the Home stack. 6 
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A P P E N D x c 

Using HyperCard Without a Hard Disk 

Tms APPENDIX DESCruBES THE SPECIAL REQUIREMENTS AND CONSIDERATIONS 

for using HyperCard without a hard disk and explains how to make a 3.5-inch 

startup disk for HyperCard. 
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HyperCard and the stacks that come with it require a lot of disk space. When 
you use HyperCard without a hard disk, there's a limit to the number (and 
size) of stacks you can use. 

The next section, "Creating a 3.5-Inch Startup Disk," explains how to create a 
special startup disk for use with HyperCard. This disk has the required 
system files and some of the more useful stacks chat come with HyperCard. 

You can use the HyperCard startup disk while you're going through the 
tutorials in this manual and continue using it as you become more experienced 
with HyperCard. Most of the time, you'll use HyperCard with this startup 
disk in one disk drive and the HyperCard and Stacks disk (which contains 
HyperCard) in the ocher. Therefore, you'll usually have access to all the stacks 
that come on the HyperCard and Stacks disk. 

Creating a 3.5-inch startup disk 

If you have a Macintosh with 800K disk drives (and no hard disk), you may 
have created startup disks for use with other Macintosh software. For an 
explanation of startup disks, see the Macintosh System Software User's Guide 
or your Macintosh owner's guide. 

The following procedures explain how to create a special startup disk for use 
with HyperCard. Although you can use HyperCard with any startup disk, you 
need this HyperCard startup disk to go through the tutorials in Chapters 2 
and 3 of chis guide. This disk also has some stacks you'll find useful, even 
when you've become an experienced HyperCard user. 

To create a HyperCard startup disk, you'll need the following disks: 

• Macintosh Utilities Disk 1 (this comes with your Macintosh) 

• a blank, initialized disk (discussed in step 2, below) 

• HyperCard Ideas (chis comes with HyperCard) 

• Macintosh Printing Tools (chis comes with your Macintosh) 
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The following procedures explain how to create a HyperCard startup disk. 

~ First, create a System Folder on a blank, initialized disk you've named 
HyperCard Startup: 

1. Start your computer with the Macintosh Utilities Disk 1 in the 
internal drive. 

2. Insert a blank, initialized disk into the external drive. 

For instructions on initializing 3.5-inch disks, see the Macintosh System 
Software User's Guide or your owner's guide. 

You can also insert a disk whose contents you no longer need. Be sure to 
select all the files on the disk and drag them to the Trash. 

3. Name the blank disk HyperCard Startup. 

Click to select the blank disk's icon and type HyperCard 
Startup. 

4. Double-click the HyperCard Startup disk icon to open it. 

You see the disk's empty directory window. 

5. Choose New Folder from the File menu. 

A new, empty folder appears in the directory window of HyperCard 
Startup. 

6. Double-click the Utilities Disk 1 icon to open it. 

7. Double-click the System Folder in the Utilities Disk 1 window. 

You see the contents of the folder, as shown in Figure C-1. 
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Figure C-1 The contents of the System Folder on Utilities Disk 1 
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8. Copy the System file by dragging its icon from the System 
Folder window of Utilities Disk 1 to the empty folder icon on 
your HyperCard Startup disk. 

If you can't see the empty folder on HyperCard Startup, move the 
directory window of HyperCard Startup into view (by dragging from its 
title bar) so that you can see the empty folder as you drag the System 
file. 

If you don't know how to drag windows or files, see the Macintosh 
System Software User's Guide or your Macintosh owner's guide. 

9. Copy the Finder by dragging its icon from the System Folder 
window of Utilities Disk 1 to the empty folder icon on your 
HyperCard Startup disk. 

10. Close the System Folder window of Utilities Disk 1 by clicking 
its close box. 

11. Click anywhere in the directory window of Utilities Disk 1 to 
activate it, then close this window by clicking its close box. 

12. Eject the Utilities Disk 1 in the internal drive by dragging its icon 
to the Trash (as shown in Figure C-2). 
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Dragging a disk to the Trash does not erase the disk; it ejects the disk 
from the drive. The dimmed icon of Utilities Disk 1 remains on the 
desktop. 

Figure C-2 Ejecting a disk 
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13. Name the new folder on HyperCard Startup "System Folder." 

Click to select the folder and type System F older. 

1J>. Copy the Art Ideas and Button Ideas stacks from the HyperCard Ideas 
disk onto the new HyperCard Starrup disk: 

1. Insert the HyperCard Ideas disk into the internal drive. 

2. Double-dick the HyperCard Ideas disk icon to open it. 

3. Double-dick the Idea Stacks folder icon on HyperCard Ideas. 

You see the contents of the folder, as shown in Figure C-3. 
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Figure C-3 The contents of the Idea Stacks folder on the HyperCard Ideas disk 

4. Copy the Art Ideas stack by dragging its icon to the directory 
window of the HyperCard Startup disk. 

Do not drag it to the System Folder- just drag it to the directory 
window of HyperCard Startup. 

5. Copy the Button Ideas stack by dragging its icon to the directory 
window of HyperCard Startup. 

Do not drag it to the System Folder-just drag it to the directory 
window of HyperCard Startup. 

6. Eject theHyperCard Ideas disk in the internal drive by dragging it 
to the Trash. 

On your screen, you should see the directory window of your HyperCard 
Startup disk, as shown in Figure C-4. 
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Figure C-4 The directory window of the HyperCard Startup disk 
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.,.. If you have a printer, copy the appropriate printer resource onto your 
HyperCard Startup disk: 

1. Insert the cliskMacintosh Printing Tools into the internal drive. 

2. Double-click the Macintosh Printing Tools clisk icon to open it. 

3. Copy the appropriate printer resource for your printer by 
dragging its icon to the System Folder on HyperCard Startup. 

If you can't see the System Folder on HyperCard Startup, move the 
directory window of the HyperCard Startup disk (by dragging from its 
title bar), so that you can see the System Folder as you drag the 
appropriate printer resource. 

If you have an ImageWriter, drag the ImageWriter printer resource to 
your System Folder. 

If you have a Laser\Vriter, drag the LaserWriter printer resource and Laser 
Prep to your System Folder. 

If you have a LaserWriter IISC, drag the LaserWriter IISC printer resource 
to your System Folder. 

4. Eject theMadntosh Printing Tools clisk by dragging it to the Trash. 
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5. Choose Restart from the Special menu. 

Now your HyperCard Starrup disk is complete. It contains everything you 
need to work with HyperCard on your Macintosh. Be sure to label it. 

•!• Be sure to make a copy of this HyperCard Startup disk and store it with the 
original HyperCard disks. If something goes wrong with your HyperCard 
Starrup disk, you'll have the stored backup copy in reserve. 

When you want to begin the tutorials in Chapters 2 and 3 of this manual, go 
to the section "Getting Started" in Chapter 2 and begin by following the 
instructions there for starting HyperCard without a hard disk. 

If you want to learn how to use HyperCard's on-line Help on your Macintosh, 
proceed to the next section. 

See the last section of this chapter for tips on using HyperCard without a 
hard disk. 

Using Help without a hard disk 

Without a hard disk, using HyperCard's on-line Help system can be a tedious 
process (because of the disk swapping required), but it's not impossible. The 
Help stack is quite large-it takes up most of a 3.5-inch disk by itself. 
Therefore, to use this stack, you have to make one of your disk drives 
available for it. 

When you're planning to use Help without a hard disk, it's a good idea to set 
aside a block of time just to explore the Help system. Once you're in the Help 
stack, you can move around in the stack without having to do much disk 
swapping (though you'll probably have to do some). However, when you try 
to leave Help-or move back and forth between Help and other stacks-­
you'll get a long succession of prompts to insert various disks in the drive. 
When this happens, it's best to tum off your computer and restart it. 

1. Start your computer with your HyperCard Startup disk in the 
internal drive and the HyperCard and Stacks disk in the other. 

If you left the directory window of your HyperCard Starrup disk open 
when you last used the disk, this window will appear on your desktop 
now. 
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2. When the Finder desktop appears, double-click the HyperCard 
and Stacks disk icon, then double-click the HyperCard icon on the 
HyperCard and Stacks disk to open it 

3. When you see your Home card, choose Help from the Go menu. 

HyperCard displays lhe direccory dialog box (shown in Figure C-5) and 
asks where the Help stack is. 

Figure C-5 HyperCard looking for Help 
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4. Click Drive until you see the name of your startup disk in the 
upper-right corner of the dialog box. 

You should also see lhe name of your startup disk above lhe directory 
list at che left of the dialog box. 

5. Click Eject to eject the startup disk. 

6. Insert the HyperCard Help disk into the drive. 

7. Click Drive, if necessary, until you see the name of the 
HyperCard Help disk in the upper-right comer of the dialog box. 

You should also see lhe name of lhe HyperCard Help disk above the 
directory list at lhe left of lhe dialog box. 
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8. Open the Help Stacks folder in the directory dialog box. 

Click, if necessary, to select the Help Stacks folder, and then click Open. 

9. Open the Help stack in the directory dialog box. 

Click, if necessary, to select Help, and then click Open. 

After you do this, your Macintosh ejects the HyperCard Help disk and 
prompts you to insert the startup disk. Follow the instructions you see 
on the screen. (You might have to repeat this process once or twice. just 
keep following the instructions on the screen.) 

Soon you see the first card of the Help stack, shown in Figure C-6. 

Figure C-6 The first card of the Help stack 
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To begin navigating the Help stack, click the tabs along the bottom of the 
first card. (Each tab is actually a button.) 

When you've finished exploring Help, it's best to rum off your computer, and 
then tum it back on again with your HyperCard Startup disk in the internal 
disk drive and the HyperCard and Stacks disk in the external drive. This way 
you can avoid the tedium of disk swapping as you continue your work with 
HyperCard. 
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Tips for using HyperCard without a hard disk 

The following general tips may help you prepare for some of the limitations 
of using HyperCard without a hard disk: 

• When you go through the tutorials in Chapters 2 and 3 of this manual, 
you need to have the Art Ideas and Button Ideas stacks on your startup 
disk. If you create your startup disk according to the instructions in the 
section "Creating a 3.5-inch Startup Disk" (earlier in this appendix), you'll 
have these stacks on your startup disk. 

• To use stacks that come on the HyperCard Ideas disk, you can copy 
them onto your startup disk (if there's room). To get more space on the 
startup disk for the stacks you want co use, remove stacks that you 
don't need. (You can always copy them back onto your startup disk 
later.) 

• When you try to open a stack chat's on your startup disk, HyperCard 
displays the directory dialog box and asks you where the stack is. Use the 
techniques described in the Macintosh Utilities User's Guide (or your 
Macintosh owner's guide) for using the directory dialog box to locate 
files. 

• If you want to use HyperCard's on-line Help system without a hard disk, 
you'll have to do some disk swapping. In the long run, you may find that 
it's more efficient co use this manual to get the information and help you 
need. The section "Using Help Without a Hard Disk," earlier in this 
appendix, describes a technique for exploring on-line Help with a 
minimum of disk swapping. 

• When you're ready to create stacks of your own, it's a good idea to 
remove some of the stacks from your startup disk to make room for 
your new stacks on this disk. To create a new stack on your startup disk: 

1. Choose the New Stack cqmmand. 

2. In the New Stack dialog box, click the Drive button until you see the 
name of your startup disk in the upper-right corner. 

3. Type a name for your new stack and click New. 
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Glossary 

Apple key: See Command key. 

background: That which is shared by a number of cards; a 
card's basic template. The background is composed of the 
background picture, background fields, and background 
buttons. 

background button: A button that appears on, and whose 
actions are the same for, all cards with the same background. 
Contrast with card button. 

background field: A field whose size, position, and text 
attributes remain constant on all cards associated with a 
particular background, but whose te>.t changes from card to 
card. Contrast with card field. 

background picture: A picture that applies to a series of 
cards. You see the Background picture by choosing 
Background from the Edit menu. Contrast with card picture. 

browse: To wander through HyperCard's stacks. 

Browse tool: The tool you use to click buttons and to set the 
insertion point in fields. 

button: Something that initiates a HyperCard action (making 
a connection, launching an application, starting a visual or 
sound effect, and so on) when you click it. See also 
background button, card button. 

button action: That which happens when a button is 
pressed. 

Button tool: The tool you use to create, change, and select 
buttons. 

card: HyperCard's basic entity-one screenful of information. 

card button: A button that appears on, and whose actions 
apply to, a single card. Contrast with background button. 

card field: A field whose size, position, text attributes, and 
contents are limited to the card on which the field is created. 
Contrast with background field. 

card picture: A picture that applies to a specific card. Contrast 
with background picture. 

Command key: The key at the lower-left side of the keyboard 
that has a propeller-shaped symbol. On some keyboards this 
key also has an Apple symbol and might be called the Apple 
key. 

current: (adj.) The one you're using now. For example, the 
current card is the one you can see on your screen. 

SOOK disk drive: The device that holds a 3.5-inch, 800 
kilobyte disk, retrieves information from it, and saves 
information to it. See also 3.5-inch disk. 

field: The place where you type regular (as opposed to Paint) 
text. Also, the tool you use to create a field. HyperCard has two 
kinds of fields-<:ard fields and background fields. 

Field tool: The tool you use to create, change, and select 
fields. 

General tool: Any HyperCard tool that isn't a Paint tool. The 
General tools are Browse, Button, and Field. 

Home card: A special card that acts as a pictorial index to 
stacks. Choose Home from the Go menu to get to Home (or 
press Command-H). 

HyperTalk: HyperCard's built-in script language for HyperCard 
users. 

keyboard equivalent key: A key you press together with the 
Command key to issue a menu command. 

layer: The order of a button or field relative to other buttons 
or fields on the same card and background. The object 
created most recently is ordinarily the topmost object (that is 
on the front layer). 

MacPaint document: Document created by the Macintosh 
MacPaint application, or any application that creates 
MacPaint-compatible graphics. 
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message: A command you send to HyperCard through a 
script or through the Message box. Some examples of 
HyperTalk messages are Go, Show, Hide, Pop 
Card, and Push Card. 

MultiFinder: A first-generation multitasking operating system 
for Macintosh computers that makes it possible to have several 
applications open at the same time, including background 
applications that let you perform one task while 1he compucer 
performs another. 

on-line help: assistance you can gee from an application 
program while i!'s running. In !his user's guide, on-line help 
refers to HyperCard's disk-based Help system. 

Paint text: Text you type using the Paine Text tool. Pain! 1e>.1 
can appear anywhere, while regular text muse appear in a 
field created with the Field tool. \Vhen you finalize Paint !ext 
by clicking, it becomes part of a picture. 

Paint tool: Any HyperCard tool you use to make pictures. 
Tools include Lasso, Brush, Spray, Eraser, Pain! Text, and 
many others. 

palette: The name for a tear-off menu when it's been com 
off. A palene remains visible on !he screen so you can use ii 
without having to pull down the menu. HyperCard has two 
palettes-Tools and Patterns. 

picture: Any graphic or part of a graphic created with a Paint 
tool. Also, an imported MacPaint document or part of a 
MacPaint document. 

point: In printing, the measurement of the height of a text 
character; one point is about 1n2 of an inch. When you select 
a font, you can also select a point size, such as 10-point, 12-
poim, and so on. 

power key: One of a number of keys on the Macintosh 
keyboard you can press 10 initiate a menu action when a Paint 
tool is active. Power keys are enabled when you choose Power 
Keys from the Options menu or check Power Keys in the User 
Preferences card in the Home stack. 

Recent: A special dialog box that holds pictorial 
representations of the las! 42 unique cards viewed. Choose 
Recent from the Go menu 10 gee the dialog box. 
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regular text: Text you type inside a field. You use the Browse 
tool to set an insertion poin! in a field and then type. Regular 
!ext is editable and searchable, while Paint text is not. 

script: A series of commands written in HyperTalk and 
associa!ed with a particular object. 

search path: The route the computer mus! follow 10 re!rieve a 
me you ask for. 

stack: A group of cards based on the same theme. A 
HyperCard document. See also card. 

System file: Software your computer uses to perform its basic 
operations. 

tear-off menw A menu that you can convert to a palette by 
dragging the pointer beyond 1he menu's edge. HyperCard has 
rwo !ear-off menus-Tools and Panerns. 

text field: See field. 

text property: A quality or a1tribu1e of a character's 
appearance. Properties include sryle, font, and size. 

3.5-inch disk: A disk made of flexible plastic 1ha1's 3.5 inches 
in diamecer and provides 800 kilobytes of information siorage. 
The disk icself is flexible, bu! the jacker is made of hard plascic. 
In spite of the hard cover, 3.5-inch disks are often called floppy 
disks, as contrasted with hard disks. 

tool: An implemen! you use to do work. HyperCard has tools 
for browsing through cards and stacks, creating text fields, 
edicing tex!, making buuons, and crea!ing and editing pictures. 

user level: The sening on the User Preferences card in the 
Home stack tha! lets you use HyperCard's cools and abilities. 
Five user levels are available: Browsing, Typing, Painting, 
Authoring, and Scripting. 



ndex 

jdresses, searching for 16-19 See also 
Address stack 

ddress stack (tutorial) 16-19, 24. See 
also card(s); stack(s) 

igrunent 86, 120-121, 135 
1phabetical order, cards and 

stacks 22. See also sorting 
ngles, changing and constraining 

159. See also Line tool 
.pple key (Command key) 212 
rrows, texc 67--08 
.rt Ideas stack 34-36, 145. 
.uthoring level 43, 66, 145. See also 

User Preferences card; user levels 
uthoring (tutorial) 42--00 

lack command (Go menu) 138 
1ackground(s) 136-137. 

See also Bkgnd Info corrunand 
buttons 52-57, 136-137,188 
canceling actions on 126 
changing 183-184 
copying 44, 131 
creating 136-137, 188-189 
cutting 128 
definition of 52 
deleting 112, 184 
erasing 159 
fields. See background fields 
names, changing 183 
New Card command and 133 
pictures. See background pictures 
saving 106-107 

selected in printing 119 
stripes on Menu bar 136-137 
versus cards 52-57 

background buttons 52-57, 
136-137, 188 

covered by card buttons 136 
creating 136-137, 188 

Background command (Edit 
menu) 55, 136-137 

background fields 54-57, 136-137 
changing 74 
creating (Background 

corrunand) 71-72, 136-137, 
188-189 

deleting 152 
description of 54, 70, 136-137 
numbers 180 
searching 142-143 
versus card fields 54 

background pictures 52-57, 136-137 
editing 136-137 
erasing 159 
selecting 190-191 

Backspace key 133 
Bkgnd Info command (Objects 

menu) 183-184. See also 
background(s) 

blowing up pictures. See FatBits 
command 

borderless rectangles 161 
borders. See also Line Size command; 

Line tool; Oval tool; Regular 
Polygon tool 

changing 159-161, 168, 202 
drawing with current pattern 168 
ftlled with current pattern 168 
in patterns 210 

Bring Closer command (Objects 
menu) 77, 186-187 

Browse tool 12, 28, 75, 148 
creating editable text with 70, 82-83 
description of 148 
versus Button 149 

browsing 12-15, 148-149. See also 
Browse tool 

definition of 12-13 
General tools and 145 
keyboard commands for 214-215 
powers associated with 111 
recap of 19 
tutorial 12-15 

Browsing level 65, 110. See also User 
Preferences card; user levels 

Brush (Tools menu) 158. See also 
Brush Shape corrunand; painting; 
Paint tools 

double-clicking 95 
dragging with modifier keys 96 
erasing with 158 
painting straight or horizontal lines 

with 158 
painting with current pattern 158 

Brush Shape command (Options 
menu) 158, 202 

Bucket 95, 162-163 
button(s) 171-177. See also 

background buttons; Button Info 
command; Button tool; icons; 
pictures 

activating 13 
background 54-57, 136-137, 188 
Browse tool and 148 
card 54, 136, 150 
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button(s) (continued) 

copying 47-48, 129, 149 
creating 63, 136, 145, 148-150, 

187-188 
cutting (Cut Button command) 127, 

149 
deleting 47, 149 
highlighted 174 
Home 47-48, 63 
icons used as 175-176 
infonnation about (Burton Info 

command) 171-177 
layers 172-173 
linking 176-177 
moving 45-46, 149, 186-187 
moving dotted line around 46 
names of (Button Info 

command) 172 
numbers 172-173 
opaque 173 
pasting (Paste command) 48, 130, 

132-133 
rectangle 173 
rounded rectangle 173 
selecting 46, 149 
shadowed 173 
shapes of 173 
sizing 149 
style of 173-174 
Telephone 45-46 
transparent 127, 173 
viewing 28 

Button Ideas 47, 238 
Button Info command (Objects 

menu) 150, 171-177. See also 
button(s); Button tool 

Auto hilite 174 
Button ID 173 
Button name 172 
Button number and layers 172-173 
dialog box 172 
Icon 175-176 
LinkTo 176-177 
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Script 177 
Show name 172 
Style 173-174 

Button tool (Tools menu) 45-46, 
148-150 

c 
cameras 90, 98 
canceling actions. See cutting; deleting; 

Undo command 
card(s). See also Card Info command, 

Home; stack(s); User Preferences 
card 

adding 21-22, 133-134 
arranging 23-24 
buttons 54, 136, 150 
canceling actions on 126 
changing 32-33, 181 
copying 130-131, 134 
creating 54, 133-134 
cutting (Cut Card command) 128, 

134 
definition of 12 
deleting 24, 112, 134, 181 
directory of. See Home 
examples of 12 
fields. See card fields 
first card, selecting 23, 133, 140 
information about 180-183 
linking 185 
miniature 132-133 
moving 133-134, 181-183 
moving 133-134, 181-183 
moving between. See Go menu 
names of 121, 181 
numbers 181-183 
pasting 130, 132-133 
position in stack 23-24, 181-183 
printing 114 
reviewing. See Recent command 
saving snapshot of 107 
searching. See Find command 
search paths 63-64 
sharing pictures among 33-38 

sorting 24 
To Do 43-45 
versus backgrounds 52-57 

card buttons 54, 136, 150 
card fields 

cover background fields 136 
description of 54, 70 
numbers 75-76, 179-180 
versus background fields 52-57 

Card Info command (Objects 
menu) 180-183 

Can't delete card 181 
Can't modify card 181 
Card number 181 
changing card position in stack 

181-183 
description of 180-181 
dialog box 181 

changes, saving. See saving 
changing 

address cards 20-21 
angles 159 
backgrounds 183-184 
borders 159--161, 168, 202 
cards 32-33, 181 
column width 121 
dots 157, 191, 203 
fields 49-51, 73-74, 77-78,151, 

177-180 
fonts 85-86, 178 
label size 120 
passwords 109-110 
stacks 105, 177 
tab order 77 
text 20-21, 84-88 
user level 31-32, 65-68 

Choose Message command 222 
circles, Oval tool and % 
cleaning paint spills 41, 96, 163 
Clear Button command (Edit 

menu) 47, 149 
Clear command (Edit menu) 64, 133 
Clear Field command (Edit menu) 152 
Clear key (keypad) 133 
clicking (mouse technique) 13, 95 



Clipboard 
Copy command and 128 
Cut command and 126 
importing graphics with 98 
non-MacPaint pictures and 98 
pasting from 132-133 
pictures and 90 
unaffected by Clear 133 
unaffected by Delete Card 134 

columns, printing 121-122. See also 
printing; Print Report command 

Command key 212 
commands 101-210. See also 

keyboard commands; messages; 
power keys or specific topic 

Back (Go menu) 138 
Background (Edit menu) 136-137 
Bkgnd Info (Objects menu) 183-184 
Bring Closer (Objects menu) 

186-187 
Brush Shape (Options menu) 202 
Button Info (Objects menu) 150, 

171-177 
Card Info (Objects menu) 180-183 
Choose Message 222 
Clear (Edit menu) 64, 133 
Clear Button (Edit menu) 47, 149 
Clear Field (Edit menu) 152 
Compact Stack (File menu) 107, 186 
Copy (Edit menu) 12!H 32 
Copy Button (Tools menu) 129 
Copy Card (Edit menu) 130, 132 
Copy Field (Edit menu) 129 
Copy Picture (Edit menu) 128-129 
Cut (Edit menu) 126-128 
Cut Button (Edit menu) 149 
Cut Card (Edit menu) 128, 134 
Cut Field (Edit menu) 56, 74 
Darken (Paint menu) 193 
Delete Card (Edit menu) 134 
Delete Stack (File menu) 112 
Draw Centered (Options menu) 

207- 208 
Draw Filled (Options menu) 

205-207,210 

Draw Multiple (Options menu) 208 
Edit Pattern (Options menu) 

203-204,209-210 
Export Paint (File menu) 106-107 
FatBits (Options menu) 1~200 
Field Info (Object menu) 177-180 
Fill (Paint menu) 191 
Find (Go menu) 140-141 
Find Whole 143-144 
First (Go menu) 23, 133, 140 
Flip Horizontal (Paint menu) 196 
Flip Vertical (Paint menu) 195 
Grid (Options menu) 198 
Help (Go menu) 139 
Home (Go menu) 138 
Import Paint (File menu) 106 
Invert (Paint menu) 191 
Keep (Paint menu) 197 
Last (Go menu) 140 
Lighten (Paint menu) 193-194 
Line Size (Options menu) 160, 

168, 202 
Message (Go menu) 144-145 
New Background (Objects 

menu) 189 
New Button (Objects menu) 

187-188 
New Card (Edit menu) 133-134 
New Field (Objects menu) 151, 188 
New Stack (File menu) 104 
Next (Go menu) 140 
Opaque (Paint menu) 196 
Open stack (File menu) 104-105 
Page Setup (File menu) 113 
Paste (Edit menu) 132-133 
Paste Button (Edit menu) 48, 130 
Paste Card (Edit menu) 130, 

132-133 
Paste Field (Edit menu) 51, 78, 130 
Paste Picrure (Edit menu) 37, 129 
Pickup (Paint menu) 192 
Polygon Sides (Options menu) 205 
Power Keys (Options menu) 

2~201 

Prev (Go menu) 140 

Print Card (File menu) 114 
Print Report (File menu) 117-125 
Print Stack (File menu) 115-117 
Protect Stack (File menu) 107-112 
Recent (Go menu) 139 
Revert (Paint menu) 197 
Rotate Left (Paint menu) 194 
Rotate Right (Paint menu) 195 
Save, lack of 24, 103 
Save a Copy (File menu) 105 
Select (Paint menu) 153, 190 
Select All (Paint menu) 190-191 
Send Farther (Objects menu) 187 
Stack Info (Objects menu) 184-186 
Text Style (Edit menu) 135 
Trace Edges (Paint menu) 194 
Transparent (Paint menu) 197 
Undo (Edit menu) 126 

Compact Stack command (File 
menu) 107, 186 

connecting. See linking 
Copy Button command (Edit 

menu) 129 
Copy Card command (Edit 

menu) 130, 132 
Copy command (Edit menu) 90, 

128-132 
copying backgrounds 131 
copying buttons and fields 129-130 
copying cards 130-131 
copying pictures 128-130 

Copy Field command (Edit menu) 51, 
77-78, 129, 152 

copying 
backgrounds 44, 131 
buttons 47-48, 129, 149 
cards 130-131, 134 
disks 4, 240 
fields 51-52, 77-78, 129, 152,236 
Finder onto startup disk 236 
from Clipboard (Paste 

command) 132-133 
pictures 33-38, 128, 154 
text 84 
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Copy Pictures command (Edit 
menu) 36, 128-129 

creating 
backgrounds 136-137, 189 
buttons 63, 136, 145, 148-150, 

187-188 
cards 54, 133-134 
fields 71-72, 136, 145, 151-153, 

178, 188 
movable Tools palette 147 
shapes 167-168 
stacks 43-45, 104 
startup disk 234-240 
text 82-88 

Curve tool (Tools menu) 95-96, 
164-165,207 

customizing, tutorial 29-60 
Cut Button command (Edit menu) 149 
Cut Card command (Edit menu) 

128, 134 
Cut command (Edit menu) 126, 128 
Cut Field command (Edit menu) 

56, 74 
cutting. See also deleting; erasing 

cards 128, 134 
backgrounds 128 
buttons 127, 149 
fields 56, 127, 152 
pictures 126-127 

D 

Darken command (Paint menu) 193 
date, headers and 117, 125 
Date message 223 
default 

field style 81 
text attributes 87, 167 

Delete Card command (Edit 
menu) 134 

Delete key, dearing selected data 
with 133 

Delete Stack command (File 
menu) 112 
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deleting. See also cutting; erasing 
backgrounds 112, 184 
buttons 47, 149 
cards 24, 112, 134, 181 
fields 56, 74, 112 
stacks 112, 181 
text 83, 152 
without inserting on Clipboard 133 

designing fields 178 
digitized images, importing 98 
digitizing cameras 90 
disk-based help. See Help system 
disk drives. See hard disk drives; 

disks 

3.5-inch disk drives, starting up 
from 

copying 4, 240 
ejecting 5, 237 
HyperCard 3, 229-239 
locked 64 
startup 234-240 

documentation, advanced xviii 
DoMenu message 224 
dots, changing 157, 191, 203. See also 

painting 
double-clicking Paint Tools 95 
dragging 20 

modifier keys and 96, 218 
problems with 154 

Draw Centered command (Options 
menu) 207-208 

Draw Filled command (Options 
menu) 205-207, 210 

Curve tool and 207 
Polygon tool and 206 
short cut for 206 

drawing. See painting; pictures or 
specific command or tool 

Draw Multiple command (Options 
menu) 208 

Brush and 160 
description of 208 
Line tool and 161 

Oval tool and 164 
Rectangle tool and 161 
Regular Polygon tool and 167-168 

duplicating. See copying 

E 

edges, tracing 194 
editing (tutorial) 20-21. ·See also 

specific topic 
patterns 203-204, 209-210 
pictures 39 
text 82-s4, 145, 148, 216 

Edit menu 125-137. See also 
commands or specific command 

description of 125-126 
short and full 66, 126 

Edit Pattern command (Options 
menu) 203-204, 209-210 

ejecting a disk 5, 237 
entering text. See text 
Eraser 39, 41, 95-96, 159. See also 

erasing; painting 
erasing. See also cutting; deleting; 

editing or specific topic 
background pictures 159 
dots 157 
pictures 159 
stack contents 112 
text 83 
with Brush 83 
with Spray tool 160 

Export Paint command 106-107 

F 

FatBits command (Options 
menu) 199-200 

field(s) 70-81. See also background 
fields; card fields; text 

active Paint 135 
background 54-57, 136-137 
card 54,57, 70, 75-76, 136, 179-180 



changing 49-51, 73-74, 77, 79-81, 
151, 177-180 

clearing 152 
copying 51-52, 77-78, 129, 152, 236 
creating 71-72, 136, 145, 151-153, 

178, 188 
cutting 56, 127, 152 
definition of 22, 70--71 
deleting 56, 74, 112 
designing 178 
ID 180 
information about 152-153, 177-178 
invisible 74, 83 
layers 75-76 
locking and unlocking 81 
moving 49-51, 72-73, 151-152, 

186-187 
moving between 74-77 
names 78-79, 119, 123 
New Card command and 133 
number of lines in 151 
numbers 75-76, 179-180 
overlapping 71 
pasting 51,56, 127, 130, 132-133 
placing 72-73 
printing order of 119 
searching in a specific (Find 

command) 142-143 
selected, moving doned line and 51 
selecting 152 
setting text properties for 135 
size, changing 49-51, 73-74 
style, changing 79-81 
tab order and 75-77 
text and 70--82, 151-153 
transparent 188 
viewing 83 
wrapping in 73, 121-122 

1ield Info command (Objects 
menu) 152-153, 177-180 

description of 177-180 
Field ID 180 
Field number 179-180 

Lock Text 81, 84, 178 
Script 180 
Show Lines 178 
Wide Margins 178 

field numbers, changing 75-76, 
179-180 

Field tool (Tools menu) 49-50, 71, 
151-153 

file(s). See also HyperCard disks; System 
file; text 

copying 4 
exporting (Export Paint 

command) 106-107 
importing MacPaint-compatible 

files lo6 
retrieving 63-64 

File menu 102-125. See also 
commands or specific command 

description of 102-103 
short and full 66, 126 

file servers, stacks and 108 
Fill command (Paint menu) 191. See 

also filling pictures 
filling pictures. See also Bucket; painting 

areas with selected panerns 162-163 
borders with current panem 168 
Draw Filled command and 

205-207,210 
Fill command and 191 

Find command (Go menu) 17-18, 
140--144. See also searching 

description of 18, 28 
can't use with Paint Text 167 
Message box 17-18 
quotation marks and 17-18 
searching for part of a word or 

name 18 
searching specific field 142-143 

Finder 
copying 236 
stack icons and 12 
version number of 2 

Find Whole command 143-144 

First command (Go menu) 23, 
133, 140 

Flip Horizontal command (Paint 
menu) 196 

Flip Vertical command (Paint 
menu) 195 

fonts, changing 85-86, 178 
formats. See also printing; Print Report 

command 
column 121-122 
printing 117-125 
row 123-124 
page llS-116 

free-form shapes. See Curve tool 

G 

General tools. See also Browse tools; 
Butron tool; Field tool 

Bkgnd Info command and 183 
description of 146 
Stack Info and 184 
versus Paint 102 

getting started (tutorial) 10--11 
Go menu 16, 137-144. See also 

commands or specific command 
Go message 224 
graphics 89-98 See also painting; Paint 

tools; pictures 
Grid command (Options menu) 198 

H 

hard disk drives 
installing HyperCard on 4-6 
starting up from 10--11 
using Help without 240--242 
using HyperCard without 8, 233-243 

headers 117, 125. See also printing; 
Print Report command 

height, text 87-88 
Help command (Go menu) 25, 139 
Help stack (tutorial) 13-15, 25, 242 
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Help system xvi, 25, 139, 240-242 
introduction to xvi 
rutorial on 13-15 
using without a hard disk 240-242 

Hide message 224 
hiding Message box 144-145 
highlighting buttons 174 
Home lS-16, 61-68 

creating button for 63 
definition of lS-16 
going to (Home command) 16, 28, 

68, 138 
linking to a stack 58-59 
search paths 63-64 
text arrow options 67-68 
tutorial lS-16 
User Preferences and 65-68 

Home button 47-48, 63 
Home command (Go menu) 28, 68, 

138 
Home icon 28 
Home stack 16, 61-68 

dangers of deleting 62, 232 
User Preferences and 65-68 

horizontal pictures 196 
horizontal printing 113, 115 
HyperCard. See also specific topic 

commands to. See messages 
customizing (tu!orial) 29-60 
disks 3, 229--239 
installing 4-6 
introduction to 1-8, 11-15 
LaserWriter and 2 
messages 221-227 
MultiFinder and 7 
package contents 3 
quieting 125 
requiremen!S for 2-3 
stacks provided with 231-232 
starting 10-11 
userlevels in 31-32, 65-68 
using without a hard disk 8, 233-243 

HyperCard icon 10 
HyperTalk 222 
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I,J 
Icon command 175-176 
icons. See also button(s) 

Address 16-17 
as buttons 175-176 
Browse 12 
Butcon Ideas 47 
Home 28 
HyperCard 10 
Intro 13 
Quick View 24 
Sort 24 
Stack 12 
To Do 43 

ID, Buuon. See Button Info command 
ID, Field. See Field Info command 
images. See picrures; shapes 
ImageWriter 98, 121 
importing pictures 90, 98, 106. See also 

pictures 
Import Paint command (File 

menu) 98, 106 
insertion point, setting 82-88 
installing HyperCard 4-6 
Intro icon 13 
Invert command (Paint menu) 191 
invisible fields and text 74 

K 

Keep command (Paint menu) 171 
keeping changes. See saving 
keyboard commands 211- 220. See 

also power keys 
browsing 214-215 
editing text 216 
modifier keys 218 
Paint tools and 217 
table of (by command) 214 
table of (by menu) 213 

keyboard equivalents. See keyboard 
commands 

keyboard shortcuts (misc. table 
oO 219--220 

keypad, Clear key on 133 
keys 

L 

Backspace 133 
Clear (keypad) 133 
Command 212 
Delete 133 
modifier 96-97, 218 
power 91-94, 200-201, 217 
Tab 22, 75-76, 219 
Tilde 14 

labels 120-121 
Landscape Printing icon 113 
LaserWriter 2 

features that don't work with 
HyperCard 113 

labels and 120 
Print Stack command and 115 
smoothing or flipping 113 

Lasso (Tools menu) 95-96, 155-156 
lassoing 95-96, 155-156. See also 

selecting 
area that has no breaks 155 
area without shrinking around black 

dots 155 
copying selections 155 
effects of 95-96, 155-156 
inverting lassoed areas, danger 

of 191 
making multiple copies 155-156 
moving selections 155 
power key for 93 
Select command and 190 

Last command (Go menu) 28, 31, 140 
layer(s) 

button 172-173 
field 75-76 
front 76 
moving buttons and fields one layer 

closer or farther 186-187 
order of 75-77 
tab 75-77 



;outs, printing 123. See also printing; 
Print Report command 

~hten command (Paint menu) 
193-194 

niting userlevels 110-112 
1es. See also painting; tool(s) or 

specific tool 
cut off text 87 
drawing 159-160 
height 87-88 
number of in fields 151 
spacing 72 
thickness of 159, 202 
viewing 81, 178 

ne Size command 160, 168, 202 
ne tool (Tools menu) 95-96, 159-160 
lking 

buttons 176-177 
cards, link broken when renaming 

stacks 185 
Home and stack 58-59 

nkTo 59, 176-177 
eking 

fields 81 
text 81, 84, 178 

x:k Text 81, 84, 178 

!acPaint 90, 98, lo6 
tanual paper feed 115, 124 
iargins, wide (Field Info 

command) 81, 178 
lemory 

requirements 2 
space in stacks 186 

1enu bar 136-137, 147 
nenus 101-210. See also commands; 

keyboard commands or specific 
menu 

Command key menu 
commands 213 

converting to palettes 40 

power keys and 91 
short and full 66, 111, 126 
tear--0ff 40, 146 

Message box 144-145, 222 
Message command (Go menu) 

144-145 
messages 221-227 

Date 223 
DoMenu 224 
Go 224 
Hide 224 
how to read 223 
Open 225 
Pop Card 225-226 
Push Card 226 
Show 226 
Show Cards 227 
Time 227 

miniature cards, pasting 132-133 
mistakes, correcting. See also cutting; 

deleting; editing; erasing; 
problems, common; Undo 
command 

modified dragging. See dragging; 
modifier keys 

modifier keys 96-97, 218 
effects of (table) 192 

mouse techniques 13, 20, 95 
movement, constricting 168 
moving 

between fields 74-77 
between stacks and cards 28 
buttons 45-46, 149, 186-187 
cards 133-134, 181-183 
fields 49-51, 72-73, 151-152, 186-187 
pictures 37-38, 154, 200 
text 84 
through stacks 23-24, 26-27, 

137-144 
MultiFinder, HyperCard and 7 
multiple images, drawing. See Draw 

Multiple command 

N 

names. See also renaming 
background, changing 183 
button 172 
card 121, 181 
field 78-79, 119, 123 
searching for 16, 141-142 
sorting 24 
stack 103-104, 177, 185 

New Background command (Objects 
menu) 189 

New Button command (Objects 
menu), dialog box 149, 187-188 

New Card command (Edit menu) 
21-22,54, 133-134 

New Field command (Objects 
menu) 71, 151, 153, 188 

New Stack command (File menu) 
44-45, 104 

Next command (Go menu) 140 
numbers 

0 

button 172-173 
card 181-183 
card layer 180 
field 75-76, 179-180 
version, System file and Finder 2 

objects, list of 170 
Object menu 170-189. See also 

commands 
on-line help. See Help System 
on-line information services xvii 
opaque 

buttons 173 
field style 79-80 
pictures 94, 96 

Opaque command (Paint menu) 196 
Open message 225 
Open Stack command (File menu) 

33-34, 104-105 
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Options menu 198-208. See also 
commands 

orientation, setting 113 
outlines, tracing 194 
Oval tool (Tools menu) 95-96, 164 
overlapping text and fields 71 

p 

page(s). See also printing 
fonnats 115-116 
numbers, in headers 117, 125 
size 113 

Page Setup command (File menu) 113 
painting 30--41 , 89-99, 15}-170, 

189-197. See also specific 
command or tool 

border 210 
Brush and 158 
Bucket and 162-163 
centered on given point 91, 162, 

205-207 
circles 164 
cleaning screen 40 
Curve tool and 164-165 
Draw Centered command and 

207-208 
Draw Filled command and 205-207 
Draw Multiple command and 

208 
Eraser and 159 
filling pictures 162-163, 205-207 
free-form shapes 164-165 
from a central point 207-208 
Line tool and 159-160 
Oval tool and 164 
paint spills 163 
Paint Text tool and 165-167 
patterns 208-210 
Pencil and 157 
Polygon tool and 169-170 
power keys 91-94, 217 
powers associated with 111 
Rectangle tool and 16o-161 
Regular Polygon tool and 167-168 
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Rounded Rectangle tool and 
161- 162 

Spray tool and 160 
text in pictures (Paint Text tool) 

165-167 
tools and 15}-170 
tutorial 30--41 

Painting level 65, 111, 135, 145. See also 
User Preferences Card; user levels 

Paint menu 189-197. See also 
commands 

Paint text. See also painting; Paint Text 
tool 

active 135 
can't use Find with 167 
identifying 84 
noneditable 82 
setting text properties for (Text Style 

command) 135 
Paint Text tool (Tools menu) 82, 95, 

135, 165-167 
Text Style command and 135 

Paint tools. See also tool(s) or specific 
tool 

Clear command and 133 
Cut command and 126 
description of 30, 32, 39, 145 
double-clicking 95 
dragging with modifier keys 96, 218 
menu bar changes and 147 
pasting and 132 
patterns and 40 
tips on 38-41 
versus General tools 102 

palettes 40, 147. See also painting 
paper feed, manual 115, 124. See also 

Print Report 
passwords 109-110 
Paste Button command (Edit 

menu) 48, 130 
Paste Card command (Edit menu) 130, 

132- 133 
Paste command (Edit menu) 90, 

132-133 

Paste Field command (Edit menu) 51 
78, 130 

Paste Picture command (Edit 
menu) 37, 130 

pasting 132-133 
buttons 48, 130, 132-133 
cards 130, 132-133 
fields 51,56, 127, 130, 132-133 
MacPaint-compatible flies 106 
pictures 37, 129 
text 127, 132-133 

patterns, changing 20}-204, 
208-210. See also filling pictures; 
painting; pictures 

Patterns menu 40, 90, 208-210. See a/s 
commands; painting; patterns or 
specific command 

description of 208 
editing patterns 209-210 
filling shapes with 191, 205-207 
short cut for 210 
tearing off 41 

Pencil (Tools menu) 39, 95-96, 
157. See also painting; Paint tools 

peripheral devices. See specific device 
Pickup command (Paint menu) 

92, 192 
pictures. See also icons; painting; Paint 

tools; patterns, changing or 
specific topic 

background 52-57, 136-137, 159, 
190-191 

basic elements 90 
Brush Shape command and 202 
changing 145, 195-196 
clearing (Clear command) 133 
copying 3}-38, 128, 154 
cutting (Cut command) 126-127 
darkening 193 
erasing (Eraser) 159 
exporting 106-107 
FatBits and 192-200 
filling (Draw Filled command) 191 
from Clipboard 90 
from Scrapbook 90 



Home card 16 
horizontal 196 
importing (Import Paint 

command) 90, 98, 106 
inverting 191 
lassoing 93 
lightening 193-194 
Line Size command and 202 
lining up elements in (Grid 

command) 198 
MacPaint 98 
menu commands 90 
moving 37-38, 154, 200 
multiple 208 
non-MacPaint 97 
opaque 94, 196 
pasting (Paste command) 37, 129 
patterns, changing 202-204, 209-210 
Pickup command and 192 
restoring latest version of 197 
rotating 194-195 
saving changes to 197 
selecting 36, 92, 153-154, 190-191 
sharing among cards 33-38 
shrinking and stretching 153-154 
special effects 97 
text as part of (Paint Text tool) 

165-167 
tracing edges of 194 
transparent 94, 197 
vertical 195 
zooming in on 199-200 

points, text size and 86-87 
Polygon Sides command (Options 

menu) 167, 205 
Polygon tool 95-96, 169-170, 206. See 

also Regular Polygon tool 
Pop Card message 225-226 
power keys 91-94, 200-201 

Paint 217 
table of 91, 200-201 

Power Keys command (Options 
menu) 95, 200-201. See also 
power keys 

preset search paths 63 
Prev command (Go menu) 140 
Previous card button 14 
Print Card command (File menu) 114 
printers. See Image Writer; LaserWriter 
printing 113-125 

cards 114-115 
columns 121-122 
controlling printouts 119 
darker 115 
fast 115 
field combinations 118 
field names in columns 121 
field order 119 
format remembered 117, 125 
headers 117, 125 
horizontal 113, 115 
labels 120-121 
manual paper feed 115, 124 
page formats 115-116 
page setup for 113 
reports 117, 125 
rows 123-124 
slowed by smoothing or 

flipping 113 
stacks 115-117 

Print Report command (File 
menu) 117-125 

Columns 121-122 
controlling printouts 119 
dialog box 118 
field combinations for 118 
Field printing order 119 
Format remembered 125 
Header 125 
Labels 120 
Manual paper feed 124 
Rows 123-124 

Print Stack command (File menu) 
115-117 

Cards printed per page 115 
dialog box 115 
Fast laser printing/darker 

printing 115 

Format remembered 118 
Headers 117 
Manual paper feed 115 
Page formats 115-116 

private access, stacks and 109 
problems, common 

changing backgrounds 136, 184 
changing card positions 181 
creating buttons 136, 149 
creating fields 72, 136, 151 
deleting cards 181 
deleting background 184 
dragging pictures 154 
losing parts of reverted pictures 195 
modifying background pictures 184 

Protect Stack command (File 
menu) 107-112 

Can't delete 109 
Can't modify 108 
Private access 109 
Set password button 109 
viewing full File menu with 111 

Push Card message 226 

Q 
Quick View icon 24 
quitting HyperCard 125 
quotation marks, Find command 

and 17-18, 142 
Quotations stack, adding to 33, 37-38 

R 

Recent command (Go menu) 26-27, 
139 

rectangle buttons 173 
rectangle field style 79-80 
Rectangle tool (Tools menu) 95-96, 

160-161. See also Rounded 
Rectangle tool 

rectangles 95-96, 160-161, 167-168 
Regular Polygon tool 95-96, 167-

168. See also Polygon tool 

Index 255 



removing. See cutting; deleting; editing; 
erasing 

renaming. See also names 
pictures 98 
stacks 106, 177 

reports, printing. See Print Report 
command 

restoring last picture saved 197 
restricting user levels 11~112 
Revert command (Paint menu) 197 
reviewing cards. See Recent command 
Rotate Left command (Paint 

menu) 194 
Rotate Right command (Paint 

menu) 195 
rotating shapes (Regular Polygon 

tool) 96 
rounded rectangle buttons 173 
Rounded Rectangle tool 95-96, 

161-162. See also Rectangle tool 
rows, printing 123-124. See also 

printing; Print Report command 

s 
Save a Copy command (File 

menu) 105 
Save command, lack of 24, 103 
saving 

background 106-107 
card snapshots 106-107 
changes when quitting 125 
patterns 204, 209 
pictures 197 
stacks 105 

scanners 90 
Scrapbook, pictures and 90 
screen 

losing part of rotated pictures 
on 195 

removing cards from 134 
snapshots of 98, 106-107 

Script button (Field Info 
command) 177 

256 Index 

scripting 
description of 66 
on User Preferences card 66 
powers associated with 111 
scripting language 222 
scripting level 135, 145, 177, 180 

scripts 66, 79, 111, 177 
Button Info command and 177 
changing field names in 7B-79 
Field Info command and 180 

scroll bar, vertical 79 
scrolling field style 79 
searches, electronic. See Help system 
searching for text 16-19, 14~144. See 

also Find command 
search paths 63-64, 186 
Select All command (Paint menu) 153, 

19~191 

Select command (Paint menu) 190 
selecting 153-154. See also lassoing or 

specific topic 
buttons 46, 149 
fields 152 
pictures 36, 92, 153-154, 

190--191 
shapes 168, 205 
text 21, 148, 166 
tools 147 

Selection tool 35, 92-96, 153-154 
Send Farther command (Objects 

menu) 77, 187 
sending a message (Message 

command) 144-145, 221-227 
setting 

passwords 109-110 
user levels 31-32, 65-68 

shadowed buttons 173 
shadow field style 79-80 
shapes. See commands; pictures or 

specific topic 
shortcuts 

Draw Filled command 206 
FatBits 200 
keyboard (table of) 219-220 

opening stacks 105 
Patterns menu 163 
screen snapshots 107 
selecting text 166 

Show Cards message 227 
Show Lines (Field Info command) 81 
Show message 226 
shrinking pictures (Selection tool) 

153-155 
sizing buttons 149 
snapshots 

card 106-107 
screen 98 

software. See disks; system software 
Sort icon 24 
sorting 24 
space, eliminating. See shrinking 

pictures 
spacing, line 72 
special effects 97 
Spray tool (Tools menu) 96, 160 
stack(s). See also cards or specific topic 

adding cards to 133-134 
Address 16-19, 24 
arrangement of cards in 23-24 
Art Ideas 34-36 
authoring 42-60 
backgrounds, unlimited number 

of 137 
blank 104 
Button Ideas 47 
card position in 23-24, 181-183 
central. See Home 
changing 105, 177 
compacting 107 
creating 43-45, 104. See also 

authoring 
customizing tutorial 29-60 
definition of 12 
deleting 110, 181 
deleting extra space in I 86 
directory of 16, 105 
ftle servers and 108 
free space in 107, 186 



Help stack 25 
Home stack 16, 61---08, 232 
linking Home to 58-59 
location of 105, 186 
moving through 23-24, 26-27, 137-

144. See also Go menu 
names of 103-104, 177, 185 
obtaining xvii 
opening 33, 104-105 
passwords and 109-110 
printed summaries of 117-125 
printing 115-117 
protecting 67, 107-112 
provided with HyperCard 231-233 
Quotations 33, 37-38 
removing cards from 128, 134 
renaming 106, 177 
retrieving (Recent command) 

63---04, 139 
saving 64, 105-106 
searching for text in (Find 

command) 16-19, 140-144 
search path for 63---04, 139 
sorting 24 
viewing 23 

Stack icon 12 
Stack Info command (Objects 

menu) 184-186 
description of 184-185 
dialog box 185 
Free in Stack 186 
Stack name 185 
Where 186 

starting up 10-11 
Startup disks 234-240 
stretching picture selections 154, 156 
stripes on menu bar. See 

background(s) 
style 

button 173-174 
field 79-81 
text 85-88, 135 

System file 2, 236 
system software 2 

T 
Tab key 2, 75-77, 219 
tab order 75-77 
tear-off menus 40, 146 
telephone numbers 16, 22. See also 

Address stack 
text 69-88. See also field(s) 

alignment of 86, 120-121, 135 
Browse tool and 148 
changing 20-21, 84-88 
copying 84 
creating 82-88 
default attributes of 87, 167 
deleting 83, 152 
editing 82-84, 145, 148, 216 
entering 82-84, 165-167 
finding 16-19, 140-141 
fields and 70-82, 151. See also 

field(s); Field tool 
fonts, changing 85-86, 178 
height 87-88 
hidden, viewing 83 
kinds of 70-71 
lines cut off 87 
locking 81, 84, 178 
moving 84 
outside a field 84 
overlapping 71 
Paint 82, 84, 135, 165-167 
pasting 127, 132-133 
properties of 84-88 
regular 82-88 
searching for 16-19, 140-144 
selected 83 
selecting 21, 148, 166 
Show Lines 81 
size 86-87 
style 85-88, 135 
typing 70 
uneditable 84 
Wide Margins 81 
wrapping 73, 121- 122 

text arrows 67---08 

Text Style command (Edit menu) 
85-88, 135 

3.5-inch disks, starting up from 234-240 
Tilde key 14 
time in headers 117, 125 
Time message 227 
To Do card 43-45 
tool(s) 

Browse 12, 28, 75, 148 
Brush 95-96, 158 
Bucket 95, 162-163 
Button 45-46, 148-150 
Curve 95-96, 164-165, 207 
Eraser 39, 41, 95-96, 159 
Field 49-50, 71, 151-153 
General 102, 146, 183-184 
Lasso 95-96, 155-156 
Line 95-96, 159-160 
menu bar changes and 147 
modifying with Power Keys 200-201 
Oval 95-96, 164 
Paint 102, 146 
Paint Text 82, 165-167 
Pencil 39, 95-96, 157 
Polygon 95-96, 169-170, 206 
Rectangle 95-96, 160-161 
Regular Polygon 95-96, 167-168 
Rounded Rectangle 95-96, 161-162 
selecting 147 
Selection 35, 92-96, 153-154 
Spray 96, 160 
switching, Paint text and 135 

Tools menu 145-170. See also General 
tools; Paint tools; tool(s) or specific 
tool 

description of 145-147 
menu bar changes and 147 
tearing off 41 
viewing 31-32 

Tools palette, movable 146-147. See 
also tool(s); painting 

Trace Edges command (Paint 
menu) 194 

Index 257 



transparent 
buttons 127, 173 
fields 81, 188 
pictures 94, 197 

Transparent command (Paint 
menu) 197 

Trash, ejecting a disk with 5, 237 
tutorials 9--00 

adding a card 21-22 
Address stack 16-19 
arranging cards in stacks 23-24 
authoring 42--60 
browsing 12-15 
changing text 20-21 
customizing 29--46 
getting started 10-11 
Help stack 25 
Home 15-16 
linking 58-59 
painting 30-41 
Recent 26-27 
searching 16-19 

Typing level 65, 110. See also User 
Preferences card; user levels 

typing text. See text 

258 Index 

u 
Undo command (Edit menu) 126 
user groups xvii 
userlevels 31-32, 65--68 

limiting 110-112 
powers associated with 111 
setting 31-32,65--08 

User Preferences·card 31-32, 65--08, 103 

v 
version numbers, System me and 

Finder 2 
vertical pictures 195 

W, X, y 

Wide Margins 81, 178 
wrapping text 73, 121-122 

z 
zooming in on pictures. See FatBits 

command 



ti, HyperCard® 1.2.2 
Quick Reference Card 

User preference levels 

Browsing Short File and Edit menus, plus the Go menu. Use of the 
Browse tool. 

Typing Same as Browsing, plus the Text Arrows option and the ability 
to edit text in existing fields. 

Painting Same as Typing, but with full File and Edit menus and use of 
the Tools menu (plus Paint, Options, and Pattern menus when 
a Paint tool is selected). Use of all the Paint tools (but not 
Button and Field tools), plus Power Keys option. 

Authoring Same as Painting, plus the Objects menu. Use of Button and 
Field tools. 

Scripting Same as Authoring, plus the ability to type into the Message 
box while it's hidden (if the Blind Typing option is selected), 
and the ability to write and edit the scripts. 



Effects of modified dragging 

Tool 

Button 
Field 
Selection 
Lasso 
Line 
Eraser 
Pencil 
Rectangle 
Curve 
Brush 
Spray 
Rounded Rectangle 
Polygon 
Oval 
Regular Polygon 

Tool 

Button 
Field 
Selection 
Lasso 
Line 
Eraser 
Pencil 
Rectangle 
Curve 
Brush 
Spray 
Rounded Rectangle 
Polygon 
Oval 
Regular Polygon 

With Command key With Option key 

Create button Copy button 
Create field Copy field 
Select tightly Copy selection 
Lasso everything Copy selection 
No effect Draw with pattern 
Erase white No effect 
Enter/leave FatBits No effect 
No effect Patterned border 
No effect Patterned border 
Erase what you paint over No effect 
Erase what you spray over No effect 
No effect Patterned border 
No effect Draw with pattern 
No effect Patterned border 
No effect Patterned border 

With Shift key 

Move button horizontally or vertically 
Move field horizontally or vertically 
Move selection horizontally or vertically 
Move selection horizontally or vertically 
Draw at 15° angles 
Erase straight horizontally or vertically 
Draw a straight horizontal or vertical line 
Draw a square 
No effect 
Paint straight horizontally or vertically 
Spray straight horizontally or vertically 
Draw a square with rounded corners 
Draw at 15° angles 
Draw a circle 
Rotate in 15° increments 



(continued) 

Key or combination 

Tilde(-) 

Down Arrow 

Up Arrow 

Tab 

Command-Option-C 

Command-Option-B 

Command-Option-$ 

Effect 

Same as Back command (General tool selected) 

Undo most recent action (Paint tool selected) 

Same as Back command (any tool selected) 

Come forward through reviewed cards 

Toggle Patterns palette (Paint tool selected) 

Advance insertion point to next background field 
(Browse tool selected) 

Edit script of current card 

Edit script of current background 

Edit script of current stack 

Holding down the Command key before and as you drag through the File 
menu shows the full File menu, even if Browsing or Typing is selected on the 
User Preferences card in the Home stack and/or in a stack's Protect Stack 
dialog box. 



How HyperCard works: An overview 

A Stade 

Bernie Squire 
Card field --------,-...i....----'--..---~ 

Paula Bailey Contr.ctor 

A button that takes ----+-'P-'r'"'-i ' mo Acme 
you to the next card 

A button that takes ----+-"""""'=-""""' 
you to the previous card 

A button that takes---------_../ 
you to another stack 

All thls ls on the background. 

Background picture---+-~• Acme Dot Company 
L3' 123 North St .Santa Clara. CA 94013 

Background fields ----1 

Pos1tion: L Name [ JD 
Empl. No : I~~! 
Buildin9 · ~=====~' 
Telephone :~-----~ 

1ii' 

Background buttons --------J7 

Another Stack 

Card picture ----1--P_n _m_o _A_cm_•-l 
Pres1dent, 
Acmt' Ool 
Company 

Thls part changes from card to card. 

Bernie Squire 
Sales Rep 
234 
D-3 Homest ead 
SSS- 1736 

On the screen you see a combination of the background and the part unique to a given card. 

•Acme Dot Company cf' 123 North St.Santa Clar• . CA 94013 

Name : fBermeSquire ~ 
Pos1hon : [[11 les ~ 

Empl No : ~2;=3,.•.,..,=="'""~ . 
Building : D .. 3 Homutead 
Telephone: [[ss-1 736 



Browsing from the keyboard 

Destination 

Help 

Home 

First card in stack 

Previous card in stack 

Next card in stack 

Last card in stack 

Retrace through cards viewed 

Forward through retraced cards 

Record of cards recently seen 

Select Browse tool 

Store current card's location for 
quick return 

Return to stored location (last 
in-first out order) 

Next field on card 

Previous field on card 

Keyboard shortcut 

Command-? 

Command-H 

Command-1 or Command-Left Arrow 

Command-2 or Left Arrow 

Command-3 or Right Arrow 

Command-4 or Command-Right Arrow 

Tilde (-), Esc, or Down Arrow 

Up Arrow 

Command-R 

Command-Tab 

Command-Down Arrow (Many locations 
can be stored.) 

Command-Up Arrow 

Tab 

Shift-Tab 

•If you've selected the Text Arrows option on the User Preferences card, hold 
down the Option key while you press this arrow key. 



Miscellaneous keyboard shortcuts· 

Key or combination 

Command-Option• 

Command-Shift-Option• 

Command-Backspace 

Command-Period 

Command-Space bar 

Command-Tab 

Command-Tab-Tab 

Command-Tab-Tab-Tab 

Command-Tilde(-) 

Command-Shift-V 

Command-Down Arrow 

Command-Up Arrow 

Option-D 

Option-0 

Option-Tab 

Effect 

Show all buttons (Browse or Button tool selected) 

Show all fields (Field tool selected) 

Delete current card 

Cancel current action Oike printing) 

Hide and show menu bar 

Select Browse tool 

Select Button tool 

Select Field tool 

Go to most recent card displayed 
(Paint tool selected) 

Paste miniature card image 
(with card on Clipboard) 

Paste a field along with its text 

Store current card's location for quick return 
(you can have many locations stored) 

Return to stored location Oast in-first out order) 

Show card picture (with Paint tool) 

Show Opaque areas (with Paint tool) 

Toggle Tools palette 

*Darker outlines indicate background fields or buttons. 



Keyboard equivalents by command 

Command Keys Menu 

Back Command-Tilde ( - ) Go 
Background Command-B Edit 
Bring Closer Command-plus ( +) Objects 
Copy Command-C Edit 
Cut Command-X Edit 
Find Command-F Go 
First Command-1 Go 
Help Command-? Go 
Home Command-H Go 
Keep Command-K Paint 
Last Command-4 Go 
Message Command-M Go 
New Card Command-N Edit 
Next Command-3 Go 
Open Stack Command-0 File 
Paste Command-V Edit 
Prev Command-2 Go 
Print Card Command-P File 
Quit HyperCard Command-Q File 
Recent Command-R Go 
Select Command-S Paint 
Select All Command-A Paint 
Send Farther Command-minus (-) Objects 
Text Style Command-T Edit 
Undo Command-Z Edit 



Text editing 

Function 

Font, next in system 
Font, previous in system 
Text Style dialog box 
Space, less between lines 
Space, more between lines 
Text size, larger 
Text size, smaller 

Keyboard shortcut 

Command-Shift-> 
Command-Shift-< 
Command-T 
Command-Option-Shift-< 
Command-Option-Shift-> 
Command-> 
Command-< 

Power keys available when using Paint tools 

Command Key Menu 

Black pattern B Patterns 
Darken D Paint 
Draw Centered (toggle) c Options 
Draw Multiple (toggle) M Options 
Fill F Paint 
Flip Horizontal H Paint 
Flip Vertical v Paint 
Grid (toggle) G Options 
Invert Paint 
Lighten L Paint 
Line size 1-4,6,8 Options 
Opaque 0 Paint 
Pickup p Paint 
Revert R Paint 
Select s Paint 
Select All A Paint 
Trace Edges E Paint 
Transparent T Paint 
White pattern w Patterns 
Rotate 90° Left [ Paint 
Rotate 90° Right l Paint 
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.... HyperCard 

• DCJCJCJCJ • CJCJ D CJ • CJ 
1• CJCJCJCJCJCJCJDD • CJD 
• DCJDCJ • CJDCJCJCJCJCJ 
• DDDD • DDDDDDD 
• DDD • DDDDCJDDCJ 
• DCJCJCJCJCJCJD • CJD • 
• CJ CJD CJ CJ CJ CJ CJD CJ CJ CJ 
• DCJCJCJCJCJCJCJCJCJCJCJ 

Please do not mark above this line 

• 1. u:::::im mm mm 
• 2. mmm 
• 3. mm 
• 4. mmmmmmm 

• s. mm mm mm 
• 6. mmm 



9. Tell Apple About ........................................................................................ . 

• Please contact your authorized Apple dealer when you have questions about your Apple products. Dealers are trained by 
Apple Computer and are given the resources to handle service and support for all Apple products. If you need the name of 
an authorized Apple dealer in your area, call toll-free: 800-538-9696. 

• Would you like to tell Apple what you think about this product? After you have had an opportunity to use this product, we 
would like to hear from you. You can help us to improve our products by responding to the questionnaire below and marking 
the appropriate boxes on the card at the right with a #2 lead pendl If you have more than one response to a question, mark 
all the boxes that apply. Please detach the card and mail it to Apple. Include additional pages of comments if you wish. 

1. How would you rate the Hype!Card software overall? (1 =poor ... 6-excellent) 

2. How Jong have you used HyperCard? (l=less than 1month,2•1-6 months, 3•over6 months) 

3. How did you acquire HyperCard? (I .. packaged with computer, 2-purchased separately) 

4. Where did you purchase HyperCard? (l"Ciealer, 2•corporate purchase, 3•education purchase, 4=university, 
S·govemment purchase, 6-Certi.fied Developer Program, 7-other) 

5. How much experience have you had with computers? (1-none ... 6=extensive) 

6. Which Apple computer are you using with HyperCard? (I •Macintosh Plus, 2•Macintosh SE, 3=Macintosh II) 

7. Where do you use Hype!Card most often? (1 =work, 2 .. home, 3·school, 4-other) 

8. How often do you use Hype!Card with your computer? (1 .. never ... 6-always) 

9. At what level are you using HyperCard? (1 =browsing, 2 .. typing, 3·painting, 4•authoring, 5'"scripting) 

10. At what level do you expect to use HyperCard eventually? (!•browsing, 2• typing, 3·painting, 4=authoring, S=scripting) 

11 . How easy is HyperCard to use? (1-difficult...6"'Very easy) 

12. How did you learn to use HyperCard? (1 •Hype!Card User's Guide, 2=Hype!Card Help system, 3=training class, 
4-friend, S-other) 

13. Does HyperCard meet your expectations? (1 =not at all ... 6=exceeds expectations) 

14. How would you rate the HyperCard User's Guide overall? (1 .. poor...6-excellent) 

15. How would you rate the Hype!Card Help system overall? (l •poor ... 6-excellent) 

16. If you experienced any problems with the manual, please describe them. (Page numbers would be useful.) 

17. What suggestions do you have for improving HyperCard? 

Thanks for your time and effort. 030-3218-B 
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THE APPLE PUBLISHING SYSTEM 

This Apple® manual was written, edited, 
and composed on a desktop publishing 
system using Apple Macintosh® 
computers and Microsoft® Word. Proof 
pages were created on the Apple 
LaserWriter® printers; final pages were 
printed on a Varityper® VT6oo™. Line 
art was created using Adobe Illustrator™ 
and HyperCard®, and typeset on a 
Linotronic® 300. POSTSCRIPT®, the 
LaserWriter page-description language, 
was developed by Adobe Systems 
Incorporated. 

Text type and display type are Apple's 
corporate font, a condensed version of 
Garamond. Bullets are ITC Zapf 
Dingbats®. Some elements, such as 
program listings, are set in Apple 
Courier, a fixed-width font. 
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