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HyperCard™ is a new kind of application—a unique information
environment for your Apple® Macintosh™ computer. Use it to look
for and store information—words, charts, pictures, digitized
photographs—about any subject that suits you. Any piece of
information in HyperCard can connect to any other piece of
information, so you can find out what you want to know in as much
or as little detail as you need.

What you need to use HyperCard

HyperCard works in any Apple Macintosh computer with 1
megabyte of memory or more, and two 800K disk drives. It works
best in systems with a hard disk drive and a printer.

% HyperCard and MultiFinder: To get the most out of your system
when you're using HyperCard and any other application under
MultiFinder™, your system should have at least 2 megabytes of
memory. Your authorized Apple dealer can quickly upgrade your
system with the necessary extra memory.

About system software

HyperCard comes with the latest System file, a file your computer
uses to perform its basic operations. The System Folder in the disk
labeled HyperCard Startup has System version 4.1.

You need to be concerned about the version number of the Systern
file if you plan to use HyperCard on your own startup disks. (Startup
disks all have System files on them.) HyperCard works fine under
System files with the version numbers in Table P-1 (or higher
numbers).

Table P-1

System file versions

Computer System Finder
Macintosh Plus System 3.2 Finder 5.3
Macintosh SE System 4.0 Finder 5.4
Macintosh II System 4.1 Finder 5.5

To find out the version of the System file on your startup disks, look
in the System file Get Info box.

Preface: Before You Begin
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Macintosh I

Do not use the System file on the HyperCard Startup disk to run
the Macintosh Il, even though its version number is 4.1: it will
not work properly. Use whatever System Folder you currently
have to start up your computer.

& LaserWriter users take note: To use a LaserWriter® printer with
HyperCard, you must be using LaserWriter file version 4.0 (or
higher numbers).

< Finder not necessary: You don't need a Finder on startup disks
that you use exclusively for HyperCard. You do, however, need a
System file.

What you need to know

This guide assumes you've already read and are familiar with the
owner’s guide that came with your computer. Before you use
HyperCard, you should know how to

D use the mouse

O open applications and documents
0O do simple editing

O use the Finder

What comes with HyperCard

Besides this manual, your HyperCard package should contain four
disks, named as follows:

O HyperCard Startup
O HyperCard & Stacks
O HyperCard Help

O HyperCard Ideas

In the unlikely event that anything is missing, immediately contact
your dealer for replacement.

See Appendix B, “HyperCard Disks,” for a list of the stacks (the
name for HyperCard documents) and other files on each disk.

What you need to use HyperCard xvil



xviii

Copy your disks

Before you do anything else, make copies of all the HyperCard disks
to use as your working disks. Then put the originals away in a safe
place.

HyperCard is an inviting program to use and to experiment with.,
HyperCard documents are extremely easy to change. You might
want to use your original HyperCard documents to replace a
document you've experimented with; so it's important that you keep
a set of these documents in their unaltered states.

Copy your HyperCard disks now, before you do anything else. If
you're not sure how to copy disks, see the owner’s guide that came
with your computer.

Installing HyperCard on a hard disk

Using HyperCard on a hard disk system is easy. Just copy all the files
on all the disks except HyperCard Startup to your hard disk.

“ Hard disk set up? This section assumes your hard disk is already
set up. If it isn’t set up yet, see the Macintosh Utilities User’s
Guide that came with your computer and your hard disk owner’s
manual for instructions.

® To install HyperCard on a hard disk:
1. Start your computer as you normally would.

2. Insert the disk labeled HyperCard & Stacks into your
computer's built-in 3.5-inch disk drive.

It doesn’t matter which drive you use if you have two 3.5-inch disk
drives.

3. Open the HyperCard & Stacks disk.

To open the disk, click its icon and choose Open from the File
menu. Double-clicking the disk also opens it.

Preface: Before You Begin



4. Choose Select All from the Edit menu, then drag dll the files
to your hard disk.

See the owner's guide that came with your computer if you don't
know how to drag to a disk.

5. Drag the HyperCard & Stacks disk to the Trash and insert the
HyperCard Help disk.

Dragging a disk to the Trash ejects the disk and removes its icon
from the desktop. (It does not erase the disk.)

6. Open the disk, choose Select All from the Edit menu, and
drag to the hard disk.

7. Drag the HyperCard Help disk to the Trash and insert the
HyperCard Ideas disk.

8. Open the disk, choose Select All from the Edit menu, and
drag to the hard disk.

9. Drag the HyperCard Ideas disk to the Trash.
HyperCard is now installed on your hard disk and ready to go.

How this guide is organized
This section describes all the chapters and appendixes in this guide.

O Chapter 1, “Browsing and Editing,” is a tutorial on getting
around in HyperCard. It teaches you how to use some of
HyperCard's most important features.

O Chapter 2, “Customizing,” presents two more tutorials. These
tutorials teach you how to customize HyperCard documents for
your Own use.

O Chapter 3, “Home,” gives details about this all-important
HyperCard document.

O Chapter 4, “Text in HyperCard,” provides information on
HyperCard fields (the places you create to hold text), how to
enter text into those fields, and how to control text styles.

O Chapter 5, “Graphics in HyperCard,” pulls together
HyperCard’s graphic elements and suggests ways to use various
HyperCard tools and commands to produce finished pictures.

How this guide Is organized X1x



0O Chapter 6, “Menu Commands,” gives detailed descriptions of
every HyperCard menu command. This chapter also includes
step-by-step instructions for carrying out HyperCard’s most
common procedures.

O Chapter 7, “Keyboard Commands,” summarizes all the
HyperCard commands and features that you can execute directly
from the keyboard.

0 Appendix A, “Common HyperCard Messages,” lists the most
common instructions you send to HyperCard using a feature
called the Message box. (This appendix is for advanced
HyperCard users.)

o Appendix B, “HyperCard Disks,” gives a listing of the
documents and other files on each of the disks that comes with
HyperCard.

Some conventions used in this guide

Several special elements in this manual’s text are designed to make
learning easier.

% By the way: A note like this presents additional information or
interesting sidelights.

Important  Be sure to read every item that’s labeled this way, with a tag
in the margin.

Warning Warnings like this alert you to situations where you could
damage software or lose data.

Definitions of terms and Terms in boldface type are defined in the glossary. Sometimes the

references to other parts of the
book sometimes appear in the

margin.

X X

definition or additional information about such terms also appears
in the margin.

A special typeface indicates characters that you should type:

It looks like this.
B How-to sections are indicated by a red symbol.

Preface: Before You Begin
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On-line help is assistance you
can get from an application
program while it's running.

About on-line help

HyperCard’s Help system gives you immediate, on-line assistance
whenever you get stuck. Use it when you've forgotten some
procedure you read about in this book, or when you want a quick
overview of a feature that’s unfamiliar to you.

On-line help versus this guide

On-line help in HyperCard differs from the help you'll find in this
user’s guide in these key ways:

0O On-line help is brief; this guide is detailed. Turn to this guide
when you need an in-depth discussion of a topic.

O On-line help might have information on a feature added after
this guide was written.

O On-line help lets you get to the information you need by clicking
buttons and by doing electronic searches. It uses HyperCard's
best features to explain HyperCard, and stands as an example of
what HyperCard can do. To find information in this guide, you
look up the subject in the table of contents or in the index and
(alas) manually turn to the referenced page.

Where to get HyperCard stacks

Stacks are collections of information created by and used with
HyperCard. You can create stacks yourself, or you can get them
from a variety of sources.

0 You'll find Stackware™ documents for sale at your local
computer software store. Stackware products are expressly
created for use with HyperCard.

O Check with your local Macintosh user group to find out the
meeting time of the HyperCard special interest group. Members
often exchange member-created stacks with each other.

O Most on-line electronic information services like CompuServe
and GEnie have Macintosh special interest groups. These groups
have (or soon will have) stacks you can get free, except for the
service's time charges.

Where to get HyperCard stacks XX



xxli

User groups

Ask your dealer for the name of a Macintosh user group near you. If
you live in the United States, you can call 1-800-538-9696 for the
name, address, and telephone number of up to three Macintosh
user groups in your geographic area.

Qutside the United States, ask your dealer or get in touch with

The Boston Computer Society
One Center Plaza

Boston, Massachusetts 02108
(617) 367-8080

or

Berkeley Macintosh User Group
1442-A Walnut Street #62
Berkeley, California 94709
(415) 849-9114

Either of these organizations can provide you with the name of a
Macintosh user group near you. You can also join either of these
groups or ask them for information on starting your own Macintosh
user group.

Advanced documentation

This guide covers everything you need to know to use HyperCard
effectively up to the scripting level. For details about scripts and
other advanced HyperCard features, see the HyperCard Script
Language Guide, available from:

Apple Programmer’s and Developer’s Association
290 SW 43rd Street

Renton, WA 98055

Telephone: (206) 251-6548

Preface: Before You Begin
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Hy perCard

HyperCard icon

Important

This chapter teaches you HyperCard basics. It covers things
everyone must know to use HyperCard. You'll learn how to

O use some important HyperCard documents (called stacks)
roam through HyperCard stacks

o

O search for information

O edit text on cards (HyperCard’s basic unit of information)
m]

create places to hold new information

Getting the most out of the tutorials

Throughout this chapter and Chapter 2, you'll see one or more
boldfaced sentences that begin with the symbol m. The symbol
marks an action for you to do, to give you some experience working
with HyperCard. Follow any numbered boldfaced steps in order.

Getting started

Before you can start your tutorials, you need to get HyperCard up
and running. You start HyperCard the same way you start any
Macintosh application.

m Start HyperCard:

If you're starting HyperCard from a hard disk:
1. Click the HyperCard icon in the Finder to select it.
2. Choose Open from the File menu.
Or double-click the icon to open it.
If you're using HyperCard with 3.5-inch disk drives:
1. Start the computer.

If the computer is already on, choose Restart from the Special
menu, (If you don't have Restart, choose Shut Down.)

2, Put a copy of the disk labeled HyperCard Startup into the
startup drive.

HyperCard cannot work with a locked disk (or locked volume).
Make sure that any disk you want to use is unlocked.

Chapter 1: Browsing and Editing
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Macintosh I

Do not use the HyperCard Startup disk. Use your regular startup
disk, and put a copy of the disk labeled HyperCard & Stacks
Into the other drive, skipping Step 3. Open HyperCard by
double-clicking Its lcon. Swap disks as needed to get fo the
Help Stacks or Ideas Stacks folders while doing the tutorial.

3. Put a copy of the disk labeled HyperCard Help into the other
drive.

HyperCard starts automatically. You'll see the screen in Figure 1-1.

™ Home Card {15
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Address Documents File Index Buﬂl Hh-—H

1 (@]
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Ideas Quotations
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Figure 1-1
Starting HyperCard

Browsing

Before you start to explore HyperCard, you'll need to know a few
terms—specifically browsing, card, stack, button, and tool.

Browsing is HyperCard’s term for roaming around cards and
stacks.

A card is HyperCard's basic unit of information. A card fills the
entire screen. (On larger-screen Macintoshes like the Macintosh 1II,
a card appears in a2 window—you have some extra room on the
edges.) What you see on the screen now is a card; Figure 1-2 shows
some others.

Browsing 3



Stack icon
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Browse tool
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Figure 1-2

Some cards—HyperCard'’s fundamental units of Information

A named collection of cards is called a stack. You can think of a
stack as a HyperCard document. Cards in a stack usually (but not
necessarily) are based on the same theme. An icon for each stack
appears in the Finder.

You do much of your browsing in HyperCard by clicking buttons.
You activate buttons with the Browse tool.

= Move the mouse around.

The little hand you see moving around when you move the mouse is
the Browse tool. HyperCard has many tools that you use to look for
and to create information. The Browse tool is the tool you’ll use
most often.

Letting HyperCard teach you

You can learn a lot about HyperCard just by using it. This is
especially true when you go through the on-line Introduction.
(On-line means presented by the computer, as opposed to
presented by this user’s guide.)

Chapter 1: Browsing and Editing
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m Go through the on-line introduction:

1. Move the mouse until the Browse tool is on the Infro icon,
and click.

(It’s near the screen’s left corner.) In a few seconds, the card in
Intro Icon Figure 1-3 appears.

Intrao

Figure 1-3
First card of the on-line Infroduction
\:] 2. Click the bufton labeled “What is HyperCard?”
During the introduction you might want to review a card you've
Previous card arrow already seen. To do that, click the left arrow button to go back

through the Introduction stack one card at a time,

2
L

You can always go back: Another way to see the previous card is
to press the Tilde key. Stacks in HyperCard often link to each
other (a concept you'll learn more about later). While the left
arrow brings you to the previous card in the stack you're looking
at, the Tilde key brings you to the last card you saw, no matter
what stack it was in.

® When you get to the card titled “What Next?” in the on-

line Introduction, click "Home to explore on my own”; then
come back to this guide and continue reading.
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Home

You should be back at the Home card, the card you saw when you
started HyperCard. You'll see Home more than any other card.
Home is your base of operations, the jumping-off point for all your
explorations in HyperCard.

™ Home Card i

Figure 1-4
Home card

The Home card, first card in the Home stack, is a visual directory
for your most important cards and stacks. Clicking one of the
pictures here brings you to the card that the picture represents.
(Each picture is actually a button.) In Chapter 2, you'll learn how io
add pictures representing your own cards and stacks to the Home
card.

To get back to Home at any time, choose Home from the Go menu.

% About the Go menu: The Go menu is HyperCard’s navigation
panel. You can use it to go from one card to another within a
stack, to trace your way back through cards and stacks you've
already seen, and to get help whenever you need it. In the early
stages of working with HyperCard, you're likely to use the Go
menu more than you’ll use any other menu.

Chapter 1: Browsing and Editing
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Address

Address icon

In a few moments you'll use the Home card to move to the Address
stack. The Address stack is your personal telephone directory.

As you're learning how to use the Address stack, you'll pick up a
valuable HyperCard skill—how to look for information by searching
for specific text rather than browsing from card to card.

Using the Address stack

The Address stack holds addresses and phone numbers. You look
for a specific name, address, or phone number using the Message
box.

= Open the Address stack and look for a name:

HyperCard comes with some sample Address cards; in this
exercise, you'll look for a card with the name Steve on it.

1. Click the button that looks like an address card.
The card in Figure 1-5 appears.

4]
=]

Figure 1-5
First card in Address stack

Using the Address stack 7



2. Choose Find from the Go menu.

The Message box appears near the bottom of the screen. (See
Figure 1-6.)

0 THe . i |
find 1 l

Figure 1-6
The Message box

3. Type Steve and press Return.

(:) The insertion point is already positioned between quotation
marks for you. (You have to type between quotation marks for
Spinning beach ball Find to work.) The pointer turns into a beach ball; it spins while

HyperCard looks for a card with the name “Steve” on it. The card
in Figure 1-7 appears.

velAaron
2260 Oak Creek Drive

Figure 1-7
Finding a card

* “It beeped at me!” If the Macintosh sounds a beep, reset the
Message box by choosing Find from the Go menu and once again
type what you want to search for. HyperCard beeps to let you
know it can't find what you ask for. Sometimes this means that you
speiled something incorrectly, and sometimes it means that what
you asked for isn't in the stack.
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HyperCard looks for the first card with text that starts with what you
typed, and puts a box around the word. Pressing Return again makes
HyperCard look for the next card with Steve on it.

m Look for part of a word or name:

HyperCard looks for what you ask, even if what you type is part of
another word. You can see this work if you type ST into the
Message box.
1. Reset the Message box by choosing Find from the Go menu
again.
Each time you choose Find, HyperCard highlights any old text
between quotation marks. The highlighted text will be replaced
by any new text you type.
2. Type ST into the Message box and press Return.
Press Return a few more times, and see the results you get.

Figure 1-8
Finding other words that start with ST

You can learn more about searching later by reading the section
called “Find” in Chapter 6.

Using the Address stack 9
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A quick browse/search recap

Find is another new way for you to get around in HyperCard. It's
different from the other ways in that it’s more specific—you have to
know what words you want to find in order to use it

You now know several ways to get around in HyperCard:
o dick buttons with the Browse tool

0 make choices from the Go menu

O search for a specific word using the Message box

Changing text

In this section you’ll change the information on one of the cards.
(In the next section you'll personalize the Address stack by putting
in the names and phone numbers of people you know.)

m Use the Message box to reach a card; then change the
card:

1. Choose Find from the Go menu.
When the Message box is already visible, choosing Find resets
the Message box, highlighting anything you've typed between
quotation marks.

2. Type Scribble and press Return.

The beach ball spins while HyperCard looks for a card with the
word “Scribble” on it. (Figure 1-9 shows the card.)

3. Select the name “Throckmorton” by dragging across it.

Dragging is a standard Macintosh technique that you're probably
already familiar with: Position the I-beam pointer at the
beginning of the word. Press and hold the mouse button while
you “drag” the pointer across the word. Release the mouse
button at the end of the word. If you've done this successfully,
“Throckmorton” is highlighted.

4. Type the name John.
The new name replaces the old one.

Chapter 1: Browsing and Editing



Name and address goes here...

..perhaps with a comment or two.

Phone number goes here.

Figure 1-9
Changing an address card

You can select any text (except Paint text, described in Chapter 6)
by dragging. Then type new text to replace it.

For more details on editing text, see the section on the Edit menu in
Chapter 6.

Adding a card

You can personalize all the cards in the Address stack by editing out
the old text and adding new text. But you'll probably find it easier to
create new cards to hold your information. You add a card to any
HyperCard stack by choosing New Card from the Edit menu. Try it
now.

m Add a new card to the Address stack:
1. Choose New Card from the Edit menu.

A new card appears, ready for you to add your own information.
(See Figure 1-10.)

2. Type your name and address.

3. Press the Tab key to move the insertion point to the phone
number line, and type your phone number.

The Tab key moves you from field to field on a card in the
Address stack. (A field is where you type text.) This card has three
fields—name and address, phone number, and date.

Adding a card 11
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4. Choose New Card again and add the name, address, and
phone number of some close friend.

Or, if you want to get down to business right away, type in contact
information for your neighborhood pizza delivery restaurant or
some other vital service.

1r

L/

=) {2

i 5

Figure 1-10
A new address card

Continue to add cards if you want. When you've finished, go on to
learn about how cards are arranged in a stack.

< Don’t worry about alphabetical order: You can create a new card
wherever you want in the stack. In a few moments, you'll
alphabetize the stack with the click of a button.

Il

How cards are arranged in a stack

When you choose New Card, HyperCard adds a new card to the
stack immediately after the one that’s on the screen.

If all the cards in a stack are created at the same time, they appear in
the order of their creation. If you choose New Card while you're
near the middle of the stack, that's where the new card goes—in the
middle of the stack.

Chapter 1: Browsing and Editing
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Arrow fo next card

Sort button

m Go through the stack one card at the time to see the
stack’s “natural order™:

1. Get to the first card in the stack by choosing First from the
Go menu.

2. Click the right arrow (the one that peints to the right, next
to the left arrow) to move through the stack, one card at a
time.

Eventually you’ll come to the new cards you created. (Most cards
in the stack are alphabetized; your cards will probably be out of
order.)

3. Keep clicking the right arrow until you come back to the first
card in the stack.

Think of the cards in a stack as being looped on a ring; when you
reach the end, you start over again. (See Figure 1-11.)

Figure 1-11
Cards ringed in a stack

4. Sort the stack by clicking the Sort button.

A dialog box appears with buttons for sorting by first name or last
name. (See Figure 1-12.)

Sort all cards of this stack according to:

First Name Last Name i Cancel '

Figure 1-12
Sort dialog box

How cards are arranged in a stack 13



Quick View button

Important

5. Choose Last Name to sort alphabetically by last name.
The beach balls spins while HyperCard completes the sort.

6. Go through the stack quickly by clicking the Quick View
button.
(Click the mouse to stop the display.) You'll see the new cards
you added sorted into their proper alphabetical place.

% Getting rid of unwanted cards: The Address stack comes with a
number of sample cards. You can eliminate the cards you don't
want: move to an unwanted card and choose Delete Card from
the Edit menu.

You don’t have to save your changes; HyperCard does it for
you automatically. As a result, there Is no Save command In
HyperCard. You'll read more about this in Chapter 6.

Explore the Help stack

Before you read any more of this book, explore the Help stack,
HyperCard’s ever-ready help system.

m Choose Help from the Go menu to get to the Help stack.
(See Figure 1-13.)

The Help stack briefly explains all of HyperCard’s features. It's not

only an extremely useful information source that's always available,
but also an excellent example of the kinds of things you can do with

HyperCard.

To use the Help stack, click one of the tabs along the card’s bottom.
(Each tab is actually a button.)

14 Chapter 1: Browsing and Editing
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Figure 1-13

Help stack’s first card

Click the Exit tab at the bottom of a card when you've finished using
Help; you'll return to the Address stack at the card that was on the
screen when you chose Help.

Recent: Seeing where you’ve been

When you used the Address stack, you saw how cards are arranged in
a stack—one after the other in a loop, as if they’re held together by a
ring. You clicked the left and right arrows to move from card to
card.

When you chose Help from the Go menu to get to the Help stack,
and later when you pressed the Exit button to come back to the
Address stack, you saw that you can move between stacks as easily as
you move between cards.

Recent: Seeing where you've been 15




Click any card to go to it.
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As you go from card to card and stack to stack, HyperCard
automatically keeps a record of where you've been. Recent shows
(in miniature) up to the last 42 cards you looked at. It's a great place
to go when you need to retrace your steps. (When you’ve passed
through more than 42 cards, the top row of Recent rolls off to make
room for a new row of cards at the bottom.)

m Choose Recent from the Go menu.
(See Figure 1-14.)

Figure 1-14
Recent

¢ Recent shows what you've seen: A stack might have hundreds of
cards in it, but if you looked at only three cards in that stack,
Recent shows only the three cards you looked at.

You can go directly back to any card represented in miniature in
Recent. Try it now.

Chapter 1: Browsing and Editing
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Go direcily to a card shown on Recent:
Click any card’s miniature picture.

(Each picture is actually a button.) You immediately go to that
card.

. Choose Recent again on the Go menu.

A rectangle encloses the image of the card you went back to.

. Click the image of the card you were on when you first

chose Recent.

What you've learned so far

In the short time you've used HyperCard, you've learned quite a lot,
Among other things, you know

O
]

]
m}
=
[m]
O

how to use the Address stack

how to get from card to card and stack to stack using the Browse
tool

how cards are arranged in a stack

how to see where you've been, and how to go back there
how to search for text

how to use the Home card as your base of operations

how to use several menu commands

You already know enough to use most of the stacks that come with
HyperCard and that are available for sale and for trade. (See
“Where to Get HyperCard Stacks” in the Preface for some specific
places to get more stacks.) Most stacks that require further
instructions have a card or two telling you what you need to know.

What you've learned so far 17



Browse tool

How to get there from here

Here's a quick summary of the ways you've seen so far to find your
way around HyperCard. They all come in handy at one time or
another.

Browse tool Click buttons with it to move to other cards.

Home Choose Home from the Go menu to reach
this graphical directory of stacks; then click
the button for the stack you want to go to.

Recent Choose Recent from the Go menu for a
pictorial summary of cards you've seen; then
dlick the picture of the card you want to go to.

First Choose First from the Go menu to get to the
first card in a stack.

Last Choose Last from the Go menu to get to the
last card in a stack.

Find Choose Find from the Go menu; then type
what you want to find and press Return.

< Not sure where the buttons are? Hold down the Command and
Option keys at the same time, and HyperCard lets you peek at
buttons on a card.

What to do next

You can continue to work with the Address stack; you can go on to
explore other stacks (Appendix B has a descriptive list of all the
stacks that come with HyperCard); or you can go on to Chapter 2 for
tutorials on customizing stacks to your own liking.

To explore more stacks or to go on to Chapter 2, be sure to start
from the Home card.

m Go back to the Home card.
You go back to the Home card by choosing Home from the Go
menu. (You'll learn more about the Home card in Chapter 3.)

* Another way to get Home: Anytime you see a picture of a house
on a card, you can click the house to go to the Home card.

Chapter 1: Browsing and Editing
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Customizing
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Chapter 2: Customizing

Sometimes the way a stack looks isn’t to your liking. The picture you
see on a particular card isn’t suited to your purposes, or a field is in
an inconvenient place or its text is in a font or style that you don’t
like. This chapter shows you how to use HyperCard's features to
customize cards and stacks.

% Customizing isn’t required: You don’t have to customize a stack
to use it. These tutorials are for people who enjoy modifying
things to meet their specific tastes. It's OK to leave stacks as they
are.

This chapter has two tutorials. The first, “Painting,” goes over some
of HyperCard's features for editing pictures. You'll learn how to

O copy pictures from one card to another
O edit the pictures you copy
O create new pictures using HyperCard’s painting tools

The second tutorial, “Authoring,” includes the basic elements of
stack creation. You'll learn how to

O create new stacks

O copy pictures, buttons and fields from existing stacks to your new
stack

O Move buttons around on a card

The tutorials are separate. If you aren't interested in authoring yet,
just do the Painting tutorial and go on to explore HyperCard.

Painting

HyperCard provides a variety of tools for changing the way a card
looks. Chief among these are the Paint tools; you use them to create
and to change pictures.

-
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Paint tool at work

Paint tools

Figure 2-1
Paint tool at work

Setting user level to see the Tools menu

You choose the tool you need from the Tools menu. To see the
Tools menu, you must tell HyperCard you're ready to use it.
(HyperCard keeps menus out of sight until you need them.)

You tell HyperCard that you’re ready to work with new tools by
changing your user level o., the User Preferences card. It's the last
card in the Home stack.

= Move to the User Preferences card of the Home stack:
1. Start from the Home card.
2. Choose Last from the Go menu.

The Last command brings you to the last card of the current
stack. The User Preferences card appears. (See Figure 2-2.)

Painting

21
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User Preferences

User Name: Prir Acme

User Level:

(O Browsing
@ Typing

) Painting
2 Authoring

() Scripting

Figure 2-2

User Preferences card

HyperCard has five user levels. Each level incorporates everything
from previous levels, plus adds new abilities. When you first start
HyperCard, you're at the Typing level. At this level you can wander

through HyperCard’s stacks and do searches, and you have the

ability to make changes to text.

Now you need to be able to use the Paint tools—an ability that
comes with the next level.

m Click the button labeled Painting.
(HyperCard stays at your new level until you change it, even if

you quit HyperCard and restart.) A new menu appears in the

menu bar.

Chapter 2: Customizing
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i User Level:

User Preferences

{ User Name: Primo Acme

Ignore this for now

More about these tools
in the next tutoriai.

Browse tool selected.
(It's the one you're
using now.)

Paint tools

i (O Browsing
i
i (O Typing
| @ Painting [ Power Keys
i (O Authoring
| O Scripting ’
; _;
= Rk
Figure 2-3

Changing user levels

Changing the way a card looks

You use the Paint tools on the Tools menu to change a card’s

picture.

Figure 2-4
Paint tools

Painting
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HyperCard comes with a stack specifically included for you to
practice your painting on, the Quotations stack. You'll go to this
stack using a command that's new to you—the Open Stack
command.

2 Get to the Quotations stack:
1. Choose Open Stack from the File menu.

The directory dialog box appears, letting you select the stack you
want to work with,

2. Select Quotations and click Open.

ol

» A quick diversion: The Quotations stack is a collection of
aphorisms and famous sayings. Guess the author of the
quotation; then click the “Who says?” button to see if you were
right. (Click it again to hide the answer.) When you want to stop
the game (or you run out of quotations), come back here.

Copying a picture from another card

Cards with pictures on them are visually more interesting than cards
with just text. You can add a picture to a card by copying an image
from another card, or by drawing a picture yourself.

Copying an image is a simple operation. To get some practice
doing it, you'll copy the images of a loaf of bread and a jug of wine
from a card in the Art Ideas stack; then you'll paste the images onto
a card in the Quotations stack.

® Copy an image from one card to another:

1. Start with the card in the Quotations stack that reads
“A book of verses underneath the bough.”

To find it, Choose Find from the Go menu, type book of
verses, and press Return. Your next step is to go to the Art
Ideas stack to copy pictures.

Chapter 2: Customizing
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Figure 2-5
Book of verses card

2. Choose Open Stack from the Flle menu.

The Directory dialog box appears so that you can choose the
stack you want to open. The Art Ideas stack is in the Idea Stacks
folder on the HyperCard Ideas disk. If you're using HyperCard
from 3.5-inch disks, you'll have to replace the Help disk
currently in the drive with the HyperCard Ideas disk. To do that,
click the eject button on the Directory dialog box and swap
disks.

. Select Art Ideas and click Open.
You're now at the first card of the Art Ideas stack.

. Move to the card labeled “Restaurants, Food, Reclpes.”

To get to this card, choose Find from the Go menu, type the
word Food, and press Return,
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Selection rectangle

Figure 2-6
Food card

5. When you find the picture you want, choose the Selection

tool on the Tools menu.

The Selection tool lets you select a part of a picture to work on.
(When you choose this tool, some new menu titles appear on
the Title bar; ignore them for now.)

. Drag diagonally across the images of the loaf of bread and

the bottle of wine to select them; then release the mouse
button.

The dotted lines move when you release the mouse button to
show that the selection is active. Don'’t worry if you select too
much; you can edit it later. If you make a mistake, choose Undo
from the Edit menu and start dragging again.

Start dragging here.

Release the mouse button
when you’'ve selected
what you want.
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Figure 2-7
Selecting a picture



Click here to go back to Quotations.

10.

. Choose Copy Picture from the Edit menu.

What you copy goes onto the Clipboard, a holding place for cut
or copied text and graphics.

. Choose the Browse tool from the Tools menu.
. Choose Recent from the Go menu.

Go back to the Quotation card by clicking its image on
Recent.
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Figure 2-8
Going back to the Quotations stack using Recent

11. Choose Paste Picture from the Edit menu.

12.

13.

The material you copied to the Clipboard is pasted to the
Quotation card. (See Figure 2-9.)

Drag the pasted plcture where you want it to go; then
click anywhere outside the picture to set it in position.

To drag the picture, move the pointer anywhere inside the
selected area, hold down the mouse button, and move the
mouse. If you make a mistake, choose Undo from the Edit
menu,

Experiment with the Paint tools to touch up your picture.

(See “Some Paint tool tips” in the next section.) It's OK to make
a mess; that's what this stack is for. You can’t hurt any other
stack while you’re in this one.
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Paste it here.
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‘l Who Says?

Figure 2-9
Pasting a copled image

You can paste as many pictures onto a card as you want. Use any of
the Paint tools to modify the picture, or paint your own picture from
scratch.

Using the Paint tools

This is a great time to experiment with the Paint tools.

L]
1

Chapter 2: Customizing

Add a new card or two to the Quotations stack:

. Select the Browse tool.
2.

Choose New Card from the Edit menu.
A new card appears.

. Type your favorite quotation on the left page.

Press Tab to set the insertion point at the top of the page.

. Click the Who Says button.

An empty box appears. (IU's actually a field—a place to hold
text—ready for you to type into.)

. Click inside the box and type the name of the quotation’s

source or author.

When you've finished typing, click the Who Says button again to
hide the box.

-
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This draws thin,
free-form things.

Draw lines with this.

This erases mistakes.

&

Double-click this
to choose a new
brush shape.

Use this to fill In
a closed shape

you’ve already

drawn.

The more you spray,

the more the pattern
shows,

6. Construct a picture on the right page using the Paint tools.
(See “Some Paint tool tips,” below.) You can borrow from other
stacks to do it. Don’t worry if your name isn't Rembrandt; this is
all just for practice (and for fun).

Some Paint tool tips

To select a Paint tool, just drag to the one you want on the Paint
menu and then experiment. Most tools start to work when you press
down the mouse button and drag, and stop when you releasc the
mouse button. Here are some tips on using Paint tools:

O Select a pattern from the Patterns menu to use with the Brush,
Bucket, and Spray tools.

O Choose Brush Shape from the Options menu and click the shape
you want. Each shape gives a different effect, so experiment with
them all.

O Use the Brush or Pencil for freehand work.
O The Eraser—erases.

Click to choose
a pattern for painting
or to fill in shapes.

O Use these tools to
=l draw clrcles, squares,
= rectangles, and other
O shapes.
[1—%—? — Choose a pattern

Y to work with these tools.
Figure 2-10

Using the Paint tools and Pattern menu
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Experiment with the other tools to see what they do.

%+ Convert menus to palettes: You can “tear off” both the Tools
menu and the Patterns menu so that you can have constant access
to them as you work. Just drag through them, past the bottom or
off to one side; then leave them where you want them. When they
get in your way, move them by dragging their top bars. Click
their close boxes to make them go away.

Figure 2-11
Tearing off a menu

Experiment time

Experiment for as long as you want with the Paint tools. Make a mess
on the screen. Create new quotation cards or modify old ones.
Practice copying graphics from other stacks.

% A quick cleanup trick: If your screen gets really messy and you
want to clean it up, double-click the eraser on the Tools palette:
Everything you painted gets erased. If you double-click by
mistake, choose Undo from the Edit menu.

-—
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You can read more about the Paint tools and what they do in the
“Tools Menu” section of Chapter 6, throughout Chapter 5, and in
the Menus section of the Help system.

B Go back to the Home card when you've finished
experimenting.

When you're ready, go on to the final lesson, Authoring, and learn
how to create stacks of your own.

Authoring

You've learned how to get around in HyperCard, and you've had
some experience in changing text and graphics on a card. In this
section you'll learn HyperCard’s real power—changing how things
work.

% You don’t have to be an author: It isn’t necessary for you to learn
how to change a stack radically in order to use HyperCard
effectively. You already have all the information you need to get
a great deal out of HyperCard. The rest of this chapter is for you if
have special needs that the stacks that come with HyperCard
don’t meet, or if you like to do things your own way.

You'll need to change your user level to become a stack author.

m Change your user level to Authoring on the User Preferences
card:

1. Choose Home from the Go menu.

If you've come here directly from the previous tutorial, the
Home card is probably already on the screen.

2. Choose Last from the Go menu.

You move to the User Preference card, the last card in the Home
stack.

3. Click the bufton labeled Authoring.

A new title—Objects—appears in the menu bar. (See
Figure 2-12.) You're now at the highest level that this guide
takes you to.

Authoring 31



Another new menu

(& File Edit Go Tools |Objects

i

User Preferences

User Name: Prim

User Level:
O Browsing
_ Typing

O Painting [ Power Keys

A high user level

To Do icon

(® Authoring

O Scripting |

/ i -,

Figure 2-12
Moving up to Authoring

Before you continue, go back to the Home card.

® Choose Home on the Go menu.

“» A browsing shortcut: You can get to the Home card from User
Preferences by clicking the right arrow (the one pointing to the
right, next to the left arrow at the bottom of the card). Here's
why: Home is the first card in the Home stack, and User
Preferences is the last card in the stack. Because you can think of
the cards in a stack as being on a ring, you can also think of the
first card in the stack as being after the last card. Try it.

Making a new stack from an existing one
You can make a new stack based on an old one.

When you make a new stack based on an existing one, the new stack
takes on the basic characteristics of the current card’s background.

In this exercise, you'll make a new stack based on the To Do card.
(You type all the things you've got to do today on the To Do card.)
® Move to the To Do card by clicking its icon.

The card in Figure 2-13 appears.
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You use the current stack’s
design for the new stack if
this box is checked.

To Do (>}
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Figure 2-13
A To Do card

You'll use the basic design of this card for your new stack.

m Create a new stack based on the To Dc stack:
1. Choose New Stack from the File menu.

The directory dialog box appears, asking you to name the new
stack. (See Figure 2-14,)

|;1 Hypert ard Stac ks]

- — _
| Js] — Harpo

| i )
} ( orive )
L J
=
New stack name: [ New |
My To Do Stack] | [ cancel )
‘—f;_j Copy current background
Figure 2-14

Making a new stack
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2.

Type My To Do stack and click New.

When you choose New Stack from the File menu, you can use the
basic design of the card that's on the screen for the new stack.
(You don't copy any of the stack’s data, just the stack’s template.)

You now have a new stack, ready for you to modify and to fill with
information. (See Figure 2-15.)

Figure 2-15
First card in new stack

Moving buttons

Customizing a stack is a matter of deciding what you like and don't
like about a design, and then changing the design. In this exercise,
you’ll change the design by moving a button around.

Move the Telephone button to the top-left side of the page:

1. Select the Butlton tool from the Tools menu.

(It’s the tool in the middle of the top row.) A box appears around
all the buttons on the card.

. Move the pointer to the center of the Telephone button,

and press and hold the mouse button.

-
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3. Drag the Telephone button to the left until it aligns with the
left edge.

4. Release the mouse button.

The moving dotted line around the button lets you know the
button is still selected. (When you click another button or when
you select another tool, the dotted line goes away.)

The top of the card should look like Figure 2-16.

Figure 2-16
To Do card with Telephone button moved

When you move a button, the only thing that changes is its position;
what the button does remains the same.

Deleting buttons

Sometimes the buttons you find in a design don’t do what you want.
For this exercise, assume that the only button you want at the top
right of the card is the Home button.

m Delete all but the Home button from the top of the card:
1. Select the Button tool from the Tools menu.
If you've been following along, you've already selected this tool.
2. Click the Address stack button.
The box around the button changes to marching ants.
3. Choose Clear Button from the Edit menu.
The button disappears.

4. Repeatl steps 1 and 3 for the rest of the butions you want to
remove.
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Copying buttons from another stack

In the Painting tutorial, you saw how to borrow pictures from other
cards to use on your own cards. You can borrow buttons in the same
way.

m Add a Help bufton by copying it from the Button Ideas stack:
1. Go to the Home card.

You can select the Browse tool, then click the Home button on
the top of the card you're on.

2. Click the Bulton Ideas icon.

(You might have to swap disks to get to this stack.) The card that
appears is actually an index.

3. Click Text Buttons.

The card in Figure 2-17 appears.
4. Select the Button tool.

Now you're ready to select a button and copy it.
5. Click the bulton marked Help.

When you're using the Button tool, you click a button to select it
rather than to make it carry out an action.

6. Choose Copy Button from the Edit menu.

7. Get back to your To Do card using Recent from the Go
menu.

Your To Do card reappears. Now you can paste the button you
just copied.

8. Choose Paste Button on the Edit menu.
The button you just copied appears.
9. Drag the button where you want it fo be.

A good place for it is next to the Home button. (See
Figure 2-18.)

10. Click the Browse tool to set the button in place.

Whenever you need help, you can click the Help button. (Try it
out, if you like. Press the Exit button at the bottom of any Help
card to get back.)

-—
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Figure 2-17
Assorted buttons

Changing a field's size and position

VY kil L You add text to a card by typing into fields with the Browse tool
S selected. The new To Do stack has three fields on it. To see them,
click the Field tool on the Tools menu.
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Figure 2-18
Help button pasted, fields visible
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You can change the size of a field or move it easily.

m Change the size of the field on the right:

1. With the Field tool still selected, click anywhere within the
card’s right field to select the field.

2. Drag the lower right corner of the field to the left to make the
field narrower.

Make it about 1/3 the width that it is now.

= Move the field you just changed by placing the pointer in its
center and dragging the field to the right.

Move it close to the right edge. (See Figure 2-19.)

Figure 2-19
Shrinking and moving fields
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Copying a field

Copying a field is as easy as moving one. And as long as you've got
the room. . .

m Make a copy of the field on the right:
1. Select the field on the right by clicking it.

You know it's selected because it’s surrounded by a moving
dotted line.

2. Choose Copy Field from the Edit menu.
3. Choose Paste Field from the Edit menu.

The pasted field is lying over the original.
4. Drag the copied field to the left.

Figure 2-20
Copying a field

You can also copy fields from other cards, just as you can copy
buttons and pictures.

Authoring
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Background is the name for
common elements shared by a
number of cards.

This is what you'd see

on the screen—a

combination of the background
and the part unique

to a given card.

All this is on the background.

40 Chapter 2: Customizing

Cards versus backgrounds

A number of cards can share the same background. When you
chose New Stack to create the stack you've been working on, you
copied the background of the card that was on the screen at the

time. Figure 2-21 shows a card with a distinct background part.

This part changes
from card to card.

Figure 2-21
A background shared by a number of cards

Buttons, fields, and pictures can live on the background of a card,
or on the card itself. When they’re on the background, these
objects—buttons, fields, and pictures—are shared by all cards
associated with that background. When they're on the card, they're
specific just to that card.

-
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No card field on this card.
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only on a specific card.

Figure 2-22
Background versus card fleld

To see what this is about, you'll first have to make a new card for the
stack you've been working on.

= Make a new card for the stack by choosing New Card from
the Edit menu.

You'll notice that the Help button you pasted appears just on the
first card—it wasn't duplicated when you chose New Card; and the
field you duplicated was only duplicated on the original card. You
created a card field and a card button, objects that work only on a
single card; contrast that with background fields and background
buttons, objects common to all cards that share a particular
background. (With the Browse tool selected, click the left arrow and
right arrow buttons at the bottom of the card to go back and forth
between cards.)
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no Help button on it. -
Copied button Molr

Duplicated field

Background has
only one field on it,

Figure 2-23
First card versus second card

The card on the right in Figure 2-23 is the one you just made with
New Card. Its features all come from the background.

m Look at the background for these cards:

1. Be sure you're on the first card in the stack by choosing First
from the Go menu.

2. Choose Background from the Edit menu.
The background appears. (See Figure 2-24.)

Diagonal lines tell you —M - R : g
that you're looking at S e Sdit bu _teile BUIRRS . o
s sk ewours, P

Figure 2-24
Background

If you switch back and forth between the background and the card
by choosing the Background command several times, you'll see
the button and the extra field disappear and reappear. (The
Background command is like a push-button light switch—if

you're looking at the card when you choose it, you switch to

the background; if you’re looking at the background when you
choose it, you switch to the card.) You can tell when you're in the
background because the menu bar in the background has diagonal
stripes.
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% You can edit background fields and buitons from the card: You
can make an existing background field or button smaller or
larger or delete it but you can’t create new background fields or
buttons unless you're in the background. That's why the field
you made smaller remains smaller when you look at the
background, and the buttons you deleted remain deleted.

To make a field, button, or picture common to a number of cards,
create it (or paste it or duplicate it) in the background.

You can move the duplicated field and the Help button from the
first card to the background. When you do that, the extra field and
the button will show on both cards, and on any new cards that you
create.

= Move the duplicated field and the Help button to the
background:

1. With the Field tool selected, click inside the duplicated
field.

Be sure you're on the card and not in the background—you
shouldn’t see any diagonal lines in the Menu bar.

2. Choose Cut Field from the Edit menu.
The field disappears.
3. Choose Background from the Edit menu.
The background appears—you see the diagonal lines again.
4. Choose Paste Field from the Edit menu.
The field reappears, now part of the background.
5. Choose Background from the Edit menu again.

You're back at the card—the diagonal lines in the Menu bar
have disappeared.

6. Select the Button tool and click the Help button.

You'll know it's selected because a moving dotted line
surrounds it.

7. Choose Cut Button from the Edit menu.

The button disappears.
8. Choose Background from the Edit menu.

The background appears—you see the diagonal lines again.
9. Choose Paste Buiton from the Edit menu.

The button reappears, now part of the background.
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10. Choose Background from the Edit menu a final time.

You end up with all buttons and fields in the background. To prove
it, create a new card.

m Choose New Card from the Edit menu.

The new card will have two fields on the right side and a Help
button at the top.

% A final note about fields: What you type on a field created in the
background changes from card to card, although the field’s size
and position remains constant on all cards associated with that
background. When you create a field on a card, the field stays just
with that card—and, of course, so does what you type in it.
Experiment by creating a few card fields in the stack you just
created to see what happens.

Experiment for a while

Continue working on this stack for a while. Make all the changes you
want. Don’t worry about messing things up; this stack is just for
practice.

m When you've finished experimenting, go back to the Home
card.

New Button button

44
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Connecting to the Home card

You've read here and in the first chapter that Home is your base of
operations. It makes sense, then, to put a button on the Home card
that gets you to the stack you just made. In this final exercise, you'll
create a new button for the Home stack, give it a2 name, and then
create a connection to your new stack.

m Create a link between the Home card and your To Do stack:

1. From the Home card, choose New Button from the Objects
menu.

HyperCard selects the Button tool and a button named New
Button appears selected in the middle of the Home card.

2. Choose Button Info from the Objects menu.
The dialog box in Figure 2-25 appears.

——
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Button Name: New Button ‘

Card button number: 21 style:

Card button 10: 77 (3 transparent

[ Show name () opaque

[ Auto hilite Orectangle
() shadow

P— ® round rect

ltw—",l (O check box

[WJ (O radio button

(“script... | ( ox ]] ("Cancel |

Figure 2-25

Button Info dialog box

3. Type Things to do Into the Button Name box.

The new name replaces the old name, New Button. (You'll find
details on the rest of this dialog box under “Button Info” in
Chapter 6.)

4. Click LinkTo.
The dialog box in Figure 2-26 appears.

EOr e

Go to destination, then aim link at:

('This Card ] [ This Stack | [ Cancel |

Figure 2-26
LinkTo didlog box
5. Choose Open Stack from the File menu.
The Directory appears.
6. Select My To Do Stack and click Open.
The first card in the stack you just created appears.
7. Click This Stack in the LinkTo dialog box.
HyperCard completes the link and returns you to the Home card.

8. Drag the new bution to a convenient place on the Home
card.
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9. Test your new button.

To do that, first select the Browse tool; then click the new bution.
You immediately go to your new stack.

[

Where to go from here

This ends your tutorials on HyperCard’s basics. You know enough
now to get off to a great start. You can go on reading in this manual
to learn more about HyperCard or you can go off on your own,
browsing and editing as you like,

® To use the Help stack to learn more about tools:
1. Choose Help from the Go menu.
This gets you to the Help stack from anypiace in HyperCard.
2. Click the Menus tab at the bottom of the card.
You'll see the Menus card.
3. Click the Tools menu and explore.

To learn about a specific tool, just click its icon. (See
Figure 2-27.)

Figure 2-27
Exploring with the Help stack

Happy wandering!
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Home is HyperCard’s central stack. Each of its cards holds
information vital to HyperCard’s performance. |

0O The first card, Home, holds buttons that take you to the most
important cards in your collection.

O ‘Three search path cards tell HyperCard where to find -
applications, documents, and stacks that you use frequently.
O The User Preferences card lets you customize the way you interact .
with HyperCard. ¥
Warning  HyperCard will not operate without a Home stack. Do not o
delete the Home stack.
-
Home card o
No matter what other cards and stacks you have, you always have
Home. Most people use it as their starting place for moving around. =3
You'll find the Home card most useful if you create a button on it
linked to each new stack and to each of your favorite cards.
]
Home Card 5
V,‘
=
File Index Book Shelf —
aj
T
Slide Show Hyper Cale -
t] e ,,
Stack Ideas Quotations L]
A 11:32AM ™
Figure 3-1
Home card 3
-~
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% Creating a graphic button for Home: To create a graphic button,
first paint or paste a small picture on Home representing the new
stack; then cover that picture with a transparent button linked to the
new stack. Or you can use icons as buttons by clicking Icon in a
selected button’s Button Info dialog box and choosing from the
icons that appear. You can also copy predesigned buttons from
the Button Ideas stack. “Copying Buttons From Another Stack” and
“Connecting to the Home Card” in Chapter 2, and “Icon” in
Chapter 6, provide step-by-step instructions for these procedures.

For information on linking buttons, see “Button Info” in Chapter 6.

Search paths

A search path is the route HyperCard follows to retrieve a stack,
application, or document. When you tell HyperCard to open
a file—by clicking a button on the Home card, for example—
HyperCard follows its own preset search paths to find the file.

o,

% Preset search paths: HyperCard first looks for the requested file
in the folder that's currently active; next it looks in the folder that
the Help stacks are in; and then it looks on the root level of the
directory—that is, on the current disk among the files that aren't
in any folders. Finally, it checks the search path cards to see what
route to follow.

If HyperCard can’t find a file you ask for, it displays a dialog box.
(See Figure 3-2.)

Ihere is lost stack?

[= HyperCard Stacks ]

£ |
‘ [ File Indey fiis

O Home

0O Jane's Graphics

| O Datebook B e J
(

| O Area Codes [,,.!
‘ [0 MAD Stack Eid Open |
I 1 masking demo

|

Cancel

) Phone s =2}

Figure 3-2
Dialog box for finding a file
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As you click your way through the directory dialog box to locate a
file, HyperCard records your path. Once you've located the file,
HyperCard notes the volume and folder (and if necessary,
subfolder) in which the file resides, and records it on the
appropriate search path card in the Home stack. The next time you
ask for that file, HyperCard will know where to look for it without
having to ask you to find it

HyperCard cannot work with a locked disk (or locked volume).
Make sure that any disk you want fo use is unlocked.

.

< Occasional housecleaning: HyperCard keeps a search path on
record until you erase it. It's a good idea to erase a search path
you use infrequently, freeing up that space on the search path
card. To erase a search path, just select it and choose Clear from
the Edit menu.

[

User Preferences

Set the User Preferences card to customize the way you interact with
HyperCard.

Figure 3-3
Setting preferences
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Click the proper user level to match what you want to do with

HyperCard. The higher the user level you choose, the more power

HyperCard gives you:

Short File and Edit menus (Figure 3-4), plus

the Go menu. Use of the Browse tool.

Same as Browsing, plus ability to edit text in

existing fields.

Same as Typing, plus full File and Edit

menus (Figure 3-4), Tools menu (plus Paint,

Options, and Pattern menus when a Paint
tool is selected), use of all Paint tools (but
not Button and Field tools), Power Keys

option.

Same as Painting, plus Objects menu, use of
Button and Field tools.

Same as Authoring, plus ability to type into
Message box while it's hidden (if the “Blind

Typing” option is chosen), plus ability to

write and edit scripts.

Browsing
Typing
Painting
Authoring
Scripting
" New Stack... Undo 82
Open Stack... 30 e s
Save a Copy... Cut $8H
Capy 3C
Page Setup... Paste Text &1
Print Card 8P Clear
Print Stack... e e
Print Report... New Card 3N
Delete Card
Quit HyperCard $8Q

Browsing and Typing get short menus.

Figure 3-4
Short and full File and Edit menus

)
Undo

New Stack... 382
Open Stack... $0

Save a Copy... Cut 38H
Compact Stack Paste Text 38U
Protect Stack... Clear

Delete Stack...

- s s New Card 3N
Page Setup... Delete Card
Print Card EP Cut Card
Print Stack... Copy Card
Print Report... B

: e Tealt Styla.., 57
Quit HyperCard 0 Background 3B

Painting, Authoring. and Scripting

get full menus.
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The Command key is marked by
a propeller-shaped symbol. On
some Macintosh keyboards, the
key also has an Apple symbol,
and some Macintosh manuals
might call it the Apple key. Both
names refer to the same key.

52 Chapter 3: Home

You can set one level now and change it to a higher one later, when
your HyperCard skills improve or when you feel comfortable
experimenting with more advanced abilities.

< User preferences and stack protection: The preferences you set
here apply in a general way to all HyperCard functions. The
tools and commands you have at your disposal while you're
using a specific stack, however, are based both upon the level
you set on User Preferences and on the specific stack’s
protection level. When a stack is set for a different level of use
than is set on User Preferences, the lower setting has
precedence. (Lower means “closer to Browsing.”) See “Protect
Stack” in Chapter 6 for details.

For information about power keys, see “Power Keys” in Chapter 5
and Chapter 6.

For details about the Message box, see “Message” in Chapter 6.

For more information on scripts, see the HyperCard Script
Language Guide.

Ways to go Home

HyperCard provides several ways to get to the Home card:
o choose Home from the Go menu

O press Command-H (Press the Command key and, while holding
it down, press H for Home)

O click the house icon that appears on most stacks

O choose Message from the Go menu, lype Go Home, and press
return.

All these methods work equally well.

-
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Field tool

hy

Browse tool

HyperCard has two kinds of text: Paint text and regular text. You
create Paint text using the Paint Text tool; you'll find details about it
in Chapter 6. This chapter covers regular text.

Creating regular text in HyperCard is a two-step process:
1. Use the Field tool to create the fields where text goes.
2. Use the Browse tool to type text into a specific field.

< Watch your preference level: To edit text in a field, you must be
at the Typing level or higher on the User Preferences card in the
Home stack. To create or change a field, you must be at
Authoring level or higher.

In the section “Fields,” you'll learn about the places where you type
regular text. The section called “Creating Text” tells you about
entering and editing text, and how to move it from one place in
HyperCard to another.

I

Fields

Fields are the boxes in which you type text. You can create
background fields and card fields. A background field appears on
every card associated with a given background. It has the same size,
shape, and position on every card; what changes from card to card
is the text in a field. Fields can be empty in one card, but have text
in another. A card field appears only on the card where you create

it (although you can copy a card field, and then paste it onto any
other card).

Chapter 4: Text in HyperCard
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No card field on this card.

Ld

_®Acme Dot Company

123 North St. Santa Clara, CA 94013

Name [Bernie Squire

Empl No. [234

|
Position: [Sales Rep e ]
]

) _I-: f —,{;l

Building: [D-3 Homestead

Telephone: [555-1736

|

ﬁ'ﬁ%ﬁ/¢'f&“

- Dot Company

|?ﬂ% 123 Morth St. Santa Clara, CA 94013

Background fields are
common to a number
of cards.

ErnpT No 1

Building [l

Telephone I 505
[

Name [Primo Acme |
Position: [President ] h
| .

Card fields appear only
on a speclfic card.

Figure 4-1
Different kinds of fields

You can have as many fields on a card or background as will fit.

Fields can overlap one another to any depth.

< Text can overiap, too: When fields overlap, the text within the

fields can also overlap if some of the fields are transparent.

Although you can create some interesting special effects this

way, you can also create quite an aesthetic mess. When you
overlap background fields and card fields, be sure to go through

each card associated with the background after you've entered

text to make sure things look the way they should.

Fields
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Move pointer here

Creating fields

You create fields by using the Field tool in the Tools menu.

and click.

Start where you want.

Drag diagonally
fo create a field.

The field pointer

Figure 4-2
Field tool in Tools menu

E To create a field:
1. Move to the card where you want the field to appear.

2. To create a background field, choose Background from the
Edit menu.

3. Choose New Field from the Objects menu.

A new field appears in the center of the screen. Alternatively,
move lhe pointer where you want the field to start; then press the
Command key and drag. (See Figure 4-3.)

4. Choose Field Info from the Objects menu and make selections
as appropriate in the Fields dialog box.
The Fields dialog box is described in detail later in this chapter,
5. Size the field appropriately.
See “Changing a Field’s Size,” later in this section. As you drag, a
dotted rectangle appears showing you how wide and how long the

field is; the lines in the rectangle show where the bottom of each
line of text will be.

is a crosshair.

Figure 4-3
Creating a new fleld by dragging
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The dotted lines go away when you choose another tool. The top-
left and bottom-right corners define the size of the field; the lines
going across show you the text lines within the field.

¢ Changing line spacing: You can change the amount of spacing
between lines by changing the number in the Height box of the
Text Style dialog box. See “Setting Text Properties,” later in this
chapter.

Important  The most common mistake In creating a field Is putting it on a
card when it's supposed to be on a background. Affer you've
created one or more fields, flip to the next card; if the fields
you've just created are on that card too, you've created
background fields.

Placing and moving fields

You can place a field wherever you want, including on top of
another field.

m To move a field:
1. Select the Field tool from the Tools menu.

The Field tool appears highlighted in the Tools menu, showing
you that it's selected.

2. Click Inside the field you want to move to select It.

The field becomes surrounded by dotted lines to show it's
selected.

3. Drag the field by its middle.

When the field is where you want it, release the mouse button. When
you move a field, any text you've typed moves with it. HyperCard
won't let you move any part of the field off the card.
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Changing a field’s size

You can change a field’s size whether or not it has text in it. When
you change its size, any text in it wraps appropriately to conform
to the new size. If you shrink the size of a non-scrolling field such
that there’s not enough room for all the text, text typed toward the
bottom of the field becomes invisible. (It’s still there, though; if
you enlarge the field, the text becomes visible again.)

Narrow field shows Short field makes

wrapped text. some text invisible.

Figure 4-4
Changing a field’s size

Changing the size or shape of a background field changes it on every
associated card.

B To change a field’s size:
1. Select the Field tool.
2, Click inside the field to select it.
The selected field is surrounded by dotted lines.
3. Drag the field from one of its corners.

You'll probably want to look through any cards affected by the field
change to see how the text looks.

Chapter 4: Text in HyperCard
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Deleting a field

You can delete a field whether or not it has text in it.

m To delete a field:

1. Select the Field tool from the Tools menu.
2. Click inside the field to select it.

3. Choose Cut Field from the Edit menu.

Choose Clear Field to eliminate the field without affecting the
Clipboard (or press the Backspace or Clear key).

Warning When you delete a field. you delete all its text along with if.
Nothing goes onto the Clipboard; It is all simply eliminated.
When you delete a background field, you irrevocably delete
text assoclated with that field in every card on which the field
appears. You cannot recover the lost text by choosing Undo
from the Edit menu.

Moving between fields

Knowing the position of a field on a card can be difficult
sometimes, Depending on the field style you've selected, empty
fields can be invisible when any tool other than the Field tool is
selected (although any text in them will still show).

B To move from one field to another in order to type text:
1. Select the Browse tool from the Tools menu.
2. Press the Tab key until you get to the field you want.

HyperCard first tabs through the background fields and then tabs
through the card fields of the current card.

When you click in a text-filled area of a field, the insertion point
appears wherever you click. When you click in an empty area of a
field, the insertion point appears at the start of that empty line.
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Tabbing goes from here...

Tab order and layers

Pressing the Tab key moves the insertion point to the field with the
next higher field number.

Initially, field numbers are in creation order. The first field created
gets the number 1, the second field gets the number 2, and so on.
(A pasted field is treated as a newly created field, no matter what its
number on the card or background from which it was copied or
cut.) If the insertion point is in field number 3 and you press Tab,
the insertion point moves to field number 4; if there are only three
fields, the insertion point moves from field 3 to field 1.

:{.Mm,\...qnd finally back to here.

| |

J"&i [ -
" M‘?-_ - ‘,u_-1 s ‘
...fo here... ,J |
) [ 5
Jtfohere.. S
Figure 4-5
Tab order

The layer is the order of the field relative to other fields on the
same card and background. When the visible card and background
have multiple fields, fields can lay over each other; the field created
most recently is ordinarily the topmost field, said to be on the front
layer. In Figure 4-5, field 1 is on the layer farthest away (or, if you
prefer, in the back), field 2 is closer, and the highest numbered
field, field 3, is on the frontmost layer. ‘The lowest numbered field is
always farthest away; the highest numbered field is always on the
frontmost layer (or in front). In fact, you can think of the field
number as being the field’s layer number.

= To see a field’s number:
1. Select the Field tool from the Tools menu.
2. Click Inside the field whose number you want to see.
3. Choose Field Info in the Object menu.
Alternatively, just double-click in the field.

Chapter 4: Text in HyperCard

-

-

-



This determines tabbing order.

Field Name: ) el

Bkgnd Tield numbetr

Bkgnd field ID: ? Styte:
lransparent
|Lock Text

opaqgue
Show Lines rectangle
Wide Margins shadow

e scrolling
Fonl...

(——

Scriplt... | DK ﬂ Cancel |

Figure 4-6
Field number, inltially determined by creation order

Changing field tab order

You can change the tab order among background or card fields by
changing the field’s layer. (Figure 4-5 in the preceding section
illustrates layers.)

m To change a field’s layer:

1. Select the Field tool from the Tools menu.

2. Click inside the field whose layer you want to change.

3. Choose Bring Closer or Send Farther from the Objects menu.

Each time you choose Bring Closer, the field gets closer to being
the frontmost layer (with a correspondingly higher field number);
each time you choose Send Farther, the field moves to a farther
layer (with a correspondingly lower number). And as the layer
order changes, so does the tab order.

Duplicating a field

Duplicating a field makes an exact copy of the field (but it doesn’t
copy the text in the field).

® To duplicate a field:
1. Select the Field tool from the Tools menu.
2. Select a field by clicking inside it.
A dotted line surrounds the field, showing that it's selected.
3. Choose Copy Field from the Edit menu.
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Type the name you want
for this field. (You can
change it any time

you want.)

4. Choose Paste Field from the Edit menu.
A copy of the selected field is created, laying on top of the
original. You need to drag the new field to where you want it.

5. Drag from within the new fleld.

» Duplicating a field doesn’t copy text: When you duplicate a
field, you don't duplicate the field’s text with it. To copy both a
field and the field’s text: First copy the field; then copy the text
and paste it to the new field.

Field names

Each field can have a name associated with it. You use field names
mostly for advanced HyperCard features such as constructing
scripts.

A field name can have any number of characters in it. You can use
any character in a field’s name,

® To name a field:
1. Select the Fleld tool from the Tools menu.
2. Select the field you want to work with by clicking Inside It.

3. Choose Field Info from the Objects menu (or just double-click
the field).

The dialog box in Figure 4-7 appears.
4. Type or change the field’s name; then press OK.

Field Name: |

Bkgnd field number: 3

: = Style:

Bkgnd field 10: 7 .
transparent

r A7) I
lock Teut opaque [

Show Lines “rectanale
qi
Wide Margins shadow

8 scrolling
Font...

;”76:’)“,’_ I
Script... L || Cancel

L™ — " |

Figure 4-7
Naming a field
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Choose one of these
styles for your field.

.0

% Script writers take note: If you change the name of a field, be
sure also to change its name everywhere else you refer to it. For
example, if you rename a field “Wrigley” and you use the old
name “Chester” in a script, the script won't work properly—it
won’t be able to find the field it needs.

Field styles

Fields can have five styles: transparent, opaque, rectangle, shadow,
or scrolling. You choose the style of a field by choosing an option
in the Field Info dialog box. (See Figure 4-8.)

% About scrolling: Scrolling adds a vertical scroll bar to the
selected field. You view text in a field with a scroll bar as you do
text in any scrollable Macintosh window. See the guide that came
with your computer for details.

Field Name: |Wrigley

Bkgnd field number: 2
'\M![s'-‘

Bkgnd field 1D: 16

- transparent
[ 1Lock Tent & opaque

| | Show Lines rectangle

[] Wide Margins shadow
scrolling

Font...

[ script... ﬂi‘ 0K ]‘ Cancel
e . -

Figure 4-8
Choosing a fleld style

You can change a field’s style even after you've typed text into the

field. Just repeat the steps you used to choose the original style.
Figure 4-9 shows examples of field styles.
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Background shows through
transparent fields.

64

. 0Opaque Shadowed

1 am that merry wanderer of the night
| jest to Oteron, and make him smile
when | g fat and bean-fed horse bequile, [
Neighing in likeness of g filly fosl:
And zometimes Turk in a gossip's bowl,
In the very tikeness of a roasted crab.

Scrolling field

Figure 4-9
Field styles

If you don't choose a style, HyperCard uses Transparent.

Lock Text

Lock Text protects the text in a field from being changed. When you
check this option on the Field Info dialog box for a selected field,
text within the field cannot be altered in any way. (The pointer
doesn’t change to an I-beam when it passes over a locked field.)

To uni~<k a field (and to allow its text to be altered), uncheck Lock
Text.

Wide Margins and Show Lines

Wide Margins and Show Lines are options you can check in the Field
Info dialog box for a selected field. These options give you more
control over the look of your text fields. Wide Margins, which works
best when the field has a rectangle or shadow style, leaves more
space in the right and left margins. (As a result, text takes up more
space.)

Chapter 4: Text in HyperCard
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These fields are the same size. ——

Shadow field,
wide margins

Shadow field,
no wide margins

Figure 4-10
Wide Margins

Show Lines lets you see where lines are as you type in text. Later, you
can click Show Lines again to hide the lines.

Show Lines in a shadowed
field with wide margins

Show Lines in an opaque field

ranshaw 1t's been 15 ranshaw, 1t been 19 year
jrars since Billingsbie werl nce Billingsbie went out f
i ‘j,‘” for the pizza. And the pizza And frankly, I'm not
| frankly, U'monot all that sure 311 that sure he's coming back

Crming back

Figure 4-11
Show Lines

Creating regular text

Regular text goes inside fields that you've created. To create text,
first you use the Browse tool to set the insertion point inside the field
you want; and then you type.
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Select the Browse tool
to start typing text.

of b

0

Browse tool

Important

Warning

Figure 4-12
Selecting the Browse tool

Use the Browse tool, not the Paint Text tool, for entering text In
flelds. Regular text is always editable in an unlocked field; Pcint
text, however, Is not editable once you have typed it and
clicked the mouse button.

Entering text

You use the keyboard to enter text in HyperCard. You must create a
field before you can type text. (See “Creating a Field,” earlier in this
chapter.)

B To enter text in a field:
1. Select the Browse tool from the Tools menu.
2, Click In the field where you want to type.

(The insertion point appears at the left edge of the line you
clicked on.)

3. Click where you want the new text to star.
Or select the text you want to replace.
4. Start typing.

Your new text is inserted at the insertion point, or replaces the
selected text.

When you tab to a field that already contains text, all the text
is selected. Typing at this point will wipe out all the old text In
the field, and replace it with what you type. To preserve the
old text, move the pointer where you want to begin typing.
and click.
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Text goes beyond the

Fields without text in them are sometimes invisible; unless you tab
to a field, or you want to type in a field that already has some text in
it, you'll have to estimate the field's position (or choose the Field
tool to see where all the fields are).

If you type more text than will fit in a non-scrolling field, the
remaining text goes off the bottom of the field. But this invisible text
isn't lost, it's just hidden. To see the hidden text, make the field
bigger.

years since Billingsbie
went out for the pi1zza went out Tor the g

And frankly, I'm nat all And frankly, I'm not all

Thnt aursibg eanetng That sure he's coming
kg :

bottom of the field
and Is hidden.

/

Same tfext in the same field.
but with the field size extended.

Figure 4-13
Revedling hidden text

Moving and copying text

You can move and copy text from one part of a field to another, or
from one field to any other field anywhere in HyperCard.

You use the same cut-and-paste techniques for moving and copying
text in HyperCard as you use in all Macintosh applications. See your
owner’s guide for details.

< Uneditable text: If you can’t edit text, check the Field Info dialog
box for that field to see if Lock Text is checked. If the field is
unlocked, or if the text exists outside of a field, you're dealing
with Paint text. To change Paint text, you must erase the old text
and create new text.
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Scroll to the font you want;
then click to select it.

Check one or more styles
for all the text in a field

Sefting text properties

You can determine how the text in each field looks by using the Text
Style dialog box.

m To set text properties:

1. Select the fleld you want to work with by clicking Inside It.
Either the Browse tool or the Field tool must be active.

2. Choose Text Style from the Edit menu.
The dialog box in Figure 4-14 appears.

3. Sel the propertles as you prefer.

You can set font, size, style, alignment, and line spacing (line
height).

(or check nothing for plain text).

The alignment you set
works on all lines in the
same field.

What you see Is
what you'll get.

68

Important

4. Click OK.
Click the size you want...
...ortype it here.
\ T | p—
__\“l"' Chicago Q | [ Ok j
Bold Couriet 10 R
Italit | Geneps T F Cancel
_lUnderline |yalvetica 14
Outline Monaco 18
L1 Shadow | New York
[[| [Jcondense Times Fine '
(Il CJExtend =l ””“ ht
L= *) Heigh
| Atign ﬁ_— - 1
S Left 12 |NRle
S Center
Right 3t
L / - |
/ This determines the space
between lines, In poinfs.
Figure 4-14

Text Style dialog box

The properties you set affect all the text within a field. You
cannot, for example, make a single word bold unless it’s the
only word In the field.
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Font

You can use any font that’s on your startup disk. You can see all the
available fonts by scrolling through the list at the bottom of the Text
Style dialog box. The font of the text you've selected is highlighted.

s To change the font, just click the one you want.

A sample of what your text will look like appears in a box at the
lower right. When you've finished with the Text Properties dialog
box and click OK, the selected text appears in the new font.

a To return to your work quickly, double-click the font you
want.

The dialog box closes immediately, and the selected text appears
with all the properties you've set.

Style

Text can appear in bold, italic, underline, outline, shadow, or a
combination of any or all of these. If the field you’ve selected has
text in any style besides plain, the appropriate boxes are checked.

m To choose a style, click the appropriate check box or boxes
In the Text Style dialog box.

An X appears in each box you've clicked.
m To cancel a slyle choice, click In the check box again.
The X goes away.

A sample of what your text will look like appears in a box at the lower
right. When you’ve finished with the Text Styles dialog box, click
OK; the text appears in the new style.

All text in a given field has the same style or styles.

Align

You can set the text in a field to align to the left side of the field, to
the right, or to be centered within the field. The same alignment
setting works for all lines within a field; you can’t set each line
separately.
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Point is a printer’s term; one
point is equal to about 1/72 of
aninch,

m To change the alignment, click the appropriate button.
A black dot shows in the button you've clicked.

When you dick the OK box and go back to your work, the text will be
aligned properly. '

Size
The box marked Size shows the size of the text in the field you've

selected. The number you see is the text’s size in points. Each
point is a single dot on the Macintosh screen.

% Preset size and style: When you start HyperCard, the preset size
and style is 12 point plain Geneva. The changes you make to size
and/or style remain in effect for all fields you create until you
change them or until you leave HyperCard. When you enter a
field you've already created, any new text takes on the size and
style of the rest of that field.

When you dick a font name in the Text Style dialog box, all the sizes
that you have in the System file for that font come up in the
scrollable window to the right of the font list; the closest one to the
actual size of the text in the active field is highlighted. (f you haven't
clicked on a font, the size you see is the size of the text in the active
field.) The highlighted size also appears in the Size box.

m To use a size other than the cne highlighted, scroll fo the
size you want and click it.

m To use a size not listed, replace the number In the Size box
with the size you want.

First select the old size by dragging across it in the size box; then
type the new one.

The highlighted size is the one that's closest to the actual size of the
text in the active field.

Height

Height is the space allowed for each line in a field, expressed in
points. The number you see in the Height box of the Text Style
dialog box includes space for the height of the characters and the
space between lines, plus a couple of points for slack. HyperCard
sets this number automatically when the font size changes; but you
can set it by typing whatever number you want.
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To change Height, replace the number in the Height box
with a new number.

First select the old number by dragging across it; then type the
new one. The new number replaces the old one.

m To make lines touch or overlap, set the Height size lower

&

than the Font size.
The exact number varies from font to font; experiment until you
get the effect you want.

Top line can get chopped: You might lose some of the top line if
you set the Height size below the Font size.

Summary

In this chapter you learned about fields and text in HyperCard. You
saw (among other things) that

a

(]
]
(m]

O

all regular text appears in fields
you create fields using the Field tool
you can create fields both on a background and on a card

fields can be enlarged or made smaller, moved, copied, cut,
deleted, and pasted

you enter text into fields using the Browse tool

O you can move, copy, cut, delete, and paste text

all text within a field shares the same properties—font, size,
style, alignment, and line spacing

Chapter 6 has more details about text and fields. See especially
“Print Report” for information on printing text in fields, and “Field
Info” to read about protecting a field’s text from being changed.
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This chapter presents an overview of HyperCard’s graphic elements
and shows how the different elements can work together. (Chapter 6
tells you what tools and commands you have at your disposal for
creating pictures.)

O “Menu Commands You Use With Graphics” provides a brief
frame of reference for using the Paint commands in different
menus to produce a finished picture.

O “Power Keys” gives details on special states and commands you
execute from the keyboard.

o “Double-Clicking Paint Tools” summarizes what happens when
you double-click on certain tools.

O “Dragging With Modifier Keys"” lists the effects of pressing
Command, Option, or Shift while you drag with different Paint
tools selected.

O “Special Effects” shows what happens when you combine several
features.

O “Importing Pictures” suggests ways to bring pictures into
HyperCard from outside sources.

Menu commands you use with graphics

To make finished pictures in HyperCard, you use commands from
several menus.

O To create the basic picture elements—shapes, patterns,
contours—use the tools on the Tools menu and the patterns on
the Pattern menu.

O To borrow pictures from cards that already exist in the current or
other stacks, use the Copy and Paste commands from the Edit
menu.

0O To bring in a picture you created someplace else using
MacPaint® or a MacPaint-compatible application, or that you
brought into the computer using a digitizing camera, scanner,
or some other peripheral device, use the Import command
from the File menu. (You can also bring in pictures through
the Clipboard and the Scrapbook.)

0O To create a picture common to several cards, use the Background
command.

0 To manipulate the picture and to do finish work—rotate parts of
it, bring up FatBits, and so on—use the commands in the Paint
menu.
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Power keys

When you choose Power Keys from the Options menu, striking a
single key does the work of selecting a specific menu command.

The Options menu is visible only when you've selected a Paint tool.

Table 5-1 shows a list of menu commands and their power-key
equivalents. (Each of these commands is described in detail in

Chapter 6.)

Table 5-1

Power keys

Command Key Menu
Darken D Paint
Draw Centered (on/off) C Options
Draw Multiple (on/off) M Options
Fill F Paint
Flip Horizontal H Paint
Flip Vertical Vv Paint
Grid (on/off) G Options
Invert I Paint
Lighten L Paint
Line size 1-4, 6, 8 Options
Opaque 0] Paint
Pickup P Paint
Revert R Paint
Rotate Left [ Paint
Rotate Right ] Paint
Select S Paint
Select All A Paint
Select black pattern B Patterns
Select white pattern W Patterns
Trace Edges E Paint
Transparent T Paint

Listed next are descriptions of a few power keys that need special

mention.

Power keys
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Power key P: Making a graphic cookie cutter

Power key P chooses the Pickup command in the Paint menu. It
works like a cookie cutter. You drag a source image (the cookie

cutter) over the image whose pattern you want to pick up (the cookie

dough). HyperCard uses the outline of the source image as the

cookie cutter. Pressing power key P is like pushing the cutter into the

dough—when you drag the cutter away again, it’s converted to the

pattern you moved it over.

1. This is the shape with
the pattern you want
to change.

3. Select the shape and
move it over the pattern.

[} ]

[l [
¥
5. Drag the shape away.
Figure 5-1

WA A LT
JIPD IR TN 1P A JI N
P

0 g
BI T
Id ald a a A

2. This is the pattern
you want to use.

1
i
o232
o232

3
Sy
o210
7Y
7%

2

4. Choose Pickup (or just
press P if power keys
are active).

Source Image picks up pattern of overlald image

Power key S: Tightening the selection

Power key S lets you lasso a picture that you've already selected with
the Selection tool. You can also press S to select an area you've just
drawn (or even erased) with another tool; once selected, you can
move it or fill it, or do whatever else you want with it.

Chapter §: Graphics in HyperCard
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Use the Selection tool
to grab the general area...

..press power key S to separate
the graphic wheat from the chaff.

Figure 5-2
Refining a selection

Power key § is especially useful when you want to select a specific
area quickly with no white space, or if your hand isn't steady enough
to use the Lasso tool with precision.

Power key T: Turning a graphic transparent

Ordinarily when you draw or paste a graphic onto a card, the
graphic is opaque—that is, it totally covers what it's drawn or pasted
over. Pressing power key T makes the graphic transparent so that
what it covers shows through.

Pasted opaque
(default choice)

!;" f’.
lr 'lf
\ HHE

K e

Pasted,
then power key T pressed

Pasted opagque with pattern

Pasted with pattern,

LB

¢ %

then power key T pressed

Figure 5-3
Opague and transparent images
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Double-clicking Paint tools

Double-clicking on certain Paint tools enhances using those tools.
Here's a list of the tools and what double-clicking does. (Chapter 6
tells you what each tool is for, and how to use it.)

Table 5-2

Effects of double-clicking Paint tools

Double-click ... Effect

Any pattern Bring up pattern editing dialog box
Brush Bring up Brush Shapes dialog box
Bucket Hide/show pattern menu

Curve Toggle Draw Filled command
Eraser Erase whole picture

Lasso Lasso every element in a picture
Lines Bring up line/border thickness dialog box
Oval Toggle Draw Filled command
Paint text Bring up Text Style dialog box
Pencil Set/cancel FatBits

Polygon Toggle Draw Filled command

Regular Polygon

Rectangle

Rounded Rectangle

Selection

Chapter 5: Graphics in HyperCard

Bring up shape selection dialog box
Toggle Draw Filled command
Toggle Draw Filled command
Select whole picture
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Dragging with modifier keys

Dragging with different tools selected has different effects,
especially if you're pressing Command, Shift, or Option at the
same time. Table 5-3 shows you what happens. Tools that aren't
listed aren’t affected by modifiers at all.

Shift

Option

Table 5-3

Effects of modified dragging

Tool Command

Selection Select tightly

Lasso Lasso everything

Line No effect

Eraser Erase in white

Pencil Get/leave FatBits

Rectangle No effect

Curve No effect

Brush Erase what you
paint over

Spray Erase what you
spray over

Rounded Rectangle  No effect

Polygon No effect

Oval No effect

Regular Polygon No effect

Move selection horizontal or vertical
Move selection horizontal or vertical
Draw at multiples of 15° angles

Erase straight horizontal or vertical
Draw straight horizontal or vertical
Draw square

No effect

Paint straight horizontal or vertical

Spray straight horizontal or vertical

Draw square with round corners
Draw at multiples of 15° angles
Draw circle

Rotate in 15° increments

Copy selection
Copy selection
Draw with pattern
No effect

No effect
Patterned border
Patterned border
No effect

No effect

Patterned border
Draw with pattern
Patterned border
Patterned border

Dragging with modifier keys
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Special effects

In many cases, holding modifier keys down in combination with
choices from the Options menu makes combinations of effects.
Experiment with different combinations to see what happens.

(Figure 54 shows some examples.)

¥

i
T—
ool

Select a part of a picture.

3

-

: ok

Lot
ARy

Use Command-Shift-Option-Drag

with Grid checked in the Options menu
to enlarge or shrink the selection
keeping the pattern consistent.

Draw Multiple
and Draw Fllled

Draw Multiple,
Grid on

Figure 5-4
Special effects
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Draw Multiple, with
Rectangle, Grid on
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Draw Multiple with
Line fool, Shiff key
held down

Draw Multiple with
Circle tool, Grid and
Draw Center on, Shift
key held down

Draw Multiple with
Line tool, Grid on
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Importing pictures

There are many products that create pictures compatible with
MacPaint. Some products let you create MacPaint pictures from
scratch, others let you digitize images using a video camera
attached directly to the Macintosh, and still others connect to the
Macintosh through an ImageWriter® printer. However you create
it, you can bring any MacPaint picture into HyperCard using the
Import Paint command on the File menu. Once you've imported a
picture, you can treat it as if you had created the imported image in
HyperCard.

< Try the Clipboard: Sometimes you might want to bring a non-
MacPaint picture into HyperCard—for example, something you
create using MacDraw or a similar application. Try copying the
picture to the Clipboard or to the Scrapbook first; then paste into
a HyperCard card.

Figure 5-5
Imported digitized image

% Built-in screen shooter: To take a quick snapshot of the screen in
nearly any Macintosh application, press Command-Shift-3. This
keyboard command, built into your Macintosh’s System file,
stores a picture of the screen on disk under the name SCREEN #,
where # is a digit from 0 through 9. (When you already have all 10
digits used, your Macintosh beeps and you can’t save more
pictures until you rename or erase some.)

Importing pictures 81
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Summary

In this chapter you saw how HyperCard’s graphic elements work
together. You learned

O which menu commands to use to perform specific tasks

O how to use power keys instead of menu commands to perform
certain functions, and about the unique effects of certain power

keys
O the effects of double-clicking Paint tools

O the effects of dragging with different Paint tools selected

O the special effects that happen when you combine different
elements

Chapter 6 gives details for using all the Paint tools in the sections
called “Tools,” “Paint,” and “Options.”

Chapter 5: Graphics in HyperCard
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Menu Commands
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General tools

Paint tools
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This chapter gives detailed descriptions of each command on all
the HyperCard menus. You can also find information on
commands in the Menus section of the on-line Help system.

% General versus Paint tools: Throughout this chapter you'll see
references to General tools and Paint tools. General tools are
those tools that appear on the first row of the Tools menu; use
them for general HyperCard tasks (browsing, creating buttons
and fields, entering text). Paint tools are all the other tools on
the menu; use them to create and edit pictures. For details, see
“Tools menu” later in this chapter.

Figure 6-1
General and Palnt fools

Menu items are described in the order that they would appear if
Scripting was checked in the User Preferences card of the Home
stack. (See “User Preferences” in Chapter 3.)

File menu

The File menu holds commands that save information to, or
retrieve information from, a disk. You can choose any command
on the file menu while you're using a General tool (that is, any of the
tools on the top row of the Tools menu); while you're using a Paint
tool, you can choose only Import Paint, Export Paint, or Quit
HyperCard.

Chapter 6: Menu Commands

Ll

-



Important

The different File menus

The level set on the User Preferences card of the Home stack, in
conjunction with the protection level set for a particular stack,
determines which menu appears when you press File. If either level
is set to Browsing or Typing, you choose a command from the short
menu (far left in Figure 6-2). Otherwise you choose from the full
menu (middle in Figure 6-2). While you're using a Paint tool, you
can choose only Import Paint, Export Paint, or Quit HyperCard
(far right in Figure 6-2) no matter how high your level is.

HEieH Eife} [FE]
New Stack... New Stack... ’
Open Stack... =0 Open Stack... =0 ‘
Save a (opy... Save a (opy...
Page Setup... Compact Stack } Import Paint...
Print Card #P Protect Stack... Export Paint...
Print Stack... Delete Stack...
Print Report...
Paqge Setup...
Quit HyperCard #0Q { Print Card #P ‘
Print Stack... :
Browsing and Typing - Prnt Report... ;

Quit HyperCard #0

Painting. Authoring.
Scripting Quit HyperCard »Q

Paint tool selected
Figure 6-2
File menus

For information on user levels, see “User Preferences” in
Chapter 3. For information on individual stack protection,
see “Protect Stack” elsewhere in this chapter.

See “Tools Menu” later in this chapter for a description of the tools.

HyperCard has no Save command. HyperCard automatically
saves what you create whenever you switch from one card to
another. To save your stack under a different name, use the
Save A Copy command.
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You use the old stack’s
design for the new stack
if this box Is checked.
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New Stack...

New Stack puts away the current stack (making sure that all the work
you've done is saved) and creates a new one.

When you choose this command, HyperCard puts up a Directory
dialog box and asks you to name the new stack:

i =, n’uFe}'i, ard Stac l:i]

Haipo

L |
L Dre ]
EA-V~‘

WL

Ne stack name: ) New

‘Smoke F fancel

S Copy current background

Figure 6-3
Naming a stack

If you click New with the box next to “Copy current background”
checked, HyperCard creates a new stack with the background fields,
background picture, and background buttons (including all actions)
of the last viewed card in the previous stack. If “Copy current
background” is unchecked, the new stack is blank.

To choose this command you must be using 2 General tool.

Open Stack...

Open Stack (or Command-O) opens an existing stack for your use.
This command brings up the Directory dialog box and waits for you
to select a stack. When you’ve made your selection, HyperCard
closes the stack you were working with and saves any changes you
made; then it gets the stack you asked for. The first card in the
summoned stack appears on the screen.

Chapter 6: Menu Commands
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< An Qpen Stack alternative: You can also open a stack by typing
Go stack name into the Message box and pressing either Return
or Enter. (You get the Message box by choosing Message from
the Go menu.) For example, to get to the Art Ideas stack, type Go
Art Ideas and press Return.

To choose this command you must be using a General tool.

% Where the stacks are: If HyperCard can't find a stack, it will ask
you to tell it where it is. If the stack is on a 3.5-inch disk, you'll
need to insert the disk into one of your drives. Stacks that come
with HyperCard are scattered among the HyperCard disks. See
Appendix B for a listing.

Save a Copy...

Save a Copy saves a copy of the stack you're working on under a
new name. (You continue to work on the original stack.) Use it to
preserve a stack in its unchanged condition while you experiment
with new variations.

[—=Fast tddie

T A2 Release Sl Tast fddie

| | _
| = Apphcations ‘ ]

Save a copy of stack in: Sape

Lopy ol fooB| |7 tancel

Figure 6-4
Saving a stack under a different name

HyperCard presets the name of the copy to “Copy of (original
stack name).” (The name is automatically selected; to change it,
just type the new name.)

To choose this command you must be using a General tool.
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Import Paint

Import Paint (available only when a Paint tool is selected) gets a
copy of a MacPaint-compatible document from the disk and pastes
it onto the current card.

When you choose Import Paint, the directory dialog box appears so
you can select a document using the hierarchical file system.
HyperCard pastes the imported document, starting at the imported
document’s upper-left corner, onto the card.

< Some picture prepping: You might want to do some preparation
work on a document before you import it. Make sure the part of
the document you want to paste is in the document’s upper-left
corner before you bring it into HyperCard. (You can't scroll
documents in HyperCard).

For complete information on graphics in HyperCard, see “Paint
Menu,” “Tools Menu” and “Pattern Menu” later in this chapter,
and Chapter 5, “Graphics in HyperCard.”

Export Paint

The Export Paint command (available only when a Paint tool is
selected) takes a snapshot of the current card and saves the snapshot
as a MacPaint document.

Export Paint creates a MacPaint document from the card on the
screen and saves it to disk under the name you give it. The image of
the full-sized card gets saved, even if you're using FatBits. If
Background is checked in the Edit menu, just the background
picture is saved.

HyperCard exports only card and background information. If you
have a tear-off menu on the screen, its image isn’t included with the
exported picture.

You can’t save buttons and actions using Export—you only save
an image of what’s on the screen (including images of buttons
and text).

Chapter 6: Menu Commands
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For complete information on graphics in HyperCard, see “Paint
Menu,” “Tool Menu” and “Pattern Menu” later in this chapter, and
Chapter 5, “Graphics in HyperCard.”

< Quick exporting: To take a quick snapshot of everything on the
screen (including the menu bar and any torn off menus), press
Command-Shift-3. This keyboard command, built into your
Macintosh’s System file and available any time, saves a picture of
the screen under the name SCREEN 7, where 7 is a digit from 0
through 9. (When you already have all 10 digits used, your
Macintosh beeps; to make room for more, go to the Finder and
rename or delete some of the snapshots.) You can use this
shortcut in almost any Macintosh application, and later import
the picture into HyperCard using the Import Paint command.

Compact Stack

This command (available only when Painting, Authoring, or
Scripting is checked in the User Preferences card of the Home stack)
gets rid of free space in a stack. Free space gets introduced into a
stack each time you delete a card, background, field, or button; the
more free space in a stack, the slower and larger the stacks.

To see the amount of free space in a stack, look at the number
following the words “Free in Stack” in the Stack Info dialog box.
(Stack Info is an item in the Objects menu, available when
Authoring or Scripting is checked on the User Preferences card.)

To use this command, you must have a General tool selected.

Protect Stack

Protect Stack sets levels of protection for the information in, and
design of, the current stack. Use it to keep your personal stacks
private, or to limit the way people can use or change your stacks.
Choosing this command brings up the dialog box in Figure 6-5.
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Protect Stack: Limit user level to:
(O ctan't delete stack (. Browsing
{_»Typing
{: Painting
i Authoring
[ Private Access ©; Scripting
[ set Password | |[: 0K :\| [ Cancel |

Figure 6-5
Protect Stack dialog box

Can't delete stack
When this box is checked, you can't delete the stack.

Private Access

When this box is checked, you must type the proper password (as
determined by Set Password, below) before HyperCard lets you use
the stack at all.

Set Password

Click this button to set or change a password. You set a password
to restrict access to the Protect Stack dialog box (thus preventing
unauthorized changes) or to restrict access to the stack. The dialog
box in Figure 6-6 appears.
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/®u sent Iil%
These would match OK. —< Uerify ne ;llg;;(‘mr? mere

Warning

Enter new password here:

Iim’ sent mel __ ]

Uerify new password here:

I None | ﬂ 0K U ‘_[_dl_uol'

Figure 6-6
Password dialog box

Type the password you want to use into the “new password” text box;
then press Tab to move the insertion point to the “verify password”
text box, and type the password again to verify it.

Click None to cancel the password and to put the dialog box away.

When you use the password later, it must match character-for-
character the one you set. (Uppercase and lowercase letters don’t
have to match.)

Enter new password here
[

These don’t match!

\®n sentm

None

Figure 6-7
Matching and nonmatching characters

When a password is set, you can't get to the Protect Stack dialog box
without knowing the password. When Private Access is checked, you
must know the password to use the stack at all.

There's no way fo find out a password once it's been set. If you
forget the password, you cannot get fo the Protect Stack
dialog box again. If you've checked Private Access and you
forget your password, you won't be able to use the stack again
once you leave It.

File menu Q1



Limit user level

The box you check here limits the commands and tools a user can
employ within the current stack. When a limit you set here conflicts
with a limit set on the User Preferences card of the Home stack, the
lower of the two levels takes precedence. (Browsing is the lowest
level.) Table 6-1 shows the powers inherent in each level.

Table 6-1

Powers associated with each user level

Browsing

Typing

Painting

Authoring

Scripting

ew Stack...
Open Stack... #0
Save a (opy...
Copy #(
Page Setup... Paste Tent =0
Print Card #=P Cleat
Print Stack... i
Print Report... | New Card  #N
\ Delete Card
Quit HyperCard #(Q

Browsing and Typing get short menus.

Figure 6-8
Short and full File and Edit menus

92 Chapter 6: Menu Commands

Short File and Edit menus (Figure 6-8), plus
the Go menu. Use of the Browse tool.

Same as Browsing, plus ability to edit text in
existing fields.

Same as Typing, plus full File and Edit menus
(Figure 6-8), Tools menu (plus Paint, Options,
and Pattern menus when a Paint tool is
selected), use of all Paint tocols (but not Button
and Field tools), Power Keys option.

Same as Painting, plus Objects menu, use of
Button and Field tools.

Same as Authoring, plus ability to write and
edit scripts.

New Stack... | Undo a2

Open Stack... #0

Save a (opy... Cut £H
Copy £

Compact Stack Paste Teut s
Protect Stack... (lear
Delete Stack...

New Card £N
Page Setup... Delete Card
Print Card P Cut Card
Print Stack... Copy Card
Print Report...

l Quit HyperCard ®Q Background B

Painting. Authoring, and Scripting
get full menus.
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Important

When you restrict a user’s level to Browsing or Typing. Protect
Stack doesn’t appear on the File menu. (See far left, Figure 6-8.)
To get a full File menu no matter what the user level is set fo
(either In Protect Stack or on the User Preference card). hold
down the Command key before you drag through the File menu.

% Card and background protection: You can also protect each
card or background individually by checking the proper box in
the Card Info or Background Info dialog boxes. See “Card Info”
and “Bkgnd Info” elsewhere in this chapter, for the details.

Delete Stack

Delete Stack (available only when Painting, Authoring, or Scripting
is checked in the User Preferences card of the Home stack) removes
all the cards, background pictures, background buttons, actions,
and fields of the current stack. It’s as though you had dragged the
stack to the Trash in the Finder. Use it when you have no further use
for a stack.

HyperCard first asks you to confirm the deletion. After the stack is
deleted, you end up at the Home card. (See “Home” in Chapter 3.)

. iy
1987 B
S

Janua| == b= &

Delete all 56 cards from stack
Harpo:HyperCard Stacks:Datebook ?

Cance!

W11 12 13 14 15 16
17 15 19 20 21 22 o3
Pl Il e - e B 11

3
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Februa

19 16 17 12
. S m

LLZF A8 LA 17 LR

PRI |

BLRULAIER

24000000

)
o
b
ﬂ‘?ﬁ
]
N
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P
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Loid a5 June
TR o910 1t 12 1z
16 17 13 19 0

2 25 26 27

March ! ¢ 3 4 % & 7
CI R ULES DU A EA B

EEIPE IR R R R

EXBEV I

/B0

]

4
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A
g

Figure 6-9

Dialog box for deletfing a stack

To choose this command you must be using a General tool.
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Page Setup

Page Setup lets you set paper size, orientation, and certain effects
for printing. You see this dialog box:

=

Imagelliriter S I: 0K |

Paper: @ US Letter A4 Letter ) .
i1 US Legal ) International Fanfold | cancel |
3 Computer Paper : ’

Orientation Special Effects: [ i

R 0

(O No Gaps Between Pages

LaserlWriter Page Setup

Landscape printing icon

94
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Paper: @ US Letter ;A4 Letter Reduce or W ﬁ]
3US Legal i BS Letter Enlarge: " ante
Orientation Printer Effects: Options

Crein )

1 T (JFont Substitution?
! (J smoothing?
[ faster Bitmap Printing?

Figure 6-10
Page Setup dialog box

< LaserWriter smoothing or flipping slows printing: If you're
using an Apple LaserWriter® with Smoothing checked in the
LaserWriter Page Setup dialog box, or with any of the flipping
options checked, printing is slowed down considerably. Print
a sample with Smoothing unchecked first to see if the results are
acceptable.

If you select the landscape printing icon for horlzontal printing
on your LaserWirlter, be sure to choose Faster Laser Printing. If
you don't, printing a stack will be extremely slow.

< Some LaserWriter printing features don’t work: The Reduce or
Enlarge feature doesn’t work for any printing in HyperCard. The
Invert option works correctly only when Fast Laser Printing is
turned off, but it takes an extremely long time to print.

To choose this command you must be using a General tool.
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Click here to change the
number of cards that will
appear on the page.

Print Card

Print Card (or Command-P) prints the current card using the
specifications you gave in Page Setup (except that cards are printed
full size, no matter what reduction or enlargement you specify). Use
it when you need a hard-copy version of any single card in any
HyperCard stack. To print all the cards in a stack, use Print Stack
(described immediately below).

To choose this command you must be using a General tool.

Print Stack...

Print Stack prints all the cards in the current stack in linear order.
(With a LaserWriter, Print Stack prints the cards in reverse order 50
that the first card is on top of the pile in the output tray.)

To choose this command you must be using a General tool.

Print Stack brings up a dialog box. (See Figure 6-11.)

[ F
Print Stack... ) ‘,T ==
[ Manual paper feed [npies:{f.] .
> - print T
D Fast laser prin ing @]
T e Gt E
PaooEam [ No space between cards
csfeDEm
EE & T0 M ' Print one card per page
j= i@ Print full size cards
7 Print half size cards
ey i Print quarter size cards
| e e
s MRS ® Standard format
EE ST oW T Split-page format
W .
Header: &3 B) 52
: - =

Figure 6-11
Print Stack dialog box
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Manual paper feed

Check the box labeled “Manual paper feed” if you're feeding the
paper by hand; HyperCard will stop the printer after each sheet and
wait for you to add more paper.

Fast laser prinfing/Darker printing

Check “Fast laser printing” on a LaserWriter printer to speed up
hard-copy production. It's recommended for most printing jobs.

If you select the landscape printing icon In the Page Setup
dialog box for horizontal printing on your Laserwriter, be sure to
check “Fast laser printing.” If you don’t, printing a stack will be
extremely slow.

Check “Darker printing” on an Apple ImageWriter printer to print
darker (useful if your ribbon is old).

Click “No space between cards” to print cards close together (for
printing two cards or more per page).

Cards printed per page

Click one of the four choices to determine how many cards are
printed per page. Look in the minipage window to see how many
cards fit on a page. (The number varies with the options you've
chosen.)

Page formats

“Standard format” and “Split-page format” determine how cards
are spaced on a page when you print a stack.

“Standard format” prints cards evenly spaced on the entire page.
This choice leaves enough room on the left edge to put binder holes
in the printout.

“Split-page format” is for sheets that will be kept in a minibinder; it
spaces cards so that the printed sheet can be folded down the
middle without creasing any card’s image.
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Standard format leaves room
for binder holes on the left side
of the page.

— Punch holes at top
and bottom...

—...and fold page on
dofted line to
prepare split-page
printouts for
mini-binders.

1
kl@"‘
@® Standard format (s standard format R /%

) Split-page format i® Split-page format

Figure 6-12
Standard format and Split-page format

Header

Tab to the Header box and type what you want to appear as a
heading at the top of each sheet. Click the proper icon(s) after you
tab to add page numbers, the date, the current time, and/or the
stack name to the header. Click icons in the order you want them to
appear in the heading. (Use the space bar to separate them.) You
can preview what the header will produce by looking in the
minipage window.

Format remembered

Once you print a stack, HyperCard remembers the format and
header you used for that stack so you can use the same setup next
time you print.
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Print Report

Print Report gathers text out of fields from the cards in a stack and
prints a report, using the design you specify in the Print Report
dialog box. Use this command to get printed summaries of your
stacks in a form most useful to you.

To choose this command you must be using a General tool.

% Reports are based on a single stack: Each report is based on
information from a single stack. There is no way to combine
information from two separate stacks into a single report.

When you choose Print Report, the dialog box in Figure 6-13

appears.
You can print up to 99 copies \
Print report... EDpies:E firrange fields in:
Click In here to feed sheets (] Manual paper feed () Labels
one at a time Darker printing ® Columns
i O ROWs: b
For ImageWriter only e e N M o R
: : : ; Print text fields from all cards:

i ! ! cointhe entive siagk

@ With the current background

; Which fields:

(<] Selected background fields:

i area code

f ! time zone

i : i region
Click here to add page number, — focations
time. date, and/or stack name - —* Print the names of;

Header: &Fn ) B < [ Cards (d Fields
What you type here goes L'/ = <|
af the top of every page
Figure 6-13

Print Report dialog box

You can print reports in three formats—labels, columns, or rows.
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Table 6-2

Here’s a list of alternatives showing the various combinations of
fields that can appear in your reports. (You can use only the last
alternative for the column format.)

O all card fields in the stack

O all background fields in the stack

O all background and all card fields in the entire stack

o all card fields from cards with the current background

O all card fields from cards with the current background, plus all or
some of the current background fields

o all or some fields from the current background

To a print a report based on one of these alternatives, you must click
buttons and check boxes on the Print Report dialog box in the
proper combination.

Table 6-2 shows you those combinations.

Controlling the printout of a report

To print... Click this radio button ..and.. Check only these boxes
All card fields in entire stack @ In the entire stack X Card fields

All background fields in entire stack @® In the entire stack X Background fields
All card fields & all background fields  ® In the entire stack & Card fields

in entire stack

All card fields of cards with current
background

& Background fields

@ With the current background Card fields

*Selected background fields of cards @®© With the current background X Selected background fields

with current background

All card fields and selected background ® With the current background X Card fields
fields of cards with current background Selected background fields

*This is the only format available for printing in columns.
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When you check “Selected background fields,” you activate a
selection box from which you select fields to print from the current
background.

m To select a field, click iis name.

Use the Scroll bar to look through the list of field names.

m To select more than one field, hold down the Shift key as you
select each name.

m To deselect a field, click itls name.

m To deselect a field when more than one are selected, hold
down the Shift key as you click.

Field printing order

The order in which you select fields determines their printing
order. On labels, the first field you select goes on the top line of the
label, the second field goes on the second line, and so on. In the
column format, the order in which you select fields determines
their lefi-to-right printing order. In the row format, the first field
you select goes on the top line of the card block, the second field
goes on the second line, and so on.

Labels

Clicking this button makes HyperCard print the fields you've
selected in a format suitable for labels. Each label contains text
from the fields of one card. HyperCard automatically centers the
text in each label.

You can change the number of labels per sheet and the size and
spacing of the labels by dragging on the highlighted parts of the
dialog box’s minipage window.

As you change the dimensions of labels by dragging in the
minipage window, HyperCard shows you the maximum number of
labels that will fit on a page. Changes you make in the position or
size of the labels are reflected in the measurements at the bottom
of the window; use the numbers that appear there as a guide. See
Figure 6-14.
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Drag here to change
size of labels.

Field name appears here.

Drag here to control number
of labels on each sheet, plus
the spacing between labels.

Important

Figure 6-14
Print Report in label format

If text on a line in a field is too wide for a label, HyperCard wraps the
text onto the next line, If there are too many lines to fit on a label,
HyperCard prints what will fit.

% About LaserWriter labels: Only use labels made especially for
LaserWriters or photocopiers. Check “Larger Print Area” under
Options on the Page Setup dialog box for better centering of text
on the labels that run along the left and right edges of the page.

% About ImageWriter labels: Use labels that are on 8.5-by-11-inch
tractor-feed pages.

Columns

In the column format, selected fields from the current background
are printed side by side in vertical columns across the page. Each
field has its own column. (See Figure 6-15.)

You must have “With the current background” checked for
the column format tfo work.,
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If a column is too narrow for the entire contents of a field to fit on
one line, HyperCard wraps the text to new lines as appropriate.

HyperCard won't let you select more fields than will fit across the
page. You can see how many will fit by looking at the minipage
window.

You can control the horizontal width of each column by dragging
the dashed separation lines.

If you check Cards under “Print the names of,” card names appear
in their own column on the far left. If you check Fields, field names
are printed across the top of the page above the appropriate
column. If a column is too narrow for the entire field name to fit,
the field name is truncated.

Casg hame Name and Addrass RANA

Card 1 Steve Aaron 555-7836 22387
2260 Oak Creek Drive

Card 2 Katie Aichler 555-484 2i23-8
8424 Middletieid Road

Carc 3 Martha Belion 555-0834 22387
8495 Jefferson St

Card 4 Marti Belisle 555-8203 5:268/3°
3703 Maude Ave

Card 5 Roger Benrey 555-3005 223
9541 Mount Vernon Dr

Card 6 Loween Blank (214) 855-5456 2:23:87
6586 Martin Ave

L e >
\\\\‘ Prainie, T L:;3§ /’,/\\\ //’/
=< -7 AN - . R4
S~ H)\”)” AN e S e
\\\\’/, \\\B&"/ \\\////

Figure 6-15
Print Report in column format

Rows

In the Row format, information from each card is printed as a
block. Fields read vertically down the page for each card.
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The 3 row layouts

You can choose among three different layouts to determine the
sequence of printing, and the amount of space across the page
that’s allocated to each block.

If you click on the left layout, each field's information is printed
across the width of the page, each field below the previous one.
With the center and right layouts, HyperCard prints blocks of
information for two cards side by side. (See Figure 6-16.)

Here are the layouts.

Drag here to change

printed field width.

] M2
[Z1[4] [E][4]

The numbers refer to card
position in the stack

Print report...  Loples:ju Arrange fields in:
| Manual paper feed [T Labels .
ODarker printing Columns -
1 1 T 1 |2 |
o) Rows: IR 1=
' (2] [EE] 2R
: Print teut fields from all cards:
In the entire stack
e UWith the current background
lWhich fields:
| ardd fields
JCard fields h
Selected background rields:
Print the names of:
Header: [ [B) 58 LlCards (] Fields

Figure 6-16
Print Report In row format

The card sequence in which the information is printed depends on
the layout order you select. If you select the layout order in the
center, reports appear beneath each other in the left column until
page bottom; The next card's report appears at the start of the right
column. If you select the layout order on the right, the block reports
alternate left-right down the page. (See Figures 6-17 and 6-18.)

If you check Fields under “Print the names of” the name of each
field is printed to the left of the field’s contents. (If the field is
empty, HyperCard skips it and doesn't print the field's name.) You
can grab the vertical dotted line and drag it to adjust the width for
the name. Card names are printed at the top of each card’s block.

Card blocks are printed in the order that the cards appear in the
stack.
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Cardt

Steve Aaron

2260 Qak Creek Dave
555-7806

Card Name:
Name and Address,

Phane Number

Phone Number:

Date 2:123187 Date:
Carg M Card 2 Card Mame:
harne AUressT  Kalwe Achior Name and Addrass
G424 Middieheld Road
Mumbear 5584844 Prone Mumber:
2/23/87 Date
Card 3 Card Namie

v andd Address:

Liartha Belion
8485 Jellarson St

Name and Address:

hone Mumber 555-0934

Date 2/23/87 Phone Number;
Date

Card Nama: Cad 4

Mamw and Address:  part Belsste Card Nama

3703 Maude Ave MName and Address

Cad 10

Emmelt Cardenas
1519 Shornt Strcet
555-8487
2/23/87

Card 11

Joshua Carlson
6221 Elliat Street
555-31¢9
2123/87

Card 12

Kart Daly

1664 Lundy Ln
Christe, Texas
(512) 555-8745
2123187

Card 13
Annette Darling

Phone MNumber 555-8203 N\ 43C Ohio Ave
P AN Bristol. Pennsyivan:a
Date 5/26/87 < s
\\\\ 1ere PRy th;-" \\ (215) 555-0586 ="
S~ame. Carr” S~o e \ 2023187 ="
Sggress. P . s N T
~o” \...,/ N~
Figure 6-17
Print report in row format, top to bottom order
Card Mame: Carg 1 Card Name: Cerg 2

Name and Addrass:  Steve Aaron

2260 Oak Creek Drve

Name and Address:

Phone Mumber: 555-7806 Phone Number:
Nate 2/23/87 ' Date:
Card Name: Card3 Card Name:

Mame and Address  Martha Belion

8495 Jellerson St

Name and Address:

Phone: Numbcr £55-0934 Phone Number
Date 2:23/87 Date
Card Hame Card5 Card Name

tame and Aitdress:  Roger Benrey

8541 Mount Vernsn Dr

WName and Address

Kalie Aichiar

9424 Middielieki Road
555.4844

2123/87

Card 4

Mani Belisle

3703 Maude Ave
555-8203
5i2687

Card 6
Loween Blank
6686 Martin Ave

Plione Number 555-3005 Praitic, Texas
Date 2123/87 Phone Number (214) 555-5456
Date 2/23/87

Card Mame Card 7 Carg Name: Caid8

tame and Adidress’  Richard Boyd AN Name and Address”  Shannon Brewne
N 6686 Black ).'.055:/ AN 7814 Clive Ave

S Mumbar 555-5080 e Prone Numye”™s_ ~ 555-1765 7

T 2:23:87,+7 .. Dae o7 2387 T
-~, N,
\‘\\//’ \\r” \\\z”’

Figure 6-18
Print report in row format, left to right order
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Manual paper feed

Check the manual paper feed box if you're feeding paper by hand;
HyperCard will stop the printer after each sheet and wait for you to
add more paper.

Header

Tab to the Header box and type what you want to appear as a
heading at the top of each sheet. Click the proper icon(s) after you
tab to add page numbers, the date, the current time, and the stack
name to the header. Click icons in the order you want them to
appear in the heading. (Use the space bar to separate them.) You
can preview what the header will produce by looking in the
minipage window.

Format remembered

Once you print a report, HyperCard remembers the format and
header you used for that stack’s report so you can use the same setup
next time you print.

Quit HyperCard

Quit HyperCard (or Command-Q) leaves HyperCard,
automatically saving any changes you've made.

Edit Menu

The Edit menu lets you change your work. Undo, Cut, Copy, Paste,
and Clear all work as they’re described in the owner's guide that
came with your computer. The other commands are unique to
HyperCard.
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The different Edit menus

The level set on the User Preferences card of the Home stack, in
conjunction with the protection level set for a particular stack,
determines which menu appears when you press Edit. If either level
is set to Browsing or Typing, you chocose a command from the short
menu (left in Figure 6-19). Otherwise you choose from a full menu
(right in Figure 6-19).

Undo #2 Undo =2
Cut *H Cut #H
Copy ®C Copy #(
Paste # Paste =D
Clear Cleat
New Card #N New Card #N
Delete Card Delete Card

Cut Card

Copy Card

| Background ¥B
Figure 6-19

Short and full Edit menus

For information on user levels, see “User Preferences” in
Chapter 3. For information on individual stack protection, see
“Protect Stack” earlier in this chapter.

Undo
[z Undo (or Command-Z) undoes your last action on a card or
background. Use it when you make a mistake or when you change
your mind about some action.
050 With the Paint tools, pressing Tilde or Escape is the same as
choosing Undo.
106 Chapter 6: Menu Commands
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Cut

Cut (or Command-X) removes the selected information from the
card or background and puts it on the Clipboard. Use Cut when you
want to move something from one place to another.

Cutting a picture

When you're using a Paint tool, Cut affects either the background
picture or the card picture, depending on whether the Background
command in the Edit menu is checked or unchecked.

m To cut a picture:
1. Select the portion of the picture you want to cut.

Use either the Lasso or the Selection tool to do it. (See “Lasso”
and “Selection Tool” later in this chapter.)

2. Choose Cut from the Edit menu.
You can also press Command-X.

Cutting buttons and fields

When you cut a button, you also cut its associated actions. If you
paste the button, you paste its actions along with it.

Important Buttons and the pictures representing them are often separate.
This s always the case if a button is transparent. Remember to
cut and paste the picture as well as the button. (You'll have to
cut and paste them separately.)

When you cut a field, all text and attributes (field name, font, and so
on) belonging to that field are cut along with it. If you paste back that
field in the same or another stack, you also paste back its attributes,
but not its text.

m To cut a button or a field:

1. Select the butlion or field tool.

2. Click the specific button or field you want to cut.

3. Choose Cut from the Edit menu (or press Command-X).
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Cutting a card

m To cut a card:
1. Move to the card you want to cut.
2. Choose Cut Card from the Edit menu.

When you cut a card, you cut everything on it—picture, fields, text,
buttons, actions, and a copy of that card’s background.

Cutting a background

You can't cut a background. To remove a background from a stack,
you must delete every card that uses that background. If there is only
one card in the stack, you must delete the stack.

Copy

Copy (or Command-C) makes a copy of the selected information
and puts it on the Clipboard. The selected information is left
unaffected (but whatever was on the Clipboard is replaced). If
you’re using a Paint tool and nothing is selected, all the Paint
information is copied.

Copying a picture

When you're using a Paint tool, Copy gets its information from
either the background picture or the card picture, depending on
whether the Background command in the Edit menu is checked or
unchecked.

u To copy a picture:
1. Select the portion of the picture you want to Copy.

Use either the Lasso or the Selection tool to do it. (See “Lasso”
and “Selection Tool” later in this chapter.)

2. Choose Copy Picture from the Edit menu.
You can also press Command-C.

3. Move to the card where you want the copied picture to
appear.

Moving between cards or stacks doesn't affect what's on the
Clipboard, the holding place for what you copied.
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4. Choose Paste Picture from the Edit menu.

Or press Command-V. The copied picture appears.
5. Drag the picture where you want it to be on the card.
6. Click anywhere outside the pasied area.

Copying buftons and fields

When you copy a button, you also copy its actions. If you paste the
button, you paste its actions along with it.

Buttons and the plctures representing them are often separate.
This Is always the case If a button Is transparent. Remember to
copy the picture as well as the bufton. (You'll have to copy
them separately.)

When you copy a field, all you copy is the field itself, you don't
copy the field's text.

To copy a button or a field:
. Select the button or field tool.
. Click the specific button or field you want to copy.

. Choose Copy Button or Copy Field from the Edit menu (or
press Command-C).

4. Move to the card where you want the copled button or field
to appear.

Moving between cards or stacks doesn't affect what's on the
Clipboard, the holding place for what you copied.

5. Choose Paste Button or Paste Field from the Edit menu.
Or press Command-V. The copied button or field appears.

6. Drag the button or field where you want it to be on the
card.

7. Click anywhere outside the pasted area.

W N~ =B

Copying a card

m To copy a card:
1. Choose Copy Card from the Edit menu.
A copy of the current card is placed onto the Clipboard.
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. Move to the card after which you want the copled card to

appear.
It can be in the current stack or in any other stack.

. Choose Paste Card from the Edit menu.

Or press Command-V. The pasted card becomes the current
card.

To change a card’s position so that it's first in a stack:

. Move to the card whose position you want to change.
. Choose Cut Card from the Edit menu.
. Choose First on the Go menu.

Or press Command-1. The first card in the stack appears.

. Choose Paste Card on the Edit menu.
Or press Command-V. The pasted card appears on the screen; it

is now the second card in the stack.

. Choose First on the Go menu again.

Or press Command-1. The first card in the stack appears.

. Choose Cut Card on the Edit menu.
The card you had originally set out to reposition is now first in the

stack.

. Choose Paste Card on the Edit menu.

(Or press Command-V.) The original first card is now second in
the stack.

When you copy a card, you copy everything associated with
it—background, picture, fields, text, buttons, and actions.

Copying a background

You copy a background by copying the card that has the
background you want. (A copied card takes everything with it.)

g b OGN = B§B

To copy a background:

. Copy a card that has the background you want.

. Move to where you want the new background.

. Paste the copied card.

. Make new cards based on the copied card’s background.
. Delete the original pasted card.

You can't replace an existing card’s background.

Chapter 6: Menu Commands
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Paste

Paste (or Command-V) takes a copy of the material that's on the
Clipboard and puts it on the screen.

O If the material is regular text, it appears at the insertion point of a
field you've chosen.

O If the material is a picture, it appears at the screen position at
which it was cut.

O If the material is a field or button, it appears at the screen
position at which it was cut. (You can move a pasted selection by
dragging within the selection.) Pasted buttons and fields retain
all their original actions.

O If the material is a card, it appears after the current card in the
stack. A pasted card pastes its background as well (assuming the
background is different from the ones surrounding it).

When you're using a Paint tool, the material you’re about to paste
can be text or a picture. If the material is regular text (that is, text
created with the Text tool), shrinking the selection by dragging the
corners with the Command key pressed makes more or less of the
text appear. (The text wraps at the right border of the selection.)
The text becomes a picture after you’ve pasted it and clicked outside
the selected area.

Pictures are pasted in opaque; if you want the background to show
through, choose Transparent from the Paint menu after you've
pasted onto the card, but before you've clicked outside the pasted
area to make the changes complete.

Pasting a card in miniature

You can paste a picture of a card in miniature, like the cards that
appear when you choose Recent from the Go menu.

B To paste a miniature:

1. Choose Copy Card or Cut Card from the Edit menu.

2. Move to the card where you want to paste the miniature.

3. Press and hold the Shift key while you choose Paste Card.
Alternately, press Command-Shift-V.

The miniature appears selected in the center of the screen.

Note that this is a picture of a card—none of the actions from the
original card come with the miniature.
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Clear

Clear removes the selected information without putting it on the
Clipboard or affecting what's already on the Clipboard.

When you're using a Paint tool, Clear affects either the selected
background picture or the selected card picture, depending on
whether the Background command in the Edit menu is checked or
unchecked.

When the Message box is visible and the insertion point is not
visible, Clear empties the Message box and puts the insertion point
in it.

Pressing the Delete or Backspace key (or the Clear key on the
keypad) has the same effect as Clear.

New Card

New Card (or Command-N) adds a card to the current stack. The
new card automatically picks up the background picture,
background buttons, and fields of the card you're looking at.

The new card is inserted immediately after the card you were
looking at. You end up looking at the card you just inserted.

B To make the new card the first one in the stack:
1. Choose First on the Go menu.

Or press Command-1. The first card in the stack appears.
2. Choose New Card on the Edit menu.

Or press Command-N. The new card appears on the screen; it is
now the second card in the stack.

3. Choose First on the Go menu again.
Or press Command-1. The first card in the stack appears again.
4. Choose Cut Card on the Edit menu.

The card you had originally set out to reposition is now first in the
stack.
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® If you want to place the cut card back into the stack, you need to
follow two more steps:

1. Move to the card you want to come immediately before the
one you've just cut.

2. Choose Paste Card on the Edit menu.
Or press Command-V.

The pasted card appears on the screen in its new position in the
stack.

Delete Card

Delete Card (or Command-Backspace or Command-Clear)
permanently eliminates the current card. Delete Card works exactly
like Cut Card, except that the deleted card does not go onto the
Clipboard and so cannot be pasted anywhere.

You can’t delete the last card in a stack. To delete the last card, use
Delete Stack from the Stack menu.

Cut Card

Cut Card (available only when Painting, Authoring, or Scripting is
checked in the User Preferences card of the Home stack) removes
the card on the screen, deletes it from the stack, and puts up the
next card in the stack. HyperCard doesn’t ask you to confirm the
cut—it just does it.

You can't cut the last card in a stack. To cut the last card, use Delete
Stack from the Stack menu.

Copy Card

Copy Card (available only when Painting, Authoring, or Scripting
is checked in the User Preferences card of the Home stack) makes a
copy of the current card and puts it on the Clipboard. Whatever was
on the Clipboard is replaced.

When you copy a card, you copy everything associated with
it—background, picture, fields, text, buttons, and actions.
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Scroll to the font you want;

Text Style

Text Style, or Command-T, (available only when Painting,
Authoring, or Scripting is checked in the User Preferences card of
the Home stack) lets you set text properties for the active field or the
active Paint text. (Paint text is text created using the Paint Text
tool.) Paint text is active until you

O switch tools after you've typed,

O click the mouse,

O leave the card, or

o switch into or out of the background.

A field is active if the insertion point is in it.

A dialog box appears, letting you choose text font, style,
alignment, size, and the height of each line in points.

then click to select if.

Check one or more styles
for all the text in a field
(or check nothing for plain text).

The alignment you set
works on all lines
in the same field.

What you see is

Click the size you want...

...or type it here.

fiia /

what you’ll get.

This determines the space
between lines, In points.

Figure 6-20
Text styles dialog box

See “Setting Text Properties” in Chapter 4 for more information.

114 Chapter 6: Menu Commands



.

Important

Background

Background, or Command-B, (available only when Painting,
Authoring, or Scripting is checked in the User Preferences card of
the Home stack) lets you edit the background picture and create
background buttons and fields.

The background serves as a template; whatever’s in the background
is common to all cards associated with that background.

-0
i{I" (%" Acme Dot Catalog
N

The Super Dot Line

Background alone With transparent card picture

Figure 6-21
Background versus card picture

The background picture is hidden by any black or opaque portions
of the card picture. (You choose Transparent and Opaque from the
Paint menu, described later in this chapter.)

A background button works for all cards associated with that
background, unless it'’s covered by a card button; a background
field appears in the same location on all cards associated with that
background, unless it's covered by a card field.

The most common mistake in creating a button or a field Is
putting it on a card when it's supposed fo be on a background.
After you've created one or more background buttons or fields,
choose Background again to get back to the Card level, and
fip to the next card; if the buttons or fields you've just created
are on that card oo, you've succeeded.

When you're working in a background, the menu bar is striped, and
a check mark appears to the left of the Background command in the
Edit menu. (See Figure 6-22.)
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Tools Pail

Striped lines mean you're working — o pe

in a background as opposed
to working on a specific card.

Edit checked

U
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Figure 6-22
Menu bar striped while working in background

There'’s no limit (beyond disk space) to the number of backgrounds
a stack can have.

Go menu

Use commands in the Go menu to navigate through stacks. You can
look through cards in the current stack, go back through cards and
stacks you've already seen, or immediately get to any stack
represented on the Home card.

| co I
